精华内容
下载资源
问答
  • 故理解iptables工作机理,学会配置iptables参数,对应 Linux 架构和运维人员就是一件一劳永逸重要工作。     本视频详细的论述了iptables 企业级防火墙从原理到配置,最后落实到实战部署的详尽过程。
  • 煤化工设备占整个煤化工的投资70%以上...在煤化工生产设备日常维护保养中,怎样合理配置设备管理与维修人员,使设备在寿命周期的使用、管理、保养及维修阶段的投资更少更为合理,是现代设备管理与维修具备的重要现实意义。
  • 目前笔者所在的公司,项目中所使用的权限管理系统并不是使用SpringSecurity 或者 SpringShiro 这套框架,其中原因:既有以上的三个原因,也有最重要的一点,这两个框架对开发人员并不是很友善,也因此,项目中使用的...

    关于为什么要自己写一套权限管理系统的原因?

    1. 满足框架的要求进行配置
    2. 没有界面操作和查看
    3. 期望更细致的管理

    目前笔者所在的公司,项目中所使用的权限管理系统并不是使用SpringSecurity 或者 SpringShiro 这套框架,其中原因:既有以上的三个原因,也有最重要的一点,这两个框架对开发人员并不是很友善,也因此,项目中使用的自己开发的权限管理。而本人便是该权限管理系统的主要开发人员,不过由于项目权限体系的需求原因,所以学习慕课某课程,深入了解权限管理的核心,提高相应的能力。

    一、权限管理项目需开发的内容

    配置管理类功能

    权限拦截类功能

    辅助类功能: 缓存(Redis)、各种树结构生成

    二、功能构成:

    1、配置管理类功能:

    • 用户、权限、角色的管理界面(扩展用:部门、权限模块)
    • 角色 - 用户管理、角色-权限管理
    • 权限更新日志管理

    2、权限拦截类功能:

    • 在切面(Filter)做权限拦截
    • 确定用户是否拥有某个权限

    3、辅助类功能:

    • 缓存(Redi)的封装和使用
    • 各种树:部门树、权限模块树、角色权限树、用户权限树
    • 权限操作恢复

    三、详细表结构设计

    设计规范:

     每个表都有自己的主键;

    字段尽量定义为NOT NULL;

    尽量为每个字段添加备注;

    数据库字段统一小写,单词之间使用下划线分隔;

    使用InnoDB存储引擎;

    可以使用varchar的字段尽可能不使用 TEXT、BLOB类型;

    表字符集选择 UTF8

    详细表结构设计:

               

    1、部门表

    CREATE TABLE `sys_dept` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT '部门id' ,
    `name`  varchar(20) NOT NULL COMMENT '部门名称' ,
    `parent_id`  int NOT NULL DEFAULT 0 COMMENT '上级部门id' ,
    `level`  varchar(200) NOT NULL DEFAULT '' COMMENT '部门层级' ,
    `seq`  int NOT NULL DEFAULT 0 COMMENT '部门在当前层级下的顺序。由小到大排序' ,
    `remark`  varchar(200) NULL DEFAULT '' COMMENT '备注' ,
    `operator`  varchar(20) NOT NULL DEFAULT '' COMMENT '操作者' ,
    `operator_time`  datetime NOT NULL ON UPDATE CURRENT_TIMESTAMP COMMENT '最后一次操作时间' ,
    `operator_ip`  varchar(20) NOT NULL DEFAULT '' COMMENT '最后一次更新操作者ip' ,
    PRIMARY KEY (`id`)
    );

    2、用户表

    CREATE TABLE `sys_user` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT 'user id' ,
    `username`  varchar(20) NOT NULL DEFAULT '' COMMENT '用户名字' ,
    `telephone`  varchar(13) NOT NULL DEFAULT '' COMMENT '联系方式' ,
    `mail`  varchar(20) NOT NULL DEFAULT '' COMMENT '邮箱' ,
    `password`  varchar(40) NOT NULL DEFAULT '' COMMENT '密码' ,
    `dept_id`  int NOT NULL DEFAULT 0 COMMENT '部门id' ,
    `status`  int NOT NULL COMMENT '用户状态' ,
    `remark`  varchar(200) NULL DEFAULT '' COMMENT '备注' ,
    `operator`  varchar(20) NOT NULL DEFAULT '' COMMENT '操作者' ,
    `operator_time`  datetime NOT NULL DEFAULT now() ON UPDATE CURRENT_TIMESTAMP COMMENT '最后一次操作时间' ,
    `operator_ip`  varchar(20) NOT NULL ,
    PRIMARY KEY (`id`)
    );

    3、权限模块表

    CREATE TABLE `sys_acl_module` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT '权限id' ,
    `name`  varchar(20) NOT NULL COMMENT '权限名称' ,
    `parent_id`  int NOT NULL DEFAULT 0 COMMENT '上级权限id' ,
    `level`  varchar(200) NOT NULL DEFAULT '' COMMENT '权限层级' ,
    `seq`  int NOT NULL DEFAULT 0 COMMENT '权限在当前层级下的顺序。由小到大排序' ,
    `status`  int NOT NULL DEFAULT 0 COMMENT '1表示可用,0表示失效' ,
    `remark`  varchar(200) NULL DEFAULT '' COMMENT '备注' ,
    `operator`  varchar(20) NOT NULL DEFAULT '' COMMENT '操作者' ,
    `operator_time`  datetime NOT NULL ON UPDATE CURRENT_TIMESTAMP COMMENT '最后一次操作时间' ,
    `operator_ip`  varchar(20) NOT NULL DEFAULT '' COMMENT '最后一次更新操作者ip' ,
    PRIMARY KEY (`id`)
    );

    4、权限表

    CREATE TABLE `sys_acl` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT '权限id' ,
    `code`  varchar(20) NOT NULL DEFAULT '' COMMENT '权限码' ,
    `name`  varchar(20) NOT NULL DEFAULT '' COMMENT '权限名称' ,
    `acl_module_id`  int NOT NULL DEFAULT 0 COMMENT '权限所在模块的id' ,
    `url`  varchar(100) NOT NULL DEFAULT '' COMMENT '请求的url,可用填正则表达式' ,
    `type`  int NOT NULL DEFAULT 1 COMMENT '类型1:菜单;2:按钮;3:其他' ,
    `status`  int NOT NULL DEFAULT 1 COMMENT '状态:1:正常;2:冻结' ,
    `seq`  int NOT NULL COMMENT '权限在当前模块下的顺序' ,
    `remark`  varchar(200) NULL DEFAULT '' COMMENT '备注' ,
    `operator`  varchar(20) NOT NULL DEFAULT '' COMMENT '操作者' ,
    `operator_time`  datetime NOT NULL DEFAULT now() ON UPDATE CURRENT_TIMESTAMP COMMENT '最后操作时间' ,
    `operator_ip`  varchar(20) NOT NULL DEFAULT '' COMMENT '最后操作者的ip' ,
    PRIMARY KEY (`id`)
    );

    5、角色表

    CREATE TABLE `sys_role` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT '角色id' ,
    `name`  varchar(20) NOT NULL DEFAULT '' COMMENT '角色名称' ,
    `type`  int NOT NULL DEFAULT 2 COMMENT '角色类型1:管理员。2:其他用户' ,
    `status`  int NOT NULL DEFAULT 1 COMMENT '状态:1:正常;2:冻结' ,
    `remark`  varchar(200) NULL DEFAULT '' COMMENT '备注' ,
    `operator`  varchar(20) NOT NULL DEFAULT '' ,
    `operator_time`  datetime NOT NULL DEFAULT now() ON UPDATE CURRENT_TIMESTAMP ,
    `opeator_ip`  varchar(20) NOT NULL DEFAULT '' ,
    PRIMARY KEY (`id`)
    );

    6、角色用户关联表

    CREATE TABLE `sys_role_user` (
    `id`  int NOT NULL AUTO_INCREMENT ,
    `role_id`  int NOT NULL COMMENT '角色id' ,
    `user_id`  int NOT NULL COMMENT '用户id' ,
    `operator`  varchar(20) NOT NULL ,
    `operator_time`  datetime NOT NULL DEFAULT now() ON UPDATE CURRENT_TIMESTAMP ,
    `operator_ip`  varchar(20) NOT NULL ,
    PRIMARY KEY (`id`)
    );

    7、角色-权限关联表

    CREATE TABLE `sys_role_acl` (
    `id`  int NOT NULL AUTO_INCREMENT ,
    `role_id`  int NOT NULL COMMENT '角色id' ,
    `acl_id`  int NOT NULL COMMENT '权限id' ,
    `operator`  varchar(20) NOT NULL ,
    `operator_time`  datetime NOT NULL DEFAULT now() ON UPDATE CURRENT_TIMESTAMP ,
    `operator_ip`  varchar(20) NOT NULL ,
    PRIMARY KEY (`id`)
    );

    8、权限相关更新记录表

    CREATE TABLE `sys_log` (
    `id`  int NOT NULL AUTO_INCREMENT COMMENT 'id' ,
    `type`  int NOT NULL DEFAULT 0 COMMENT '权限更新的类型:1:部门;2:用户;3:权限模块;4:权限;5:角色;6:角色用户关系;7:角色权限关系;' ,
    `target_id`  int NOT NULL COMMENT '基于type指定的对象id,比如用户、角色、权限表的主键' ,
    `old_value`  text NOT NULL ,
    `new_value`  text NOT NULL ,
    `operator`  varchar(255) NOT NULL ,
    `operator_time`  datetime NOT NULL ON UPDATE CURRENT_TIMESTAMP ,
    `operator_ip`  varchar(255) NOT NULL ,
    `status`  int NOT NULL COMMENT '当前是否复原过0:没有;1:有' ,
    PRIMARY KEY (`id`)
    );

    注意: 

                datetime类型只支持Mysql5.6.5以上版本。

                以下的版本将 datetime 换成 TIMESTAMP 即可。

    展开全文
  • 2.3 产品配置模型 产品配置中客户、销售代表和定单处理人员可以从企业提供的产品特征和选项列表中进行选择,就可以得到具体的配置产品。客户可以对具体的配置产品进行网上定单。通用的产品配置模型如图2所示。1...
  • Activiti(一)创建

    2020-05-27 17:10:26
    众所周知,Activiti作为Java中的高级框架,Activiti 是一个针对企业用户、开发人员 、系统管理员的轻量级工作流业务管理平台,其核心是使用 java 开发的快速 、 稳定的 BPMN2.0 流程引擎 。它可以与 spring 完美集成...

    众所周知,Activiti作为Java中的高级框架,Activiti 是一个针对企业用户、开发人员 、系统管理员的轻量级工作流业务管理平台,其核心是使用 java 开发的快速 、 稳定的 BPMN2.0 流程引擎 。它可以与 spring 完美集成。


    现在开始我们进入Activiti的学习


     

    第一步:我们在数据库创建表activiti,表中不需要有任何的数据

    create database activiti

     


     

    第二步:创建一个Maven项目,这里就不做演示了


    第三步:配置文件activiti.cfg.xml

    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns="http://www.springframework.org/schema/beans"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xmlns:context="http://www.springframework.org/schema/context"
           xmlns:tx="http://www.springframework.org/schema/tx"
           xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd
    						http://www.springframework.org/schema/contex http://www.springframework.org/schema/context/spring-context.xsd
    						http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx.xsd">
    
        <!--数据源配置-->
        <bean id="dataSource" class="org.apache.commons.dbcp.BasicDataSource">
            <property name="driverClassName" value="com.mysql.cj.jdbc.Driver" />
            <property name="url" value="jdbc:mysql://localhost:3306/activiti?serverTimezone=UTC" />
            <property name="username" value="root" />
            <property name="password" value="010126" />
        </bean>
    
        <!--activiti单独运行的ProcessEngine配置对象(processEngineConfiguration)
          默认情况下:bean的id=processEngineConfiguration
          要改变bean的名称,部署时需要在代码中添加bean的id:例子:processEngineConfiguration01
            ProcessEngineConfiguration processEngineConfiguration=ProcessEngineConfiguration       .createProcessEngineConfigurationFromResource("activiti.cfg.xml","processEngineConfiguration01");
      -->
        <bean id="processEngineConfiguration" class="org.activiti.engine.impl.cfg.StandaloneProcessEngineConfiguration">
            <!--数据源-->
            <property name="dataSource" ref="dataSource"></property>
    
        
            <!--是否生成表结构-->
            <property name="databaseSchemaUpdate" value="true"/>
        </bean>
    
    
    </beans>

    创建类ActivitiDeploymenTest,从表创建的角度看,有两种方式

    第一种方式:

     public void testGenTableOne(){
            //创建ProcessEngine对象
            ProcessEngine processEngine= ProcessEngines.getDefaultProcessEngine();
            System.out.println(processEngine);
        }

    第二种方式:

     public void testGenTableTwo(){
            //1:创建ProcessEngineConfiguration对象
            //第一个参数:配置文件名称  第二个参数是processEngineConfiguration的bean的id
            ProcessEngineConfiguration processEngineConfiguration=
                    ProcessEngineConfiguration.createProcessEngineConfigurationFromResource("activiti.cfg.xml");
           //2:创建ProcessEngine对象
            ProcessEngine processEngine=processEngineConfiguration.buildProcessEngine();
    
            //3;输出ProcessEnine对象
            System.out.println(processEngine);
        }

    部署分析:

    以上两种方式都是可以的,但是相较于第二种方式,第一种的条件会比较多

    第一种方式的条件:

    1. 项目中activiti配置文件名称:activiti.cfg.xml
    2. activiti.cfg.xml配置bean的id必须是"processEngineConfiguration",并且不可改变

    第二种方式需要注意:

     <bean id="processEngineConfiguration" class="org.activiti.engine.impl.cfg.StandaloneProcessEngineConfiguration">

    由于bean的id默认时processEngineConfiguration,如果需要改变成processEngineConfiguration01那么需要添加bean的id

    ProcessEngineConfiguration processEngineConfiguration=
       ProcessEngineConfiguration.createProcessEngineConfigurationFromResource("activiti.cfg.xml","processEngineConfiguration01");

     

    运行后结果:




    私人建议:

    两种方法都有各自的优缺点,第一种方式比较局限性,第二种方式代码多一些,activiti的很多功能实现都是需要获取ProcessEngine对象,所以建议可以做一个工具封装,需要用到的时候调用即可

    public class ReturnProcessEngineUtil {
    
        //Id未改变
        public static ProcessEngine getProcessEngine(){
            ProcessEngineConfiguration processEngineConfiguration=ProcessEngineConfiguration.createProcessEngineConfigurationFromResource("activiti.cfg.xml");
            ProcessEngine processEngine=processEngineConfiguration.buildProcessEngine();
            return processEngine;
        }
        //Id改变
        public static ProcessEngine getProcessEngine(String beanName){
            ProcessEngineConfiguration processEngineConfiguration=ProcessEngineConfiguration.createProcessEngineConfigurationFromResource("activiti.cfg.xml",beanName);
            ProcessEngine processEngine=processEngineConfiguration.buildProcessEngine();
            return processEngine;
        }
    }
    

    调用

     ProcessEngine processEngine= ReturnProcessEngineUtil.getProcessEngine();

     



    原创文章,未经允许禁止盗用



     

    展开全文
  • 如今大批企业返工复产,大家都开始上班了,堆积了三个月的工作量相当大,各种返工登记,健康登记单,人员统计单等等,有些小伙伴苦于没有现成的模板来完成,需要花费大量的公余时间完成,现在有一款直接自定义配置...

    bd2ddcb8027adf6478ba61a1dc903d25.png

    如今大批企业返工复产,大家都开始上班了,堆积了三个月的工作量相当大,各种返工登记表,健康登记单,人员统计单等等,有些小伙伴苦于没有现成的模板来完成,需要花费大量的公余时间完成,现在有一款直接自定义配置的工具来帮助完成这些繁琐的步骤,只需几步就可以解决

    希塔数据shujuyizhan.com

    点击右上角登录按键,通过手机号验证码登录

    6ef1ae3d6833f97f4bdbcbbcfa3994cd.png

    点击创建应用

    65682b99ac929fd05710693fa6d15073.png

    选择单应用模板进入,输入应用名称,进入设计界面

    cd49a365445e7fbd26cc55ce3eb1198e.png

    2b5e71d5e832dc29405cb3e309f8d707.png

    4192a89f6092d9596b3ec9b0af31f398.png

    添加字段,输入字段名,进入字段设置,根据需求添加字段类型

    分为基础属性,位置/外观,高级属性

    88b5d807c5f211466ae53067fbd97522.png

    020d2f46c51e8f08749831ec33a29472.png

    编辑完成后,右上角点击完成编辑,也可提前预览

    65682b99ac929fd05710693fa6d15073.png

    自定义表单制作完成,点击设计可重新编辑

    点击分享,选择两种访问方式

    1:可根据网页访问地址填写表单

    2:可选择微信扫码登录填写表单

    根据需要,可设置启动网址访问密码,保障数据安全

    d02a658932f51afc0178a1bba3e8e75c.png

    点击数据可查看创建的表单配置字段

    6fd19e65967731756d7fa349515d5ed6.png

    文末附上详细操作短视频

    8488920bdd82e060a856ba2979387c8b.png
    如何简单配置自定义表单https://www.zhihu.com/video/1229136577277706240

    有其他任何问题联系 @希塔数据

    展开全文
  • 企业组网规划与实现

    2021-04-11 22:54:21
    1. 实训要求 掌握企业组网常用技术,IP地址规划,拓扑设计,网络项目实施。 2. 实训内容 1.按照项目描述和要求完成设备调试 2.设计文档的编写 3.按照内容要求画出拓扑图 ...1 部门人员分布与网络规划 部门 人数 V

    1. 实训要求

    掌握企业组网常用技术,IP地址规划,拓扑设计,网络项目实施。

    2. 实训内容

    1.按照项目描述和要求完成设备调试
    2.设计文档的编写
    3.按照内容要求画出拓扑图
    4.配置路由器、交换机、服务器等的配置信息
    5.调试各设备是否能按照要求互通
    3. 项目描述
    一个规模近200人的轨道交通设备有限公司,目前有19个部门,其中管理人员近60人:
    各部门及人数的分配与网络规划情况见表1所示;
    网络设备的连接情况见表2所示;
    各设备的编址情况见表3所示。
    表1 部门人员分布与网络规划表

    部门	人数	VLAN 	IP地址与掩码	默认网关	连接设备	对应接口	备注
    董事长	1	10	192.168.1.8/29	192.168.1.9	BDSC1	0/3	 
    总经理	1	20	192.168.1.16/29	192.168.1.17	BDSC1	0/4	 
    副总经理	1	30	192.168.1.24/29	192.168.1.25	BDSC1	0/5	 
    网络运营部	1	100	192.168.1.32/29	192.168.1.33	BDSC1	0/2	 
    财务总监	1	40	192.168.1.56/29	192.168.1.57	BDSA1	0/1	 
    财务部	4	50	192.168.1.64/29	192.168.1.65	BDSA1	0/2	 
    技术部	15	60	192.168.1.96/27	192.168.1.97	BDSA2	0/1-2	 
    质检部	7	70	192.168.2.16/28	192.168.2.17	BDSA3	0/3	 
    物资部	7	80	192.168.2.32/28	192.168.2.33	BDSA3	  0/4	 
    营销部	5	90	192.168.2.48/28	192.168.2.49	BDSA3	  0/5	 
    库房1	2	120	192.168.2.8/30	192.168.2.9	BDSA4	0/1	 
    库房2	2	130	192.168.2.4/30	192.168.2.5	BDSA4	0/2	 
    生产部	6	140	192.168.2.64/28	192.168.2.65	BDSA4	0/3-4	
    

    表2-1 核心交换机BDSC1端口连接列表
    序号 BDSC1端口 连接设备 连接端口 备注

    1	Fa0/1	BDSW1	Fa0/9	
    2	Fa0/2	网络运营部	NIC	
    3	Fa0/3	董事长	NIC	
    4	Fa0/4	总经理	NIC	
    5	Fa0/5	副总经理	NIC	
    6	Fa0/6	BDSA1	Fa0/6	
    7	Fa0/7	BDSA2	Fa0/7	链路聚合
    8	Fa0/8		Fa0/8
    

    9 其他端口备用

    表2-2 核心交换机BDSC2端口连接列表
    序号 BDSC2端口 连接设备 连接端口 备注

    1	Fa0/1	BDSW2	Fa0/9	 
    2	Fa0/2	BDSA3	Fa0/2	 
    3	Fa0/23	BDSA4	Fa0/23	链路聚合
    4	Fa0/24		Fa0/24	
    5	其他端口备用
    

    表3 设备编址表

    设备	接口	IP地址与掩码	连接设备	连接端口	备注
    BDSC1	Fa0/1	192.168.100.1/30	BDSW1	Fa0/9	其他各VLAN子接口IP参见表1
    BDSC2	Fa0/1	192.168.200.1/30	BDSW2	Fa0/9	其他各VLAN子接口IP参见表1
    BDR	Eth1/0	192.168.110.2/30	BDSW1	Fa0/1	 
    	Eth1/1	192.168.120.2/30	BDSW2	Fa0/1	 
    	Fa0/0	218.14.85.68/29	Inside Server	NIC	 
    	S0/3/0	218.14.85.5/30	ISP	S0/3/0	 
    BDSW2	Fa0/9	192.168.200.2/30	BDSC2	Fa0/1	 
    	Fa0/1	192.168.120.1/30	BDR	Eth1/1	 
    BDSW1	Fa0/9	192.168.100.2/30	BDSC1	Fa0/1	 
    	Fa0/1	192.168.110.1/30	BDR	Eth1/0	 
    ISP	Se0/3/0	218.14.85.6/30	BDR	Se0/3/0	 
    	Fa0/0	218.14.85.33/30	Outside Server	NIC	 
    	Fa0/1	222.1.1.1/30	 	 	 
    Inside Server	NIC	218.14.85.67/29	 	 	 
    Outside Server	NIC	218.14.85.34/30	 	 	 
    外网用户	NIC	222.1.1.2/30	 	 	 
    

    4. 项目实施

    任务1:BDSA1上的配置要求
    修改主机名为BDSA1
    配置与BDSC1连接的接口类型为trunk
    按表1所示将相应接口加入对应的VLAN中
    任务2:BDSA2上的配置要求
    修改主机名为BDSA2
    配置与BDSC1连接的接口为链路聚合组1,并运行LACP协议
    任务3:BDSA3上的配置要求
    修改主机名为BDSA3
    配置与BDSC2连接的接口类型为trunk
    按表1及网络结构图所示将相应接口加入对应的VLAN中
    任务4:BDSA4上的配置要求
    修改主机名为BDSA4
    配置与BDSC2连接的接口为链路聚合组1,并运行LACP协议
    按表1所示将相应接口加入对应的VLAN中
    任务5:BDSC1上的配置要求
    安全方面
    修改主机名为BDSC1
    控制台线路登录口令:个人学号
    vty 0–4 登录口令:个人学号
    口令加密保存
    二层配置
    按表2-1及表1创建各部门所属VLAN
    按表2-1,设备各接口类型及链路聚合,以实现BDSC1与BDSA1、BDSC1与BDSA2之间进行VLAN互联三层配置
    将Fa0/1接口类型设为路由接口,并指定IP地址为:192.168.100.1/30
    让董事长办公室、总经理办公室、副总经理办公室、网络运营部、财务总监、财务部、技术部的用户能自动获取TCP/IP等参数,参考表1中的各部门地址段、网关信息,要求配置DHCP地址池,地址池编号同VLAN号,DNS服务器地址统一为:219.149.194.55
    指定各VLAN子接口地址
    路由配置
    配置默认路由(下一跳地址为对端接口IP地址)
    任务6:BDSC2上的配置要求
    安全方面
    修改主机名为BDSC2
    控制台线路登录口令:个人学号
    vty 0–4 登录口令:个人学号
    口令加密保存
    二层配置
    按表2-2及表1创建各部门所属VLAN
    按表2-2,设备各接口类型及链路聚合,以实现BDSC2与BDSA3、BDSC2与BDSA4之间进行VLAN互联
    三层配置
    将Fa0/1接口类型设为路由接口,并指定IP地址为:192.168.200.1/30
    让质检部、物资部、营销部、库房、生产部、车间办公室1、车间办公室2能自动获取TCP/IP等参数,参考表1中的各部门地址段、网关信息,要求配置DHCP地址池,地址池编号同VLAN号,DNS服务器地址统一为:219.149.194.55
    指定各VLAN子接口地址
    配置路由
    配置默认路由(下一跳为对端接口IP地址)

    任务7:工作站上的配置
    各部门的PC自动获取TCP/IP等参数
    任务8:BDSW1上的配置
    修改主机名为BDSW1
    控制台线路登录口令:个人学号
    vty 0–4 登录口令:个人学号
    口令加密保存
    按照表3配置各接口IP地址
    配置OSPF路由协议,定义配置区域为1,跳跃距离为110
    配置到互联网的默认路由(下一跳地址为对端接口IP地址),配置到两个内网(将公司的内部网络进行汇聚,BDSC1所在内网汇聚后为192.168.1.0/24,BDSC2所在内网汇聚后为192.168.2.0/24)的静态路由(下一跳分别为对端接口IP地址)
    任务9:BDSW2上的配置
    修改主机名为BDSW2
    控制台线路登录口令:个人学号
    vty 0–4 登录口令:个人学号
    口令加密保存
    按照表3配置各接口IP地址
    配置OSPF路由协议,定义配置区域为2,跳跃距离为110
    配置到互联网的默认路由(下一跳地址为对端接口IP地址),配置到两个内网(将公司的内部网络进行汇聚,BDSC1所在内网汇聚后为192.168.1.0/24,BDSC2所在内网汇聚后为192.168.2.0/24)的静态路由(下一跳分别为对端接口IP地址)
    任务10:BDR上的配置
    修改主机名为BDR
    控制台线路登录口令:个人学号
    vty 0–4 登录口令:个人学号
    口令加密保存
    按照表3配置各接口IP地址

    配置OSPF路由协议,定义f0/0、s0/3/0端口为骨干区域,f0/1为区域3,e1/0、e1/1分别为区域1和2,跳跃距离均为110
    配置到互联网的默认路由(下一跳为本接口),配置到两个内网(将公司的内部网络进行汇聚后)的静态路由(下一跳分别为对端接口IP地址)
    配置访问控制列表(列表号为1),不允许库房1和库房2用户访问外网
    配置访问控制列表(列表号为1),允许所有内部网络(192.168.0.0)在接口S0/3/0上均可通过 NAT 建立映射(先将内部网络地址汇聚一条地址192.168.0.0后,再进行基于端口S0/3/0的NAT映射)。
    虚拟互联网的配置
    任务1:ISP上的配置
    修改主机名为ISP
    按表3配置配置各接口地址
    配置到Inside Server的一条静态路由。使用 ISP 的串行接口作为下一跳。
    配置到DNS的一条静态路由,使用串行接口作为下一跳
    配置s0/3/0为骨干区域,配置OSPF路由协议,跳跃距离为110
    任务2:WWW服务器的配置
    设置IP地址为:218.14.85.34/30,网关为:218.14.85.33
    5. 网络拓扑

    图1 网络拓扑
    在这里插入图片描述

    6. 实训配置

    BDSA1上的配置

    配置端口模式并分配VLAN
    interface FastEthernet0/1
     switchport access vlan 40
     switchport mode access
    
    interface FastEthernet0/2
     switchport access vlan 50
     switchport mode access
    
    interface FastEthernet0/6
     switchport mode trunk
    

    BDSA2上的配置

    配置端口模式并分配VLAN
    interface FastEthernet0/1
     switchport access vlan 60
     switchport mode access
    
    interface FastEthernet0/2
     switchport access vlan 60
     switchport mode access
    

    配置端口模式和LACP协议

    interface FastEthernet0/7
     channel-protocol lacp
     channel-group 1 mode active
     switchport mode trunk
    
    interface FastEthernet0/8
     channel-protocol lacp
     channel-group 1 mode active
     switchport mode trunk
    

    BDSA3上的配置

    配置端口模式并分配VLAN
    interface FastEthernet0/2
     switchport mode trunk
    interface FastEthernet0/3
     switchport access vlan 70
     switchport mode access
    interface FastEthernet0/4
     switchport access vlan 80
     switchport mode access
    interface FastEthernet0/5
     switchport access vlan 90
     switchport mode access
    

    BDSA4上的配置

    配置端口模式并分配VLAN
    interface FastEthernet0/1
     switchport access vlan 120
     switchport mode access
    interface FastEthernet0/2
     switchport access vlan 130
     switchport mode access
    interface FastEthernet0/3
     switchport access vlan 140
     switchport mode access
    interface FastEthernet0/4
     switchport access vlan 140
     switchport mode access
    配置端口模式和LACP协议
    interface FastEthernet0/23
     channel-protocol lacp
     channel-group 1 mode active
     switchport mode trunk
    
    interface FastEthernet0/24
     channel-protocol lacp
     channel-group 1 mode active
     switchport mode trunk
    

    BDSC1上的配置

    配置各VLAN的DHCP地址池
    ip dhcp pool 10
     network 192.168.1.8 255.255.255.248
     default-router 192.168.1.9
     dns-server 219.149.194.55
    ip dhcp pool 20
     network 192.168.1.16 255.255.255.248
     default-router 192.168.1.17
     dns-server 219.149.194.55
    ip dhcp pool 30
     network 192.168.1.24 255.255.255.248
     default-router 192.168.1.25
     dns-server 219.149.194.55
    ip dhcp pool 100
     network 192.168.1.32 255.255.255.248
     default-router 192.168.1.33
     dns-server 219.149.194.55
    ip dhcp pool 40
     network 192.168.1.56 255.255.255.248
     default-router 192.168.1.57
     dns-server 219.149.194.55
    ip dhcp pool 50
     network 192.168.1.64 255.255.255.248
     default-router 192.168.1.65
     dns-server 219.149.194.55
    ip dhcp pool 60
     network 192.168.1.96 255.255.255.224
     default-router 192.168.1.97
     dns-server 219.149.194.55
    

    配置端口模式和LACP协议

    interface FastEthernet0/7
     channel-protocol lacp
     channel-group 1 mode active
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface FastEthernet0/8
     channel-protocol lacp
     channel-group 1 mode active
     switchport trunk encapsulation dot1q
     switchport mode trunk
    

    配置各VLAN的SVI接口地址

    interface Vlan10
     ip address 192.168.1.9 255.255.255.248
    interface Vlan20
     ip address 192.168.1.17 255.255.255.248
    interface Vlan30
     ip address 192.168.1.25 255.255.255.248
    
    interface Vlan40
     ip address 192.168.1.57 255.255.255.248
    interface Vlan50
     ip address 192.168.1.65 255.255.255.248
    interface Vlan60
     ip address 192.168.1.97 255.255.255.224
    interface Vlan100
     ip address 192.168.1.33 255.255.255.248
    
    打开路由功能 配置到互联网的默认路由
    ip routing
    ip route 0.0.0.0 0.0.0.0 192.168.100.2
    

    BDSC2上的配置

    配置各VLAN的DHCP地址池
    ip dhcp pool 70
     network 192.168.2.16 255.255.255.240
     default-router 192.168.2.17
     dns-server 219.149.194.55
    ip dhcp pool 80
     network 192.168.2.32 255.255.255.240
     default-router 192.168.2.33
     dns-server 219.149.194.55
    ip dhcp pool 90
     network 192.168.2.48 255.255.255.240
     default-router 192.168.2.49
     dns-server 219.149.194.55
    ip dhcp pool 120
     network 192.168.2.8 255.255.255.252
     default-router 192.168.2.9
     dns-server 219.149.194.55
    ip dhcp pool 130
     network 192.168.2.4 255.255.255.252
     default-router 192.168.2.5
     dns-server 219.149.194.55
    ip dhcp pool 140
     network 192.168.2.64 255.255.255.240
     default-router 192.168.2.65
     dns-server 219.149.194.55
    配置端口模式和LACP协议
    interface FastEthernet0/23
     channel-protocol lacp
     channel-group 1 mode active
     switchport trunk encapsulation dot1q
     switchport mode trunk
    
    interface FastEthernet0/24
     channel-protocol lacp
     channel-group 1 mode active
     switchport trunk encapsulation dot1q
     switchport mode trunk
    
    配置各VLAN的SVI接口地址
    interface Vlan70
     ip address 192.168.2.17 255.255.255.240
    
    interface Vlan80
     ip address 192.168.2.33 255.255.255.240
    
    interface Vlan90
     ip address 192.168.2.49 255.255.255.240
    
    interface Vlan120
     ip address 192.168.2.9 255.255.255.252
    
    interface Vlan130
     ip address 192.168.2.5 255.255.255.252
    
    interface Vlan140
     ip address 192.168.2.65 255.255.255.240
    
    打开路由功能 配置到互联网的默认路由
    ip routing
    ip route 0.0.0.0 0.0.0.0 192.168.200.2 
    

    BDSW1上的配置

    配置OSPF协议
    router ospf 110
     network 192.168.110.0 0.0.0.255 area 1
     network 192.168.100.0 0.0.0.255 area 1
    
    配置到互联网的默认路由和到两个字网的静态路由
    ip route 0.0.0.0 0.0.0.0 192.168.110.2 
    ip route 192.168.1.0 255.255.255.0 192.168.100.1 
    ip route 192.168.2.0 255.255.255.0 192.168.110.2 
    

    BDSW2上的配置

    配置OSPF协议
    router ospf 110
     network 192.168.120.0 0.0.0.255 area 2
     network 192.168.200.0 0.0.0.255 area 2
    
    配置到互联网的默认路由和到两个子网的静态路由
    ip route 0.0.0.0 0.0.0.0 192.168.120.2 
    ip route 192.168.1.0 255.255.255.0 192.168.120.2 
    ip route 192.168.2.0 255.255.255.0 192.168.200.1 
    

    6.1 BDR上的配置

    6.1.1 配置OSPF协议

    router ospf 110
     network 218.14.85.0 0.0.0.255 area 0
     network 219.149.194.0 0.0.0.255 area 3
     network 192.168.110.0 0.0.0.255 area 1
     network 192.168.120.0 0.0.0.255 are
    

    a 2

    6.1.2 配置到互联网的默认路由和到两个子网的静态路由

    ip route 0.0.0.0 0.0.0.0 Serial0/3/0
    ip route 192.168.1.0 255.255.255.0 192.168.110.1 
    ip route 192.168.2.0 255.255.255.0 192.168.120.1
    

    6.1.3 建立NAT映射并配置访问控制列表

    access-list 1 permit 192.168.0.0 0.0.255.255
    ip nat inside source list 1 interface Serial0/3/0 overload
    
    access-list 1 deny 192.168.2.4 0.0.0.3
    access-list 1 deny 192.168.2.8 0.0.0.3
    access-list 1 permit any
    

    6.2 ISP上的配置

    6.2.1 配置OSPF协议

    router ospf 110
     network 218.14.85.0 0.0.0.255 area 0
    

    6.2.2 配置到Inside Server和DNS-Server的静态路由

    ip route 219.149.194.0 255.255.255.0 Serial0/3/0 
    ip route 218.14.85.64 255.255.255.248 Serial0/3/0 
    

    6.2.3 在交换机和路由器上配置密码

    line console 0
    password 个人学号
    login
    line vty 0 4
    password 个人学号
    login
    exit
    service password-encryption
    
    1. 实验测试
      7.1 按表1各部门的用户均能自动获取tcp/ip等参数

    7.2 内网外网用户可以访问内网服务器:www.chinaiplab.com

    7.3 所有用户

    7.4 除库房1和库房2部门外的用户均能访问外网服务器:www.biaodu.net

    7.5 除库房1和库房2部门外的用户

    1. 网络实施
      8.1. 网络模块

    视频 网络模块
    8.2. 光前熔接

    图3光纤熔接光纤熔接机成功图

    图4光纤熔接含个人标签图

    图5 光纤接上设备正常运行图

    1. 设备选型
      表1设备选型
      序号 产品名称 产品型号 产品描述 数量 单位 单价 合计
      1 路由器 华为(HUAWEI)ar1220c-s 企业全千兆双W口路由器带200-300台PC AR1220C-S 2 台 2999 5998
      2 防火墙 华三(H3C)F100-C-G3 中小型多业务千兆企业级安全管理防火墙 带机量300-400 免费100条SSL VPN 1 台 3999 3999
      3 核心交换机 华为S1730S-L24P-A 企业级交换机 24口千兆以太网 网吧酒店公寓POE供电企业办公交换机-S1730S-L24P-A 2 台 2199 4398
      4 汇聚交换机 华为S5735S-L24T4X-A 企业级交换机24口千兆以太网电口+4万兆光口网络云全管理网管核心汇聚接入组网S5735S-L24T4X-A 2 台 3999 7998
      5 接入交换机 华为S1730S-S24T4S-A 华为HUAWEI企业级交换机24口全千兆以太网+4千兆光口网络云管理网管核心汇聚弱三层 S1730S-S24T4S-A 4 台 1499 7996
      6 服务器 华为华为2488 V5 8盘 服务器 主机 机架 51182CPU 16G2 600G*2SAS 双电 Raid2G 电容 质 3 台 48488 145464
      7 存储 群晖DS920+ 群晖(Synology)DS920+ 四核心4盘位 NAS网络存储服务器 (无内置硬盘 ) 1 T 4680 4680
      8 FC光交换机 拓宾 企业级千兆/百兆8光2电单双纤收发器SC/FC/ST光口光纤汇聚交换机一台价 全千兆8光2电传输3KM 多模双纤-SC 1 台 560 560
      总计 181093

    2. 实训总结
      通过本次设计,让我了解了网络工程这个专业在社会中站有重要的地位,信息化时代,缺少了网络,社会进步不会很快。
      本次实训,也让我深入了解路由器跟交换机的基本配置,这个虽说不难,但是会容易出错,交换机跟路由器的数量多,自然你配置的信息量就会增大,信息量大就非常容易出错,这也是我在配置的时候多次重做的原因。
      本次实训,通过用企业的网络规划为例子,实现总部跟分部的网络互联互通,这里面再次涉及到大二学期学的几个很重要的协议,首先说说路由重发布吧,一台设备同时运行于两个协议或两个进程,默认从两端学习到的路由条目不共享;重发布技术就是人为的进行共享;通过是路由重发布,来实现让谁登录跟不让谁登录的一个管理模式。
      在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的所有部分都可以连通了。 为了实现重分发,路由器必须同时运行多种路由协议,这样,每种路由协议才可以取路由表中的所有或部分其他协议的路由来进行广播。
      在路由器上配置多路由协议间的重分发,比如将路由协议A重分发到路由协议B中,要先进入路由协议B的路由模式下,然后再执行redistribute命令进行重分发的操作,并配置相应的路由选路参数。
      一般做多路由协议间的重分发要做双向的,即将路由协议A重分发到路由协议B后,再执行路由协议B到路由协议A的重分发,或是配置单向的重分发后,在添加一条指向到对方的默认路由(这一般用于外部路由协议间,如配置BGP时)。路由重分发,即将一种路由协议中的路由条目转换为另一种路由协议的路由条目,达到多路由环境下的网络互通。
      这里面的核心交换机是本次网络规划的重中之重,网络的互联互通的心脏,说他重要吧,其实我在这里面掉了很多坑,比如对于VLAN的划分,虽说之前有做过类似的实验,但是这次我体会到了什么叫不简单,首先你要通过PC端,分配几个VLAN,怎么分配才能实现要求,当然了,这里面一旦配置出错,就可能是重新来过,所以无论哪一步,都得了解他的工作过程,这样能尽可能的减少出错,提高我们的规划效率。
      再来谈谈核心交换机里的DHCP,也就是常说的自动获取IP地址,这个技术在这里看来发挥的作用不是很大,因为我们也可以用静态的,简单说就是手动分配IP地址到没台PC端,追中 同样能实现互联互通,但是,在大型网络规划中,你想去配置几百台的IP,好像是不太现实,一个DHCP用几分钟就能解决的事,干嘛还要花费那么多人力呢。
      通过本次实训,让我清楚的认识到有很多小知识点没有认真去琢磨,并发现平时学习过程中没有对知识点好好巩固,本次课设,还有很多不懂的地方,通过网上查阅跟问同学,虽然暂时解决了一部分问题,但是毕竟还不完全是自己解决的。
      最后还要感谢老师以及同学的帮助,能让我如期完成此次设计内容!

    展开全文
  • 企业里很多数据库,数据库中的和字段非常多。如何掌握整个企业的数据库的结构呢,从而进行快速应用呢?对于专门的数据管理人员而言,这个还是有可能的。而对于普通业务人员,这几乎是不可能的任务。 那么怎么才能...
  • 制造型企业的总体规划是一种通常...为了实现这一目标,制造型企业可以使用总体规划模型来制定生产计划,该生产计划可以轻松帮助确定人员配置要求,所需材料,时间估算和预算成本,使您的制造工厂能够有效地提前计划。
  • 数据库文档是我们在企业项目开发中需要交付的文档,通常需要开发人员去手工编写。编写完成后,数据库发生变更又需要手动的进行修改,从而浪费了大量的人力。并且这种文档并没有什么技术含量,被安排做这个工作的...
  • 通过一些工具,使非技术人员(普通人)参与企业数字系统的配置和开发成为可能。  目前市场上出现的工具,如国外的Airtable、国内的云平台,都属于“无代码”的范畴。它们的共同特点是可以帮助企业管理者通过可视...
  • 从诞生之初,Spring框架就坚守它的宗旨:简化企业级应用开发,同时给复杂问题提供强大的、非侵入性解决方案。一年前发布的Spring2.0就把这些主题推到了一个新的高度。XML Schema的支持和自定义命名空间的使用大大...
  • 可以让企业业务人员(不会任何代码)只要会Excel,会画表格,采用“拖拉拽”的方式,根据自己对业务流程的理解,就可以完成大部分流程的构建。模块化也大大降低了配置过程中出现bug的风险。如果在系统的应用过程...
  • 善翔生产企业协助办公系统(以下简称系统)是针对中小生产企业开发的,基于B/S结构的办公管理系统。  系统以PHP+smarty+mysql实现,模块化组合,功能强大,操作简单,方便配置、升级,既可以在互联网上使用,也可以...
  • hsweb 企业后台管理基础框架业务功能现在:权限管理: 权限资源-角色-用户.配置管理: kv结构,自定义配置.可通过此功能配置数据字典.脚本管理: 动态脚本,支持javascript,groovy,java动态编译执行.表单管理: 动态表单,...
  • 企业人事管理系统

    热门讨论 2012-05-17 11:20:09
    企业人事管理系统是现代企事业单位管理人员、工资、日常考勤所必须拥有的信息化管理系统之一,它包括人事信息的增、删、改、查,人员调动、人员离职,人事信息的打印输出,日常考勤管理、工资管理和福利管理等, ...
  • linux运维必会MySQL企业面试题老男孩教育运维班全体学员MySQL必会企业面试题 最实战、最细致、最落地的运维实训基地,老男孩教育连续多年国内平均就业工资最高! 数据库的重要性是所有技术里最核心最需要掌握的...
  • 企业级CMDB实战课程

    2020-11-09 18:57:21
    实战项目之CMDB客户端数据采集实战 高内聚低耦合的思想实战 CMDB收集资产之参考Django框架对配置文件的解耦 CMDB收集资产之对资产采集进行可插拔式的配置 CMDB收集资产之客户端功能的解耦 数据提交API的验证 CMDB...
  • 利用SMS进行企业计算机...企业中需要资产统计,那绝对的是全人工操作:每一台机器都需要管理人员仔细查看,检查每台计算机的硬件配置和资产统计是否相符。碰到有些计算机无法启动,还要拆开机器检查配置,可以说是...
  • 在各种不同的文件使用场景中,通过多维、多级的权限模板,根据配置的权限,限制用户对指定文件夹或文件的指定操作范围,使公司能够在确保安全的前提下轻松共享文件。 在Yotta企业云盘中,管理员可以为市场部设置多个...
  • , 本书内容在三个维度上具有重要特色:功能维度,从HBase的安装配置、参数设置,到数据模型、结构设计、客户端使用、高级特性,本书做了系统且详尽的介绍;实战维度,不仅通过3个典型的应用案例详细讲解了如何使用...
  • 施工企业财务软件

    2018-05-04 16:17:48
    15 付款审批管理 借款审批 按权限流行对下级的借款申请进行审批,对历史借款总额,借款总额,当前工资总额进行自动汇总,减少因为人员流动造成 的损失。 16 报销审批 严格按流程管理内部报销制度,对于报销进项发票...
  • 智能Excel:英文名:SmartExcel 智能EXCEL软件登录界面 是针对中小企业量身定制开发的一款企业管理平台...第二类是无需二次开发、零代码,智能Excel平台化能让管理人员和业务专家打造管理系统的完全配置化的自主平台。
  • 本书是讲述Delphi最经典的著作之一,作为Delphi的新版本,Delphi 6不仅能帮助程序员高效开发Windows应用程序,简化Web服务、中间软件以及后台数据库系统的合成,还是目前惟一全面支持所有主流业界标准的开发工具和...
  • 4.小型企业建站,具有一定网页基础的人员建设宣传网站。 《领林企业网站管理系统》主要模块有: 文章模块: 可对图文内容进行分类管理,如“公司新闻”、“资料发布”等可用该模块来完成,简单的图文形式的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 396
精华内容 158
关键字:

企业人员配置表