精华内容
下载资源
问答
  • 局域网发现协议
    千次阅读
    2018-08-10 14:58:53

    局域网发现的意义

    局域网发现设备是通信的第一步,通信需要先知道对方的ip地址,因为一般使用 DHCP 动态分配 ip 地址的局域网内,各个主机的 IP 地址是由 DHCP 服务器来帮你分配 IP 地址的。所以在很多情况下,你要知道对方的 IP 地址是比较麻烦的。

    因此,局域网发现,我们要解决的事情就是:如何找到局域网内其他设备,并获取到设备的ip;

    查询资料之后,发现使用udp单播、组播、广播来实现的方式都有,并且亲测确实都可行,那么哪种更合适呢,这也是我写这篇的目的,让大家对这些有个基本概念和对比;

    使用哪种协议实现

    udp 不用保证数据可靠性,传输速度快;并且一般tcp是不用于多播场景的;那使用udp如何实现呢?

    使用udp 单播、组播还是广播

    先来了解什么是单播和组播、广播

    • 单播 
      只有一个源点网络和一个终点网络。源点网络和终点网络的关系是一对一的。数据报途径的每一个路由器都要将这个分组仅从一个接口转发出去。

    图例: 
    这里写图片描述

    • 多播 
      在多播系统中,有一个源点一组终点。这是一对多的关系。在这种类型的通信中,源地址是一个单播地址,而目的地址则是一个组地址。

    图例: 
    这里写图片描述

    单播和组播、广播的区别

    • 多播的优点 
      q 具有同种业务的主机加入同一数据流,共享同一通道,节省了带宽和服务器的优点,具有广播的优点而又没有广播所需要的带宽。 
      q 服务器的总带宽不受客户端带宽的限制。由于组播协议由接收者的需求来确定是否进行数据流的转发,所以服务器端的带宽是常量,与客户端的数量无关。 
      与单播一样,多播是允许在广域网即Internet上进行传输的,而广播仅仅在同一局域网上才能进行。

    • 广播的缺点 
      q 多播与单播相比没有纠错机制,当发生错误的时候难以弥补,但是可以在应用层来实现此种功能。 
      q 多播的网络支持存在缺陷,需要路由器及网络协议栈的支持。 
      多播的应用主要有网上视频、网上会议等。

    • 组播与广播 
      广播数据报的接收是被动的。 
      连接到子网上的所有主机都要接收广播数据报,这会增加网络流量,并且子网上的主机增加额外的负担。 
      UDP广播只能在内网(同一网段)有效,而组播可以较好实现跨网段群发数据。 
      UDP广播:消耗更多网络带宽,路由器向子网内的每个终端都投递一份数据包,不论这些终端是否乐于接收该数据包; 
      UDP组播:有了很大优化,只有终端加入到了一个广播组,UDP组播的数据才能被他接收到; 
      多播数据报的接收是主动的。主机主动加入指定的多播组,才会接收该组的多播数据报。 
      不同子网内的A,B进行组播通信,依靠IGMP协议;局域网组播,不考虑跨网段的组播实现,因此组播路由协议IGMP与本文要介绍的内容无关;

    局域网的多播

    多播的地址是特定的,D类地址用于多播。D类IP地址就是多播IP地址,即224.0.0.0至239.255.255.255之间的IP地址,并被划分为局部连接多播地址、预留多播地址和管理权限多播地址3类: 
    局部多播地址:在224.0.0.0~224.0.0.255之间,这是为路由协议和其他用途保留的地址,路由器并不转发属于此范围的IP包。 
    q 预留多播地址:在224.0.1.0~238.255.255.255之间,可用于全球范围(如Internet)或网络协议。 
    q 管理权限多播地址:在239.0.0.0~239.255.255.255之间,可供组织内部使用,类似于私有IP地址,不能用于Internet,可限制多播范围。

    初步结论

    局域网发现可以使用: 
    1.udp单播,获取源主机的ip和子网掩码,得到该局域网的ip地址范围,然后使用udp单播轮询 找到对应的目标主机;

    2.udp组播,让源主机和目标主机都加到同一个局部多播地址;源主机给该多播地址发送组播消息即可;

    3.udp广播,使用广播地址255.255.255.255 来广播定制好的消息;

    综合考虑:udp单播轮询比较耗时,而且如果局域网内设备较多,UDP发送过快的话,会导致本地发送缓冲区丢包;接收过慢的话,也会导致接收缓冲丢包;单播和广播一样,对于不需要关心该消息的主机是一种打扰; 
    因此,使用udp组播来实现局域网发现比使用udp广播更合适;并且我之后会学习mdns和dns-sd,而这两种都是基于udp组播,所以用组播来实现对于后面的深入研究更有意义; 
    现在,我们来实现一个最简单的局域网发现的demo;具体实现请看下一篇

    更多相关内容
  • 局域网简易网络协议分析工具是一款免费的局域网网络协议分析工具,软件虽然小巧,不过功能很全面,局域网内的协议、地址和数据等信息都可以显示,而且搜索分析速度很快,非常好用!
  • 本文主要介绍了局域网中最常用的三种网络协议。网络中不同的工作站,服务器之间能传输数据,源于协议的存在。随着网络的发展,不同的开发商开发了不同的通信方式。为了使通信成功可靠,网络中的所有主机都必须使用...
  • 网络-局域网协议

    2018-09-13 09:57:37
    局域网相关协议及其概述,满足网络初接触者了解局域网的相关概念及有哪些相关协议,是入门的不二选择
  • 计算机网络局域网协议

    千次阅读 2020-05-24 14:43:12
    根据计算机网络的拓扑结构,可将网络分为总线型、树型、...局域网中传输数据的基本单元为“帧”,当采用不同的局域网通信协议时,其中具体的数据帧格式也会不同,目前常见的数据帧格式包括PPP帧和MAC帧。所有的局域网

    根据计算机网络的拓扑结构,可将网络分为总线型、树型、星型、环型和网状型五种类型。常见的局域网组网方式包括令牌环、光纤分布数字接口和以太网等。

    一、概述

    在不同类型的网络拓扑结构中,网络设备的连接方式、传输介质的选择、网络的可靠性及可扩展性均存在差异。在组建网络时,通常需要综合网络功能和性能需求、环境状况和投入成本等因素,以确定所采用的网络拓扑方案。

    局域网中传输数据的基本单元为“帧”,当采用不同的局域网通信协议时,其中具体的数据帧格式也会不同,目前常见的数据帧格式包括PPP帧和MAC帧。所有的局域网通信协议都需要解决帧定界、透明传输和差错检测这三个基本问题。

    常见的局域网组网方式包括令牌环、光纤分布数字接口(FDDI,Fiber Distributing Data Interface)和以太网等。

    1.令牌环

    令牌环网络的拓扑结构为环型拓扑,它使用同轴电缆作为传输介质,抗干扰性强。在令牌环网络中,使用一种被称为令牌的特殊数据帧进行访问控制,令牌循环遍历环路中的每台主机,主机在接收到令牌后才能发送数据。这种网络的结构固定,不便于网络拓展和增加主机,且维护令牌需要付出额外代价,在令牌损坏后,整个网络将不能正常工作。

    2.光纤分布数字接口

    光纤分布数字接口FDDI的网络拓扑结构同样为环型拓扑,采用光纤作为传输介质,有着较高的网络带宽。FDDI组网方式只支持采用光缆或5类电缆作为传输介质,这种组网方式成本较高,多用于连接多个局域网的骨干网。

    3.以太网

    以太网相对于前两种方式具有结构简单、成本低的特点,在实际应用中也更为常见。以太网使用双绞线作为传输介质,最大覆盖半径可达数百米之内。随着以太网技术的发展,其数据传输速率可达到从10Mbps到100Gbps不等。

    二、PPP帧与MAC帧

    数据链路层的常用信道有两种,即点对点信道和广播信道。

    在点对点信道中,发送端仅发送数据给接收端,是一种一对一的通信方式。

    在广播信道中,发送端将数据发送给连接至信道的多个设备,由于信道被多个设备共享,数据碰撞概率高,故需要通过网络协议来进行协调。

    1.点对点信道

    PPP(Point-to-Point Protocol)协议只提供无比特差错的数据传输服务,是目前使用点对点信道的网络中应用最广泛的数据链路层协议。

    终端用户通过因特网服务提供商(ISP,Internet Service Provider)所提供的数据链路层协议,获得相应的网络访问服务,中国电信和网通等ISP均采用PPP协议为终端用户提供通信服务。PPPoE(Point-to-Point Protocol over Ethernet)协议及PPPoA(Point-to-Point Protocol over ATM)协议是由PPP协议衍生而来的两个协议, 目前家庭常用的ADSL宽带上网方式就是采用了PPPoE协议技术。

    PPP协议规定的数据帧格式如图2-11所示,数据帧首部包含4个字段,尾部包含2个字段。首部的第一个字段和尾部的第二个字段均为标志字段,起到帧定界符的作用。标志字段Flag被规定为十六进制数0x7E,转化成二进制数即为01111110。在PPP帧的首部,标志字段之后依次为地址字段和控制字段,地址字段规定为0xFF,控制字段规定为0x03。首部最后一个字段长度为2字节,为协议字段,表示数据部分所对应的网络层协议。若协议字段值为0x0021,则表示数据部分为IP数据报;若协议字段值为0xC021,则表示数据部分为链路控制协议LCP的数据。尾部第一个字段即帧校验序列,用于检测数据比特差错。

    图2-11 PPP数据帧格式

    为保证数据的透明传输,PPP协议对异步和同步这两种传输方式分别采用了字符填充法和比特填充法。使用异步传输时,PPP协议定义转义字符为0x7D,在RFC1662文档中定义了相应的字符填充方法;在同步传输中,则采用“零”比特填充法实现透明传输。

    2.广播信道

    数据链路层被拆分为两个子层:逻辑链路控制LLC子层和介质访问控制MAC子层。MAC子层负责与接入到传输介质相关的所有工作,LLC子层的作用被逐渐淡化。

    以太网MAC帧的格式具有两种标准,一种是以太网V2标准(DIX Ethernet V2),另一种是IEEE 802.3标准,其中以太网V2标准的MAC帧应用最为广泛。

    如图2-12所示为MAC帧的格式示意图,前两个长度为6字节的字段分别代表目的地址和源地址,第三个字段长度为2字节,用于表示上一层协议的类型。若第三个字段值为0x0800,则表示上一层使用IP协议,数据部分为IP数据报。数据部分的长度在46~1500字节。从图2-12中可以看出,物理层所传输的数据比MAC帧多8个字节,前7个字节用于实现接收端与发送端时钟频率的同步,第8个字节为帧开始定界符,标识MAC帧的开始。

    图2-12 MAC帧格式

    这里的MAC地址由IEEE802.3规定的扩展唯一标识EUI-48(EUI,Extended Unique Identifier)表示,它是一个由48位二进制表示的字符串,又称为物理地址、硬件地址。此地址由24位公司ID(也称为制造商ID)和24位扩展ID(也称为网卡ID)组成。公司ID被唯一指派给每个网络适配器的制造商;扩展ID在装配时被唯一指派给每个网络适配器。两者组合,即可生成全球唯一的48位的MAC地址。

    三、CSMA/CD协议

    CSMA/CD协议是以太网所采用的一种监听避免“碰撞”的协议,该协议工作在OSI模型数据链路层的MAC子层,是一种“争用”型的半双工介质访问控制协议,包含以下几个要素。

    1.多点接入

    CSMA/CD协议的应用环境为总线型网络,网络中的主机以多点接入的方式连接在总线上。

    2.载波监听

    CSMA/CD协议要求发送端在发送数据前对总线进行监听,若监听到其他计算机在发送数据,则等待一段时间后,确认总线空闲时才开始发送数据。

    3.“碰撞”监听

    在数据发送过程中需保持对总线上信号的监听,根据信号电平的变化幅度即可判断是否发生了“碰撞”。一旦监听到“碰撞”,就立即停止数据发送,等待一段时间后再次尝试重发,直至发送成功。

    四、虚拟局域网

    虚拟局域网(VLAN,Virtual Local network)是一种将局域网设备从逻辑上划分为多个网段,从而实现虚拟工作组的交换技术。

    在典型的局域网中,通常一个工作组属于同一个网段,多个逻辑工作组之间通过网桥或者路由器交换数据,逻辑工作组受到节点所在物理位置的限制。

    虚拟局域网使用交换机,以软件的方式实现逻辑工作组的划分与管理,不受物理位置的限制而组建的局域网。

    如图2-13所示为一个虚拟局域网,一个VLAN可以包含一台或多台交换机,如图中椭圆形区域所示,有3个VLAN。PC-1、PC-2、PC-3、PC-4在同一个VLAN中,但连接到不同的交换机。同时,一个VLAN中的所有主机也可以连接到同一台交换机上,如PC-5与PC-6连接到Switch A。

    图2-13 虚拟局域网

    不同虚拟局域网的组网方法,主要表现在对虚拟局域网成员的定义上,通常有四种:交换机端口号、MAC地址、网络层地址和IP广播组等方式。虚拟局域网不同划分方法的优缺点如表2-8所示。

    表2- 8虚拟局域网不同划分方法的优缺点

    划分方法

    优点

    缺点

    交换机端口

    可简单定义VLAN成员,将交换机端口定义为相应的VLAN组当用户改变端口时,需要重新进行配置

    MAC地址

    当用户物理位置改变时,VLAN不用重新配置当交换机初始化时,所有的用户都必须进行配置

    网络层地址

    根据协议类型划分,方便网络管理效率低,检查每个数据包的网络层地址需要消耗处理时间

    IP广播组

    灵活性好,且较易通过路由器进行扩展不适合局域网,因其效率不高

    五、高速以太网

    高速以太网是指传输速率达到或超过100Mb/s的以太网,适用于较远距离的传输。

    1.快速以太网

    快速以太网(Fast Ethernet)的传输速率比传统10BASE-T以太网快10倍,数据传输速率达到100Mb/s。100BASE-T标准的快速以太网仍使用IEEE802.3的CSMA/CD(Carrier Sensing Multiple Access with Collision Detection)协议,并采用星型拓扑结构。用户只需更换一个适配器,再配上一个100Mb/s的集线器就可方便地由10BASE-T以太网直接升级到100Mb/s。目前的10Mb/s和100Mb/s以太网是使用无屏蔽双绞线布线的。

    100BASE-T以太网有3种与传输介质相关的标准,如表2-9所示。

    1)100BASE-TX:支持2对5类非屏蔽双绞线(UTP)或2对1类屏蔽双绞线(STP)。其中,一对双绞线用于发送,而另一对双绞线用于接收。因此,100BASE-TX工作在全双工模式,每个节点均可以同时以100Mb/s的速率发送与接收数据。

    2)100BASE-T4:支持4对3类或5类非屏蔽双绞线。其中,3对双绞线用于数据传输,每一对均以33.3 Mb/s的速率传送数据;而另一对用作冲突检测的接收信道。

    3)100BASE-FX:支持两芯的多模或单模光纤。其中,一根光纤用于数据发送,另一根光纤用于数据接收。100BASE-FX工作在全双工模式,主要用作高速主干网,从节点到集线器的距离可以达到2 km。

    表2- 9不同传输介质的100BASE-T以太网技术指标

    以太网标准

    100BASE-TX

    100BASE-T4

    100BASE-FX

    传输介质

    2对UTP-5

    2对STP-1

    4对UTP-3/5

    2芯光纤

    信号技术

    MLT-3

    MLT-3

    8B6T,NTZ

    4B5B,NRZI

    数据速率

    100Mb/s

    100Mb/s

    100Mb/s

    100Mb/s

    最大段长

    100m

    100m

    100m

    200m

    网络跨度

    200m

    200m

    200m

    400m

    2.吉比特以太网

    吉比特以太网的数据传输速率是快速以太网的10倍,可达到1Gb/s。吉比特以太网保留了传统10BASE-T以太网的基本特征,具有相同的帧格式和类似的组网方法。

    吉比特以太网定义了基于双绞线的物理层标准1000BASE-T和基于光纤通道的物理层标准1000BASE-X:

    1)1000BASE-T,即IEEE 802.3ab,使用4对5类非屏蔽双绞线,双绞线长度可达100 m。

    2)1000BASE-X,即IEEE 802.3z,有以下3种有关传输介质的标准:

    (1)1000BASE-CX;

    (2)1000BASE-LX;

    (3)1000BASE-SX。

    IEEE 802.3z标准的吉比特以太网具有以下特点:

    1)支持全双工和半双工两种工作方式;

    2)在半双工方式下采用CSMA/CD协议,而在全双工方式下不采用该协议;

    3)向后兼容10BASE-T和100BASE-T技术。

    3.10吉比特以太网

    10吉比特以太网又称万兆以太网,使用IEEE 802.3以太网介质访问控制MAC协议。与传统的以太网标准相比,10吉比特以太网具有以下特征:

    1)只支持双工模式,不支持单工模式,而传统的以太网标准均支持单工/双工模式。

    2)由于传输速率高,10吉比特以太网只能使用光纤作为传输介质,而传统的以太网标准均支持同轴电缆。

    3)不支持CSMA/CD协议,因为该协议只适用于速率较慢的单工以太网。

    4)使用64B/66B和8B/10B两种编码方式,而传统以太网只使用8B/10B的编码方式。

    5)具有支持局域网和广域网的接口,且有效距离可达40 km,而传统的以太网只支持局域网应用,有效传输距离不超过5 km。

    100 Mb/s以太网、1 Gb/s以太网和10 Gb/s以太网均属于共享介质方式的高速以太网。这里,介绍一些其他类型的高速以太网。

    1)光纤分布式数据接口。光纤分布式数据接口(FDDI,Fiber Distributed Data Interface)是一个使用光纤作为传输介质的令牌环网,使用共享介质方式。其主要具有以下几个特点:

    (1)使用IEEE 802.5的单令牌环网MAC协议。

    (2)兼容IEEE 802标准的局域网。

    (3)数据传输速率为100 Mb/s,联网的节点数不超过1000,环路长度为100 km。

    (4)使用双环结构,提高容错能力。

    (5)可以使用多模或单模光纤。

    2)高性能并行接口。高性能并行接口(HIPPI,High-Performance Parallel Interface)是一个美国国家标准协会标准,主要用于连接外围设备、处理器和巨型机等。

    HIPPI标准具有以下特点:

    (1)HIPPI提供点对点的接口,可以在两个设备间建立连接。

    (2)HIPPI工作在单工模式下,只能沿着一个方向传输数据,但是,两条单工通道可以组成一条双工通道。

    由于光纤价格昂贵,HIPPI在设计之初,只能采用双绞线作为数据传输的媒介。

    3)光纤通道。光纤通道(FC,Fibre Channel)是一种高速网络互联技术,主要用于连接计算机存储设备。

    光纤通道标准定义了三种不同的拓扑结构:点到点、仲裁环和交换网。

    六、宽带接入技术

    1.xDSL 技术

    xDSL技术是使用数字技术改造现有的模拟电话用户线,可以承载宽带业务。

    前缀x表示在数字用户线(DSL,Digital Subscriber Line)上实现的不同带宽方案。

    表2-10列出了xDSL的几种类型。其中ADSL(Asymmetric DSL)表示非对称数字用户线,HDSL(High speed DSL)表示高速数字用户线,SDSL(Single-line DSL)表示1对线的数字用户线,VDSL(Very high speed DSL)表示甚高速数字用户线。

    表2- 10 xDSL类型

    xDSL

    对称性

    下行带宽

    上行带宽

    极限传输距离

    ADSL

    不对称

    1.5 Mb/s

    64 kb/s

    4.6~5.5 km

    HDSL(1对线)

    对称

    768 Kb/s

    768 kb/s

    2.7~3.6 km

    SDSL

    对称

    1.5 Mb/s

    1.5 Mb/s

    3 km

    VDSL

    不对称

    52 Mb/s

    1.6~2.3 Mb/s

    0.3 km

    DSL(ISDN)

    对称

    160 Kb/s

    160 Kb/s

    4.6~5.5 km

    ADSL有上行和下行之分,其不对称的原因在于用户下载的数据量要大于上传的数据量。

    如图2-14所示,ADSL接入网包含数字用户线接入复用器(DSLAM,DSL Access Multiplexer)、用户线和用户设施如ADSL调制解调器(ATU-R,ADSLTransceiver Unit Remote Terminal End)、电话机和PC等。

    图2-14 ADSL接入网的组成

    ADSL的优势在于可以利用现有电话网中的用户线,而不需要重新布线。

    2.光纤同轴混合网

    光纤同轴混合网(HFC,Hybrid Fiber Coax)是一种居民宽带接入网,在原有有线电视网(CATV,Community Antenna TeleVision)的基础上发展而来。HFC网不仅能够传输电视信号,还能提供电话、数据等业务。

    HFC网采用光纤作为主干线路,并使用模拟光纤技术,如图2-15所示。头端发射出的光信号经过模拟光纤到达光纤节点,光纤节点将接收到的光信号转换为电信号,电信号经由光纤节点下游的同轴电缆传送到居民区。

    图2-15 HFC网的体系结构

    HFC网具有以下特点:

    1)HFC网以光纤作为主干线路。

    2)HFC网采用节点体系结构。

    3)HFC网具有更宽的频谱,且具有双向传输能力。

    4)用户接口盒。每个家庭都需要安装一个用户接口盒(UIB,User Interface Box)。

    3.FTTx 技术

    光纤通信是利用光波作为载波,以光纤作为传输媒体,将信息从源节点传送至目的节点的一种通信方式。

    光纤通信具有容量大、传输距离远、抗干扰能力强、性能稳定和保密性能好等优点,已在各种不同的骨干网中得到了广泛应用。

    FTTx中x代表不同的技术。

    1)光纤到户(FTTH,Fiber To The Home)是家庭接入的解决方案,即将光纤一直铺设到用户家庭内。

    2)光纤到大楼(FTTB,Fiber To The Building)方案能解决一幢大楼有多个用户连接宽带的情况。

    3)光纤到路边(FTTC,Fiber To The Curb)是指将光纤铺设到离家庭或办公室1km以内的路边,从路边到单个用户,可以采用双绞线或同轴电缆,以星型结构连接。FTTC代替了普通旧式电话服务,只需通过一条线就可以完成电话、有线电视、多媒体和其他通信业务。

    FTTx还提供其他宽带接入方案,如光纤到节点或邻区(FTTN,Fiber To The Node/Neighborhood)、光纤到交换机(FTTE,Fiber To The Exchange)、光纤到小区(FTTZ,Fiber To The Zone)和光纤到办公室(FTTO,Fiber To The Office)等。

     

     

     

     

     

    IEEE 802

     

    IEEE 802也指IEEE标准中关于局域网和城域网的一系列标准。更确切的说,IEEE 802标准仅限定在传输可变大小的网络。

    系列标准

    IEEE 802系列标准是IEEE 802 LAN/MAN 标准委员会制定的局域网、城域网技术标准。其中最广泛使用的有以太网令牌环无线局域网等。这一系列标准中的每一个子标准都由委员会中的一个专门工作组负责。

    IEEE 802委员会成立于1980年2月,它的任务是制定局域网和城域网标准。IEEE 802中定义的服务和协议限定在OSI模型[OSI网络参考模型]的最低两层(即物理层数据链路层)。事实上,IEEE 802将OSI的数据链路层分为两个子层,分别是逻辑链路控制(Logical Link Control, LLC)和介质访问控制(Media Access Control, MAC),如下所示:

    · 数据链路层

    · 逻辑链路控制子层

    · 介质访问控制子层

    · 物理层

    IEEE 802系列标准是IEEE 802 LAN/MAN 标准委员会制定的局域网、城域网技术标准。其中最广泛使用的有以太网令牌环无线局域网等。这一系列标准中的每一个子标准都由委员会中的一个专门工作组负责。

    802委员会前有20多个分委员会。

    IEEE 802现有标准

    IEEE 802.1 :局域网体系结构、寻址、网络互联和网络

    IEEE 802.1A:概述和系统结构

    IEEE 802.1B:网络管理和网络互连

    IEEE 802.2 :逻辑链路控制子层(LLC)的定义。

    IEEE 802.3 :以太网介质访问控制协议 (CSMA/CD)及物理层技术规范 [1]  

    IEEE 802.4 :令牌总线网(Token-Bus)的介质访问控制协议及物理层技术规范。

    IEEE 802.5 :令牌环网(Token-Ring)的介质访问控制协议及物理层技术规范。

    IEEE 802.6 :城域网介质访问控制协议DQDB (Distributed Queue Dual Bus 分布式队列双总线)及物理层技术规范。

    IEEE 802.7 :宽带技术咨询组,提供有关宽带联网的技术咨询。

    IEEE 802.8 :光纤技术咨询组,提供有关光纤联网的技术咨询。

    IEEE 802.9 :综合声音数据的局域网(IVD LAN)介质访问控制协议及物理层技术规范。

    IEEE 802.10:网络安全技术咨询组,定义了网络互操作的认证和加密方法。

    IEEE 802.11无线局域网(WLAN)的介质访问控制协议及物理层技术规范。

    IEEE 802.11,1997年,原始标准(2Mbit/s,播在2.4GHz)。

    IEEE 802.11a,1999年,物理层补充(54Mbit/s,播在5GHz)。

    IEEE 802.11b,1999年,物理层补充(11Mbit/s播在2.4GHz)。

    IEEE 802.11c,符合802.1D的媒体接入控制层桥接(MAC Layer Bridging)。

    IEEE 802.11d,根据各国无线电规定做的调整。

    IEEE 802.11e,对服务等级(Quality of Service, QoS)的支持。

    IEEE 802.11f,基站的互连性(IAPP,Inter-Access Point Protocol),2006年2月被IEEE批准撤销。

    IEEE 802.11g,2003年,物理层补充(54Mbit/s,播在2.4GHz)。

    IEEE 802.11h,2004年,无线覆盖半径的调整,室内(indoor)和室外(outdoor)信道(5GHz频段)。

    IEEE 802.11i,2004年,无线网络的安全方面的补充。.

    IEEE 802.11j,2004年,根据日本规定做的升级。

    IEEE 802.11l,预留及准备不使用。

    IEEE 802.11m,维护标准;互斥及极限。

    IEEE 802.11n,更高传输速率的改善,基础速率提升到72.2Mbit/s,可以使用双倍带宽40MHz,此时速率提升到150Mbit/s。支持多输入多输出技术(Multi-Input Multi-Output,MIMO)。

    IEEE 802.11k,该协议规范规定了无线局域网频谱测量规范。该规范的制订体现了无线局域网络对频谱资源智能化使用的需求。

    IEEE 802.11p,这个通信协定主要用在车用电子的无线通信上。它设置上是从IEEE 802.11来扩充延伸,来符合智能型运输系统(Intelligent Transportation Systems,ITS)的相关应用。

    IEEE 802.11ac,802.11n的潜在继承者,更高传输速率的改善,当使用多基站时将无线速率提高到至少1Gbps,将单信道速率提高到至少500Mbps。使用更高的无线带宽(80MHz-160MHz)(802.11n只有40MHz),更多的MIMO流(最多8条流),更好的调制方式(QAM256)。目前是草案标准(draft),预计正式标准于2012年晚些时间推出。Quantenna公司在2011年11月15日推出了世界上第一只采用802.11ac的无线路由器Broadcom公司于2012年1月5日也发布了它的第一支支持802.11ac的芯片。

    IEEE 802.11ae-2012

    IEEE 802.12 : [1]  [2-3]  需求优先的介质访问控制协议(100VG AnyLAN)。

    IEEE 802.13 :(未使用 )【不吉利的数字,没有人愿意使用它---查自《计算机网络-Andrew S. Tanebaum》 Page 63 - 1.6.2 国际标准领域中最有影响的组织】

    IEEE 802.14:采用线缆调制解调器(Cable Modem)的交互式电视介质访问控制协议及网络层技术规范。

    IEEE 802.15:采用蓝牙技术的无线个人网(Wireless Personal Area Networks,WPAN)技术规范。

    IEEE 802.15.1:无线个人网络。

    IEEE 802.15.4:低速无线个人网络

    IEEE 802.16:宽带无线连接工作组,开发2~66GHz的无线接入系统空中接口

    IEEE 802.17:弹性分组环 (Resilient Packet Ring,RPR)工作组,制定了单性分组环网访问控制协议及有关标准。

    IEEE 802.18:宽带无线局域网技术咨询组(Radio Regulatory)。

    IEEE 802.19:多重虚拟局域网共存(Coexistence)技术咨询组。

    IEEE 802.20:移动宽带无线接入( Mobile Broadband Wireless Access ,MBWA)工作组,制定宽带无线接入网的解决 。

    IEEE 802.21:媒介独立换手(Media Independent Handover)。

    IEEE 802.22: [4]  无线区域网(Wireless Regional Area Network)

    IEEE 802.23:紧急服务工作组 (Emergency Service Work Group)

    展开全文
  • 三种常见的局域网通信协议.pdf
  • 实验1 局域网网络协议分析与验证 实验目的 理解DIX Ethernt V2 帧结构 验证ARP协议的请求报文和响应报文结构 学习常用网络协议分析工具wireshark 实验内容 使用wireshark捕获数据包 分析数据包结构 实验环境包括拓扑...
  • 设计和组建无线局域网网络数据包捕获和协议分析实用.pdf
  • 局域网通信协议网络术语文.pdf
  • C#实现搜索局域网网络设备IP功能,输入起止网段IP即可实现搜索
  • 无线局域网的安全协议与加密技术汇编.pdf
  • 无线局域网MAC层协议的性能研究归类.pdf
  • 无线局域网的安全协议与加密技术终稿.pdf
  • 计 课程名称 计算机网络 _ 题目名称 _ 学生学院 _计算机学院 _ 专业班级 _ 学 号 学生姓名 指导教师 _ _ _ _ _ 2013 年 1 月 11 日 随意编辑 精品文档 计算机网络课程设计 一 设计题目 使用 ARP 协议获取局域网内部...
  • 无线局域网网络协议分析与监测系统 无线局域网网络协议分析与监测系统
  • 局域网组建协议汇编.pdf
  • 网络管理之局域网协议设置一点通 电脑资料.doc
  • 基于硬件多线程网络处理器功耗可控无线局域网MAC协议实现.pdf
  • 3、无线局域网 组成WLAN的基本单元是基本服务集(BSS),BSS包含一个固定的AP和多个终端。 3.1、基本概念: AP(Access Point,无线访问节点):无线接入点,常见是我们家用的带有天线路由器,手机通过wifi与路由器天线...

    3、无线局域网

    组成WLAN的基本单元是基本服务集(BSS),BSS包含一个固定的AP和多个终端。

    3.1、基本概念:

    AP(Access Point,无线访问节点):无线接入点,常见是我们家用的带有天线路由器,手机通过wifi与路由器天线传输与接收数据信号。AP分为室内AP、室分AP和室外AP。

    • 室内:室内放装型AP设备。对于建筑结构较简单、面积相对较小、用户相对集中的场合及对容量需求较大的区域,如小型会议室、酒吧、休闲中心等场景宜选用室内放装型AP设备,该类型设备可根据不同环境灵活实施分布,也可同时工作在AP和桥接等混合模式下。

    • 室分:室内分布型AP设备。对于建筑面积较大、用户分布较广且已建有多系统合用的室内分布系统的场合,如大型办公楼、商住楼、酒店、宾馆、机场、车站等场景宜选用室内分布型AP设备,该类型设备接入室内分布系统作为WLAN系统的信号源,以实现对室内WLAN信号的覆盖。

    • 室外:室外分布型AP设备。对于接入点多,用户量大,且用户分布较为集中的场合下,如学校、大型会展中心等大型场所,宜选用室外AP设备组网。

    AP(Access Control):接入控制器,负责把来自不同AP的数据进行汇聚并接入Internet,同时完成AP设备的配置管理、无线用户的认证、管理及宽带访问、安全等控制功能。

    3.2、无线拓扑

    3.2.1、独立基本服务集(IBSS)

    IBSS(independent BSS)是最简单的通信方式,终端通过自身的无线网卡直接通信,当设备之间的网卡都设置成ad hoc(点对点)模式时,它们之间可以相互连接并传输文件。有效距离20~40米范围内,就可在终端上查找到对方,设置好共享让多台设备之间通过直接连接方式进行数据共享。最简单的方式是两台安装有无线网卡的计算机实施无线互联,其中一台计算机连接Internet就可以共享带宽。

    在这里插入图片描述

    ad hoc(点对点)模式,是一种省去了无线中介设备AP而搭建起来的对等网络结构,只要安装了无线网卡,计算机彼此之间即可实现无线互联。没有严格的控制中心。所有结点的地位平等,即是一个对等式网络。

    ad hoc网络的特点之一就是安全性较差,易受窃听和攻击。除非家庭一般极小使用。

    3.2.2、基本服务集(BSS)

    BSS(Basic Service Sets,基本服务集)是由AP(无线接入点)提供的无线信号决定的区域(蜂窝),也被称为基本服务区(BSA),两个含义相同。BSS在实际情景中,指的是一个区域内多台设备能通过这台AP的无线信号上网和相互通信,比如我们在一家火锅店内,在这个范围内顾客和员工使用手机、笔记本这些设备上网,都是通过这家店的一台无线路由器。BSS包含一个固定的AP和多个终端。

    在这里插入图片描述
    上图中连接了一台交换机,这种通过AP(无线接入点)与交换机有线或无线网络进行通信,称为DS(Distribution System,分布式系统)。

    服务集标识符(SSID)是一个独一无二的32字符标识符,是对BSS的标识。简单的说就是一个独一无二的标识,比如一般家庭在无线路由器上设置一个SSID可以是中文也可以的字符,当使用手机、笔记本或者一些家用电器连接wifi时就可以看到很多名称,1加1等于2、某某的wifi、tplink2421、SY36643等这些标识,这些就是SSID。

    BSSID是AP的身份标识,它也是通常所说的MAC地址。
    在这里插入图片描述

    3.2.3、扩展服务集(ESS)

    ESS(Extended Service Sets,扩展服务集 ),扩展无线网络覆盖范围,通过分布式系统连接多个使用相同SSID的BSS来构成。接入点的覆盖小区之间部分重叠,以实现客户端的无缝漫游。使用者在无线覆盖区域移动时,信息号不中断。

    扩展服务集
    以上图为例,ESS由两个BSS区域构成,SSID相同,BSSID不同,SSID相同是为了使用者在接入WIFI信号下不用转换网络来源,BSSID不同是使用了两个的AP(无线接入点),它们的MAC地址必然不同。从一个AP漫游到另一AP必须至少重叠10%~20%才不会信号中断。还有一个条件是两个AP的频率不能相同。

    扩展服务集要求:

    • 两个独立BSS的AP一定要连接到同一个分布式系统
    • 两个SSID一定要相同
    • 两个BSS一定要有重叠的覆盖区域。

    3.2.4、VAP

    VAP(virtual AP,虚拟AP),即虚拟AP,在AP设备上虚拟出多个虚拟的AP。在平日生活我们常在餐厅、宾馆、大型购物场连接WIFI时,会发现几个SSID相近的WIFI信号源,选择哪一个使用同样的密码都可以连接上网。为什么要设置多个虚拟的AP(虚拟的接入点)?这是为了差异化上网服务,把顾客与员工区分开来,还有顾客上网的分流,员工使用的无线网络网速快,使用内部密码,顾客上网速度自然要低一些,能够维持基本的上网条件但不支持视频和网游。

    不同VAP安全设置,QoS设置等策略和功能不一样。不同VAP一般第一个VAP的MAC是跟AP的MAC地址一样,后面的是虚拟出来的,通常是在后面加1。
    在这里插入图片描述

    3.3、无线局域网组网方案

    3.3.1、自治式网络

    AP模式指作在这种模式下的路由器只有接入功能,并没有用到路由功能,也称为FAT AP(胖AP)模式。
    AP模式
    这种组网下的AP功能完善,每个AP都要分别配置,相互独立工作,因此叫做“胖AP”。在那些比较大单位部署AP较多,不能集中统一管理,维护相当麻烦。在家庭这种方式还可以,在单位企业不会采用这种方式。

    3.3.2、AP+AC组网

    AC(Access Controller,接入控制器),AC对无线局域网中的所有AP进行控制和管理。无线控制器还可以与认证服务器配合使用,来为WLAN用户提供认证服务。

    在这里插入图片描述
    AC负责管理所有的AP,在AC上能够对连接的AP统一配置,对AP进行实时监控、漫游管理、安全控制。安全性提高、部署、维护更容易。因此叫做“瘦AP(Fit AP)”。

    AC可以实现三个非常重要的功能,快速搜索AP、AP间负荷均衡、无缝漫游,这三个功能是通过在AP支持的802.11k无线资源测量协议、802.11v无线网络管理协议、802.11r快速漫游协议来实现。

    1、同一网段内小型网络
    适用小型企业或单位,终端数量不超过200台,工作在二层,也称为二层AP+AC组网。就只有交换机与AC、AP连接,在同一广播域、同一网关。
    在这里插入图片描述
    2、不同网段AP+AC组网
    三层AP+AC组网,顾名思义,工作在第三层不同网段上,适用于中、大型网络,以大型园区。AC放在核心机房进行统一管控。
    在这里插入图片描述

    展开全文
  • 本次实验通过配置RIPv2协议、OSPF协议、静态路由、动态NAT实现了各局域网内的PC可经边界路由器进行私有IP到公有IP的转换,并成功访问公网服务器。

    系列文章目录

    【计算机网络】思科实验(1):交换机的VLAN划分

    【计算机网络】思科实验(2):交换机间的VLAN通信

    【计算机网络】思科实验(3):使用三层交换机实现跨VLAN间的通信

    【计算机网络】思科实验(4):综合实验作业之办公室的跨VLAN通信

    【计算机网络】思科实验(5):单臂路由跨VLAN通信

    【计算机网络】思科实验(6):路由器的静态路由配置

    【计算机网络】思科实验(7):网络地址转换之路由器静态NAT模拟

    【计算机网络】思科实验(8):网络地址转换之路由器动态NAT模拟

    【计算机网络】思科实验(9):动态路由协议RIPv2

    【计算机网络】思科实验(10):动态路由协议OSPF

    【计算机网络】思科实验(11):综合实验作业之局域网与路由协议


    实验环境:Packet Tracer


    前言

    本次实验主题:使用3台二层交换机和1台三层交换机实现办公室内跨VLAN间的通信。实验内容来自课堂。本文仅对实验步骤做记录。


    一、题意理解

    若有两个自治系统,如下图所示,A自治系统获得一个202.13.5.10-202.13.5.120个公网IP地址,B自治系统获得了203.13.10.100-203.13.10.150个公网IP地址。

    但A系统内存在4个局域网,分别有80、16、30和8个用户,B系统内存在3个局域网,分别有32、47、120个用户。所以A系统和B系统分别使用192.168.1.0/24和10.0.0.0/24作为内部私有地址。

    154.55.12.0/24,177.12.5.0/24和220.12.2.0/24网段分别为公共网络中所经过网络。按照图中拓扑,请完成以下要求。

    (1) 尽量以最小网络进行地址分配,将私有地址空间分配给各个局域网。

    (2) A系统使用RIP协议,B系统使用OSPF协议完成路由。

    (3) 公网采用静态路由策略,让每台电脑都可以连接到服务器Server0。
    题目

    这也就是说,为了完成这个实验,使每台电脑都可以Ping通Server,我们需要做的有以下几点:

    • 建立网络拓扑。
    • 以最小网络进行私网IP地址分配,并设置好各设备的IP/SM/GW。
    • 对自治系统A、B,设置动态NAT,添加公私网IP映射关系。
    • 给自治系统A配置RIP协议。
    • 给自治系统B配置OSPF协议。
    • 给公网路由器添加静态路由。

    二、建立网络拓扑

    2.1 初步搭建拓扑结构

    添加7台计算机,表示7个局域网;

    添加1台服务器;

    添加1台二层交换机2960 ;

    添加7台路由器2811。

    在R0、R1、R2、R5、R6中分别添加1个WIC-2T网卡模块(先关闭路由器,添加完成后再开启)。

    如下图建立网络拓扑,使用直通线、DCE串口线、交叉线连接好设备。
    网络拓扑

    2.2 以最小网络进行私有IP地址分配

    首先是自治系统A:

    A的内部地址192.168.1.0/24

    A系统内存在4个局域网,分别有80、16、30和8个用户,每个局域网有1个网关

    80 < 2^7-2 = 128-2=126
    30 <= 2^5-2 = 32-2=30
    16 < 2^5-2 = 32-2=30
    8 < 2^4-2 = 16-2=14

    Net用户数主机位私有IP地址范围掩码位子网掩码
    Net 1807192.168.1.0-192.168.1.12732-7=25255.255.255.128
    Net 3305192.168.1.128-192.168.1.15932-5=27255.255.255.224
    Net 2165192.168.1.160-192.168.1.19132-5=27255.255.255.224
    Net 484192.168.1.192-192.168.1.20732-4=28255.255.255.240

    然后是自治系统B:

    B的内部地址10.0.0.0/24

    B系统内存在3个局域网,分别有32、47、120个用户,每个局域网有1个网关

    120+1 < 2^7-2 = 128-2=126
    47+1 < 2^6-2 = 64-2=62
    32+1 < 2^6-2 = 64-2=62

    Net用户数主机位私有IP地址范围掩码位子网掩码
    Net 3120710.0.0.0-10.0.0.12732-7=25255.255.255.128
    Net 247610.0.0.128-10.0.0.19132-6=26255.255.255.192
    Net 132610.0.0.192-10.0.0.25532-6=26255.255.255.192

    2.3 设置各设备的IP/SM/GW

    设置路由器的IP/SM时,路由器不同端口的IP不能处于同一网段,还有别忘了开启端口,串行端口的时钟频率设为64000。
    IP/SM/GW

    【在本实验中,交换机各端口需处于同一网段中!】

    三、自治系统A

    3.1 添加RIP协议

    在Router0、Router1、Router2中添加RIP协议:

    Router(config)#router rip
    Router(config-router)#version 2
    Router(config-router)#network 192.168.1.0
    Router(config-router)#end
    

    3.2 检查连通性

    添加完RIPv2协议后可以使用设备互ping,检查连通性。

    如用Router2去ping四个局域网的PC,都能ping通:
    ping

    3.3 设置动态NAT

    3.3.1 划分端口

    在Router2中划分私网、公网的端口。

    代码如下:

    Router#conf t
    Router(config)#interface se0/1/0
    Router(config-if)#ip nat inside
    Router(config-if)#exit
    Router(config)#interface se0/1/1
    Router(config-if)#ip nat inside
    Router(config-if)#exit
    Router(config)#interface fa0/1
    Router(config-if)#ip nat outside
    Router(config-if)#exit
    

    3.3.2 添加公私网的IP映射信息

    在Router2中添加公私网的IP映射信息。

    代码如下:

    Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
    Router(config)#ip nat pool a 202.13.5.10 202.13.5.120 netmask 255.255.255.0
    Router(config)#ip nat inside source list 1 pool a
    Router(config)#end
    

    3.3.3 添加静态路由

    此时用私网Net4的PC去ping划分公、私网的路由器Router0的公网端口,会返回目标不可达的信息,说明此时私网的路由表不全。
    ping
    所以需要给Router0、Router1添加静态路由信息。

    由于Router0、Router1处于私网内部,访问公网需要通过划分公、私网的Router2,所以在Router0、Router1中只添加默认的静态路由信息即可。

    在Router0中:
    默认静态路由
    在Router1中:
    默认静态路由

    3.3.4 观察IP地址变化

    用私网Net4的PC去ping公网服务器,观察到私网IP成功转化为公网IP,动态NAT设置完成。
    ping

    四、自治系统B

    4.1 添加OSPF协议

    在Route3、Router4中添加OSPF协议.

    在Router3中:

    Router>enable
    Router#conf t
    Router(config)#ip routing
    Router(config)#router ospf 1
    Router(config-router)#network 10.0.0.192 0.0.0.255 area 0
    Router(config-router)#network 10.0.0.128 255.255.255.0 area 0
    Router(config-router)#end
    

    在Router4中:

    Router>enable
    Router#conf t
    Router(config)#ip routing
    Router(config)#router ospf 1
    Router(config-router)#network 10.0.0.0 0.0.0.255 area 0
    Router(config-router)#network 10.0.0.128 255.255.255.0 area 0
    Router(config-router)#end
    

    在Router5中:

    Router>enable
    Router#conf t
    Router(config)#ip routing
    Router(config)#router ospf 1
    Router(config-router)#network 10.0.0.0 0.0.0.255 area 0
    Router(config-router)#network 10.0.0.192 255.255.255.0 area 0
    Router(config-router)#end
    

    添加完成后在Router5中可以看到以下信息:

    O       10.0.0.0/25 [110/2] via 10.0.0.132, 00:01:03, FastEthernet0/1
    C       10.0.0.128/26 is directly connected, FastEthernet0/1
    O       10.0.0.192/26 [110/2] via 10.0.0.131, 00:01:03,
    

    4.2 检查连通性

    添加完OSPF协议后可以使用设备互ping,检查连通性。

    如用Net3的PC去ping一下Net1的PC和Net2的PC,能ping通:
    ping

    4.3 设置动态NAT

    4.3.1 划分端口

    在Router5中划分私网、公网的端口。

    代码如下:

    Router>enable
    Router#conf t
    Router(config)#interface fa0/1
    Router(config-if)#ip nat inside
    Router(config-if)#exit
    Router(config)#interface se0/3/0
    Router(config-if)#ip nat outside
    Router(config-if)#exit
    

    4.3.2 添加公私网的IP映射信息

    在Router5中添加公私网的IP映射信息。

    代码如下:

    Router(config)#access 2 permit 10.0.0.0 0.0.255.255
    Router(config)#ip nat pool b 203.13.10.100 203.13.10.150 netmask 255.255.255.0
    Router(config)#ip nat inside source list 2 pool b
    Router(config)#end
    

    4.3.3 添加静态路由

    所以需要给Router3、Router4添加静态路由信息。

    由于Router3、Router4处于私网内部,访问公网需要通过划分公、私网的Router5,所以在Router3、Router4中只添加默认的静态路由信息即可。

    在Router3中:
    默认静态路由
    在Router4中:
    默认静态路由

    4.3.4 观察IP地址变化

    用私网Net3的PC去ping公网服务器,观察到私网IP成功转化为公网IP,动态NAT设置完成。
    IP变化

    五、公网

    5.1 添加公网的静态路由

    在Router2中:
    R2的静态路由
    在Router5中:
    R5的静态路由

    在Router6中:
    R6的静态路由
    R6的静态路由

    5.2 检查连通性

    静态路由添加完了之后可以在路由器中ping一下目标网段中的某个设备,检查一下静态路由是否添加正确。

    比如说在Router2中ping一下分别位于两个目标网段中的服务器和路由器:
    ping
    用自治系统A中Net2的PC去ping一下公网中的服务器:
    ping
    用自治系统B中Net1的PC去ping一下公网中的服务器:
    ping


    总结

    本次实验通过配置RIPv2协议、OSPF协议、静态路由、动态NAT实现了各局域网内的PC可经边界路由器进行私有IP到公有IP的转换,并成功访问公网服务器。

    (放假啦!终于有时间把之前剩余的部分修改发出来了!因为有修改过,所以步骤可能会有一些衔接不上(?)或者存在一些ping通问题。路由协议的配置那里我还是有一点不太清楚,就全部配置了一样的子网掩码补码,好像不是很影响。)

    展开全文
  • 网络(局域网和广域网、网址、协议网络硬件) 局域网和广域网 1、局域网(Local Area Network),简称LAN,是指在某一区域内由多台计算机互联成的计算机组。“某一区域”指的是同一办公室、同一建筑物、同一公司和同一...
  • 网络游戏-具有无线接入网络因特网协议网关的独立无线局域网.zip
  • 已实现的功能: 1、用户登录 2、在线用户列表 3、实时聊天:群聊、私聊 4、好友上线提示 JFrame界面简洁、操作简单!
  • 一、轮询访问介质访问控制 (一)介质访问控制 信道划分介质访问控制(MAC Multiple Access Control )协议: ...轮询访问MAC协议/轮流协议/轮转访问MAC协议:既要不产生冲突,又要发送时占全部带宽。 ①、轮询
  • 网络游戏-具有移动管理的无线接入网络因特网协议网关的无线局域网.zip
  • 局域网中的基本概念2.Vlan 概述3.VLAN工作原理三、实验部分问题1:一个HUB的所有端口是属于同一个广播域吗?是属于同一个冲突域吗?交换机呢?问题2:能够在一条链路上承载多vlan的链路,叫什么链路?该链路上的数据...
  • 无线局域网安全协议与增强WLAN安全的方案、电子技术,开发板制作交流
  • 如何配置局域网中的通讯协议实用.pdf

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 161,092
精华内容 64,436
关键字:

局域网常用的网络协议