精华内容
下载资源
问答
  • 网络拓扑图企业网络设计基本流程认识网络常见的路由协议分类:常见路由协议类型:网络层次结构:TCP/IP协议网络拓扑图企业网络设计基本流程网络设计基本原则网络拓扑设计原则网络设计的方法和思路网络架构安全域和...

    认识网络

    构建网络的目的:就是为了相互之间能够通信,而通信的目的就是为了传达信息。(信息传达和信息接收的安全性。)
    企业网络的目的:是作为企业业务的支撑平台,是企业的信息中枢。

    • 网络:被称为计算机网络,它是计算机技术和通信技术相结合的产物。
    • 节点:这里的节点就是一个个的机房以及机房里面的设备(路由器、交换机、防火墙、PC…)
    • 链路:就是有线和无线,有线:网络、光纤、电缆等等…

    网络中常见的协议:

    • VLAN技术:虚拟局域网;
    • STP技术:生成树协议;
    • VRRP技术:虚拟路由冗余协议;
    • VPN:虚拟专用网络。
      在这里插入图片描述

    常见的路由协议分类:

    • 静态:设置好路由器和主机并将路由信息固定的一种方法。
    • 动态:路由协议在进行过程中自动的设置路由控制信息的一种方法

    静态路由通常手工配置,网络发生故障时需要管理员手动修改,动态路由协议可以在由其他路可达目的主机的前题下自动学习路由,绕过故障节点。
    在这里插入图片描述

    常见路由协议类型:

    一、内部网关协议:
    内部网关协议(IGP:Interior Gateway Protocol),适用于单个ISP的统一路由协议的运行,一般由一个ISP运营的网络位于一个AS(自治系统)内,有统一的AS number(自治系统号),用来处理内部路由。


    RIP、IGRP(Cisco私有协议)、EIGRP(Cisco私有协议)、OSPF、IS-IS等都是内部网关协议。


    1、RIP(Routing Information Protocol):路由信息协议。
    是一种比较简单的内部网关协议,主要用于规模较小的网络,比如校园网以及结构较简单的地区性网络。对于更为复杂的环境和大型网络,一般不使用RIP。
    RIP是一种基于距离矢量(Distance-Vector)算法的协议,它通过UDP报文进行路由信息的交换,使用的端口号为520。其使用跳数来衡量到达目的地址的距离,为了限制收敛时间,RIP规定度量值(该值等于从本网络到达目的网络间的路由器数量)为0到15之间的整数,大于等于16的跳数将会定义为网络或主机不可达,因此RIP不适合大型网络。
    RIP有两个版本:RIP V1(有类别路由协议)和RIP V2(无分类路由协议)。


    2、IGRP(Interior Gateway Routing Protool):内部网关路由协议。
    属于Cisco的私有协议,最大跳数默认为100,现已被Cisco独立开发的EIGRP协议取代。


    3、OSPF(Open Shortest Path First):开放式最短路径优先协议。
    属于链路状态路由协议,OSPF提出了“区域(area)”的概念,每个区域中所有路由器维护着一个相同的链路状态数据库 (LSDB),其使用链路状态数据库,通过最短生成树算法(SPF算法)计算得到路由表,因此其收敛速度较快。目前OSPF协议在各种网络中广泛部署,目前针对IPv4协议使用的是OSPF Version 2(RFC2328);针对IPv6协议使用OSPF Version 3(RFC2740)。


    4、IS-IS(Intermediate System-to-Intermediate System):中间系统到中间系统路由协议。
    属于链路状态路由协议。与OSPF协议相似,其使用最短路径优先SPF(Shortest Path First)算法进行路由计算。

    二、域间路由协议
    BGP(Border Gateway Protocol):边界网关协议。
    为了维护各个ISP的独立利益,标准化组织制定了ISP间的路由协议BGP,其用来处理各ISP之间的路由传递。
    与内部网关协议不同的是,其不在于发现和计算路由,而在于控制路由的传播和选择最佳路由。

    网络层次结构:

    传统的网络层次结构是OSI七层模型,但在现实中采用的是TCP/IP协议。
    (一)OSI七层模型
    (1)物理层
    设备之间原始数据传输,数据格式比特流。
    (2)数据链路层
    将原始比特流转换成逻辑传输数据,mac地址寻址,数据格式帧。
    (3)网络层
    最复杂的一层,通信子网最高层。通过路由算法提供最佳传输路径。数据格式IP数据包。
    数据链路层解决同一网络节点间数据传输,网络层解决不同子网间通信。
    (4)传输层
    拆分数据包,提供端对端不同主机用户进程间传输数据,提供可靠或不可靠传输及流量控制,是连接通信子网和资源子网的桥梁。数据格式TCP数据包。
    (5)会话层
    不同机器用户间建立或解除会话关系。
    (6)表示层
    数据的表示方式(格式处理及编码转换)及特定功能实现(加解密、解压缩等)。
    (7)应用层
    向用户提供服务,完成用户在网络上想完成的工作。如上网、发邮件、下载ftp等。

    TCP/IP协议

    (1)链路层
    包括物理层和数据链路层链路层是通过mac地址传输数据的。
    (2)网络层
    包括多种协议。
    IP协议:通过路由选择将数据封装后交给链路层。
    ICMP协议:用于主机和路由器直接传递控制消息,常用的ping就是用这个协议。
    ARP协议:是正向地址解析协议,通过IP查找mac地址。
    RARP协议:是反向地址解析协议,通过mac地址查找IP。
    (3)传输层
    TCP协议:传输控制协议,面向连接的、可靠的、基于IP的传输层协议。
    UDP协议:用户数据报协议,提供面向事务的简单不可靠信息传送协议。
    (4)应用层
    FTP协议:文件传输协议,用于文件的上传下载。
    Telnet协议:用户远程登录服务。
    DNS协议:域名解析协议,提供域名到IP的解析。
    SMTP协议:简单的邮件传送协议,用于控制信件的发送中转。
    NFS协议:网络文件系统,用于不同主机间文件共享。
    HTTP协议:超文本传输协议,用于实现互联网访问功能。

    模型结构:

    在这里插入图片描述

    网络拓扑图

    • 拓扑简单的的说就是几何结构,是指网络中各个站点相互连接的形式,主要有总线型拓扑、星型拓扑、环形拓扑以及混合型拓扑。

    网络拓扑结构类型:

    1. 总线拓扑
      总线拓扑结构是将网络中的所有设备通过相应的硬件接口直接连接到公共总线上,结点之间按广播方式通信,一个结点发出的信息,总线上的其它结点均可“收听”到。
      优点:结构简单、布线容易、可靠性较高,易于扩充,是局域网常采用的拓扑结构。
      缺点:所有的数据都需经过总线传送,总线成为整个网络的瓶颈;出现故障诊断较为困难。最著名的总线拓扑结构是以太网(Ethernet)。
      在这里插入图片描述

    1. 星型拓扑
      每个结点都由一条单独的通信线路与中心结点连结。
      优点:结构简单、容易实现、便于管理,连接点的故障容易监测和排除。
      缺点:中心结点是全网络的可靠瓶颈,中心结点出现故障会导致网络的瘫痪。
      在这里插入图片描述

    3.环形拓扑
    各结点通过通信线路组成闭合回路,环中数据只能单向传输。
    优点:结构简单、容易实现,适合使用光纤,传输距离远,传输延迟确定。
    缺点:环网中的每个结点均成为网络可靠性的瓶颈,任意结点出现故障都会造成网络瘫痪,另外故障诊断也较困难。最著名的环形拓扑结构网络是令牌环网(Token Ring)
    在这里插入图片描述


    1. 树型拓扑
      是一种层次结构,结点按层次连结,信息交换主要在上下结点之间进行,相邻结点或同层结点之间一般不进行数据交换。
      优点:连结简单,维护方便,适用于汇集信息的应用要求。
      缺点:资源共享能力较低,可靠性不高,任何一个工作站或链路的故障都会影响整个网络的运行。
      在这里插入图片描述

    5.网状拓扑
    又称作无规则结构,结点之间的联结是任意的,没有规律。
    优点:系统可靠性高,比较容易扩展,但是结构复杂,每一结点都与多点进行连结,因此必须采用路由算法和流量控制方法。目前广域网基本上采用网状拓扑结构。
    缺点:由于结点也多个结点连接,故结点的路由选择由选择和流量控制难度大,管理软件复杂,硬件成本高。
    在这里插入图片描述
    广域网与局域网所使用的网络拓扑结构有所不同。广域网多采用分布式或树型结构,局域网常用总线型、环型、星型或树型结构

    企业网络设计基本流程

    网络设计基本原则

    网络设计的基本原则
    可靠性:要求网络在发生一定的故障时,仍然能够保证承载的业务不中断
    可扩展性:要求网络能够支持不断增加的业务量。
    可运营性:保证网络的运行和维护
    可管理性:要求网络提供标准的管理手段,便于监控和维护
    成本问题:综合考虑,选择性价比高的网络设计方案。

    网络拓扑设计原则

    在这里插入图片描述

    模块化设计原则:根据所承载的功能区域来划分不同的模块;
    层次化设计原则:根据企业需求设计网络,选用二层,三层网络模型;
    性价比:
    高性能:
    可靠性:
    安全性:

    网络设计的方法和思路

    • 模块化的设计方法、层次化的设计方法

    层次化设计的优点:
    节约成本、容易理解、有利于模块化、有利于故障隔离;
    模块化设计优点:
    将一个企业网络按照功能的不同,分为了不同的模块,不同的模块有不同的需求和特点;
    每一个模块相对独立,可以单独构建这个模块里面需要的一些结构,模块之间相互没有影响;
    便于扩容、管理,不同模块有不同的安全策略;在这里插入图片描述
    DMZ:非军事区域(官方称呼),互联网服务区或者互联网隔离区(民间称呼);


    模块的安全等级:
    安全等级由低到高:
    陌生访客–>分支机构–>DMZ–>数据中心/服务器群–>管理中心;
    分支机构一般有固定的地址;
    管理中心存储着高权限的账号,一旦被入侵,对整个网络危害最大;

    • 自上而下的设计思路和自下而上的设计思路
      在这里插入图片描述

    • 根据场景设计合适的方案
      在这里插入图片描述

    网络架构

    • 三层网络架构:接入层–>汇聚层–>核心层;
      适用场景–通常用于大型网络的构建,需要通过IP路由实现跨网段的通讯;

    • 二层网络架构:接入层–>汇聚层或者核心层;
      它的组网能力是非常有限的,一般用于中小型局域网;

    一般企业网络使用三层网络结构:

    • 接入层:终端的接入、访问控制;
    • 汇聚层:路由汇聚、流量收敛;
    • 核心层:高速数据转发、要求高可靠性。

    安全域和边界:

    企业网络的经典结构就是基于安全域的网络结构,一般包括企业数据中心,企业办公内网,DMZ区,广域网和Internet几个部分。

    企业网络各个区域之间通信受到限制,区域内部通信多不进行限制。

    为了保障企业的信息安全,我们应该从哪几个方面入手?

    1、终端计算机

    2、互联网出入口

    3、广域网出入口

    4、公司对外发布服务的DMZ服务器

    5、VPN和类似远程连接设备。

    上述五个方面,基本涵盖了公司网络边界的几个方面。

    对公司网络边界进行防护,仅仅是做好公司信息安全防护工作的第一步。

    那么接下来我们应该考虑什么呢?

    当然是如果上述五个方面被黑客攻陷了,那么我们还拿什么进行防护?

    这就涉及到了黑客攻击的几个步骤,黑客提权或者拿到设备权限之后,第一件事就是想知道我们的内网是什么样子的。

    那么,他们一定会进行内网扫描。而网络扫描这种事情,又是一种特征非常明显的网络攻击行为,非常易于识别。

    这就要求我们企业安全管理人员要重点关注内网扫描,做好被攻击后的进一步防护工作。

    由于上述5个方面易于被黑客攻陷,易于产生信息安全问题,那么我们就不能让这些区域可直接访问我们的核心资源。因此,需要进行安全域划分。同时,我们也要在各个高风险安全域的核心交换机上部署IDS,做好网络安全监控,并且在安全域出入口处部署防火墙,针对IDS产生的报警及时切断相关网络访问路径,保障损失的最小化。

    于是,企业网络安全的基本中的基本要求就是根据面临的风险,划分安全域,在安全域之间部署防火墙,在每个安全域内部署IDS。这也是我个人理解的网络安全域划分的本质安全需要。

    设计流程

    在这里插入图片描述

    • 对于小企业来说,一般参照到IP连通这个步骤。
    • 大型企业基本上可以完全参照这个流程来。

    1 . 规划
    组织策略:考虑公司的组织架构,就是公司有哪些部门。

    • 业务策略:就是公司当前的业务以及公司未来需要发展的业务。比如教育行业,物流行业等等。
    • 财务决策:公司的财务情况,能拿多少钱出来,预算是多少。

    2 . 简要的网络设计方案。

    • 设计:根据业务需求客户需要规划出网络拓扑图。
    • 需求分析:就是根据组织策略,来考虑不同部门的网络配置情况。
    • 项目计划:考虑项目进度(开始时间、完成时间)、成本多少、质量达到什么标准。
    • 设备选购:需要购买哪些设备。CPU 内存,吞吐量够不够,支持哪些协议,带机数量不同的接入,他们的流量是不一样的。

    3 . 详细设计的网络方案

    • 满足企业用户现阶段技术和业务上的需求。

    4 . 实施:根据需求规划网络

    • 新建网络:根据详细设计方案,直接进行落实。
    • 主要点:验证/测试整个网络是否满足企业在业务和技术上需求。
    • 对现有网络的改造:割接

    5 . 运营:

    • 保障企业网络业务能够持续、健康的运作。
    • 主要是对设备/系统运行进行主动监控。
    • CPU 内存 带宽 链路带宽比例。

    这些指标达到一定的预警范围,我们就需要对它进行处理(80-85%)。
    考虑是否进行扩容,
    可用性、可靠性、安全性

    6 . 提升:

    • 主要是围绕规划中的组织策略来的,针对的是企业网络在运营过程中遇到的问题。

    为什么要分析用户需求

    用户需求:即企业需求(这里的用户指的就是企业);

    IT应用:实际上就是将给我们的业务需求转换成我们的技术需求。(主要是由架构师和售前做的);

    如何分析用户需求:

    1. 识别网络现状:
      通过查看现有网络的文档;
      通过咨询相关岗位的负责人;
      通过网络监听;
      通过流量分析;
    2. 定义组织目标:
      提升客户满意度;
      扩展业务类型,增加服务项目;
      增强竞争力;
      削减开支;
    3. 组织限制:
      政策、预算、人力资源、技术资源、时间安排等客观因素;
    4. 定义技术目标:
      扩大网络容量;
      简化网络管理;
      提升网络安全;
      增强网络可靠性;
    5. 定义技术限制:
      设备限制,设备能否达到技术要求,
    展开全文
  • 今天开始我们就从最基础解析如何构建 HTML5 Canvas 拓扑图应用,HT 内部封装了一个拓扑图形组件 ht.graph....简单说来就是:拓扑图是泛化的说法,电信网管的网络拓扑图、电力的电网拓扑图、工业控制的监控图、工作
  • 本次设计主要针对企业网络构建规划方案进行简单设计,对企业网络的组建,各楼层信息点划分,企业网络拓扑图设计,使用防火墙及其设备的介绍,网络安全方案等。
  • 网络拓扑图标

    2018-07-11 15:09:19
    构建中小企业网络常用图标,可用于PPT,visio等网络示意图/拓扑图制图
  • 中小型企业网络构建(思科)

    千次阅读 2020-06-11 13:25:10
    网络培训中心网络系统设计1、引言2、网络设计过程综述2.1 设计目标2.2 ...网络拓扑图4.2 设备选型4.3 IP地址及VLAN划分5、网络设备配置5.1 交换机配置5.1.1 核心层交换机配置5.1.2 接入层交换机配置5.2 路由器配置5.3...

    1、引言

    随着社会的不断发展和“互联网+”时代的到来,公司对员工的计算机技能要求越来越高,随之各种各样的计算机培训机构在全国各地不断涌现,导致对于网络的需求量也越来越多,对网络传输的可靠性和安全性的要求也越来越高。面对激烈的竞争,各个培训机构对信息传输,信息处理,信息收集等工作量不多增加,所以为了提高该培训机构的竞争力,就必须建立一套完整的可靠的网络设计,以便于各个部门各个楼层之间的信息快速、稳定、安全的传输。通过这次学习能够很好地掌握网络方面的基础知识及专业技能。
    本次的毕业设计,主要通过思科模拟器Cisco Packet Tracer进行设计与规划,主要是交换机和路由器的基本配置,使其公司的网络实现全网互通、网络安全等预想的效果。本公司网络设计主要运用和网络技术的相关知识,其中主要用NAT技术是用来做地址转换,ACL用于控制访问列表,实现与互联网的互通互联,交换、路由等技术是实现整个公司的网络互联。

    2、网络设计过程综述

    2.1 设计目标

    本次设计将为腾飞培训中心建立一套完整的网络体系结构,该设计以现代网络技术和以在今后的发展中能够快速适应网络发展潮流为基础,以能够实现公司网络全部通畅为主要目标,将公司内部的各种打印机、服务器、PC等终端设备和局域网建立连接,实现公司内部的信息数据资源的传输与交流,并且能够与外网相连,使公司内部相关人员能够在网上发布与公司相关的信息,实现线上教学,同时使学员可以通过外网获取学习资源,提高学员对学习的兴趣,提高公司的知名度和实现公司内部网络与公网的信息的良好交流。

    2.2 设计综述

    在设计网络时要从实际出发,本着以组建良好的网络,但要节约成本为前提,根据该公司的特点和实际情况,在设计中要采用一些相对来说较成熟的网络技术,使公司今后的网络一般不会出问题,因为该公司的主要业务是关于计算机的培训,教学部的几个部门,例如Java部、网页设计部、数据库部等在教学中可能要上网查找一些资料,所以要求公司内部网络与外网之间的传输速率不能太低,至少要达到200Mb/s,以便满足现在和未来数据的信息传输的需求。同时因为随着网络的发展,网络的更新速度更快了,所以要保证在以后随着计算机网络发展而出现的新技术时,系统设备可以不用更换,但却能够迅速的投入使用,这样可以为公司节约今后换取设备的成本费用,最后就是要保证公司内部的信息安全,必要确保公司内部信息资源和教学资源的安全性和机密性,以及各种在线信息的安全性,由此同时还要防止一些常见黑客和病毒入侵,以确保本公司系统的可要性和能正常运行。

    3、用户需求分析

    3.1 公司概况

    3.1.1 公司的地理位置

    腾飞培训中心位于北京的一栋万达写字楼内,一共有三层楼,分别为第七层、第八层和第九层。第七层主要为行政部门,第八层和第九层主要用于平时教学。

    3.1.2 公司的组织架构

    腾飞培训中心的机构设置总体上分为行政部和教学部,其部门设置和人员信息见图3-1。

    在这里插入图片描述
    图3-1 行政部门结构图
    1.行政部门包含经理办公室,财务部、技术部、咨询部、市场部、服务器群、人力资源部。
    1)经理办公室分为两间办公室,一个为总经理办公室,另一个为副经理办公室,每间经理办公室都有一个秘书,负责帮助经理处理一些事情,所以每个经理办公室需要两台电脑,但只有经理的电脑可以访问各个部门的电脑。
    2)由于财务部人员较多,故需要15台电脑。
    3)技术部按小组的模式工作,主要分为网站维护小组、系统维护小组、服务4)咨询部和人事部各需要20台计算机。
    5)市场部内部分为市场调研部、市场分析部和市场综合部,由于市场调研部的工作人员需要经常深入市场调查,所以需要得到电脑不是那么多,故给市场调研部分配6台电脑足矣,市场调研部和市场综合部个分配10台电脑。
    6)服务器群可以让技术部的人去管理,这样可以使人员达到最大利用率,避免人员浪费。具体人数见表3-1。
    表3-1 行政部门人员信息表
    在这里插入图片描述
    教学部包含Java部、网页设计部、数据库部、算法部、网络设计部、美工部。具体架构见图3-2。
    在这里插入图片描述
    图3-2 教学部门结构图
    教学部包含Java部、网页设计部、数据库部、算法部、网络设计部、美工部。
    1)教学部教师专用计算机数目如下: Java部、网页设计部、数据库部、算法部、网络设计部、美工部各需要6台计算机。
    2)因为Java部、网页设计部、数据库部、网络设计部、美工部的教学都以上机操作为主,所以各需要学生计算机较多,同时因为算法部以理论知识为主要教学内容,所以算法部所需的计算机数目并不像其他几个部门那么多,故具体数据见表3-2。

    表3-2 教学部门人员表
    在这里插入图片描述

    3.2 公司网络系统的功能需求

    通过组网公司希望能够完成的主要业务包括办公自动化、电子邮件、因特网信息服务、文件共享和上交作业、公司财务管理、对非法信息进行保护、通过公司网访问因特网。具体见表3-3。
    在这里插入图片描述

    3.3 公司网络系统的性能要求

    3.3.1 网速要求

    网速是指在用手机或电脑上网时,上传或者下载视频、图像等时,请求数据时所用的时间长短。由于该公司的主要业务是计算机培训机构,需要经常上网查资料和下载软件,所以公司的网速不能太慢。网速受传输介质的影响较大,故采用现在最流行的光纤技术,使公司的网速不低于千兆。另一方面影响网速的因素还有服务器种类、硬件设施和传输距离等,所以在选择服务器种类和硬件设施时一定要选择一些性能较好的,同时要保证传输距离不是太远。由于该公司位于一栋楼房里面的第七层和第八九层,相对来说距离较近,故采用屏蔽双绞线,又因为该公司的网速的要求比较高,采用光纤通信,具体见表3-4。
    在这里插入图片描述

    3.3.2 带宽要求

    带宽就是在一定时间内传输信息量的多少。影响网络中带宽的因素有很多,所以本公司在设计网络时,重点考虑带宽的影响因素。采用一些性能较好的交换机、路由器和一些其他网络设备,同时采用光纤通信,以确保学员和员工在使用网络时,网速不至于那么迟缓。

    3.3.3 安全要求

    1)物理安全
    物理安全是网络系统安全的基础,它主要包括设备的防水、防火、防止断电等措施。所以在为本公司组建网络时就建设了防火系统,同时对中央机房也设置了恒温恒压的工作环境。同时突然断电是对网络和服务器的最大打击,很容易使网络服务不能正常运行,甚至设备损坏,因此储备了一些备用电源。机房要需要专职人员管理,做好出入登记。
    2)信息安全
    信息安全主要是网络的访问控制、病毒防范等。防火墙是组织内外网的主要屏障,因此在设计网络时就加入了防火墙,在内网防范病毒方面,安装杀毒软件,及时查杀服务器和终端,限制网上下载和盗版软件使用,定期更新补丁,病毒库升级。内网设备上配置了必要的安全配置,防止常见的协议攻击。
    3)人员管理安全
    安全的最大隐患最终还是对人员管理的安全,在安全的设备,一定要有人员的安全使用才能保证真正的安全。公司的使用人员并不都是计算机专业人员,因此,对相关的使用者进行必要的安全知识培训是非常必要的,同时,为了避免其他人员随意进入网络中心,所以我们规定除经理和技术部组长以上的等级可以进入中心机房,但是进入之前必须要经过领导的同意,其他人员不得入内,如果技术部的普通员工要进入中心机房,必须得到领导的同意,并且必须有相关等级更高的技术人员陪同。

    4、公司网络设计

    4.1 网络拓扑图

    公司网络分成两大部分,行政部子网和教学部子网,中间都通过路由器相连,为了提高网络语信息安全性,设置了防火墙,系统网络拓扑图见4-1。
    在这里插入图片描述
    公司的行政部分为7个部门,为了确保对网速的要求和平时的业务处理的顺利进行,所以每个部门放一台二层交换机,以达到缓冲的作用,同时可以使用VLAN技术对每个部门划分为一定的区域,以防止在通信的过程中产生信息冗余。行政部拓扑图见4-2。
    在这里插入图片描述
    公司的教学部分为6个部门,为了确保对网速的要求和教学的顺利进行,所以每个教学部门放一台二层交换机,同时可以使用VLAN技术对每个部门划分为一定的区域,以防止在通信的过程中产生信息冗余。教学部拓扑图见4-3。
    在这里插入图片描述
    每台设备的端口划分具体见表4-1;
    在这里插入图片描述

    4.2 设备选型

    从公司的实际角度出发,本着以经济适用,性能较好,便于在今后的发展中更新和兼容性比较好的原则,选取以下设备作为本次组网的物理设备,具体设备见表4-2。
    在这里插入图片描述

    4.3 IP地址及VLAN划分

    在互联网中一共有五类地址,因为A类地址可以分配的主机数较少,达不到本公司的要求,因此我们只能选A类B类或者C类地址。同时又因为A类地址有126个网络地址,每个A类地址可以有1600多万个主机,他们都在同一个广播域中,而在同一个广播域又有不可能有那么多许多节点,结果导致那么多个地址没有完全分配出去,所以我们一般不选择A类的共有地址来划分子网,但是同时A类的私有地址没有那么多,故我们一般选择B类地址或者C类地址来划分。又因为该公司分为三层,第七层主要是一些行政部门,所需要规划的计算机数目没那么多,所以可以采用C类地址192.168.10.0/24-192.168.70.0/24,而第八层和第九层主要是一些教学部门,考虑到要建设一些机房,所以可采用B类地址172.18.10.0/24-172.18.80.0/24,这样做一方面可以避免网络地址的浪费,同时也可以为公司节约一些成本。
    VLAN是一种在物理上的逻辑划分,他可以将一个网络划分为若干个虚拟网络,可以有效的避免广播风暴,提高网络的安全性,同时相同VLAN之间可以相互通信,不同VLAN之间使用相应的技术也可以使其通信,基于它实现简单,方便管理的特点,我们可以对该公司的各个部门进行VLAN划分。综上所述,腾飞公司各部门IP分配和VLAN划分见表4-3。
    在这里插入图片描述

    5、网络设备配置

    5.1 交换机配置

    5.1.1 核心层交换机配置

    因为核心层交换机的配置类似,所以我们以行政部三层交换机SW1为例,叙述具体配置过程。
    1)首先将各个VLAN划分进去,并且封装3-15号端口(以SW1为例),具体代码如下:
    Switch>en //进入特权模式
    Switch>enable //进入全局模式
    Switch#configure terminal
    SW1(config)#vlan 10 //创建VLAN10
    SW1(config)#int r f0/3-15 //进入3-15号端口
    SW1(config-if)#sw tr encapsulation dot1q //把3-15号端口进行封装
    SW1(config-if)#sw mo tr //设置为trunk链路
    SW1(config-if)#exit //退出
    2)配置以太网通道
    SW1(config)#int r f0/23-24 //进入23-24号端口
    SW1(config-if)#sw tr encapsulation dot1q //把23-24号端口进行封装
    SW1(config-if)#sw mo tr //设置为trunk链路
    SW1(config-if)#channel-group 1 mode on //把他们划分为同一组
    SW1(config-if)#exit //退出
    3)配置STP 和RIP路由。
    SW1(config)#spanning-tree vlan 10 root primary //VLAN10-70允许通过
    SW1(config)#spanning-tree vlan 80 root secondary //VLAN80-300不允许通过
    SW1(config)#router rip
    SW1(config)#version 2
    SW1(config)#no auto-summary
    SW1(config)#network 192.168.10.0 //其余IP配置如此

    5.1.2 接入层交换机配置

    因为接入层交换机的配置类似,所以我们以市场部的接入层交换机为例。具体配置如下:
    1)因为各个部门之间不能相互通信,所以要为每个部分划分不同VLAN。以财务部为例,其他配置类似:
    Switch>en //进入特权模式
    Switch#conf t //进入全局模式
    Switch(config)#hostname caiwubu //改名
    caiwubu(config)#vlan 20 //创建VLAN20
    caiwubu(config-vlan)#int r f0/2-3 //进入2-3号端口
    caiwubu(config-if)#sw mo ac
    caiwubu(config-if)#sw ac vlan 20 //把2-3号端口划分到VLAN20里面
    caiwubu(config-if)#exit //退出
    2)为每台交换机配置TRUNK链路。以财务部为例,其他配置类似:
    caiwubu(config-if)#int f0/1 //进入1号端口
    caiwubu(config-if)#sw mo tr //把1号端口设置为trunk模式
    caiwubu(config-if)#exit //退出
    caiwubu(config-if)#int f0/4 //进入4号端口
    caiwubu(config-if)#sw mo tr //把4号端口设置为trunk模式
    caiwubu(config-if)#exi //退出

    5.2 路由器配置

    1)为路由器的每个端口设置IP。
    Router>enable //进入特权模式
    Router#configure terminal //进入全局模式
    Router(config)#interface FastEthernet 0/0 //进入0号端口
    Router(config-if)#ip address 192.168.80.2 255.255.255.0 //添加ip
    Router(config-if)#no shutdown //开启端口
    3)配置ACL和NAT
    Router(config-if)#access-list 1 permit 192.168.10.0 0.0.0.255 //其余的IP配置如此

    5.3 防火墙配置

    防火墙主要分为两部分,第一部分是增加物理防火墙,就是在出口路由和互联网之间增加一台防火墙,以确保一些非法的IP和人员入侵本公司盗取公司的一些重要的资料。第二部部分就是增加一些软件防火墙,可以在路由器上设置ACL访问控制列表,避免非法人员进入。

    5.4 配置测试

    (1)测试相同部门内部之间可以互通(以JAVA部为例)。选择Java部门某一台PC其IP地址为172.18.10.2,从该PC发送Ping命令到同一子网内的另一台IP地址为172.18.20.2目的主机,结果显示可以互通。测试的前提条件是确保电脑已经配置正确的IP地址,测试结果如图5-1所示:
    在这里插入图片描述
    (2)测试不相同部门内部之间可以互通(以JAVA部为例)。选择Java部门某一台PC其IP地址为172.18.10.2,从该PC发送Ping命令到不同部门的另一台IP地址为172.18.40.2目的主机,结果显示可以互通。测试的前提条件是确保电脑已经配置正确的IP地址,测试结果如图5-2所示:
    在这里插入图片描述
    (3)测试行政部中的经理室可以访问教学部的任何一个部门(以访问JAVA部为例)。选择经理室某一台PC其IP地址为192.168.10.3,从该PC发送Ping命令到教学部的另一台IP地址为172.18.10.2目的主机,结果显示可以互通。测试的前提条件是确保电脑已经配置正确的IP地址,测试结果如图5-3所示:
    在这里插入图片描述
    (4)测试行政部中除经理室外其他部门不可以访问教学部的任何一个部门,(以访问网页设计部为例)。选择行政部中的任意一个部门的某一台PC其IP地址为192.168.20.1,从该PC发送Ping命令到教学部的另一台IP地址为172.18.20.2目的主机,结果显示不可以互通。测试的前提条件是确保电脑已经配置正确的IP地址,测试结果如图5-3所示:
    在这里插入图片描述

    6 公司网络服务

    6.1 FTP服务

    FTP服务器的主要作用是用于教学部的学生上交作业和各位培训老师上传一些可以供学生自主学习的学习资料,具体配置如下(以Windows 2007为例):
    1.基本要求:
    操作系统需求:已安装了Windows 2007操作系统;
    保证由交换机连接的局域网彼此间能够通信;
    2.具体配置步骤:
    1)创建和管理FTP服务器
    首先要创建一个FTP服务器,然后对所创建的服务器进行一些属性的设置。
    然后通过使用IE浏览器进行访问所创建的网站,以用来查看是否创建成功。
    在这里插入图片描述
    2)为了使公司员工和学员不能随便访问通过FTP所共享的信息,所以要求对每个用户在通过FTP访问时设置不同的权限,故创建Active directory隔离用户的FTP站点
    首先要把作为服务的升级计算机为域控制器
    建立OU
    在这里插入图片描述
    在AD数据库中设置用户的主目录
    公司员工:ftp1,ftproot应该被设置为c:\my ftp,fpt1 ftpdir设置为ftp1
    教学人员:ftp2,ftproot应该被设置为c:\my ftp,ftp2 ftpdir设置为ftp2
    学员: ftp3,ftproot应该被设置为c:\my ftp,ftp3 ftpdir设置为ftp3
    新建AD隔离FTP站点
    在这里插入图片描述

    6.2 Web服务

    主要用于学员、老师和公司员工上网,查一些学习资料,具体配置如下:
    1.基本要求:
    操作系统需求:已安装了Windows 2007操作系统;
    保证由交换机连接的局域网彼此间能够通信;
    IE浏览器运行正常。
    2.具体步骤:
    1)设置WEB默认站点的属性,访问默认站点;
    2)创建自己的WEB站点Test,设置测试网页内容为:Welcome to Tengfei Training Center!通过客户端访问自己创建的测试站点;
    在这里插入图片描述
    3)创建虚拟目录,使用虚拟目录存放WEB页,网页内容设置为:Welcome to Tengfei Training Center!;
    4)通过输入本公司的网址,发现可以访问本公司的页面测试结果:
    在这里插入图片描述

    6.3 Mail服务

    主要用于邮件的发送,方便老师和学员,公司员工和管理者之间的沟通,具体配置如下:
    1.基本要求:
    操作系统需求:已安装了Windows 2007操作系统;
    保证由交换机连接的局域网彼此间能够通信;
    2.具体步骤:
    1)在服务器上安装STMP、POP3、DNS。
    在这里插入图片描述
    在这里插入图片描述
    2)配置DNS和POP3服务(DNS为例)
    在这里插入图片描述
    3)配置完成后,我们可以通过使用任意学号过着公司员工的邮箱账号测试,发现可以发送邮件,即配置成功。

    7 公司网络安全问题及对策

    随着互联网的发展应用和计算机技术的不断成熟,网络安全已经是现在互联网面临的主要问题了,每时每刻世界上都有无数的黑客在攻击破坏一些网络,盗取一些重要的资料,其实网络安全的本质就是网络中信息的安全,所以提高网络安全我们可以从提高网络中的信息安全入手。为了达到这个目的,我们要首先了解一些常见的入侵手段,比如口令入侵、协议入侵、开放端口入侵、木马病毒入侵等。针对像以上这几个入侵手段,腾飞公司做了一下几个措施。
    (1)口令入侵:口令入侵主要是针对一些不设密码的主机或者文档进行入侵,以便于达到盗取一些资料为目的入侵方式,针对这种入侵,在为公司设计网络时我们采用了对公司的网关设置一些较为复杂的密码,尤其是网络管理员也就是技术部和一些重要部门的主机,同时当员工在使用电脑时提醒员工为自己工作时的电脑设置一个相对来说较复杂的密码,对一些相对来说重要的文档进行加密,防止一些商业黑客的入侵。
    (2)开放端口入侵:端口是IP的一部分,一些黑客可以利用一些开放的端口进行入侵盗取资料,所以为了避免一些非法人员以此为条件进行入侵,该公司在设计时就关闭了一些不常用的端口,同时也增加了一些物理防御设备,如防火墙等,以达到防止黑客入侵。
    (3)木马病毒入侵:这是对计算机危害最大的一种入侵方式,它可以使被入侵的计算机完全不受自己的控制,甚至可以使被入侵者的计算机陷入瘫痪状态,,所以为了避免这种攻击,在为该公司设计网络是就加入了防火墙等安全设备,并且在路由器上启用了VPN协议和ACL访问控制列表,同时也在电脑里安装了杀毒软件,以达到避免入侵的效果。
    (4)设备级安全:设备级安全是网络的第一道屏障,它最大限度的限制能够远程管理网络设备的IP地址列表等,所以本公司在必要时可以关闭部分或全部远程管理功能,同时关闭一些出差的技术人员可以管理公司网络的特权,以达到防止数据在网络传输中被监听窃取,同时对于核心网络设备,如核心层交换机和路由器,我们采用不设远程管理的IP 地址。

    结束语

    致谢

    参考文献

    1 雷震甲.《网络工程师教程》.清华大学出版社
    2章春梅.《计算机网络技术导论》.南京信息职业技术学院
    3殷玉明.《交换机与路由器配置项目式教程》.电子工业出版社
    4李建林.《局域网交换机与路由器的配置与管理》.电子工业出版社
    5高春林.《计算机组网技术与配置》.清华大学出版社
    6刘业辉.《光传输系统(中兴)组建与管理》.电子工业出版社
    7王公儒.《综合布线工程实用技术》.中国铁道出版社

    注:已在知网查重,重复率为2.1%。未经本人允许,请勿转卖。

    展开全文
  • ensp实操--企业私有网络构建运维

    千次阅读 2020-04-21 14:10:36
    企业私有网络构建运维 拓展–使用模拟器接入互联网 拓扑图 配置Cloud1 R3 [Huawei]int G 0/0/2 [Huawei-GigabitEthernet0/0/2]ip add 192.168.10.9 24 [Huawei-GigabitEthernet0/0/2]quit [Huawei]ip route-static...

    实战案例——使用模拟器构建局域网络
    1.案例目标
    (1)通过组网设计,掌握小型网络的组建、路由的设计,对小型网络系统进行分析,提出建网解决方案。
    (2)综合运用路由、VLAN的相关技术。
    (3)综合运用VLAN创建、Access和Trunk接口配置、VLAN间路由配置、DHCP地址池配置,以及动态路由配置,实现小型网络的互连互通。
    2.案例分析
    (1).架构分析
    1>需求分析
    本实验的目的在于建立小型局域网。由于公司由不同部门组成,并分布在不同地点,因此需要划分不同网络实现互联互通。设计以下网络:两个部门各使用一台交换机连接,然后连接到总交换机,再通过路由器与外网以及其他部门网络相连。为了控制网络上的广播风暴,增加网络的安全性,在交换机上需要设置VLAN,在路由器与交换机之间需要设置动态路由OSPF协议。
    2>环境要求
    配置网卡的计算机。华为eNSP模拟软件。
    (2).规划拓扑
    1>拓扑描述
    地点1包括部门1和部门2;地点2包括部门3。
    部门1网络为子网3:192.168.3.0/24,对应VLAN3。
    部门2网络为子网9:192.168.9.0/24,对应VLAN9。
    部门1、部门2的计算机分别通过交换机S1、S2接入,然后通过总交换机S3互连。
    S3连接路由器R1,R1通过R2与地点2的部门3网络子网5:10.0.5.0/24相连。
    2>拓扑图
    在这里插入图片描述
    3.案例实施
    配置各个设备
    (1).PC机
    PC1
    在这里插入图片描述
    PC2
    在这里插入图片描述
    PC3
    在这里插入图片描述
    (2).交换机
    1>S1配置

    <HUAWEI>system-view 
    [HUAWEI]sysname S1
    [S1]vlan batch 3 9 1002	
    [S1]interface GigabitEthernet 0/0/2
    [S1-GigabitEthernet0/0/2]port link-type access
    [S1-GigabitEthernet0/0/2]port default vlan 3
    [S1-GigabitEthernet0/0/2]quit
    [S1]interface GigabitEthernet 0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk
    [S1-GigabitEthernet0/0/1]port trunk allow-pass vlan 3 9 1002
    

    2>S2配置

    <Huawei>system-view
    [Huawei]sysname S2
    [S2]vlan batch 3 9 1002
    [S2]interface GigabitEthernet 0/0/2
    [S2-GigabitEthernet0/0/2]port link-type access
    [S2-GigabitEthernet0/0/2]port default vlan 9
    [S2-GigabitEthernet0/0/2]quit
    [S2]interface GigabitEthernet 0/0/1
    [S2-GigabitEthernet0/0/1]port link-type trunk
    [S2-GigabitEthernet0/0/1]port trunk allow-pass vlan 3 9 1002
    

    3>S3配置

    <Huawei>system-view
    [Huawei]sysname S3
    [S3]vlan batch 3 9 1002
    [S3]interface GigabitEthernet 0/0/2
    [S3-GigabitEthernet0/0/2]port link-type trunk
    [S3-GigabitEthernet0/0/2]port trunk allow-pass vlan 3 9 1002
    [S3-GigabitEthernet0/0/2]quit
    [S3]interface GigabitEthernet 0/0/3
    [S3-GigabitEthernet0/0/3]port link-type trunk
    [S3-GigabitEthernet0/0/3]port trunk allow-pass vlan 3 9 1002
    [S3-GigabitEthernet0/0/3]quit
    [S3]interface GigabitEthernet 0/0/1
    [S3-GigabitEthernet0/0/1]port link-type access
    [S3-GigabitEthernet0/0/1]port default vlan 1002
    [S3-GigabitEthernet0/0/1]quit
    [S3]dhcp enable
    [S3]interface Vlanif 3
    [S3-Vlanif3]ip address 192.168.3.1 24
    [S3-Vlanif3]interface Vlanif 9
    [S3-Vlanif9]ip address 192.168.9.1 24
    [S3-Vlanif9]dhcp select global
    [S3-Vlanif9]interface Vlanif 1002
    [S3-Vlanif1002]ip address 192.168.2.1 24
    [S3-Vlanif1002]quit
    [S3]ospf 1
    [S3-ospf-1]area 0
    [S3-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [S3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [S3-ospf-1-area-0.0.0.0]network 192.168.9.0 0.0.0.255
    [S3-ospf-1-area-0.0.0.0]quit
    [S3-ospf-1]quit
    [S3]ip pool vlan9
    [S3-ip-pool-vlan9]gateway-list 192.168.9.1
    [S3-ip-pool-vlan9]network 192.168.9.0 mask 255.255.255.0
    [S3-ip-pool-vlan9]lease day 3
    [S3-ip-pool-vlan9]dns-list 8.8.8.8
    

    4>S4配置

    <Huawei>system-view
    [Huawei]sysname S4
    [S4]vlan batch 105 1004
    [S4]interface GigabitEthernet 0/0/1
    [S4-GigabitEthernet0/0/1]port link-type access
    [S4-GigabitEthernet0/0/1]port default vlan 1004
    [S4-GigabitEthernet0/0/1]quit
    [S4]interface GigabitEthernet 0/0/2
    [S4-GigabitEthernet0/0/2]port link-type access
    [S4-GigabitEthernet0/0/2]port default vlan 105
    [S4-GigabitEthernet0/0/2]quit
    [S4]interface Vlanif 1004
    [S4-Vlanif1004]ip address 192.168.4.1 24
    [S4-Vlanif1004]quit
    [S4]interface Vlanif 105
    [S4-Vlanif105]ip address 10.0.5.1 24
    [S4]ospf 1
    [S4-ospf-1]area 0
    [S4-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    [S4-ospf-1-area-0.0.0.0]network 10.0.5.0 0.0.0.255
    

    (3).路由器
    5>R1配置

    <Huawei>sys
    [Huawei]sysname R1
    [R1]interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.2.2 24
    [R1-GigabitEthernet0/0/1]quit
    [R1]interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.3.2 24
    [R1-GigabitEthernet0/0/0]quit
    [R1]ospf 1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    

    6>R2配置

    <Huawei>sys
    [Huawei]sysname R2
    [R2]interface GigabitEthernet 0/0/1
    [R2-GigabitEthernet0/0/1]ip address 192.168.4.2 24
    [R2-GigabitEthernet0/0/1]quit
    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.3.1 24
    [R2-GigabitEthernet0/0/0]quit
    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    

    4.网络连通性测试
    在PC1上通过PING命令对PC2和PC3进行连通测试

    Welcome to use PC Simulator!
    
    PC>ping 192.168.9.254
    
    Ping 192.168.9.254: 32 data bytes, Press Ctrl_C to break
    From 192.168.9.254: bytes=32 seq=1 ttl=127 time=58 ms
    From 192.168.9.254: bytes=32 seq=2 ttl=127 time=61 ms
    From 192.168.9.254: bytes=32 seq=3 ttl=127 time=65 ms
    --- 192.168.9.254 ping statistics ---
      2 packet(s) transmitted
      2	packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 61/61/65 ms
    
    PC> ping 10.0.5.2
    Ping 10.0.5.2: 32 data bytes, Press Ctrl_C to break
    From 10.0.5.2: bytes=32 seq=1 ttl=127 time=421 ms
    From 10.0.5.2: bytes=32 seq=2 ttl=127 time=426 ms
    --- 10.0.5.2 ping statistics ---
      1 packet(s) transmitted
      1	packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 421/426/426 ms
    

    在PC3上通过PING命令对PC1和PC2进行连通测试

    Welcome to use PC Simulator!
    
    PC>ping 192.168.3.2
    
    Ping 192.168.3.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.3.2: bytes=32 seq=1 ttl=124 time=71 ms
    From 192.168.3.2: bytes=32 seq=2 ttl=124 time=69 ms
    From 192.168.3.2: bytes=32 seq=3 ttl=124 time=75 ms
    --- 192.168.3.2 ping statistics ---
      2 packet(s) transmitted
      2	packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 71/71/75 ms
    
    PC>ping 192.168.9.254
    
    Ping 192.168.9.254: 32 data bytes,Press Ctrl_C to break
    From 192.168.9.254: bytes=32 seq=1 ttl=124 time=75 ms
    From 192.168.9.254: bytes=32 seq=2 ttl=124 time=78 ms
    From 192.168.9.254: bytes=32 seq=3 ttl=124 time=81 ms
    --- 192.168.9.254 ping statistics ---
      2 packet(s) transmitted
      2	packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 75/80/81 ms
    

    拓展–使用模拟器接入互联网
    拓扑图
    在这里插入图片描述
    配置Cloud1
    在这里插入图片描述
    R3

    [Huawei]int G 0/0/2
    [Huawei-GigabitEthernet0/0/2]ip add 192.168.10.9 24
    [Huawei-GigabitEthernet0/0/2]quit
    [Huawei]ip route-static 0.0.0.0 0 192.168.10.1
    [Huawei]ospf 1
    [Huawei-ospf-1]default-route-advertise always cost 200 type 1
    

    物理机添加路由

    使用管理员身份运行CMD
    C:\WINDOWS\system32>route add 192.168.3.0 mask 255.255.255.0 192.168.10.9
     操作完成!
    
    C:\WINDOWS\system32>route add 10.0.5.0 mask 255.255.255.0 192.168.10.9
     操作完成!
    
    C:\WINDOWS\system32>route add 192.168.9.0 mask 255.255.255.0 192.168.10.9
    操作完成!
    

    测试连通性

    C:\WINDOWS\system32>ping 192.168.9.254
    
    正在 Ping 192.168.9.254 具有 32 字节的数据:
    请求超时。
    来自 192.168.9.254 的回复: 字节=32 时间=88ms TTL=126
    来自 192.168.9.254 的回复: 字节=32 时间=51ms TTL=126
    来自 192.168.9.254 的回复: 字节=32 时间=68ms TTL=126
    
    192.168.9.254 的 Ping 统计信息:
        数据包: 已发送 = 4,已接收 = 3,丢失 = 1 (25% 丢失),
    往返行程的估计时间(以毫秒为单位):
        最短 = 51ms,最长 = 88ms,平均 = 69ms
    
    C:\WINDOWS\system32>ping 192.168.3.2
    
    正在 Ping 192.168.3.2 具有 32 字节的数据:
    来自 192.168.3.2 的回复: 字节=32 时间=21ms TTL=254
    来自 192.168.3.2 的回复: 字节=32 时间=17ms TTL=254
    来自 192.168.3.2 的回复: 字节=32 时间=10ms TTL=254
    来自 192.168.3.2 的回复: 字节=32 时间=7ms TTL=254
    
    192.168.3.2 的 Ping 统计信息:
        数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
        最短 = 7ms,最长 = 21ms,平均 = 13ms
    
    C:\WINDOWS\system32>ping 10.0.5.2
    
    正在 Ping 10.0.5.2 具有 32 字节的数据:
    来自 10.0.5.2 的回复: 字节=32 时间=80ms TTL=125
    来自 10.0.5.2 的回复: 字节=32 时间=38ms TTL=125
    来自 10.0.5.2 的回复: 字节=32 时间=35ms TTL=125
    来自 10.0.5.2 的回复: 字节=32 时间=53ms TTL=125
    
    10.0.5.2 的 Ping 统计信息:
        数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
    往返行程的估计时间(以毫秒为单位):
        最短 = 35ms,最长 = 80ms,平均 = 51ms
    
    展开全文
  • 使用HTML5 Canvas技术,绘制清新、流畅的网络图,可用于社交网络图、拓扑图、流程图、地图等需求, JS组件封装,藏繁琐于简洁,轻松构建优雅的互联网应用与企业应用,让数据的在线可视化变得容易   下载地址:...
    一套基于HTML5的网络图组件

    使用HTML5 Canvas技术,绘制清新、流畅的网络图,可用于社交网络图、拓扑图、流程图、地图等需求, JS组件封装,藏繁琐于简洁,轻松构建优雅的互联网应用与企业应用,让数据的在线可视化变得容易

     

    下载地址http://im.gitom.com/qunee/demos

    有什么问题可以与我联系 QQ:285264911

     

    组件特点

    • 轻巧、高性能 - 支持上万图元,流畅操作
    • 矢量图形 - 支持矢量图形,无极缩放
    • 交互体验 - 漫游交互,改进交互事件、支持手持设备
    • 注重细节 - GIF动画,丰富渐变,层次控制等

    Qunee发音

    Qunee - 发音为“kjuːni”,寓意优雅轻巧,符合我们对于产品细节与用户体验的一种态度

    提供Web图形解决方案

    地图 - 地铁图、统计地图

    Qunee提供的丰富矢量图形,对于点线之类数据的展现,能得心应手得解决,可运用于地铁、管线这样的应用

    Qunee支持漫游交互、无极缩放、不限制坐标范围,这很适合地图的呈现,加上多边形丰富的样式,可用于解决地图背景、以及统计地图之类的问题

    拓扑图 - 社交网络图、网络管理图

    支持节点、连线、分组等图元类型,具有良好的层次控制,支持上万图形元素,并且流畅操作,带来轻快、高效的视觉体验,适合解决网状数据的呈现与交互问题

    其他 - 组织图、思维导图、流程图

    借助强大的树形布局器,可以解决树形结构数据的自动布局问题,可运用于组织图、思维导图等

    提供丰富的基本图形与箭头样式,支持弯曲、正交等连线类型,加上包含关系的控制,可以解决流程图之类的问题

    轻松开发

    Qunee for HTML5使用JavaScript语言进行开发,引入qunee-min.js文件,编写简单的代码,就可以开发出来网络拓扑图

    <!DOCTYPE html><html><head><title>Hello Qunee for HTML5</title><scriptsrc="http://demo.qunee.com/lib/qunee-min.js"></script><script>function init(){var graph =new Q.Graph('canvas');var hello = graph.createNode("Hello",-100,-50);
          hello.image = Q.Graphs.server;var qunee = graph.createNode("Qunee",100,50);var edge = graph.createEdge("Hello\nQunee", hello, qunee);
    
          edge.setStyle(Q.Styles.LABEL_OFFSET_Y,-10);
          edge.setStyle(Q.Styles.LABEL_POSITION, Q.Position.CENTER_TOP);
          edge.setStyle(Q.Styles.LABEL_ANCHOR_POSITION, Q.Position.CENTER_BOTTOM);
          edge.setStyle(Q.Styles.LABEL_BORDER,1);
          edge.setStyle(Q.Styles.LABEL_POINTER,true);
          edge.setStyle(Q.Styles.LABEL_PADDING,new Q.Insets(2,5));
          edge.setStyle(Q.Styles.LABEL_BACKGROUND_GRADIENT,
              Q.Gradient.LINEAR_GRADIENT_VERTICAL);}</script></head><bodyonload="init();"><divstyle="width:800px; height:500px; margin:auto;"id="canvas"/></body></html>
    为什么选择HTML5技术?

    以前富客户端应用主要通过插件技术实现,比如Adobe Flash, Microsoft Silverlight, Java Applet,都存在些问题(需要安装插件,不支持移动平台等),相比之下HTML5的优势是:

    • 不需要安装插件
    • 跨平台,支持主流浏览器和移动设备
    • w3c的国际标准

     

    随着技术的发展,主流浏览器对HTML5支持越来越完善,网页不再只是展示文字和图片,使用HTML5技术组合,可以实现更多的功能:实时通讯、本地存储、 图形绘制,借助Canvas,SVG以及CSS3技术, 可以实现丰富的图形界面和动画

    有了这些技术的支撑,网页中呈现专业的图形组件成为了可能,Qunee for HTML5选择HTML5技术,将这种可能性变为现实, 降低了技术门槛,使得高效、丰富、动态的图形展示变的容易。

     

    展开全文
  • 大型公司网络构建

    2020-03-07 20:16:13
    模拟的是一个总公司与分公司,...拓扑图: 因为我是直接把命令打在文本里然后复制到控制台的,我就直接复制下来。 总公司配置: 左1接入交换机: hostname yh-sscb no ip domain lookup vtp domain yehao.com vtp ...
  • 实验总体拓扑图: 此实验使用ENSP,以及7台路由器模拟器,构建深圳与成都各部之间互通与不同,走什么、哪条路由?以及路径优劣, 选路问题, sham-link 技术使用。 本实验理论基础: MPLS 技术在骨干的宽带 IP 网络...
  • 中小型企业网络设计

    2008-05-08 10:44:59
    具体设计实施办法 设计1:XX网络构建方案设计;...要求:网络拓扑结构; 动态分配IP地址; 每个员工在Web服务器上均可发布自己的主页; 提供员工自己维护及管理各自主页的机制。 设计3:企业内部的DNS...
  • 针对某消费品公司的矩阵制企业项目小组结构进行了研究,以职能部门的人员为节点,以项目小组作为超边,构建基于超图的矩阵制企业项目小组超网络拓扑结构;建立了节点具有竞争力的矩阵制企业项目小组的非均齐超网络...
  • 这是一个比较完善的资料,可以让你学会,路由器协议的一些基本的配置,里面有标准的课程设计模板,还有构建拓扑图,以及一些协议的配置方法
  • 企业构建局域网,考虑到企业的很多业务依托于网络,要求企业内部用户能够髙速的访问企业服务器...问题:1.1 在该网络拓扑图中,请根据用户需求和设计要求,指出至少三个不合理之处,并简要说明理由。 问题:1.2...
  • 自己的课程报告,是关于小型企业网络课程设计,主要几个部门,然后构建局域网,主要有4个部门,办公室,资源部,市场部等,本文是基于一个课程的网络互联课程设计,根据实践环境设计一个小型企业内部的网络组建。...
  • eNSP搭建数据中心网络

    2020-04-23 23:11:42
    eNSP企业私有网络构建 eNSP企业私有网络添加防火墙 eNSP搭建无线网络 一、拓扑图以及cloud的配置 拓扑图 cloud配置 二、配置FW1 [SRG]sysname FW1 [FW1]interface g [FW1]interface GigabitEthernet 0/0/0 [FW1-...
  • 网络工程课程设计

    2012-05-16 20:39:17
    用于网络工程课程设计参考,内含构建企业网需求说明,网络规划与设计,设备选型,详细拓扑图和配置命令
  • 此文是利用NLB(网络负载平衡)来实现...实验需要六台机器,拓扑图如下: 其中客户机为真机,其余五台均为虚拟机,其中FTP1、FTP2为DFS机器,如下图: 1、 首先我们先搭建域,把FTP1、FTP2、NLB1、NLB2加入...
  • 网络拓扑图: 实验环境描述: 某公司因企业范围日益扩大,最近订购了一套基于B/S结构的电子商务系统,在证使部署之前,要求对现有的httpd服务器进行改造,首先需要增加MySQL数据库服务 需求描述: 1. 编译安装MySQL...
  • 基于消费者网络的创新扩散模型表明, 各图书产品面对消费者网络拓扑结构的非一致性, 揭示各产品消费者群体创新采纳的学习影响机制差异性, 研究结果有益于深入了解创新产品扩散的内部规律及制定针对性的营销策略.
  • 2、概要设计:画出网络拓扑结构,说明报告中主要功能的实现过程(VLAN 划分、子网规划、WWW服务器、FTP服务器、MAIL服务器等。 3、详细设计:交换机和路由器配置文件的清单。 4、调试分析:路由、交换之间采用...
  • 帮助广大ICT从业者和客户快速熟悉华为数通系列产品,了解并掌握相关产品的操作和配置、提升对企业ICT网络的规划、建设、运维能力,从而帮助企业构建更高效,更优质的企业ICT网络。2、图形化操作支持拓扑创建、修改、...
  • 4.2.1 bacula的几种网络备份拓扑 4.2.2 编译与安装bacula 4.2.3 初始化MySQL数据库 4.3 配置一个bacula备份系统 4.3.1 配置bacula的Console端 4.3.2 配置bacula的Director端 4.3.3 配置bacula的SD ...
  • 通过 eNSP 模拟中小型企业网并在网络设备上采用 VLAN 虚拟局域网、DHCP协议自动分配地址,以及高级ACL和PPP协议,使构建企业网能满足业务需求,部门之间的传递的安全性。 注:以下案例仅供参考。 一、需求分析 ...
  • 实验环境: 按如图1所示拓扑图构建域环境,域名为ittongluren.com。其中域控制器主机名为DC_Server。将主机ISA_Server加入到域中,成为域成员服务器,然后增加第2块网卡,连接内部网络的网卡标识为LAN,连接外部...
  • 2.1方案拓扑图 11 2.2 基本架构 11 2.3 系统说明 12 2.4 系统特点 12 2.5 系统软硬件配置 14 第三章 离线部分—数据备份系统说明 15 3.1为什么要备份 15 3.2数据备份的原则 15 3.3数据备份的策略 17 3.3.1备份系统...
  • 项目10 DNS服务器配置 课题引入--项目背景 某企业有一个局域网/24网络拓扑如下图所示该企业中已经有自己的网页员工希望通过域名来...网络拓扑图 项目配置需求 现要求在企业内部构建一台 DNS服务器为局域网中的计算机
  • 使用HTML5 Canvas技术,绘制清新、流畅的网络图,可用于社交网络图、拓扑图、流程图、地图等需求, JS组件封装,藏繁琐于简洁,轻松构建优雅的互联网应用与企业应用,让数据的在线可视化变得容易。
  • 华为网络拓扑模拟系统,学习华为认证必要的路由交换模拟软件。 eNSP是图形化网络仿真平台,该平台通过对真实网络设备的仿真模拟,帮助广大ICT从业者和客户快速熟悉华为数通系列产品,了解并掌握相关产品的操作和配置...

空空如也

空空如也

1 2 3
收藏数 45
精华内容 18
关键字:

企业网络构建网络拓扑图