精华内容
下载资源
问答
  • 企业网网络拓扑图
    千次阅读
    2020-08-05 20:34:34
     下图为2020年8月5日下午课上所画的企业网络拓扑图。图右模拟场景为一中型企业,主要网络设备有pc端计算机、服务器、无线设备、接入层交换机、汇聚层交换机、以及核心路由器。其中企业pc端用户数百个,由三台接入层交换机接入进行数据接入,再用两台汇聚层交换机进行数据的汇聚,最后由两台核心级路由器进行快速的转发。其优点在于在其核心层以及汇聚层分别使用两台交换机和路由器,使其网络结构更加安全,冗余;缺点在于其成本较高。图左为一小型企业网络拓扑图,由一台交换机进行接入,再使用一台路由器进行网络接入。其优点在于结构简单,易维护,成本低,缺点为单点故障,安全性低。
    

    在这里插入图片描述

    更多相关内容
  • 各种企业单位网络拓扑图
  • 网络中小企业网络组建局域网组建网络组建与规划网络结构拓扑图1.doc.pdf
  • 小型企业网拓扑图及详细配置.rar,小型企业网拓扑图及详细配置.doc
  • 1.三层交换机架构,内网、外、B校区(子公司)三个区域 2.网络划分多个vlan 3交换机之间配置trunk,两台核心交换机链路捆绑 4.在两台核心交换机上配置MSTP-VRRP(多生成树协议) 5.部分主体交换机配置了OSPF协议 6...
  • 12-20人规模企业网设计 ensp网络拓扑图工程文件 NAT、PPPoE、IP ROUTE-STATIC 详细配置教程 https://www.orcy.net.cn/2371.html
  • 大中型网络架构,各种拓扑图,仅供参考
  • 局域网设计方案网络拓扑结构设计思路拓扑结构
  • 企业网络拓扑设计

    2019-01-08 17:00:09
    其中包含详细的网络结构设计和拓扑图PKT文件,详细的源代码。
  • 创建地址池 租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5 87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文 SW1 u t m system-view sys SW1 dhcp ...

    84d9800d5484c07f7088f817ab9ce0e2.png

    单臂路由 有缺陷 三层交换机

    1.创建vlan 原则:所有交换机创建一模一样的vlan

    2.把接口类型做好 原则:只在交换机的接口配置,交换机之间一定是trunk,交换机与 其他设备一定是aceess(单臂路由和无线设备除外)

    3.做MSTP 原则:所有MSTP配置必须一模一样(优先级的命令除外)

    4.网关

    5.路由

    6.DHCP 全局:网关和DHCP服务器是同一台设备

    网关处开全局模式,创建地址池

    接口:几乎不用

    中继:网关和DHCP服务器不是同一台设备且不是同一个网段

    中继:网关在哪里,哪里做中继命令(2条命令)

    服务器:服务器IP地指处开全局,创建地址池

    租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5

    87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文

    SW1

    u t m

    system-view

    sys SW1

    dhcp enable

    vlan batch 6 10 20 30 40

    port-group group-member g0/0/1 to g0/0/5

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    quit

    stp instance 1 priority 0

    stp instance 2 priority 4096

    interface vlanif 10

    ip add 192.168.10.254 24

    dhcp select relay

    dhcp relay server-ip 192.168.6.2

    interface vlanif 20

    ip add 192.168.20.254 24

    dhcp select relay

    dhcp relay server-ip 192.168.6.2

    return

    SW2

    u t m

    system-view

    dhcp enable

    sys SW2

    vlan batch 6 10 20 30 40

    port-group group-member g0/0/1 to g0/0/5

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    int g0/0/6

    port link-type access

    port default vlan 6

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    quit

    stp instance 1 priority 4096

    stp instance 2 priority 0

    interface vlanif 30

    ip add 192.168.30.254 24

    dhcp select relay

    dhcp relay server-ip 192.168.6.2

    interface vlanif 40

    ip add 192.168.40.254 24

    dhcp select relay

    dhcp relay server-ip 192.168.6.2

    interface vlanif 6

    ip add 192.168.6.1 24

    return

    SW3

    u t m

    system-view

    sys SW3

    vlan batch 6 10 20 30 40

    port-group group-member e0/0/1 e0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    int e0/0/3

    port link-type access

    port default vlan 10

    int e0/0/4

    port link-type access

    port default vlan 20

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    SW4

    u t m

    system-view

    sys SW4

    vlan batch 6 10 20 30 40

    port-group group-member e0/0/1 e0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    int e0/0/3

    port link-type access

    port default vlan 10

    int e0/0/4

    port link-type access

    port default vlan 30

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    SW5

    u t m

    system-view

    sys SW5

    vlan batch 6 10 20 30 40

    port-group group-member e0/0/1 e0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    int e0/0/3

    port link-type access

    port default vlan 20

    int e0/0/4

    port link-type access

    port default vlan 40

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    SW6

    u t m

    system-view

    sys SW6

    vlan batch 6 10 20 30 40

    port-group group-member e0/0/1 e0/0/2

    port link-type trunk

    port trunk allow-pass vlan all

    quit

    int e0/0/3

    port link-type access

    port default vlan 40

    int e0/0/4

    port link-type access

    port default vlan 30

    quit

    stp region-configuration

    region-name 1

    instance 1 vlan 10 20

    instance 2 vlan 30 40

    active region-configuration

    DHCP

    u t m

    sys

    sys DHCP

    dhcp enable

    interface g0/0/0

    ip add 192.168.6.2 24

    dhcp select global

    quit

    ip pool p10

    network 192.168.10.0 mask 24

    gateway-list 192.168.10.254

    ip pool p20

    network 192.168.20.0 mask 24

    gateway-list 192.168.20.254

    ip pool p30

    network 192.168.30.0 mask 24

    gateway-list 192.168.30.254

    ip pool p40

    network 192.168.40.0 mask 24

    gateway-list 192.168.40.254

    quit

    ip route-static 192.168.0.0 16 192.168.6.1

    return

    展开全文
  • 大型企业网拓扑图

    2013-10-06 13:11:51
    涵盖网络整体拓扑图和协议,可以帮助学习网络协议以及刚刚接触网络拓扑结构的同学更好的了解
  • 文章首先分析了煤炭企业对数据中心的功能需求,对比了云计算在煤炭企业数据中心中的应用优势,设计了基于云计算的煤炭企业数据中心的总体方案,然后进行网络拓扑设计,最后提出了基于云计算的煤炭企业数据中心的实施对策...
  • 大中企业的三层交换机+二层交换机+路由,一用一备,可以联接两条外线,划分多个VLAN,隔离广播域,同一VLAN的主机可以PING通,不同VLAN间主机PING不通
  • 网络拓扑图企业网络设计基本流程

    万次阅读 多人点赞 2020-07-20 23:37:54
    网络拓扑图企业网络设计基本流程认识网络常见的路由协议分类:常见路由协议类型:网络层次结构:TCP/IP协议网络拓扑图企业网络设计基本流程网络设计基本原则网络拓扑设计原则网络设计的方法和思路网络架构安全域和...

    认识网络

    构建网络的目的:就是为了相互之间能够通信,而通信的目的就是为了传达信息。(信息传达和信息接收的安全性。)
    企业网络的目的:是作为企业业务的支撑平台,是企业的信息中枢。

    • 网络:被称为计算机网络,它是计算机技术和通信技术相结合的产物。
    • 节点:这里的节点就是一个个的机房以及机房里面的设备(路由器、交换机、防火墙、PC…)
    • 链路:就是有线和无线,有线:网络、光纤、电缆等等…

    网络中常见的协议:

    • VLAN技术:虚拟局域网;
    • STP技术:生成树协议;
    • VRRP技术:虚拟路由冗余协议;
    • VPN:虚拟专用网络。
      在这里插入图片描述

    常见的路由协议分类:

    • 静态:设置好路由器和主机并将路由信息固定的一种方法。
    • 动态:路由协议在进行过程中自动的设置路由控制信息的一种方法

    静态路由通常手工配置,网络发生故障时需要管理员手动修改,动态路由协议可以在由其他路可达目的主机的前题下自动学习路由,绕过故障节点。
    在这里插入图片描述

    常见路由协议类型:

    一、内部网关协议:
    内部网关协议(IGP:Interior Gateway Protocol),适用于单个ISP的统一路由协议的运行,一般由一个ISP运营的网络位于一个AS(自治系统)内,有统一的AS number(自治系统号),用来处理内部路由。


    RIP、IGRP(Cisco私有协议)、EIGRP(Cisco私有协议)、OSPF、IS-IS等都是内部网关协议。


    1、RIP(Routing Information Protocol):路由信息协议。
    是一种比较简单的内部网关协议,主要用于规模较小的网络,比如校园网以及结构较简单的地区性网络。对于更为复杂的环境和大型网络,一般不使用RIP。
    RIP是一种基于距离矢量(Distance-Vector)算法的协议,它通过UDP报文进行路由信息的交换,使用的端口号为520。其使用跳数来衡量到达目的地址的距离,为了限制收敛时间,RIP规定度量值(该值等于从本网络到达目的网络间的路由器数量)为0到15之间的整数,大于等于16的跳数将会定义为网络或主机不可达,因此RIP不适合大型网络。
    RIP有两个版本:RIP V1(有类别路由协议)和RIP V2(无分类路由协议)。


    2、IGRP(Interior Gateway Routing Protool):内部网关路由协议。
    属于Cisco的私有协议,最大跳数默认为100,现已被Cisco独立开发的EIGRP协议取代。


    3、OSPF(Open Shortest Path First):开放式最短路径优先协议。
    属于链路状态路由协议,OSPF提出了“区域(area)”的概念,每个区域中所有路由器维护着一个相同的链路状态数据库 (LSDB),其使用链路状态数据库,通过最短生成树算法(SPF算法)计算得到路由表,因此其收敛速度较快。目前OSPF协议在各种网络中广泛部署,目前针对IPv4协议使用的是OSPF Version 2(RFC2328);针对IPv6协议使用OSPF Version 3(RFC2740)。


    4、IS-IS(Intermediate System-to-Intermediate System):中间系统到中间系统路由协议。
    属于链路状态路由协议。与OSPF协议相似,其使用最短路径优先SPF(Shortest Path First)算法进行路由计算。

    二、域间路由协议
    BGP(Border Gateway Protocol):边界网关协议。
    为了维护各个ISP的独立利益,标准化组织制定了ISP间的路由协议BGP,其用来处理各ISP之间的路由传递。
    与内部网关协议不同的是,其不在于发现和计算路由,而在于控制路由的传播和选择最佳路由。

    网络层次结构:

    传统的网络层次结构是OSI七层模型,但在现实中采用的是TCP/IP协议。
    (一)OSI七层模型
    (1)物理层
    设备之间原始数据传输,数据格式比特流。
    (2)数据链路层
    将原始比特流转换成逻辑传输数据,mac地址寻址,数据格式帧。
    (3)网络层
    最复杂的一层,通信子网最高层。通过路由算法提供最佳传输路径。数据格式IP数据包。
    数据链路层解决同一网络节点间数据传输,网络层解决不同子网间通信。
    (4)传输层
    拆分数据包,提供端对端不同主机用户进程间传输数据,提供可靠或不可靠传输及流量控制,是连接通信子网和资源子网的桥梁。数据格式TCP数据包。
    (5)会话层
    不同机器用户间建立或解除会话关系。
    (6)表示层
    数据的表示方式(格式处理及编码转换)及特定功能实现(加解密、解压缩等)。
    (7)应用层
    向用户提供服务,完成用户在网络上想完成的工作。如上网、发邮件、下载ftp等。

    TCP/IP协议

    (1)链路层
    包括物理层和数据链路层链路层是通过mac地址传输数据的。
    (2)网络层
    包括多种协议。
    IP协议:通过路由选择将数据封装后交给链路层。
    ICMP协议:用于主机和路由器直接传递控制消息,常用的ping就是用这个协议。
    ARP协议:是正向地址解析协议,通过IP查找mac地址。
    RARP协议:是反向地址解析协议,通过mac地址查找IP。
    (3)传输层
    TCP协议:传输控制协议,面向连接的、可靠的、基于IP的传输层协议。
    UDP协议:用户数据报协议,提供面向事务的简单不可靠信息传送协议。
    (4)应用层
    FTP协议:文件传输协议,用于文件的上传下载。
    Telnet协议:用户远程登录服务。
    DNS协议:域名解析协议,提供域名到IP的解析。
    SMTP协议:简单的邮件传送协议,用于控制信件的发送中转。
    NFS协议:网络文件系统,用于不同主机间文件共享。
    HTTP协议:超文本传输协议,用于实现互联网访问功能。

    模型结构:

    在这里插入图片描述

    网络拓扑图

    • 拓扑简单的的说就是几何结构,是指网络中各个站点相互连接的形式,主要有总线型拓扑、星型拓扑、环形拓扑以及混合型拓扑。

    网络拓扑结构类型:

    1. 总线拓扑
      总线拓扑结构是将网络中的所有设备通过相应的硬件接口直接连接到公共总线上,结点之间按广播方式通信,一个结点发出的信息,总线上的其它结点均可“收听”到。
      优点:结构简单、布线容易、可靠性较高,易于扩充,是局域网常采用的拓扑结构。
      缺点:所有的数据都需经过总线传送,总线成为整个网络的瓶颈;出现故障诊断较为困难。最著名的总线拓扑结构是以太网(Ethernet)。
      在这里插入图片描述

    1. 星型拓扑
      每个结点都由一条单独的通信线路与中心结点连结。
      优点:结构简单、容易实现、便于管理,连接点的故障容易监测和排除。
      缺点:中心结点是全网络的可靠瓶颈,中心结点出现故障会导致网络的瘫痪。
      在这里插入图片描述

    3.环形拓扑
    各结点通过通信线路组成闭合回路,环中数据只能单向传输。
    优点:结构简单、容易实现,适合使用光纤,传输距离远,传输延迟确定。
    缺点:环网中的每个结点均成为网络可靠性的瓶颈,任意结点出现故障都会造成网络瘫痪,另外故障诊断也较困难。最著名的环形拓扑结构网络是令牌环网(Token Ring)
    在这里插入图片描述


    1. 树型拓扑
      是一种层次结构,结点按层次连结,信息交换主要在上下结点之间进行,相邻结点或同层结点之间一般不进行数据交换。
      优点:连结简单,维护方便,适用于汇集信息的应用要求。
      缺点:资源共享能力较低,可靠性不高,任何一个工作站或链路的故障都会影响整个网络的运行。
      在这里插入图片描述

    5.网状拓扑
    又称作无规则结构,结点之间的联结是任意的,没有规律。
    优点:系统可靠性高,比较容易扩展,但是结构复杂,每一结点都与多点进行连结,因此必须采用路由算法和流量控制方法。目前广域网基本上采用网状拓扑结构。
    缺点:由于结点也多个结点连接,故结点的路由选择由选择和流量控制难度大,管理软件复杂,硬件成本高。
    在这里插入图片描述
    广域网与局域网所使用的网络拓扑结构有所不同。广域网多采用分布式或树型结构,局域网常用总线型、环型、星型或树型结构

    企业网络设计基本流程

    网络设计基本原则

    网络设计的基本原则
    可靠性:要求网络在发生一定的故障时,仍然能够保证承载的业务不中断
    可扩展性:要求网络能够支持不断增加的业务量。
    可运营性:保证网络的运行和维护
    可管理性:要求网络提供标准的管理手段,便于监控和维护
    成本问题:综合考虑,选择性价比高的网络设计方案。

    网络拓扑设计原则

    在这里插入图片描述

    模块化设计原则:根据所承载的功能区域来划分不同的模块;
    层次化设计原则:根据企业需求设计网络,选用二层,三层网络模型;
    性价比:
    高性能:
    可靠性:
    安全性:

    网络设计的方法和思路

    • 模块化的设计方法、层次化的设计方法

    层次化设计的优点:
    节约成本、容易理解、有利于模块化、有利于故障隔离;
    模块化设计优点:
    将一个企业网络按照功能的不同,分为了不同的模块,不同的模块有不同的需求和特点;
    每一个模块相对独立,可以单独构建这个模块里面需要的一些结构,模块之间相互没有影响;
    便于扩容、管理,不同模块有不同的安全策略;在这里插入图片描述
    DMZ:非军事区域(官方称呼),互联网服务区或者互联网隔离区(民间称呼);


    模块的安全等级:
    安全等级由低到高:
    陌生访客–>分支机构–>DMZ–>数据中心/服务器群–>管理中心;
    分支机构一般有固定的地址;
    管理中心存储着高权限的账号,一旦被入侵,对整个网络危害最大;

    • 自上而下的设计思路和自下而上的设计思路
      在这里插入图片描述

    • 根据场景设计合适的方案
      在这里插入图片描述

    网络架构

    • 三层网络架构:接入层–>汇聚层–>核心层;
      适用场景–通常用于大型网络的构建,需要通过IP路由实现跨网段的通讯;

    • 二层网络架构:接入层–>汇聚层或者核心层;
      它的组网能力是非常有限的,一般用于中小型局域网;

    一般企业网络使用三层网络结构:

    • 接入层:终端的接入、访问控制;
    • 汇聚层:路由汇聚、流量收敛;
    • 核心层:高速数据转发、要求高可靠性。

    安全域和边界:

    企业网络的经典结构就是基于安全域的网络结构,一般包括企业数据中心,企业办公内网,DMZ区,广域网和Internet几个部分。

    企业网络各个区域之间通信受到限制,区域内部通信多不进行限制。

    为了保障企业的信息安全,我们应该从哪几个方面入手?

    1、终端计算机

    2、互联网出入口

    3、广域网出入口

    4、公司对外发布服务的DMZ服务器

    5、VPN和类似远程连接设备。

    上述五个方面,基本涵盖了公司网络边界的几个方面。

    对公司网络边界进行防护,仅仅是做好公司信息安全防护工作的第一步。

    那么接下来我们应该考虑什么呢?

    当然是如果上述五个方面被黑客攻陷了,那么我们还拿什么进行防护?

    这就涉及到了黑客攻击的几个步骤,黑客提权或者拿到设备权限之后,第一件事就是想知道我们的内网是什么样子的。

    那么,他们一定会进行内网扫描。而网络扫描这种事情,又是一种特征非常明显的网络攻击行为,非常易于识别。

    这就要求我们企业安全管理人员要重点关注内网扫描,做好被攻击后的进一步防护工作。

    由于上述5个方面易于被黑客攻陷,易于产生信息安全问题,那么我们就不能让这些区域可直接访问我们的核心资源。因此,需要进行安全域划分。同时,我们也要在各个高风险安全域的核心交换机上部署IDS,做好网络安全监控,并且在安全域出入口处部署防火墙,针对IDS产生的报警及时切断相关网络访问路径,保障损失的最小化。

    于是,企业网络安全的基本中的基本要求就是根据面临的风险,划分安全域,在安全域之间部署防火墙,在每个安全域内部署IDS。这也是我个人理解的网络安全域划分的本质安全需要。

    设计流程

    在这里插入图片描述

    • 对于小企业来说,一般参照到IP连通这个步骤。
    • 大型企业基本上可以完全参照这个流程来。

    1 . 规划
    组织策略:考虑公司的组织架构,就是公司有哪些部门。

    • 业务策略:就是公司当前的业务以及公司未来需要发展的业务。比如教育行业,物流行业等等。
    • 财务决策:公司的财务情况,能拿多少钱出来,预算是多少。

    2 . 简要的网络设计方案。

    • 设计:根据业务需求客户需要规划出网络拓扑图。
    • 需求分析:就是根据组织策略,来考虑不同部门的网络配置情况。
    • 项目计划:考虑项目进度(开始时间、完成时间)、成本多少、质量达到什么标准。
    • 设备选购:需要购买哪些设备。CPU 内存,吞吐量够不够,支持哪些协议,带机数量不同的接入,他们的流量是不一样的。

    3 . 详细设计的网络方案

    • 满足企业用户现阶段技术和业务上的需求。

    4 . 实施:根据需求规划网络

    • 新建网络:根据详细设计方案,直接进行落实。
    • 主要点:验证/测试整个网络是否满足企业在业务和技术上需求。
    • 对现有网络的改造:割接

    5 . 运营:

    • 保障企业网络业务能够持续、健康的运作。
    • 主要是对设备/系统运行进行主动监控。
    • CPU 内存 带宽 链路带宽比例。

    这些指标达到一定的预警范围,我们就需要对它进行处理(80-85%)。
    考虑是否进行扩容,
    可用性、可靠性、安全性

    6 . 提升:

    • 主要是围绕规划中的组织策略来的,针对的是企业网络在运营过程中遇到的问题。

    为什么要分析用户需求

    用户需求:即企业需求(这里的用户指的就是企业);

    IT应用:实际上就是将给我们的业务需求转换成我们的技术需求。(主要是由架构师和售前做的);

    如何分析用户需求:

    1. 识别网络现状:
      通过查看现有网络的文档;
      通过咨询相关岗位的负责人;
      通过网络监听;
      通过流量分析;
    2. 定义组织目标:
      提升客户满意度;
      扩展业务类型,增加服务项目;
      增强竞争力;
      削减开支;
    3. 组织限制:
      政策、预算、人力资源、技术资源、时间安排等客观因素;
    4. 定义技术目标:
      扩大网络容量;
      简化网络管理;
      提升网络安全;
      增强网络可靠性;
    5. 定义技术限制:
      设备限制,设备能否达到技术要求,
    展开全文
  • 画出一个简单的网络拓扑图,该网络包含10台客户机,一台共享打印机,两台文件服务器, (1) 该网络使用总线型结构(2)使用星型
  • 练习华为大型公司网络构建拓扑图

    千次阅读 2022-03-21 15:18:21
    此次练习的网络拓扑图,用于自己做笔记。 配置思路: 从下到上 先配置PC1-PC4、服务器的IP 地址、子网掩码、网关。 创建所需vlan(所有交换机配置相同) 配置链路状态(trunk、access)、加入所属vlan 配置各...

    转载于:https://blog.51cto.com/13555524/2065007

    此次练习的网络拓扑图,用于自己做笔记。

    配置思路:

    1. 从下到上
    2. 先配置PC1-PC4、服务器的IP 地址、子网掩码、网关。
    3. 创建所需vlan(所有交换机配置相同)
    4. 配置链路状态(trunk、access)、加入所属vlan
    5. 配置各端口IP地址
    6. 配置VRRP(这里是三个网关相互冗余)
    7. 配置动态路由(ospf)把R1-R4 、SW7设置为骨干区域

    这是我大体思路。接下来是配置

    1*首先配置各个PC和服务器的IP地址等。

    PC1地址:192.168.10.1/24 网关:192.168.10.254

    PC2地址:192.168.20.1/24 网关:192.168.20.254

    PC3地址:192.168.10.2/24 网关:192.168.10.254

    PC4地址:192.168.20.2/24 网关:192.168.20.254

    服务器地址:192.168.70.1/24 网关:192.168.70.254

    如图:

    其它同理

    2*在SW1-SW7上全部创建vlan10、vlan20

    [SW1]vlan batch 10 20

    其它同理

    3*配置链路状态(trunk、access)、加入所属vlan

    通常交换机与交换机之间用trunk,交换机与非交换机之间用access

    先配置SW1:

    [SW1]port-group group-member e0/0/13 e0/0/11
    [SW1-port-group] port link-type trunk
    [SW1-port-group] port trunk allow-pass vlan all

    [SW1]int e0/0/1 
    [SW1-Ethernet0/0/1]port link-type access 
    [SW1-Ethernet0/0/1]port default vlan 10

     SW2:

    [SW2]port-group group-member e0/0/11 e0/0/14
    [SW2-port-group] port link-type trunk
    [SW2-port-group] port trunk allow-pass vlan all

    [SW2]int e0/0/1 
    [SW2-Ethernet0/0/1]port link-type access 
    [SW2-Ethernet0/0/1]port default vlan 20

    SW3:

    [SW3]port-group group-member e0/0/13 e0/0/11
    [SW3-port-group] port link-type trunk
    [SW3-port-group] port trunk allow-pass vlan all

    [SW3]int e0/0/1 
    [SW3-Ethernet0/0/1]port link-type access 
    [SW3-Ethernet0/0/1]port default vlan 10

    SW4:

    [SW4]port-group group-member e0/0/11 e0/0/14
    [SW4-port-group] port link-type trunk
    [SW4-port-group] port trunk allow-pass vlan all

    [SW4]int e0/0/1 
    [SW4-Ethernet0/0/1]port link-type access 
    [SW4-Ethernet0/0/1]port default vlan 20

    SW5:

    [SW5]port-group group-member g0/0/12 to g0/0/14   
    [SW5-port-group]port link-type trunk 
    [SW5-port-group]port trunk allow-pass vlan all

     

     

    [SW5]port-group group-member g0/0/1 to g0/0/3
    [SW5-port-group]port link-type access
    [SW5-port-group]port default vlan 10

     SW6:

    [SW6]port-group group-member g0/0/12 to g0/0/14   
    [SW6-port-group]port link-type trunk 
    [SW6-port-group]port trunk allow-pass vlan all

    [SW6]port-group group-member g0/0/1 to g0/0/3
    [SW6-port-group]port link-type access
    [SW6-port-group]port default vlan 20

    SW1-SW7创建vlan30 40 50 60 70:

    [SW1]vlan batch 30 40 50 60 70(其它同理)

    SW7:

    [SW7]int e0/0/1
    [SW7-Ethernet0/0/1]port link-type access
    [SW7-Ethernet0/0/1]port default vlan 30

    [SW7]int e0/0/2
    [SW7-Ethernet0/0/2]port link-type access
    [SW7-Ethernet0/0/2]port default vlan 40

    [SW7]int e0/0/3
    [SW7-Ethernet0/0/3]port link-type access
    [SW7-Ethernet0/0/3]port default vlan 50

    [SW7]int e0/0/4
    [SW7-Ethernet0/0/4]port link-type access
    [SW7-Ethernet0/0/4]port default vlan 60

    4*配置各端口IP地址

    R1:

    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.10.253 24

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.20.252 24

    [R1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip address 192.168.30.1 24

    R2:

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.10.251 24

    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 192.168.20.251 24

    [R2]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip address 192.168.40.1 24

    R3:

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip address 192.168.10.252 24

    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip address 192.168.20.253 24

    [R3]int g0/0/2
    [R3-GigabitEthernet0/0/2]ip address 192.168.50.1 24

    SW7:

    [SW7]int Vlanif 30
    [SW7-Vlanif30]ip address 192.168.30.2 24

    [SW7]int Vlanif 40
    [SW7-Vlanif40]ip address 192.168.40.2 24

    [SW7]int Vlanif 50
    [SW7-Vlanif50]ip address 192.168.50.2 24

    [SW7]int Vlanif 60
    [SW7-Vlanif60]ip address 192.168.60.2 24

    R4:

    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip address 192.168.70.254 24

    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip address 192.168.60.1 24

    5*配置VRRP(虚拟网关)

    R1:

    [R1]interface GigabitEthernet0/0/0
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254    //指定虚拟网关为192.168.10.254
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 priority 150  //设置优先级150优先级越大越好

    [R1]interface GigabitEthernet0/0/1
    [R1-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254    //指定虚拟网关为192.168.20.254
    [R1-GigabitEthernet0/0/1]vrrp vrid 2 priority 130  //设置优先级130优先级越大越好

    R2:

    [R2]interface GigabitEthernet0/0/0
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254   
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 priority 110  

    [R2]interface GigabitEthernet0/0/1
    [R2-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254   
    [R2-GigabitEthernet0/0/1]vrrp vrid 2 priority 110  

    R3:

    [R3]interface GigabitEthernet0/0/0
    [R3-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254   
    [R3-GigabitEthernet0/0/0]vrrp vrid 1 priority 130  

    [R3]interface GigabitEthernet0/0/1
    [R3-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254   
    [R3-GigabitEthernet0/0/1]vrrp vrid 2 priority 150  

    此时查看下Master选举情况

    R1:

    [R1]dis vrrp brief 

     R2:

    [R2]dis vrrp brief 

    R3:

    [R3]dis vrrp brief 

     7*配置动态路由(ospf)把R1-R4 、SW7设置为骨干区域

    R1:

    [R1]ospf 1
    [R1-ospf-1]area 0 
    [R1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R1-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R1-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255 

    R2:

    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R2-ospf-1-area-0.0.0.0]network 192.168.40.0 0.0.0.255 

    R3:

    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R3-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R3-ospf-1-area-0.0.0.0]network 192.168.50.0 0.0.0.255

    R4:

    [R4]ospf 1
    [R4-ospf-1]area 0
    [R4-ospf-1-area-0.0.0.0]network 192.168.60.0 0.0.0.255 
    [R4-ospf-1-area-0.0.0.0]network 192.168.70.0 0.0.0.255 

    SW7:

    [SW7]ospf 1  
    [SW7-ospf-1]area 0
    [SW7-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.40.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.50.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.60.0 0.0.0.255

    此时全网互通!

     

     

    展开全文
  • 网络拓扑图制作工具

    2014-02-13 14:42:20
    一款流程图、网络图绘制软件,新颖小巧,功能强大,可以很方便的绘制各种专业的业务流程图,程序流程图,数据流程图,网络拓扑图等。它在设计时采用全拖曳式操作,并提供各种图形模板库并结合实例模板库,最大限度的...
  • 认识网络、几种常用的网络拓扑图

    万次阅读 多人点赞 2020-07-20 20:11:35
    交换协议: VLAN技术:虚拟局域网 STP技术:生成树协议 VRRP技术:虚拟路由冗余协议 ...网络:被称为计算机网络,它是计算机技术和通信技术相结合的产物。 节点:这里的节点就是一个个的机房以及机房里面的
  • 要搞懂网络安全等级保护信息安全技术体系设计之网络架构设计与安全防护设计,弄懂本设计集文档中的253张拓扑设计就够了。内含通用整体安全技术架构设计、云平台安全架构设计、物联网安全架构设计、工控系统等保安全...
  • 企业网络建设拓扑

    千次阅读 2019-09-24 10:42:56
    1.通过实验了解企业网络建设拓扑方案 2.加深熟悉在建设中运用到的网络协议 3.锻炼自己的排错能力 二、实验器材 公司内部: 1.接入层:二层交换机x4 2.汇聚层:三层交换机x2 3.核心层:三层交换机x2 4.边界:路由器x2...
  • 一,常见的网络拓扑图图标 二,核心交换机,汇聚交换机,接入交换机的区别? 三,核心交换机,汇聚交换机,接入交换机如何使用? 一、核心层交换机和汇聚层交换机区别 1、功能区别 2、...
  • 路由与交换技术综合实例 小型企业网拓扑图及详细配置
  • 由于核心设备的价格比较贵,比如CISCO设备,所以大部分企业使用的是单核心的网络拓扑设计。 但是这种设计有个致命的缺点,容易造成单点故障。当工程师们意识到了这个问题之后,第二种拓扑结构就产生了。 ...
  • 云服务器网络结构拓扑图

    千次阅读 2021-08-14 06:47:25
    云服务器网络结构拓扑图 内容精选换一换查询指定弹性云服务器的网络列表。无GET /v2.1/{project_id}/servers/{server_id}/ips参数说明请参见表1。参数说明参数是否必选描述project_id是项目ID。获取方法请参见获取...
  • 网络拓扑图主要由两个部分组成:企业网络、模拟外部网络即模拟Internet网络。具体说明如下: (1)为了便于观察,简化了企业网络的三层架构拓扑,将核心层与汇聚层合并,因此在拓扑图上看到的企业网络是由核心层/...
  • 网络拓扑图(附华为、CiscoVisio图标)

    万次阅读 多人点赞 2020-10-24 12:00:00
    什么是网络拓扑图网络拓扑图是指由网络节点设备和通信介质构成的网络结构图。 什么是网络拓扑架构? 网络拓扑结构是指用传输媒体互联各种设备的物理布局,就是用什么方式把网络中的计算机等设备连接起来。 ...
  • NETWORK06 - 企业网络拓扑图

    千次阅读 2018-09-09 11:35:28
    原 NETWORK06 - 企业网络拓扑图 ...
  • visio画的网络拓扑图(我们企业的)

    热门讨论 2011-12-26 13:41:33
    用visio画的全厂网络拓扑图,有感兴趣的可以作参考。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 29,106
精华内容 11,642
关键字:

企业网网络拓扑图