精华内容
下载资源
问答
  • IS-IS,即中间系统(Intermediate System) 到中间系统的域内路由信息交换协议,它最初是由国际标准化组织IsO为它无连接网络协议设计一种动态路由协议。为了提供对IP路由支持,IETF 对IS-IS进行了扩充和修改,使...

    前言

    IS-IS和OSPF都是基于链路状态技术的路由协议,它能够同时支持CLNP和IP网络层协议。目前,ISIS是业界尤其是大型IPS最广泛应用的IGP协议之一。

    一、ISIS协议原理概述

    1.什么是ISIS?

    IS-IS,即中间系统(Intermediate System) 到中间系统的域内路由信息交换协议。它最初是由国际标准化组织IsO为它的无连接网络协议设计的一种动态路由协议。为了提供对IP的路由支持,IETF对IS-IS进行了扩充和修改,使它能够同时应用在TCP/IP和OSI环境中,称为集成化IS-IS。IS-IS属于内部网关协议(IGP), 是一种链路状态协议,使用最短路径优先算法进行路由计算。
    在这里插入图片描述

    2、IS-IS 协议原理

    • IS-IS协议只支持两种类型的网络:广播型网络(Broadcast) 与点到点网络(P2P)。 IS-IS .
      邻居关系有Level-1和Level-2两种。在P2P网络上,只要IS能够收到对端的P2P IIH报文,
      就认为邻居能够建立,邻居状态为UP。在广播网络上,邻居建立需要三方握手过程。在IS-IS中,只要邻居关系建立,则意味着邻接关系同时建立了,邻居之间可以进行LSP的交换,达到LSDB的同步。
    • 邻接关系建立后,邻居IS间进行LSDB的同步,同步过程主要由邻居间交互LSP和SNP协议报文来完成的。LSP 用于描述链路状态信息。每个IS产生一个或多个LSP来描述它与周围邻居IS的连接; LSP报文中包含了发送者的System ID的序列号。SNP用于描述LSDB中LSB的摘要信息,并对邻居之间最新接收的LSP进行确认。SNP 包括CSNP和PSNP, CSNP 包括LSDB中所有LSP的摘要信息,从而可以在相邻路由器间保持LSDB的同步。在广播网络上,CSNP由DIS (指定IS)定期发送,在P2P链路上,CSNP 只在第一次建 立邻接关系时发送。PSNP只列举最近收到的一个或多个LSP的序号,它能够一次对多个 LSP进行确认。
    • IS-IS路由器接口启动IP协议后,相关的IP路由信息作为CLV附在LSP中,以叶节点的
      方式传递。IP 信息的变化不会影响到网络拓扑。

    3、IS-IS协议的基本特点

    1.1 IS-IS协议是一种链路状态协议,使用最短路径优先算法(SPF算法)进行路由计算。在这里插入图片描述
    在这里插入图片描述1.2 ISIS使用Hello包建立邻居关系、使用LSP交换链路状态信息,采用分层设计。在这里插入图片描述
    在这里插入图片描述1.3 ISIS有2种路由选择级别,L1和L2。

    • L1负责在同一个区域内传播链路状态信息(类似OSPF中的1类和2类)
    • L2负责在不同的区域内相互传播链路状态信息(类似OSPF的3类)
      1.4 ISIS的三种路由器:
    • L1能获取区域内的路径信息。Level-1路由器负责区域内的路由,它只维护一个Level-1 的LSDB,该LSDB包含本区域的路由信息,到区域外的报文转发给最近的Level-1-2路由器在这里插入图片描述
    • L2能获取区域间的路径信息。 Level-2 路由器负责区域间的路由,它维护一个Level-2r LSDB,该LSDB包含区域间的路由信息,所有Level-2 路由器和Level-1-2路由器组成路由域的骨干网,负责不同区域间通信,骨干网必须是物理连续的在这里插入图片描述
    • L1-2:能同时获取区域内和区域间路径。同时属于Level-1和Level-2的路由器称为Level-1-2路由器,Level-1-2 路由器维护两个LSDB,Level-1的LSDB用于区域内路由,Level-2 的LSDB用于区域间路由。在这里插入图片描述
      Level-1-2路由器维护两个LSDB,Level-1的LSDB用于区域内路由,Level-2的LSDB用于区域间路由

    1.5 连接L2路由器和L1/L2路由器的路径会形成骨干区域在这里插入图片描述
    1.6 IS-IS区域边界位于链路上,而不是路由器中,每台IS-IS路由器仅属于一个区域
    1.7 在华为路由器上,IS-IS不会自动缩放接口的度量值,接口的默认度量值是10,可以手动进行更改。
    1.8 ISIS的报文形式
    在这里插入图片描述
    1.9 ISIS适用网络类型
    在这里插入图片描述

    3.邻居关系图

    3.1 在同一个区域内

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    3.2 两个不同的区域之间

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    4.ISIS中的NET

    在这里插入图片描述

    在IS-IS协议中,IS 间建立邻居、交换路由信息所使用的Hello、 LSP 等协议报文,均直
    接承载在OSI数据链路帧中,而不像其他IGP由IP来承载。这些协议报文的格式是OSI报文
    格式,报文中包含有OSI地址。在OSI体系结构中,使用OSI地址标识网络设备,建立拓扑
    信息, OSI地址采用NSAP地址格式。NSAP由IDP (Initial Domain Paf和DSP (Domain SpecificPart)组成。IDP 相当于IP地址中的主网络号,DSP相当于IP地址中的子网号和主机地址。
    在这里插入图片描述
    IDP部分是ISO规定的,它由AFI (地址分配机构和地址格式)与IDI (内部域标识)组成。DSP由HO-DSP (用来分割区域)、System ID (用来区分主机)和NSEL (用来指示服务类型)组成。
    在集成IS-IS中,将NSAP地址划分成三部分:区域地址、System ID和NSEL。IDP 的DSP中的HO-DSP -起用来标识路由域中的区域,因此将(IDP、 HO-DSP) -起称为区域地址。
    一般情况下,一台路由器只需要配置一个区域地址,且同一区域中所有节点的区域地址都相同。为支持区域的平滑合并、分裂、迁移,一台路由器最多可配置3个区域地址。
    System ID用来在区域内唯一标识终端系统或路由器, 它的长度固定为6字节。System ID的指定可以有不同的方法,但要保证能够唯一标识终端系统或路由器, -般System ID由Router ID或者MAC地址转换而成。
    NESL的作用类似于IP中的协议标识符,不同的传输对应不同的NSEL。在IP中,NSEL
    均为00。
    NET (Network Entity Title 网络实体名称)指的是IS本身的网络层信息,不包括传输层
    信息,可以看作是一类特殊的NSAP,即NSEL为0的NSAP地址。NET的长度与NSAP相同,
    最多为20个字节,最少为8个字节。
    例如,若NET为ab.cdef.1234.5678.9abc.00 ,则Area为ab.cdef , System ID为1234.5678.9abc,NSEL为00。
    下图为根据Router ID来生成对应的System ID.在这里插入图片描述

    三、ISIS在ENSP上设置

    实验配置

    1、实验环境
    在ensp上面搭建拓扑图
    在这里插入图片描述
    2、配置各个路由器的路由接口IP地址和回环地址
    3、配置IS-IS
    (1)R1

    [R1]isis 1
    [R1-isis-1]network-entity 49.0001.0010.0100.1001.00
    [R1-isis-1]is-level level-1
    [R1-isis-1]q
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]isis enable
    [R1-GigabitEthernet0/0/1]int loo 0
    [R1-LoopBack0]isis enable 

    (2)R2

    [R2]isis 1
    [R2-isis-1]network-entity 49.0001.0020.0200.2002.00
    [R2-isis-1]is-level level-1-2  //此条命令可以省略,isis默认级别为 level-1-2
    [R2-isis-1]q
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]isis enable 
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]isis enable
    [R2-GigabitEthernet0/0/1]int loo 0
    [R2-LoopBack0]isis enable 

    (3)R3

    [R3]isis 1
    [R3-isis-1]network-entity 49.0000.0030.0300.3003.00
    [R3-isis-1]is-level level-2
    [R3-isis-1]q
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]isis enable 
    [R3-GigabitEthernet0/0/1]int g0/0/0
    [R3-GigabitEthernet0/0/0]isis enable
    [R3-GigabitEthernet0/0/0]interface loo 0
    [R3-LoopBack0]isis enable

    (4)R4

    [R4]isis 1
    [R4-isis-1]network-entity 49.0002.0040.0400.4004.00
    [R4-isis-1]is-level level-1-2
    [R4-isis-1]q
    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]isis enable 
    [R4-GigabitEthernet0/0/0]int g0/0/1
    [R4-GigabitEthernet0/0/1]isis enable 
    [R4-GigabitEthernet0/0/1]int loo 0
    [R4-LoopBack0]isis enable
    

    (5)R5

    [R5]isis 1
    [R5-isis-1]network-entity 49.0002.0050.0500.5005.00 
    [R5-isis-1]is-level level-1
    [R5-isis-1]q
    [R5]int g0/0/1
    [R5-GigabitEthernet0/0/1]isis enable 
    [R5-GigabitEthernet0/0/1]int loo 0
    [R5-LoopBack0]isis enable 
    [R5-LoopBack0]int loo 1
    [R5-LoopBack1]isis enable 
    [R5-LoopBack1]int loo 2
    [R5-LoopBack2]isis enable 
    

    4、配置RIP
    (1)R1

    [R1]rip 1
    [R1-rip-1]version 2
    [R1-rip-1]un summary 
    [R1-rip-1]network 16.0.0.0

    (2)R6

    [R6]rip 1
    [R6-rip-1]version 2
    [R6-rip-1]un summary 
    [R6-rip-1]network 16.0.0.0
    [R6-rip-1]network 203.0.0.0
    [R6-rip-1]network 203.0.1.0
    [R6-rip-1]6.0.0.0

    5、配置路由重分发
    路由重分发就是打通RIP与ISIS,使得他们的所属的区域路由能够相互学习路由表,在他们相连的路由器R1上配置。

    [R1]isis 1
    [R1-isis-1]import-route rip 1 level-1
    [R1-isis-1]q
    [R1]rip 1
    [R1-rip-1]import-route isis 1 cost 5

    6、路由泄露(在L1/2上将其他区域的路由信息引入,在华为手册上叫路由泄露)
    由于R1是L1路由器,所以只能获得area1区域内部的路由表信息,不能够获得area2和area0的信息,所以打通R2(L1/2),能够让R1学习到area0的信息,同理,R5也不能获得区域外的信息,打通R4(L1/2),这样整个链路就通了
    R2泄露给R1,查看R1路由表发现学习到新路由表

    [R2]isis 1
    [R2-isis-1]import-route isis level-2 into level-1

    R4泄露给R5,查看R5路由表发现学习到新路由表

    [R4]isis 1
    [R4-isis-1]import-route isis level-2 into level-1

    7、路由汇总
    我们发现R5和R6的两个loopback地址是同网段的,使用其他路由器查看路由表的时候,可以发现这些loopback地址是分开的,我们可以汇总
    (1)在ABR上做路由汇总(区域间路由汇总)

    [R4]isis 1
    [R4-isis-1]summary 202.0.0.0 255.255.254.0 level-1-2
    

    在这里插入图片描述
    (2)在ASBR上做路由汇总(不同协议间的路由汇总)

    [R1]isis 1
    [R1-isis-1]summary 203.0.0.0 255.255.254.0 level-1
    

    在这里插入图片描述
    实验结束

    四、ISIS和OSPF差别

    • 在IS-IS中,每个路由器都只属于一个区域;而在OSPF中,一个路由器的不同接口可以属于不同的区域。
    • 在IS-IS中,单个区域没有骨干与非骨干区域的概念;而在OSPF中,Area0被定义为骨干区域。
    • 在IS-IS中,Level-1和Level-2级别的路由都采用SPF算法,分别生成最短路径树SPT(Shortest Path Tree);而在OSPF中,只有在同一个区域内才使用SPF算法,区域之间的路由需要通过骨干区域来转发。
      在这里插入图片描述

    在这里插入图片描述

    展开全文
  • 自治系统与互联网的路由选择协议

    千次阅读 2018-03-04 19:25:43
    一、自治系统 互联网采用分层路由选择协议,并且将整个互联网划分为许多较小自治系统(Autonomous System,AS),一个...自治系统内部路由选择成为域内路由选择(inter domain routing),自治系统之间路由...

    一、自治系统

          互联网采用分层的路由选择协议,并且将整个互联网划分为许多较小的自治系统(Autonomous System,AS),一个自治系统内的所有网络都属于一个行政单位,例如,一所大学、一个公司,政府的一个部门等。一个自治系统最重要的特点是它有权选择在本系统内部采用何种路由选择协议。自治系统内部的路由选择成为域内路由选择(inter domain routing),自治系统之间的路由选择协议成为域间路由选择协议(intra domain routing)。

          这样,自治概念的提出实际是将互联网分为两层,一层是自治系统内部网络,可以将它成为第一层的路由,自治系统内部的路由器完成第一层区域的主机之间的分组交换。,另外,如果一个自治系统管理内部的路由器,通过主干网路由器连接到主干区域(backbone area),连接自治系统的主干路由器就构成了主干区域,即第二层路由。

          第一层区域之间的分组交换是通过主干路由器实现的。引进自治系统的概念使得网络之间的互联更加容易。作为一个自治系统,其核心是路由寻址的“自治”。它应该包含以下两个内容:

    (1)自治系统内部的路由器连接内部网络全部的路由信息,并且能够通过一条路径将发送到其它自治系统的分组传送到连接本自治系统的主干路由器上。

    (2)自治系统内部的路由器要像主干路由器报告内部路由信息。

    二、互联网路由选择协议的分类

         互联网将路由选择协议分为两大类:内部网关协议(Interior Gateway Protocol,IGP),外部网关协议(External Gateway Protocol,EGP)。

          内部网关协议是在一个自治系统内部使用的路由选择协议,这与互联网中其它自治系统选择什么路由选择协议无关。目前,内部网关协议主要有:路由信息协议(Routing Information Protocol,RIP)和开放最短路径优先(Open Shortest Path First,OSPF)协议。

          当源主机和谜目的主机处在不同的自治系统中,并且这两个自治系统使用不同的内部网管协议时,当分组传送到两个自治系统的边界时,就需要使用一种协议将路由信息传递到另一个自治系统中,这时就需要使用外部网关协议。目前,外部网关协议主要是边界网关协议(Border Gateway Protocol,BGP)。

          每个自治系统运行本系统的内部路由选择协议IGP,但是每一个自治系统都有一个或者多个与其它自治系统连接的路由器,出运行本系统的内部路由选择协议外,还需要运行自治系统之间的路由选择协议EGP。那么在各个自治系统内使用的内部网关协议可以使路由信息协议,也可以是开放最短路径协议。在主干路由器之间必须使用外部网关协议。

          注意:

    (1)路由选择算法和路由选择协议在概念上是不同的。网络上的主机、路由器通过路由选择算法形成路由表,已确定分组转发的传输路径。而路由选择协议是由路由器用来完路由表的建立和路由信息更新的通信协议。

    (2)早期技术文档中使用的“网关(Gateway)”,相当于今天人们熟悉的“路由器(Router)”。从网络互联的角度来看,网关和路由器是有区别的。但是由于历史原因,在路由讨论中,“网关”与“路由器”没有加以区分。

    展开全文
  • IS-IS,即中间系统(Intermediate System)到中间系统的域内路由信息交换协议 能够同时应用在TCP/IP和OSI环境中,称为集成化IS-IS IS-IS属于内部网关协议(IGP),是一种链路状态协议,使用最短路径优先算法进行路由...

    一、IS-IS路由协议

    1.概念

    • IS-IS,即中间系统(Intermediate System)到中间系统的域内路由信息交换协议
    • 能够同时应用在TCP/IP和OSI环境中,称为集成化IS-IS
    • IS-IS属于内部网关协议(IGP),是一种链路状态协议,使用最短路径优先算法进行路由计算(使用SPF算法)
    • 使用Hello包建立邻居关系、使用LSP交换链路状态信息,采用分层设计
    • 有2种路由选择级别,L1和L2
      • L1负责在同一个区域内传播链路状态信息(类似OSPF中的1类和2类)
      • L2负责在不同的区域内相互传播链路状态信息(类似OSPF的3类)
    • 三种路由器
      • L1能获取区域内的路径信息
      • L2能获取区域间的路径信息
      • L1-2能同时获取区域内和区域间路径
    • 连接L2路由器和L1/ L2路由器的路径会形成骨干区域
    • IS-IS区域边界位于链路上,而不是路由器中,每台IS-IS路由器仅属于一个区域
      在这里插入图片描述

    2.IS-IS系统

    在IS-IS系统中

    • IS相当于TCP/IP系统中的路由器,是IS-IS协议中生成路由和传播路由信息的基本单元
    • ES相当于TCP/IP中的主机系统
    • ES不参与路由协议的处理,在ISO中使用专门的ES-IS协议定义终端系统与中间系统间的通信,而在TCP/IP网络中,使用ARP\DHCP等协议取代ES-IS协议
    • RD(路由域)相当于TCP/IP中的自治系统,Area是路由域的细分单元,与OSPF概念相同

    3.级别

    OSI给IS-IS定义了4个路由级别,即level-0到level-3

    • level-0存在于ES与IS之间,由ES-IS协议来完成,在TCP/IP网络中,这个级别由ARP协议完成
    • level-1路由存在于同一个区域内的不同IS间,又称为区域内路由
    • level-2路由存在于同一路由域内的区域间,又称域间路由
    • level-3路由存在于路由域间,每个路由域相当于一个资质系统。在TCP/IP系统中,level-3由BGP协议来完成

    当IS要发送报文到另一个IS时,查看报文中的目的地址,发现其位于区域内的不同子网,则IS会选择最优的路径进行转发;如果目的地址在不同一个区域,则IS把数据转发到本区域内最近的level-1-2路由器上,然后由level-1-2路由器负责数据转发

    Level-1路由器负责区域内的路由,它只维护一个level-1的LSDB,该LSDB包含本区域的路由信息,到区域外的报文转发给最近的level-1-2路由器;level-2路由器负责区域间的路由,它维护一个level-2的LSDB,该LSDB包含区域间的路由信息,所有level-2路由器和level-1-2路由器组成路由域的骨干网,负责不同区域间通信,骨干网必须是物理连续的;同时属于level-1和level-2的路由器称为level-1-2路由器,level-1-2路由器维护两个LSDB,level-1的LSDB用于区域内路由,level-2的LSDB用于区域间路由

    4.IS-IS中的NET

    • NET(Network Entity Title,网络实体名称)指的是IS本身的网络层信息,不包括传输层信息,可以看作是一类特殊的NSAP,即NSEL为0的NSAP地址。NET的长度与NSAP相同,最多为20个字节,最少为8个字节

    • NSEL的作用类似于IP中的协议标识符,不同的传输对应不同的NSEL。在IP中,NSEL均为00

    • System ID用来在区域内唯一标识终端系统或路由器,它的长度固定为6字节。System ID的指定可以有不同的方法,但要保证能够唯一标识终端系统或路由器,一般System ID由Router ID或者MAC地址转换而成

    • 例如,若NET为ab.cdef.1234.5678.9abc.00,则Area为ab.cdef,System ID为1234.5678.9.abc,NSEL为00

    • 比如下图为根据Router ID来生成对应的System ID
      在这里插入图片描述
      在IS-IS协议中

    • IS间建立邻居、交换路由信息所使用的Hello、LSP等协议报文,均直接承载在OSI数据链路帧中,而不像其他IGP由IP来承载

    • 这些协议报文的格式是OSI报文格式,报文中含有OSI地址

    • 在OSI体系结构中,使用OSI地址标识网络设备,建立拓扑信息,OSI地址采用NSAP地址格式

    • NSAP由IDP(Initial Domain Part)和DSP(Domain Specific Part)组成

    • IDP相当于IP地址中的网络号,DSP相当于IP地址中的子网络号和主机地址

      • IDP部分是ISO规定的,它由AFI(地址分配机构和地址格式)与IDI(内部域标识)组成
      • DSP由HO-DSP(用来分割区域)、System ID(用来区分主机)和NSEL(用来指示服务类型)组成

    5.IS-IS协议原理

    • IS-IS协议只支持两种类型的网络
      • 广播型网络(Broadcast)
      • 点到点网络(P2P)
    • 在P2P网络上,只要IS能够到对端的P2P报文,就认为邻居能够建立,邻居状态为UP
    • 在广播网络上,邻居建立需要三方握手过程
    • 在IS-IS中,只要邻居关系建立,则意味着邻接关系同时建立了,邻居之间可以进行LSP的交换,达到LSDB的同步
    • 邻接关系建立后,邻居IS间进行LSDB的同步,同步过程最主要由邻居交互LSP和SNP协议报文来完成的
    • LSP用于描述链路状态信息。每个IS产生一个或多个LSP来描述它与周围邻居IS的链接;LSP报文中包含了发送者的System ID的序列号
    • SNP用于描述LSDB中LSB的摘要信息,并对邻居之间最新接收的LSP进行确认
    • SNP包括CSNP和PSNP,CSNP包括LSDB中所有LSP的摘要信息,从而可以在相邻路由器间保持LSDB的同步
    • 在广播网络上,CSNP由DIS指定(IS)定期发送,在P2P链路上,CSNP只在第一次建立邻接关系时发送
    • PSNP只列举最近收到的一个或多个LSP的序号,它能够一次对多个LSP进行确认
    • IS-IS路由器接口启动IP协议后,相关的IP路由信息作为CLV附在LSP中,以叶节点的方式传递。IP信息的变化不会影响到网络拓扑

    二、IS-IS小实验

    1.常用配置命令

    • 查看命令
    dis isis peer  	 	//查看邻居关系
    dis isis 1 brief    		//查看接口明细
    dis isis interface g0/0/1	//查看接口详情
    
    • 配置命令
    [Huawei]  isis 1   //后面跟进程。默认不加就是1进程
    [Huawei-isis-1]  network-entity 49.0001.0010.0100.1001.00  //补足三位,然后4位分割
    [Huawei-isis-1]  is-level level-1    //根据网络结构配置IS-IS路由类型,这边有路由器类型
    [Huawei-isis-1]  int g0/0/1   //进接口
    [Huawei-g0/0/1] isis enable		//启动
    
    • 路由重分发与路由汇总
    isis 1
    import-route   rip 1 lever-1   		//引入后变成L1信息  默认值
    
    rip 1
    import-route isis 1 cost 5 		//对于rip的度量值是跳数
    
    isis 1
    import-route isis level-2 into level-1	//华为手册这个叫路由泄露
    
    
    isis 1
    summary 202.0.0.0 255.255.254.0 level-1-2	//ABR汇总:域间路由汇总
    
    isis 1
    summary 203.0.0.0 255.255.254.0 level-1	//ASBR汇总:不同协议间的路由汇总
    

    2.实验环境

    • 实验软件:eNSP软件
      • 6台路由器

    1)拓扑图

    在这里插入图片描述

    • 实验要求
      • 1.通过IS-IS协议全网互通
      • 2.配置域间路由汇总
      • 3.配置不同协议间的路由汇总
      • 4.配置ISIS级别1和级别2之间的路由重分发
      • 5.调整ISIS的COST值

    2)详细配置

    2.1 R1配置

    • 启动IS-IS协议,并设置级别以及宣告IP地址,将各个接口配置上IP并开启IS-IS协议
    • 启动RIP协议并设置好版本以及宣告IP地址
    [R1]dis cu
    #
    sysname R1
    #
    isis 1
     is-level level-1     //将isis等级设置为1
     network-entity 49.0001.0010.0100.1001.00  //宣告IP地址
    #
    firewall zone Local
     priority 16
     interface GigabitEthernet0/0/0
     ip address 16.0.0.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.252
     isis enable 1    //在接口内开启isis
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    rip 1
     undo summary
     version 2
     network 16.0.0.0
    
    
    • R2-R6配置基本相同,下面就不做过多详解

    2.2 R2配置

    [R2]dis cu
    #
    sysname R2
    #
    isis 1
     network-entity 49.0001.0020.0200.2002.00
    #
    interface GigabitEthernet0/0/0
     ip address 23.0.0.1 255.255.255.252
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.2 255.255.255.252
     isis enable 1
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    

    2.3 R3配置

    [R3]dis cu
    #
    sysname R3
    #
    isis 1
     is-level level-2
     network-entity 49.0000.0030.0300.3003.00
    #
    interface GigabitEthernet0/0/0
     ip address 23.0.0.2 255.255.255.252
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 34.0.0.1 255.255.255.252
     isis enable 1
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    

    2.4 R4配置

    [R4]dis cu
    #
    sysname R4
    #
    isis 1
     network-entity 49.0002.0040.0400.4004.00
    #
    interface GigabitEthernet0/0/0
     ip address 45.0.0.1 255.255.255.252
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 34.0.0.2 255.255.255.252
     isis enable 1
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    

    2.5 R5配置

    [R5]dis cu
    #
    sysname R5
    #
    isis 1
     is-level level-1
     network-entity 49.0002.0050.0500.5005.00
    #
    interface GigabitEthernet0/0/0
     ip address 45.0.0.2 255.255.255.252
     isis enable 1
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
     isis enable 1
    #
    interface LoopBack1
     ip address 202.0.0.1 255.255.255.0
     isis enable 1
    #
    interface LoopBack2
     ip address 202.0.1.1 255.255.255.0
     isis enable 1
    

    2.6 R6配置

    [R6]dis cu
    #
    sysname R6
    #
    interface GigabitEthernet0/0/0
     ip address 16.0.0.2 255.255.255.252
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.255
    #
    interface LoopBack1
     ip address 203.0.0.1 255.255.255.0
    #
    interface LoopBack2
     ip address 203.0.1.1 255.255.255.0
    #
    rip 1
     undo summary
     version 2
     network 16.0.0.0
     network 6.0.0.0
     network 203.0.0.0
     network 203.0.1.0
    

    2.7 路由重分发配置

    • 先查看R2路由表中的信息
    [R2]dis ip routing-table  //用此命令查看
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 15       Routes : 15       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  ISIS-L1 15   10          D   12.0.0.1        GigabitEthernet
    0/0/1
            2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
            3.3.3.3/32  ISIS-L2 15   10          D   23.0.0.2        GigabitEthernet
    0/0/0
            4.4.4.4/32  ISIS-L2 15   20          D   23.0.0.2        GigabitEthernet
    0/0/0
            5.5.5.5/32  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.0/30  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/1
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           23.0.0.0/30  Direct  0    0           D   23.0.0.1        GigabitEthernet
    0/0/0
           23.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           34.0.0.0/30  ISIS-L2 15   20          D   23.0.0.2        GigabitEthernet
    0/0/0
           45.0.0.0/30  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          202.0.1.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
    
    • 然后在R1路由中将rip协议与isis协议互相注入
    [R1]rip 1
    [R1-rip-1]import-route isis 1 cost 5 	//将rip注入到isis中
    [R1-rip-1]q
    [R1]isis 1
    [R1-isis-1]import-route rip 1 level-1	//将isis注入到rip中
    
    • 再查看R2的路由信息,可以看到isis中的路由可以学习到rip中路由表条目了
    [R2]dis ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 19       Routes : 19       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  ISIS-L1 15   10          D   12.0.0.1        GigabitEthernet
    0/0/1
            2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
            3.3.3.3/32  ISIS-L2 15   10          D   23.0.0.2        GigabitEthernet
    0/0/0
            4.4.4.4/32  ISIS-L2 15   20          D   23.0.0.2        GigabitEthernet
    0/0/0
            5.5.5.5/32  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
            6.6.6.6/32  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
           12.0.0.0/30  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/1
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           16.0.0.0/30  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
           23.0.0.0/30  Direct  0    0           D   23.0.0.1        GigabitEthernet
    0/0/0
           23.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           34.0.0.0/30  ISIS-L2 15   20          D   23.0.0.2        GigabitEthernet
    0/0/0
           45.0.0.0/30  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          202.0.1.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          203.0.0.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
          203.0.1.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
    
    • 但是此时再查看R1和R6的路由表,可以发现学习不到isis中的路由网段,且R5也学习不到本区域外的网段
    [R5]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 12       Routes : 12       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            0.0.0.0/0   ISIS-L1 15   10          D   45.0.0.1        GigabitEthernet
    0/0/0
            4.4.4.4/32  ISIS-L1 15   10          D   45.0.0.1        GigabitEthernet
    0/0/0
            5.5.5.5/32  Direct  0    0           D   127.0.0.1       LoopBack0
           34.0.0.0/30  ISIS-L1 15   20          D   45.0.0.1        GigabitEthernet
    0/0/0
           45.0.0.0/30  Direct  0    0           D   45.0.0.2        GigabitEthernet
    0/0/0
           45.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  Direct  0    0           D   202.0.0.1       LoopBack1
          202.0.0.1/32  Direct  0    0           D   127.0.0.1       LoopBack1
          202.0.1.0/24  Direct  0    0           D   202.0.1.1       LoopBack2
          202.0.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack2
    
    
    • 因为R1的级别为L1,只能学习区域内的路由;因此,需要用路由泄露功能
    [R2]isis 1    //在R2路由中使用路由泄露功能
    [R2-isis-1]import-route isis level-2 into level-1  //将isisL2的信息泄露成L1的信息
    
    • 此时再次查看R1和R6,可以发现已经学习到路由条目了
    [R1]dis ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 20       Routes : 20       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            0.0.0.0/0   ISIS-L1 15   10          D   12.0.0.2        GigabitEthernet
    0/0/1
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
            2.2.2.2/32  ISIS-L1 15   10          D   12.0.0.2        GigabitEthernet
    0/0/1
            3.3.3.3/32  ISIS-L1 15   20          D   12.0.0.2        GigabitEthernet
    0/0/1
            4.4.4.4/32  ISIS-L1 15   30          D   12.0.0.2        GigabitEthernet
    0/0/1
            5.5.5.5/32  ISIS-L1 15   40          D   12.0.0.2        GigabitEthernet
    0/0/1
            6.6.6.6/32  RIP     100  1           D   16.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.0/30  Direct  0    0           D   12.0.0.1        GigabitEthernet
    0/0/1
           12.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           16.0.0.0/30  Direct  0    0           D   16.0.0.1        GigabitEthernet
    0/0/0
           16.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.0/30  ISIS-L1 15   20          D   12.0.0.2        GigabitEthernet
    0/0/1
           34.0.0.0/30  ISIS-L1 15   30          D   12.0.0.2        GigabitEthernet
    0/0/1
           45.0.0.0/30  ISIS-L1 15   40          D   12.0.0.2        GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  ISIS-L1 15   40          D   12.0.0.2        GigabitEthernet
    0/0/1
          202.0.1.0/24  ISIS-L1 15   40          D   12.0.0.2        GigabitEthernet
    0/0/1
          203.0.0.0/24  RIP     100  1           D   16.0.0.2        GigabitEthernet
    0/0/0
          203.0.1.0/24  RIP     100  1           D   16.0.0.2        GigabitEthernet
    0/0/0
    
    [R6]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 20       Routes : 20       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.2/32  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
            3.3.3.3/32  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
            4.4.4.4/32  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
            5.5.5.5/32  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
            6.6.6.6/32  Direct  0    0           D   127.0.0.1       LoopBack0
           12.0.0.0/30  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
           16.0.0.0/30  Direct  0    0           D   16.0.0.2        GigabitEthernet
    0/0/0
           16.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.0/30  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
           34.0.0.0/30  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
           45.0.0.0/30  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
          202.0.1.0/24  RIP     100  6           D   16.0.0.1        GigabitEthernet
    0/0/0
          203.0.0.0/24  Direct  0    0           D   203.0.0.1       LoopBack1
          203.0.0.1/32  Direct  0    0           D   127.0.0.1       LoopBack1
          203.0.1.0/24  Direct  0    0           D   203.0.1.1       LoopBack2
          203.0.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack2
    
    
    • 用相同的办法,在R4上使用路由泄露功能
    [R4]isis 
    [R4-isis-1]import-route isis level-2 into level-1 
    
    [R5]dis ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 21       Routes : 21       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            0.0.0.0/0   ISIS-L1 15   10          D   45.0.0.1        GigabitEthernet
    0/0/0
            1.1.1.1/32  ISIS-L1 15   40          D   45.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.2/32  ISIS-L1 15   30          D   45.0.0.1        GigabitEthernet
    0/0/0
            3.3.3.3/32  ISIS-L1 15   20          D   45.0.0.1        GigabitEthernet
    0/0/0
            4.4.4.4/32  ISIS-L1 15   10          D   45.0.0.1        GigabitEthernet
    0/0/0
            5.5.5.5/32  Direct  0    0           D   127.0.0.1       LoopBack0
            6.6.6.6/32  ISIS-L1 15   104         D   45.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.0/30  ISIS-L1 15   40          D   45.0.0.1        GigabitEthernet
    0/0/0
           16.0.0.0/30  ISIS-L1 15   104         D   45.0.0.1        GigabitEthernet
    0/0/0
           23.0.0.0/30  ISIS-L1 15   30          D   45.0.0.1        GigabitEthernet
    0/0/0
           34.0.0.0/30  ISIS-L1 15   20          D   45.0.0.1        GigabitEthernet
    0/0/0
           45.0.0.0/30  Direct  0    0           D   45.0.0.2        GigabitEthernet
    0/0/0
           45.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  Direct  0    0           D   202.0.0.1       LoopBack1
          202.0.0.1/32  Direct  0    0           D   127.0.0.1       LoopBack1
          202.0.1.0/24  Direct  0    0           D   202.0.1.1       LoopBack2
          202.0.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack2
          203.0.0.0/24  ISIS-L1 15   104         D   45.0.0.1        GigabitEthernet
    0/0/0
          203.0.1.0/24  ISIS-L1 15   104         D   45.0.0.1        GigabitEthernet
    0/0/0
    

    2.8 路由汇总

    • 需要路由汇总是因为R5和R6的两个loopback地址虽然是同网段的,但是用其他路由器查看路由表时,地址是分开的
    [R2]dis ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 19       Routes : 19       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    。。。省略部分内容
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          202.0.1.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          203.0.0.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
          203.0.1.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
    
    • 在R1与R4上进行汇总
    [R4]isis 	
    [R4-isis-1]summary 202.0.0.0 255.255.254.0 level-1-2
    
    [R1]isis                           
    [R1-isis-1]summary 203.0.0.0 255.255.254.0 level-1
    
    
    • 再在R2路由器上查看
    [R2]dis ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 19       Routes : 19       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    。。。省略部分内容
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/23  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          203.0.0.0/23  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
    
    • 实验结束

    总结

    • IS-IS有那么几个特点
      • 维护一个链路状态数据库,并使用SPF算法来计算最佳路径;
      • 用Hello包建立和维护邻居关系;
      • 使用区域来构造两级层次化的拓扑结构;
      • 在区域之间可以使用路由汇总来减少路由器的负担;
      • 支持VLSM和CIDR;
      • 在广播多路访问网络通过选举指定IS(DIS)来管理和控制网络上的泛洪扩散;
      • 具有认证功能;
      • IS-IS采用Cost作为度量值;
      • 快速收敛;
      • 适合大型网络。
    展开全文
  • 自治系统(AS)路由协议的分类

    万次阅读 2007-07-19 16:31:00
    一个AS可以是一些运行单个IGP(内部网关协议)协议的路由器集合。也可以是一些运行不同路由选择协议但都属于同一个组织机构的路由器集合。 不管是哪种情况,外部世界都将整个AS看作是一个实体。 每个自治系统都有...

    一个AS是一组共享相似的路由策略并在单一管理域中运行的路由器的集合。一个AS可以是一些运行单个IGP(内部网关协议)协议的路由器集合。也可以是一些运行不同路由选择协议但都属于同一个组织机构的路由器集合。 不管是哪种情况,外部世界都将整个AS看作是一个实体。

     每个自治系统都有一个唯一的自治系统编号.这个编号是由因特网授权的管理机构IANA分配的。它的基本思想就是希望通过不同的编号来区分不同的自治系统。这样.当网络管理员不希望自己的通信数据通过某个自治系统时,这种编号方式就十分有用了。例如.该网络管理员的网络完全可以访问某个自治系统.但由于它可能是由竞争对手在管理,或是缺乏足够的安全机制,因此.可能要回避它。

    通过采用路由协议和自治系统编号,路由器就可以确定彼此问的路径和路由信息的交换方法。

    自治系统的编号范围是165535。其中164511是注册的因特网编号,6451265535是专用网络编号。

    路由协议的分类

    按照工作区域,路由协议可以分为IGPEGP 

    IGP(InteriorGateway Protocols)内部网关协议

    在同一个自治系统内交换路由信息,RIPOSPFISlS 都属于IGPIGP的主要目的是发现和计算自治域内的路由信息。

    EGP(Exterior Gateway Protocols)外部网关协议

    用于连接不同的自治系统,在不同的自治系统之间交换路由信息,主要使用路由策略和路由过滤等控制路由信息在自治域间的传播,应用的一个实例是BGP

    按照路由的寻径算法和交换路由信息的方式,路由协议可以分为距离矢量协议(Distant-Vector)和链路状态协议。距离矢量协议包括RIPBGP,链路状态协议包括OSPFIS-IS

    距离矢量路由协议基于贝尔曼一福特算法,使用D-V法的路由器通常以一定的时间间隔向相邻的路由器发送他们完整的路由表。接收到路由表的邻居路由器将收到的路由表和自己的路由表进行比较.新的路由或到己知网络但开销(Metric)更小的路由都被加入到路由表中。相邻路由器然后再继续向外广播它自己的路由表(包括更新后的路由)。距离矢量路由器关心的是到目的网段的距离(Metric)和矢量(方向.从哪个接口转发数据)。在发送数据前,路由协议计算到目的网段的Metric.在收到邻居路由器通告的路由时,将学到的网段信息和收到此网段信息的接口关联起来,以后有数据要转发到这个网段就使用这个关联的接口。

    距离矢量路由协议的优点:配置简单.占用较少的内存和CPU处理时间。缺点:

    扩展性较差,比如RIP最大跳数不能超过16跳。  

    链路状态路由协议基于Dijkstra算法,有时破称为最短路径优先算法。最短路径优先算法提供RIPD-V算法更大的扩展性和快速收敛性.但是它的算法耗费更多的路由器内存和处理能力。D-V算法关心网络中链路或接口的状态(updownIP地址、掩码),每个路由器将自己已知的链路状态向该区域的其他路由器通告。这些通告称为链路状态通告(LSALink State Advertisement)。通过这种方式区域内的每台路由器部建寺了一个本区域的完整的链路状态数据库。然后路由器根据收集到的链路状态信息来创建它自己的网络拓朴图,形成一个到各个目的网段的带权有向图。

     链路状态算法使用增量更新的机制。只当链路的状态发生了变化时才发送路由更新信息,这种方式节省了相邻路由器之间的链路带宽。部分更新只包含改变了的链路状态信息,而不是整个的路由表。

    展开全文
  • 1.OSPF概述: OSPF属于链路状态路由协议、也就是说不像...OSPF在共同的管理下运行着一组相同的路由协议的集合称之为一个自制系统 (Autonomous System ,AS)可以是一个企业或者一个运营商等等。OSPF分为内部网关...
  • 因特网的路由选择协议的特点是:属于自适应的选择协议(即动态的);是分布式路由选择协议;采用分层次的路由选择协议,即分自治系统内部和自治系统外部路由选择协议。因特网的路由选择协议划分为两大类:内部网关...
  • ※第二:了解一下ospf的路由类型: 如下图所示 共有4种类型 内部路由器(internal Router)---是指所有接口都属于同一个区域路由器 区域边界路由器(Area Border Routers,ABR)------是指连接一个或者多个区域...
  • OSPF单和多

    2020-03-01 21:13:42
    OSPF 协议是公有标准协议,属于内部网关协议中 链路状态 路由协议; OSPF 报文是直接封装在 IP 头部后面属于 OSI 模型 第三层; OSPF 报文协议号是 89 , 报文发送方式是组播地址: 224.0.0.5(所有...
  • PBR在城网上应用

    2011-04-01 17:15:46
    简单介绍:这是模拟城一部分。 PC1,PC2模拟分公司。 CENTER 部署在总公司区域 district 1部分在城市一个区域,属于这个区核心层 ISP1和2之间启用RIP通告...ISP与公司网络之间没有启任何路由协议,都是使用...
  • CentOS6-路由配置(静态)

    2018-03-11 14:42:19
    在数据传输过程中,只有相同网段才属于一个广播,才可以进行ARP寻址建立网络连接,如果不在一个网段,则需要通过网关(路由),才可以跟其他网络中pc、路由、等网络设备进行通信。在这个建立通讯和数...
  • 在 单 个 区 办 配 置OSPF ...OSPF是一种内部网关协议(IGP),也就是说它在属于同一自治系统路由器间发布路由信息。 OSPF是为解决RIP不能解决大型、可扩展网络需求而写OSPF解决了以下问...
  • BGP

    2011-05-30 15:49:00
    BGP不使用传统域内路由协议的距离度量,而是基于路径、网络策略和规则集来决定路由。 自从1994年以来,BGP版本4在互联网上广泛使用,更早的版本都已经废弃。版本4的主要改进在于支持无类别域间路由(CIDR)并使用...
  • 了解IS-IS

    2020-08-29 19:19:10
    IS-IS(中间系统到中间系统的域内路由信息交换协议),属于内部网关协议,是一种链路状态协议,使用SPF算法进行路由计算。位于网络层,早期一些运营商选择IS-IS作为其网络IGP路由协议,主要是因为集成IS-IS能够...
  • 动态路由协议按工作区域划分: 1、 内部网关协议IGP:在同一个自治系统AS内交换路由信息,IGP的主要目的是发现和计算自治域内...2、可以是运营相同协议的路由器集合,也可以是运行不同路由协议属于同一个组织机...
  • 什么是VLAN

    2013-10-23 09:59:12
     路由协议工作在网络层,相应工作设备有路由器和路由交换机(即三层交换机)。该方式允许一个VLAN跨越多个交换机,或一个端口位于多个VLAN中。  就目前来说,对于VLAN划分主要采取上述第1、3种方式,第2种方式...
  • IBGP/EBGP/BGP/IGP

    2013-03-23 01:33:32
    所以IBGP和IGP不是一个概念,IGP都是运行在一个AS域内的路由协议所以说它是内部网关路由协议,而EGP可以运行在多个AS域上,IBGP就是在同一个AS上运行BGP协议但是它并不是IGP。 转载于:...
  • BGP基本概念 在正式介绍BGP之前我们先介绍一下基础知识 ...IGP主要目的是发现和计算自治域内的路由信息。 BGP(Border Gateway Protocol,边界网关协议)是用来连接Internet上独立系统的路由选择协议
  • 当一台路由器运行了OSPF协议和内外一种协议的时候,些路由器并不是ASBR,只有当把另外一种路由协议重发布到OSPF的时候,这台路由器才是 ASBR。 当外部路由协议进入OSPF的时候,才会产生第五类LSA,它不属于任何...
  • PIM-SM属于稀疏模式的域内组播路由协议。与PIM-DM不同的是,PIM-SM不会将组播数据扩散到全网,而只将组播数据传输到有组成员的网络,一般用于规模较大、组成员分布稀疏的组播网络,且PIM-SM同时适用于ASM模型和SSM...
  • IP组播配置与管理——3

    千次阅读 2018-03-26 15:46:03
    PIM-SM(IPv4)配置与管理PIM-SM属于稀疏模式的域内组播路由协议。它与PIM-DM不同的是,PIM-SM不会将组播数据扩散到全网,而只将组播数据传输到有组成员的网络,一般用于规模较大、组成员分布稀疏的组播网络,且PIM-...
  • CISCO 技术大集合

    2013-05-22 01:07:13
    以下在Router1上设置了访问192.1.0.64/26这个网下一跳地址为192.200.10.6,即当有目的地址属于192.1.0.64/26网络范围数据报,应将其路由到地址为192.200.10.6相邻路由器。在Router3上设置了访问192.1.0.128/26...
  • TCP_IP详解卷1

    热门讨论 2010-12-29 10:53:54
    描述了属于每一层各个协议以及它们如何在不同操作系统中运行。作者用Lawrence Berkeley实验室tcpdump程序来捕获不同操作系统和TCP/IP实现之间传输不同分组。对tcpdump输出研究可以帮助理解不同协议如何工作...
  • 答:广 播式网络是属于共享广播信道,不 存在路由选择问题,可 以不要网络层,但 从OSI 观点,网络设备应连接到网络层服务访问点,因此将服务访问点设置在高层协议与数据 链路层中逻辑链路子层交界面上,IEEE ...
  • 计算机网络复习题

    2014-12-29 19:01:35
    分组转发 属于同一条虚电路分组均按照同一路由进行转发 每个分组独立选择路由进行转发 当结点出故障时 所有通过出故障结点虚电路均不能工作 出故障结点可能会丢失分组,一些路由可能会发生变化 分组顺序...
  •  15、以下哪象不是UDP协议的特性  A、提供可kao 服务  B、提供无连接服务  C、提供端到端服务  D、提供全双工服务  Key: A 16、无线居网需要实现移动结点的哪几层功能?  1.物理层 2.数据链路层 3....
  •  反过来,如果两台主机子网掩码原来都是255.255.255.128,误将主机二设为255.255.255.192,主机一向主机二发送数据时,由于IP地址与错误子网掩码相与,误认两台主机处于不同网络,则会将本来属于同一子网内的...
  • 作用问题 - 局部作用 / 嵌套作用 / 全局作用 / 内置作用 / 和作用相关关键字 用模块管理函数 - 模块概念 / 用自定义模块管理函数 / 命名冲突时候会怎样(同一个模块和不同模块) Day07 - 字符...

空空如也

空空如也

1 2
收藏数 31
精华内容 12
关键字:

属于域内路由协议的是