精华内容
下载资源
问答
  • 帧中继dlci
    2022-07-21 18:50:23

    帧中继网配置实例

    帧中继(frame relay)是一种公用数据网通讯协议。帧中继是一种有效的数据传输技术,它可以在一对一或者一对多的应用中快速而低廉的传输数位信息。它可以使用于语音、数据通信,既可用于局域网(LAN)也可用于广域网(WAN)的通信。每个帧中继用户将得到一个接到帧中继节点的专线。帧中继网络对于端用户来说,它通过一条经常改变且对用户不可见的通道来处理和其他用户间的数据传输。



    1、实验目标

    通过帧中继协议方式联通两台路由器实现 IP 层互通


    2、网络拓扑图

    在这里插入图片描述

    有些路由器默认是不带 Serial 接口的,但是可以通过手动添加 Serial 接口的硬件来实现,首先选中要添加 Seria l接口的路由器,点击右键,选择设置,进入视图,然后把 2SA 拉取到上面的排孔中,然后就可得到 Serial 接口了

    注:添加接口卡只用在设备关闭的情况下才可以进行操作

    在这里插入图片描述


    3、配置步骤

    (1)设置路由器 R1 的端口 IP 地址及链路层协议

    <Huawei>system-view
    [Huawei]sysname R1
    [R1]interface Serial1/0/0
    [R1-Serial1/0/0]ip address 10.1.1.1 24	
    [R1-Serial1/0/0]link-protocol fr  //配置端口封装类型为帧中继协议链路协议 
    [R1-Serial1/0/0]fr interface-type dte  //配置端口类型为 DTE 
    [R1-Serial1/0/0]fr dlci 100  //配置本地 DLCI 号
    [R1-fr-dlci-Serial1/0/0-100]quit
    
    //如果对端路由器支持逆向地址解析功能,则配置地址动态映射,否则配置静态地址映射,命令如下:
    [R1-Serial1/0/0]fr inarp  //配置动态地址映射
    [R1-Serial1/0/0]fr map ip 10.1.1.2 100  //配置静态地址映射
    [R1-Serial1/0/0]quit
    

    (2)设置路由器 R2 的端口 IP 地址及链路层协议

    <Huawei>system-view
    [Huawei]sysname R2	
    [R2]interface Serial1/0/0
    [R2-Serial1/0/0]ip address 10.1.1.2 24
    [R2-Serial1/0/0]link-protocol fr	
    [R2-Serial1/0/0]fr interface-type dce	
    [R2-Serial1/0/0]fr dlci 100  //配置本地 DLCI 号
    [R2-fr-dlci-Serial1/0/0-100]quit
    	
    //如果对端路由器支持逆向地址解析功能,则配置地址动态映射,否则配置静态地址映射,命令如下:
    [R2-Serial1/0/0]fr inarp  //配置动态地址映射
    [R2-Serial1/0/0]fr map ip 10.1.1.1 100  //配置静态地址映射
    [R2-Serial1/0/0]quit
    

    4、测试

    (1)在路由器 R2 上查看帧中继映射信息

    帧中继协议端口通过地址映射到了对端的 DLCI,即双方可以通信。

    [R2]display fr map-info 
    Map Statistics for interface Serial1/0/0 (DCE)
      DLCI = 100, IP 10.1.1.1, Serial1/0/0
        create time = 2022/07/21 18:25:00, status = ACTIVE
        encapsulation = ietf, vlink = 2
    

    (2)在 R1 上可以 ping 通 R2 的端口地址,说明链路层帧中继工作正常

    [R1]ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=60 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=20 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
    
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/30/60 ms
    

    5、小结

    帧中继的主要特点:
    用户信息以帧(frame)为单位进行传送,网络在传送过程中对帧结构、传送差错等情况进行检查,对出错帧直接予以丢弃,同时,通过对帧中地址段DLCI的识别,实现用户信息的统计复用。

    帧中继网络用虚电路(Virtual Circuit,VC)来连接网络两端的帧中继设备,每条虚电路用数据链路连接标识符(Data Link Connection Identifier,DCLI)定义帧中继连接通道。

    帧中继网络提供了用户设备之间进行数据通信的能力,其设备可分为数据终端设备(Data Terminal Equipment,DTE)和数据通信设备(Data Communication Equipment,DCE),DCE 用于将 DTE 接入网络。

    帧中继网络接口分为用户网络接口(User Network Interface,UNI)和网络间接口(Network Network Interface,NNI),UNI 指 DTE 和 DCE 之间的接口,NNI 指 DCE 和 DCE 之间的端口。


    文章如有错误之处,欢迎各位大佬批评指正

    更多相关内容
  • 实验二 帧中继的基本配置

    千次阅读 2021-06-06 10:46:59
    1.掌握帧中继基本概念、DLCI含义、LMI作用、静态和动态映射的区别 2.掌握帧中继的基本配置:如接口封装、DLCI配置、LMI配置等 3.能够对帧中继进行基本故障排除 二、实验设备 PC终端1cisco packet trcater 软件。 三...

    实验二 帧中继的基本配置

    一、实验目的
    1.掌握帧中继基本概念、DLCI含义、LMI作用、静态和动态映射的区别
    2.掌握帧中继的基本配置:如接口封装、DLCI配置、LMI配置等
    3.能够对帧中继进行基本故障排除
    二、实验设备
    PC终端1cisco packet trcater 软件。
    三、实验拓扑
    在这里插入图片描述

    在上图中,路由器RA和RB,RC,RD建立了三条虚电路,其中,
    s0//3/0.1 point-to-point 101 192.168.10.1/24 连接RB
    s0//3/0.2 multipoint 102 103 192.16820.1/24 连接RC RD
    四、实验内容
    1.按上图添加四台路由器,并分别为4台路由器加上串口模块;
    2.添加帧中继云,并分别与4台路由器相连;
    3.按上图设置好四台路由器的DLCI值;
    在这里插入图片描述

    4.配置号帧中继连接
    在这里插入图片描述

    5.接口连线時,应把路由器接口作为DTE端。
    6.配置要求:
    (1)每台路由用自己的学号作为主机名,设置特权模式的密码为cisco, 关闭路由器的自动查询功能。
    (2)路由器RA上帧中继类型为Cisco,lmi类型为ansi,在子接口s0/3/0.2上建立静态映射。
    (3)路由器RB、RC和RD上帧中继类型为cisco,lmi类型为ansi,建立静态映射。
    路由器RA配置序列
    配RA的基础信息
    Router>en
    Router#
    Router#config t
    Router(config)#hostname RA
    RA(config)#no ip domain-Lookup
    RA(config)#enable password cisco
    配置RA的s0/3/0接口上的帧中继协议及LMI(类型为ansi)
    RA(config)#int s0/3/0
    RA(config-if)#encapsulation frame-relay
    RA(config-if)#frame-relay lmi-type ansi
    RA(config-if)#no shutdown
    创建子接口s0/3/0.1,类型为point-to-point
    RA(config)#int s0/3/0.1 point-to-point
    RA(config-subif)#ip address 192.168.10.1 255.255.255.0
    RA(config-subif)#frame-relay interface-dlci 101
    RA(config-subif)#exit
    创建子接口s0/3/0.2,类型为multipoint
    RA(config)#int s0/3/0.2 multipoint
    RA(config-subif)#ip address 192.168.20.1 255.255.255.0
    RA(config-subif)#frame-relay interface-dlci 102
    RA(config-subif)#frame-relay interface-dlci 103
    设置子接口s0/3/0.2上的静态映射
    RA(config)#int s0/3/0.2 multipoint
    RA(config-subif)#frame-relay map ip 192.168.20.2 102
    RA(config-subif)#frame-relay map ip 192.168.20.3 103
    RA(config-subif)#end

    路由器RB的配置
    配RB的基础信息
    Router>en
    Router#config t
    Router(config)#hostname RB
    RB(config)#no ip domain-lookup
    RB(config)#enable password cisco
    配置RB的s0/3/0接口上的帧中继协议及LMI(类型为ansi)
    RB(config)#int s0/3/0
    RB(config-if)#ip address 192.168.10.2 255.255.255.0
    RB(config-if)#no shutdown
    RB(config-if)#encapsulation frame-relay
    RB(config-if)#frame-relay lmi-type ansi
    RB(config-if)#exit
    关闭路由器RB上的自动映射,设置静态映射
    RB(config)#int s0/3/0
    RB(config-if)#no frame-relay inverse-arp
    RB(config-if)#frame-relay map ip 192.168.10.1 101 broadcast
    RB(config-if)#end

    路由器RC的配置序列:
    配RC的基础信息
    Router>en
    Router#config t
    Router(config)#hostname RC
    RC(config)#no ip domain-lookup
    RC(config)#enable password cisco
    配置RC的s0/3/0接口上的帧中继协议及LMI(类型为ansi)
    RC(config)#int s0/3/0
    RC(config-if)#encapsulation frame-relay
    RC(config-if)#frame-relay lmi-type ansi
    RC(config-if)#ip address 192.168.20.2 255.255.255.0
    RC(config-if)#no shutdown
    关闭路由器RC上的自动映射,设置静态映射
    RC(config-if)#no frame-relay inverse-arp
    RC(config-if)#frame-relay map ip 192.168.20.1 201 broadcast

    路由器RD的配置序列
    配RD的基础信息
    Router>en
    Router#config t
    Router(config)#hostname RD
    RD(config)#no ip domain-lookup
    RD(config)#enable password cisco
    配置RD的s0/3/0接口上的帧中继协议及LMI(类型为ansi)
    RD(config)#int s0/3/0
    RD(config-if)#encapsulation frame-relay
    RD(config-if)#frame-relay lmi-type
    RD(config-if)#frame-relay lmi-type ansi
    RD(config-if)#ip address 192.168.20.3 255.255.255.0
    RD(config-if)#no shutdown

    查看命令:
    RA#sh frame-relay map //查看映射
    RA#show frame-relay lmi //查看lmi类型
    RA#show frame-relay pvc //查看虚电路

    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述

    展开全文
  • 帧中继

    千次阅读 2015-07-03 16:04:00
    帧中继就像一个局域网 帧中继中的dlci就像局域网中的mac地址,也是唯一的。 帧中继中各路由器的ip就是局域网中的ip,都是在同一个网段。

    帧中继就像一个局域网,帧中继地址映射是用来把下一跳 IP 地址和本地 DLCI (相当于一个接口的mac地址)联系起来,通熟即DLCI就是通往下一跳的出口。



    帧中继中的dlci就像局域网中的mac地址,是唯一的,不同的是一个接口可以有多个dlci,但一个dlci仅且只能被使用一次。每条pvc两端有两个唯一的dlci(这两个dlci在帧中继交换机中相对应),并且其他pvc不能再使用这两个dlci。

    帧中继中各路由器的ip就是局域网中的ip,都是在同一个网段。


    帧中继点到点、点到多点区别:两个的唯一的区别在于点到点用于每个子接口对应一个网段(每条pvc一个网段);而点到多点是所有子接口都是一个网段的(只有dlci不同)。


    虚拟电路介绍:

    根据虚电路建立方式的不同,虚电路分为两种类型:永久虚电路(PermanentVirtualCircuit,PVC)和交换虚电路(SwitchedVirtualCircuit,SVC)。手工设置产生的虚电路称为永久虚电路。通过协议协商产生的虚电路称为交换虚电路,这种虚电路由帧中继协议自动创建和删除。目前在帧中继中使用最多的方式是永久虚电路方式。在永久虚电路方式下,需要检测虚电路是否可用。本地管理接口(LocalManagementInterface,LMI)协议就是用来检测虚电路是否可用的。


    帧中继地址映射
    帧中继地址映射是把对端设备的ip地址与本地的帧中继地址(即本地的DLCI)关联起来,使高层协议能通过本地dlci找到对端设备。
    帧中继主要用来承载IP协议,在发送IP报文时,根据路由表只能知道报文的下一跳地址,发送前必须由该地址确定它对应的DLCI。这个过程可以通过查找帧中继地址映射表来完成,因为地址映射表中存放的是下一跳IP地址和下一跳对应的本地DLCI的映射关系,最后交由帧中继交换机完成通讯。
    地址映射表可以由手工配置(注意DLCI只在本地有意义不能跨过帧中交换机使用,静态配置接口的frame-relay map ip 1.1.1.1 102 broadcast中1.1.1.1为PVC对端的地址而DLCI值201为本接口的DLCI),也可以由InverseARP(逆向地址解析协议)动态维护。


    点对多点配置步骤:

    1)帧中继交换机即DCE,规划好每条PVC两端的对应DLCI值(帧中继交换机的单个接口可以配置多个DLCI),如下图,


    2)配置终端路由器为DTE并设置好接口IP即可,此时DTE会动态获取帧中交换机的MAP映射关系(当然DTE也可以关闭动态映射而使用静态配置法,结果是一样的)。




    A、帧中继静态映射实例:

    1、帧中继交换机配置为全拓扑互通型(属于点到多点技术,所有接口在同一个网段中,),即R1、2、3两两互通。但在现实中为了节约资源经常用中央-分支拓扑。


    2、配置如下



    frame-sw#

    frame-relay switching 

    !


    interface Serial0/0
     no ip address
     encapsulation frame-relay
     serial restart-delay 0
     frame-relay lmi-type cisco
     frame-relay intf-type dce
     frame-relay route 201 interface Serial0/2 102
     frame-relay route 203 interface Serial0/1 302
    !
    interface Serial0/1
     no ip address
     encapsulation frame-relay
     serial restart-delay 0
     frame-relay lmi-type cisco
     frame-relay intf-type dce
     frame-relay route 301 interface Serial0/2 103
     frame-relay route 302 interface Serial0/0 203
    !
    interface Serial0/2
     no ip address
     encapsulation frame-relay
     serial restart-delay 0
     frame-relay lmi-type cisco
     frame-relay intf-type dce
     frame-relay route 102 interface Serial0/0 201
     frame-relay route 103 interface Serial0/1 301
    !


    R1#

    interface Loopback1
     ip address 1.1.1.1 255.255.255.255

    !

    interface Serial0/1
     ip address 10.10.10.1 255.255.255.0
     encapsulation frame-relay
     ip split-horizon
     frame-relay map ip 10.10.10.2 102 broadcast  \\静态映射关系配置且DLCI为本地。如果是动态映射配完Serial0/1的ip就可以,这项不用配置。
     frame-relay map ip 10.10.10.3 103 broadcast
     no frame-relay inverse-arp   \\关闭逆向ARP,默认是开启的,用于动态映射。


    R2# 

    !
    interface Loopback1
     ip address 2.2.2.2 255.255.255.255

    !
    interface Serial0/0
     ip address 10.10.10.2 255.255.255.0
     encapsulation frame-relay
     frame-relay map ip 10.10.10.1 201 broadcast
     frame-relay map ip 10.10.10.3 203 broadcast
     no frame-relay inverse-arp

    R3#

    !
    interface Loopback1
     ip address 3.3.3.3 255.255.255.255

    interface Serial0/0
     ip address 10.10.10.3 255.255.255.0
     encapsulation frame-relay
     frame-relay map ip 10.10.10.1 301 broadcast
     frame-relay map ip 10.10.10.2 302 broadcast
     no frame-relay inverse-arp


    2、查看帧中继交换机路由show frame-relay route

    frame-sw#sh frame-relay route 
    Input Intf      Input Dlci      Output Intf     Output Dlci     Status
    Serial0/0       201             Serial0/2       102             active \\如果处于inactive状态,可能是dte路由器没有起来,排查步骤1、sh ip int bri 2、sh ip int 接口 3、debug fram lmi看
    Serial0/0       203             Serial0/1       302             active    动态数据报交流过程。
    Serial0/1       301             Serial0/2       103             active
    Serial0/1       302             Serial0/0       203             active
    Serial0/2       102             Serial0/0       201             active
    Serial0/2       103             Serial0/1       301             active
    frame-sw#





    3、查看帧中继路由器映射表

    R1#sh fram map
    Serial0/1 (up): ip 10.10.10.2 dlci 102(0x66,0x1860), static,
                  broadcast,
                  CISCO, status defined, active
    Serial0/1 (up): ip 10.10.10.3 dlci 103(0x67,0x1870), static,
                  broadcast,
                  CISCO, status defined, active

    R2#show frame-relay map
    Serial0/0 (up): ip 10.10.10.1 dlci 201(0xC9,0x3090), static,
                  broadcast,
                  CISCO, status defined, active
    Serial0/0 (up): ip 10.10.10.3 dlci 203(0xCB,0x30B0), static,
                  broadcast,
                  CISCO, status defined, active

    R3#show frame-relay map
    Serial0/0 (up): ip 10.10.10.1 dlci 301(0x12D,0x48D0), static,
                  broadcast,
                  CISCO, status defined, active
    Serial0/0 (up): ip 10.10.10.2 dlci 302(0x12E,0x48E0), static,
                  broadcast,
                  CISCO, status defined, active


    4、检查帧中继静态映射结果:两两路由器接口ip都可以互ping (略)。



    B、帧中继点到点技术,

    1、点到点全拓扑互联





    帧中继交换机的配置与上面一样。


    R4#

    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay lmi-type cisco
    !
    interface Serial0/0.1 point-to-point  \\指定点到点,如果只有一条pvc(即两个路由互联)可以不分接口,而直接使用点到点物理接口,结果一个样。
     ip address 10.10.10.1 255.255.255.0
     frame-relay interface-dlci 102   \\经实训发现点到点模式下此步必须配置,即便开启动态映射,路由器DTE已成功获得dlci,但pvc中的两个路由器仍然无法通讯,sh fram map 发现其实不存在映射关系。
    !
    interface Serial0/0.2 point-to-point
     ip address 10.10.12.1 255.255.255.0
     frame-relay interface-dlci 103



    R5# 

    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay lmi-type cisco
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.10.2 255.255.255.0
     frame-relay interface-dlci 201   
    !
    interface Serial0/0.2 point-to-point
     ip address 10.10.11.1 255.255.255.0
     frame-relay interface-dlci 203 



    R6#

    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay lmi-type cisco
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.11.2 255.255.255.0
     frame-relay interface-dlci 302   
    !
    interface Serial0/0.2 point-to-point
     ip address 10.10.12.2 255.255.255.0
     frame-relay interface-dlci 301   
    !



    2、查看帧中继路由器映射表

    R4#sh fram map
    Serial0/0.1 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
              status defined, active
    Serial0/0.2 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
              status defined, active

    R5#sh fram map
    Serial0/0.2 (up): point-to-point dlci, dlci 203(0xCB,0x30B0), broadcast
              status defined, active
    Serial0/0.1 (up): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast
              status defined, active

    R6#sh fram map
    Serial0/0.2 (up): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
              status defined, active
    Serial0/0.1 (up): point-to-point dlci, dlci 302(0x12E,0x48E0), broadcast
              status defined, active


    ny以上是点到点分开配置的,其实在复杂的拓扑中点到点、点到多点是合在一起配置的,两者并不冲突。













    展开全文
  • 可以肯定,不论是在实验室里还是在其他的地方,帧中继交换机都是很有用的设备。...从本质上来说,帧中继交换技术是—种基于数据链路连接标识(DLCI)的帧交换技术。在路由器的帧中继ARP表中,DLCI号是与接口关联的。帧中
  • 帧中继网络基本配置

    2021-01-07 04:02:18
    帧中继网络基本配置 R1: interface Serial1/0/0 link-protocol fr undo fr inarp //关闭反向ARP,手工配置映射信息 fr map ip 10.10.123.2 102 broadcast //IP地址为对端,DLCI号为本端 fr map ip 10.10.123.3 103 ...
  • 11.3 帧中继基本配置

    千次阅读 2021-11-16 15:29:30
    帧中继(Frame Relay)是一种面向连接的数据链路层技术,主要用在公共或专用网上的局域网互联以及广域网连接。 帧中继协议是一种简化的2.5X的广域网协议,它在控制层面上提供虚电路的管理、带宽管理和防止阻塞等...

    原理概述

            帧中继(Frame Relay)是一种面向连接的数据链路层技术,主要用在公共或专用网上的局域网互联以及广域网连接。

            帧中继协议是一种简化的2.5X的广域网协议,它在控制层面上提供虚电路的管理、带宽管理和防止阻塞等功能。在传送数据时使用的传输链路是逻辑连接,而不是物理连接。在一个物理连接上可以复用多个逻辑连接,实现带宽的复用和动态分配,帧透明传输和错误检测,但不提供重传操作。与传统的电路交换相比,帧中继网络有利于多用户、多速率数据的传输,也充分利用了网络资源。

            帧中继网络两端的设备用虚电路来连接。每条虚电路是用数据链路连接标识符定义的一条帧中继连接通道,提供了用户设备(如路由器和主机等)之间进行数据通信的能力。帧中继网络的相关术语如下:

            ●DTE(Data Terminal Equipment,数据终端设备):通常指用户侧的主机或终端等;

            ●DCE(Data Circuit-terminating Equipment,数据电路终结设备):为用户设备提供接入的设备,属于网络设备,如帧中继交换机;

            ●DLCI(Data Link Connection Identifier,数据链路连接标识):虚链路接口的标识。帧中继能够在单一物理传输线路上提供多条虚电路,虚电路通过DLCI来区分;

            ●PVC(Permanent Virtual Circuit,永久虚电路):永久虚电路是指给用户提供固定的虚电路,该电路一旦建立,则链路永远生效,除非管理员手动删除。PVC用于两端之间频繁的、流量稳定的数据传输。

            逆向地址解析协议(Inverse ARP)的主要功能是求解每条虚电路连接的对端设备的IP地址。如果知道了某条虚电路连接的对端设备的IP协议地址,在本地就可以生成对端IP地址与DLCI的映射(MAP),从而避免手工配置地址映射。

    实验目的

    •         掌握帧中继交换机的配置
    •         掌握动态映射的配置
    •         掌握静态映射的配置
    •         掌握子接口和DLCI的映射配置

    实验内容

            本实验模拟企业网络场景。公司A的总部和分部分别设在不同地方,总部路由器R1和分部路由器R2通过帧中继网络相连,总部与分部之间申请了一条PVC。由于业务的发展,公司A与公司B有了密切的业务来往,公司B路由器R3也采用帧中继并使用动态映射方式与公司A相连,即只能与公司A总部直接通信。现需要采用帧中继子接口配置和静态路由使R3能通过R1访问R2,实现全网全通。

    实验编址

    设备接口  IP地址子网掩码默认网关DLCI
    R1Serial 1/0/011.1.1.1255.255.255.0N/A102
    Serial 1/0/0.122.1.1.1255.255.255.0N/A103
    R2Serial 1/0/011.1.1.2255.255.255.0N/A201
    R3Serial 1/0/022.1.1.3255.255.255.0N/A301

    实验拓扑

    实验步骤

    1.基本配置 

            根据实验编址表进行相应的基本IP地址配置。

            在帧中继交换机上配置两条PVC,R1和R2一条,R1和R3一条。

            ⑴在帧中继交换机上建立一条PVC,这条PVC在 S0/0/1 接口上分配DLCI为102,在 S0/0/2 接口上分配DLCI201,二者同属一条PVC。如下图:

    ⑵ 在帧中继交换机上建立另一条PVC,这条PVC在S0/0/1接口上分配DLCI为103,在S0/0/3接口上分配DLCI 301,二者同属于另一条PVC。如下图:

    2.静态与动态映射的配置

            帧中继接口在转发数据包时必须查找帧中继地址映射表来确定下一跳的 DLCI 。地址映射表中存放对端IP地址和下一跳的DLCI的映射关系。只有找到相应的映射表项,才能完成二层帧中继报头的封装,这个机制类似于以太网中的ARP机制。该地址映射表可以手动配置(静态),也可以使用Inverse ARP协议来自动建立(动态)。

            公司A总部使用动态映射,在R1的S1/0/0接口配置链路层协议为FR,并使用 fr inarp 命令允许帧中继逆向地址解析功能自动生成地址映射表。 

            [R1]int s1/0/0
            [R1-Serial1/0/0]link-    
            [R1-Serial1/0/0]link-protocol fr
            Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N] :y
            [R1-Serial1/0/0]fr inarp

            注意,默认情况下,串行接口使用的链路层协议为PPP,当试图改变接口默认的封装方式的时候,路由器会弹出一个警告,输入“y”即可。此外,帧中继接口的逆向地址解析功能默认是开启的,所以  fr inarp 命令可以不配置。

            公司A分部由于只需要与总部通信即可,使用静态映射,在R2的S1/0/0接口下配置链路层协议为FR,关闭逆向解析功能,使用 fr map ip 命令手工配置R1的IP地址与DLCI的静态映射。

            [R2]int s1/0/0
            [R2-Serial1/0/0]link-protocol fr
            Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y 
            [R2-Serial1/0/0]undo fr inarp 
            [R2-Serial1/0/0]fr map ip 11.1.1.1 201

            将R1的IP地址与R2本端DLCI 201 配置为一条静态地址映射,即R2通过下一跳DLCI 201来访问R1。

            默认情况下,帧中继不支持广播或组播数据的转发。如果需要在帧中继上运行一些动态路由协议,比如OSPF协议,需要在静态映射后面添加broadcast参数,从而使PVC能够正常发送来自路由协议的广播或组播流量。

            [R2-Serial1/0/0]fr map ip 11.1.1.1 201 broadcast 

            配置完成后,在R1与R2上使用 display fr pvc-info 命令查看PVC的建立情况。

            <R1>dis fr pvc-info
            PVC statistics for interface Serial1/0/0 (DTE, physical UP) 
               DLCI = 102, USAGE = UNUSED (00000000), Serial1/0/0
                create time = 2021/11/16 16:34:42, status = ACTIVE
                InARP = Enable, PVC-GROUP = NONE
                in packets = 6, in bytes = 2018634629120
                out packets = 23, out bytes = 980
     
                DLCI = 103, USAGE = UNUSED (00000000), Serial1/0/0
                create time = 2021/11/16 16:50:52, status = ACTIVE
                InARP = Enable, PVC-GROUP = NONE
                in packets = 0, in bytes = 0
                out packets = 1, out bytes = 30

            <R2>dis fr pvc-info 
            PVC statistics for interface Serial1/0/0 (DTE, physical UP) 
                DLCI = 201, USAGE = LOCAL (00000100), Serial1/0/0
                create time = 2021/11/16 16:41:22, status = ACTIVE
                InARP = Disable, PVC-GROUP = NONE
                in packets = 15, in bytes = 3178275799040
                out packets = 6, out bytes = 470

            可以观察到,R1上有两条PVC,R2上有一条PVC,都为激活状态。

            使用ping命令测试R1与R2之间的连通性:通信正常。

            <R1>ping 11.1.1.2
              PING 11.1.1.2: 56  data bytes, press CTRL_C to break
                Reply from 11.1.1.2: bytes=56 Sequence=1 ttl=255 time=20 ms
                Reply from 11.1.1.2: bytes=56 Sequence=2 ttl=255 time=30 ms
                Reply from 11.1.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms
                Reply from 11.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
                Reply from 11.1.1.2: bytes=56 Sequence=5 ttl=255 time=1 ms

    3.子接口配置和静态路由

            由于业务需要,公司B需要和公司A互相通信。

            公司B和公司A总部之间互联IP网段使用22.1.1.0/24。在R3的 S1/0/0 接口配置链路层协议为 FR,并保持默认开启的逆向地址解析功能。

            [R3]int s1/0/0
            [R3-Serial1/0/0]link-protocol fr
            Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y

            配置完成后,在R3上使用display fr pvc-info 命令查看PVC建立情况。

            <R3>dis fr pvc-info 
            P VC statistics for interface Serial1/0/0 (DTE, physical UP) 
                DLCI = 301, USAGE = UNUSED(00000000), Serial1/0/0
                create time = 2021/11/16 17:10:51, status = ACTIVE
                InARP = Enable, PVC-GROUP = NONE
                in packets = 4, in bytes = 515396075520
                out packets = 4, out bytes = 120

            可以观察到,R3的PVC已经激活。

            为实现与R1的互通,需要在R1上创建子接口 S1/0/0.1 ,配置与R3同网段的IP地址,并手工指定本地DLCI配置虚电路。

            [R1]int s1/0/0.1
            [R1-Serial1/0/0.1]ip address 22.1.1.1 24
            [R1-Serial1/0/0.1]fr dlci 103 

            默认情况下,帧中继交换机分配的DLCI都关联到用户设备的物理接口上,而子接口关联的DLCI需要手动指定。

            配置完成后,测试R1与R3之间能否正常通信。

            <R1>ping 22.1.1.3
              PING 22.1.1.3: 56  data bytes, press CTRL_C to break
                Reply from 22.1.1.3: bytes=56 Sequence=1 ttl=255 time=40 ms
                Reply from 22.1.1.3: bytes=56 Sequence=2 ttl=255 time=20 ms
                Reply from 22.1.1.3: bytes=56 Sequence=3 ttl=255 time=20 ms
                Reply from 22.1.1.3: bytes=56 Sequence=4 ttl=255 time=30 ms
                Reply from 22.1.1.3: bytes=56 Sequence=5 ttl=255 time=20 ms

            可以观察到,R1与R3已经正常通信。测试R2与R3间能否正常通信。

            <R3>ping 11.1.1.2
              PING 11.1.1.2: 56  data bytes, press CTRL_C to break
                Request time out
                Request time out
                Request time out
                Request time out

            无法正常通信。这是因为R2与R3不在同一个网段上,需要有到达对方的路由才能连通。

            为了使R2与R3之间能够互相通信,在R3上配置静态路由,目的地址为R2,下一跳为R1的子接口;同样在R2上也需要配置静态路由,目的地址为R3,下一跳为R1的S1/0/0接口地址。

            [R3]ip route-static 11.1.1.2 32 22.1.1.1

            [R2]ip route-static 22.1.1.3 32 11.1.1.1

            再次测试R2与R3之间的连通性。

            [R2]ping 22.1.1.3
              PING 22.1.1.3: 56  data bytes, press CTRL_C to break
                Reply from 22.1.1.3: bytes=56 Sequence=1 ttl=254 time=20 ms
                Reply from 22.1.1.3: bytes=56 Sequence=2 ttl=254 time=30 ms
                Reply from 22.1.1.3: bytes=56 Sequence=3 ttl=254 time=40 ms
                Reply from 22.1.1.3: bytes=56 Sequence=4 ttl=254 time=20 ms
                Reply from 22.1.1.3: bytes=56 Sequence=5 ttl=254 time=30 ms

            可以发现,R3与R1之间可以正常通信。使用 tracert 命令查看它们之间的路径。

            [R2]tracert 22.1.1.3

             traceroute to  22.1.1.3(22.1.1.3), max hops: 30 ,packet length: 40,press CTRL_C
             to break 

             1 11.1.1.1 30 ms  20 ms  20 ms 

             2 22.1.1.3 30 ms  20 ms  30 ms 

            [R3]tracert 11.1.1.2

             traceroute to  11.1.1.2(11.1.1.2), max hops: 30 ,packet length: 40,press CTRL_C
             to break 

             1 22.1.1.1 20 ms  20 ms  20 ms 

             2 11.1.1.2 30 ms  20 ms  20 ms 

            观察发现,R3和R2之间的流量经过了R1。至此,公司A与公司B所有的设备间都能够正常通信。

            

    展开全文
  • 帧中继交换机的配置

    2017-11-15 00:00:00
    可以肯定,不论是在实验室里还是在其他的地方,帧中继交换机都是很有用的设备。就像引导寄存器一样,帧中继交换机的设置也是路由器设置中非常精深的内容之一。学会如何配置帧中继交换机,就能够建立很多不同的网络模型。...
  • FR(帧中继)1.2 术语1.3 帧中继的接口类型1.4 虚电路1.5 LMI协议LMI的协商过程LMI的版本Inverse ArpInverse arp的协商过程FR通信的条件1.6 帧中继交互流程分析1.7 帧中继运行路由协议注意事项1.7.1 RIP1.7.2 OSPF2...
  • 帧中继原理浅谈

    万次阅读 多人点赞 2017-06-08 11:58:34
    帧中继技术,在有些时候似乎比较容易让人感到模糊,今天来谈一下它的几个基本概念,DLCI、二层映射以及三种接口类型。 一、DLCI在谈DLCI前,先稍微介绍一下帧中继帧中继是一种使用了包交换方式的标准的广域网技术...
  • 转载于:https://www.cnblogs.com/fanweisheng/p/11168311.html
  • HDLC PPP FR(帧中继

    千次阅读 2021-07-24 07:55:03
    3.2.5 DLCI(帧中继数据链路标识) 帧中继DLCI标识不同的虚电路,DLCI只在本地接口和与之直接相连的对端接口有效,只具有本地意义,不具有全局有效性。 在帧中继网络中,不同的物理接口上相同的DLCI并不表示是同一...
  • 帧中继 通信原理分析

    千次阅读 2018-10-27 21:53:10
    Frame-relay(帧中继)是广域网二层的分组交换技术 首先来看看专线和Frame-relay的区别 如图,如果公司总部需要和3个分部通信, 上面的网络拓扑是使用专线,下面的网络拓扑是使用Frame-relay 使用Frame-relay...
  • 帧中继(Frame relay /FR)

    千次阅读 2020-12-20 21:58:56
    帧中继(Frame relay /FR) 基础知识 (1)OSI模型中,它处于第二层。它是一个二层协议。 (2)一般使用星型拓扑 一台路由器作为Hub节点,多台路由器作为Spoke节点 它们之间连通需要帧中继交换机,也就是运营商端帮...
  • 帧中继的简单配置

    2022-02-22 18:14:02
    帧中继的简单配置 帧中继网络(DBMA)不支持组播和广播,并且是通过vc虚拟链路互联 虚链路通过DLCI标识,可以粗略的理解成mac地址,是唯一的,fr交换机通过与路由器之间的映射进行互通 当rt1发送数据帧给rt2时,可以...
  • 我们都知道,帧中继直接运行ospf存在问题,这个问题原理: ​ `如果二层为帧中继,默认为NBMA网络,需要手动指邻居,因为不支持广播和组播` 那我们就以帧中继作为二层链路,看ospf几种特殊的网络类型如何配置
  • 帧中继实验

    千次阅读 2014-08-01 19:41:21
    一、在Packet Tracer上边画好拓扑,并配置好模块和帧中继DLCI  先看下配好的拓扑图:  配置过程:  1、添加3台路由器,我用的是2811,为路由器添加S端口模块,我用的是NM-4A/S模块。  2、添加一个Cloud...
  • 帧中继交换机用R3模拟。R1:DLCI 103R2:DLCI 301命令:R1:r1(config)#int s0/0r1()#ip add 192.168.1.1 255.255.255.0r1(config-if)#no shr1(config-if)#encapsulation frame-relayr1(config-if)#frame-relay ...
  • 原理概述 OSPF将网络分为4种不同的类型,即Point-to-Point、Broadcast、NBMA 及Point-to-MultiPoint,不同网络...在帧中继的环境中,OSPF默认的网络类型是NBMA。 实验目的 掌握OSPF在帧中继网络中的配置方法 ...
  • 文章目录一、帧中继云是什么?二、使用步骤1.搭建网络拓扑图2.配置网络设备各端口IP地址3.配置静态路由(使目标可达)4.配置中继云5.对接中继云接口(使网络连通)6.执行ping测试(测试线路的连通性) 一、帧中继云...
  • 目录一、帧中继网络的定义二、三、结语 一、帧中继网络的定义 二、 三、 结语 以上就是本次计算机网络华为eNSP模拟器实验的的全部内容,篇幅较长,感谢您的阅读和支持,若有表述或代码中有不当之处,望指出!您的...
  • ppp-帧中继

    2020-08-30 19:51:32
    目录ppppap协议chap协议帧中继frame routefr地址映射 ppp ppp的组件 lcp链路控制协议 ncp网络控制协议 认证协议:两个工作协议,pap和chap 会话建立: 链路建立和配置协商,主要是lcp完成的,比如mtu大小,是否...
  • 帧中继PVC使用 数据链路连接标识符 (Data Link Connection Identity,DLCI[帧标记])标识DTE设备 控制时钟频率的是DCE,被动端设备DTE -----------------------------             ...
  • 帧中继技术介绍-ielab

    2019-07-22 15:00:40
    帧中继地址映射 帧中继地址映射是把对端设备的协议地址与对端设备的帧中继地址(本地的DLCI)关联起来,使高层协议能通过对端设备的协议地址寻址到对端设备。 帧中继主要用来承载IP协议,在发送IP报文时,根据...
  • 在串口链路中link-protocol还可以配置成fr,即使用帧中继,现在对帧中继进行学习。 帧中继技术是在数据链路层用简化的方法传送和交换数据单元的快速分组交换技术。帧中继技术是在分组交换技术充分发展,数字与光纤...
  • 第 18章虚电路网络:帧中继和ATM 在第 8章中,我们已讨论了交换技术。我们说过有三种交换技术 1 电路交换、分组交换和 报文交换。我们也提到分组交换可以使用两种方法:虚电路方岳和数据报方法。 在本章中,我们讨论虚...
  • Ensp实验随心记——帧中继

    千次阅读 2020-08-04 01:03:25
    理论才是实验的关键,学好理论再看实验,才知所以然。实验有步骤顺序性,愿意学能看懂的。有错误请批评指正。 FR动态映射静态映射 动态映射 先配置R1和R2 通讯是双向的。所以 ...这两行命令是缺省配置,...将自己的DLCI
  • 华为路由器--帧中继

    千次阅读 2020-04-20 19:26:50
    帧中继网络 帧中继FR(Frame Relay)协议工作在数据链路层。 用户设备称作数据终端设备 DTE(Data Terminal Equipment) 为用户提供接入的设备为网络设备,称为数据电路终结设备DCE(Data Circuit-terminating Equipment...
  • 每个帧中继用户将得到一个接到帧中继节点的专线。帧中继网络对于端用户来说,它通过一条经常改变且对用户不可见的信道来处理和其他用户间的数据传输 实验目的 掌握帧中继交换机的配置 掌握动态映射的配置 掌握静态...
  • 帧中继网络与NBMA/P2MA

    2022-08-06 09:32:00
    帧中继网络模拟出NBMA/P2MA两种网络类型。
  • DLCI 简介

    2019-10-03 12:40:36
     帧中继协议是一种统计复用的协议,它在单一物理传输线路上能够提供多条虚电路。每条虚电路都是用DLCI(Data Link Connection Identifier)来标识。虚电路是面向连接的,它将用户数据帧按顺序传送至目的地。从建立...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,998
精华内容 799
热门标签
关键字:

帧中继dlci