一、开篇

帧中继在现在来说,虽然是一个过时的技术,但是它毕竟占据了很长一段时间的历史舞台,毕竟有它存在的价值,而且在以后开发的新技术中主要用的也是帧中继的原理,所以了解和学习帧中继是很有必要的

二、通过ARP自动的让DLCI和IP地址之间形成映射

1、默认情况下帧中继网络使用反向ARP进行DLCI和IP地址之间的映射

2、只需要在路由器和帧中继交换机之间的接口下面开启封装

interface s1/0

encapsulation frame-relay


show frame-relay map 查看DLCI和IP地址之间的映射


三、手动去配置DLCI和ip地址的映射

1、为了避免自动映射造成的可控性太差,我们需要手动的对DICI和IP地址之间进行映射,这样我们就要去关闭反向ARP

interface s1/0在所有的路由器与帧中继交换机之间的接口上

no frame-relay iverse-arp关闭反向arp


clear frame-relay inarp清空之前制动映射留下的缓存


2、手动的去配置映射

frame-relay map ip 对方的IP 自己对应对方的DLCI

frame-relay map ip 192.168.1.2 102 broadcast

frame-relay map ip 192.168.1.3 103 broadcast


3、拓扑图及配置

225940312.png

225942449.png



R1:

interface s1/0

encapsulation frame-relay在接口下封装协议

no frame-relay iverse-arp关闭反向ARP

frame-relay map ip 192.168.1.2 102 broadcast 手动配置映射

frame-relay map ip 192.168.1.3 103 broadcast

R2:

interface s1/0

encapsulation frame-relay

no frame-relay iverse-arp

frame-relay map ip 192.168.1.1 201 broadcast

R3:

interface s1/0

encapsulation frame-relay

no frame-relay iverse-arp

frame-relay map ip 192.168.1.1 301 broadcast

现在只有两条PVC,所以R2和R3之间不能建立PVC,默认是不能够通信的

R1(DLCI:102)-----------------------R2(DLCI:201)

R1(DLCI:103)-----------------------R3(DLCI:301)

4、多路复用技术

在R2和R3不能建立PVC的情况下,我们要让它们之间能够通信,则需要使用多路复用技术,将到达对方的流量通过R1进行传输

R2:

frame-relay map ip 192.168.1.1 201 broadcast

frame-relay map ip 192.168.1.3 201 broadcast

R3:

frame-relay map ip 192.168.1.2 301 broadcast

frame-relay map ip 192.168.1.1 301 broadcast


5、帧中继网络和多路复用之间的冲突

如果我们要在帧中继路由器上运行距离矢量路由协议,当路由流量通过帧中继网络传输到一个多路复用的接口上(一个物理接口承载多条逻辑链路)的时候,由于水平分割原则,从一个接口上学习到的路由不能在从这个接口发送出去,可能会导致spoke路由器学到的路由不完整

解决办法:

第一种办法:对于RIP,帧中继网络的水平分割已经默关闭,但是对于EIGRP默认是开启的,第一种解决办法就是关闭水平分割

第二种办法,划分逻辑子接口,这样既不会违背水平分割的原则,也不会影响路由器端到端的连通性问题

6、子接口的配置

子接口的封装和反向ARP的关闭都是在物理接口上进行的,下面的子接口会自动去继承

R1:

interface s1/0

no ip address

no shutdown

encapsulation frame-relay

no frame-relay iverse-arp

interface s1/0.1 point-to-point

ip address 192.168.1.1 255.255.255.252

frame-relay interface-dlci 102

interface s1/0.2 point-to-point

ip address 192.168.1.5 255.255.255.252

frame-relay interface-dlci 103

R2:

interface s1/0

ip address 192.168.1.2 255.255.255.252

no shudown

encapsulation frame-relay

no frame-relay iverse-arp

frame-relay map ip 192.168.1.1 201 broadcast

R3:

interface s1/0

ip address 192.168.1.6 255.255.255.252

no shudown

encapsulation frame-relay

no frame-relay iverse-arp

frame-relay map ip 192.168.1.5 301 broadcast



7、还原接口的默认配置

如果需要清空之前在接口上的配置可以使用一下命令

conf t

defalut interface s1/0 将这个接口恢复到初始化配置