精华内容
下载资源
问答
  • OSPF路由协议详解

    万次阅读 多人点赞 2019-06-18 16:44:48
    无类别链路状态路由协议,组播更新224.0.0.5/6;跨层封装到三层,协议号89; 基于拓扑工作,故更新量大-----需要结构化部署–区域划分、地址规划 触发更新、每30min周期更新 OSPF的数据包: Hello包 DBD–数据库描述...

    OSPF:开放式最短路径优先协议
    无类别链路状态路由协议,组播更新224.0.0.5/6;跨层封装到三层,协议号89;
    基于拓扑工作,故更新量大-----需要结构化部署–区域划分、地址规划
    触发更新、每30min周期更新

    OSPF的数据包:
    Hello包
    DBD–数据库描述包
    LSR–链路状态请求
    LSU–链路状态更新 携带各种LSA
    LSack–链路状态确认
    在这里插入图片描述

    状态机----OSPF建立时,存在各个阶段;
    1、down 本地一旦发出hello包进入下一状态
    2、Init初始化 本地接收到的hello包存在本地的RID进入下一状态
    3、2way双向通信 邻居关系建立标志;
    条件匹配:点到点网络直接进入下一状态;MA网络将进行DR/BDR选举(40S),非DR/BDR间不得进入下一状态;
    4、exstart 预启动 使用类似hello的DBD进行主从关系选举,RID大为主,主优先进入下
    一状态
    5、Exchange 准交换 使用真实的DBD包进行数据库目录共享,需要ACK;
    6、Loading 加载 使用LSR/LSU/LSack来获取未知的LSA信息;
    7、Full转发 邻接关系建立的标志

    OSPF工作过程:
    启动配置完成后,本地使用hello包建立邻居关系,生成邻居表;
    进行条件匹配,匹配失败者间保持为邻居关系,仅hello包周期保活即可;
    匹配成功者间,将使用DBD/LSR/LSU/LSack来获取未知的LSA信息,当收集其网络中所有LSA后,生成LSDB–数据表;之后使用最短路径算法,计算本地到达所有未知网段的最佳路由,然后将其加载路由表中,收敛完成。
    结构突变—1、新增网段 发送新的DBD 未知设备会使用LSR获取
    2、断开网段 发送新的DBD 未知设备会使用LSR获取

    名词:
    LSA–链路状态通告 —存在多种类别,携带不同环境下产生的拓扑或路由信息;该信息依赖
    LSU数据包传递;
    LSDB–链路状态数据库 —各种的LSA的集合
    OSPF的收敛行为------LSA洪泛 LSDB同步

    配置:
    r1(config)#router ospf 1 启动OSPF协议,启动时需要配置进程号,进行号仅具有本地意义
    r1(config-router)#router-id 1.1.1.1 全网唯一,手工–环回最大数值–物理接口最大数值
    宣告:1、激活 2、路由或拓扑 3、区域划分
    r1(config-router)#network 12.1.1.1 0.0.0.0 area 0
    r1(config-router)#network 1.1.1.1 0.0.0.0 area 0
    宣告时必须携带反掩码

    区域划分规则:
    1、星型结构
    2、必须存在ABR-边界路由器

    【1】当启动配置完成后,邻居间使用hello包建立邻居关系,生成邻居表:
    Hello包–用于邻居的发现、关系、保活
    hello time为10s或30s dead time 为hello time 的4倍;
    在这里插入图片描述

    Hello包中和邻居必须完全一致的参数:hello time和dead time
    区域ID
    认证字段
    末梢区域标记
    r2#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    1.1.1.1 0 FULL/ - 00:00:39 12.1.1.1 Serial1/0
    3.3.3.3 0 FULL/ - 00:00:38 23.1.1.2 Serial1/1
    状态机
    【2】邻居关系建立后,进行条件匹配,匹配失败保持为邻居关系,仅hello包保活
    匹配成功成为邻接关系,将使用DBD/LSR/LSU/LSACK来获取未知的LSA信息,生成数据库表:
    DBD:携带MTU值;强制邻居间MTU值必须一致,否则卡在exstart或exchange状态;
    DBD包中的描述字段:I 为1标示该包为本地发出的第一个DBD包
    M为0标示该包为本地发出的最后一个DBD包
    MS为1标示本地为主;
    隐性确认:从使用主的序列号来对主进行确认;

    r1#show ip ospf database 查看数据库简表
    OSPF存在各种类别的LSA,简表内仅记录分类的基础信息;

    【3】OSPF协议在生成好数据库表后,将基于最短路径规则将最佳路径加载到本地的路由表中
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2

    O标示本地区域内的路由–本地基于拓扑计算所得
    O IA 标示其他区域的路由通过ABR导入 --域间路由
    O E1/2 标示通过其他协议或进程计算所得,之后ASBR重发布导入 域外路由
    ON1/2 标示通过其他协议或进程计算所得,之后ASBR重发布导入,同时本地为NSSA或完
    全NSSA区域 -----域外路由

    管理距离为110;度量为cost=开销值=参考带宽/接口实际带宽
    Ospf选路,就是选择cost值之和最小路径;默认参考带宽为100M;若接口带宽大于参考带宽,将可能导致选路不佳,可以修改参考带宽
    r1(config)#router ospf 1
    r1(config-router)#default auto-cost reference-bandwidth ?
    <1-4294967> The reference bandwidth in terms of Mbits per second
    r1(config-router)#default auto-cost reference-bandwidth 1000
    注:所有设备均需修改;

    【4】OSPF建立邻接关系的条件
    网络类型:点到点网络类型 ----必然成为邻接关系
    MA----进行DR/BDR选举,所有非DR/BDR仅与DR/BDR建立邻接关系;非DR/BDR间正常保持为邻居关系;
    选择规则:1、比较接口优先级,默认为1,大优;
    2、若优先级相同,比较RID,数值大优;

    干涉选举:
    1、DR优选级最大,BDR次大;DR选择为非抢占,故修改优先级后,正常需要重启OSPF进程
    r1(config)#interface fastEthernet 0/0
    r1(config-if)#ip ospf priority 3
    r1#clear ip ospf process
    Reset ALL OSPF processes? [no]: yes
    2、DR优选级最大,BDR次大;其他设备优先级修改为0,标示不参选;
    切记:不能将所有参选接口优先级修改为0;

    【5】OSPF接口网络类型
    设备接口网络类型: 环回 点到点 BMA NBMA
    所谓的OSPF接口网络类型,是指OSPF协议在设备不同网络类型下的不同工作方式;

    设备接口网络类型 OSPF 接口网络类型(工作方式)
    环回接口 LOOPBACK LOOPBACK 无hello包,发送32位主机路由
    串口(HDLC/PPP)点到点 POINT_TO_POINT hello time 10s;不选DR;
    以太网接口 BMA BROADCAST hello time 10s;选DR;

    MGRE NBMA
    注:在tunnel接口上,OSPF默认的工作方式为点到点;这种工作方式在MGRE环境下,将无法正常建立邻居关系—因为点到点工作方式只能和一个邻居建邻;
    可以将接口工作方式修改为BROADCAST;切记BROADCAST和POINT_TO_POINT工作方式均为10s的hello time,故能够建立邻居关系,但由于一个选DR,另一个不选,不能正常收敛路由;
    r2(config)#interface tunnel 0
    r2(config-if)#ip ospf network broadcast
    注:若ROADCAST的工作环境为星型或部分网状结构都可能出现DR位置错误问题;
    必须修改DR的位置到最合适的地方;

    建议:
    1、在星型结构中可以定义为broadcast 类型,但注意DR位置;或修改为点到多点工作方式;
    2、在部分网状结构中直接定义为点到多点
    3、在全连网状建议broadcast ;
    r1(config)#interface tunnel 0
    r1(config-if)#ip ospf network point-to-multipoint

    点到多点工作方式:hello time 为30s;不选DR;
    2、不连续骨干

    解决方法:
    1、tunnel --在两台ABR上建立tunnel,然后将其宣告到OSPF协议中;
    缺点:选路不佳,对中间区域周期、触发占用;

    2、OSPF虚链路—相当于OSPF关闭了区域限制;
    在两台ABR上配置,然后骨干区域的ABR为非骨干区域间的ABR授权;
    R2(config)#router ospf 1
    R2(config-router)#area 1 virtual-link 4.4.4.4
    优点:选路正常,为减少对中间区域的资源占用,取消所有周期信息–hello、更新
    缺点:不可靠

    3、多进程双向重发布 --在一台设备启动多个进程时,每个进程为独立协议,用于自己的RID,自己的数据库和邻居关系,这些数据库不共享,仅将所以计算所得路径加载到同一张路由表中;若多个进程工作于同一接口上,仅最先启动进程生效;
    R4(config)#router ospf 1
    R4(config-router)#redistribute ospf 2 subnets
    R4(config-router)#exit
    R4(config)#router ospf 2
    R4(config-router)#redistribute ospf 1 subnets

    二、OSPF的数据库表 -----该表格由各种类别的LSA组成;
    所有类别LSA均存在以下参数:
    LS age: 119 老化时间,周期1800s归0,触发更新归0;最大老化3609;
    Options: (No TOS-capability, DC)
    LS Type: Router Links 类别名,此处为1类;
    Link State ID: 1.1.1.1 link-id—目录中番号
    Advertising Router: 1.1.1.1 通告者的RID;
    LS Seq Number: 80000003
    Checksum: 0x67F8
    Length: 60
    Number of Links: 3

               传播范围               通告者              携带信息 
    

    LSA1 Router 单区域(本区域) 本区域内所有设备 本地直连拓扑
    LSA2network 本区域 DR MA部分的拓扑
    LSA3Summary 整个OSPF区域 ABR O IA 域间路由
    LSA4 asbr-summary 除ASBR所在区域 ABR ASBR的位置
    外的整个OSPF区域
    和ASBR同区域的设备是通过1类来获取ASBR位置;
    LSA5 external 整个OSPF区域 ASBR O E 域外路由
    LSA7 nssa-external NSSA区域 ASBR O N 域外路由

             LINK ID(目录中的番号)            通告者     
    

    LSA1 通告者的RID 本地区域内所有设备
    LSA2 DR接口IP地址 DR
    LSA3 IA 路由目标 ABR,在经过下一个ABR时修改为本地
    LSA4 ASBR的RID ABR,在经过下一个ABR时修改为本地
    LAS5 E 路由目标 ASBR
    LSA7 N 路由目标 ASBR

    三、优化,减少OSPF的LSA的更新量
    【1】汇总 --减少骨干区域的LSA量
    (1)域间汇总–只能在ABR上操作
    r1(config)#router ospf 1
    r1(config-router)#area 2 range 5.5.4.0 255.255.254.0
    通过本区域内1/2类LSA计算所得
    (2)域外汇总–在ASBR上操作
    r4(config)#router ospf 1
    r4(config-router)#summary-address 99.1.0.0 255.255.252.0

    【2】特殊区域—减少非骨干区域
    不得为骨干区域,不能存在虚链路;

    (1)不存在ASBR
    {1}末梢区域----拒绝4/5的LSA,自动产生一条3类的缺省路由指向骨干
    r5(config)#router ospf 1
    r5(config-router)#area 2 stub 本区域内所有设备均需配置

    {2}完全末梢区域----在末梢区域的基础上进一步拒绝3类的LSA,仅保留一条3类缺省
    先将整个区域配置为末梢区域,然后仅在ABR上定义完全即可
    r1(config-router)#area 2 stub no-summary

    (2)存在ASBR
    {1}NSSA ----非完全末梢区域
    拒绝4/5的LSA,本区域ASBR产生的5类使用7类传输;7类LSA在离开本区域时被ABR修改为5类;不会自动产生缺省;
    作用:拒绝网络中其他区域的ASBR产生的4/5的信息;但为了避免环路产生,故不自动产生缺省,在管理员确定无环的前提下可以手工添加缺省路由;
    r3(config)#router ospf 1
    r3(config-router)#area 1 nssa

    {2}完全NSSA
    在NSSA的基础上进一步拒绝3类LSA;自动产生3类的缺省指向区域0;
    先将该区域配置为NSSA,然后仅在ABR上定义完全即可
    r3(config-router)#area 1 nssa no-summary

    四、OSPF的扩展配置
    1、认证
    【1】接口认证
    1)接口明文
    r1(config)#interface ethernet 0/0
    r1(config-if)#ip ospf authentication 开启明文认证需求,开启后本地所有ospf数据包中认证类型字段被修改,邻居间若不一致将不能建立邻居关系
    r1(config-if)#ip ospf authentication-key cisco123 配置明文密码

    2)接口密文
    r6(config)#int s0/1
    r6(config-if)#ip ospf authentication message-digest 开启秘文认证需求,开启后本地所有ospf数据包中认证类型字段被修改,邻居间若不一致将不能建立邻居关系
    r6(config-if)#ip ospf message-digest-key 1 md5 cisco123

    【2】区域认证
    例:在R1上开启关于区域0的明文或密文认证;然后仅仅只是将R1上所有属于区域0的接口,认证类型字段修改,相当于在R1上所有区域0接口配置明文或密文认证需求;但每个接口的秘钥还是需要逐一配置;
    r12(config)#router ospf 1
    r12(config-router)#area 2 authentication 明文
    r12(config-router)#area 2 authentication message-digest 密文

    【3】虚链路认证
    r1(config)#router ospf 1
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication-key cisco
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication message-digest
    r1(config-router)#area 1 virtual-link 4.4.4.4 message-digest-key 1 md5 cisco123

    2、被动接口
    r1(config)#router ospf 1
    r1(config-router)#passive-interface ethernet 0/1

    3、加快收敛—邻居间直连接口hello和dead 必须完全一致
    r7(config)#interface s0/1
    r7(config-if)#ip ospf hello-interval 5
    r7(config-if)#ip ospf dead-interval 20
    注:修改本端的hello time本端的dead time自动4倍关系匹配;

    4、缺省
    3类缺省—通过特殊区域自动产生;
    末梢、完全末梢、完全NSSA自动产生;

    5类缺省—本地路由表中必须已经存在缺省路由,通过什么方式产生的无所谓;
    之后,可以使用专用指令将其重发布到OSPF协议中
    r9(config)#router ospf 2
    r9(config-router)#default-information originate
    默认进入路由为类型2,OE2;度量为1;
    类型1:在内部传递时不叠加内部度量;
    类型2:在内部叠加度量; 默认
    若网络中存在多台边界路由器,均进行重发布行为,建议修改为类型1;
    r9(config-router)#default-information originate metric-type 1

    r9(config-router)#default-information originate always 强制向内网发布缺省路由信息;

    7类缺省–ASBR上通过其他协议学习到的缺省导入OSPF,同时所导入区域为NSSA区域;
    r12(config)#router ospf 1
    r12(config-router)#area 2 nssa default-information-originate

    注:若一台设备同时学习多种缺省; 内部优于外部 3类优于5/7类;
    若5类和7类相遇,先比度量,小优;若度量一致那么5类优于7类;

    展开全文
  • OSPF路由过滤、汇总和默认路由

    千次阅读 2020-05-18 09:00:20
    OSPF路由过滤、汇总和默认路由 1、路由过滤 1类LSA和2类LSA不能进行过滤,因为链路状态逻辑要求区域内的所有路由器维持完全相同的LSDB;否则会导致SPF无法正常工作和计算出的路由出错。 因此OSPF只有一下过滤方法:...
                OSPF路由过滤、汇总和默认路由
    

    1、路由过滤
    1类LSA和2类LSA不能进行过滤,因为链路状态逻辑要求区域内的所有路由器维持完全相同的LSDB;否则会导致SPF无法正常工作和计算出的路由出错。
    因此OSPF只有一下过滤方法:
    —在ABR上过滤3类LSA;
    —在ASBR上过滤5类LSA(暂不讨论);
    —在路由器上对OSPF原本要加入到IP路由表中的路由进行过滤。

    1.1 过滤3类LSA(ABR)
    —定义前缀列表:
    全局:ip prefix-list *** [seq xx(序列号)] permit/deny x.x.x.x/xx [ge xx][le xx]
    注:默认最后拒绝(跟ACL一样)。
    ip prefix-list 1 permit 0.0.0.0/0 le 32 全部允许

    —OSPF视图:area xx filter-list prefix *** in/out
    注:in–IOS将禁止3类LSA泛洪到配置的区域;
    out–IOS将把来自配置区域的3类LSA过滤掉。

    1.2 过滤要加入到路由表中的OSPF路由(并不是过滤3类LSA)
    —定义前缀列表;
    —OSPF视图:distribute-list prefix *** in
    注:前缀列表拒绝的网络号(路由),相应的3类LSA没有被过滤,可以继续发送给其他OSPF邻居学习。

    2、路由汇总
    OSPF必须在ABR和ASBR处汇总;但不允许在其他OSPF路由器汇总(区域内部不允许汇总),原因也在于确保同一个区域LSDB同步。

    2.1 ABR汇总
    OSPF视图:area xx range 前缀 掩码 [cost xx][not-advertise]
    注:命令中区域号表示子网所属区域;
    cost可以指定汇总路由的度量值;如果不指定则汇总路由选用子网路由中度量值最小的;
    默认是advertise,通告汇总路由,抑制明细路由;
    如果修改为not-advertise,则连汇总路由也不通告(相当于路由过滤)。

    注:只要有一条明细路由有效,则汇总路由就有效;
    ABR做汇总后,会产生一条同等汇总路由指向null(黑洞口),用于防环;
    ABR汇总只能汇总区域内路由(ABR跟需要聚合的子网在同一个区域)。

    2.2 在ASBR汇总
    OSPF视图:summary-address 前缀 掩码 [not-advertise] [tag xx]
    注:not-advertise表示连汇总路由也不通告;默认只通告汇总,为汇总路由条目创建一条5类LSA;
    如果汇总范围内有一条明细路由有效,则汇总就有效;
    此命令中不能指定汇总路由的metric;
    tag xx —tag为一个没有单位的整数,一类路由的标记。

    3、默认路由
    3.1 创建OSPF网络的默认路由(除特殊区域)
    OSPF视图:default-information originate [always][metric xx][metric-type 1/2][route-map ***]
    注:在路由器本身存在缺省路由(默认路由)时,可以通过上述命令向其他OSPF路由器发布缺省路由(5类LSA);
    如果本路由器没有缺省路由,则添加关键字always也能实现发布默认给其他路由器;
    metric-type指定发布默认路由类型,默认为E2,可指定为E1;
    —E2路由进入OSPF网络后,metric值随引入时不改变;
    —E1路由进入OSPF网络后,metric值会随传递而增加。
    Route-map中permit语句匹配来确定何时通过以及何时撤销默认路由;还支持修改度量值、路由类型等功能。

    3.2 末节区域
    特征:1.ABR使用3类LSA创建一条默认路由泛洪到末节区域;
    2.ABR不将4/5类LSA泛洪到末节区域;
    3.末节区域内不能引入外部路由(静态、RIP、EIGRP等);
    4.末节区域内的所有路由器都必须配置为末节属性,否则无法建立邻居关系(区域flag不一致)。

    1、末节区域(stub)
    —过滤5类LSA(4类LSA);OSPF区域间所有路由会学习
    —ABR主动发送一条默认给区域内部路由器。
    OSPF视图:area xx stub
    ABR OSPF视图:area xx default-cost xx (改Cost,默认为1)在同时有两个ABR的情况下,通过修改这个COST值来实现选路

    2、绝对末节区域(绝对stub)
    —过滤3类LSA、5类LSA(4类LSA);
    —ABR主动发送一条默认给区域内部路由器。
    OSPF视图:area xx stub no-summary
    注:区域中路由器只有一条3类LSA,为ABR发布的默认路由。
    只需要在ABR上设置加上no-summary;绝对stub内部路由器任然是area xx stub 即可。

    3、次末节区域(NSSA)
    NSSA可以重分布(引入)外部路由,但必须为7类LSA(与5类LSA相似)。
    注:stub和绝对stub区域不能引入外部路由。
    过滤5类LSA(4类LSA)。

     NSSA区域路由器—OSPF视图:area xx nssa
      
     ABR的OSPF视图:area xx nssa default-information-originate
       注:手工指定ABR发布一条7类LSA(默认路由)。
    
       注:ABR将LSA7转成LSA5,传播到其他区域。这时,ABR也成为了ASBR,因为它也引入了LSA5。其它路由器看到LSA5的通告路由器是ABR。
    

    4、绝对次末节区域(绝对NSSA)
    ABR的OSPF视图:area xx nssa default-information-originate no-summary
    绝对NSSA内部路由器OSPF视图:area xx nssa
    注:绝对NSSA区域内部路由器也不必学习3类LSA。

    注:(绝对)次末节区域重分布的外部路由(7类LSA)在NSSA的ABR进行转换,转换为5类LSA发布到其他区域。
    除NSSA需手工指定默认路由到NSSA的区域内部,其他3种特殊区域都是ABR自动发布默认路由。

    区域类型 区域内是否 区域内是否 是否能够重分布
    有5类LSA 有3类LSA 外部路由
    stub 否 有 否
    绝对stub 否 否 否
    NSSA 否 有 是(7类LSA)
    绝对NSSA 否 否 是(7类LSA)

    4、OSPF虚链接
    OSPF虚链接让两个连接到同一个非骨干区域的ABR能够穿越该区域建立邻居关系;OSFP虚链接相当于直连的点到点接口。
    OSPF视图:area xx virtual-link x.x.x.x(对方RID)
    注:area xx指定的区域为两边ABR建立连接的中转区域,承载ABR之间的OSPF报文;
    中转区域不能为骨干区域和特殊区域。
    show ip ospf virtual-link
    show ip ospf neighbor [detail x.x.x.x]

    展开全文
  • OSPF路由计算

    千次阅读 2019-01-15 17:21:40
    区域内路由计算 图论表示 OSPF将一个区域的拓扑抽象成一个向图。图的节点是路由器、转接网络和stub网络。节点之间使用边进行连接。路由器到transit network的cost值等于接口cost值,transit network到路由器的cost...

    版本声明:转载请注明出处。未经允许,禁止商业用途。

    区域内路由计算

    图论表示

    OSPF将一个区域的拓扑抽象成一个向图。图的节点是路由器、转接网络和stub网络。节点之间使用边进行连接。路由器到transit network的cost值等于接口cost值,transit network到路由器的cost值等于0。路由器到stub网络有边。但是stub网络到路由器没有边。这意味着流量不能穿越stub网络。

    LSA角度

    路由器节点对应router-LSA。转接网络对应network-LSA

    节点ID32位数字,它和节点类型(路由器或网络)唯一标识一个节点。对于路由器,节点ID是路由器的OSPF router ID。对于网络节点,它是网络中DRIP地址。

    Dijkstra算法

    Step1 进行路由计算的路由器把自己作为根节点加入最短路径树S,将根节点可直达的节点列为候选人(如果没有可直达节点,则计算结束)。程序实现方式为,distance[v0]=0; distance[u]=arcs[v0][u],其它节点的distance为无穷大。即程序中没有候选人列表,distance不是无穷大,就说明是候选人或者加入了最短路径树。

    Step2 将候选人列表中到根节点cost值最小的节点加入最短路径树并且从候选人列表中删除。程序思路:加入S则打上标记。程序中这是一个循环。

    Step3 把新加入的节点所能直达的节点列为候选人,同时更新原有候选人的路径。程序实现方式为:节点u加入S。有可能减少从v0出发,途径S中的节点,到达目前还不在S中的某节点w的路径长度。如果有这样的路径的话,这条路径一定经过u,所以应将原路径v0->w修改为v0->u->w。效果是从非候选人变成候选人(原本distance[w]为无穷大),也可能是变成更好的候选人(原本distance[w]不是无穷大)。程序中这是一个循环。

    Step4 如果候选人列表为空,则计算结束,否则,返回Step2。程序中这是外层循环。

    因为后加入最短路径树的节点的路径cost值大于先加入最短路径树的节点的路径cost值,所以一旦找到最短路径,不会出现到某个节点的最短路径需要修改的情况。

    Dijkstra 算法的时间复杂度为O(n^2)。优化后为O(nlogn)

    这里程序和自然语言描述最大的差异在于,自然语言描述的思路是层层向外推,直到包含了最远的节点,程序形式上看起来却是毫无差异的从编号为0的节点开始循环,形式上看起来并不是从v开始处理。

    区域间路由的计算

    对于每条区域内路由,ABR会将其转换成3类LSA,放入其它区域的LSDB,然后通告给那些邻居中的邻居。如果一个区域有多个ABR时,每个ABR都会生成和通告3类LSA。

    骨干区域ABR要特殊一些,骨干区域的ABR会将学习到的对应于区域A的网络的3类LSA,它首先计算出区域间路由,路由的cost值为network summary-LSA中的cost+到生成该3类LSA的ABR的cost,然后重新生成新的3类LSA,然后放置到区域B的LSDB。

    到同一网络,如果有多条3类LSA。则比较 network summary-LSA中的cost+到生成该3类LSA的ABR的cost ,选择值小的路由,最终下一跳指向该ABR的方向。

    AS外部路由的计算

    不像3类LSA的泛洪范围是一个区域,经过区域0时要重新生成,5类LSA的泛洪范围是整个AS,在整个AS传输时不会重新生成。但是对应于每个ASBR,其所在区域的ABR要生成4类LSA,和3类LSA类似,4类LSA的泛洪范围也只是一个区域。4类LSA经过区域0时要重新生成。到ASBR的路由本质上是一种区域间路由。

    有多个ASBR时,一条external路由对应多个5类LSA。有多个ABR时,对于一个ASBR就会有多条4类LSA。到ABR x的cost值+ ABR x生成的4类LSA中的cost  = 到ASBR的cost值。至于选择哪一条5类LSA通告的路由,需要取决于5类LSA中的metric type和metric值。优选metric tyep为E1的路由。Metric type同为E2时,选择metric值小的路由,如果metric值相同,则选择ASBR近的路由。Metric type同为E1时,选择metric值+到ASBR的cost值 最小的路由。下一跳指向本区域中产生对应ASBR LSA的ABR。

    可以看到,OSPF区域间路由和AS外部路由的计算,其实更像是距离矢量协议。距离矢量协议就要考虑放防环路的问题,OSPF区域间路由没有环路,是因为OSPF限制了区域间路由的传播途径,最长路径为非骨干区域A---区域0----非骨干区域B,这样就不会出现一个区域的路由又回到这个区域中的情况。

    展开全文
  • OSPF路由过滤

    千次阅读 2019-07-29 22:33:24
    文章目录分发列表前缀列表针对ospfarea x range xx not-advertiseroute-...distribute-list分发列表是用于控制路由更新的一个工具,只能过滤路由信息,不能过滤LSA。(所以说对距离矢量路由协议比较适用,如:RIP、...

    分发列表

    • 分发列表–是一种操作路由表显示路由条目 使用时不太推荐,有局限性(本路由器过滤的路由不会影响下游路由器)
    • distribute-list分发列表是用于控制路由更新的一个工具,只能过滤路由信息,不能过滤LSA。(所以说对距离矢量路由协议比较适用,如:RIP、EIGRP。 像OSPF 链路状态路由协议,IN方向(影响本地路由表,但LSDB里是有的),OUT方向不起作用; 但对本地始发路由可以过滤,原因是通过路由的重分发,而不是LSA传递。)
    • 过滤方式不是针对哪个接口的In,而是针对是否要写入核心路由表,而且该命令只会干掉核心路由表,但是LSA依然会存储在路由器的ram里面.
    • 什么是核心路由表,就是自己的show ip route 显示的路由表,这种方法在OSPF中,算是比较粗暴的方法,只能自己干自己。对别人不起做作。

    案例(单一路由环境下-ospf)
    在这里插入图片描述
    R2(config)# access-list 1 deny 192.168.3.0
    R2(config)# access-list 1 permit any
    R2(config)# router ospf 1
    R2(config-router)# distribute-list 1 in fa0/0
    注意这时候,首先在R2的路由表里,3.0的路由就被干掉了。注意,这时候实际上,area内OSPF路由器产生的LSA已经是装载到了R2的OSPF database之中,而在R2从OSPF database中计算路由,并准备将路由条目装载进路由表之前,in方向的分发列表发生作用了,将3.0的路由过滤掉了,因此R2的路由表中,是没有3.0的OSPF路由的。但是,虽然R2自己路由表里没3.0路由,这不妨碍R2将相关LSA泛洪给R3,因此,R3仍然是有1.0、2.0、3.0以及12.0的OSPF路由的。

    案例(单一路由环境下-OSPF out方向分发列表)
    在这里插入图片描述
    分发列表,部署在OSPF这样的链路状态路由协议中,如果要用out方向,则只能用在这样的场合。如上图,在R1上部署,R1使用重发布直连的方式引入这三条外部路由,那么out方向的分发列表,只能在R1上部署,且对这三条路由产生作用。
    R1(config)# access-list 1 deny 192.168.3.0
    R1(config)# access-list 1 permit any
    R1(config)# router ospf 1
    R1(config-router)# redistribute connected subnets
    R1(config-router)# network 192.168.12.1 0.0.0.0 area 0
    R1(config-router)# distribute-list 1 out
    上述配置实现后,R1将过滤掉3.0路由。

    前缀列表

    prefix-list:专门用于抓取控制层面流量–只能为发布列表、route-map服务;

    • 前缀列表的可控性比访问列表高得多,支持增量修改,更为灵活

    • 判断路由前缀与前缀列表中的前缀是否匹配

    • 前缀列表包含序列号,从最小的开始匹配,默认序列为8,以5增加可以使用序号插入

    • 如果前缀不与前缀列表中的任何条目匹配,将被拒绝

      • A 类:0 开头的 0 0000000
        B 类:10 开头的 10 000000
        C 类:110 开头的 110 00000
    • /24 24 是长度 既前面 24 位固定

    • 用 Le ge 定义掩码,如果没有 ge 和 le 则网络掩码就是/后面的数字
      规则:len < ge-value <= le-value

    • 匹配规则:至上而下逐一匹配,上条匹配按上条执行,不查看小条;末尾隐含拒绝所有;

    r3(config)#ip prefix-list xx permit 1.1.1.0/23
    r3(config)#ip prefix-list xx permit 2.2.2.0/24 le 30 掩码范围 24-30
    r3(config)#ip prefix-list xx permit 3.3.3.0/24 ge 30 掩码范围 30-32
    r3(config)#ip prefix-list xx permit 4.4.4.0/24 ge 25 le 30 25-30

    • 默认路由既缺省路由
      主机路由掩码是 32 位

    r3(config)#ip prefix-list xx permit 0.0.0.0/0 ge 32 匹配所有的主机路由
    r3(config)#ip prefix-list xx permit 0.0.0.0/1 ge 8 le 8 匹配所有的 A 类地址
    r3(config)#ip prefix-list xx permit 128.0.0.0/2 ge 16 le 16 匹配所有 B 类地址
    r3(config)#ip prefix-list xx permit 192.0.0.0/3 ge 24 le 32 匹配所有 C 类及 C 类子网
    r3(config)#ip prefix-list xx seq 12 deny 9.9.9.0/24
    也可以随意删除条目;
    r3(config)#ip prefix-list xx permit 0.0.0.0/0 le 32 允许所有

    针对ospf
    • Router(config-router)# area area-id filter-list prefix prefix-list-name in
      用来在ABR上作summary lsa过滤,如果是骨干区域(非骨干区域),就阻止从该区域转换到其他非骨干区域(骨干区域)符合特定条件的summary lsa生成,过滤彻底。
    • Router(config-router)# area area-id filter-list prefix prefix-list-name out

    area x range xx not-advertise

    • 汇总和明细都不通告来过滤明细路由(明细都不通告)
    • 用来在ABR上summary lsa做过滤,如果是骨干区域(非骨干区域),就防止从该区域转换到其他非骨干区域(骨干区域)符合特定条件的summary lsa生成,类似filter-policy export(area)命令的作用,但又有点区别,该命令只对本区域的区域内路由作过滤不对区域间路由做过滤。(原因是:这条命令是聚合命令,目前我们VRP和IOS的聚合命令的实现是只对本区域的路由做聚合而不对区域间路由做聚合,所以说abr-summary not-advertise这条命令实际只是对本区域的区域内路由起过滤作用。)

    在这里插入图片描述

    • 对应IOS命令为:Router(config-router)#area 10 range 1.1.1.0 255.255.255.0 no-advertise
      在R2上配置abr-summary过滤1.1.1.1/32的summary lsa。
      [R2-ospf-1-area-0.0.0.100]abr-summary 1.1.1.1 255.255.255.255 not-advertise
      配置后在R3上查看lsa,发现已经没有了1.1.1.1的lsa信息。

    route-map

    在这里插入图片描述
    在R2上做route-map拒绝R1的192.168.10.0/24和192.168.11.0/24.

    access-list 101 permit ip 192.168.10.0 0.0.0.255 any
    access-list 101 permit ip 192.168.11.0 0.0.0.255 any //抓流量
    route-map ccie deny 10 小动作拒绝
    match ip address 101 匹配acl101
    route-map ccie permit 20 大动作空表允许所有流量
    redistribute rip metric-type 1 subnets route-map ccie //重发布时调用route-map

    补充 Track

    track 1 ip sla 1 //定义一个track监控,监控的对象是lsa探针
    Ip sla 1 /定义一个sla探针
    Ip sla auto dsicovery
    Icmp-echo 10.1.13.3 定义一个ping探针
    Ip sla schedule 1 life forever start-time now 设置探针生效时间和开始时间
    Ip route 10.10.1.1 255.255.255.255 10.3.1.3 track 1 //如果track1监控成功那么路由生效,否则失效。

    展开全文
  • 1、单区域配置OSPF路由 先配置好IP地址信息: #物理接口 interface GigabitEthernet0/0/0 ip address 10.0.123.2 255.255.255.0 # #回环接口 interface LoopBack0 ip address 10.0.1.1 255.255.255.0 # ...
  • OSPF 路由汇总配置

    千次阅读 2020-11-08 14:36:30
    1.拓扑图 ...提取码:8888 eNSP ...提取码:8888 2、网络需求 ... SW使用network命令在各个用户VLAN上激活OSPF,使得OSPF路由器能够学习到用户VLAN的相关路由; c. R2的Loopback接口都不直接通告到OSPF
  • OSPF路由协议总结

    2020-05-25 11:45:44
    OSPF(open shortest path Fist0)是IETF组织开发的一个基于链路状态的内部网关协议,具有收敛快、路由无环、可扩展等优点。 文章目录一、OSPF基础概念1.1 协议特点1.2 OSPF概念【一】Router-id【二】cost【三】Link...
  • RIP OSPF路由引入

    2021-11-17 17:28:38
    RIP OSPF路由引入原理概述二、实验拓扑在这里插入图片描述三、实验内容1.配置ip地址2.左边配置rip右边配置ospf3.双向引入总结与思考 原理概述 不同的网络会根据自身的实际情况来选择路由协议 不同的路由协议计算...
  • 一、OSPF路由类型 二、E1与E2开销的计算 一、OSPF路由类型 OSPF路由类型 路由指示符 路由类型 描述 O OSPF的域内路由(1类LSA与2类LSA) 路由器所有区域内的网络,以路由器LSA和网络LSA的方式被...
  • OSPF路由系统构建

    2021-03-19 11:30:27
    修改OSPF cost5.OSPF的基础配置6.OSPF的查看及验证二、OSPF的工作过程1.OSPF协议工作过程三个阶段2.OSPF的三张表三、OSPF邻居建立过程1.OSPF的报文类型2.建立邻居关系(邻接关系 全毗邻)3.点到点网络建立邻居过程4....
  • ospf路由引入

    千次阅读 2020-02-01 20:14:12
    network 192.168.1.0 255.255.255.0 --此时,不仅将network宣告到ospf协议中,也一并192.168.1.0这个接口启用ospf协议,这个接口上发送和接收ospf报文。 --导入默认路由: [r1-ospf-1]default-route-advertise ...
  • OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),在单一自治系统(AS)内部工作。 跨层封装于3层报头,协议号89;标准报头中存在RID/区域ID和认证参数...
  • OSPF路由协议 在同一个OSPF自制系统内每一台运行OSPF协议的路由器总是将本地网络的连接状态用LSA(链路状态通告)描述,并广播到整个自制系统中去。这样,每台路由器都收到了自制系统中所有路由器生成的LSA,这些...
  • 单区域OSPF路由协议配置

    千次阅读 2020-05-07 21:48:19
    掌握OSPF动态路由协议的配置、诊断方法。 实验要求: 1、配置OSPF动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的OSPF动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些...
  • 1. OSPF协议   OSPF(Open Shortest Path First:开放...另外,OSPF通过触发更新能够快速了解当前网络的拓扑变化。   OSPF还支持网络扩展, 也就是当网络上的路由器越来越多, 路由信息流量急剧增长的时...
  • OSPF路由协议说明

    2020-05-25 00:57:36
    OSPF基本知识: OSPF(Open Shortest Path First开放式最短路径优先)是一个内部...OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等。 是一个无类别链路状态路由协议,使用组
  • Hello大家好,本篇博文讲述的是大学网络工程思科路由器之ospf路由配置实验,供各大专院校学生与老师参考,如需转载,需注原创 接下来,我们来讲一讲,如何进行OSPF路由配置实验 首先,我们选好进行实验的器材:分别...
  • 静态路由 ISP路由 策略路由 OSPF路由

    千次阅读 2018-11-15 14:43:53
    静态路由(英语:Static routing),一种路由的方式,路由项(routing entry)由手动配置,而非动态决定。与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是...
  • OSPF路由是如何选路?

    千次阅读 2020-04-12 17:46:10
    如图配置 VLAN、IP和OSPF R1/R2配置静态路由,访问PC-2 确保 PC-1与PC-2可以互相访问 PC-1的网关配置在 SW1 上 R1是主出口设备,R2是备份出口设备 要求数据转发是最优路径 1.2 方案 搭建实验环境,如图-1所示。 图...
  • 路由协议之OSPF

    万次阅读 多人点赞 2018-11-22 08:26:13
    OSPF中的路由汇总和路由过滤 OSPF中的虚拟链路 虚拟链路有两种存在的意义 OSPF中的认证 华为模拟器中的配置 OSPF协议 OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议IGP,用于在单一...
  • 一、OSPF路由认证 (1)链路认证 明文认证: (config-if)#ip ospf authentication (config-if)#ip ospf authentication-key 密码 密文认证: (config-if)#ip ospf authentication message-digest (config-...
  • OSPF路由协议

    千次阅读 2021-12-10 07:01:40
    OSPF路由协议一、OSPF的基本概念和工作过程1.1 OSPF路由协议概述2.1 内部网关协议和外部网关协议 一、OSPF的基本概念和工作过程 1.1 OSPF路由协议概述 1.OSPF是内部网关路由协议 2.OSPF是链路状态路由协议 2.1 内部...
  • OSPF路由协议基本配置及手动配置路由器优先级 R1: interface GigabitEthernet0/0/0 ip address 10.1.1.1 255.255.255.0 ospf dr-priority 100 //手工配置路由器优先级,确保指定路由器接口成为DR interface ...
  • ospf是一种链路状态路由协议,属于IP协议。协议号为89,OSPF更新与带宽有关。 RIP指一种距离矢量路由协议,属于IGP协议。使用UDP协议进行路由信息的交互,端口号为520。 RIP更新周期是30S;RIP更新路由是发送整个...
  • OSPF

    2020-07-18 16:59:15
    OSPF(开放最短路径优先协议) 基本信息: 版本:OSPFV1(实验室版本)、OSPFV2(先投入商用的服务于IPV4的) ... OSPF是一种典型的链路状态型路由协议(在传递路由信息的同时传递拓扑信息) 通过LSA传递路由及...
  • OSPF网络中,若存在大量的外部路由,不仅会占用路由器的CPU与内存资源,而且会增加网络管理人员的管理麻烦,所以,我们可以使用一种类似网关的作用来解决此类问题。我们在边界路由器ASBR注入一条OSPF默认路...
  • OSPF之外部引入路由

    千次阅读 2020-03-03 22:01:32
    ①:外部路由:外部路由就是路由不属于OSPF区域,但是路由信息通过某种手段进入了OSPF中,那么这就称为外部路由 ②:本章中包含了AS-External-LSA以及ASBR-Summary-LSA的解释,外部路由类型,外部路由的Forwarding ...
  • 华为路由器ospf路由控制及安全

    万次阅读 2016-07-27 15:14:58
    session 1 ospf路由控制 一、ospf路由聚合  这个拓扑中AR1上3个loopback在area1中宣告,AR4上的2个loopback模拟lsa5(lsa7)重分布进ospf中,现在分别在ABR(AR2)和ASBR(AR4)上做内部路由聚合以及外部路由...
  • OSPF外部路由

    千次阅读 2021-10-23 15:36:05
    路由协议视图下:import-route static/ospf…… ASBR:引入外部路由OSPF路由器 ABR:边界路由器:OSPF中骨干区域与其他区域交接处的路由器 五类LSA:AS-External-LSA(AS外部LSA) ASBR产生,用于描述如何从ASBR...
  • OSPF路由协议概述:开放式最短路径优先(Open Shortest Path First,OSPF)是目前广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 14,596
精华内容 5,838
关键字:

修改ospf路由更新