精华内容
下载资源
问答
  • 路由交换技术常用版)

    千次阅读 2019-12-27 23:30:39
    参考资料《路由交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。 其中有部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。 一、网络分层设计模型 二、...

    路由知识

    参考资料《路由与交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。
    其中有部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。

    一、网络分层设计模型

    在这里插入图片描述

    二、交换网部分

    1.交换机的工作原理(广播域、冲突域的理解)

    工作原理:
    a、地址学习
    b、帧的转发
    c、环路防止
    广播域:广播数据时可以发送到的区域
    冲突域:数据必然发送到的区域

    2.交换机的基本配置

    (登录方法、视图模式、?和TAB键的作用、恢复出厂设置、显示运行配置)
    在这里插入图片描述
    登录方法:en
    视图模式:conf t
    ? :显示该命令下的所有命令及简单描述(以结尾)
    Tab :自动补全当前代码
    恢复出厂:set default(交换机)、del(路由器)
    显示运行:show …(ip router)
    重启:reload
    查看运行配置:show running-config

    3.VLAN的作用、划分方法和划分配置

    Vlan的作用:
    VLAN优点:广播控制,安全性,带宽利用,延迟;
    VLAN的缺点:VLAN之间的信号交流复杂,加大了路由器负载,过多的VLAN会造成网络性能下降,导致网络主干链路流量加大,增加了网络的抽象性,专用性仍然很强。
    Vlan的划分方法:vlan 10;vlan 20;
    Vlan的划分配置:
    Int fa0/1
    switchport mode access
    switchport access vlan 100

    4.二层和三层交换机上的Trunk链路配置,VLAN网关配置

    Trunk配置:
    (二层交换机)
    Int fa0/1
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    (三层交换机)
    Int fa0/1
    SWitchport trunk encapsulation dot1q
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    配置VLAN的IP地址:
    Switch(config)#interface vlan 10 //进入VLAN10
    Switch(config-if)#ip add 192.168.10.1 255.255.255.0 //给VLAN10配置IP地址
    Switch(config-if)#exit

    5.交换机端口链路聚合

    静态链路聚合:
    Switch(config)#int port-channel 1(聚合号)
    #exit
    #Int range fa0/1-2
    #channel-group 1 mode on
    动态链路聚合:
    int port-channel 1
    interface ethernet 0/0/1-2
    channel-group 1 mode active

    6.生成树协议(判断根桥、根端口和指定端口 spanning-tree配置)

    在这里插入图片描述
    S(config)# spanning-tree vlan 10 root primary (主根)
    S(config)# Spanning-tree vlan 10 root secondary (备份根)

    S(config)# Spanning-tree vlan 10 priority 24576 (网桥优先级)

    S(config)# int fa0/1
    S(config)# Spanning-tree port-priorit 110 (端口优先级)
    判断根桥:
    根据优先级和MAC地址,优先级小的那个就是根桥;
    如果优先级一样就看MAC地址,MAC最小的就剩根桥
    判断根端口:
    端口所在ID值较小的端口(离根桥最近,花销最小的设备上的端口)
    判断指定端口:
    根桥上的端口全是指定端口
    (如果是非根桥的指定端口,选择端口所在ID值较小的端口)

    三、冲突域与广播域

    1、交换机(链路层)

    所有端口同一广播域;同一端口同一冲突域。

    2、路由器(网络层)

    它的一个接口就是一个广播域;它的一个接口就是一个冲突域。
    (无255.255.255.255)

    3、一个vlan一个广播域。

    4、集线器(物理层)

    所有端口在同一个广播域;所有端口同一个冲突域。

    四、注意点1(vlan创建)

    1、VLAN创建后,其配置信息写在交换机的flash中,配置文件是vlan.dat
    2、要删除某个VLAN,则只要在全局模式下使用no命令即可
    (但先要将该VLAN中的端口指定到其它VLAN中,然后删除该VLAN)
    3、如要彻底删除VLAN的配置,必须删除文件VLAN.dat
    4、同一个vlan主机间可自由通信,不同vlan之间必须通过路由器或三层交换机进行数据包路由转发。
    5、Vlan作用:广播控制,安全性,带宽利用,延迟。
    6、交换机分割了冲突域,但不能分割广播域,随着交换机端口数量的增多,网络中广播增多,降低了网络效率,为了分割广播域,引入vlan。

    五、注意点2(三层交换机与静态链路聚合)

    1、三层交换机与两层交换机相比,trunk多了一个封装:
    switchport trunk encapsulation dot1q
    switchport mode trunk
    swichport trunk allowed vlan all

    2、链路聚合:(静态链路聚合)
    int port-channel channel-id
    exit
    interface ethernet interface-id
    channel-group channel-id mode on

    六、网络基础部分

    1.理解IP地址,子网掩码,路由器接口IP地址配置命令

    IP地址:(IPv4地址总数=232=42亿个)例如172.16.122.1
    在这里插入图片描述
    子网掩码:
    在这里插入图片描述在这里插入图片描述

    IP地址配置命令:
    int fa0/1
    IP address 192.168.100.1 255.255.255.0
    no shutdown(打开端口)

    2.掌握使用CIDR地址计算网址的方法

    在这里插入图片描述

    3.IP地址中网关的作用和配置

    作用:网关实质上是一个网络通向其他网络的IP地址
    IP地址配置:IP address 192.168.1.1 255.255.255.0

    4.子网划分

    在这里插入图片描述

    七、路由网部分

    1.路由器的工作原理(广播域、冲突域的理解)

    工作原理:路由与转发
    在这里插入图片描述
    广播域(基于第二层(链路层)):
    广播域就是说如果站点发出一个广播信号后能接收到这个信号的范围。通常来说一个局域网就是一个广播域。
    冲突域(基于第一层(物理层)):
    一个站点向另一个站点发出信号。除目的站点外,有多少站点能收到这个信号。这些站点就构成一个冲突域。

    2.路由器的基本配置

    (登录方法、视图模式、显示运行配置)
    登陆方法,视图模式:
    在这里插入图片描述
    显示历史记录:show history

    3.路由器的VLAN单臂路由、VLAN间路由、直连路由,静态路由,默认路由

    单臂路由(实现Vlan间的通信):
    Router_config# Int f0/0
    Router_config# no shutdown
    exit
    Int f0/0.10(子接口)
    encapsulation dot1q 10
    ip address 192.168.10.254(网关地址) 255.255.255.0(子网掩码)

    直连路由:
    interface f0/0
    ip address 10.1.1.1 255.0.0.0(或者192.168.2.1 255.255.255.0)
    no shutdown

    静态路由:
    ip route 192.168.1.0(目的网络地址) 255.255.255.0 (子网掩码) 192.168.2.1(下一跳IP地址,与本路由器直接相连的下一路由器的接口地址)

    ip route 192.168.1.0 255.255.255.0 s0/0 (下一跳路由接口号)

    默认路由:当在路由表中找不到目标网络的条目时,请求转发到默认路由接口
    ip route 0.0.0.0 0.0.0.0 192.168.2.2
    Vlan间路由即vlan间通信成功

    4.动态路由RIP、OSPF、EIGRP配置

    RIP配置:
    router rip
    version 2 //version 2代表rip 2不能变\或默认路由:default_information orig
    no auto-summary \关闭自动汇总
    network 192.168.1.0
    network 192.168.2.0(需要配置rip的网络地址)

    EIGRP配置:
    router eigrp 10
    no auto-summary
    network 192.168.9.0(需要配置的网段地址)

    OSPF配置:
    router ospf 10(进程号)
    router-id 1.1.1.1 (路由器ID:标识路由器)
    network 192.168.3.0(网络号) 0.0.0.255(反向子网掩码) area 0 (区域号)
    network 172.16.0.0 0.0.255.255 area 0

    Router ID——是在OSPF区域内唯一标识一台路由器的IP地址

    5.RIP和OSPF 特点对比

    在这里插入图片描述

    6.广域网配置(PPP,认证PAP)

    PPP(Point to Point Protocol)协议:
    在点对点链路上运行的数据链路层协议
    PAP:
    两次握手认证协议,口令以明文传送,被认证方首先发起认证请求。
    PPP配置:
    单向认证:

    (被认证方)
    host name Ra
    Int s0/1/1
    ip address ip 200.100.100.1 255.255.255.0
    encapsulation ppp
    ppp pap sent-username Ra password 123456 //Ra发送过去的认证消息
    No shutdowm
    exit

    (主认证方)
    host name Rb
    user-name Ra password 123456
    Int s0/1/1
    ip address 200.100.100.2 255.255.255.0
    encapsulation ppp
    ppp authentication pap
    No shutdown
    exit
    双向认证:
    在这里插入图片描述

    八、注意点3(vlan间路由技术与ip路由协议)

    1、vlan间路由技术: 三层交换
    2、单臂路由产生的瓶颈:数据量大,路由器和交换机之间的路径会成为整个网络的瓶颈。
    解决:应用三层交换机—>二层交换+三层转发
    3、创建VLAN: vlan 30
    4、配置网关地址
    interface vlan 30
    ip address 192.168.30.1 255.255.255.0
    5、启动IP路由协议
    ip routing

    九、注意点4(各类路由)

    1、直连路由:在路由器上配置了接口的IP地址
    Int f 0/0
    ip add 10.1.1.1 255.0.0.0
    no shut
    特点:运用在规模较小,拓扑机构固定的网络中
    2、静态路由:由管理员手工配置,是单向的;
    ip route 192.168.1.0(目标地址)255.255.255.0 192.168.2.1(下一站地址)
    特点:路由表是人工设置的,除非网络管理员干预,否则静态路由不发生变化。
    2、默认路由:
    IP route 0.0.0.0 0.0.0.0 192.168.2.2(下一跳地址)
    特点:默认路由的优先级最低,即没有找到其他路由项时使用。
    使用环境:一般应用在只有一个出口的末端网络,用于连接Internet,安全性不高,作为其他路由的补充。
    4、单臂路由:(此时交换机上做trunk)
    Int f0/0.10
    encapsulation dotlq 10
    ip add 192.168.10.1 255.255.255.0
    int f0/0 no shut

    十、注意点5(各类配置)

    1、路由技术(动态路由):路由器之间通过路由协议动态地构建路由表
    2、自治系统:执行统一路由策略的一组网络设备的组合
    Rip、eigrp、ospf三种动态路由协议工作原理、特点和度量方法
    3、rip配置(路由标记是R)
    route rip
    version 2// 默认路由是default_imformation orig
    no auto-summary
    network
    show IP route

    4、Eigrp配置 (路由标记是D)
    router eigrp 10
    no auto-summary
    network 192.168.1.0
    show ip route show ip eigrp neighbor show ip eigrp topology

    5、Ospf配置(路由标记是O)
    route ospf 1
    router -id 1.1.1.1
    network 192.168.3.0 0.0.0.255 area 0
    show ip route show ip ospf neighbor show ip ospf database

    十一、注意点6(PPP和PAP拓展)

    1、Ppp协议:在串行链路上封装上层数据报文的方法,采用链路控制协议来建立配置控制和测试,采用网络控制协议来支持多种网络层路由协议。
    2、Ppp链路建立:链路不可用,链路建立 认证 网络层协议 链路终止阶段
    优点:支持同步或异步串行链路的传输,支持多种网络层协议,支持错误检测,支持用户认证,允许进行数据压缩。
    3、pap两次握手协议:口令以明文发送,认证方首先发起认证请求

    十二、网络安全部分

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)

    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝

    2.NAT(静态NAT、动态NAT和端口NAT)

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)
    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝
    2.NAT(静态NAT、动态NAT和端口NAT)
    .NAT的3种实现方式
    *静态转换——内部私有IP的服务器对内网和外网提供WEB、FTP等服务
    *动态转换——内部主机(私有IP)通过NAT转换使用公用地址池访问INTERNET
    *端口转换——内部主机(私有IP)通过NAT转换使用同1个公用地址访问INTERNET

    十三、ACL

    1、标准访问控制列表

    只使用源地址进行过滤,表明是允许还是拒绝

    2、访问控制列表号

    从1到99

    3、扩展访问控制列表

    *基于源和目的地址、传输层协议和应用端口号进行过滤
    *每个条件都必须匹配,才会施加允许或拒绝条件
    *使用扩展ACL可以实现更加精确的流量控制
    *访问控制列表号从100到199

    展开全文
  • 路由交换技术需要知道的基础知识点视图的作用与切换方式常用的基础操作几条比打的命令telnet管理设备(交换机、路由器)web管理设备vlan、trunkhybridvlan间路由(单臂路由、三层交换机)链路捆绑STP二级目录三级...

    视图的作用与切换方式

    用户视图:刚开始登入交换机时的视图,一般看到的时尖括号<>。
    return:返回用户视图

    系统视图:在用户视图下输入system-view后进入系统视图,一般为方括号[]
    在这里插入图片描述

    几条比打的命令

    在这里插入图片描述

    web管理设备

    管理设备的方式:带内管理、带外管理
    带内管理:指的时网络管理控制信息与用户承载业务的网络是同一个逻辑通道。即使用到带宽的管理方式。
    带内管理方式有:WEB、Telnet(telnet时用的外网IP)
    带外管理:指的时网络管理控制信息与用户承载业务的网络不是同一个逻辑通道。即使用内网的管理方式,不占用带宽。
    带外管理方式用:Console、Telnet(telnet时用的时内网的IP)

    vlan、trunk、hybrid

    交换机广播域:所有接口都在一个广播域中。
    虚拟局域网:vlan ——好处/功能:1.划分广播域 2.管理方便 3.增强网络安全性
    1-4094都是vlan可用的范围交换机默认的接口都是vlan1
    交换机根据连接的对象不同,接口模式:

    • access 用于接入链路:
      access口只能属于一个VLAN,默认只允许vlan1通过其他vlan流量需要手动放行,一般用于连接计算机端口
    • trunk 主干链路模式:
      可以允许多个VLAN通过,可以接收和发送多个VLAN报文,一般用于交换机与交换机相关的接口
    • hybrid 混合模式:
      华为默认的接口模式是hybrid模式;
      既可以实现Access接口的功能,也可以实现Trunk接口的功能;
      不借助三层设备即可实现跨VLAN通信和访问控制;
      untagged:出交换机会把指定标签解除的一张表(解除标签列表);
      tagged:出某些指定的vlan(有标签的)经过交换机时,无条件放行的一张列表(白名单列表);
      :同一个vlan只能存在于untagged和tagged其中一个表。
      pvid:标签。

    1.vlan的创建与划分

    一个交换机相连的两台PC机连接的接口必须设置同一个vlan和同网段的IP地址就能实现通讯
    在这里插入图片描述

    2.trunk的创建

    实现交换机之间的VLAN通信只使用一条链路,且通过标识来区分不同VLAN的数据
    在这里插入图片描述

    创建vlan进入接口(一般选末端接口好区分),再创建一个trunk端口设置trunk端口允许通过的vlan流量两边交换机要一样的设置,相同vlan间才能通信。

    3.hybrid的创建

    在这里插入图片描述
    在这里插入图片描述

    vlan间路由(单臂路由、三层交换技术)

    单臂路由

    • 作用: 实现不同vlan间的通信
    • 单臂路由当只有二层交换机,又要实现不同的vlan间通信,需要用到单臂路由技术。
    • 理论: 两台主机分别在不同vlan里连接着同一台交换机,交换机连接着路由器。PC1和PC2连接的交换机链路是access接口,access的作用就是给发送出去的数据打上vlan标签,接收时脱去标签。
      路由器连接的交换机链路是trunk接口,trunk接口作用为:通过不同(多个)的vlan数据。
      此时PC1需要向PC2发送数据,将数据封装上源IP地址源MAC地址为PC1的,目的IP地址为PC2的,目的MAC地址为网关R1进行封装在SW1的入口e0/0/1时打上vlan2的标签,数据传输到R1,这时R1会将数据加上源IP地址为PC1的,源MAC为R1的,目的IP地址和目的MAC地址为PC2的进行重新封装并将vlan2标签换成vlan3,传输给SW1,在SW1出口处e0/0/2脱去标签vlan3,最后数据传输到PC2。
      注: 未知目标Mac地址时可以开启ARP广播一下[R1-GigabitEthernet0/0/0.20]arp broadcast enable
    • 过程:
      1.交换机部分配置命令在这里插入图片描述
      2.路由器部分配置命令
      在这里插入图片描述
      注:推荐使用dot1q termination vid 10命令这个是通用配法图片上是支持个别路由器;

    三层交换技术

    三层交换是二层交换和三层转发 (交换机和路由器结合体,具有路由功能)不光可以交换数据帧,也可以进行数据包的转发。
    物理接口下三层交换机不能配IP地址的只能把接口配置vlanif接口,通过vlanif接口可以配置IP地址,成为不同vlan对应的网关,从而实现不同vlan间路由;

    三层交换的配置如下:
    在这里插入图片描述
    在这里插入图片描述

    三层交换原理:一次路由,多次交换。

    链路捆绑

    指将多个物理端口汇聚在一起,形成一个逻辑端口来增加带宽的一种放法,又称为多接口负载均衡组或链路聚合组在两台设备之间建立链路聚合组,可以提供更高的通讯带宽和更高可靠性,还提供了设备间通讯的冗余保护
    链路聚合实现的条件:

    1. 每个Eth-Trunk接口下最多可以包含8个成员接口。
    2. 成员接口不能配置任何业务和静态MAC地址。
    3. 成员接口加入Eth-Trunk时,必须为缺省的hybrid类型接口。
    4. Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk。
    5. 一个以太网接口只能加入到一个Eth-Trunk接口,如果需要加入其它的Eth-Trunk接口,必须退出原来的Eth-Trunk接口。
    6. 一个Eth-Trunk接口中的成员接口必须是同一类型,例如:FE口GE口不能加入同一个Eth-Trunk接口(即带宽必须一样)。
    7. 如果将不同接口板上的以太网接口加入到同一个Eth-Trunk。
    8. 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,两端才能正常通信。(链路两边都要做Eth-Trunk接口)
    9. 当成员接口的速率不一致时,实际使用中速率小的接口可能会出现拥塞,导致丢包。
      10.当成员接口加入Eth-Trunk后,学习MAC地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习。

    链路捆绑配置:
    SW1配置在这里插入图片描述
    SW2配置
    在这里插入图片描述
    第二种

    [Huawei]int Eth-Trunk 1
    [Huawei-Eth-Trunk1]bpdu enable
    [Huawei-Eth-Trunk1]mode lacp-static
    [Huawei-Eth-Trunk1]trunkport GigabitEthernet 0/0/2 to 0/0/4
    [Huawei-Eth-Trunk1]max active-linknumber 2

    STP

    STP概述

    STP - Spanning Tree Protocol(生成树协议)
    为什么要有生成树协议?
    因为当有环路存在时,广播的发送会引起全网的广播风暴,因此需要打破环路生成的条件,而生成树协议技术解决二层广播风暴的重要手段,另外我们会阻塞一些端口,打破环路生产条件。当链路出现问题时,这些被阻塞的端口可以过渡到转发状态,实现链路备份的作用。
    STP作用
    1.逻辑上断开环路,防止广播风暴的产生
    2.当线路故障时,阻塞接口被激活,恢复通信,起到备份路线作用

    BPDU网桥协议数据单元

    STP的各种选举时通过交换BPDU报文来实现的,BPDU是直接封装在以太网帧中的(802.3 802.2)。
    对参与STP的所有SW,他们低通过数据消息的交换来获取网络中其他SW的信息,这种消息就被称为BPDU。

    BPDU是直接封装在二层的协议
    PBDU的功能:
    1.选举根桥
    2.确定冗余路径的位置
    3.通过阻塞特定端口来避免环路
    4.通告网络的拓扑变更
    5.监控生成树的状态
    BPDU每2S由根桥发送一次,最初的网络每个SW都认为自己是根桥,都会发送BPDU,比较lowest BID,选举出一个根桥,此时就只有根桥发送BPDU。非根桥只进行转发,转发时只修改bridge-id和cost字段。

    BPDU分两种类型:
    1.配置BPDU——通常由根网桥以周期性间隔发出,包括了STP参数,用于进行各种选举。
    2.TCN(拓扑变更通告)BPDU——这种BPDU是当交换机检测到拓扑发生变更时所产生。
    TCN BPDU :这种BPDU是SW检测到拓扑时产生的,可由非根网桥发出。

    选举根交换机的规则:

    lowest BID=网桥优先级+MAC地址(越小越优先)
    交换机默认网桥优先级时32768

    设置成根网桥的两种方法
    1.修改网桥优先级命令:[SW1]stp priority 0 (数值需要设定为4096的倍数)
    2.设置此网桥为根网桥:[SW1]stp root primary (优先级将变成0)
    查看谁是根网桥的命令:display stp

    端口角色
    RP:根端口,每个非根网桥上有且只有一个,选举到在根网桥上路径开始值最小的成为根端口
    DP:指定端口,根网桥上每个端口都是指定端口,非根网桥上需要转发数据的端口也是指定端口
    AP:预定端口,该接口状态为discarding状态,只收BPDU,不发BPDU

    端口状态描述
    Disabled(禁用状态):不转发数据帧,不学习MAC地址表,不参与生成树计算。
    Blocking(阻塞状态):不转发数据帧,不学习MAC地址表,接收并处理BPDU,不发送BPDU。
    Listening(侦听状态):不转发数据帧,不学习MAC地址,参与生成树计算,接收并发送BPDU。
    Learning(学习状态):不转发数据帧,学习MAC地址表,参与生成树计算,接收并发送BPDU端口。
    Fowarding(转发状态):转发数据帧,学习MAC地址表,参与生成树计算,接收并发送BPDU端口。

    端口由Blocking过渡到Fowarding有50S延迟,Blocking到Listening有20S老化时间,Listening到Learning有15s过渡时间,Learning到Fowarding有15s延迟

    选举根端口、指定端口的规则:

    1.Lowest past cost to root bridge(到达根的最小路径开销)
    2.Lowest sender BID(最小的发送方BID)
    3.Lowest sender port ID(最小的发送方)PID:端口优先级(默认128)+端口号

    修改网桥接口优先级命令:[SW1-Ethernet0/0/2]stp port priority 0(16的倍数)
    查看端口状态命令:display stp brief

    RSTP:快速生成树协议

    作用:缩短生成树端由阻塞到转发状态的过渡时间
    开启快速生成树的方法
    [ ]stp enable
    [ ]stp mode rstp
    MSTP:多实例生成树 让指定的一个VLAN或者是多个VLAN生成一棵树,实现链路的负载均衡

    展开全文
  • 1、什么是局域网? 局域网LAN(local Area Network) *同一组织/机构建立,没有借助于第三方机构(如运营商)所构建的信息数据传输网,一般...局域网常用技术 以太网技术 局域网常用设备 集线器、交换机 2.2 以太网 ...

    1、什么是局域网?

    局域网LAN(local Area Network)
    *同一组织/机构建立,没有借助于第三方机构(如运营商)所构建的信息数据传输网,一般早10km以内。
    局域网常用技术
    以太网技术
    局域网常用设备
    集线器、交换机

    OSI模型

    路由补充知识:OSI模型

    1、 二层交换机工作在第二层!
    2、三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。 三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。 对于数据包转发等规律性的过程由硬件高速实现,而像路由信息更新、路由表维护、路由计算、路由确定等功能,由软件实现。
    3、ACL包过滤:Acess Control List,即访问控制列表
    4、网关(Gateway):又称网间连接器、协议转换器。网关在网络层以上实现网络互连,是复杂的网络互连设备,仅用于两个高层协议不同的网络互连。网关既可以用于广域网互连,也可以用于局域网互连。 网关是一种充当转换重任的计算机系统或设备。使用在不同的通信协议、数据格式或语言,甚至体系结构完全不同的两种系统之间,网关是一个翻译器。与网桥只是简单地传达信息不同,网关对收到的信息要重新打包,以适应目的系统的需求。同层–应用层。
    5、大型局域网的核心层发生故障将导致之全网故障,
    预防措施:不采用单核心网络,使用双机主备互联、多机环网互联、多机Full-mesh互联等具有冗余备份功能的组网。
    6、双机热备、双机互备、双机双工之间的区别:https://blog.csdn.net/apple9005/article/details/79012625

    展开全文
  • 本书是华为ICT学院路由交换技术官方教材,旨在帮助初级阶段的学生进一步学习网络技术的常用协议和对应的配置方法。 本书的写作顺序为先交换后路由。本书首先对交换网络进行了概述,以便读者学习本书后文的内容。接...
  • 常用的参数: -t 表示将不间断向目标IP发送数据包,直到我们强迫其停止。 用法:ping -t -l 定义发送数据包的大小,默认为32字节,我们利用它可以最大定义到65500字节。 用法:ping [-l length] -n 定义向目标IP...

    1.Ping命令:

    PING (Packet Internet Grope),因特网包探索器,用于测试网络连接量的程序。Ping发送一个ICMP回声请求消息给目的地并报告是否收到所希望的ICMP回声应答。

    是DOS命令,一般用于检查网络是否通畅或者网络连接速度的命令,也叫时延,其值越大,速度越慢。

    同时某些病毒木马会强行大量远程执行ping命令抢占你的网络资源,导致系统变慢,网速变慢。

    它所利用的原理:网络上的机器都有唯一确定的IP地址,我们给目标IP地址发送一个数据包,对方就要返回一个同样大小的数据包,根据返回的数据包我们可以确定目标主机的存在,可以初步判断目标主机的操作系统等。

    常用的参数:

    -t 表示将不间断向目标IP发送数据包,直到我们强迫其停止。 用法:ping -t

    -l 定义发送数据包的大小,默认为32字节,我们利用它可以最大定义到65500字节。

    用法:ping [-l length]

    -n 定义向目标IP发送数据包的次数,默认为3次。用法:ping [-n count]

    例如:ping 127.0.0.1

    83b387dde8bae10b47d94469fe3b8140.png

    127.0.0.1是回送地址,指本地机。若能ping通则说明本地网卡或TCP/IP协议没有故障;若ping不通则说明本地网卡或TCP/IP协议有故障;

    2.nbtstat

    (一)概述

    显示基于 TCP/IP 的 NetBIOS (NetBT) 协议统计资料、本地计算机和远程计算机的 NetBIOS 名称表和 NetBIOS 名称缓存。nbtstat 可以刷新 NetBIOS 名称缓存和使用 Windows Internet 名称服务 (WINS) 注册的名称。

    该命令使用TCP/IP上的NetBIOS显示协议统计和当前TCP/IP连接,使用这个命令你可以得到远程主机的NetBIOS信息,比如用户名、所属的工作组、网卡的MAC地址等

    (二)、语法:

    nbtstat [-a RemoteName] [-A IPAddress] [-c] [-n] [-r] [-R] [-RR] [-s] [-S] [Interval]

    nbtstat的基本参数

    -a 列出为其主机名提供的远程计算机名字表。

    -A 列出为其IP地址提供的远程计算机名字表。

    -c 列出包括了IP地址的远程名字高速缓存器。

    -n 列出本地NetBIOS名字。

    -r 列出通过广播和WINS解析的名字。

    -R 消除和重新加载远程高速缓存器名字表。

    -S 列出有目的地IP地址的会话表。

    -s 列出会话表对话。

    3.netstat

    (一)、概述

    Netstat是DOS命令,是一个监控TCP/IP网络的非常有用的工具,它可以显示路由表、实际的网络连接以及每一个网络接口设备的状态信息.Netstat用于显示与IP、TCP、UDP和ICMP协议相关的统计数据,一般用于检验本机各端口的网络连接情况。

    (二)、语法:

    netstat [-a] [-b] [-e] [-n] [-o] [-p proto] [-r] [-s] [-v]

    netstat的基本参数

    -a 显示所有连接和监听端口。

    -b 显示包含于创建每个连接或监听端口的可执行组件。

    -e 显示以太网统计信息。

    -n 以数字形式显示地址和端口号。

    -o 显示与每个连接相关的所属进程 ID。

    -s 显示按协议统计信息。

    -v 与 -b 选项一起使用时将显示包含于为所有可执行组件创建连接或监听端口的组件

    4f993c2515c582d20bc5596afa0948ac.png

    4.tracert

    Tracert(跟踪路由)是路由跟踪实用程序,用于确定 IP 数据报访问目标所采取的路径。Tracert 命令用 IP 生存时间 (TTL) 字段和 ICMP 错误消息来确定从一个主机到网络上其他主机的路由。

    8a279952f9dd501eb446dc5ecfaab8da.png

    5.arp

    地址解析协议,显示和修改arp缓存中的项目。arp 缓存中包含一个或多个表,它们用于存储 IP 地址及其经过解析的以太网或令牌环物理地址。

    计算机上安装的每一个以太网或令牌环网络适配器都有自己单独的表。

    如果在没有参数的情况下使用,则 arp 命令将显示帮助信息。

    arp缓存表查看方法

    arp -a 显示所有接口的当前arp缓存表。

    arp -d 命令可以删除ARP表中所有的内容;

    arp -d IP 可以删除指定ip所在行的内容

    arp -s 可以手动在ARP表中指定IP地址与MAC地址的对应,类型为static(静态),此项存在硬盘中,而不是缓存表,计算机重新启动后仍然存在,且遵循静态优于动态的原则,所以这个设置不对,可能导致无法上网.

    d0d956c8c8bf2d7abcd8097e96107d31.png

    6.Net

    net view

    作 用:显示域列表、计算机列表或指定计算机的共享资源列表。

    命令格式:net view [computername | /domain[:domainname]]

    参数介绍:

    (1)键入不带参数的net view显示当前域的计算机列表。 (2)computername 指定要查看其共享资源的计算机。 (3)/domain[:domainname]指定要查看其可用计算机的域。

    展开全文
  • 在传统技术中,常用更换高速率的接口板或更换支持高速率接口板的设备的方式来增加带宽,但这种方案需要付出高额的费用,而且不够灵活。采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一个...
  • 本书全面地介绍了数据通信的基本原理,从LTE承载的通信架构出发,对IP基础内容、通用数据链路层技术常用路由协议、MPLS关键技术进行了详细介绍;同时,也对IP的后续演进协议IPv6、安全设备防火墙、SDN等进行了简单...
  •  路由交换(数通)基础知识 2). 网络基本概念、IP网络构架、标准化组织与协议 3). OSI、TCP/IP协议模型结构、各个层次的功能以及报文封装 4). IPv4子网划分 5). ARP原理 6). TCP/UDP原理 7). 数据转发...
  • 常用路由协议的梳理静态路由:优点:无需进行路由交换、更高的安全性、有的情况下必须使用静态路由,如DDR、使用NAT技术的网络环境。缺点:网络的扩展性能差、配置烦琐。动态路由:(Rip、OSPF、EIGRP、BGP)Rip具有...
  • Switching Plus,H3C认证路由交换互联网络专家)。H3CIE-RS+认证强调和注重网络规划、网络故障排查等综合能力的培养。H3CIE-RS+认证不仅将帮助您掌握大中型数据网络中常用网络技术知识和规划设计知识,还将让您具备...
  • 路由交换(数通)基础知识        2). 网络基本概念、IP网络构架、标准化组织与协议        3). OSI、TCP/IP协议模型结构、各个层次的...
  • 在传统技术中,常用更换高速率的接口板或更换支持高速率接口板的设备的方式来增加带宽,但这种方案需要付出高额的费用,而且不够灵活。 采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一...
  • 你的技术员不行么,没把有些端口屏蔽咯。 建议从新装系统,给每台计算机MACK地址和IP帮定了, 解决方案1:关闭局域网内所有交换机5分钟后。重新接通电源,观察网络是否恢复正常!(原因:可能是交换机长时间没有...
  • 在早期网络发展当中所使用的路由交换协议已经不再满足现今的网络规模和发展速度,我们今天就来看看“从古至今”常用的路由和交换协议。RIP动态路由协议:路由信息协议(Routing Information Protocol,缩写:RIP)是一...
  • 二、单臂路由

    千次阅读 2020-02-02 15:23:04
    ​ VLAN技术交换网络中非常基础的技术。在网络组件中,通过在交换机上划分适当数目的VLAN,不仅能有效隔离广播风暴,还能提高网络安全安全系数及网络带宽的利用效率。划分VLAN之后,解决VLAN间通信的通常的常用...
  • 在确定你要折腾无线路由器之前,请先确认你具备以下几点技能:1、对电子电路有一定...2、对网络技术有一定了解,知道IP寻址原理、NAT、路由交换、vlan等常用含义;3、对计算机技术有一定的了解,能熟练操作win...
  • 网通交换培训教材

    2012-07-10 10:56:19
    1.2 交换技术 8 1.2.1 电路交换 8 1.2.2 报文交换 8 1.2.3 分组交换 9 1.3 信令基础 10 1.3.1 信令的概念 10 1.3.2 信令的分类 12 1.4 软交换基础 17 1.4.1 软交换的概念 17 1.4.2 软交换的接口协议 18 第2章 程控...
  • 认识网络、几种常用的网络拓扑图

    千次阅读 2020-07-20 20:11:35
    交换协议: VLAN技术:虚拟局域网 STP技术:生成树协议 VRRP技术:虚拟路由冗余协议 VPN:虚拟专用网络 名词解释 路由协议:http、HTTPS、tcp、ip 静态路由配置 OSPF协议 RIP协议 ACL访问控制 什么是网络? 简单点...
  • 1、计算机网络=通信技术+计算机技术 所以计算机网络就是一种特殊的通信技术。 定义:计算机网络就是互连的、...网络核心:1)关键功能:路由+转发 2)解决的基本问题,即源主机->目的主机:数据交换 ISP ...
  • 版权声明 主要针对希赛出版的架构师考试教程《系统架构设计师...2.交换技术 (1)电路交换 (2)报文交换 (3)分组交换 特点与应用场合 3. 路由技术 路由协议 (1)内部网关协议 (2)外部网关协议 (3)核心网...
  • CISCO 技术大集合

    2013-05-22 01:07:13
    CISCO 技术大集合 {适合你们的技术} 二、命令状态 1. router> 路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容。 2. router# 在router>提示符...
  • 思科网络技术学院教程CCNA1

    热门讨论 2013-05-28 06:37:53
     本书为思科网络技术学院第1学期的配套书面教程,主要内容包括:网络介绍、网络技术基础、网络介质、线缆测试、局域网和广域网布线、以太网基础、以太网技术、以太网交换、tcp/ip协议族和ip寻址、路由基础和子网、...
  • 1、应用层--常用协议包括HTTP、HTTPS、SMTP、POP3、FTP等,主要是客户端与服务器端的数据交换方法。 2、传输层--定义数据传输的方法,主要定义了两种协议,分别是TCP协议与UDP协议。TCP协议在传输数据时会检查数据...
  • 路由交换常用架构6.通过各主流厂商模拟器模拟实际操作7.参考各厂商官网方案不断复盘,举一反三8.常见防火墙设备的选型调试9.网络安全、行为管理技术、堡垒机等安全必备技术根据市场需求不断更新网络技术知识 转载于:...
  • 前言 本文梳理网络层相关知识。 网络层概述 网络层的主要任务是把分组从源端传到目的端,为分组交换网上的不同主机...从整个网络层数据交换技术的发展来看,交换技术经历了一个由电路交换、报文交换到现在最常用的分
  • ,结合模拟软件全面地分析和调试各种网络设备,完成路由交换等实验内容,在实际操作中理解网络技术,逐步巩固和深化理论知识,从而掌握网络工程中的常用技术和实际操作技能。
  • 计网实验笔记

    2019-04-07 20:13:07
    常见的网络技术 以太网、令牌环、FDDI(光纤分布式数据接口)、分组交换(packet switching)、信元交换(ATM)、无线网络(wireless network)、互联协议(Internet Protocol) 路由种类 静态路由 动态路由 ...
  • 网络基础知识及拓扑

    2020-07-20 20:07:48
    交换协议: VLAN技术:虚拟局域网 STP技术:生成树协议 VRRP技术: SVI: 路由协议: 静态路由配置 OSPF协议 RIP协议 ACL访问控制 2、网络常见图标 3、网络设计的基本原则 可靠性 为使网络可靠地运行,我们方案中...
  • CISCO完全手册(英文版)

    2008-12-13 08:39:47
    由联网基础开始,详细讲解了Cisco联网技术、Cisco局域网交换技术以及Cisco路由的有关内容。既有当前最热门问题的详细讨论,如无线局域网、MLS和虚拟个人网络,也有关于交换方法、路由、访问列表和故障排除等方面的...
  • lvs负载均衡群集

    2018-01-29 21:50:21
    前言:我们在学习路由交换的时候讲过hsrp热备份路由协议,今天要给大家介绍的是lvs群集,为了实现负载均衡,提高服务器的工作效率,当其中有服务器发生故障的时候也不会影响客户的访问。群集在企业中应用非常广泛,...

空空如也

空空如也

1 2 3 4
收藏数 65
精华内容 26
关键字:

常用路由交换技术