精华内容
下载资源
问答
  • 华为路由器、交换机配置命令

    万次阅读 多人点赞 2018-12-29 21:38:41
    华为路由器交换机配置命令是大家使用时经常遇到的,顾名思义关于交换机的计算机命令,路由器命令交换机命令和动静态命令都将在文中提到。 史上最全华为路由器交换机配置命令大合集,熟练掌握下面的华为路由器...

    计算机命令、路由器命令、交换机命令、动静态命令都将在文中提到,主要针对华为路由器、交换机配置命令,熟练掌握下面的华为路由器、交换机配置的知识点,你只需花几分钟的时间,就能明白华为路由器、交换机配置。

    1、常用命令

    日常工作中,我们经常用到的计算机PC上的一些命令,比如:

    No. Command Note
    1 ping 192.168.1.1 检查网络的连通性
    2 tracert 10.10.10.1 跟踪路由
    3 ipconfig /all 查看本机连接的IP配置
    4 arp -a 查看本机的arp缓存表
    5 route print 查看路由表
    6 nslookup *.com 查询域名对应ip地址
    7 nbtstat -n 查询本机网络配置
    8 netstat 显示活动的TCP信息
    9 net 解决网络问题
    10 ftp 10.10.10.1 远程登录上传和下载
    11 telnet 10.10.10.1 远程登录

    2、快速命令

    这些命令,有时候也会用到,比如:

    item command note
    1 login 登录
    2 logout 注销
    3 shutdown-now 关机
    4 init 0 关机

    3、组合命令

    sn. command note
    1 ifconfig eth0 net mask 设置IP地址
    2 ifconfig eth0 mask down 禁用IP地址
    3 route add 0.0.0.0 gw 设置网关
    4 route del default gw 删除网关
    5 route add default gw 设置网关

    华为路由器交换机配置命令

    友情提示:华为设备加电开机后,在命令行(CLI)界面,可以看到_,然后使用下面这些命令,进行各种配置,这些配置保存在设备上,使用save进行保存。

    no. item command
    1 sys 进入系统视图
    2 sys R1 修改设备名称R1
    3 un in en 关闭日志提醒
    4 dis cur 显示当前配置
    5 dis int 显示接口信息
    6 dis vlan all 显示路由信息
    7 dis ver 显示版本信息
    8 super password 修改特权用户密码
    9 int e0/1 进入接口视图
    10 ip add 10.65.1.1 255.255.255.0 配置接口IP
    11 ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 静态路由=网关
    12 rip 三层交换机支持rip路由协议
    13 local-user ftp ftp远程上传和下载
    14 int vty 0 4 进入虚拟终端
    15 authentication-mode password 设置口令模式
    16 set authentication-mode password simple 123 设置口令
    17 user privilege level 3 用户级别
    18 int 0/1 进入端口模式
    19 duplex{half 100
    20 speed {10
    21 flow-control 配置端口流控
    22 mdi{across auto
    23 port link-type{trunk access
    24 port access vlan 3 当前端口加入到VLAN
    25 port trunk pvid vlan 3 设置trunk端口的PVID
    26 undo shutdown 激活端口
    27 shutdown 关闭端口
    28 quit 返回上一级
    29 vlan 3 创建VLAN
    30 [R1-vlan3]port e0/1 在VLAN中增加端口
    31 [R1-vlan3]port e0/1 to e0/4 在VLAN中增加4个端口
    32 monitor-port 指定镜像端口
    33 port mirror 指定被镜像端口
    34 port mirror int_listobserving-port int_type int_num 指定镜像和被镜像
    35 descriptionstring 指定VLAN描述字符
    36 description 删除VLAN描述字符
    37 dis vlan 3 查看VLAN设置
    38 stp{enable disable}
    39 stp priority 4096 设置交换机的优先级
    40 stp root{primary secondary}
    41 stp cost 200 设置交换机的端口花费
    42 link-aggregatione0/1 to e0/4 {ingress both}
    43 undo link-aggregatione {0/1 all}
    44 isolate-user-vlan enable 设置主VLAN
    45 isolate-user-vlan secondary 设置主VLAN包括的子VLAN
    46 port hybrid pvid vlan 设置VLAN的PVID
    47 port hybrid pvid 删除VLAN的PVID
    48 port hybrid vlan vlan_id_list untagged 设置无标识的VLAN,如果包的VLANID与PVID一致,则去掉VLAN信息,因病认PVID=1,所以,设置PVID为所属的VLANID,设置可以互通的VLAN为untagged。

    路由器命令

    no. command note
    1 dispaly version 显示版本信息
    2 display current-configuration 显示当前配置
    3 display interfaces 显示接口信息
    4 display ip route 显示路由信息
    5 sysname R1 更改设备名称
    6 super password 123 设置口令
    7 interface serial 0 进入接口
    8 ip address 配置端口IP地址
    9 un shutdown 激活端口
    10 link-protocol hdlc 绑定hdlc协议
    11 user-interface vty 0 4 设置虚拟电路
    12 authentication-mode password 虚拟电路密码
    13 set authentication-mode password simple 123 简单密码
    14 user privilege level 3 用户级别
    15 quit 返回上一级
    16 debugging hdlc all serial 0 显示所有信息
    17 debugging hdlc event serial 0 调试事件信息
    18 debugging hdlc packet serial 0 显示包信息

    华为路由器设备命令

    No. command note
    1 ip route-static 129.1.0.0 16 10.0.0.2 静态路由到IP
    2 ip route-static 192.1.0.0 255.255.0.0 10.0.0.2 静态路由到IP
    3 ip route-static 129.1.0.0 16 serial2 静态路由到接口
    4 ijp route-static 0.0.0.0 0.0.0.0 10.0.0.2 静态路由默认到IP
    5 rip 设置动态路由
    6 rip work 设置工作允许
    7 rip input 设置入口允许
    8 rip output 设置出口允许
    9 network 10.0.0.0 设置交换路由网络
    10 net work all 设置与所有网络交换
    11 peer ip -address
    12 summary 路由合
    13 rip version1 设置工作在版本1
    14 rip version2 multicast 设置版本2,多播方式
    15 rip split-horizon 水平分隔
    16 route rid A.B.C.D 配置路由器的ID
    17 ospf enable 启动OSPF协议
    18 import-route direct 引入直连路由
    19 ospf enable area 配置ospf区域
    20 rule normal permit source 10.0.0.0 0.0.0.255 允许源地址
    21 rule normal deny source any 阻止源地址

    扩展访问控制列表操作符的含义

    No. item note
    1 equal port number 等于
    2 greater-than port number 大于
    3 less-than port number 小于
    4 not-equal port number 不等
    5 range port number1 portnumber2 区间

    扩展访问控制列表举例

    [Quidway]acl101
    [Quidway-acl-101]rule deny souce any destination any
    [Quidway-acl-101]rule permit icmp source any destination any icmp-type echo
    [Quidway-acl-101]rulepermit icmp source any destination any icmp-type echo-reply
    [Quidway]acl 102
    [Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0
    [Quidway-acl-102]rule deny ip source any destination any
    [Quidway]acl 103
    [Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp
    [Quidway-acl-103]rule permit tcp source any destination10.0.0.2 0.0.0.0 destination-port equal www
    [Quidway]firewall enable
    [Quidway]firewall default permit|deny
    [Quidway]inte0
    [Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound
    [Quidway]firewallenable [Quidway]firewall default permit
    [Quidway]acl 101
    [Quidway-acl-101]rule deny ip source any destination any
    [Quidway-acl-101]rule permit ipsource 129.38.1.10 destination any [Quidway-acl-101]rule permit ipsource 129.38.1.20 destination any [Quidway-acl-101]rule permit ipsource 129.38.1.30 destination any [Quidway-acl-101]rule permit ipsource 129.38.1.40 destination any [Quidway-acl-101]quit
    [Quidway]int e0
    [Quidway-Ethernet0]firewall packet-filter 101 inbound
    [Quidway]acl 102
    //外部特定主机和大于1024端口的数据包允许进入S0
    [Quidway-acl-102]rule deny ipsource any destinationany
    [Quidway-acl-102]rule permit tcp source 202.39.2.30 destination 202.38.160.10
    [Quidway-acl-102]rule permit tcp source any destination 202.38.160.10 destination-port great-than 1024
    [Quidway-acl-102]quit
    [Quidway]int s0
    [Quidway-Serial0]firewall packet-filter 102 inbound;202.38.160.1是路由器出口IP。
    [Quidway-Serial0]nat outbound 101 interface;是Easyip,将acl101允许的IP从本接口出时变换源地址。
    

    内部服务器地址转换配置命令(静态nat):

    nat server global[port]inside port[protocol]
    global_port不写时使用inside_port
    [Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.1 ftp tcp [Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.2 telnet tcp
    [Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.3 www tcp 
    
    设有公网IP:202.38.160.101~202.38.160.103可以使用。;对外访问(原例题) [Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1;建立地址池 [Quidway]acl1
    [Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255;指定允许的内部网络 [Quidway-acl-1]rule deny source any
    [Quidway-acl-1]int serial 0
    [Quidway-Serial0]nat outbound 1 address-group pool 1;在s0口从地址池取出IP对外访问
    [Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
    [Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
    [Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
    [Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp
    

    PPP设置:

    [Quidway-s0]link-protocol ppp;默认的协议
    

    PPP验证

    主验方:pap|chap 
    [Quidway]local-user q2 password{simple|cipher}hello;路由器1 [Quidway]interface serial0
    [Quidway-serial0]ppp authentication-mode{pap|chap}
    [Quidway-serial0]ppp chap user q1;pap时,没有此句
    
    pap被验方:
    [Quidway]interface serial0;路由器2
    [Quidway-serial0]ppp pap local-user q2 password{simple|cipher}hello
    
    chap被验方: [Quidway]interfaceserial0;路由器2 [Quidway-serial0]pppchapuserq2;自己路由器名 [Quidway-serial0]local-userq1password{simple|cipher}hello;对方路由器名 帧中继frame-relay(二分册6-61) [q1]frswitching [q1]ints1 [q1-Serial1]ipaddress192.168.34.51255.255.255.0 [q1-Serial1]link-protocolfr
    

    装帧中继协议

    [q1-Serial1]fr interface-type dce
    [q1-Serial1]fr dlci 100
    [q1-Serial1]fr in arp
    [q1-Serial1]fr map ip 192.168.34.52 dlci 100
    [q2]ints1
    [q2-Serial1]ip address 192.168.34.52 255.255.255.0
    [q2-Serial1]link-protocol fr
    [q2-Serial1]fr interface-type dte
    [q2-Serial1]fr dlci 100
    [q2-Serial1]fr in arp
    [q2-Serial1]fr map ip 192.168.34.51 dlci 100
    

    帧中继监测

    [q1]display fr lmi-info[]interface type number]
    [q1]display fr map
    [q1]display fr pvc-info[serial interface-number][dlci dlci-number] [q1]display fr dlci-switch
    [q1]display fr interface
    [q1]reset fr in arp-info
    [q1]debugging fr all[interface type number] [q1]debugging fr arp[interface type number]
    [q1]debugging fr event[interface type number] [q1]debugging fr lmi[interface type number]
    

    启动ftp服务

    [Quidway]local-user ftp password{simple|cipher}aaa service-type ftp [Quidway]ftp server enable
    
    展开全文
  • 交换机基本命令

    2019-04-27 14:42:00
    1 案例1:交换机基本命令模式 1.1 问题 本例要求熟练掌握交换机每个模式的配置命令 对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端...

    1 案例1:交换机基本命令模式

    1.1 问题

    本例要求熟练掌握交换机每个模式的配置命令

    对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式远程访问、配置交换机,这种方式要求此交换机已配置有IP地址且已接入计算机网络,后续课程会学习此访问方式。

    1)通过超级终端访问交换机

    2)交换机工作模式的进入与退出

    真实设备环境,如图-1所示。

    图-1

    1.2 方案

    本例中的配置练习可采用思科模拟器 —— Cisco Packet Tracer 6.2来实现。

    1)安装Packet Tracer 6.2

    双击安装包执行默认安装,然后将中文语言文件Chinese.ptl解压到安装目录下的多语言文件夹,比如C:\Program Files (x86)\Cisco Packet Tracer 6.0\languages。

    双击桌面的Cisco Packet Tracer快捷方式以启动程序,打开菜单“Options”-->“Preferences”-->切换到“Interface”选项卡-->选择下方的Chinese.ptl-->单击右下角“Change Language”按钮,弹出提示时单击“OK”,如图-2所示。

    图-2

    关闭当前Packet Tracer程序,然后再重新启动此程序,可发现已经变成中文语言界面了(当前汉化的还不完整),如图-3所示。

    图-3

    2)建立实验网络拓扑

    在Packet Tracer程序主窗口中,添加一台Cisco 2960交换机、一台普通PC机,并添加Console连接、直通网线连接,如图-4所示,确认完毕后将当前拓扑结构保存为c2960-pc.pkt文件。

    图-4

    其中,连接细节如下:

    • 交换机的Console口 <--> PC机的RS 232串口。
    • 交换机的FastEthernet0/24接口 <--> PC机的FastEthernet0网卡。

    1.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:通过超级终端访问交换机。

    1)配置并打开超级终端

    在此前建立的Packet Tracer实验拓扑环境中,单击PC机以打开此设备,确认电源已启动(机箱示意图上的指示灯为黄绿色),切换到“桌面选项卡”,如图-5所示,找到其中的“终端”并单击打开。

    图-5

    在弹出的终端配置窗口中,如图-6所示,单击“确定”以接受默认值。

    图-6

    接下来就可以看到“终端”窗口了,其中显示了通过Console线连接的交换机初始化信息,回车后可进入交换机的“Switch>”配置系统,如图-7所示。

    图-7

    提示:在Packet Tracer环境中,可直接单击交换机图标,然后切换到“命令行”选项卡,也可以进入IOS配置环境。

    步骤二:交换机工作模式的进入与退出

    1) 交换机工作模式的进入如下:

    1. Switch>enable //切换为特权模式
    2. Switch# configure terminal     //进入全局配置模式
    3. Enter configuration commands, one per line. End with CNTL/Z.
    4. Switch(config)#interface fastEthernet 0/1 //进入接口模式
    5. Switch(config-if)#

    2)交换机工作模式的退出下:

    1. Switch(config-if)#exit //接口模式退到全局配置模式
    2. Switch(config)#exit //全局配置模式退到特权模式
    3. Switch#exit //特权模式退到用户模式
    4. Switch>

    注:exit 返回上一模式

    end 从接口或者特全局配置模式回到特权模式,快捷键Ctrl+z同等效果

    思科设备命令行不区分大小写,与Linux命令行不同

    命令输入错误卡住时同时按键盘ctrl+shift+6这三个键即可

    2 案例2:交换机命令行基本配置

    2.1 问题

    修改及查看交换机配置

    1)修改交换机主机名

    2)查看交换机配置信息

    3)查看IOS名称以及版本信息

    2.2 方案

    在Packet Tracer程序主窗口中,添加一台Cisco 2960交换机,进入交换机,输入相关命令进行配置和查看交换机

    2.3 步骤

    实现此案例需要按照如下步骤进行。

    步骤一:修改交换机主机名

    进入全局配置模式后,使用hostname指令可以为交换机设置主机名。例如,以下操作可以将主机名设置为s1:

    1. Switch(config)# hostname s1                     //配置主机名
    2. s1(config)#    

    步骤二:查看交换机配置信息

    查看交换机当前的运行配置:

    1. 查看交换机当前的运行配置(或write terminal):
    2. s1# show running-config                 //查看当前的运行配置
    3. Building configuration...
    4. Current configuration : 1052 bytes
    5. !
    6. version 12.2
    7. no service timestamps log datetime msec
    8. no service timestamps debug datetime msec
    9. no service password-encryption
    10. !
    11. hostname sw1                         //已配置主机名
    12. !
    13. !
    14. !
    15. !
    16. spanning-tree mode pvst
    17. !
    18. interface FastEthernet0/1
    19. !
    20. interface FastEthernet0/2
    21. !
    22. interface FastEthernet0/3
    23. !
    24. interface FastEthernet0/4
    25. !
    26. interface FastEthernet0/5
    27. !
    28. interface FastEthernet0/6
    29. !
    30. interface FastEthernet0/7
    31. !
    32. interface FastEthernet0/8
    33. !
    34. interface FastEthernet0/9
    35. !
    36. interface FastEthernet0/10
    37. !
    38. interface FastEthernet0/11
    39. !
    40. interface FastEthernet0/12
    41. !
    42. interface FastEthernet0/13
    43. !
    44. interface FastEthernet0/14
    45. !
    46. interface FastEthernet0/15
    47. !
    48. interface FastEthernet0/16
    49. !
    50. interface FastEthernet0/17
    51. !
    52. interface FastEthernet0/18
    53. !
    54. interface FastEthernet0/19
    55. !
    56. interface FastEthernet0/20
    57. !
    58. interface FastEthernet0/21
    59. !
    60. interface FastEthernet0/22
    61. !
    62. interface FastEthernet0/23
    63. !
    64. interface FastEthernet0/24
    65. !
    66. interface GigabitEthernet1/1
    67. !
    68. interface GigabitEthernet1/2
    69. !
    70. interface Vlan1
    71. no ip address
    72. shutdown
    73. !
    74. !
    75. line con 0
    76. !
    77. line vty 0 4
    78. login
    79. line vty 5 15
    80. login
    81. !
    82. !
    83. end
    84. sw1#

    步骤三:查看IOS名称以及版本信息

    查看ios名称及版本信息

    1. s1#show version
    2. Cisco Internetwork Operating System Software
    3. IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE(fc1)
    4. Copyright (c) 1986-2005 by cisco Systems, Inc.
    5. Compiled Wed 18-May-05 22:31 by jharirba
    6. Image text-base: 0x80010000, data-base: 0x80562000
    7. ROM: Bootstrap program is is C2950 boot loader
    8. Switch uptime is 1 minutes, 39 seconds
    9. System returned to ROM by power-on
    10. Cisco WS-C2950-24 (RC32300) processor (revision C0) with 21039K bytes of memory.
    11. Processor board ID FHK0610Z0WC
    12. Last reset from system-reset
    13. Running Standard Image
    14. 24 FastEthernet/IEEE 802.3 interface(s)
    15. 63488K bytes of flash-simulated non-volatile configuration memory.
    16. Base ethernet MAC Address: 00E0.B026.B88C
    17. Motherboard assembly number: 73-5781-09
    18. Power supply part number: 34-0965-01
    19. Motherboard serial number: FOC061004SZ
    20. Power supply serial number: DAB0609127D
    21. Model revision number: C0
    22. Motherboard revision number: A0
    23. Model number: WS-C2950-24
    24. System serial number: FHK0610Z0WC
    25. Configuration register is 0xF

    3 案例3:交换机密码设置

    3.1 问题

    配置交换机的访问口令

    1)配置用户进入特权模式的明文密码为123

    2)配置用户进入特权模式的密文密码为456

    3)配置conslole口令为789

    3.2 方案

    配置交换机访问口令

    实现此案例需要按照如下步骤进行。

    3.3 步骤

    步骤一:交换机密码配置

    1)设置特权模式口令

    包括两种典型的方法:

    方法1(明文):enable password 密码字串

    方法2(加密):enable secret 密码字串

    比如,以下操作将明文口令设为123、加密口令设置为456:

    1. sw2960(config)# enable password 123
    2. sw2960(config)# enable secret 456

    返回特权模式,查看运行配置可观察两种口令设置的差异:

    1. sw2960(config)# end     //返回特权模式
    2. sw2960#
    3. %SYS-5-CONFIG_I: Configured from console by console
    4. sw2960# show running-config     //查看当前的运行配置
    5. .. ..
    6. !
    7. hostname sw2960
    8. !
    9. enable secret 5 $1$mERr$pUBB1obEqpmMUtC1rBieD1         //加密口令设置
    10. enable password 123    //非加密的口令设置
    11. !
    12. !
    13. .. ..

    执行disable切换到用户模式,再执行enable切换到特权模式,此时会要求输入正确的口令才允许进入(如果明文/密文口令都设置了,则密文口令起作用):

    1. sw2960> enable
    2. Password:     //尝试明文口令123无效
    3. Password: //输入密文口令456验证成功
    4. sw2960#

    步骤二:设置console口令

    以下操作配置交换机console口令

    1. Sw2960(config)#line console 0
    2. Sw2960(config-line)#password 789 //设置consol口令
    3. Sw2960(config-line)#login

    切换到用户模式,提示输入conslole口令才能再次进入到用户模式:

    1. Sw2960(config-line)#end
    2. Sw2960#
    3. %SYS-5-CONFIG_I: Configured from console by console
    4. Sw2960#exit
    5. Sw2960 con0 is now available
    6. Press RETURN to get started.
    7. User Access Verification
    8. Password:

    步骤三:清空设备配置

    1. Switch(config)#exit
    2. Switch#write
    3. Switch#erase startup-config
    4. Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] //此时系统询问是否确定删除,按回车即可
    5. [OK]
    6. Erase of nvram: complete

    步骤四:重启设备检测配置状况

    1. Switch#reload
    2. Proceed with reload? [confirm] //此时系统询问是否确定重启,按回车即可

    转载于:https://www.cnblogs.com/tiki/p/10778723.html

    展开全文
  • 网工交换机配置命令

    2019-10-15 11:43:36
    交换机配置基本命令 system-view //进入系统视图 sysname R1 //修改设备名称 interface GigabitEthernet 0/0/0 //进入R1 GE0接口 ip address 12.1.1.1 24 //GE0接口配置IP 密码认证模式 ...
    • 交换机配置基本命令
    system-view						//进入系统视图
    sysname R1						//修改设备名称
    interface GigabitEthernet 0/0/0	//进入R1 GE0接口
    ip address 12.1.1.1 24			//GE0接口配置IP
    

    密码认证模式

    system-view
    sysname R1
    user-interface console 0		//进入console线路
    authentication-mode password	//选择密码认证模式
    

    aaa认证模式

    user-interface console 0
    authentication-mode aaa			//选择aaa模式的认证
    aaa								//进入aaa认证模式
    local-user user0 password cipher huawei123	//创建账号及对应密码
    local-user user0 privilege level 0			//分配账号权限级别
    quit
    

    配置ssh远程登录

    stelnet server enable			//开启SSH协议
    rsa local-key-pair create		//创建加密报文的密钥对
    1024							//密钥长度
    aaa								//使用aaa认证模式
    local-user user-ssh password cipher huawei123	//创建账号及对应密码
    local-user user-ssh privilege level 2			//分配账号权限级别
    local-user user-ssh service-type ssh			//创建ssh用户
    quit
    user-interface vty 0 4  						//进入vty线路
    authentication-mode aaa
    protocol inbound ssh							//开启vty线路的ssh访问功能
    quit
    ssh user user-ssh authentication-type all		//定义ssh用户的认证模式
    
    

    接口隔离配置

    system-view
    port-isolate mode L2		//端口隔离模式选择L2
    interface GigabitEthernet 0/0/0		//进入GE0接口
    port-isolate enable group 1			//接口隔离选择默认组1
    

    接口速率及模式设置

    system-view
    interface GigabitEthernet 0/0/1		//进入GE1接口
    negotiation auto					//自动协商
    auto speed 100						//协商速率为100
    auto duplex full					//全双工模式
    

    查看所有MAC地址表项:display mac-address
    显示vlanif接口的MAC地址:display interface vlanif 10
    在MAC地址表中增加静态MAC地址表项,目的MAC地址为0001-0002-0003,VLAN10的报文从接口Ethernet0/0/5转发出去

    mac-address static 0001-0002-0003 ethernet 0/0/5 vlan 10
    
    • 配置和管理VLAN
      基于接口划分VLAN
    vlan 10					//创建vlan10
    quit
    vlan 20					//创建vlan20
    quit
    display vlan summary	//查看设备vlan信息
    interface Ethernet0/0/1
    port link-type access	//配置接口类型
    port default valn 10	//将接口e0/0/1划入对应的vlan10
    quit
    interface Ethernet0/0/2
    port default valn 20	//将接口e0/0/2划入对应的vlan20
    quit
    interface Ethernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 30	//将接口e0/0/3划入对应的vlan30
    

    基于MAC地址划分VLAN

    system-view
    sysname SwitchA
    vlan batch 2
    interface GigabitEthernet 0/0/1
    port link-type hybrid
    port hybrid tagged vlan 2	//通过vlan2
    quit
    interface GigabitEthernet 0/0/2
    port link-type hybrid 		//配置接口类型为hybrid
    port hybrid untagged vlan 2	//将接口加入vlan2
    quit
    vlan 2						//进入vlan2配置
    mac-vlan mac-address 22-22-22-22	//PC的MAC地址与VLAN2关联
    quit
    interface GigabitEthernet 0/0/2
    mac-vlan enable 					//基于MAC地址启用接口
    
    
    • 配置GVRP协议
      全局使能GVRP功能
    system-view
    sysname SwitchA
    vcmp role silent
    

    配置接口为Trunk类型,并允许所有VLAN通过

    interface GigabitEthernet 0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    interface GigabitEthernet 0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit 
    

    使能接口GVRP功能,并配置接口注册模式

    interface GigabitEthernet 0/0/1
    gvrp
    gvrp registration normal
    quit
    interface GigabitEthernet 0/0/2
    gvrp
    gvrp registration normal
    quit
    

    最后推荐一个公众号,一枚IT技术人成长路上关于生活和职场的思考,欢迎书友们前来交流和分享心得

    在这里插入图片描述

    展开全文
  • 交换机基本命令模式

    千次阅读 2019-05-16 13:04:53
    交换机基本命令模式 对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式...

    交换机基本命令模式

    对于思科交换机来说,主要有2种配置途径:
    其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;
    其二,通过telnet方式远程访问、配置交换机,这种方式要求此交换机已配置有IP地址且已接入计算机网络。
    1)通过超级终端访问交换机
    2)交换机工作模式的进入与退出
    真实设备环境,如图所示。
    在这里插入图片描述

    本例中的配置练习可采用思科模拟器 —— Cisco Packet Tracer 6.2来实现。

    安装Packet Tracer 6.2

    双击安装包执行默认安装,然后将中文语言文件Chinese.ptl解压到安装目录下的多语言文件夹,比如C:\Program Files (x86)\Cisco Packet Tracer 6.0\languages。
    双击桌面的Cisco Packet Tracer快捷方式以启动程序,打开菜单“Options”–>“Preferences”–>切换到“Interface”选项卡–>选择下方的Chinese.ptl–>单击右下角“Change Language”按钮,弹出提示时单击“OK”,如图所示。
    在这里插入图片描述
    关闭当前Packet Tracer程序,然后再重新启动此程序,可发现已经变成中文语言界面了(当前汉化的还不完整),如图所示。
    在这里插入图片描述

    (2)建立实验网络拓扑

    在Packet Tracer程序主窗口中,添加一台Cisco 2960交换机、一台普通PC机,并添加Console连接、直通网线连接,如图-4所示,确认完毕后将当前拓扑结构保存为c2960-pc.pkt文件。
    在这里插入图片描述
    其中,连接细节如下:
    交换机的Console口 <–> PC机的RS 232串口。
    交换机的FastEthernet0/24接口 <–> PC机的FastEthernet0网卡。

    一:通过超级终端访问交换机。

    (1)配置并打开超级终端

    在此前建立的Packet Tracer实验拓扑环境中,单击PC机以打开此设备,确认电源已启动(机箱示意图上的指示灯为黄绿色),切换到“桌面选项卡”,如图所示,找到其中的“终端”并单击打开。

    在这里插入图片描述
    在弹出的终端配置窗口中,如图所示,单击“确定”以接受默认值。

    在这里插入图片描述
    接下来就可以看到“终端”窗口了,其中显示了通过Console线连接的交换机初始化信息,回车后可进入交换机的“Switch>”配置系统,如图所示。
    在这里插入图片描述

    提示:在Packet Tracer环境中,可直接单击交换机图标,然后切换到“命令行”选项卡,也可以进入IOS配置环境。

    步骤二:交换机工作模式的进入与退出

    (1) 交换机工作模式的进入如下:

    Switch>enable   //切换为特权模式
    Switch# configure terminal      //进入全局配置模式
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#interface fastEthernet 0/1      //进入接口模式
    Switch(config-if)#
    

    (2)交换机工作模式的退出下:

    Switch(config-if)#exit                           //接口模式退到全局配置模式
    Switch(config)#exit                              //全局配置模式退到特权模式
    Switch#exit                                       //特权模式退到用户模式
    Switch>
    

    注:exit 返回上一模式
    end 从接口或者全局配置模式回到特权模式,快捷键Ctrl+z同等效果
    思科设备命令行不区分大小写,与Linux命令行不同
    命令输入错误卡住时同时按键盘ctrl+shift+6这三个键即可

    交换机基本命令

    在Packet Tracer程序主窗口中,添加一台Cisco 2960交换机,进入交换机,输入相关命令进行配置和查看交换机

    实现此案例需要按照如下步骤进行。

    步骤一:修改交换机主机名

    进入全局配置模式后,使用hostname指令可以为交换机设置主机名。例如,以下操作可以将主机名设置为s1:

    Switch(config)# hostname s1                     //配置主机名
    s1(config)#    
    

    二:查看交换机配置信息

    查看交换机当前的运行配置:
    查看交换机当前的运行配置:

    s1# show running-config                  //查看当前的运行配置
    Building configuration...
    Current configuration : 1052 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname sw1                          //已配置主机名
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
     no ip address
     shutdown
    !
    !
    line con 0
    !
    line vty 0 4
     login
    line vty 5 15
     login
    !
    !
    end
    sw1#
    

    三:查看IOS名称以及版本信息

    查看ios名称及版本信息

    s1#show version 
    Cisco Internetwork Operating System Software
    IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE   SOFTWARE(fc1)
    Copyright (c) 1986-2005 by cisco Systems, Inc.
    Compiled Wed 18-May-05 22:31 by jharirba
    Image text-base: 0x80010000, data-base: 0x80562000
    ROM: Bootstrap program is is C2950 boot loader
    Switch uptime is 1 minutes, 39 seconds
    System returned to ROM by power-on
    Cisco WS-C2950-24 (RC32300) processor (revision C0) with 21039K bytes of memory.
    Processor board ID FHK0610Z0WC
    Last reset from system-reset
    Running Standard Image
    24 FastEthernet/IEEE 802.3 interface(s)
    63488K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00E0.B026.B88C
    Motherboard assembly number: 73-5781-09 
    Power supply part number: 34-0965-01
    Motherboard serial number: FOC061004SZ
    Power supply serial number: DAB0609127D
    Model revision number: C0
    Motherboard revision number: A0
    Model number: WS-C2950-24
    System serial number: FHK0610Z0WC
    Configuration register is 0xF
    

    交换机基本配置

    步骤一:交换机密码配置

    (1)为交换机配置特权密码Taren1
    打开交换机命令行配置界面

    Switch>en
    Switch#conf t
    Switch(config)#enable password Taren1
    

    步骤二:保存配置并重启设备检测密码可用情况

    Switch(config)#exit
    Switch#write
    Switch#reload
    ……….
    ………
    Switch>enable
    Password:                            //此时需要输入密码才能进入特权模式
    

    步骤三:清空设备配置

    Switch#erase startup-config
    Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]         //此时系统询问是否确定删除,按回车即可
    [OK]
    Erase of nvram: complete
    

    步骤四:重启设备检测配置状况

    Switch#reload
    Proceed with reload? [confirm]      //此时系统询问是否确定重启,按回车即可
    
    展开全文
  • 华为交换机配置,仅供参考:1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位...
  • 锐捷交换机配置命令

    千次阅读 2019-09-24 16:41:37
    锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:配置交换机的整体...
  • 思科交换机常用命令汇总 show version show running-config show vlan brief show ip interface brief show running-config interface f0/1 show ip route show inventory //显示设备SN、设备名 更换MAC地址 在...
  • H3C 交换机配置命令

    千次阅读 2018-12-20 16:26:11
    H3C 交换机配置命令 三层和二层交换机配置命令 dis this 查看下属命令 save 保存 reboot 重启 初始化命令和提示选项 reset saved-configuration 初始----清除所有配置信息后 提示是否初始化:The saved ...
  • 交换机常见命令

    2020-01-14 14:24:29
    时间设置(华为交换机) clock datetime HH:MM:SS YYYY-MM-DD clock timezone BJ add 8:00:00 dis clockssh登陆(华为交换机) rsa local-key-pair create //生成密钥 aaa local-user wzl password cipher admin //...
  • 华为交换机配置命令

    千次阅读 2013-07-16 21:50:18
    华为交换机配置命令 sys 进入系统视图 interface Gigabitethernet 0/0/1 进入接口视图 ip address 10.10.10.10 255.255.255.0 配置端口的ip地址 description aaa 给接口配置描述信息 port link-trunk {...
  • 交换机路由器命令 给路由器配置IP地址Router#:conf t 进入全局模式Router(config)#int f 端口 进入端口模式Router(config-if)#:ip address ip+子网掩码 配置IP和子网掩码Router(config-if)#...
  • 1.设置交换机名称 switch(config)#hostname DSHD DSHD(config)# 2.设置交换机管理IP地址 switch(config)#interface vlan1 switch(config)#ip address 10.1.1.1 255.255.255.0 switch(config-if)#no shutdown switch...
  • Cisco交换机常用命令

    千次阅读 2015-10-25 21:16:08
    交换机口令设置: switch>enable 进入特权模式 switch#config terminal 进入全局配置模式 switch(config)#hostname 设置交换机的主机名 switch(config)#enable secret Cisco 设置特权加密口令 switch(config...
  • 《CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...
  • 思科交换机基础命令

    千次阅读 2018-06-21 15:57:24
    enable 进入特权模式S# configure terminal 进入全局配置模式S(config)# hostname name 改变交换机名称S(config)# enable password level level_# password 设置用户口令(level_#=1)或特权口令(level_#=15)S...
  • 如何进入交换机配置命令窗口

    万次阅读 2019-04-21 21:46:12
    计算机与交换机的“Console”端口连接 网管型交换机一般都有“Console”端口,用于进行交换机配置。  物理连接完成后就要进行交换机软件配置,下面以思科“Catalyst 1900”为例来说明如何进行交换机软件配置: 第1...
  • H3C交换机配置命令大全 H3C交换机 ################################################   1、system-view 进入系统视图模式   2、sysname 为设备命名   3、display current-configuration 当前配置情况 ...
  • cisco交换机常用命令

    万次阅读 2012-06-17 19:56:52
    cisco交换机常用命令  switch>enable 进入特权模式  switch#config terminal 进入全局配置模式  switch(config)#hostname 设置交换机的主机名  switch(config)#enable secret xxx 设置特权加密...
  • sysname xuetu /修改交换机名字为“xuetu”(名字可自己更改) ospf /进入ospf协议视图 quit /返回上一个视图**(逐级返回)** return=Ctrl+Z /直接返回用户视图 reset saved-configuration /恢复出厂设置 reboot /...
  • Brocade博科交换机重要命令指南

    千次阅读 2020-07-16 15:52:27
    管理博科交换机 ********************************************************************* 1、连接PC与交换机 1.1 设置本机IP为10.77.77.77.* 网段255.255.255.0 ...2、常用命令 2.1 ipaddrshow 查看ip地...
  • 光纤交换机常用命令

    千次阅读 2017-11-27 11:06:00
    使用电脑连接管理网口,默认IP地址为:192.168.0.1,掩码:255.255.255.0 ...1. switchStatusShow 查看交换机的总体健康状态 switch:admin> switchstatusshow Switch Health Report Switch Name: SWF...
  • 博达交换机命令大全

    2013-12-18 15:04:30
    博达交换机配置命令大全,详细解读,并有实例演示
  • 华为交换机配置命令总结

    千次阅读 2020-05-22 17:47:36
    1、配置文件相关命令 [Quidway]display current-configuration #显示当前生效的配置 [Quidway]display saved-configuration # 显示flash中配置文件,即下次上电启动时所用的配置文件 reset saved-configuration # 檫...
  • 计算机三级考点交换机命令总结考点1:交换机基本配置Switch>enable(进入特权模式)Switch#config terminal(进入全局配置模式)Switch#copy running-config startup-config(保存配置文件)1、在全局配置模式下:Switch...
  • 在常见的计算机网络中,网线主要用来连接计算机与交换机(或宽带路由器)、交换机交换机交换机与路由器,以及需要连网的其他各种设备。网线的制作与测试是作为网络管理员的一个入门技能。 1)制作一根直通双绞 ...
  • 华为交换机基本命令

    2017-11-20 12:37:00
    (1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优 先级来实现;  (2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式; ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 17,390
精华内容 6,956
关键字:

修改交换机名称的命令