精华内容
下载资源
问答
  • 华为交换机配置命令
    2020-12-18 17:48:11

    文档大全

    华为交换机的基本操作命令

    设置日期和时间——时间对于交换机来说非常重要,时间不对很多功能无法实现

    clock timezone BJ add 08:00:00

    ——在用户视图下输入此命令

    clock datetime  13:45:30 2017-09-20

    ----

    设置当前时间和日期,

    24

    小时制

    system-view

    ------

    进入系统视图

    [Huawei]

    -----------

    进入系统视图后

    <>

    变成了

    [ ]

    创建

    Vlan

    并把端口加入

    VLAN

    [ Huawei]vlan 2

    ------------

    在系统视图下操作,创建

    Vlan 2

    [Huawei-vlan2]

    #--

    创建了

    vlan2

    并进入

    vlan2

    [Huawei-vlan2]quit

    #--

    退出

    vlan2

    [Huawei]vlan batch 3 to 20

    #--

    批量创建

    vlan

    3

    30

    Info: This operation may take a few seconds. Please wait for a moment...done.

    [Huawei]vlan

    batch

    21

    22

    25

    #--

    批量创建

    vlan

    ,创建了

    21

    22

    25

    三个

    vlan

    Info: This operation may take a few seconds. Please wait for a moment...done.

    [Huawei]undo

    vlan

    21

    #--

    删除

    vlan

    21

    [Huawei]undo vlan batch 22 25

    #--

    批量删除

    vlan

    ,删除

    22

    25

    Warning:

    The

    configurations

    of

    the

    VLAN

    will

    be

    deleted.

    Continue?[Y/N]:y

    #--

    询问是否真的删除

    Info: This operation may take a few seconds. Please wait for a moment...done.

    [Huawei]interface GigabitEthernet 0/0/2

    #--

    进入

    G0/0/2

    端口

    [Huawei-GigabitEthernet0/0/2]

    port link-type access

    #--

    更改端口的连接类型为

    access

    [Huawei-GigabitEthernet0/0/2]

    port default vlan 2

    #--

    更改端口的默认

    vlan

    vlan 2

    [Huawei]

    port-group 3-10

    #--

    创建了一个名为

    3-10

    的端口组

    ,

    并进

    入这个组

    [Huawei-port-group-3-10]

    group-member

    GigabitEthernet

    0/0/3

    to

    GigabitEthernet

    0/0/10

    #--

    在组内

    ,

    G0/0/3

    G0/0/10

    端口抓进来

    更多相关内容
  • 华为交换机常见命令总结 ,内包含交换命令 学习阶段可以使用到路由交换的hcie阶段。更新时间2020年2月8日。pdf文件可以自己可以修改
  • 华为交换机命令

    2021-12-29 11:22:48
    1、用户模式登陆设备后,直接...每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 创建vlan并将端口加入vlan1、创建vlan创建单个vlan 批量创建vl...

    1、用户模式登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;

    2、视图模式用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;

    3、交换机改名

    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉

    4、进入接口

    5、退出此端口

    创建vlan并将端口加入vlan1、创建vlan创建单个vlan

    批量创建vlan

    2、更改端口的链接类型由于华为交换机的端口出厂时默认都是hybrid类型或auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    为何要选择access类型??因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。

    • trunk端口用于交换机相连,pvid必须一致。

    • access 类型只能属于1 个vlan

    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

    3、端口加入vlan

    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

    4、端口的批量操作——端口组原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

    批量更改,先更改端口类型,再统一加入某个vlan,如下:

    5、vlan的查看全局查看vlan信息

    查看端口与vlan对应关系

    6、允许所有vlan通过

    首次登入交换机或路由器

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

    1、恢复出厂设置注意Y和N的选项,不要输错。

    2、设置新密码新交换机第一次上电,或恢复出厂设置后,要求设置新密码出厂自带的用户名是admin,密码是admin@huawei.com

    3、首次保存配置第一次保存设置时,需输入文件名,只需按回车

    4、设置日期和时间

    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式

    5、开启必要的服务和功能开启telnet服务,stp功能,http服务

    6、设置vty,telnet登录

    7、设置一个用户用于网页登录

    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。

    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

    8、关闭交换机自动弹出配置改变告警输入配置命令后设备会提示如下类似信息:

    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:

    以上命令建立一个聚合端口,并设置了端口的属性

    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

    开启DHCP功能,设置地址池,并应用

    主要是限制访客网与办公网、财务网互访

    注意源地址和目的地址的反向掩码

    展开全文
  • 华为交换机常用命令

    万次阅读 2021-01-17 17:05:43
    华为交换机常用命令视图分类用户视图登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the numberof current VTY users on line is 1.The current login ...

    华为交换机常用命令

    视图分类

    用户视图

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the number

    of current VTY users on line is 1.

    The current login time is 2020-04-10 12:15:00+00:00.

    系统视图

    用户模式下,输入system-view命令进入视图模式,可执行设备全局配置的命令system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]

    局部视图

    系统视图模式下,输入局部配置命令,进入局部对像的配置视图。如interface GE 1/0/0,进入GE1/0/0端口配置模式system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]interface GigabitEthernet 1/0/1

    [ZD_agg_5720-GigabitEthernet1/0/1]

    常用命令

    命令简介命令缩写解释displaydis查看相应对象信息

    undo撤消或反向操作对应命令

    system-viewsy进入系统视图

    sysname设置交换机名称

    quitq退出当前视图

    reboot交换机重启

    reset

    restart重新启动当前接口

    shutdown关闭当前接口

    信息查看命令

    交换机信息查看display version 查看交换机软件版本

    display clock 查看交换机时钟

    交换机配置查看display saved-configuration 显示系统保存配置

    display current-configuration 显示系统当前配置

    当前对象信息查看display this 显示当前信息。

    display this include-default 显示当前接口视图下的接口信息,包括默认值。

    display this interface 显示当前接口视图下的接口信息。

    查看接口display interface 查看接口当前运行状态和接口统计信息

    display interface brief 查看接口状态和配置的简要信息。

    display interface description 查看指定接口的描述信息

    display interface vlanif 查看VLANIF接口的状态信息、配置信息和统计信息。

    查看IP相关display ip interface 查看接口与IP相关的配置和统计信息,包括接口接收和发送的报文数、字节数和组播报文数,以及接口接收、发送、转发和丢弃的广播报文数。

    display ip interface brief 看接口与IP相关的简要信息,包括IP地址、子网掩码、物理链路和协议的Up/Down状态以及处于不同状态的接口数目。

    display ip interface description 查看接口与IP相关的简要信息,包括IP地址、子网掩码、物理层状态、链路层协议状态,及接口描述信息和处于不同状态的接口数目。

    display ip pool 显示所有ip pool

    display ip pool name {pool name} {all|conflict|expired|used} 显示ip pool详细信息

    display ip host 查看静态DNS表项

    display ip socket 查看已创建的IPv4 Socket信息。

    display ip statistics 显示IP流量统计信息。

    查看路由display ip routing-table 显示路由信息

    display ospf peer 查看ospf邻接等信息

    display ospf peer brief 查看ospf邻接等简要信息

    display rip 查看rip路由信息

    网络及流量display network status { all|tcp|udp|port port-number } 显示IP流量统计信息

    display tcp statistics 查看TCP流量统计信息

    display udp statistics 查看UDP流量统计信息

    VLAN查看display vlan 显示VLAN信息

    display vlan {pvid} verbose 查看vlan的详细信息

    display port vlan 查看VLAN中包含的接口信息

    display sub-vlan 查看Sub-VLAN类型的VLAN表项信息

    display super-vlan 查看Super-VLAN类型的VLAN表项信息

    display mac-vlan mac-address all 查看所有MAC地址划分VLAN的配置信息

    display mac-vlan vlan 2 查看vlan 2 MAC地址划分VLAN的配置信息

    查看ACL配置display acl {all | name | ipv6} 查看ACL

    display traffic classifier user-defined 查看用户定义的流分类

    display traffic behavior user-defined 查看用户定义的流行为

    display traffic policy user-defined {policy name} 查看用户定义的流策略

    display traffic-applied {inbound | outbound | interface | vlan} 查看流策略应用情况

    display traffic policy {global | interface | statistics | vlan } {inbound | outbound} 查看更多流策略信息

    display traffic policy statistics {global | interface | vlan} {inbound | outbound} 查看流策略统计信息

    display traffic-filter applied-record 查看acl应用的接口

    查看NAT配置#路由器命令

    display nat static {acl | global | inside | interface} 查看静态NAT信息

    display nat session {all | dest | number | protocol | source} 查看动态NAT信息

    display nat server {acl | global | inside | interface} 查看NAT server信息

    配置管理命令

    端口管理port 配置接口的缺省VLAN并加入该VLAN

    port description 配置接口的描述信息,描述与接口相连的设备类型。

    port gigabitethernet 0/0/1 to 0/0/4

    port default vlan 配置接口的缺省VLAN并同时加入这个VLAN。

    port link-type {access | hybird | trunk} 配置接口的链路类型

    port trunk allow-pass vlan {vlanid} 将trunk接口加入vlan

    端口配置speed {10|100|auto} 配置端口工作速率

    duplex {half|full|auto} 配置端口工作状态

    端口组操作display port-group {all} 查看端口组

    port-group {id} 创建端口组

    group-member gigabitethernet 0/0/2 to gigabitethernet 0/0/10 将2到10端口加入端口组

    VLAN管理vlan {id} 创建VLAN并进入VLAN视图,如果VLAN已存在,直接进入该VLAN的视图。

    vlan batch 10 to 20 批量创建VLAN

    vlan range 10 to 20 创建临时VLAN组,并进入VLAN-Range视图

    vlan statistics 配置VLAN的流量统计模式,即配置按包或按字节进行VLAN流量统计。

    vlan statistics interval 配置VLAN的流量统计的时间间隔

    ip address 用来配置接口的IP地址。

    接口管理interface gigabitethernet 0/0/1 进入指定的接口或子接口视图,进入0/0/1的接口

    DNS管理#查看

    display dns dynamic-host 查看动态DNS表项

    display dns domain 查看域名后缀的相关信息

    display dns server 查看DNS服务器的相关信息

    #设置

    dns domain domain-name 命令用来配置域名后缀,如 dns domain com.cn。

    dns resolve 命令用来使能动态域名解析功能

    dns server {ip} 命令用来配置DNS服务器的IP地址

    ip host {domain} {ip} 命令用来配置静态DNS表项 ip host www.huawei.com 10.10.10.4。

    DHCP管理dhcp enable 命令用来开启DHCP功能。

    dhcp select global 从全局配置中获取dhcp配置

    ACL管理acl {name | number | ipv6} 创建acl

    rule [{ruleid}] permit ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建允许规则

    rule [{ruleid}] deny ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建拒绝规则

    traffic-filter {inbound | outbound} acl {acl number} 在接口上应用acl规则

    #创建流分类

    traffic classifier {classifier name} operator { and |or }

    if-match acl {acl number} 为流分类设置匹配规则

    #创建流行为

    traffic behavior {behavior name}

    permit | deny | redirect 为流行为配置动作

    #创建流策略

    traffic policy {policy name}

    classifier {classifier name} behavior {behavior name} 关联流分类与流行为

    #将流策略应用到接口

    interface g0/0/1

    traffic-policy {policy name} {inbound | outbound} 接口绑定流策略

    NAT管理#边界路由器接口上配置静态NAT

    nat static global {外部ip} inside {内部ip} 添加静态nat,内外部ip一对一

    #动态NAT,使用dis nat session查看

    nat address-group {groupid} {ip开始} {ip结束} 添加外部可用地址池

    nat outbound {acl id} address-group {address-group id} no-pat 添加动态地址转换

    #NAPT,使用dis nat session查看

    nat outbound {acl id} [address-group {address-group id}] 添加动态端口地址转换

    #NAT server,使用dis nat server查看

    nat server protocol tcp global {外部ip} {外部端口} inside {内部ip} {内部端口} 添加nat server转换

    用户管理#查看本地用户

    display local-user

    #查看用户接口

    display user-interface

    #设置用户vty0为4个并发

    user-interface vty 0 4

    #进入用户console0接口

    user-interface console 0

    #用户管理

    local-user {username} password cipher {password}

    local-user {username} level 15

    local-user {username} service-type telnet terminal ssh

    绑定IP与MACuser-bind ip-address 10.0.0.2 mac-address 0001-0203-0405

    user privilege level 3

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。

    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

    日志与统计#打开统计

    display counters 查看接口的流量统计计数

    statistic enable

    trace mac enable

    trace mac aa99-6600-5600 vlan 2

    其它命令display stp 显示生成树信息

    display mac-address 显示MAC地址表

    display bridge mac-address 查看当前桥接设备mac地址

    display arp 显示ARP信息表

    display voice-vlan oui 查看Voice VLAN的OUI及其相关属性。

    display voice-vlan status 查看当前Voice VLAN的相关信息

    mac-vlan mac-address

    操作实战

    VLAN操作

    创建vlan,设置vlan的ip,并将端口加入vlan中。#进入全局配置视图

    system-view

    #新建vlan2

    [Huawei] vlan 2

    #进入vlan2的接口视图

    [Huawei] interface vlan 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #进入0/0/1接口,配置为access接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/1

    [Huawei-GigabitEthernet0/0/1] port link-type access

    [Huawei-GigabitEthernet0/0/1] port default vlan 2

    #进入0/0/2接口,配置为trunk接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/2

    [Huawei-GigabitEthernet0/0/2] port link-type trunk

    [Huawei-GigabitEthernet0/0/2] port trunk allow-pass vlan 2

    #查看端口配置的信息

    [Huawei-GigabitEthernet0/0/2] dis this

    #进入vlan2,将0/0/2到0/0/5端口加入到vlan2中(port link-type需要是access类型)

    [Huawei] vlan 2

    [Huawei-vlan2] port GigabitEthernet 0/0/2 to 0/0/5

    端口组操作

    需要对多个端口进行相同操作时,可以创建端口组进行批量操作。#创建端口组1,进行批量端口操作

    [Huawei] port-group 1

    #将6到10端口加入端口组

    [Huawei-port-group-1] group-member gigabitethernet 0/0/6 to gigabitethernet 0/0/10

    #批量将2~10端口修改为access模式

    [Huawei-port-group-1] port link-type access

    #批量将6~10端口加入到vlan 2中

    [Huawei-port-group-1] port default vlan 2

    IP POOL操作 system-view

    #进入ip pool中

    [Huawei] ip pool vlan10

    #在ip pool中添加dns server

    [Huawei-ip-pool-vlan10] dns-list 8.8.8.8

    #设置网关

    [Huawei-ip-pool-vlan10] gateway-list 10.0.0.1

    #设置ip pool的ip段和池,需要与vlanif接口配置匹配,否则ip分配不了

    [Huawei-ip-pool-vlan10] network 10.0.0.0 mask 255.255.255.0

    #过期时间

    [Huawei-ip-pool-vlan10] lease day 10

    DHCP操作 system-view

    #全局打开DHCP服务

    [Huawei] dhcp enable

    #进入vlan的接口视图

    [Huawei] interface vlanif 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #从全局配置中获取dhcp配置

    [Huawei-Vlanif2] dhcp select global

    静态添加路由 system-view

    display ip routing-table

    #ip route-static 目的ip 目标地址掩码 下一跳ip

    [Huawei] ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    #删除路由

    [Huawei] undo ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    RIP路由管理 system-view

    #修改loopback0地址

    [Huawei] int LoopBack 0

    [Huawei-LoopBack0] ip address 1.1.1.1 0

    #创建rip进程

    [Huawei] rip 1

    #启动版本2

    [Huawei-rip-1] version 2

    #宣告网段

    [Huawei] network 10.0.0.0

    [Huawei] network 1.0.0.0

    OSPF路由管理 system-view

    #创建ospf

    [Huawei] ospf 1 router-id 1.1.1.1

    #创建area0区域

    [Huawei-ospf-1] area 0

    #加入192.168.0.0/24子网

    [Huawei-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

    [Huawei-ospf-1-area-0.0.0.0]dis this

    #

    area 0.0.0.0

    network 192.168.0.0 0.0.0.255

    #

    [Huawei-ospf-1-area-0.0.0.0]

    ACL管理 system-view

    #配置acl

    [Huawei] acl 3000

    [Huawei-acl-adv-3000] rule permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] quit

    #配置流分类,匹配acl

    [Huawei] traffic classifier c0 operator or

    [Huawei-classifier-c0] if-match acl 3000

    [Huawei-classifier-c0] quit

    #配置流行为,设置动作

    [Huawei-behavior-b0] traffic behavior b0

    [Huawei-behavior-b0] permit

    [Huawei-behavior-b0] quit

    #配置流策略,关联流分类c0与流行为b0

    [Huawei] traffic policy p0

    [Huawei-trafficpolicy-p1] classifier c0 behavior b0

    [Huawei-trafficpolicy-p1] quit

    #配置流策略应用到接口

    [Huawei] interface g0/0/1

    [Huawei-GigabitEthernet0/0/1] traffic-policy p0 inbound

    [Huawei-GigabitEthernet0/0/1] return

    用户管理#查看本地用户

    display local-user

    system-view

    #进入aaa配置模式

    [Huawei] aaa

    #配置本地用户账号密码

    [Huawei-aaa] loca-user user1 password cipher 123456

    #用户服务类型为telnet,使用telnet登陆

    [Huawei-aaa] local-user user1 service-type telnet

    #配置用户特权等级15

    [Huawei-aaa] local-user user1 privilege level 15

    展开全文
  • 华为交换机配置命令 1、配置文件相关命令 [Quidway]display current-configuration 显示当前生效的配置 [Quidway]display saved-configuration 显示flash中配置文件,即下次上电启动时所用的配置文件 reset saved-...

    华为交换机配置命令

    1、配置文件相关命令

    [Quidway]display current-configuration 显示当前生效的配置
    [Quidway]display saved-configuration
    

    显示flash中配置文件,即下次上电启动时所用的配置文件

    reset saved-configuration 檫除旧的配置文件
    reboot 交换机重启
    display version 显示系统版本信息
    

    2、基本配置

    [Quidway]super password 修改特权用户密码
    [Quidway]sysname 交换机命名
    [Quidway]interface ethernet 1/0/1 进入接口视图
    [Quidway]interface vlan 1 进入接口视图
    [Quidway-Vlan-interfacex]ip address 10.1.1.11 255.255.0.0配置VLAN的IP地址
    [Quidway]ip route-static 0.0.0.0 0.0.0.0 10.1.1.1 静态路由=网关
    

    3、telnet配置

    [Quidway]user-interface vty 0 4 进入虚拟终端
    [S3026-ui-vty0-4]authentication-mode password 设置口令模式
    [S3026-ui-vty0-4]set authentication-mode password simple xmws123设置口令
    [S3026-ui-vty0-4]user privilege level 3 用户级别
    

    4、端口配置

    [Quidway-Ethernet1/0/1]duplex {half|full|auto} 配置端口工作状态
    [Quidway-Ethernet1/0/1]speed {10|100|auto} 配置端口工作速率
    [Quidway-Ethernet1/0/1]flow-control 配置端口流控
    [Quidway-Ethernet1/0/1]mdi {across|auto|normal} 配置端口平接扭接
    [Quidway-Ethernet1/0/1]port link-type {trunk|access|hybrid} 设置端口工作模式
    [Quidway-Ethernet1/0/1]undo shutdown 激活端口
    [Quidway-Ethernet1/0/2]quit 退出系统视图
    

    5、链路聚合配置

    [DeviceA] link-aggregation group 1 mode manual 创建手工聚合组1
    [Qw_A] interface ethernet 1/0/1 将以太网端口Ethernet1/0/1加入聚合组1
    [Qw_A-Ethernet1/0/1] port link-aggregation group 1
    [Qw_A-Ethernet1/0/1] interface ethernet 1/0/2 将以太网端口Ethernet1/0/1加入聚合组1
    [Qw_A-Ethernet1/0/2] port link-aggregation group 1
    [Qw_A] link-aggregation group 1 service-type tunnel # 在手工聚合组的基础上创建tunnel业务环回组。
    [Qw_A] interface ethernet 1/0/1 将以太网端口Ethernet1/0/1加入业务环回组。
    [Qw_A-Ethernet1/0/1] undo stp
    [Qw_A-Ethernet1/0/1] port link-aggregation group 1
    

    6、端口镜像

    [Quidway]monitor-port 指定镜像端口
    [Quidway]port mirror 指定被镜像端口
    [Quidway]port mirror int_list observing-port int_type int_num  指定镜像和被镜像
    

    7、VLAN配置

    [Quidway]vlan 4 创建VLAN
    [Quidway-vlan4]port ethernet 1/0/1 to ethernet 1/0/4  在VLAN中增加端口
    
    ① 配置基于access的VLAN
    [Quidway-Ethernet1/0/2]port access vlan 4  当前端口加入到VLAN
    

    注意:缺省情况下,端口的链路类型为 Access类型,所有Access端口均属于且只属于VLAN1

    ② 配置基于trunk的VLAN
    [Quidway-Ethernet1/0/24]port link-type trunk 设置当前端口为trunk
    [Quidway-Ethernet1/0/24]port trunk permit vlan {ID|All} 设trunk允许的VLAN
    

    注意:所有端口缺省情况下都是允许 VLAN1的报文通过的

    [Quidway-Ethernet1/0/2]port trunk pvid vlan 34 设置trunk端口的PVID
    
    ③ 配置基于Hybrid端口的VLAN
    [Quidway-Ethernet1/0/2]port link-type hybrid 配置端口的链路类型为Hybrid类型
    [Quidway-Ethernet1/0/2]port hybrid vlan vlan-id-list { tagged | untagged } 允许指定的VLAN通过当前Hybrid端口
    

    注意:缺省情况下,所有 Hybrid端口只允许VLAN1通过

    [Quidway-Ethernet1/0/2]port hybrid pvid vlan vlan-id 设置Hybrid端口的缺省VLAN
    

    注意:缺省情况下,Hybrid端口的缺省VLAN为VLAN1

    ④ VLAN描述
    [Quidway]description string 指定VLAN描述字符
    [Quidway]undo description 删除VLAN描述字符
    [Quidway]display vlan [vlan_id] 查看VLAN设置
    
    ⑤ 私有VLAN配置
    [Qw_A-vlanx]isolate-user-vlan enable 设置主vlan
    [Qw_A]Isolate-user-vlan secondary 设置主vlan包括的子vlan
    [Quidway-Ethernet1/0/2]port hybrid pvid vlan 设置vlan的pvid
    [Quidway-Ethernet1/0/2]port hybrid pvid 删除vlan的pvid
    [Quidway-Ethernet1/0/2]port hybrid vlan vlan_id_list untagged  设置无标识的vlan如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.
    

    8、STP配置

    [Quidway]stp {enable|disable} 设置生成树,默认关闭
    [Quidway]stp mode rstp 设置生成树模式为 rstp
    [Quidway]stp priority 8192 设置交换机的优先级
    [Quidway]stp root {primary|secondary} 设置为根或根的备份
    [Quidway-Ethernet0/1]stp cost 200 设置交换机端口的花费
    

    MSTP配置:

    # 配置MST域名为info,MSTP修订级别为1,VLAN映射关系为VLAN2~VLAN10映射到生成树实例 1上,VLAN20~VLAN30映射生成树实例2上。
    system-view
    [Sysname] stp region-configuration
    [Sysname-mst-region] region-name info
    [Sysname-mst-region] instance 1 vlan 2 to 10
    [Sysname-mst-region] instance 2 vlan 20 to 30
    [Sysname-mst-region] revision-level 1
    [Sysname-mst-region] active region-configuration
    

    9、MAC地址表的操作

    ① 在系统视图下添加 MAC地址表项
    [Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id ;添加MAC地址表项
    

    在添加MAC地址表项时,命令中interface参数指定的端口必须属于 vlan参数指定的VLAN,否则将添加失败。

    如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

    ② 在以太网端口视图下添加 MAC地址表项
    [Quidway-Ethernet1/0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id
    

    在添加MAC地址表项时,当前的端口必须属于命令中 vlan参数指定的VLAN,否则将添加失败;

    如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

    [Quidway]mac-address timer { aging age | no-aging } 设置MAC地址表项的老化时间
    

    注意:缺省情况下,MAC地址表项的老化时间为 300秒,使用参数no-aging时表示不对MAC地址表项进行老化。

    ③ MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的) MAC地址表项起作用。\
    [Quidway-Ethernet1/0/2]mac-address max-mac-count count 设置端口最多可以学习到的MAC地址数量;
    

    注意:缺省情况下,没有配置对端口学习 MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大 MAC地址学习个数。

    [Quidway-Ethernet1/0/2]port-mac start-mac-address 配置以太网端口MAC地址的起始值
    

    在缺省情况下,E126/E126A交换机的以太网端口是没有配置 MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的 MAC地址,将使用该协议预置的 MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源 MAC地址发送二层协议报文,会造成在某台设备的不同端口学习到相同 MAC地址的情况,可能会对 MAC地址表的维护产生影响。

    [Quidway]display mac-address 显示地址表信息
    [Quidway]display mac-address aging-time 显示地址表动态表项的老化时间
    [Quidway]display port-mac 显示用户配置的以太网端口 MAC地址的起始值
    

    10、GVRP配置

    [Qw_A] gvrp 开启全局GVRP
    [Qw_A-Ethernet1/0/1] gvrp 在以太网端口Ethernet1/0/1上开启GVRP
    [Qw_A-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal } 配置GVRP端口注册模式,缺省为normal。
    [Qw_A] display garp statistics [ interface interface-list ] 显示GARP统计信息
    [Qw_A] display garp timer [ interface interface-list ] 显示GARP定时器的值
    [Qw_A] display gvrp statistics [ interface interface-list ] 显示GVRP统计信息
    [Qw_A] display gvrp status 显示GVRP的全局状态信息
    [Qw_A] display gvrp statusreset garp statistics [ interface interface-list ] 清除GARP统计
    

    11、DLDP配置

    [Qw_A] interface gigabitethernet 1/1/1
    [Qw_A-GigabitEthernet1/1/1] duplex full 配置端口工作在强制全双工模式
    [Qw_A-GigabitEthernet1/1/1] speed 1000 速率为1000Mbits/s
    [Qw_A] dldp enable 全局开启DLDP。
    [Qw_A] dldp interval 15 设置发送DLDP报文的时间间隔为 15秒。
    [Qw_A] dldp work-mode { enhance | normal }配置DLDP协议的工作模式为加强模式。 缺省为normal。
    [Qw_A] dldp unidirectional-shutdown { auto | manual }配置DLDP单向链路操作模式为自动模式。 缺省为auto
    [Qw_A] display dldp 1 查看DLDP状态。
    
    • 当光纤交叉连接时,可能有两个或三个端口处于 Disable状态,剩余端口处于Inactive状态。
    • 当光纤一端连接正确,一端未连接时:如果DLDP的工作模式为normal,则有收光的一端处于 Advertisement状态,没有收光的一端处于 Inactive状态。如果DLDP的工作模式为enhance,则有收光的一端处于 Disable状态,没有收光的一端处于Inactive状态。
    • dldp reset命令在全局下可以重置所有端口的 DLDP状态,在接口下可以充值该端口的DLDP状态

    12、端口隔离配置

    1. 通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、 三层数据的隔离,既增强了网络的安全性,也为用户提供了灵活的组网方案。
    [Sysname] interface ethernet1/0/2 将以太网端口Ethernet1/0/2加入隔离组。
    [Sysname-Ethernet1/0/2] port isolate
    [Sysname] display isolate port 显示隔离组中的端口信息
    
    1. 配置隔离组后,只有隔离组内各个端口之间的报文不能互通, 隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。
    2. 端口隔离特性与以太网端口所属的 VLAN无关。
    3. 当汇聚组中的某个端口加入或离开隔离组后, 本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。
    4. 对于既处于某个聚合组又处于某个隔离组的一组端口, 其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。
    5. 如果某个聚合组中的端口同时属于某个隔离组, 当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。
    6. 当隔离组中的某个端口加入聚合组时, 该聚合组中的所有端口,会自动加入隔离组中。

    13、端口安全配置

    [Switch] port-security enable 启动端口安全功能
    [Switch] interface Ethernet 1/0/1 进入以太网Ethernet1/0/1端口视图
    [Switch-Ethernet1/0/1] port-security max-mac-count 80 设置端口允许接入的最大 MAC地址数为80
    [Switch-Ethernet1/0/1] port-security port-mode autolearn 配置端口的安全模式为autolearn
    [Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1将Host 的MAC地址0001-0002-0003作为Security MAC添加到VLAN 1中
    [Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily设置Intrusion Protection特性被触发后,暂时关闭该端口
    [Switch]port-security timer disableport 30 关闭时间为30秒。
    

    14、端口绑定配置

    通过端口绑定特性,网络管理员可以将用户的 MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定 MAC地址和IP地址的用户发出的报文进行转发, 提高了系统的安全性,增强了对网络安全的监控。

    [Qw_A-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1
    

    将Host 1的MAC地址和IP地址绑定到Ethernet1/0/1端口。有的交换机上绑定的配置不一样

    [Qw_A] interface ethernet 1/0/2
    [Qw_A-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405端口过滤配置
    [Qw_A] interface ethernet1/0/1 配置端口Ethernet1/0/1的端口过滤功能。
    [Qw_A-Ethernet1/0/1] ip check source ip-address mac-address
    [Qw_A] dhcp-snooping 开启DHCP Snooping功能。
    [Qw_A] interface ethernet1/0/2设置与DHCP服务器相连的端口 Ethernet1/0/2为信任端口。
    [Qw_A-Ethernet1/0/2] dhcp-snooping trust 在端口Ethernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源 IP地址对服务器进行攻击
    

    15、BFD配置

    Qw_A、Qw_B、Qw_C相互可达,在Qw_A上配置静态路由可以到达 Qw_C,并使能BFD检测功能。

    ① 在Qw_A上配置静态路由,并使能 BFD检测功能,通过BFD echo报文方式实现BFD功能。
    <Qw_A> system-view
    [Qw_A] bfd echo-source-ip 123.1.1.1
    [Qw_A] interface vlan-interface 10
    [Qw_A-vlan-interface10] bfd min-echo-receive-interval 300
    [Qw_A-vlan-interface10] bfd detect-multiplier 7
    [Qw_A-vlan-interface10] quit
    [Qw_A] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet
    
    ② 在Qw_A上打开BFD功能调试信息开关。
    <Qw_A> debugging bfd event
    <Qw_A> debugging bfd scm
    <Qw_A> terminal debugging
    
    ③ 在Qw_A上可以打开BFD功能调试信息开关,断开Hub和Qw_B之间的链路,验证配置结果。
    ④ Qw_A能够快速感知Qw_A与Qw_B之间链路的变化。

    16、QinQ配置

    Provider A、Provider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000,Provider B属于运营商网络的 VLAN2000。

    Provider A和Provider B之间,运营商采用其他厂商的设备, TPID值为0x8200。

    Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer A的VLAN20的报文可以和Customer C的VLAN20的报文经过运营商网络的 VLAN2000转发后互通。

    [ProviderA] interface ethernet 1/0/1 # 配置端口为Hybrid端口,且允许VLAN10,VLAN20,VLAN1000和VLAN2000的报文通过,并且在发送时去掉外层 Tag。
    [ProviderA-Ethernet1/0/1] port link-type hybrid
    [ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged
    [ProviderA-Ethernet1/0/1] qinq vid 1000
    将来自VLAN10的报文封装VLAN ID为1000的外层Tag。
    
    [ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10
    [ProviderA-Ethernet1/0/1-vid-1000] quit
    [ProviderA-Ethernet1/0/1] qinq vid 2000
    将来自VLAN20的报文封装VLAN ID为2000的外层Tag。
    
    [ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20
    [ProviderA] interface ethernet 1/0/2 配置端口的缺省VLAN为VLAN1000。
    [ProviderA-Ethernet1/0/2] port access vlan 1000
    [ProviderA-Ethernet1/0/2] qinq enable
    配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。
    
    [ProviderA] interface ethernet 1/0/3
    配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。
    [ProviderA-Ethernet1/0/3] port link-type trunk
    [ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000
    [ProviderA-Ethernet1/0/3] qinq ethernet-type 8200
    为与公共网络中的设备进行互通, 配置端口添加外层 Tag时采用的TPID值为0x8200。
    [ProviderB] interface ethernet 1/0/1
    配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。
    [ProviderB-Ethernet1/0/1] port link-type trunk
    [ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000
    [ProviderB-Ethernet1/0/1] qinq ethernet-type 8200
    

    为与公共网络中的设备进行互通, 配置端口添加外层 Tag时采用的TPID值为0x8200。

    [ProviderB-Ethernet1/0/1] quit
    [ProviderB] interface ethernet 1/0/2 # 配置端口的缺省 VLAN为VLAN2000。
    [ProviderB-Ethernet1/0/2] port access vlan 2000
    [ProviderB-Ethernet1/0/2] qinq enable
    

    配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

    展开全文
  • 常用交换机配置命令

    千次阅读 2019-06-26 14:30:52
    本文基于华为和思科各数通设备的常用命令来对比学习,这两个命令体系是网络项目中常见的,其他一些厂家也是基于类似的命令体系.下面也会根据公司业务需求列举部分网络设备厂家,比如H3C,盛科的命令不同之处. 1. 查看...
  • 1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s...键入命令,配置以太网交换机或查...
  • 查看当前系统时间 dis time all 手动修改系统时间clock datetime 15:44:40 2017-10-24 查看SN dis elabel(所显示的Barcode后面那串数字就是SN)
  • [计算机]交换机配置命令.doc

    千次阅读 2021-07-10 01:16:25
    [计算机]交换机配置命令交换机配置命令集锦1、 进入全局配置模式1、Switch-3548 > enablePassword : ********Switch-3548 # config tSwitch-3548 (config) #2、 启用交换机的HTTP Server2、Switch-3548 (config) ...
  • 华为交换机常用命令大全

    千次阅读 2021-05-15 18:12:49
    01 — 基础配置命令 1、用户模式 登陆设备后,直接进入用户模式,尖括号...每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vl...
  • 各种交换机配置命令

    2021-06-29 07:55:21
    麦普交换机一. 基本配置进入特权模式:Switch>enSwitch#进入全局模式:Switch# configterminalSwitch(Config)#退出命令exit举例:Switch#exitSwitch>帮助命令:help举例:Switch>helpenable -- Enable ...
  • 华为交换机基础命令合集

    千次阅读 2021-10-29 12:04:38
    网络工程必考的认证:HCIA HCIP HCIE 1、用户模式 ... 2、视图模式 ...每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 1、创建vlan 创建...
  • 阿尔卡特交换机常用命令

    千次阅读 2020-12-31 11:15:27
    OmniSwitch查看日志的命令是:格式:show log swlog [timestamp start_time [end_time]]show log swlog timestamp 05/21/2015 11:30 05/21/2015 12:30发现私自添加路由器导致DHCP分发确认路由器IP,查到MAC,交换机...
  • 交换机常用命令

    千次阅读 2019-08-22 12:36:13
    一://所有show命令都在特权模式下使用,switch#//是特权模式//如果是其他模式+do show mac-address-table //查看mac地址 chear mac-adress-table //清空mac地址 show ip intserface brief = show ip...
  • 、备份配置 copy running-config startup-config 2、清楚启动文件 write erase 3、查看系统相关信息 show version 4、查看硬件相关信息 show module 5、查看相关特性 ...show feature
  • 迈普3100交换机配置命令大全

    千次阅读 2021-07-17 06:40:09
    一.基本配置进入特权模式:Switch> enSwitch#进入全局模式:Switch# config ...修改交换机的主机名hostname XXX举例:设置提示符为Test。Switch(Config)#hostname TestTest(config)#二.查看命令查看交换机当前配...
  • 华为交换机配置命令---转

    千次阅读 2021-01-12 01:12:09
    华为交换机配置命令本文网址:http://bbs.bitscn.com/121555 复制华为QuidWay交换机配置命令手册:1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如...
  • -理解交换机转发原理 -能完成交换机的基本配置 提示:以下是本篇文章正文内容,下面案例可供参考 参考 : https://blog.csdn.net/weixin_51486343/article/details/109219242 一、数据链路层  数据链路层...
  • 描述:中兴网络设备交换机路由器查看系统时间检查命令方法 命令: show clock
  • 路由/交换机命令大全~!路由/交换机命令大全~!交换机命令switch> 用户模式1:进入特权模式enableswitch> enableswitch#2:进入全局配置模式configure terminalswitch> enableswitch#configure terminal...
  • 华三华为交换机配置时间

    千次阅读 2021-12-13 09:18:04
    华三交换机配置日期时间 两种方法: 1、手动配置时间 2、配置ntp服务器,使用ntp服务器的时间 第一种:手动配置时间 (1)查看交换机当前时间:dis clock 你好! 这是你第一次使用 Markdown编辑器 所展示的欢迎页。...
  • if)#ip address 192.168.1.10 255.255.255.0 (config-if)#no shutdown 修改交换机老化时间 (config)#mac-address-table aging-time 20 (config)#end 添删vlan (config)#vlan 888 (config-vlan)#name a888 (config)#...
  • 华为交换机配置命令后需要重启吗

    千次阅读 2021-01-17 17:05:50
    展开全部华为交换机有下面几种情况需要重启:1、清空配置,e68a84e8a2ad62616964757a686964616f31333433623131reset config,后,需要重启。2、去除密码时需要重启。3、更新非热补丁需要重启。4、软件版本升级完成后...
  • switch常用的交换机配置命令

    千次阅读 2022-01-23 12:13:52
    1.clock set:设置交换机时间,日期。 Switch>en Switch#clock set 12: 12: 12 10 oct 2017 //设置交换机的...2.hostname:用于修改交换机的主机名。 Switch#config terminal Switch(config)#hostname mjl //
  • 查看当前系统时间 dis time all 手动修改系统时间clock datetime14:25:002020-6-19
  • Brocade博科交换机重要命令指南

    千次阅读 2020-07-16 15:52:27
    管理博科交换机 ********************************************************************* 1、连接PC与交换机 1.1 设置本机IP为10.77.77.77.* 网段255.255.255.0 ...2、常用命令 2.1 ipaddrshow 查看ip地...
  • 小白也能看懂的华为交换机常用命令大全

    千次阅读 多人点赞 2021-04-16 14:41:05
    01 — 基础配置命令 1、用户模式 登陆设备后,直接进入用户模式,尖...每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vlan并...
  • 路由器、交换机配置命令简写对照表 全称 简写 含义 enable en 特权模式 configure terminal conf t 配置模式 interface f0/0 in f0/0 f0/0 接口配置模式 interface f0/0.1 in f0/0.1 子接口配置模式 ...
  • 查看系统时间 enable show clock 更改系统时间 enable clock set 13:42:00 Nov 12 2021
  • 锐捷交换机配置命令

    千次阅读 多人点赞 2019-09-24 16:41:37
    锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:配置交换机的整体...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 31,244
精华内容 12,497
关键字:

修改交换机时间的命令