精华内容
下载资源
问答
  • 数据交换的三种技术
    千次阅读
    2019-09-18 05:30:46
    1.电路交换技术
    
      网络交换技术共经历了四个发展阶段,电路交换技术、报文交换技术、分组交换技术和ATM技术。公众电话网(PSTN网)和移动网(包括GSM网和CDMA网)采用的都是电路交换技术,它的基本特点是采用面向连接的方式,在双方进行通信之前,需要为通信双方分配一条具有固定带宽的通信电路,通信双方在通信过程中将一直占用所分配的资源,直到通信结束,并且在电路的建立和释放过程中都需要利用相关的信令协议。这种方式的优点是在通信过程中可以保证为用户提供足够的带宽,并且实时性强,时延小,交换设备成本较低,但同时带来的缺点是网络的带宽利用率不高,一旦电路被建立不管通信双方是否处于通话状态,分配的电路都一直被占用。
    
    2.报文交换技术
    
      报文交换技术和分组交换技术类似,也是采用存储转发机制,但报文交换是以报文作为传送单元,由于报文长度差异很大,长报文可能导致很大的时延,并且对每个节点来说缓冲区的分配也比较困难,为了满足各种长度报文的需要并且达到高效的目的,节点需要分配不同大小的缓冲区,否则就有可能造成数据传送的失败。在实际应用中报文交换主要用于传输报文较短、实时性要求较低的通信业务,如公用电报网。报文交换比分组交换出现的要早一些,分组交换是在报文交换的基础上,将报文分割成分组进行传输,在传输时延和传输效率上进行了平衡,从而得到广泛的应用。
    
    3.分组交换技术
    
      电路交换技术主要适用于传送话音相关的业务,这种网络交换方式对于数据业务而言,有着很大的局限性。首先数据通信具有很强的突发性,峰值比特率和平均比特率相差较大,如果采用电路交换技术,若按峰值比特率分配电路带宽则会造成资源的极大浪费,如果按照平均比特率分配带宽,则会造成数据的大量丢失。其次是和语音业务比较起来,数据业务对时延没有严格的要求,但需要进行无差错的传输,而语音信号可以有一定程度的失真但实时性一定要高。分组交换技术就是针对数据通信业务的特点而提出的一种交换方式,它的基本特点是面向无连接而采用存储转发的方式,将需要传送的数据按照一定的长度分割成许多小段数据,并在数据之前增加相应的用于对数据进行选路和校验等功能的头部字段,作为数据传送的基本单元即分组。采用分组交换技术,在通信之前不需要建立连接,每个节点首先将前一节点送来的分组收下并保存在缓冲区中,然后根据分组头部中的地址信息选择适当的链路将其发送至下一个节点,这样在通信过程中可以根据用户的要求和网络的能力来动态分配带宽。分组交换比电路交换的电路利用率高,但时延较大。
    
    分组交换提供的业务
          交换虚电路——指在两个用户之间建立的临时逻辑连接。 永久虚电路——指在两个用户之间建立的永久性的逻辑连接。用户一开机,一条永久虚电路就自动建立起来了。
    
    分组交换网络
    
    数据报网络是一个面向无连接的网络
    
    虚电路网络是一个面向连接的网络为每条连接中的连接维护状态信息.
    
    路、报文、分组交换的特点和比较
    
    (1)电路交换:由于电路交换在通信之前要在通信双方之间建立一条被双方独占的物理通路(由通信双方之间的交换设备和链路逐段连接而成),因而有以下优缺点。
    优点:
    ①由于通信线路为通信双方用户专用,数据直达,所以传输数据的时延非常小。
    ②通信双方之间的物理通路一旦建立,双方可以随时通信,实时性强。
    ③双方通信时按发送顺序传送数据,不存在失序问题。
    ④电路交换既适用于传输模拟信号,也适用于传输数字信号。
    ⑤电路交换的交换的交换设备(交换机等)及控制均较简单。
    缺点:
    ①电路交换的平均连接建立时间对计算机通信来说嫌长。
    ②电路交换连接建立后,物理通路被通信双方独占,即使通信线路空闲,也不能供其他用户使用,因而信道利用低。
    ③电路交换时,数据直达,不同类型、不同规格、不同速率的终端很难相互进行通信,也难以在通信过程中进行差错控制。
    
    (2)报文交换:报文交换是以报文为数据交换的单位,报文携带有目标地址、源地址等信息,在交换结点采用存储转发的传输方式,因而有以下优缺点:
    优点:
    ①报文交换不需要为通信双方预先建立一条专用的通信线路,不存在连接建立时延,用户可随时发送报文。
    ②由于采用存储转发的传输方式,使之具有下列优点:a.在报文交换中便于设置代码检验和数据重发设施,加之交换结点还具有路径选择,就可以做到某条传输路径发生故障时,重新选择另一条路径传输数据,提高了传输的可靠性;b.在存储转发中容易实现代码转换和速率匹配,甚至收发双方可以不同时处于可用状态。这样就便于类型、规格和速度不同的计算机之间进行通信;c.提供多目标服务,即一个报文可以同时发送到多个目的地址,这在电路交换中是很难实现的;d.允许建立数据传输的优先级,使优先级高的报文优先转换。
    ③通信双方不是固定占有一条通信线路,而是在不同的时间一段一段地部分占有这条物理通路,因而大大提高了通信线路的利用率。
    缺点:
    ①由于数据进入交换结点后要经历存储、转发这一过程,从而引起转发时延(包括接收报文、检验正确性、排队、发送时间等),而且网络的通信量愈大,造成的时延就愈大,因此报文交换的实时性差,不适合传送实时或交互式业务的数据。
    ②报文交换只适用于数字信号。
    ③由于报文长度没有限制,而每个中间结点都要完整地接收传来的整个报文,当输出线路不空闲时,还可能要存储几个完整报文等待转发,要求网络中每个结点有较大的缓冲区。为了降低成本,减少结点的缓冲存储器的容量,有时要把等待转发的报文存在磁盘上,进一步增加了传送时延。
    
    (3)分组交换:分组交换仍采用存储转发传输方式,但将一个长报文先分割为若干个较短的分组,然后把这些分组(携带源、目的地址和编号信息)逐个地发送出去,因此分组交换除了具有报文的优点外,与报文交换相比有以下优缺点:
    优点:
    ①加速了数据在网络中的传输。因为分组是逐个传输,可以使后一个分组的存储操作与前一个分组的转发操作并行,这种流水线式传输方式减少了报文的传输时间。此外,传输一个分组所需的缓冲区比传输一份报文所需的缓冲区小得多,这样因缓冲区不足而等待发送的机率及等待的时间也必然少得多。
    ②简化了存储管理。因为分组的长度固定,相应的缓冲区的大小也固定,在交换结点中存储器的管理通常被简化为对缓冲区的管理,相对比较容易。
    ③减少了出错机率和重发数据量。因为分组较短,其出错机率必然减少,每次重发的数据量也就大大减少,这样不仅提高了可靠性,也减少了传输时延。
    ④由于分组短小,更适用于采用优先级策略,便于及时传送一些紧急数据,因此对于计算机之间的突发式的数据通信,分组交换显然更为合适些。
    缺点:
    ①尽管分组交换比报文交换的传输时延少,但仍存在存储转发时延,而且其结点交换机必须具有更强的处理能力。
    ②分组交换与报文交换一样,每个分组都要加上源、目的地址和分组编号等信息,使传送的信息量大约增大5%~10%,一定程度上降低了通信效率,增加了处理的时间,使控制复杂,时延增加。
    ③当分组交换采用数据报服务时,可能出现失序、丢失或重复分组,分组到达目的结点时,要对分组按编号进行排序等工作,增加了麻烦。若采用虚电路服务,虽无失序问题,但有呼叫建立、数据传输和虚电路释放三个过程。
    总之,若要传送的数据量很大,且其传送时间远大于呼叫时间,则采用电路交换较为合适;当端到端的通路有很多段的链路组成时,采用分组交换传送数据较为合适。从提高整个网络的信道利用率上看,报文交换和分组交换优于电路交换,其中分组交换比报文交换的时延小,尤其适合于计算机之间的突发式的数据通信。

    转载于:https://my.oschina.net/stayStand/blog/615864

    更多相关内容
  • 如果两台主机需要通信的话,最直接的方法是使用通信链路连接任意一对主机,这会导致 N2N^2N2 链路问题,在成本和技术方面都是不可行的;如果将每台主机与一台交换设备相连,这样每台主机仅需要一条链路,交换设备...

    数据交换

    网络核心解决的基本问题:通过数据交换来实现数据从源主机通过网络核心送达目的主机。

    为什么需要数据交换?如果两台主机需要通信的话,最直接的方法是使用通信链路连接任意一对主机,这会导致 N 2 N^2 N2 链路问题,在成本和技术方面都是不可行的;如果将每台主机与一台交换设备相连,这样每台主机仅需要一条链路,交换设备可以实现这些主机之间的数据转发,但局限于网络规模及主机间的距离;为了保证连通性并且适应不同的网络规模,于是将交换设备互连在一起形成交换网络,主机与交换网络中的某台交换设备相连,交换网络负责将数据转发至目的主机。
    在这里插入图片描述

    数据交换从技术分类上来看,可以大致分为三大类:电路交换、报文交换、分组交换。

    电路交换

    最典型电路交换网络:电话网络
    在这里插入图片描述

    电路交换的三个阶段:
    (1)建立连接(呼叫、电路建立)
    (2)通信
    (3)释放连接(拆除电路)

    电路交换在通信过程中最显著的特点是资源独占,通信连接通过多路复用技术(Multiplexing)来共享中继线,因此电路交换网络才能够同时进行多路通信。

    多路复用技术

    多路复用(Multiplexing),简称复用,将链路、网络资源(如带宽)划分为“资源片”,将资源片分配给各路通信,每路通信独占其分配到的资源片进行通信。
    也就是说资源独占其实是多路复用技术的特点,电路交换网络由于采用了多路复用技术,所以也具有资源独占的特点。
    在这里插入图片描述

    缺点:由于资源片被独占,当建立的连接不使用该资源传输数据时,这样的资源片被闲置(idle)。

    典型的多路复用技术:频分多路复用、时分多路复用、波分多路复用、码分多路复用。

    频分多路复用 FDM

    频分多路复用(Frequency-division multiplexing,FDM),是指载波带宽被划分为多种不同频带的子信道,每个子信道可以并行传送一路信号的一种多路复用技术(共享时间)
    用户在分配到一定的频带后,在通信过程中始终都占用这个频带,例如下图中四个不同颜色代表四个用户所占用的频带。
    在这里插入图片描述

    时分多路复用 TDM

    时间域被分成周期循环的等长的时分复用帧(TDM 帧),每个用户在每个 TDM 帧中占用固定序号的时隙,每个用户所占用的时隙是周期性出现(其周期就是 TDM 帧的长度)。
    时分多路复用的所有用户是在不同的时间占用相同的频带宽度(共享信道的频率)
    在这里插入图片描述

    波分多路复用 WDM

    波分复用就是光的频分复用,波分复用的实质就是频分复用。

    码分多路复用 CDM

    CDM 与 FDM(频分多路复用)和 TDM(时分多路复用)不同,它划分编码空间,它既共享信道的频率,也共享时间,是一种真正的动态复用技术。码分多路复用广泛应用于无线链路共享,如蜂窝网、卫星通信等。
    每个用户分配一个唯一的 m m m 比特码片序列(chipping sequence),其中 “0” 用 “-1” 表示,“1” 用 “+1” 表示,各用户使用相同频率载波,利用各自码片序列编码数据,编码信号=(原始数据)× (码片序列):

    • 发送比特 1(+1) 时站点就发送码片序列;
    • 发送比特 0(-1) 时就发送码片序列的反码。

    当两个或多个用户同时发送时,各路数据在信道中被线性相加。为了从信道中分离出各路信号,要求各用户的码片序列是相互正交的,即对任意两个用户的码片序列 S i , S j S_i,S_j Si,Sj,应满足:
    1 m S i ⋅ S j = { 1 , i = j 0 , i ≠ j             1 m S i ⋅ S j ‾ = { − 1 , i = j 0 , i ≠ j \frac{1}{m}S_i \cdot S_j = \left\{ \begin{array}{ll} 1, & i=j \\ 0, & i \neq j \end{array} \right. \ \ \ \ \ \ \ \ \ \ \ \frac{1}{m}S_i \cdot \overline{S_j} = \left\{ \begin{array}{ll} -1, & i=j \\ 0, & i \neq j \end{array} \right. m1SiSj={1,0,i=ji=j           m1SiSj={1,0,i=ji=j其中 S j ‾ \overline{S_j} Sj 是码片序列 S j S_j Sj 的反码。

    { d i } \{d_i\} {di} 为发送的原始数据序列,各用户的叠加向量为:
    P = ∑ i = 1 N d i ⋅ S i P=\sum_{i=1}^{N}d_i \cdot S_i P=i=1NdiSi接收用户利用发送用户的码片序列与信道中的叠加向量进行内积运算,就可以得到对应用户发送的数据(解码):
    1 m S i ⋅ P = { 1 , S i ∈ P − 1 S i ‾ ∈ P 0 , S i , S i ‾ ∉ P \frac{1}{m}S_i \cdot P= \left\{ \begin{array}{ll} 1, & S_i \in P \\ -1 & \overline{S_i} \in P \\ 0, & S_i,\overline{S_i} \notin P \end{array} \right. m1SiP=1,10,SiPSiPSi,Si/P举例:
    在这里插入图片描述

    报文交换

    报文指源主机(应用)发送的信息整体,如一个文件,报文整个地发送,一次一跳,报文交换是分组交换的前身

    每一个结点接收整个报文,检查目标结点地址,然后根据网络中的交通情况在适当的时候转发到下一个结点。经过多次的存储——转发,最后到达目标,因而这样的网络叫存储——转发网络。其中的交换结点要有足够大的存储空间(一般是磁盘),用以缓冲收到的长报文
    在这里插入图片描述

    分组交换

    分组:报文分拆出来的一序列相对较小的数据包,在拆分出的原始数据加上头部信息形成一个分组。因此,分组交换需要报文的拆分(源主机处)和重组(目的主机处),也会产生额外开销。

    分组交换采用的是统计多路复用(Statistical Multiplexing)各用户所占用的共享链路带宽并不是事先分配好的,而是采用动态分配带宽的方式:对于分组队列中的每一个分组,都是使用链路的全部带宽进行传输;但从统计角度来说,如果某用户发送的数据多,那么它所占用的共享链路带宽也要多,即按需共享链路
    在这里插入图片描述

    分组交换与报文交换都采用了存储-转发交换方式:

    • 报文交换以完整报文进行“存储-转发”
    • 分组交换以较小的分组进行“存储转发”
    • 分组交换中的交换节点(路由器)大部分时间可以并行地转发分组,而报文交换只能串行转发报文,且分组交换交换节点所需的缓冲空间要小于报文交换,从这点来看,分组交换要优于报文交换。

    分组交换与电路交换

    • 电路交换采用 FDM、TDM 等多路复用技术,而分组交换采用的是统计多路复用。
    • 分组交换允许更多用户同时使用网络,网络资源充分共享,因此分组交换适用于突发数据传输网络。
    • 分组交换无需呼叫建立、拆除,技术相对简单。
    • 分组交换可能产生拥塞:分组延迟和丢失,需要协议处理可靠数据传输和拥塞控制。
    • 电路交换是面向语音实时交互通信提出的,在分组交换网络中实现电路级性能保障还有很多问题需要解决。
    展开全文
  • 路由与交换技术(常用版)

    万次阅读 多人点赞 2019-12-27 23:30:39
    参考资料《路由与交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。 其中部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。 一、网络分层设计模型 二、...

    路由知识

    参考资料《路由与交换技术》及其实验指导,清华大学出版社;总结了常用的一些知识点,其他也会陆续总结分享。
    其中有部分知识点重复,重复的知识点是相互补充,加深记忆,还望见谅。

    一、网络分层设计模型

    在这里插入图片描述

    二、交换网部分

    1.交换机的工作原理(广播域、冲突域的理解)

    工作原理:
    a、地址学习
    b、帧的转发
    c、环路防止
    广播域:广播数据时可以发送到的区域
    冲突域:数据必然发送到的区域

    2.交换机的基本配置

    (登录方法、视图模式、?和TAB键的作用、恢复出厂设置、显示运行配置)
    在这里插入图片描述
    登录方法:en
    视图模式:conf t
    ? :显示该命令下的所有命令及简单描述(以结尾)
    Tab :自动补全当前代码
    恢复出厂:set default(交换机)、del(路由器)
    显示运行:show …(ip router)
    重启:reload
    查看运行配置:show running-config

    3.VLAN的作用、划分方法和划分配置

    Vlan的作用:
    VLAN优点:广播控制,安全性,带宽利用,延迟;
    VLAN的缺点:VLAN之间的信号交流复杂,加大了路由器负载,过多的VLAN会造成网络性能下降,导致网络主干链路流量加大,增加了网络的抽象性,专用性仍然很强。
    Vlan的划分方法:vlan 10;vlan 20;
    Vlan的划分配置:
    Int fa0/1
    switchport mode access
    switchport access vlan 100

    4.二层和三层交换机上的Trunk链路配置,VLAN网关配置

    Trunk配置:
    (二层交换机)
    Int fa0/1
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    (三层交换机)
    Int fa0/1
    SWitchport trunk encapsulation dot1q
    Switchport mode trunk
    Switchport trunk allowed vlan all
    No shutdown

    配置VLAN的IP地址:
    Switch(config)#interface vlan 10 //进入VLAN10
    Switch(config-if)#ip add 192.168.10.1 255.255.255.0 //给VLAN10配置IP地址
    Switch(config-if)#exit

    5.交换机端口链路聚合

    静态链路聚合:
    Switch(config)#int port-channel 1(聚合号)
    #exit
    #Int range fa0/1-2
    #channel-group 1 mode on
    动态链路聚合:
    int port-channel 1
    interface ethernet 0/0/1-2
    channel-group 1 mode active

    6.生成树协议(判断根桥、根端口和指定端口 spanning-tree配置)

    在这里插入图片描述
    S(config)# spanning-tree vlan 10 root primary (主根)
    S(config)# Spanning-tree vlan 10 root secondary (备份根)

    S(config)# Spanning-tree vlan 10 priority 24576 (网桥优先级)

    S(config)# int fa0/1
    S(config)# Spanning-tree port-priorit 110 (端口优先级)
    判断根桥:
    根据优先级和MAC地址,优先级小的那个就是根桥;
    如果优先级一样就看MAC地址,MAC最小的就剩根桥
    判断根端口:
    端口所在ID值较小的端口(离根桥最近,花销最小的设备上的端口)
    判断指定端口:
    根桥上的端口全是指定端口
    (如果是非根桥的指定端口,选择端口所在ID值较小的端口)

    三、冲突域与广播域

    1、交换机(链路层)

    所有端口同一广播域;同一端口同一冲突域。

    2、路由器(网络层)

    它的一个接口就是一个广播域;它的一个接口就是一个冲突域。
    (无255.255.255.255)

    3、一个vlan一个广播域。

    4、集线器(物理层)

    所有端口在同一个广播域;所有端口同一个冲突域。

    四、注意点1(vlan创建)

    1、VLAN创建后,其配置信息写在交换机的flash中,配置文件是vlan.dat
    2、要删除某个VLAN,则只要在全局模式下使用no命令即可
    (但先要将该VLAN中的端口指定到其它VLAN中,然后删除该VLAN)
    3、如要彻底删除VLAN的配置,必须删除文件VLAN.dat
    4、同一个vlan主机间可自由通信,不同vlan之间必须通过路由器或三层交换机进行数据包路由转发。
    5、Vlan作用:广播控制,安全性,带宽利用,延迟。
    6、交换机分割了冲突域,但不能分割广播域,随着交换机端口数量的增多,网络中广播增多,降低了网络效率,为了分割广播域,引入vlan。

    五、注意点2(三层交换机与静态链路聚合)

    1、三层交换机与两层交换机相比,trunk多了一个封装:
    switchport trunk encapsulation dot1q
    switchport mode trunk
    swichport trunk allowed vlan all

    2、链路聚合:(静态链路聚合)
    int port-channel channel-id
    exit
    interface ethernet interface-id
    channel-group channel-id mode on

    六、网络基础部分

    1.理解IP地址,子网掩码,路由器接口IP地址配置命令

    IP地址:(IPv4地址总数=232=42亿个)例如172.16.122.1
    在这里插入图片描述
    子网掩码:
    在这里插入图片描述在这里插入图片描述

    IP地址配置命令:
    int fa0/1
    IP address 192.168.100.1 255.255.255.0
    no shutdown(打开端口)

    2.掌握使用CIDR地址计算网址的方法

    在这里插入图片描述

    3.IP地址中网关的作用和配置

    作用:网关实质上是一个网络通向其他网络的IP地址
    IP地址配置:IP address 192.168.1.1 255.255.255.0

    4.子网划分

    在这里插入图片描述

    七、路由网部分

    1.路由器的工作原理(广播域、冲突域的理解)

    工作原理:路由与转发
    在这里插入图片描述
    广播域(基于第二层(链路层)):
    广播域就是说如果站点发出一个广播信号后能接收到这个信号的范围。通常来说一个局域网就是一个广播域。
    冲突域(基于第一层(物理层)):
    一个站点向另一个站点发出信号。除目的站点外,有多少站点能收到这个信号。这些站点就构成一个冲突域。

    2.路由器的基本配置

    (登录方法、视图模式、显示运行配置)
    登陆方法,视图模式:
    在这里插入图片描述
    显示历史记录:show history

    3.路由器的VLAN单臂路由、VLAN间路由、直连路由,静态路由,默认路由

    单臂路由(实现Vlan间的通信):
    Router_config# Int f0/0
    Router_config# no shutdown
    exit
    Int f0/0.10(子接口)
    encapsulation dot1q 10
    ip address 192.168.10.254(网关地址) 255.255.255.0(子网掩码)

    直连路由:
    interface f0/0
    ip address 10.1.1.1 255.0.0.0(或者192.168.2.1 255.255.255.0)
    no shutdown

    静态路由:
    ip route 192.168.1.0(目的网络地址) 255.255.255.0 (子网掩码) 192.168.2.1(下一跳IP地址,与本路由器直接相连的下一路由器的接口地址)

    ip route 192.168.1.0 255.255.255.0 s0/0 (下一跳路由接口号)

    默认路由:当在路由表中找不到目标网络的条目时,请求转发到默认路由接口
    ip route 0.0.0.0 0.0.0.0 192.168.2.2
    Vlan间路由即vlan间通信成功

    4.动态路由RIP、OSPF、EIGRP配置

    RIP配置:
    router rip
    version 2 //version 2代表rip 2不能变\或默认路由:default_information orig
    no auto-summary \关闭自动汇总
    network 192.168.1.0
    network 192.168.2.0(需要配置rip的网络地址)

    EIGRP配置:
    router eigrp 10
    no auto-summary
    network 192.168.9.0(需要配置的网段地址)

    OSPF配置:
    router ospf 10(进程号)
    router-id 1.1.1.1 (路由器ID:标识路由器)
    network 192.168.3.0(网络号) 0.0.0.255(反向子网掩码) area 0 (区域号)
    network 172.16.0.0 0.0.255.255 area 0

    Router ID——是在OSPF区域内唯一标识一台路由器的IP地址

    5.RIP和OSPF 特点对比

    在这里插入图片描述

    6.广域网配置(PPP,认证PAP)

    PPP(Point to Point Protocol)协议:
    在点对点链路上运行的数据链路层协议
    PAP:
    两次握手认证协议,口令以明文传送,被认证方首先发起认证请求。
    PPP配置:
    单向认证:

    (被认证方)
    host name Ra
    Int s0/1/1
    ip address ip 200.100.100.1 255.255.255.0
    encapsulation ppp
    ppp pap sent-username Ra password 123456 //Ra发送过去的认证消息
    No shutdowm
    exit

    (主认证方)
    host name Rb
    user-name Ra password 123456
    Int s0/1/1
    ip address 200.100.100.2 255.255.255.0
    encapsulation ppp
    ppp authentication pap
    No shutdown
    exit
    双向认证:
    在这里插入图片描述

    八、注意点3(vlan间路由技术与ip路由协议)

    1、vlan间路由技术: 三层交换
    2、单臂路由产生的瓶颈:数据量大,路由器和交换机之间的路径会成为整个网络的瓶颈。
    解决:应用三层交换机—>二层交换+三层转发
    3、创建VLAN: vlan 30
    4、配置网关地址
    interface vlan 30
    ip address 192.168.30.1 255.255.255.0
    5、启动IP路由协议
    ip routing

    九、注意点4(各类路由)

    1、直连路由:在路由器上配置了接口的IP地址
    Int f 0/0
    ip add 10.1.1.1 255.0.0.0
    no shut
    特点:运用在规模较小,拓扑机构固定的网络中
    2、静态路由:由管理员手工配置,是单向的;
    ip route 192.168.1.0(目标地址)255.255.255.0 192.168.2.1(下一站地址)
    特点:路由表是人工设置的,除非网络管理员干预,否则静态路由不发生变化。
    2、默认路由:
    IP route 0.0.0.0 0.0.0.0 192.168.2.2(下一跳地址)
    特点:默认路由的优先级最低,即没有找到其他路由项时使用。
    使用环境:一般应用在只有一个出口的末端网络,用于连接Internet,安全性不高,作为其他路由的补充。
    4、单臂路由:(此时交换机上做trunk)
    Int f0/0.10
    encapsulation dotlq 10
    ip add 192.168.10.1 255.255.255.0
    int f0/0 no shut

    十、注意点5(各类配置)

    1、路由技术(动态路由):路由器之间通过路由协议动态地构建路由表
    2、自治系统:执行统一路由策略的一组网络设备的组合
    Rip、eigrp、ospf三种动态路由协议工作原理、特点和度量方法
    3、rip配置(路由标记是R)
    route rip
    version 2// 默认路由是default_imformation orig
    no auto-summary
    network
    show IP route

    4、Eigrp配置 (路由标记是D)
    router eigrp 10
    no auto-summary
    network 192.168.1.0
    show ip route show ip eigrp neighbor show ip eigrp topology

    5、Ospf配置(路由标记是O)
    route ospf 1
    router -id 1.1.1.1
    network 192.168.3.0 0.0.0.255 area 0
    show ip route show ip ospf neighbor show ip ospf database

    十一、注意点6(PPP和PAP拓展)

    1、Ppp协议:在串行链路上封装上层数据报文的方法,采用链路控制协议来建立配置控制和测试,采用网络控制协议来支持多种网络层路由协议。
    2、Ppp链路建立:链路不可用,链路建立 认证 网络层协议 链路终止阶段
    优点:支持同步或异步串行链路的传输,支持多种网络层协议,支持错误检测,支持用户认证,允许进行数据压缩。
    3、pap两次握手协议:口令以明文发送,认证方首先发起认证请求

    十二、网络安全部分

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)

    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝

    2.NAT(静态NAT、动态NAT和端口NAT)

    1.路由器和三层交换机上的ACL作用及其配置(标准和扩展)
    *可以限制网络流量、提高网络性能。   
    *提供对通信流量的控制手段。   
    *是提供网络安全访问的基本手段。
    *可以在路由器端口处决定哪种类型的通信流量被转发或被阻塞。
    *访问控制列表(ACL)——应用于路由器接口的指令列表 ,用于指定哪些数据包可以接收转发,哪些数据包需要拒绝
    2.NAT(静态NAT、动态NAT和端口NAT)
    .NAT的3种实现方式
    *静态转换——内部私有IP的服务器对内网和外网提供WEB、FTP等服务
    *动态转换——内部主机(私有IP)通过NAT转换使用公用地址池访问INTERNET
    *端口转换——内部主机(私有IP)通过NAT转换使用同1个公用地址访问INTERNET

    十三、ACL

    1、标准访问控制列表

    只使用源地址进行过滤,表明是允许还是拒绝

    2、访问控制列表号

    从1到99

    3、扩展访问控制列表

    *基于源和目的地址、传输层协议和应用端口号进行过滤
    *每个条件都必须匹配,才会施加允许或拒绝条件
    *使用扩展ACL可以实现更加精确的流量控制
    *访问控制列表号从100到199

    展开全文
  • 氨氮不仅是生活污水主要污染物之一,也是引起水体富营养化主要因素之一不少研究对蛭石、蒙脱石、沸石、离子交换树脂等常见离子交换材料在氨氮废水处理中的应用进行了探索,取得了不同的处理效果文中基于已研究结果...
  • 【企业常见应用技术系列】第二期:华为路由交换由学习汇总
  • 路由交换的一些常见知识点总结

    千次阅读 2022-03-22 19:26:03
    原则上,TCP应该能够在从硬线连接到分组交换或电路交换网络的各种通信系统之上操作。 各个层哪些协议,以及知名协议对应的端口号。 HTTP :80端口 Telnet:23端口 FTP:20和21端口 SMTP:25端口 TFTP:22端口 DNS:53...

    1. OSI七层模型结构,以及各个层的作用。

    2.TCP/IP协议栈模型结构,功能,与OSI七层模型的对应关系。

    TCP/IP协议是规范不同主机之间进行通信的一系列协议,其中涉及到数据的封装,传输,寻址等一系列内容,是计算机领域非常重要的基础知识

        IP是Internet Protocol(网际互连协议)的缩写,是TCP/IP体系中的网络层协议。

    设计IP的目的是提高网络的可扩展性:

        一是解决互联网问题,实现大规模、异构网络的互联互通;

        二是分割顶层网络应用和底层网络技术之间的耦合关系,以利于两者的独立发展。

    根据端到端的设计原则,IP只为主机提供一种无连接、不可靠的、尽力而为的数据包传输服务。

    传输控制协议(TCP,Transmission Control Protocol)是一种面向连接的、可靠的、基于字节流的传输层通信协议,

    由IETF的RFC 793 [1]  定义。

    TCP旨在适应支持多网络应用的分层协议层次结构。

       连接到不同但互连的计算机通信网络的主计算机中的成对进程之间依靠TCP提供可靠的通信服务。

      TCP假设它可以从较低级别的协议获得简单的,可能不可靠的数据报服务。

      原则上,TCP应该能够在从硬线连接到分组交换或电路交换网络的各种通信系统之上操作。
     

    各个层有哪些协议,以及知名协议对应的端口号。

    HTTP :80端口

    Telnet:23端口

    FTP:20和21端口

    SMTP:25端口

    TFTP:22端口

    DNS:53端口

    SNMP:161和162端口

    DHCP:68端口

    TCP/UDP两大协议簇;协议簇的区别?应用场景。

                                  TCP/UDP协议簇都包含的协议

    TCP

    UDP

    Telnet

    TFTP

    HTTP

    DNS

    FTP

    SNMP

    SMTP

    DHCP

     三次握手、四次挥手

     

     arp协议的作用,arp欺骗怎么防御

    作用

     

    防御方法:  

    01: 静态MAC地址绑定 windows 电脑命令 =>  arp -s [网关] [正常的MAC地址]  如: arp -s 192.168.3.1  9c-06-1b-b4-3e-b8 

    02: 双向静态绑定, 推荐家庭网络, 公共网络不适用

    03: 安全软件和防火墙

    TCP、UDP、IP、数据帧报文头部有哪些字段

    TCP数据段格式    
          TCP是一种可靠的、面向连接的字节流服务。源主机在传送数据前需要先和目标主机建立连接。然后,在此连接上,被编号的数据段按序收发。同时,要求对每个数据段进行确认,保证了可靠性。如果在指定的时间内没有收到目标主机对所发数据段的确认,源主机将再次发送该数据段。 下图为TCP头部结构:

    UDP数据段格式    
        UDP是一种不可靠的、无连接的数据报服务。源主机在传送数据前不需要和目标主机建立连接。数据被冠以源、目标端口号等UDP报头字段后直接发往目的主机。这时,每个数据段的可靠性依靠上层协议来保证。在传送数据较少、较小的情况下,UDP比TCP更加高效。   
    下图为UDP的头部结构:

       

    IP报文段格式
    下图为IP的头部结构:

     

     

    展开全文
  • 路由交换技术(一)---- 网络基础概述

    千次阅读 多人点赞 2020-06-20 14:54:19
    计算机-计算机通信网络 (标志:戴维斯 Davies 首次提出了“分组”,之后就了分组交换技术) 计算机网络标准化阶段 高速网络阶段 ​ 网络分类 网络拓扑结构: 计算机通信分类:单播、广播、多播 1.2 ...
  • 有关交换技术之前所采用的电路交换,报文交换这些基本已经见不到了,所以一般学习也接触不到。但是为了更好的理解当下的交换技术,从而还是理解下最好。看到一份别人做的swf动画中,对这四个技术的区别做的总结还是...
  • 1.3 说明现在常见交换方法哪多个各什么特点及应用场所 答电路交换,多速率电路交换.快速电路交换,分组交换, 帧交换, 帧中继ATM交换, IP交换, 多协议标识交换(MPLS, 光交换, 软交换. 电路交换 信息传送最小单位是...
  • 通信技术有很多,下面选几个在物联网应用比较适合的和大家详细分析其特点和适用场景。 终端双向通讯(A类): 边缘计算网关是工业物联网不可或缺的设备,它就像人体的神经,将感知到的各类讯息传递给大脑进行处理,...
  • 光纤交换技术PDF格式

    2009-11-06 14:49:29
    光纤交换技术PDF格式 Fabric Channel交换技术,储备网络交换设备,交换机登录方式/状态,常用命令,fabricshow,常见故障诊断
  • 网络中的数据通信介绍了网络通信的几种基本方式!三种常见的数据交换技术在本文由详细介绍!
  • 计算机网络结构与数据交换技术

    万次阅读 热门讨论 2021-03-28 17:24:28
    一、计算机网络结构 大规模现代计算机网络:网络边缘、接入网络与网络核心 1.网络边缘:连接到网络上的所有端系统(例如:连接到网络上的计算机、服务器、智能手机等)...常见的网络接入技术:电话拨号接入、非对称数
  • 目录: 01.《交换那些事儿》- 基础维护篇 - 流统 02.《交换那些事儿》- 基础维护篇 - 镜像 03.《交换那些事儿》- 基础维护篇 - IRF升级指导 ...24.《交换那些事儿》 -技术专题篇 - DRNI部署网络模型介绍
  • 信息安全的五个基本要素,即需保证信息的... 5、解密、加密技术 6、身份认证技术 用来确定访问或介入信息系统用户或者设备身份的合法性的技术,典型的手段用户名口令、身份识别、PKI 证书和生物认证等。 参考资料:
  • 几种常见的网络攻防技术 前言 一、SQL注入 二、XSS 攻击 1.反射型 2.存储型 三、CSRF 攻击 四、DDoS 攻击 五、DNS劫持 六、JSON 劫持 七、暴力破解 文章同样适用于非专业的朋友们,全文通俗化表达,一定能找到你亲身...
  • 当前,随着互联网技术日益成熟,有线网络从铜线向光纤的顺利...那么,常见的物联网通信技术有那些呢? 从技术层面来讲,通常将物联网分为三层,分别是感知层、网络层、应用层。其中,网络层肩负数据、信息安全可靠...
  • 常见的该类设备电话交换机、程控数字交换系统。 特点:采用面向物理连接的工作方式;采用同步时分复用技术;对用户信息透明传输,电话网对用户的信息不做处理。 优点:传输时延小;传输效率高,不需要添加控制信息...
  • 个人学习笔记:路由交换学习思路

    千次阅读 2019-06-13 12:46:29
    交换技术 vlan QinQ 生成树 VRRP DHCP配置 路由配置 RIP OSPF ISIS BGP 路由策略 策略路由 组播 IP组播基础 IGMP PIM VPN QOS 目前就想到了这么多路由交换的常见知识点....
  • 《网络互连技术:路由、交换与远程访问》每章配大量的、形式丰富的思考与练习题用于读者巩固每章所学内容,特别适合于规范的课堂教学使用。还配《网络互连技术——路由、交换与远程访问实训教程》一书,以巩固所...
  • 路由与交换课程设计

    万次阅读 多人点赞 2019-01-09 01:21:16
     组建某网络,公司三层楼,每层都不同的部门,完成以下网络需求:  1)搭建公司私有局域网络环境,利用P AT技术,使用路由设备(路由器、防火器等)完成由局域网到互联网的接入。  2)在局域网中公司各部门间...
  • 计算机网络中的三种交换方式

    千次阅读 2021-11-02 09:35:52
    计算机网络中的三种交换方式一、电路交换二、分组交换三、报文交换 一、电路交换 电话交换机接通电话线的方式称为电路交换; 从通信资源的分配角度来看,交换(switching)就是按照某种方式动态地分配传输路线的...
  • 文章目录中间件是什么为什么使用中间件常见的中间件哪些 中间件是什么 中间件是一种独立的系统软件或服务程序,分布式应用软件借助这种软件在不同的技术之间共享资源。中间件位于客户机/ 服务器的操作系统之上,...
  • 多路复用技术分为以下四种: 1、频分多路复用,特点是把电路或空间的频带资源分为多个频段,并将其分配给多个用户,每个用户终端的数据通过分配给它的子通路传输。主要用于电话和电缆电视系统。 2、时分多路复用,...
  • 常用数据交换格式

    千次阅读 2020-01-03 21:37:32
    什么是数据交换格式?、JSON、XML
  • 企业网中哪些常见的网络设备? 这些网络设备的功能是什么? 企业级网络设备和家用网络设备什么不同? 一、 交换机 交换机是组建企业网时最基本的设备,下面从交换机的功能,低端和高端交换机的区别,...
  • 题目:比较电路交换、报文交换、分组交换的主要优缺点 答:见下表: 优点 缺点 电路交换 (1).信息的传输时延小,且对一次接续而言,传输...
  • 常见的交换机接口哪些?

    千次阅读 2019-09-18 07:14:40
     RJ-45接口是目前最常见的网络设备接口,俗称"水晶头",属于双绞线以太网接口类型。RJ-45插头只能沿固定方向插入,设一个塑料弹片与RJ-45插槽卡住以防止脱落。 (https://s1.51cto.com/images...
  • 物联网技术有哪些

    千次阅读 2022-03-22 14:22:48
    定义上常常是这样说的,物联网是是新一代信息技术的重要...那么物联网技术有哪些?  1、传感器技术  计算机应用中的关键技术。大家都知道,到目前为止绝大部分计算机处理的都是数字信号。自从有计算机以来就需要传感器
  • 个人结合诸多资料,总结的一些JavaEE常见面试题,主要针对初/中级程序员。想要word完整版下载的,评论里留言留下你的邮箱!

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 137,158
精华内容 54,863
关键字:

常见的交换技术有