精华内容
下载资源
问答
  • 问题描述:将Debug切换成realse编译时,报错:“error MSB8008: 指定的平台工具集(v120)未安装或无效。” 解决方法(英版和汉版): ①Project > Properties > Configuration Properties > General ...

    系统:win7

    环境:VS2010

    语言:C++

    问题描述:将Debug切换成realse编译时,报错:“error MSB8008: 指定的平台工具集(v120)未安装或无效。”


    解决方法(英版和汉版):

    ①Project > Properties > Configuration Properties > General (General) > Platform Toolset >> v100

    ②项目属性->配置属性->平台工作集 ,将其修改为:V100即可。

    展开全文
  • VS2012兼容VS2010时注意平台工具集

    千次阅读 2013-12-18 09:55:04
    当2012打开2010的程序时,如果更新了平台工具集,会导致生成的可执行程序出问题,是因为用V110的平台工具集编译了V100的平台工具集,这是要在项目属性里设置平台工具集V100
    当2012打开2010的程序时,如果更新了平台工具集,会导致生成的可执行程序出问题,是因为用V110的平台工具集编译了V100的平台工具集,这是要在项目属性里设置平台工具集V100
    
    展开全文
  • 参考链接 相关解决方案 转载于:https://www.cnblogs.com/eat-too-much/p/10843399.html

    参考链接

    相关解决方案

    转载于:https://www.cnblogs.com/eat-too-much/p/10843399.html

    展开全文
  • 什么是平台工具集平台工具集其实是MSBuild 其目录所在C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0。 只有安装了对应的vs版本才能选择对应的选项。 VS从2010之后开始支持使用之前的版本进行编译,可以在...

    一、什么是平台工具集:

    1. 平台工具集其实是MSBuild
    2. 其目录所在C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0。
    3. VS从2010之后开始支持使用之前的版本进行编译,可以在工程属性->常规中进行设置。
      在这里插入图片描述

    VS各版本对应的工具集版本号如下:
    -Visual Studio 2019: V142
    -Visual Studio 2017: V141
    -Visual Studio 2015: V140
    -Visual Studio 2013: V120
    -Visual Studio 2012: V110
    -Visual Studio 2010: V100
    -Visual Studio 2008: V90
    -Visual Studio 2005: V80
    -Visual Studio 2003: V71
    -Visual Studio 2002: V70
    -Visual Studio 6: V60

    二、单独安装平台工具集

    2.1 场景

    我现在电脑只安装了vs2019开发环境,也就是我只有v142版本的工具集。如果我想打开vs2017或者vs2015版本的项目,怎么办?第一种方法就是升级平台工具集,然鹅这种方法对项目的改动比较大,如果项目中有很多依赖项,往往会因为主工程和依赖库版本不匹配,导致编译不过,不建议。另一种方法就是保持工具集版本不动。

    2.2 方法

    1. 利用visual studio 2019 installer安装vs2017,2015对应的工具集
      运行installer,“单个组件”->“编译器、生成器和运行时”,找到v140-vs2015 C++生成工具v141-vs2017 C++生成工具,勾选上,点击"修改"。
      在这里插入图片描述

    在这里插入图片描述

    1. 用vs2019打开15或者17项目时,会提示"重定向项目",平台工具集选"无升级",这样就是用老的工具集。项目名称后会有个括号,如下图。
      ![![在这里插入

    在这里插入图片描述

    1. 安装好对应的工具集后,在项目属性页可以看到相应的选项。
      在这里插入图片描述

    2.3 注意

    我电脑上只安装了vs2019,并且2019 installer里面只找到了2017,2015的工具集,如果需要更早的vs2012,2010对应的工具集,除了安装对应的IDE我暂时也不知道有什么办法。

    展开全文
  • VS修改平台工具集

    万次阅读 2017-06-18 20:26:56
    MSB8020 无法找到 Visual Studio 2010 的生成工具(平台工具集 =“v100”)。若要使用 v100 生成工具进行生成,请安装 Visual Studio 2010 生成工具。或者,可以升级到当前 Visual Studio 工具,方式是通过选择“项目...
  • vs2012平台下新建QT application工程,将工具集改成VS2010 V100之后生成出错,情况如下: 1>qtmaind.lib(qtmain_win.obj) : error LNK2038: 检测到“_MSC_VER”的不匹配项: 值“1700”不匹配值“1600”(moc_rr.obj ...
  • VS平台工具集.zip

    2020-05-16 20:29:45
    解压内容到VS所在盘(一般是C 盘 )C:\Program Files (x86)\MSBuild 即可
  • 在VS2010, 编译时错误描述: 错误 1 error MSB8008: 指定的平台工具集(v110)未安装或无效。请确保选择受支持的 Platform...打开:项目 -> 属性 -> 配置属性 -> 常规 -> 平台工具集:v110 ,将v110 修改为v100
  • 如何:修改目标框架和平台工具集

    千次阅读 2018-03-14 17:36:22
    适应与高版本的vs使用低版本的,你可以直接选择低版本的工具集来编译代码可以更改 Visual C++ 项目设置以面向不同版本的 .NET Framework 和使用不同的平台工具集。 默认情况下,项目系统将使用对应于你用于创建该...
  • 解决方法: 打开项目属性–>选择配置属性–>常规–>平台工具集,选择v100(原来工具集里没有v141项)。修改完后重新编译就OK了。
  • vs 开发 qt 遇到 无法找到 Visual Studio 2010 的生成工具(平台工具集 =“v100”) 解决方案
  • vs平台工具集问题

    千次阅读 2019-09-06 10:39:30
    最近在看《windows黑客编程技术详解》,书还可以,都是些比较零碎但是实用和有效的代码 由于里边全是vs2013的例子,我vs2017工具集不...右键项目“GlobalHook_Test”,属性,配置属性,常规,平台工具集。 程序工具...
  • Vs2019 低版本平台工具集解决办法 * 兼容2008~2017 平台工具集。 * 解压复制到C:\Program Files (x86)目录即可。 * 适用 Visual Studio 2019 ,11月份更新
  • vs 平台工具集版本

    千次阅读 2018-10-14 15:02:59
    VS从2010之后开始支持使用之前...VS各版本对应的工具集版本号如下: -Visual Studio 2015: V140 -Visual Studio 2013: V120 -Visual Studio 2012: V110 -Visual Studio 2010: V100 -Visual Studio 2008: V90 ...
  • 平台工具集(v110)是vs2012下用的,你是用vs2010打开工程,它默认是用v100, 所以这个工程可能用vs2012打开并更新过。 解决方法: 详细的解决方法可参考VC错误:http://www.vcerror.com/?p=318
  • 平台工具集(v110)是vs2012下用的,你是用vs2010打开工程,它默认是用v100, 所以这个工程可能用vs2012打开并更新过。 解决方法:右键点击你的项目,选择属性,再点击配置属性中的常规,常规中有个平台工作集,把V110...
  • vs平台工具集

    万次阅读 2015-08-09 09:32:00
    vs2010版本之后支持使用之前的...其中vs2013中可以识别已经安装的vs2012(Visual Studio 2012 (v110)), vs2012可以识别已安装的vs2010(Visual Studio 2010 (v100)),vs2010可以识别已经安装的vs2008(Visual Stud
  • 编译时错误: 运行时错误: 产生这个问题的原因是我之前在VS2015中调式过该工程,所以工程的平台工具集配置成了V140,而VS2010对应的平台工具集V100.所以,只需手动将工具集的版本改回来:右键点击你的项目,选择...
  • VS2015平台工具集问题

    2017-08-31 02:49:05
    你好, 我请教一下,我要修改一个工具的代码(VS2010编的),但是我的电脑是VS2015,为了让别人(VS2010)还能继续编译,我该如何做呢?还有就是工具的客户不用添加工具集V140也可以正常使用,两个问题,谢谢。
  • 平台工具集(v110)是vs2012下用的,你是用vs2010打开工程,它默认是用v100, 所以这个工程可能用vs2012打开并更新过。 解决方法:右键点击你的项目,选择属性,再点击配置属性中的常规,常规中有个平台工作集,把V1
  • 平台工具集是用vs2010打开工程,它默认是用v100,所以这个工程可能用vs2010更高版本打开并更新过。 解决方法:右键点击你的项目,选择属性,再点击配置属性中的常规,常规中有个平台工作集,把V120改成V100,点击...
  • vs 平台工具集

    2015-03-03 14:40:00
    2019独角兽企业重金招聘Python工程师标准>>> ...vs 2010 -> v100 vs 2013 -> v120 必须安装了 vs 2010 才能使用 v100 转载于:https://my.oschina.net/zsjasper/blog/381917
  • VS平台工具集版本

    千次阅读 2016-06-17 14:20:00
    VS从2010之后开始支持使用之前的版本进行编译,可以在工程属性->常规中进行设置。...VS各版本对应的工具集版本号如下: -Visual Studio 2015: V140 -Visual Studio 2013: V120 -Visual Studio 2012: ...
  • 在运行一个手写识别程序(其实跟编写的什么内容无关。。。)时,出现 这样的错误。后来在CSDN上看见有个人的解决方案...但是由于我的版本是VS2010,我把平台工具集改成VS
  • 今天在编译用vs2012编译C++动态库提示:error MSB8020: The builds tools for v140_xp (Platform ... To build using the v140_xp build tools ,后来发现源代码用vs2015编译用的是v140平台,vs2012用的是v110平台,...
  • 如何:修改目标框架和平台工具集 Visual Studio 2013 其他版本 可以更改 Visual C++ 项目设置以面向不同版本的 .NET Framework 和使用不同的平台工具集。 默认情况下,项目

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 888
精华内容 355
关键字:

平台工具集v100