精华内容
下载资源
问答
  • 三层交换机的优点在于接口类型丰富,支持的三层功能强大,路由能力强大,适合用于大型的网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。...


    二层交换机和三层交换机的区别

    二层交换机用于小型的局域网络。这个就不用多言了,在小型局域网中,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的解决方案。

    三层交换机的优点在于接口类型丰富,支持的三层功能强大,路由能力强大,适合用于大型的网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。

    三层交换机的最重要的功能是加快大型局域网络内部的数据的快速转发,加入路由功能也是为这个目的服务的。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。

    一般来说,在内网数据流量大,要求快速转发响应的网络中,如全部由三层交换机来做这个工作,会造成三层交换机负担过重,响应速度受影响,将网间的路由交由路由器去完成,充分发挥不同设备的优点,不失为一种好的组网策略,当然,前提是客户的腰包很鼓,不然就退而求其次,让三层交换机也兼为网际互连。

    三层交换机和路由器的区别

    1. 主要功能不同

    虽然三层交换机与路由器都具有路由功能,但我们不能因此而把它们等同起来,正如现在许多网络设备同时具备多种传统网络设备功能一样,就如现在有许多宽带路 由器不仅具有路由功能,还提供了交换机端口、硬件防火墙功能,但不能把它与交换机或者防火墙等同起来一样。因为这些路由器的主要功能还是路由功能,其它功 能只不过是其附加功能,其目的是使设备适用面更广、使其更加实用。这里的三层交换机也一样,它仍是交换机产品,只不过它是具备了一些基本的路由功能的交换 机,它的主要功能仍是数据交换。也就是说它同时具备了数据交换和路由由发两种功能,但其主要功能还是数据交换;而路由器仅具有路由转发这一种主要功能。

    2. 主要适用的环境不一样

    三层交换机的路由功能通常比较简单,因为它所面对的主要是简单的局域网连接。正因如此,三层交换机的路由功能通常比较简单,路由路径远没有路由器那么复杂。它用在局域网中的主要用途还是提供快速数据交换功能,满足局域网数据交换频繁的应用特点。

    而路由器则不同,它的设计初哀就是为了满足不同类型的网络连接,虽然也适用于局域网之间的连接,但它的路由功能更多的体现在不同类型网络之间的互联上,如 局域网与广域网之间的连接、不同协议的网络之间的连接等,所以路由器主要是用于不同类型的网络之间。它最主要的功能就是路由转发,解决好各种复杂路由路径 网络的连接就是它的最终目的,所以路由器的路由功能通常非常强大,不仅适用于同种协议的局域网间,更适用于不同协议的局域网与广域网间。它的优势在于选择 最佳路由、负荷分担、链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。为了与各种类型的网络连接,路由器的接口类型非常丰富,而三层交换机 则一般仅同类型的局域网接口,非常简单。

    3. 性能体现不一样

    从技术上讲,路由器和三层交换机在数据包交换操作上存在着明显区别。路由器一般由基于微处理器的软件路 由引擎执行数据包交换,而三层交换机通过硬件执行数据包交换。三层交换机在对第一个数据流进行路由后,它将会产生一个MAC地址与IP地址的映射表,当同 样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。同时,三层交 换机的路由查找是针对数据流的,它利用缓存技术,很容易利用ASIC技术来实现,因此,可以大大节约成本,并实现快速转发。而路由器的转发采用最长匹配的 方式,实现复杂,通常使用软件来实现,转发效率较低。

    正因如此,从整体性能上比较的话,三层交换机的性能要远优于路由器,非常适用于数据交换频繁的局域网中;而路由器虽然路由功能非常强大,但它的数据包转发 效率远低于三层交换机,更适合于数据交换不是很频繁的不同类型网络的互联,如局域网与互联网的互联。如果把路由器,特别是高档路由器用于局域网中,则在相 当大程度上是一种浪费(就其强大的路由功能而言),而且还不能很好地满足局域网通信性能需求,影响子网间的正常通信。

    综上所述,三层交换机与路由器之间还是存在着非常大的本质区别的。无论从哪方面来说,在局域网中进行多子网连接,最好还选用三层交换机,特别是在不同子网 数据交换频繁的环境中。一方面可以确保子网间的通信性能需求,另一方面省去了另外购买交换机的投资。当然,如果子网间的通信不是很频繁,采用路由器也无可 厚非,也可达到子网安全隔离相互通信的目的。具体要根据实际需求来定。

    区别:二层、路由、三层、四层

    二层交换技术

    二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。具体的工作流程如下:

    (1)当交换机从某个端口收到一个数据包,它先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上的;

    (2)再去读取包头中的目的MAC地址,并在地址表中查找相应的端口;

    (3)如表中有与这目的MAC地址对应的端口,把数据包直接复制到这端口上;

    (4)如表中找不到相应的端口则把数据包广播到所有端口上,当目的机器对源机器回应时,交换机又可以学习一目的MAC地址与哪个端口对应,在下次传送数据时就不再需要对所有端口进行广播了。不断的循环这个过程,对于全网的MAC地址信息都可以学习到,二层交换机就是这样建立和维护它自己的地址表。

    路由技术

    路由器工作在OSI模型的第三层——网络层操作,其工作模式与二层交换相似,但路由器工作在第三层,这个区别决定了路由和交换在传递包时使用不同的控制信息,实现功能的方式就不同。工作原理是在路由器的内部也有一个表,这个表所标示的是如果要去某一个地方,下一步应该向那里走,如果能从路由表中找到数据包下一步往那里走,把链路层信息加上转发出去;如果不能知道下一步走向那里,则将此包丢弃,然后返回一个信息交给源地址。

    路由技术实质上来说不过两种功能:决定最优路由和转发数据包。路由表中写入各种信息,由路由算法计算出到达目的地址的最佳路径,然后由相对简单直接的转发机制发送数据包。接受数据的下一台路由器依照相同的工作方式继续转发,依次类推,直到数据包到达目的路由器。而路由表的维护,也有两种不同的方式。一种是路由信息的更新,将部分或者全部的路由信息公布出去,路由器通过互相学习路由信息,就掌握了全网的拓扑结构,这一类的路由协议称为距离矢量路由协议;另一种是路由器将自己的链路状态信息进行广播,通过互相学习掌握全网的路由信息,进而计算出最佳的转发路径,这类路由协议称为链路状态路由协议。

    由于路由器需要做大量的路径计算工作,一般处理器的工作能力直接决定其性能的优劣。当然这一判断还是对中低端路由器而言,因为高端路由器往往采用分布式处理系统体系设计。

    三层交换技术

    使用IP的设备A------------------------三层交换机------------------------使用IP的设备B比如A要给B发送数据,已知目的IP,那么A就用子网掩码取得网络地址,判断目的IP是否与自己在同一网段。

    如果在同一网段,但不知道转发数据所需的MAC地址,A就发送一个ARP请求,B返回其MAC地址,A用此MAC封装数据包并发送给交换机,交换机起用二层交换模块,查找MAC地址表,将数据包转发到相应的端口。

    如果目的IP地址显示不是同一网段的,那么A要实现和B的通讯,在流缓存条目中没有对应MAC地址条目,就将第一个正常数据包发送向一个缺省网关,这个缺省网关一般在操作系统中已经设好,对应第三层路由模块,所以可见对于不是同一子网的数据,最先在MAC表中放的是缺省网关的MAC地址;然后就由三层模块接收到此数据包,查询路由表以确定到达B的路由,将构造一个新的帧头,其中以缺省网关的MAC地址为源MAC地址,以主机B的MAC地址为目的MAC地址。通过一定的识别触发机制,确立主机A与B的MAC地址及转发端口的对应关系,并记录进流缓存条目表,以后的A到B的数据,就直接交由二层交换模块完成。这就通常所说的一次路由多次转发。

    二层交换机用于小型的局域网络。这个就不用多言了,在小型局域网中,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的解决方案。

    路由器的优点在于接口类型丰富,支持的三层功能强大,路由能力强大,适合用于大型的网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。

    三层交换机的最重要的功能是加快大型局域网络内部的数据的快速转发,加入路由功能也是为这个目的服务的。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由功能的快速转发的三层交换机就成为首选。

    四层交换技术

    第四层交换的一个简单定义是:它是一种功能,它决定传输不仅仅依据MAC地址(第二层网桥)或源/目标IP地址(第三层路由),而且依据TCP/UDP(第四层)应用端口号。第四层交换功能就象是虚IP,指向物理服务器。它传输的业务服从的协议多种多样,有HTTP、FTP、NFS、Telnet或其他协议。这些业务在物理服务器基础上,需要复杂的载量平衡算法。在IP世界,业务类型由终端TCP或UDP端口地址来决定,在第四层交换中的应用区间则由源端和终端IP地址、TCP和UDP端口共同决定。在第四层交换中为每个供搜寻使用的服务器组设立虚IP地址(VIP),每组服务器支持某种应用。在域名服务器(DNS)中存储的每个应用服务器地址是VIP,而不是真实的服务器地址。当某用户申请应用时,一个带有目标服务器组的VIP连接请求(例如一个TCP SYN包)发给服务器交换机。服务器交换机在组中选取最好的服务器,将终端地址中的VIP用实际服务器的IP取代,并将连接请求传给服务器。这样,同一区间所有的包由服务器交换机进行映射,在用户和同一服务器间进行传输。第四层交换的原理OSI模型的第四层是传输层。传输层负责端对端通信,即在网络源和目标系统之间协调通信。在IP协议栈中这是TCP(一种传输协议)和UDP(用户数据包协议)所在的协议层。

    在第四层中,TCP和UDP标题包含端口号(portnumber),它们可以唯一区分每个数据包包含哪些应用协议(例如HTTP、FTP等)。端点系统利用这种信息来区分包中的数据,尤其是端口号使一个接收端计算机系统能够确定它所收到的IP包类型,并把它交给合适的高层软件。端口号和设备IP地址的组合通常称作"插口(socket)"。1和255之间的端口号被保留,他们称为"熟知"端口,也就是说,在所有主机TCP/I P协议栈实现中,这些端口号是相同的。除了"熟知"端口外,标准UNIX服务分配在256到1024端口范围,定制的应用一般在1024以上分配端口号。分配端口号的最近清单可以在RFc1700"Assigned Numbers"上找到。TCP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第4层交换的基础。

    具有第四层功能的交换机能够起到与服务器相连接的"虚拟IP"(VIP)前端的作用。每台服务器和支持单一或通用应用的服务器组都配置一个VIP地址。这个VIP地址被发送出去并在域名系统上注册。在发出一个服务请求时,第四层交换机通过判定TCP开始,来识别一次会话的开始。然后它利用复杂的算法来确定处理这个请求的最佳服务器。一旦做出这种决定,交换机就将会话与一个具体的IP地址联系在一起,并用该服务器真正的IP地址来代替服务器上的VIP地址。

    每台第四层交换机都保存一个与被选择的服务器相配的源IP地址以及源TCP端口相关联的连接表。然后第四层交换机向这台服务器转发连接请求。所有后续包在客户机与服务器之间重新影射和转发,直到交换机发现会话为止。在使用第四层交换的情况下,接入可以与真正的服务器连接在一起来满足用户制定的规则,诸如使每台服务器上有相等数量的接入或根据不同服务器的容量来分配传输流。

    如何选择第三层交换机

    目前,第三层交换机呈现出较强的增长趋势,正在局域网中取代路由器,其巨大的市场潜力正在吸引着大批国内外厂商加入角逐。可喜的是国内厂商在关键技术方面已经开发出了自已的ASIC芯片和网管软件,从而为用户在品牌的选择上提供了广阔的空间。目前,国内市场主要厂商有Cisco、3Com、安奈特、Extreme、Fountry、Avaya、Nortel、Entersys、D-Link、SVA、神州数码网络、华为、同方网络、清华比威和TCL等。面对如此丰富多彩的品牌,用户在选择时要从哪些方面入手是必须解决的问题。

    对于第三层交换机的选择,由于不同用户的网络结构和应用都会有所不同,所以在选择第三层交换机的侧重点也就有所不同。但对于用户而言,一般要注意如下几方面。

    1.注重满配置时的吞吐量 与任何电子产品一样,选择第三层交换机时,首先要分析各种产品的性能指标,然而面对诸如交换容量(Gbps)、背板带宽(Gbps)、处理能力(Mpps)、吞吐量(Mpps)等众多技术指标,您最好还是紧紧抓住“满配置时的吞吐量”这个指标,因为其他技术指标用户一般没有能力进行测量,惟有吞吐量是用户可以使用Smart Bits和IXIA等测试仪表直接测量和验证的指标。

    2.分布式优于集中式 不同品牌的交换机所采用的交换机技术也不同,主要可分为集中式和分布式两类。传统总线式交换结构模块是集中式,现代交换矩阵模块是分布式。由于企业内联网中运行的音频、视频及数据信息量越来越大,使之对交换机处理能力的要求也越来越高,为了实现在高端口密度条件下的高速无阻塞交换,采用分布式第三层交换机是明智的选择。因为总线式交换机模块在以太网环境下,仍然避免不了冲突,而矩阵式恰恰避免了端口交换时的冲突现象。

    3.关注延时与延时抖动指标 企业内联网几乎都是高速局域网,其目的之一就是为了音频和视频等大容量多媒体数据的传输,而这些大容量多媒体数据包最忌因延时较长和数据包丢失使信息传输产生抖动。有些传统集中式交换机的延时高达2ms,而某些现代分布式交换机的延时只有10ms左右,两者相差上百倍。而导致延时过高的原因通常包括阻塞设计的交换结构和过量使用缓冲等,所以,关注延时实际上需要关注产品的模块结构。

    4.性能稳定 第三层交换机多用于骨干和汇聚层,如果性能不稳定,则会波及网络系统的大部分主机,甚至整个网络系统。所以,只有性能稳定的第三层交换机才是网络系统连续、可靠、安全和正常运行的保证。当然,性能稳定看似抽象,似乎需要历史检测才能有说服力。其实不然,由于设备性能实际上是通过多项基本技术指标和市场声誉来实现的。所以,您可以通过吞吐量、延迟、丢帧率、地址表深度、线端阻塞和多对一功能等多项指标以及市场应用调查来确定。

    5.安全可靠 作为网络核心设备的第三层交换机,自然是黑客攻击的重要对象,这就要求必须将第三层交换机纳入网络安全防护的范围。当然,这里所说的“安全可靠”,应该包括第三层交换机的软件和硬件。所以,从“安全”上讲,配备支持性能优良、没有安全漏洞防火墙功能的第三层交换机是非常必要的。从“可靠”上看,因客观上任何产品都不能保证其不发生故障,而发生故障时能否迅速切换到一个好设备上是需要关心的问题。另外,在硬件上要考虑冗余能力,如电源、管理模块和端口等重要部件是否支持冗余,这对诸如电信、金融等对安全可靠性要求高的用户尤其重要。还有就是散热方式,如散热风扇等设置是否合理等。最后,对宽带运营商来说,认证功能也是考察的重要方面。以前交换机是给企业用的,上了网就直接连出去了,不需要认证。而宽带运营商则需要确认用户是否记录在案。用户访问Internet时出现了一个窗口,输入用户名和密码才能通过认证,所以宽带运营商的第三层交换机还应支持一些特殊的协议如802.1x等,以实现认证。

    6.功能齐全 产品不但要满足现有需求,还应满足未来一段时间内的需求,从而给用户一个增值空间。如当公司员工增加时,可以插上模块来扩充而不必淘汰原有设备。还有一些功能,如组播、QoS、端口干路(Port Trunking)、802.1d跨越树(Spanning Tree)以及是否支持RIP、OSPF等路由协议,对第三层交换机来说都是十分重要的。以组播为例,在VOD应用中,如果一组用户同时点播一个节目,用组播协议可以保证交换机在高密度视频流点播时非常顺畅地进行数据处理,反之,如果交换机不支持组播协议,则占用的带宽就相当大。再如QoS功能可以根据用户不同需求将其划分为不同等级,可以使宽带运营商按端口流量计费,从而为不同用户提供不同服务。另外,访问列表功能。如果在接入层划分VLAN,则不同VLAN用户间是不能通讯的,因为这是基于第二层的VLAN。若想通讯,必须通过第三层。如企业的财务部与市场部,一般都不来往,若有用户需要访问,则网管人员可以通过第三层交换机进行一个简单命令行设置,使VLAN间正常通讯,这就是访问列表功能。它是从路由器移植到第三层交换机上的一个功能,可以实现不同VLAN间的单向或双向通讯。如果发现外部某IP地址总发送无用数据包到自己网络上,则可以在访问列表中设置,禁止其发送数据包。

    展开全文
  • 三层交换机vlan连接

    2020-05-20 12:03:52
    三层路由器交换机vlan连接 四台pc机分在两台交换机下 pc4,pc6在vlan10下且在一个网段 192.168.1.0 网段下,网关为192.168.1.254 pc5,pc7在vlan20下且在一个网段 192.168.2.0 网段下,网关为192.168.2.254 首先,...

    三层交换机 vlan 连接

    四台pc机分在两台交换机下
    pc4,pc6在vlan10下且在一个网段 192.168.1.0 网段下,网关为192.168.1.254
    pc5,pc7在vlan20下且在一个网段 192.168.2.0 网段下,网关为192.168.2.254

    在这里插入图片描述

    首先,配置各个pc机ip,接着配置两台交换机。
    交换机下先进入conf模式,
    接着输入vlan 10 创建vlan10,输入vlan20,创建vlan20
    在这里插入图片描述
    在这里插入图片描述
    将vlan 10,和vlan 20绑定在接口f0/1和f0/2上。
    在这里插入图片描述
    在交换机上进入f0/1,interface f0/1,绑定vlan 10
    在这里插入图片描述
    同理,进入f0/2,绑定f0/20
    进入f0/3,因为f0/3与另一台交换机相连,所以进入,开启turnk口
    在这里插入图片描述
    f0/4与三层交换机相连,进入f0/4,开启turnk口
    (以太网端口二种链路类型:Access 和Trunk。
    Access 类型的端口:只能属于1 个VLAN,一般用于连接计算机的端口;
    Trunk 类型的端口:可以允许多个VLAN 通过,可以接收和发送多个VLAN 的报文,一般用于交换机之间连接的端口;)
    交换机2也是如此

    配置完成后,此时vlan内就可以互相ping通了但同一个交换机底下却不能互通。这需要配置三层交换机。
    先创建vlan10,20,进入vlan 10,设置ip,使vlan10口成为1.0网关.
    在这里插入图片描述
    在这里插入图片描述
    同理,设置vlan20的IP,成为2.0网关
    设置真实接口f0/1,然后开启trunk口
    在这里插入图片描述
    这样,三层交换机也配好了,可以跨vlan连接了

    展开全文
  • 三层交换机S1的配置: 二层交换机S2的配置: 二层交换机S3的配置: “ip routing”配置命令开启三层交换机的IP路由; VLAN能将不同网段的广播隔离开; 二层交换机无法实现不同VLAN间的路由功能; 三层交换机的...

    目录

    三层交换机S1的配置:

    二层交换机S2的配置:

    二层交换机S3的配置:


    1. “ip routing”配置命令开启三层交换机的IP路由;
    2. VLAN能将不同网段的广播隔离开;
    3. 二层交换机无法实现不同VLAN间的路由功能;
    4. 三层交换机的功能 = 二层交换机的功能 + 路由器的功能;
    5. 在VLAN端口配置IP,将GW指向相应VLAN的SVI地址可实现不同VLAN间的通信。
    6. 交换虚拟端口(SVI, Switch Virtual Interface):虚拟的路由器与每个VLAN进行连接的端口。 

    三层交换机S1的配置:

    //配置三层接口之前,首先创建VLAN及端口分配
    S1(config)#VLAN 2 //创建vlan2
    S1(config-vlan)#exit
    
    S1(config)#interface fa0/1 //进入端口配置模式
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface fa0/2
    S1(config-if)#switchport trunk encapsulation dot1q //配置Trunk封装为802.1q协议
    S1(config-if)#switchport mode trunk //设置为主干道trunk模式
    
    S1(config)#interface vlan 1 
    S1(config-if)#ip address 192.168.1.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口 
    
    S1(config)#interface vlan 2
    S1(config-if)#ip address 192.168.2.1 255.255.255.0 //在VLAN端口配置网关IP地址
    S1(config-if)#no shutdown //开启端口
    S1(config-if)#exit
    
    S1(config)#ip routing //开启三层交换机的IP路由功能

    二层交换机S2的配置:

    S2(config)#vlan 2 //在全局配置模式下创建VLAN
    S2(config-vlan)#exit
    
    S2(config)#interface fa0/1 //进入端口配置模式
    S2(config-if)#switchport mode trunk //端口配置为Trunk模式用来进行交换机互联,可允许多个VLAN通信
    
    S2(config-if)#interface fa0/2 //进入端口配置模式
    S2(config-if)#switchport access vlan 1 //将端口分配到vlan 1
    
    S2(config-if)#interface fa0/3
    S2(config-if)#switchport access vlan 2 //将交换机端口分配到vlan2

    二层交换机S3的配置:

    S3(config)#vlan 2
    S3(config-vlan)#exit
    
    S3(config)#interface fa0/1
    S3(config-if)#switchport mode trunk
    
    S3(config-if)#interface fa0/2
    S3(config-if)#switchport access vlan 2
    
    S3(config-if)#interface fa0/3
    S3(config-if)#switchport access vlan 1

     

    展开全文
  • 二层交换机:二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。...三层交换机: 三层交换...

     二层交换机:二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。

    具体如下:

    (1)当交换机从某个端口收到一个数据包,它先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上;

    (2)再去读取包头中的目的MAC地址,并在地址表中查找相应的端口;

    (3)如表中有与这目的MAC地址对应的端口,把数据包直接复制到这端口上。

            三层交换机: 三层交换技术就是将路由技术与交换技术合二为一的技术。在对第一个数据流进行路由后,它将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。

             路由器:传统地,路由器工作于OSI七层协议中的第三层,其主要任务是接收来自一个网络接口的数据包,根据其中所含的目的地址,决定转发到下一个目的地址。因此,路由器首先得在转发路由表中查找它的目的地址,若找到了目的地址,就在数据包的帧格前添加下一个MAC地址,同时IP数据包头的TTL(Time To Live)域也开始减数,并重新计算校验和。当数据包被送到输出端口时,它需要按顺序等待,以便被传送到输出链路上。

             路由器在工作时能够按照某种路由通信协议查找设备中的路由表。如果到某一特定节点有一条以上的路径,则基本预先确定的路由准则是选择最优(或最经济)的传输路径。由于各种网络段和其相互连接情况可能会因环境变化而变化,因此路由情况的信息一般也按所使用的路由信息协议的规定而定时更新。

             主要区别:二层交换机工作在数据链路层,三层交换机工作在网络层,路由器工作在网络层。

             具体区别如下:

             二层交换机和三层交换机的区别:

             三层交换机使用了三层交换技术

             简单地说,三层交换技术就是:二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。

            什么是三层交换

            三层交换(也称多层交换技术,或IP交换技术)是相对于传统交换概念而提出的。众所周知,传统的交换技术是在OSI网络标准模型中的第二层——数据链路层进行*作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发。简单地说,三层交换技术就是:二层交换技术+三层转发技术。

             三层交换技术的出现,解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。

             其原理是:假设两个使用IP协议的站点A、B通过第三层交换机进行通信,发送站点A在开始发送时,把自己的IP地址与B站的IP地址比较,判断B站是否与自己在同一子网内。若目的站B与发送站A在同一子网内,则进行二层的转发。若两个站点不在同一子网内,如发送站A要与目的站B通信,发送站A要向“缺省网关”发出ARP(地址解析)封包,而“缺省网关”的IP地址其实是三层交换机的三层交换模块。当发送站A对“缺省网关”的IP地址广播出一个ARP请求时,如果三层交换模块在以前的通信过程中已经知道B站的MAC地址,则向发送站A回复B的MAC地址。否则三层交换模块根据路由信息向B站广播一个ARP请求,B站得到此ARP请求后向三层交换模块回复其MAC地址,三层交换模块保存此地址并回复给发送站A,同时将B站的MAC地址发送到二层交换引擎的MAC地址表中。从这以后,当A向B发送的数据包便全部交给二层交换处理,信息得以高速交换。由于仅仅在路由过程中才需要三层处理,绝大部分数据都通过二层交换转发,因此三层交换机的速度很快,接近二层交换机的速度,同时比相同路由器的价格低很多。

             第二层交换机和路由器的区别:

            传统交换机从网桥发展而来,属于OSI第二层即数据链路层设备。它根据MAC地址寻址,通过站表选择路由,站表的建立和维护由交换机自动进行。路由器属于OSI第三层即网络层设备,它根据IP地址进行寻址,通过路由表路由协议产生。交换机最大的好处是快速,由于交换机只须识别帧中MAC地址,直接根据MAC地址产生选择转发端口算法简单,便于ASIC实现,因此转发速度极高。但交换机的工作机制也带来一些问题。

             1.回路:根据交换机地址学习和站表建立算法,交换机之间不允许存在回路。一旦存在回路,必须启动生成树算法,阻塞掉产生回路的端口。而路由器的路由协议没有这个问题,路由器之间可以有多条通路来平衡负载,提高可靠性。

             2.负载集中:交换机之间只能有一条通路,使得信息集中在一条通信链路上,不能进行动态分配,以平衡负载。而路由器的路由协议算法可以避免这一点,OSPF路由协议算法不但能产生多条路由,而且能为不同的网络应用选择各自不同的最佳路由。

             3.广播控制:交换机只能缩小冲突域,而不能缩小广播域。整个交换式网络就是一个大的广播域,广播报文散到整个交换式网络。而路由器可以隔离广播域,广播报文不能通过路由器继续进行广播。

             4.子网划分:交换机只能识别MAC地址。MAC地址是物理地址,而且采用平坦的地址结构,因此不能根据MAC地址来划分子网。而路由器识别IP地址,IP地址由网络管理员分配,是逻辑地址且IP地址具有层次结构,被划分成网络号和主机号,可以非常方便地用于划分子网,路由器的主要功能就是用于连接不同的网络。

             5.保密问题:虽说交换机也可以根据帧的源MAC地址、目的MAC地址和其他帧中内容对帧实施过滤,但路由器根据报文的源IP地址、目的IP地址、TCP端口地址等内容对报文实施过滤,更加直观方便。

             6.介质相关:交换机作为桥接设备也能完成不同链路层和物理层之间的转换,但这种转换过程比较复杂,不适合ASIC实现,势必降低交换机的转发速度。因此目前交换机主要完成相同或相似物理介质和链路协议的网络互连,而不会用来在物理介质和链路层协议相差甚元的网络之间进行互连。而路由器则不同,它主要用于不同网络之间互连,因此能连接不同物理介质、链路层协议和网络层协议的网络。路由器在功能上虽然占据了优势,但价格昂贵,报文转发速度低。近几年,交换机为提高性能做了许多改进,其中最突出的改进是虚拟网络和三层交换。

             划分子网可以缩小广播域,减少广播风暴对网络的影响。路由器每一接口连接一个子网,广播报文不能经过路由器广播出去,连接在路由器不同接口的子网属于不同子网,子网范围由路由器物理划分。对交换机而言,每一个端口对应一个网段,由于子网由若干网段构成,通过对交换机端口的组合,可以逻辑划分子网。广播报文只能在子网内广播,不能扩散到别的子网内,通过合理划分逻辑子网,达到控制广播的目的。由于逻辑子网由交换机端口任意组合,没有物理上的相关性,因此称为虚拟子网,或叫虚拟网。虚拟网技术不用路由器就解决了广播报文的隔离问题,且虚拟网内网段与其物理位置无关,即相邻网段可以属于不同虚拟网,而相隔甚远的两个网段可能属于不同虚拟网,而相隔甚远的两个网段可能属于同一个虚拟网。不同虚拟网内的终端之间不能相互通信,增强了对网络内数据的访问控制。

             第三层交换机和路由器的区别:

             在第三层交换技术出现之前,几乎没有必要将路由功能器件和路由器区别开来,他们完全是相同的:提供路由功能正在路由器的工作,然而,现在第三层交换机完全能够执行传统路由器的大多数功能。作为网络互连的设备,第三层交换机具有以下特征:
             1.转发基于第三层地址的业务流;

             2.完全交换功能;

             3.可以完成特殊服务,如报文过滤或认证;

             4.执行或不执行路由处理。

             第三层交换机与传统路由器相比有如下优点:

             1.子网间传输带宽可任意分配:传统路由器每个接口连接一个子网,子网通过路由器进行传输的速率被接口的带宽所限制。而三层交换机则不同,它可以把多个端口定义成一个虚拟网,把多个端口组成的虚拟网作为虚拟网接口,该虚拟网内信息可通过组成虚拟网的端口送给三层交换机,由于端口数可任意指定,子网间传输带宽没有限制。

             2.合理配置信息资源:由于访问子网内资源速率和访问全局网中资源速率没有区别,子网设置单独服务器的意义不大,通过在全局网中设置服务器群不仅节省费用,更可以合理配置信息资源。

             3.降低成本:通常的网络设计用交换机构成子网,用路由器进行子网间互连。目前采用三层交换机进行网络设计,既可以进行任意虚拟子网划分,又可以通过交换机三层路由功能完成子网间通信,为此节省了价格昂贵的路由器。

             4.交换机之间连接灵活:作为交换机,它们之间不允许存在回路,作为路由器,又可有多条通路来提高可靠性、平衡负载。三层交换机用生成树算法阻塞造成回路的端口,但进行路由选择时,依然把阻塞掉的通路作为可选路径参与路由选择。

             交换机和路由器是性能和功能的矛盾体,交换机交换速度快,但控制功能弱,路由器控制性能强,但报文转发速度慢。解决这个矛盾的最新技术是三层交换,既有交换机线速转发报文能力,又有路由器良好的控制功能。
     
     
     
     
    一、三层交换机与路由器的主要区别 之所以有人搞不清三层交换机和路由器之间的区别,最根本就是三层交换机也具有“路由”功能,与传统路由器的路由功能总体上是一致的。虽然如此,三层交换机与路由器还是存在着相当大的本质区别的,下面分别予以介绍。1. 主要功能不同 虽然三层交换机与路由器都具有路由功能,但我们不能因此而把它们等同起来,正如现在许多网络设备同时具备多种传统网络设备功能一样,就如现在有许多宽带路由器不仅具有路由功能,还提供了交换机端口、硬件防火墙功能,但不能把它与交换机或者防火墙等同起来一样。因为这些路由器的主要功能还是路由功能,其它功能只不过是其附加功能,其目的是使设备适用面更广、使其更加实用。这里的三层交换机也一样,它仍是交换机产品,只不过它是具备了一些基本的路由功能的交换机,它的主要功能仍是数据交换。也就是说它同时具备了数据交换和路由 由发两种功能,但其主要功能还是数据交换;而路由器仅具有路由转发这一种主要功能。2. 主要适用的环境不一样三层交换机的路由功能通常比较简单,因为它所面对的主要是简单的局域网连接。正因如此,三层交换机的路由功能通常比较简单,路由路径远没有路由器那么复杂。它用在局域网中的主要用途还是提供快速数据交换功能,满足局域网数据交换频繁的应用特点。 而路由器则不同,它的设计初哀就是为了满足不同类型的网络连接,虽然也适用于局域网之间的连接,但它的路由功能更多的体现在不同类型网络之间的互联上,如局域网与广域网之间的连接、不同协议的网络之间的连接等,所以路由器主要是用于不同类型的网络之间。它最主要的功能就是路由转发,解决好各种复杂路由路径网络的连接就是它的最终目的,所以路由器的路由功能通常非常强大,不仅适用于同种协议的局域网间,更适用于不同协议的局域网与广域网间。它的优势在于选择最佳路由、负荷分担、链路备份及和其他网络进行路由信息的交换等等路由器所具有功能。为了与各种类型的网缌?樱?酚善鞯慕涌诶嘈头浅7岣唬???憬换换?蛞话憬鐾?嘈偷木钟蛲?涌冢?浅<虻ァ?3. 性能体现不一样 从技术上讲,路由器和三层交换机在数据包交换操作上存在着明显区别。路由器一般由基于微处理器的软件路由引擎执行数据包交换,而三层交换机通过硬件执行数据包交换。三层交换机在对第一个数据流进行路由后,它将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。同时,三层交换机的路由查找是针对数据流的,它利用缓存技术,很容易利用ASIC技术来实现,因此,可以大大节约成本,并实现快速转发。而路由器的转发采用最长匹配的方式,实现复杂,通常使用软件来实现,转发效率较低。 正因如此,从整体性能上比较的话,三层交换机的性能要远优于路由器,非常适用于数据交换频繁的局域网中;而路由器虽然路由功能非常强大,但它的数据包转发效率远低于三层交换机,更适合于数据交换不是很频繁的不同类型网络的互联,如局域网与互联网的互联。如果把路由器,特别是高档路由器用于局域网中,则在相当大程度上是一种浪费(就其强大的路由功能而言),而且还不能很好地满足局域网通信性能需求,影响子网间的正常通信。 综上所述,三层交换机与路由器之间还是存在着非常大的本质区别的。无论从哪方面来说,在局域网中进行多子网连接,最好还选用三层交换机,特别是在不同子网数据交换频繁的环境中。一方面可以确保子网间的通信性能需求,另一方面省去了另外购买交换机的投资。当然,如果子网间的通信不是很频繁,采用路由器也无可厚非,也可达到子网安全隔离相互通信的目的。具体要根据实际需求来定
     
     
         三层交换机的最重要的目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由
    ,多次转发。对于数据包转发等规律性的过程由硬件高速实现,而像路由信息更新、路由表维护、路由计算、路由
    确定等功能,由软件实现。
          出于安全和管理方便的考虑,主要是为了减小广播风暴的危害,必须把大型局域网按功能或地域等因素化成一个个小的
    局域网,这就使得VLAN技术在网络中得到大量应用,而不同VLAN之间的通信都要经过路由器来完成转发,
    随着网间互访的不断增加。单纯使用路由器来实现网间访问,不但由于端口数量有限,而且路由速度较慢。从而
    限制了网络的规模和访问速度。基于这种情况三层交换机便应用而生。三层交换机是为IP设计的,接口类型简单;
    拥有很强二层包处理能力,非常适合用于大型局域网内的数据路由与交换,它既可以工作在协议第三层替代或是部分完成
    传统路由器的功能,同时又具有几乎第二层交换的速度,且价格相对便宜。
           三层交换机出现最重要的目的是加快大型局域网内部的数据交换,所具有的路由功能也多是围绕这个目的而展开的,所以它的
    路由功能没有同一档次的专业路由器强。毕竟在安全、协议支持等方面还有许多欠缺,并不能完全取代路由器的工作。
           在实际中的典型用法是:处于同一个局域网中的各个子网的互联以及局域网中VLAN间的路由,用三层交换机来代替路由。
    而只有局域网与公网互联之间要实现跨地域的网络访问,才通过专业路由器。
         从表面上看,第三层交换机是第二层交换器与路由器的合二为一,然而这种结合并非简单的物理结合,而是各取所长的逻辑
    结合。其重要表现是,当某一信息源的第一个数据流进行第三层交换后,其中的路由系统会产生一个MAC地址与IP地址的映射表,
    并将该表存储起来,当同一信息源的后续数据流再次进入交换环境时,交换机将根据第一次产生并保存的地址映射表,直接从第二层
    由源地址传输到目的地址,不再经过第三路由系统处理,从而消除路由选择的网络延迟。
     

     

    展开全文
  • 华为三层交换机相关配置

    千次阅读 2019-01-10 10:38:11
     三层交换机可以进行网页管理, 前提是 HTTP 服务要开启,且交换机 Flash 里有 web 管理文件并被成功加载。 上一步进行了 FTP 服务器配置,如果交换机里没有 ZIP 后缀名的 WEB 管理文件,就需要先用 FTP 把 WEB ...
  • 讲述三层交换机的路由连接方法

    千次阅读 2014-03-14 16:21:28
    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要许多的,而且三层交换机只能使用一个网络。 而且通常只是局域网子网之间的互联...
  • 三层交换机与路由器区别

    千次阅读 2019-01-27 15:15:34
    1、原理上:三层交换机为同源同目的ip的数据包进行一次路由,后续则进行二层交换处理,判断依据为数据包的mac,vlan-id,ip,来源端口;路由器则对每个数据包进行三层路由选择,转发效率较低。 2、应用上:三层...
  • 二层交换机与三层交换机区别详解! 我们习惯说,在二层网络环境中相同vlan之间可以通信,不同vlan之间不可以通信,如果想通信必须借助三层设备,所以说三层交换机必须要做的事情是路由转发,但是二、三层交换机具体...
  • 为什么三层交换机无法替代路由器? 一、总结 一句话总结: 路由器在核心网络里,一般都充当着出口和核心转发这一块,接入层和汇聚层基本上都被三层交换机所取代了 二、为什么三层交换机无法替代路由器 ...
  • 但随着网络应用程序多样性的增加以及融合网络应用的发展,三层交换机的应用在数据中心,复杂的企业网络,商业应用乃至高级客户项目中蓬勃发展。那么,二层与三层交换机之间有什么区别呢?飞速(FS)本文将为您详述。 ...
  • 二层交换机、三层交换机和路由器的原理及区别

    万次阅读 多人点赞 2012-12-04 15:45:19
    层交换机:  二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。 具体如下: (1)...
  • 层交换机:  二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。 具体如下: (1)...
  • 二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。具体如下: 1.当交换机从某个端口收到...
  • 二层交换机工作于OSI模型的第2层(数据链路层),故而称为二层交换机。二层交换技术的发展已经比较成熟,二层交换机属数据链...三层交换机就是具有部分路由器功能的交换机,三层交换机的最重要目的是加快大型局域网...
  • 层交换机:  二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。 具体如下: (1)...
  • <!DOCTYPE ... 二层交换机:二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录
  • 二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。 具体如下: (1)当交换机从某个...
  • 三层交换机连接路由器

    千次阅读 2015-02-26 15:35:49
    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要许多的,而且三层交换机只能使用一个网络。 而且通常只是局域网子网之间的互联...
  • 【科普杂谈】三层交换机 标签(空格分隔): 【科普杂谈】 二层交换机: 二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与...
  • 三层交换机工作原理

    2011-06-23 08:39:18
    三层交换机工作原理 三层的涵义  三层交换机中的“三层”指的是OSI(开放系统互连)七层参考模型的下面三层。如果您想理解三层交换,首先就需要理解OSI参考模型。  1、什么是OSI参考模型  OSI...
  •  二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。 具体如下: (1)当交换机从...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,917
精华内容 1,966
关键字:

弱三层交换机