精华内容
下载资源
问答
  • [h3c] undo info-center enable 关闭 [h3c] info-center enable 开启 执行命令 terminal monitor 使能终端显示信息中心发送信息的功能;需注意:重新连接的时候默认是开启的 执行 undo info-c
    在做华三或者华为的配置的时候,经常会遇到设备出现一些告警信息,很是影响操作:两种方法
    
    <h3c> undo terminal monitor		关闭
    <h3c> terminal monitor			开启
    

    或者

    [h3c] undo info-center enable	关闭
    [h3c] info-center enable 		开启
    

    执行命令 terminal monitor 使能终端显示信息中心发送信息的功能;此命令只影响输入命令的当前终端。

    执行 undo terminal monitor 取消显示功能时,相当于执行 undo terminal debugging,undo terminal logging,undo terminal trapping 命令,所有的 Debug/Log/Trap 信息在本终端都不显示。

    执行 undo info-center enable 命令行后,设备上产生的Log、Trap和Debug信息都不再记录,包括执行 undo info-center enable 命令产生的日志信息也不记录。

    展开全文
  • h3c交换机命令提示

    2011-05-12 19:05:47
    五十多分千千万让人为热舞我额外额外 违反为绯闻而无法额外额外
  • 本文实例讲述了jquery+css3实现的弹出层效果。分享给大家供大家参考,具体如下: 可能出现的情况 1)一列都有,按顺序弹出对应的弹出层 2)只有单个一个弹出3)不按顺序不按规律随机弹出层 jquery 弹出层 解决 第...
  • 网络虚拟化技术(二) H3C IRF

    万次阅读 2018-05-02 22:29:11
    上一期整理了一下Cisco的VSS技术,这一期整理了一下H3C IRF技术。H3C IRF技术目前由IRF1、 IRF2 已经发展到了IRF3。有什么区别?看下图。IRF2其实就是修复并增强了IRF1的一些问题和功能。IRF3,是除了可以实现横向...

    前言

    欢迎关注驴哥公众号,认真看驴哥文章。

    上一期整理了一下Cisco的VSS技术,这一期整理了一下H3C IRF技术。H3C IRF技术目前由IRF1、 IRF2 已经发展到了IRF3。有什么区别?看下图。


    IRF2其实就是修复并增强了IRF1的一些问题和功能。IRF3,是除了可以实现横向设备虚拟化(例如两台核心设备),还可以实现纵向设备虚拟化(例如两台核心设备与20台接入设备)。再通俗一点,就是可以将核心设备与接入设备一起进行虚拟化,形成一个大二层网络。厉害不厉害?厉害极了!敢用不敢用?得考虑考虑。


    概念

    1.IRF(Intelligent Resilient Framework,智能弹性架构):将多台设备通过IRF物理端口互联,虚拟成一台设备。

    2.IRF角色:Master/Slave Master管理IRF,Slave作为Master设备的备份和扩展。

    3.IRF端口:用于IRF成员互联的逻辑接口,分为IRF-Port1和IRF-Port2,需要和物理端口绑定才能生效。

    4.IRF物理端口:用于IRF成员设备互联的物理端口,需要与IRF绑定才能生效。

    5.IRF合并:两个物理机箱最终虚拟为一台IRF逻辑设备的过程叫IRF合并。

    6.IRF分裂:因为故障,IRF系统分裂为两个IRF的过程叫IRF分裂。

    优势

    1.统一管理,登录IRF任意成员设备均可以管理IRF系统。(Cisco VSS 只能登录Active设备进行管理)

    2.高可靠性,IRF域内Master/Slave设备形成1:N备份。(Csico VSS只能支持两台设备虚拟化,H3C IRF最少可以支持4台设备虚拟化)

    3.可扩展性,网络从端口数量、带宽等层面得到扩展。(核心技术是网络扩展性,Cisco 6500系列带宽可以扩展至1.4T,H3C IRF母鸡)。

    IRF工作原理

    1.IRF互联

    (1)物理连接:IRF物理端口一般为万兆SFP+模块或者SFP+电缆。具体情况得参考具体设备型号。万兆SFP+模块适用于远距离连接,根据采用模块不同,最大传输距离可达10KM(Cisco VSS 互联最大传输距离可达40KM)。SFP+电缆(H3C堆叠线缆)一般传输在10m以内,适用于在机房内短距互联。

    (2) 连接要求:IRF物理端口需要与IRF虚拟端口绑定起来,一个IRF虚拟端口下最多可以绑定4个IRF物理端口。两台设备互联,设备一的IRF虚拟端口IRF-port1只能与设备二的IRF虚拟端口IRF-port2互联,反之亦然。

    (3) 连接拓扑:链形连接、环形连接。

    2.拓扑收集

    IRF成员设备之间通过IRF Hello报文进行拓扑收集,IRF Hello报文携带 IRF端口连接关系、成员设备编号、成员设备优先级、成员设备的桥MAC等内容。IRF Hello报文周期性的由UP的IRF端口发送给邻居。经过一段时间,所有成员都会收集到完整的拓扑信息。(拓扑收敛)

    3.角色选举

    现有Master设备,在无故障情况下不会因为IRF成员的加入或者离开而发生角色变化。选举优先级如下:

    成员优先级大的优先>系统运行时间长的优先>桥MAC地址小的优先

    竞选失败一方会自动重启,然后会以Slave的角色,使用Master的配置重新初始化启动。

    IRF维护管理

    1.成员编号:成员加入IRF前统一进行编号,编号命令irf member 1 renumber 2

    2.接口命名:irf member 1接口:g1/0/1  irf member 2接口:g2/0/1

    3.IRF多活冲突检测MAD:检测手段包括LACP(链路聚合控制协议)、IP BFD(双向转发检测)、GARP (ARP检测)。

    当检测出IRF分裂后,将会保留成员编号最小的Master设备,其他设备均处于Recovery状态,关闭除IRF端口外的其他端口,保证其他IRF成员设备不再进行业务转发。

    4.IRF故障恢复:修复IRF故障链路、修复IRF故障设备。

    IRF配置

    1.官方配置流程

    2.配置步骤


    irf domain 10  

     /配置irf domian ID,默认为0/

    irf member 1 renumber 2 

     /配置irf member ID,默认是1/

    interface T1/0/49

    shutdown

    interface T1/0/50

    shutdown

    /shutdown掉irf物理接口,因为要与irf虚拟接口绑定前,物理接口必须是shutdown状态/

    irf-port 1/1 (Device A 虚拟接口)

    irf-port 2/2 (Device B 虚拟接口)

    /配置IRF虚拟接口,A设备与B设备IRF虚拟接口名称不能相同,一台为1,另一台为2/

    port group interface T1/0/49

    port group interface T1/0/50

    /将物理接口与虚拟接口进行绑定/

    interface T1/0/49

    undo shutdown

    interface T1/0/50

    undo shutdown

    /启用irf物理接口/

    save

    /非常重要!!!保存当前配置/

    irf-port-configuration active

    /激活irf端口下配置,配置完此命令后,设备会进行master/slave选举,选举失败一方会重启/

    #其他辅助配置命令#

    irf member 2 description AA-BB 

    /为IRF成员设备进行描述/

    irf-port load-sharing mode 

    /配置irf端口负载分担模式/


    3.MAD配置

    LACP MAD:LACP协议报文中携带Active ID,设备正常运行,所有LACP报文中,Active ID相同,IRF分裂时,Active ID不同。 LACP MAD检测方式需要支持LACP协议的中间设备,能够配置聚合接口分别于IRF成员互联。

    interface bridge-aggregation 20

    link-aggregation mode dynamic 

    /配置聚合接口,并将聚合接口模式设置为dynamic,默认为static/

    mad enable

    /启用MAD检测/

    interface g1/0/2

    port link-aggregation group 20

    interface g2/0/2

    port link-aggregation group 20

    /分别选择IRF成员的一个接口,并将其加入聚合接口中/

    剩下的工作是要把Device C与 A、B互联接口配置为聚合接口就可以了。


    BFD MAD:在IRF中启用一个三层接口,因为这个三层接口属于每一个IRF成员,所以有几个IRF成员就要为这个三层接口配置几个IP地址。正常情况下,只有Master 上的MAD IP生效,其余Slave的MAD IP均不生效,BFD会话处于Down的状态。当IRF分裂,存在多个Master设备,则多个MAD IP生效,BFD会话被激活,则IRF分裂就会被检测到。BFD MAD组网模式中,所有IRF成员需要全互联。所以如果仅有两台设备,则无需使用中间设备,如果多台设备,还是建议使用中间设备实现全互联接口比较方便。(辣鸡)

    vlan 50

    port g1/0/3 port g2/0/3

    \创建一个VLAN 50,并将两台设备用于BFD MAD物理接口加入到VLAN 50中\

    interface vlan 50

    mad bfd enable

    mad ip address 1.1.1.1 24 member 1

    mad ip address 1.1.1.2 24 member 2

    \启用三层接口,并为每个IRF成员配置IP地址,注意IP地址必须为同一网段\

    interface g1/0/3

    undo stp enable

    interface g2/0/3

    undo stp enable

    \BFD MAD与 STP互斥,所以要将BFD MAD物理接口shutdown\(辣鸡again)


    ARP MAD:ARP MAD 是使用free ARP报文携带 Active ID值,IRF正常运行时,MSTP阻塞一条链路,ARP报文无法到达其他设备。当IRF分裂,STP重新计算,原阻塞端口被打开,另一台设备就可以接受到ARP报文,完成分裂检测。

    stp enable

    \在IRF中使能STP\

    undo irf mac-address persistent

    \取消 MAC地址保持功能,因为要快速检测出IRF分裂,就要将ARP快速老化\

    vlan 20

    port g1/0/2 port g2/0/2

    \创建VLAN 20,将与中间设备互联的物理接口加入到VLAN 20中\

    interface vlan-interface 20

    ip address 1.1.1.1 24

    mad arp enable

    \为三层接口配置IP地址,并使能ARP MAD检测功能\

    中间设备配置

    vlan 20

    port g1/0/1 port g1/0/2

    \将中间设备与IRF互联接口划分到VLAN 20中即可,使IRF成员用于ARP MAD检测物理接口二层可达即可\ (辣鸡 aaagain,本来用虚拟化就是要消除STP,结果还要依赖STP)

    好了,上面就是IRF的一些总结和小小观点,欢迎给驴哥留言讨论。

    展开全文
  • 关于弹出消息窗口的自动关闭

    万次阅读 2016-07-14 11:50:35
    关于弹出消息窗口的自动关闭的两种方式


    1.方法1

    1.1. 直接在代码中添加

    // 弹出消息窗口自动关闭,需要指出的是,Windows 2000的user32.dll没有导出这个函数。
    extern "C"
    {
        int WINAPI MessageBoxTimeoutA(IN HWND hWnd, IN LPCSTR lpText, IN LPCSTR lpCaption, IN UINT uType, IN WORD wLanguageId, IN DWORD dwMilliseconds);
        int WINAPI MessageBoxTimeoutW(IN HWND hWnd, IN LPCWSTR lpText, IN LPCWSTR lpCaption, IN UINT uType, IN WORD wLanguageId, IN DWORD dwMilliseconds);
    };
    #ifdef UNICODE
    #define MessageBoxTimeout MessageBoxTimeoutW
    #else
    #define MessageBoxTimeout MessageBoxTimeoutA
    #endif

    1.2. 调用

        MessageBoxTimeout(this->GetSafeHwnd(), _T("弹出5秒后会自动关闭!这是一个模态对话框。"), _T("会自动关闭的MessageBox"),  MB_ICONINFORMATION, GetSystemDefaultLangID(), 5000);
        //参数说明:父窗口的句柄为NULL的情况下,将弹出非模态对话框;延时关闭的时间为0的情况下,弹出的MessageBox需要手动关闭
        MessageBoxTimeout(NULL, _T("弹出5秒后会自动关闭!这是一个非模态对话框。"), _T("会自动关闭的MessageBox"),  MB_ICONINFORMATION, GetSystemDefaultLangID(), 5000);


    参考网址:http://blog.sina.com.cn/s/blog_4b0f3b420100mglb.html


    win7 x86,vs2013,测试通过


    2.方法2


    2.1.此api是微软的一个未公开api,在user32.dll中,功能就是弹出一个对话框MessageBox,并定时自动退出。 
    下面为头文件,随便取个名字,我取的是MsgBoxTimeout.h 。

    #include <windows.h>
    #include <tchar.h>
    
    //Functions & other definitions required-->
    typedef int (__stdcall *MSGBOXAAPI)(IN HWND hWnd, 
            IN LPCSTR lpText, IN LPCSTR lpCaption, 
            IN UINT uType, IN WORD wLanguageId, IN DWORD dwMilliseconds);
    typedef int (__stdcall *MSGBOXWAPI)(IN HWND hWnd, 
            IN LPCWSTR lpText, IN LPCWSTR lpCaption, 
            IN UINT uType, IN WORD wLanguageId, IN DWORD dwMilliseconds);
    
    int MessageBoxTimeoutA(IN HWND hWnd, IN LPCSTR lpText, 
        IN LPCSTR lpCaption, IN UINT uType, 
        IN WORD wLanguageId, IN DWORD dwMilliseconds);
    int MessageBoxTimeoutW(IN HWND hWnd, IN LPCWSTR lpText, 
        IN LPCWSTR lpCaption, IN UINT uType, 
        IN WORD wLanguageId, IN DWORD dwMilliseconds);
    
    #ifdef UNICODE
        #define MessageBoxTimeout MessageBoxTimeoutW
    #else
        #define MessageBoxTimeout MessageBoxTimeoutA
    #endif 
    
    #define MB_TIMEDOUT 32000
    
    int MessageBoxTimeoutA(HWND hWnd, LPCSTR lpText, 
        LPCSTR lpCaption, UINT uType, WORD wLanguageId, 
        DWORD dwMilliseconds)
    {
        static MSGBOXAAPI MsgBoxTOA = NULL;
    
        if (!MsgBoxTOA)
        {
            HMODULE hUser32 = GetModuleHandle(_T("user32.dll"));
            if (hUser32)
            {
                MsgBoxTOA = (MSGBOXAAPI)GetProcAddress(hUser32, 
                                          "MessageBoxTimeoutA");
                //fall through to 'if (MsgBoxTOA)...'
            }
            else
            {
                //stuff happened, add code to handle it here 
                //(possibly just call MessageBox())
                return 0;
            }
        }
    
        if (MsgBoxTOA)
        {
            return MsgBoxTOA(hWnd, lpText, lpCaption, 
                  uType, wLanguageId, dwMilliseconds);
        }
    
        return 0;
    }
    
    int MessageBoxTimeoutW(HWND hWnd, LPCWSTR lpText, 
        LPCWSTR lpCaption, UINT uType, WORD wLanguageId, DWORD dwMilliseconds)
    {
        static MSGBOXWAPI MsgBoxTOW = NULL;
    
        if (!MsgBoxTOW)
        {
            HMODULE hUser32 = GetModuleHandle(_T("user32.dll"));
            if (hUser32)
            {
                MsgBoxTOW = (MSGBOXWAPI)GetProcAddress(hUser32, 
                                          "MessageBoxTimeoutW");
                //fall through to 'if (MsgBoxTOW)...'
            }
            else
            {
                //stuff happened, add code to handle it here 
                //(possibly just call MessageBox())
                return 0;
            }
        }
    
        if (MsgBoxTOW)
        {
            return MsgBoxTOW(hWnd, lpText, lpCaption, 
                   uType, wLanguageId, dwMilliseconds);
        }
    
        return 0;
    }
    //End required definitions <--

    2.2. 调用方式

    #include "MsgBoxTimeout.h"
    void CTestDlg::OnBnClickedButton2()
    {
        //you must load user32.dll before calling the function
        HMODULE hUser32 = LoadLibrary(_T("user32.dll"));
    
        if (hUser32)
        {
            int iRet = 0;
            UINT uiFlags = MB_OK | MB_SETFOREGROUND | MB_SYSTEMMODAL | MB_ICONINFORMATION;
    
            iRet = MessageBoxTimeout(NULL, _T("Test a timeout of 2 seconds."),
                _T("MessageBoxTimeout Test"), uiFlags, 0, 2000);
            //iRet will = 1
    
            uiFlags = MB_YESNO | MB_SETFOREGROUND | MB_SYSTEMMODAL | MB_ICONINFORMATION;
    
            iRet = MessageBoxTimeout(NULL, _T("Test a timeout of 5 seconds."),
                _T("MessageBoxTimeout Test"), uiFlags, 0, 5000);
            //iRet will = MB_TIMEDOUT if no buttons pressed, button values otherwise
    
            //only unload user32.dll when you have no further need 
            //for the MessageBoxTimeout function
            FreeLibrary(hUser32);
        }
    }


    参考网址:http://blog.csdn.net/a379039233/article/details/49445207

    展开全文
  • H3C模拟器---HCL使用心得

    万次阅读 2016-05-21 00:28:57
    H3C的模拟器出来也有两年了,被大家吐槽吃资源和长相丑陋,但是作为网络工程师或者H3C认证的学员又不得不使用它,可以说是“食之无味,弃之可惜”,非常的鸡肋。话不多说,今天博主来分享一下使用HCL的两个心得...

            H3C的模拟器出来也有两年了,被大家吐槽吃资源和长相丑陋,但是作为网络工程师或者H3C认证的学员又不得不使用它,可以说是“食之无味,弃之可惜”,非常的鸡肋。话不多说,今天博主来分享一下使用HCL的两个心得(目前只有两个,如果有新的发现会更新此文)。

            更改字体颜色

    1. 打开HCL的安装目录,默认路径为C:\Program Files (x86)\HCL\
    2. 双击打开putty.exe,在左侧找到Window下的Appearance,在右侧点击Change
      putty配置窗口
    3. 在弹出的对话框中选择你喜欢的字体,点击确定退出。
      字体配置窗口
    4. 在左侧Window下找到 Colors选项,勾选Use system colors
      更改颜色
    5. 在左侧点击Session,选择Default Settings,点击save
      保存配置
    6. 配置完成

            使用SecureCRT连接HCL

            事先声明,此方法为本人自己琢磨发现的,是一种临时的连接方法,每增加一台设备,就需要手工配置一次。

    1. 在HCL中添加一个设备,如路由器
      添加路由器
    2. 打开SecureCRT,新建会话,会话协议选择Serial
      新建会话
    3. Port选项选择Named Pipe,Name of pipe中填入\\.\pipe\topo1-device1
      配置管道
    4. 会话名称自拟,如:R1
      会话名称
    5. 点击完成,连接到路由器。

            要连接第二台设备,只需在新建会话中把\\.\pipe\topo1-device1的device1改成device2即可。

    展开全文
  • H3C模拟器安装

    千次阅读 2019-03-06 18:12:23
    华三云实验室(H3C Cloud Lab,简称HCL)是一款界面图形化的全真网络模拟软件,用户可以通过该软件实现H3C公司多个型号的虚拟设备的组网,是用户学习、测试基于H3C公司Comware V7平台的网络设备的必备工具。H3C ...
  • 安装HCL H3C Cloud Lab (HCL)时遇到的问题及解决办法汇总 安装HCL有感 遇到的问题汇总 1,see the logfile...for details 2,请检查Virtual Box API是否安装正确 解决方法 3,当前系统用户名中包含非ASCLL字符,...
  • IRF称之为智能弹性架构,是H3C自主研发的硬件虚拟化技术,它的核心思想是将多台设备通过IRF物理端口连接在一起,进行必要的配置后,虚拟化成一台“分布式设备”。使用这种虚拟换技术可以集合多台设备的硬件资源和...
  • 基于H3C CAS的云计算平台搭建

    千次阅读 2017-01-08 10:13:23
    基于H3C CAS的云计算平台搭建1.H3C CAS介绍 H3C CAS(CloudAutomation System)云计算管理平台是H3C 公司推出的构建云计算基础架构的资源管理平台,它为数据中心云计算基础架构提供虚拟化管理解决方案,实现对数据...
  • H3C交换机配置命令大全【转载】

    千次阅读 2019-02-26 22:10:11
    杭州华三通信技术有限公司(简称H3C), 致力于IP技术与产品的研究、开发、生产、销售及服务。H3C不但拥有全线路由器和以太网交换机产品,还在网络安全、IP存储、IP监控、语音视讯、WLAN、SOHO及软件管理系统等领域...
  • H3C常见问题

    万次阅读 2017-05-11 11:10:17
    1. HCL安装完成后,启动HCL后,虚拟设备启动特别慢,点击打开命令行,弹出对话框后不显示任何信息,也不能输入命令问题? 该问题是由于宿主机的VT-x或AMD-V功能没有打开,导致虚拟机运行缓慢。HCL的虚拟机运行...
  • 框中的两项不要勾选就可以
  • winPos:弹出窗口的位置,支持8种内置位置(c,l,t,r,b,lt,rt,lb,rb)及自定义窗口坐标,默认为c。 各参数意义:c:页面中间,l:页面左侧,t:页面顶部,r:页面右侧,b:页面顶部,lt:左上角,rt:右上角,lb:左下角,rb:右下角 ...
  • 在主页面弹出一个弹出

    千次阅读 2017-08-27 14:42:58
    <title>layer弹出层 <script type="text/javascript" src="jquery-1.8.2.min.js"></script> <script type="text/javascript" src="layer/layer.js"></script>    ;margin-top:350px; margin-...
  • 自己动手写H3C校园网登录客户端(Linux平台版)

    万次阅读 多人点赞 2012-04-11 20:21:03
    自己动手写H3C校园网登录客户端(Linux平台版) By 马冬亮(凝霜 Loki) 一个人的战争(http://blog.csdn.net/MDL13412)  周一晚上的时候,和实验室的ZL同学提聊到了Android手机使用Wifi连接学校的无线网掉线的...
  • 关闭弹出干扰消息 为交换机lsw1设置终端登录密码Taren1,退出终端重进以验证登录效果 将会话的闲置超时设为1分钟 恢复出厂设置,重新进入后观察设备名变化 1.2 步骤 实现此案例需要按照如下步骤进行。 步骤一:关闭...
  • c语言库函数总结----stdlib.h

    千次阅读 多人点赞 2019-11-18 19:33:39
    stdlib .h 头文件定义了四个变量类型、一些宏和各种通用工具函数。 double atof(const char *str) 库函数 stdlib.h 函数原型 double atof(const char *str) //时间:2019年11月15日 //作者:Kroner //...
  • 需要一个弹出一个div区域来进行对一些内容的修改,花了一天时间实现了这些效果。 html文件: &lt;!DOCTYPE html&gt; &lt;html&gt;  &lt;head&gt;  &lt;meta charset="utf-8&...
  • ),Bootstrap3对2并不兼容,建议直接根据其开发文档使用Bootstrap3。本文也是根据Bootstrap3制作。同时,Bootstrap3所提供的JavaScript效果需要到jQuery1.11( 点击打开链接 )支持,可以到jQuery官网中下载兼容旧...
  • jeesite学习笔记——焦点弹出窗口

    千次阅读 2018-08-29 20:57:50
    一,效果需求: 当鼠标点击文本框或者标签后焦点移动到文本框时,弹出一个新...1.由于是在添加内容模块弹出面板,所以要在form.jsp文件中给文本框添加焦点事件; &lt;div class="contro...
  • Matlab弹出窗口定义

    千次阅读 2019-02-23 14:07:05
    使用uigetfile函数直接在弹出窗口选择打开 打开指定格式的文件 uigetfile(’.m’) %选择.m文件 多种后缀文件进行选择性的打开 [filename,pathname] = … uigetfile({’.m’ ; '.slx’ ; ‘.mat’ ; '.*’}, ...
  • jsp页面的弹出

    千次阅读 2017-03-01 09:32:25
     {name:'关闭我',callback:function(){_this.innerHTML = '弹出菜单';}}  ]  }  );   _this.innerHTML = '关闭菜单';  return false;  };    ()" value="最简单的对话框"/> ()">...
  • H3C S5800交换机配合Windows XP SP3的802.1X客户端认证,用户认证通过后很快掉线 一、 组网: 在某项目售前测试中,H3C S5800交换机作为接入层交换机,直接连接用户PC。 用户使用Windows XP自带802.1X...
  • 本文借助easyx库函数(提供下载链接),很方便地用C语言实现了鼠标、按钮、进度条、坐标尺等操作,为普通C程序的友好人机交互界面提供了一种简单便捷的方案。
  • 页面自定义弹出输入框

    千次阅读 2015-02-27 11:28:30
    网上查找的资料代码,自己调试整理成可以用在个个地方的弹出输入框,可以在一个页面中有多个不同的弹出框 封装js PopDrag.js if(!Function.prototype.bind) { Function.prototype.bind = function(o,args) { ...
  • java 弹出确认对话框的举例

    千次阅读 2018-08-12 22:02:49
    若“取消”,则关闭对话框,不执行刚才的操作。 效果图如下: 代码如下: &lt;%@ page language="java" contentType="text/html; charset=utf-8" pageEncoding="utf-8"%&...
  • 小甲鱼零基础入门学习python笔记

    万次阅读 多人点赞 2019-08-14 11:06:30
    幂运算(3的二次方) 3的二次方后取负 注:先幂运算、然后乘除、后加减、后逻辑 3的负二次方 比较操作符 逻辑操作符 优先级问题 007 了不起的分支和循环 打飞机游戏框架: 加载背景音乐 播放背景音乐(设置单曲循环...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 65,127
精华内容 26,050
关键字:

关闭h3c的弹出消息