精华内容
下载资源
问答
  • 路由器关闭DHCP后无法进入设置页面怎么办?当把路由器当交换机使用的时候,需要关闭DHCP服务才能正常使用,但是关闭DHCP后路由器就进不去设置页面了,下面分享解决办法
  • margin-right:0cm">1级路由器 (AX3 PRO) lan ip:192.168.3.1DHCP功能开 ; margin-right:0cm">2级路由器 (open WRT) lan ip:192.168.1.1DHCP功能开 ; margin-right:0cm">2级路由器下连了一台计算机 pc1 自动取得...
  • 一、让cisco路由器具有DHCP功能 DHCP服务器大大地简化了网络管理人员的工作,一般情况下大家都是搭建基于Windows/linux等基于系统平台的应用级别的DHCP服务器。其实,在有Cisco路由器的网络中,我们完全不必重新...

    下面列举两例Cisco路由器的特殊应用,就当是为大家提供一个思路吧。

    一、让cisco路由器具有DHCP功能

    DHCP服务器大大地简化了网络管理人员的工作,一般情况下大家都是搭建基于Windows/linux等基于系统平台的应用级别的DHCP服务器。其实,在有Cisco路由器的网络中,我们完全不必重新搭建新的DHCP服务器,只需将cisco路由器配置成一个DHCP服务器,是它具有路由和DHCP的双重功能。

    下面考试,大就在真是的网络环境中进行测试,有一台cisco路由器我们要将其配置成一个DHCP服务器,为了简化操作考试,大将用另外一台cisco路由器作为客户端从该路由器获取IP地址。

    1、将路由器配置成DHCP

    配置的命令及其解释如下:

    dhcp#configure terminal

    //进入全局模式

    dhcp(config)#service dhcp

    //启用dhcp服务

    dhcp(config)#no ip dhcp conflict logging

    //关闭dhcp日志记录

    dhcp(config)#ip dhcp pool ctocio

    //配置dhcp服务器的名称为ctocio

    dhcp(dhcp-config)#network 192.168.2.0 255.255.255.0

    //配置dhcp服务器可分配的网段

    dhcp(dhcp-config)#default-router 192.168.2.1

    //配置默认网关为192.168.2.1

    dhcp(dhcp-config)#dns-server 192.168.2.1

    //配置dns为192.168.2.1

    dhcp(dhcp-config)#exit

    //退出dhcp配置模式

    dhcp(config)#ip dhcp excluded-address 192.168.2.2 192.168.2.10

    //配置dhcp排除分配的地址

    dhcp(config)#exit

    //退出全局模式

    dhcp(config)#show run

    //查看路由配置

    2、客户端获取IP

    在另外一个和R1相连的R2上,如果要为某个端口设置IP地址,通过下面的命令就可从R1的DHCP服务器中获取IP地址。

    Client#configure terminal

    //进入全局模式

    dhcp(config)#interface fastethernet 0/1

    //进入fastethernet 0/1接口

    dhcp(config-if)#ip address dhcp

    //从dhcp获取IP地址

    这样稍等片刻,就会显示类似" Interface FastEthernet0/0 assigned DHCP address 192.168.2.11,mask 255.255.255.0,host name R2"这样的提示,客户端获取IP成功。

    在实际的网络环境中,客户端通过交换机连接到cisco路由器,我们可以为该路由器配置DHCP功能,使其不仅具有路由功能,还具有DHCP功能,另外,将客户端配置成自动获得IP地址,然后设置好网关即可。这样做的好处是,不仅免去了部署专门的DHCP服务器的麻烦节省了网络资源,同时充分挖掘了Cisco路由器的功能,也方便今后的网络管理。特别是在大型网络环境中,将不同子网的关键路由器配置成DHCP服务器,管理和维护都非常方便。

    二、让cisco路由器具有DNS功能

    DNS是重要的网络服务,在大型网络中一般是需要部署DNS服务器的。其实,在Cisco路由器中也可以设置DNS服务器。不过,和大家通常所指的DNS服务器不同的是,在cisco路由器中配置DNS主要是两个方面:一是开启Cisco路由器的DNS功能,并添加相应的DNS的IP地址,使其具有域名解析功能;另外,在Cisco中可以添加多条DNS记录,每条DNS是有优先级的,在Cisco中需要调整其顺序来设置优先级别。

    1、配置DNS服
    务器

    登录路由器然后输入如下配置命令即可:

    vnet81#configure terminal

    //进入配置模式

    vnet81(config)#ip name-server 202.100.64.68

    //设置DNS为202.100.64.68

    vnet81(config)#exit

    vnet81#show running-config

    //查看路由器配置,DNS配置成功

    vnet81#write

    //保存配置

    上述配置虽然比较简单,但是非常实用。在cisco路由器中开启并设置DNS后,客户端就不用在TCP/IP属性中设置DNS服务器的地址了,就可以直接从路由器中获得DNS服务器的地址。这样既加快了域名解析速度,也省去了设置的麻烦。另外,在比较大的网络中DNS服务器的负载比较大,需要响应客户端的DNS请求,如果在每个子网的关键路由器中添加这样一条DNS记录就能够在一定程度上解放DNS服务器。

    2、调整DNS优先级别

    同样的登录到Cisco路由器,进行设置。如果此前已经设置了DNS,而这条DNS是优先级别最高的要调整其优先级需要先删除这条记录,然后再重新设置,其命令是:

    vnet81#configure terminal

    //进入配置模式

    vnet81#no ip name-server

    //删除DNS配置

    vnet81#ip name-server 61.164.95.98 202.100.64.68

    //添加两台DNS记录,它们之间是有优先级的,最前面的优先级高,每一跳记录之间用空格分开

    vnet81#show run

    //查看DNS配置

    在实际的网络环境中,我们一般本地的DNS服务器设置为第一个,使其可以优先进行域名解析这样可以提高解析的速度。后面的DNS一般设置为本地ISP的DNS服务器地址,作为候补。

    总结:上面的两例应用往往为大家所忽略或者不知,其实在Cisco路由器中还有很多实用的功能有待大家去挖掘。在企业IT投入紧缩的情况下,让网络设备的功能最大化何尝不是我们努力的方向?

     

    转载于:https://blog.51cto.com/242436/980059

    展开全文
  • 路由器DHCP的配置详细方法

    千次阅读 2014-03-08 07:45:08
    动态主机设置协议(Dynamic HostConfiguration Protocol, DHCP)是一个局域网的网络协议,使用UDP协议工作,主要有两个用途:给内部网络或网络服务供应商自动分配IP地址给用户给内部网络管理员作为对所有计算机作...


    动态主机设置协议(Dynamic HostConfiguration Protocol, DHCP)是一个局域网的网络协议,使用UDP协议工作,主要有两个用途:给内部网络或网络服务供应商自动分配IP地址给用户给内部网络管理员作为对所有计算机作中央管理的手段,其优点是设置简单,方便高效,并为网内的每台主机设置固定的IP,而且可以动态的指定哪些IP是不能用的,所以在实际生活中得以广泛的运用。         

    另外这里还要注意连线之间的问题:

    直通线     即正线   标准568B:两端线序一样,从左至右线序是:白橙,橙,白绿,蓝,白蓝,绿,白棕,棕。  

             双绞线    即反线   标准568A:一端为正线的线序,另一端为从左至右:白绿,绿,白橙,蓝,白蓝,橙,白棕,棕。         

             同类设备间相连使用交叉线方式;异类设备间相连使用直通线方式。 一般同一层的设置是用双绞线,不同层的设置使用直通线。

             下面在模拟器PacketTracer软件中开始组建一个简单的局域网实现动态IP的分配:

    配置方式主要如下:

    Router>en

    Router#conf t

    Enter configuration commands, one perline.  End with CNTL/Z.

    Router(config)#int f0/0

    Router(config-if)#no shutdown       //因为路由器的端口默认是关闭的,所以需要保持打开

     

    %LINK-5-CHANGED: Interface FastEthernet0/0,changed state to up

     

    %LINEPROTO-5-UPDOWN: Line protocol on InterfaceFastEthernet0/0, changed state to up

     

    Router(config-if)#ip address 192.168.0.254255.255.255.0    //指定该端口号的IP地址

    Router(config-if)#exit

    Router(config)#ip dhcp excluded-address192.168.0.1 192.168.0.10  //设置排除固定IP,将剩余的IP作为动态分配

    Router(config)#ip dhcp pool A    //设定IP线程池并进入

    Router(dhcp-config)#network 192.168.0.0255.255.255.0    //指定动态分配的IP段

    Router(dhcp-config)#default-router192.168.0.254         //设定默认的网关

    Router(dhcp-config)#dns-server 61.139.2.69          //设定默认的DNS服务地址

    Router(dhcp-config)#lease                                  //设定分配IP的使用期限,在模拟器下无该功能

     

    最后双击任意台电脑图标进入IP Configuration选项选择DHCP即可动态获取IP

    因为在IP分配池中指定从192.168.0.1——192.168.0,10作为固定IP段,所以动态IP分配是从192.168.0.11开始的,另外还可以再次进入IP池指定固定IP段。

             还有一点就是当一个路由器连接两个局域网的时候,如果都需要设置DHCP动态分配,那么另外个局域网的IP地址池可以设置为ip dhcp pool B  因为路由器是连接的不同网段,所以不能用同一个地址池进行分配。

    展开全文
  • H3C路由器DHCP服务器设置

    千次阅读 2019-01-07 11:09:46
    1dhcp enable 使能dhcp功能2dhcp server forbidden-ip 192.168.1.1 设置此ip不参与自动分配3dhcp server ip-pool 0 定义一个名为0的地址池4network 192.168.1.0 mask 255.255.255.0 设置自动分配ip的网络地址范围5...

    1
    dhcp enable 使能dhcp功能
    2
    dhcp server forbidden-ip 192.168.1.1 设置此ip不参与自动分配
    3
    dhcp server ip-pool 0 定义一个名为0的地址池
    4
    network 192.168.1.0 mask 255.255.255.0 设置自动分配ip的网络地址范围
    5
    gateway-list 192.168.1.1 设置自动获取ip的网关地址
    6
    dns-list 222.74.1.200 设置自动获取的dns地址为222.74.1.200 (dns 根据电信分配的实际地址设置)
    7
    expired day 5 设置地址租期为5天

    注意dns如果为多地址 可以再后面加逗号隔开

    转载于:https://blog.51cto.com/speediness/2339570

    展开全文
  • Cisco PT模拟实验(18) 路由器DHCP服务器及中继配置实验目的:掌握路由器DHCP服务器的配置方法掌握DHCP中继代理的配置方法 掌握DHCP协议及其中继的原理及实现过程实验背景: 随着公司网络规模不断扩大,公司内办公...

    Cisco PT模拟实验(18) 路由器DHCP服务器及中继配置

    实验目的: 

            掌握路由器DHCP服务器的配置方法

            掌握DHCP中继代理的配置方法

            掌握DHCP协议及其中继的原理及实现过程

    实验背景

                随着公司网络规模不断扩大,公司内办公电脑越来越多,原先的固定IP接入方案已经不再适用于复杂多变的网络环境。为了简化网管的管理维护工作,公司决定采用将路由器配置为DHCP服务器,使得企业网内部主机接入后自动获取IP地址,从而实现主机之间的相互通信。

    技术原理

    • DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网的网络协议,使用UDP协议工作, 主要有两个用途:给内部网络或网络服务供应商自动分配IP地址,给用户或者内部网络管理员作为对所有计算机作中央管理的手段。

    • 当DHCP客户机Client与DHCP服务器Server在同一个物理网段,则客户机可以正确地获得动态分配的ip地址。DHCP的实现过程,大致如下:

      • 客户机请求DHCP:首先向局域网内广播DHCP Discover包(源地址为0.0.0.0,目的地址为255.255.255.255),找到能够给它提供IP的DHCP服务器。

      • 服务器响应:当可用的DHCP Server接收到Discover包后,通过发送DHCP Offer包给予应答,意在告诉Client端它可以提供IP地址。

      • 客户机请求IP:Client端接收到Offer包之后,发送DHCP Request包请求分配IP。

      • 服务器确认IP租约:DHCP Server发送ACK数据包,确认信息。

    • DHCP中继(代理),即DHCP Relay(DHCPR),可以实现在物理网段和不同子网之间处理和转发dhcp信息的功能。如果不在同一个物理网段,则需要中继代理。DHCP中继的实现过程,大致如下:

      • 当客户机启动并进行DHCP初始化时,它会在本地网络广播配置请求报文。

      • 如果本地网络存在DHCP服务器,则可以直接进行DHCP配置,不需要DHCP中继。

      • 如果本地网络没有DHCP服务器,则本地网络中的DHCP代理收到该广播报文后,将该DHCP报文的源IP地址修改为该Vlanif或上联接口的IP地址,而目的地址则为DHCP代理配置的DHCP服务器IP地址,以单播形式将DHCP Discovery包转发给指定DHCP服务器。

      • DHCP服务器根据请求信息进行配置,并直接转发给DHCP中继,再将配置信息以广播形式发送给客户机,完成IP地址动态分配。

    • DHCP配置模式 (dhcp-config)#


    实验设备:Router-PT 2台;Switch_2960 1台;PC 2台,Server 1台;直通线,交叉线,串口线。

    实验拓扑

    wKioL1m42h2gJ6RoAAA0m6sFEOU498.png-wh_50

    实验步骤:

            新建Cisco PT 拓扑图

            将各PC及Server的IP及网关地址等设置为自动获取(DHCP)

            对各Router进行相关配置(接口IP、时钟频率等)

            在Router0和Router1上配置RIP动态路由

            在Router0上配置DHCP服务并创建所需地址池

            在Router1上配置DHCP中继代理

            测试各终端(PC、Server)之间的互通性


    # PC设置
    设置PC的IP地址、子网掩码、默认网关、DNS服务器为DHCP
    /*=Part1  Router0 基本配置  */
    Router>enable
    Router#conf t
    Router(config)#inter f0/0                 //进入第0模块第0端口(快速以太网接口)
    Router(config-if)#ip address 192.168.1.1 255.255.255.0    //配置f0/0接口IP
    Router(config-if)#no shutdown             //开启端口,默认关闭
    Router(config-if)#exit
    Router(config)#interface serial 2/0       //进入第2模块第0端口(串行接口)
    Router(config-if)#ip address 10.254.10.1 255.255.255.0    //配置s2/0接口IP
    Router(config-if)#clock rate 64000        //必须配置时钟才可通信
    Router(config-if)#no shutdown             //开启端口,默认关闭
    Router(config-if)#exit
    /*=Part2  RIP动态路由配置  */
    Router(config)#router rip                     //进入路由配置模式 — 启用RIP协议
    Router(config-router)#version 2               //使用版本2,即RIPv2协议
    Router(config-router)#network 192.168.1.0     //指定需要通告的网络(位于路由接口)
    Router(config-router)#network 10.254.10.0
    Router(config-router)#exit
    /*=Part3  DHCP服务器配置  */
    Router(config)#service dhcp                   //启用DHCP功能
    //配置DHCP地址池cisco1
    Router(config)#ip dhcp pool cisco1
    Router(dhcp-config)#network 192.168.1.0 255.255.255.0     //DHCP地址池范围
    Router(dhcp-config)#default-router 192.168.1.1        //客户端的默认网关
    Router(dhcp-config)#dns-server 114.114.114.114        //客户端的DNS服务器
    Router(dhcp-config)#exit
    Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.100  //排除DHCP分配的地址
    //配置DHCP地址池cisco2
    Router(config)#ip dhcp pool cisco2
    Router(dhcp-config)#network 192.168.2.0 255.255.255.0     //DHCP地址池范围
    Router(dhcp-config)#default-router 192.168.2.1        //客户端的默认网关
    Router(dhcp-config)#dns-server 114.114.114.114        //客户端的DNS服务器
    Router(dhcp-config)#exit
    Router(config)#ip dhcp excluded-address 192.168.2.100 192.168.2.200  //排除DHCP分配的地址
    Router(config)#^Z
    Router#show ip dhcp pool            
    Router#show ip dhcp binding
    /*=Part1  Router1 基本配置  */
    Router>enable
    Router#conf t
    Router(config)#inter f0/0                 //进入第0模块第0端口(快速以太网接口)
    Router(config-if)#ip address 192.168.2.1 255.255.255.0    //配置f0/0接口IP
    Router(config-if)#no shutdown             //开启端口,默认关闭
    Router(config-if)#exit
    Router(config)#interface serial 2/0       //进入第2模块第0端口(串行接口)
    Router(config-if)#ip address 10.254.10.2 255.255.255.0    //配置s2/0接口IP
    Router(config-if)#no shutdown             //开启端口,默认关闭
    Router(config)#exit
    /*=Part2  RIP动态路由配置  */
    Router(config)#router rip                     //进入路由配置模式 — 启用RIP协议
    Router(config-router)#version 2               //使用版本2,即RIPv2协议
    Router(config-router)#network 192.168.2.0     //指定需要通告的网络(位于路由接口)
    Router(config-router)#network 10.254.10.0
    Router(config-router)#exit
    /*=Part3  DHCP中继代理配置  */
    Router(config)#service dhcp                //启用DHCP功能
    Router(config)#inter f0/0                  //进入第0模块第0端口(快速以太网接口)
    Router(config-if)#ip helper-address 10.254.10.1    
    //将192.168.2.0子网内的DHCP请求包转发到10.254.10.1
    Router(config-if)#^Z
    Router#show r
    # 链路测试(本例各终端IP如下,不同实验环境下所获取的IP地址可能不同)
    PC0和PC1(命令提示符CMD下)
    ping 192.168.1.1                  //链路通
    ping 10.254.10.1                  //链路通
    ping 192.168.2.2                  //链路通



    实验环境: Windows 7,Cisco PT 7.0

    参考资料:CCNA学习指南(第7版)

     


    转载于:https://blog.51cto.com/microdq/1964944

    展开全文
  • 【图文详解】路由器设置关闭DHCP后电脑手机无法上网 首先,明确此问题产生是因为 DHCP服务被关闭路由器无法为局域网内的计算机自动分配IP地址,而电脑默认设置都是自动获取IP地址,这
  • 路由器DHCP服务、VTP、SHRP和PVST+生成树的配置实验环境描述:在GND3软件环境下模拟完成以下操作1. 在交换机上配置VTP实现整个网络上vlan的统一控制2. 在R5上配置DHCP服务使作为服务器的虚拟机win7自动获取到IP地址...
  • 思科路由器的DNS及DHCP功能

    千次阅读 2012-01-19 16:48:56
    我们知道,思科路由器功能强大、负载能力强而著称,能更好地服务于网络。今天,我们在这里为大家介绍其两个特殊的应用,一起来看看吧。 一、DNS功能 在大型网络中一般都是需要部署DNS服务器的,而DNS是重要...
  • 我的光猫支持路由功能,这时候光猫就算是一个路由了,然后我从光猫的lan口接了一根线到水星路由器的wan口,并且把水星路由器dhcp服务给关闭了,并且把自己的电脑的mac地址与静态IP给绑定在里面,但是我给电脑插上...
  •  目前很多的宽带路由器都具有设置DHCP服务器的功能,TP-LINK推出的TL-410是一款面向家庭用户的宽带路由器,其外观小巧,时尚。而且价格便宜,非常适合家庭用户学生一族的使用。TL-R410宽带路由器也具有支持DHCP服务器...
  • 12使用路由器配置DHCP

    2013-07-29 00:59:35
    使用路由器配置DHCP路由器配置DHCP ·作用:实现局域网中的客户机自动获取IP地址 ·配置 1 定义地址池 Router(config)#ip dhcp pool vlan1 2 设定IP地址池段 network 192.168.1.0 255.255.255.0 3 设定网关地址 ...
  • R1(服务端)---------------------------------------------R2(客户端) Cisco 路由器的dhcp 配置 配置的命令及其解释如下: R1dhcp服务的配置 dhcp#configure terminal ...//打开dhcp功能 dhcp(...
  • 二级路由器设置为何要关闭DHCP服务

    千次阅读 2015-02-15 13:29:00
    因为如果不关闭dhcp的话会和一级路由相冲突,你这个因该是lan口的连接法吧,如果不然的话是不需要关闭dhcp功能路由器路由器的连接方法有两种,一种是wan口连,一种是lan口连方法1:WAN口连接。任意一台电脑...
  • 2,使用DHCP连接ONENET的时候,则不用考虑路由器的IP了,因为DHCP动态获取的IP地址和路由器的必定在同一个IP分段里面。do_dhcp()一定要放置在while(1)中 while(1) /*循环执行的函数*/ ...
  • 一、实验目的:掌握DHCP服务基本配置及DHCP中继服务配置,实现全网互通 二、拓扑图: 三、具体步骤配置: (1)R1路由器配置: Router>enable --进入特权模式 Router#configure terminal --进入全局配置...
  • 实例一 小明家是宽带上网,通过TP Link路由器分了一条线给邻居小红。而邻居小红有多个设备需要上网,她在...原因就是小红家的路由器默认是开启DHCP服务的,在这个小局域网中产生了DHCP冲突,导致网络不正常,解决...
  • 原标题:给电脑增加无线路由器功能,开机就能连接互联网!如果你的无线路由器距离台式机比较远,或者不想购买无线路由器,那么你可以试着用电脑来给手机和pad提供无线WiFi来上网。不过,电脑增加无线路由器功能...
  • 宽带路由器主要功能

    2012-06-15 17:08:40
    MAC功能  目前大部分宽带运营商都将MAC地址和用户的...带有MAC地址功能的宽带路由器可将网卡上的MAC地址写入,让服务器通过接入时的MAC地址验证,以获取宽带接入认证。 网络地址转换(NAT)功能  NAT功能将局域
  • 不过,电脑增加无线路由器功能必须要有无线网卡,不限内置还是外置的,也就是说,台式机只要插上一个USB无线网卡一样能用(40元左右)。一、WIN7下把电脑变成无线路由器方法下面开始正式图文设置教程(参考网上的方法...
  • 无线路由器中继功能桥接方法

    万次阅读 2010-04-16 12:48:00
    From:http://www.router.net.cn/Article/33539.html作者:佚名 文章来源:百度博客 点击数:1575 更新时间:2009-12-23 9:25:34向大家介绍无线路由器中继功能设置,可能好多...无线路由器中继功能桥接方法你经常会遇到
  • 路由器DHCP服务那没有识别某IP地址是否已上线就不再分配的功能DHCP服务只能识别自己分配出去的。 所以静态IP范围必须不在DHCP服务的范围内。 例如DHCP服务那是192.168.1.99-192.168.1.199,那么静态手工设置...
  • 无线路由器桥接功能

    2011-08-04 19:55:17
    路由器设置和原来一样 只是要开启Bridge功能, 在Bridge栏里填写副路由器的mac地址(LAN口mac地址) 、关闭频道自动切换功能,设置一个固定的频道(一般无线AP都有11个通道,通常组建无线办公环境,选用1,6,11号通道...
  • 首先了解无线宽带路由器,它好比将单纯性无线AP和宽带路由器合二为一的扩展型产品,不仅具备单纯性无线AP所有功能如支持DHCP客户端、支持VPN、防火墙、支持WEP加密等等,而且还包括了网络地址转换(NAT)功能,可支持...
  • dhcp是动态主机设置协议(Dynamic Host Configuration Protocol, DHCP)是一个局域网的网络协议...本文跟随小编来了解一下dhcp应该开启还是关闭_dhcp关闭会怎么样,dhcp服务如何开启和关闭dhcp应该开启还是关闭_dhc...
  • 网络设备的配置是考验一个网络工程师或者是网络管理员实际...本文将要为大家简单介绍一下在路由器DHCP的设置,有不懂的朋友们可以进来看看。说到DHCP,还是得需要重复的说明一下,避免大家把这个概念忘记了,动...
  • 相信大家有看到男子改WiFi密码被隔壁邻居质疑的这条新闻吧,那么几天我告诉你几个路由器小技巧(基本路由器都可以使用哦)如何管理路由器?(以我的设备为例)可以在路由器下方寻找这个代码如图然后连接上WiFi到浏览器...
  • 路由器环境下路由器的入口IP地址及DHCP设置探讨 多路由器环境下路由器的入口IP地址及DHCP设置探讨 这里把路由器的LAN口管理IP地址称为路由器的入口地址,把直接接入互联网的路由器称为主路由器,其他路由器...
  • 设置磊科无线路由器,使得在寝室能用手机wifi拨号上网,主要是要使用路由器的交换机功能: (1)网线插LAN口 (2)电脑连上路由器(无线或者有线都行),登陆路由器设置,在浏览器中输入默认路由器登录地址即可,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 13,690
精华内容 5,476
关键字:

关闭路由器dhcp功能后