精华内容
下载资源
问答
  • H3CNE 320题 RIPv2路由自动汇总

    千次阅读 2013-12-30 16:39:00
    320. MSR路由器通过RIPv2 和外界交换路由信息,在路由表里有 10.1.1.0/24、10.1.2.0/24、10.1.3.0/24 三条路由,那么该路由器上增加如下RIP的配置: [MSR-rip-1] summary 那么该路由器将会对外发送如下哪个网段的...
    320. MSR路由器通过RIPv2 和外界交换路由信息,在路由表里有 10.1.1.0/24、10.1.2.0/24、10.1.3.0/24 三条路由,那么该路由器上增加如下RIP的配置:
    [MSR-rip-1] summary
    那么该路由器将会对外发送如下哪个网段的路由?
    A. 10.1.0.0/16
    B. 10.1.2.0/22
    C. 10.0.0.0/8
    D. 10.1.0.0/22


    answer:C


    解释:

    因为是RIP2汇总 汇总的是8位主路由 这个是规定  

    RIP协议本身都是在主类网络的边界进行汇总的,如果是RIP V2没有关闭自动汇总的话是自动汇总为主类网络的,如果是手动汇总的话,可以汇总成D选型的。

    展开全文
  • 华为ENSP模拟器环境下 如图 配置命令上一章已经介绍过,这里就不在赘述, ...RIPv1和RIPv2都有自动汇总机制,RIPv1无法关闭自动汇总,RIPv2可以关闭自动汇总,并且 对于华为设备而言当我们启用RIP...

    华为ENSP模拟器环境下

    如图

    配置命令上一章已经介绍过,这里就不在赘述,

    总结:

    1.什么是自动汇总?

    当子网路由传递到主类网段边界的时候,路由器会将子网路由汇总为主类网段再发送出去。

     

    2.RIPv1和RIPv2对于自动汇总有什么区别?

    RIPv1和RIPv2都有自动汇总机制,RIPv1无法关闭自动汇总,RIPv2可以关闭自动汇总,并且

    对于华为设备而言当我们启用RIPv2的时候自动汇总机制已经被默认关闭。

    所以我们才会看到通过RIPv1学到的23.0.0.0/8路由和通过RIPv2学到的23.1.1.0/24路由。

     

     

     

     

    展开全文
  • Cisco常用配置命令 一.交换机的基本配置 C2950# config terminal 进入全局配置模式 show interface fastethernet0/1 查看端口0/1的配置结果 show interface fastethernet0/1 status 查看端口0/1的状态 show ...
    Cisco常用配置命令
    一.交换机的基本配置
    C2950#
    config terminal 进入全局配置模式
    show interface fastethernet0/1 查看端口0/1的配置结果
    show interface fastethernet0/1 status 查看端口0/1的状态
    show mac-address-table 查看整个MAC地址表
    clear mac-address-table restricted static 清除限定性地址
    C2950(config)#
    hostname 2950A / 设置主机名为2950A
    interface f0/23 / 进入端口23的配置模式
    enable password cisco / 设置enable password为cisco
    enable secret cisco1 / 设置enable secret为cisco1
    ip address 192.168.1.1 255.255.255.0 / 设置交换机IP地址
    ip default-gateway 192.168.1.254 / 设置默认网关
    ip domain-name cisco.com / 设置域名
    ip name-server 200.0.0.1 / 设置域名服务器
    配置查看MAC地址表
    mac-address-table ?
    mac-address-table aging-time 100 / 设置超时是时间为100s
    mac-address-table permanent 0000.0c01.cc /f0/3 加入永久地址
    mac-address-table restricted static 0000.0c02.bbcc / f0/6 f0/7 加入静态地址
    end
    show mac-address-table /查看整个Mac地址表
    clear mac-address-table restricted static
    C2950(config-if)#
    interface fastethernet0/1 /进入接口F0/1子配置模式
    interface Ethernet0 /进入以太网口0子配置模式
    no shutdown /激活接口
    speed ? /查看speed命令的子命令
    speed 100 /设置该端口速率为100Mb/s
    dulplex full/half/auto /设置该端口为全双工
    description TO_PC1 /设置该端口描述为TO_PC1
    show interface fastethernet 0/1 /查看端口0/1的配置结果
    show interface fastethernet 0/1 status /查看端口0/1的状态
    配置VTP和STP
    一. 配置VTP
    2950A #vlan database /进入VLAN配置子模式
    show vtp status /查看VTP设置信息
    show vlan /查看VLAN配置信息
    copy running-config startup-config /保存配置文件
    2950A (vlan)#vtp server/client /设置本交换机为server/client模式
    vtp pruning /启动修剪功能
    vtp domain vtpserver /设置域名为vtpserver
    vlan 2 /创建VLAN2,系统将自动命名
    vlan 3 name vlan3 /创建VLAN3,并命名为vlan3
    Switch(config-if)#
    switchport mode trunk /设置当前端口为Trunk模式
    switchport trunk allowed vlan all /设置允许从该端×××换数据的VLAN
    switchport trunk vlan remote vlan6 /设置允许交换数据的Vlan(除vlan6外)
    switchport mode access /设置端口为静态VLAN访问模式
    switchport access vlan2 /将端口9分配给相信的VLAN2
    show vlan
    生成树协议配置(负载均衡)
    Switch#
    spanning-tree vlan 1 port-priority 10 /设置VLAN 1的端口的权值为10 (默认值为128)
    spanning-tree vlan 1 cost 19 /设置VLAN 1生成树路径值为19
    专题三 配置路由协议
    Router# enable
    Router#config terminal
    Router(conf)#hostname R1
    show session /查看终端服务器的会话
    show line 1 /查看线路1的状态
    clear line 2 /清除线路2
    A. 静态路由
    格式:ip route ip-addr subnet-mask gateway 加入静态路由
    R1(conf)#ip route 192.168.1.0 255.255.255.0 10.1.1.1
    ip routing /启动IP路由
    B. 动态路由
    (1)配置RIP协议
    no logging console 防止大量的端口状态变化信息和报警信息对配置过程的影响
    [no] ip routing 允许/不允许路由选择协议
    router ri p 进入RIP协议配置模式
    network 192.168.1.0 声明192.168.1.0与路由器R1直接邻接
    version 2 设置RIP协议的版本为2
    neighbor ip-addr 说明邻接路由器,以使它们能够自动更新路由
    passive interface 接口 阻止在指定的接口发送路由更新协议
    show ip route 查看路由表信息
    show ip route rip/igrp/ospf 查看RIP/IGRP/OSPF协议路由信息
    (2)配置IGRP协议
    no keepalive /不监测keepalive信号,即不连接设备时可激活该接口
    bandwidth x /设置带宽为x(Kb/s)
    clockrate x /设置时钟频率为x(HZ)
    timer basic /更新时间 到期时间 抑制与否清除时间 设置自定义的路由更新时间……
    no metric holddown /禁止抑制功能,路由信息删除后可立即接受新的
    metric maximum-hop 50 /当信息包穿过50个路由器时,删除信息包
    router igrp/eigrp autonomous-system /进入IGRP协议配置子模式
    (3)配置OSPF协议
    router ospf 1 /指定使用ospf选择协议,并运行在1号进程中
    network 网络地址 掩码反码 area 区域号 /说明与区域1的172.16.4.6邻接
    area 区域号 stub /将区域x转化为根区
    show ip ospf neighbor /列出与本路由器是“邻接”关系的路由器
    no ospf auto-cost-determination /使OSPF不自动根据每个接口的带宽,计算出其cost
    ip ospf cost /手动设置接口的cost
    area 1 range 172.16.4.0 255.255.255.0 /说明区域一的范围是子网172.16.4.0/24
    (4)配置EIGRP协议
    no auto-summary 关闭EIGRP协议的路由自动汇总功能
    network network-addr 掩码反码
    广域网接入
    一.配置ISDN
    isdn switch-type switch-type /设置交换机类型为 switch-type
    interface bri 0 /进入ISDN的BRI接口配置模式
    encapsulation ppp /设置封装协议为ppp
    ppp multilink /启动ppp多连接
    dialer string 80000002 /设置拨号串,R2的ISDN号码为80000002
    dialer-group 1 /设置拨号组号为1,把BRI 0接口与拨号列表1相关联
    dialer-list 1 protocol ip permit /设置拨号列表1,即当有IP包时将引起拨号
    dialer load-threshold load /设置达到load后,启动第二个B通道.
    logging console /在终端上显示监测信息
    debug dialer /监测dialer信息
    undebug all /关闭所有调试信息
    二. 配置PPP和DDR
    ppp authentication chap /设置PPP认证方式为CHAP
    clockrate speed /设置DCE端线路速度为speed
    dialer idle-timeout 120 /设置拨号空闲时间为120s
    no cdp enable /禁止通过此接口传递CDP控制数据
    dialer map ip 192.168.1.2 name R2 broadcast 800000002
    /设置拨号串,将IP地址与ISDN的SPID对应起来.
    usename R2 password secret
    /设置用户名和口令,即设置拨号链路对端路由器名为R2,口令为secret.
    三. 配置帧中继
    frame-relay lmi-type cisco /设置帧中继的LMI类型为cisco
    no frame-relay inverse-arp /关闭帧中继逆向ARP
    no ip address /只在数据链路层工作,无需IP地址
    frame-relay interface-dlci dlci
    interface serial 2 /进入串行口2端口配置模式
    frame-relay route 303 interface Serial 1 302 在串行口2的DLCI 303与串行口1的DLCI 302之间建立关联
    show frame route /显示完整的路由信息
    frame-relay map ip 192.168.1.2 302 broadcast /将IP地址192.168.1.2与帧中继的DLCI 302关联起来
    interface s 0.1 划分子接口,对其进行逻辑划分
    interface s 0.1 point-to-point 划分子接口,并设置为点对点模式
    ×××配置
    一 L2TP的配置与测试
    A:命令模式:特权用户模式Quidway#
    (1)show l2tp session 显示当前的L2TP会话的信息
    举例:Quidway#show l2tp session
    (2) show l2tp tunnel 显示当前的L2TP通道的信息
    举例:Quidway#show l2tp tunnel
    (3)clear vpdn tunnel l2tp remote-name 断开通道对端名称为X的通道连接
    举例:Quidway#clear vpdn tunnel l2tp A8010
    B:命令模式:全局配置模式Quidway(config)#
    (4) [no] vpdn-group group-nunmber 创建/删除组号为x的VPDN组
    举例:Quidway(config)#vpdn-group 2
    默认情况:系统默认没有创建VPDN组
    (5)[no] interface vitual-template vitual-template-number 创建/删除虚接口模块
    举例:Quidway(config)#interface virtual-template 1
    默认配置:系统默认没有创建虚接口模块
    C:命令模式:VPDN组配置模式Quidway(config-vpdn1)#
    (6) [no]lcp renegotiation 允许/不允许LCP再次协商
    举例:Quidway(config-vpdn1)#lcp renegotiation
    扩展:lcp renegotiation always 一直允许进行LCP协商
    默认情况:系统默认不重新进行LCP协商
    (7)local name name 指定通道本端的名称为name
    no local name 将通道本端的名称恢复成默认名称
    举例:Quidway(config-vpdn1)#local name itsme
    默认情况:系统默认的本端名称为路由器名
    (8) [no] l2tp tunnel authentication 启用/关闭L2TP通道验证功能
    举例:Quidway(config-vpdn1)#no l2tp tunnel authentication
    默认情况:系统默认对L2TP通道进行验证
    (9) l2tp tunnel password password 设置L2TP通道验证的密码为password
    no l2tp tunnel password 将L2TP通道验证的密码还原为默认值
    举例:Quidway(config-vpdn1)#l2tp tunnel password yougotit
    默认情况:系统默认的通道验证密码为路由器名
    (10) [no] force-local-chap 强制/禁止LNS与Client之间重新进行CHAP验证
    举例:Quidway(config-vpdn1)#force-local-chap
    默认情况:系统默认不进行CHAP的重新验证
    (11)accept-dialin l2tp virtual-template virtual-template-number remote
    remote-peer-name 接受名称为remote-peer-name的对端发起的L2TP通道连接请求,并根据vitual-template virtual-template-number 创建virtual-access接口
    no accept dialin 删除此设置
    举例: Quidway(config-vpdn1)#accept-dialin l2tp virtual-template 1 remote A8010
    , 默认情况:系统默认为禁止接受呼入
    二 IPSec的配置
    Crypto isakmp policy1 /配置IKE策略1
    Authentication pre-share /IKE策略1的验证方法设为pre-share
    Group 2;1024-bit Diffie-Hellman /加密算法未设置则取默认值:DES
    Crypto isakmp key test123 address 202.96.1.2 /设置Pre-share密钥为test123,此值两端需一致
    crypto ipsec transform-set ×××tag ah-md5-hmac esp-des
    /设置AH散列算法为md5,ESP加密算法为DES.
    crypto map ×××demo 10 ipsec-isakmp /定义crypto map
    set peer 202.96.1.2 /设置隧道对端IP地址
    set transform-set ×××tag /设置隧道AH及ESP
    match address 101
    interface Tunnel0 /定义隧道接口
    ipaddress 192.168.1.1 255.255.255.0 /隧道端口IP地址
    no ip directed-broadcast
    tunnel source 202.96.1.1 /隧道源端地址
    tunnel destination 202.96.1.2 /隧道目的端地址
    crypto map ×××demo /应用×××demo于此接口
    其他的略
    NAT——网络地址转换
    (1)静态地址转换
    ip nat inside source static 内部地址 合法地址 (全局配置模式)
    举例: ip nat inside source static 10.1.1.2 192.1.1.2
    在内部地址X和合法地址Y之间建立静态转换
    ip nat inside /说明该端口是内网接口
    ip nat outside /说明该端口是外网接口
    (2)动态地址转换
    ip nat pool 地址池名称 起始IP地址 终止IP地址 netmask 子网掩码 (全局配置模式)
    举例:ip nat pool poolA 192.1.1.2 192.1.1.10 netmask 255.255.255.0
    /设置合法地址池,名为PoolA, 地址范围为192.1.1.2~192.1.1.10,子网掩码为255.255.255.0
    access-list 标号 permit 源地址 通配符(其中标号为1~99间的整数)
    举例:access-list 1 permit 10.1.1.0 0.0.0.255
    定义标准访问列表1,指出10.1.1.0/24的本地地址进行NAT转换
    ip nat inside source list 访问列表标号 pool 地址池名称
    举例:ip nat inside source list 1 pool poolA
    设置:对访问列表1中设置的本地地址,应用PoolA池进行动态地址转换
    (3)复用动态地址转换
    ip nat inside source list 访问列表标号 pool 地址池名称 overload
    举例:ip nat inside source list 1 pool poolA overload
    设置:对访问列表1中设置的本地地址,应用PoolA池进行复用动态地址转换

    转载于:https://blog.51cto.com/hankaixiaoyue/344722

    展开全文
  • Ospf的路由汇总分为区域间汇总和外部路由汇总,配置命令是不一样的 给出公式 Ospf区域间汇总 在abr上配置* A(config-router)#area区域号range汇总(网段)ip汇总掩码 外部路由汇总,在asbr上* A(config-...
    Ospf的路由汇总分为区域间汇总和外部路由的汇总,配置命令是不一样的 <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    给出公式

    Ospf区域间汇总

    abr上配置*

    A(config-router)#area 区域号 range 汇总(网段)ip 汇总掩码

    外部路由汇总,在asbr*

    A(config-router)#summary-address 汇总ip 汇总掩码

    看拓扑

    R1的 s1/0202.110.100.1      255.255.255.0

    R2s1/0202.110.100.2       255.255.2550

    R2s1/1为 202.110.101.1       255.255.255.0

    R3s1/1202.110.101.2         255.255.255.0

    R1r2s1/0端口为ospf的主干区域0

    R2s1/1r3s1/1ospf区域1

    注意下在r2上的路由发布,将两条链路分开在两个区域中发布

    端口配置省略

    R1r3上发布就不写了,直接看下r3的路由

    r2上的路由模式下写汇总注意区域号,我们是将区域0ip子网汇总那么就区域0

    再看r3的路由

    看下外部路由汇总的拓扑

    R1r2s1/0端口为rip协议

    R2s1/1r3s1/1osp协议

    R1的 s1/0202.110.100.1      255.255.255.0

    R2s1/0202.110.100.2       255.255.2550

    R2s1/1为 202.110.101.1       255.255.255.0

    R3s1/1202.110.101.2         255.255.255.0

    再来外部路由汇总,外部路由汇总就是将除了ospf协议外的路由协议的路由汇总例如ripeigrp,注意下r2的路由发布,要将两条链路发布到两种不同的协议中

    需要路由再发布,否则r1学习不到r3的路由

    看下r3的路由e2为外部路由

    r2上进行路由汇总

    再次看下r3的路由

    在进行外部路由汇总,如果有rip协议在的话,记得一定要在rip协议上关闭路由汇总,否则会按照**来进行自动汇总

    转载于:https://blog.51cto.com/zhaofei/340653

    展开全文
  • 自动路由汇总小实验

    2009-10-10 19:21:37
    本实验来源于CCNA ICND2第七章,做完后对不连续网络和路由汇总的认识加深了。 下面上实验拓扑,辅以罗列简单的配置。 R111: fa0/0:172.16.3.1/24 fa1/0:10.1.3.1/24 s0/1:172.16.1.1/24 s1/0:10.1.1.1/24 R333: ...
  • BGP路由汇总

    2017-11-12 19:18:00
    3、当路由被引入到BGP时,如果路由是主类网络的边界时,BGP才会自动汇总 4、使用network命令进行汇总的方法:如下图所示 1)如下图所示,如果使用network进行汇总路由,则明细路由不要引入BGP,否则不会使用汇...
  • EIGRP优化—路由汇总

    千次阅读 2018-03-27 12:52:54
    自动汇总 手动汇总 EIGRP路由汇总 汇总路由会进一步加快EIGRP的收敛时间,假如一台路由器收到一条某个网络查询消息时,而该网络正好被自己路由表中的一条汇总路由所包括,那么它便会立即对此查询进行应答。...
  • 实验拓扑: 在启用RIP 版本2 后得到的 在 R1上的路由表 ...接下来我们关闭自动汇总的功能 no autu-sumay,在R1上得到新的路由表, 还是以 3.3.4.1这个报文为列,路由条目中不存在这条路由,...
  • RIP自动汇总及有无类路由 实验配置: RIPv1 R1#conft R1(conifg)#intf0/0 R1(config-if)#ipadd172.16.1.1255.255.255.0 R1(config-if)#noshutdown R1(config-if)#ints0/0 R1(config-if)#clock...
  • 提示:用router rip命令启用RIP协议,注意RIP协议的版本号设置,在版本2下要关闭自动路由聚合功能,请在network命令中正确书写每台路由器应对外宣告哪些网络号。达到全网可通的目的 在RTA的命令: 在RTB的命令 测试...
  • EIGRP的手动汇总与自动汇总指的是对于路由条目的汇总,也就是路由汇总。比如: 10.10.0.0/24 10.10.1.0/24 …… 10.10.255.0/24 上述路由网段可汇总成10.10.0.0/16 上述的方法采用的是无类域间路由技术(CIDR) 该...
  • 路由配置命令

    2020-12-17 10:01:24
    路由配置命令 文章目录静态路由协议路由RIP配置OSPF路由 (单区域)EIGIP路由交换机SSH配置端口安全(**交换机**)示例:VLAN配置VLAN中继的配置VLAN间路由的配置路由器-单臂路由三层交换机VLAN间路由VTP配置二层交换机...
  • 路由协议基本命令

    2019-05-08 19:08:52
    配置静态路由 交换机A的配置    Ruijie(config)#ip route 172.16.2.0 255.255.255.0 gigabitEthernet 0/1 172.16.1.2              &...
  • HCNA——RIP的路由汇总

    2018-09-20 21:51:59
    HCNA——RIP的路由汇总 RIP V1的路由汇总 路由聚合的原理是,同一个自然网段内的不同子网的...在有类网络的边界自动汇总,并且不能关闭汇总。 PS:VLSM 可变长子网掩码 RIP-2路由聚合 RIP-2支持路由聚合,因为R...
  • RIP路由协议的汇总

    千次阅读 2019-06-23 11:25:38
    RIP路由协议的汇总 当网络中路由器的路由条目非常多时,可以通过路由汇总来减少路由条目数,加快收敛时间和增强网络稳定性。 路由汇总的原理是,同一个自然网段内的不通子网的路由在向外(其他网段)发送时聚合成一...
  • 并传送文件其它配置配置登录标语指定下次启动装载的配置文件指定下次启动装载的配置文件设置下次启动用的文件删除保存的配置文件关闭消息提示功能路由IP配置浮动静态路由描述接口默认(缺省)路由使用带源参数的ping...
  • 配置汇总路由EIGRP的自动汇总功能在有些高版本的IOS中默认是关闭的;在某些低版本的ios中默认是打开的,可以用show running-config|inc rotue查看是否打开。EIGRP自动汇总只针对自己产生的(直连路由路由,对于...
  • 文章目录前言一、ISIS基本原理1.1概述1.2ISIS路由器分类1.3ISIS邻居关系1.4NSAP地址二、ISIS基本配置2.1路由泄露2.2路由重分发2.3路由汇总2.4实验拓扑图2.4实验步骤2.5各路由器配置命令 前言 ISIS是一个分级的链接...
  • eigrp的自动汇总与手工汇总

    千次阅读 2019-04-07 15:41:33
    在eigrp中存在两种汇总方式:自动汇总与手工汇总。...自动汇总,只对内部路由生效 !内部路由就是EIGRP协议宣告的子网,外部网络就是通过重分布等其他方式进入EIGRP协议的路由条目。在默认情况下,e...
  • OSPF路由过滤、汇总和默认路由

    千次阅读 2020-05-18 09:00:20
    OSPF路由过滤、汇总和默认路由 1、路由过滤 1类LSA和2类LSA不能进行过滤,因为链路状态逻辑要求区域内的所有路由器维持完全相同的LSDB;否则会导致SPF无法正常工作和计算出的路由出错。 因此OSPF只有一下过滤方法:...
  • 实验21: EIGRP路由汇总 1.实验目的 通过本实验可以掌握: ...默认的时候EIGRP的自动汇总是开启的,自动汇总只对本地产生的EIGRP路由汇总,可以通过“no auto-summary”命令关闭自动汇总,然后进行手工汇...
  • 华为路由交换基础命令

    千次阅读 2019-07-14 23:00:14
    3、使能自动汇总[V2默认开启,但不生效] [Huawei-rip-1]summary always 或关闭接口水平分割 [接口]undo rip split-horizon 4、手动汇总 [Huawei-GigabitEthernet0/0/0]rip summary-address 聚合后网络 子网掩码 ...
  • VLSM 路由汇总

    2009-10-10 14:43:50
    VLSM 不连续网络 路由汇总 这里要注意的是对“使用了两个掩码”的理解。比方说A类网络10.0.0.0,当他所有的子网都使用255.255.255.0的掩码时,这中设计没有使用VLSM 。如果一个子网使用/24掩码,另一个子网使用/30...
  • 一、RIP路由汇总功能介绍 rip的路由汇总功能,能够对rip 学习/自己产生 的明细路由汇总后传递给rip邻居,减少路由器的路由条目 需要更多网工学习资料,HCIA/HCIP/HCIE学习视频,可以点击:进入群聊 二、RIP应用...
  • Linux命令 汇总

    2018-03-03 09:51:43
    命令功能说明线上查询及帮助命令 (2 个)man查看命令帮助,命令的词典,更复杂的还有 info,但不常用。help查看 Linux 内置命令的帮助,比如 cd 命令。文件和目录操作命令 (18 个)ls全拼 list,功能是列出目录的内容...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,196
精华内容 2,478
关键字:

关闭路由自动汇总的命令