精华内容
下载资源
问答
  • 距离矢量路由协议

    千次阅读 2019-02-03 23:07:50
    距离矢量路由选择协议 大多数的距离矢量协议算法都是基于RE.Bellman ,L.R.Ford 和D.R.Fulkerson算法为基础(EIGRP协议除外)。...距离矢量路由协议中,每台路由器的信息都依赖于邻居路由器,而邻居路由器又依赖...

    距离矢量路由选择协议
    大多数的距离矢量协议算法都是基于RE.Bellman ,L.R.Ford 和D.R.Fulkerson算法为基础(EIGRP协议除外)。
    距离矢量算法的名称的由来是因为路由是以矢量(距离、大小)方式通告出去的。其中距离是根据度量定义的,方向是由下一跳路由器定义的。例如:目标在路由器X方向,距离为5跳。
    距离矢量路由协议中,每台路由器的信息都依赖于邻居路由器,而邻居路由器又依赖于它们的邻居路由器。所以,距离矢量路由协议又被认为是“依照传闻进行路由选择”的协议。
    距离矢量协议的共同属性:
    典型的距离矢量协议都会使用一个路由选择算法。算法中路由器通过广播整个路由表,定期的向所有邻居发送路由更新信息(EIGRP除外)。
    1.定期更新(periodic updates)
    定期更新意味着经过特定时间周期,就要发送更新信息。
    2.邻居(neighbor)
    邻居通常意味着共享相同数据链路的路由器或更高层上的逻辑邻居关系。距离矢量路由协议向邻居发送路由器(只考虑路由器)更新信息,并依靠邻居再向它们的邻居传递更新信息。
    3.广播更新(broadcast updates)
    当路由器被激活时(运行路由协议),它会向网络中发送广播更新信息,使运行相同路由协议的路由器收到广播数据包并做出相应动作。不关心路由更新的主机或运行其他协议的路由器丢弃该数据包。
    4.全路由选择表更新
    大多数距离矢量路由协议使用广播向邻居发送整个路由表。而邻居路由器在接受时,只会选择自己路由表中没有的信息加表,丢弃其他信息。

    依照传闻进行路由选择在这里插入图片描述
    如图,正在执行一个距离矢量算法,度量为跳数。
    T0时刻,路由器A、B、C、D正好可用。此时这四台路由器所具有的唯一信息就是它们各自的直连网络。路由器标识了这些网络,并且指明了它们直连链路,所以跳数为0.每台路由器都将向它的所有邻居广播这些信息。
    T1时刻,路由器接受并处理第一个更新信息。查看A的路由表,路由器B发送给路由器A的更新信息指明B可以到达10.1.2.0和10.1.3.0网段,并且跳数为0.距离B为0跳,那么距离A就为1跳。所以路由器A将跳数+1。然后A对比自己的路由表发现已经有10.1.2.0网段,并且距离为0跳。A就只把10.1.3.0这个自己没有的网段路由加表,指定下一跳为10.1.2.2跳数为1。
    T2时刻,随着更新周期再次到期,另一组更新消息被广播。路由器B向路由器A发送了最新的路由表信息。路由器再次将B路由器通告的路由跳数+1,然后对比自己路由表,将自己没有的10.1.4.0加表,下一跳为10.1.2.2,跳数为2。
    T3时刻,网络收敛完成。每台路由器都已经知道了每个网络以及下一跳和距离跳数。

    距离矢量算法的保障机制:
    1.路由失效计时器
    我们在已收敛的网络中,当一条链路故障时,该链路的直连路由器会发送更新信息,使网络重新收敛。
    但是,当一台路由器出现故障,没设备发消息,但在其他路由器中关于故障路由器链路的路由依然存在,其他路由器会正常的路由转发数据给不存在的故障路由器,这样就形成了路由黑洞。所以为了防止这种名存实亡的现象。路由器会为路由表中每条路由设置一个失效计时器。若路由器在路由项失效计时器失效前收到了该路由的更新消息,就将失效计时器复位;若失效计时器超时了还没收到更新信息,就将该路由标为不可达,并将在下一个更新周期时传递该消息给其他路由器。
    2.水平分割
    路由的指向和数据的流向相反的路由就逆向路由(reverse route).
    水平分割(split horizon)是一种在两台路由器之间阻止逆向路由的技术。这样做不仅节约了资源,而且能阻止将一台路由器发送的路由更新再输入到该路由器中。
    我们将在两台或多台路由器之间的数据循环叫做路由环路。
    执行水平分割可以阻止邻居间的环路产生。
    水平分割分为两种:
    (1)简单水平分割,采用抑制消息的方式。
    (2)毒性逆转水平分割:将超时路由设为不可达(例如将跳数设为16跳)的更新消息发送给邻居。邻居接收以后做修改并向所有邻居发送更新消息(也包括给发送的路由器)。这样做的目的有两个:一是传递网络不可达消息,二是表示自己收到了这个消息(隐式确认)。
    3.计数无穷大
    水平分割可以阻止邻居间的环路,但不能阻止网络中的环路。
    当网络中某条路由出现环路后,该条路由在不断的更新过程中度量会变大,趋于无穷时,网络中的路由器会认为该网络不可达(RIP中16跳就是不可达)。但这样网络的收敛速度还是很慢。
    4.触发更新
    触发更新(Triggered Update)又叫快速更新。原理:如果一个度量变好或变坏。那么路由器将立即发送更新信息,而不等更新计时器超时。这样重新收敛的速度会比每台路由器必须等待更新周期要快,而且可以大大减少更新到无穷大所引发的问题,虽然不能完全消除。
    虽然触发更新能更快的发送更新信息,但在重收敛的过程中还是会发生混乱和路由错误。
    5.抑制计时器
    触发更新为正在重新收敛的网络提供了应变能力。重收敛时为了降低接收错误路由选择信息的可能性。抑制计时器引入某种怀疑量。
    如果一个目标的度量增加,那么路由器将为路由设置抑制计时器。直到计时器超时,路由器才会接受该路由相关信息。
    6.异步更新
    防止路由器同时发送更新信息造成链路拥塞,影响系统时延。
    维护路由异步更新的方法:
    (1)每台路由器的更新计时器独立于路由选择进程,因而不会受到路由器处理负载的影响。
    (2)在每个周期更新中加入一个小的随机时间或定时抖动作为时间偏移。
    如果路由器实现了严格的,独立于系统的计时方法,那么还必须按照随机的方式激活。共享一个广播网络内的所有路由器。因为并组启动整组路由器(如大面积断电),可能会造成所有路由器同时发送更新信息。
    如果随机变量与共享网络的路由器数量相比足够大,那么更新周期的随机性是有效的。在足够大的网络中,过小的随机化会被路由器所克服,为了保证有效性,更新计时器应该分布在中等更新周期的50%的范围内。

    展开全文
  • 距离矢量路由协议与链路状态路由协议的区别以及分类
  • 距离矢量路由协议中路由环路问题的解决方法概括来讲,主要分为六种:定义最大值、水平分割技术、路由中毒、反向路由中毒、控制更新时间、触发更新。本文一一讲解了各种解决方法的实现原理。
  • R1: enable config terminal host r1 no ip domain-lookup int f0/0 ip address 10.0.1.2 255.255.255.0 no shut exit int f0/1 ip address 192.168.2.1 255.255.255.0 no shut exit router rip //rip协议,...

    一:按rip默认的version 1配置:

    1:拓扑结构图

    2:配置代码

    R1:
    enable
    config terminal
    host r1
    no ip domain-lookup
    int f0/0
    ip address 10.0.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.2.1 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 10.0.1.0 
    network 192.168.2.0 
    exit
    
    R2:
    enable
    config terminal
    host r2
    no ip domain-lookup
    int f0/0
    ip address 192.168.2.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.3.1 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 192.168.2.0 
    network 192.168.3.0 
    exit
    
    R3:
    enable
    config terminal
    host r3
    no ip domain-lookup
    int f0/0
    ip address 192.168.3.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 10.0.2.2 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 192.168.3.0 
    network 10.0.2.0 
    Exit

    3:配置结果与截图

    R1#show ip route

    R2#show ip route

    R3#show ip route

    PC1:

    PC2:

    分析过程和PC1的完全一样

     

    二:按rip默认的version 2配置:

    1:拓扑结构图

    2:配置代码

    R1:
    enable
    config terminal
    host r1
    no ip domain-lookup
    int f0/0
    ip address 10.0.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.2.1 255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 10.0.1.0 
    network 192.168.2.0 
    exit
    
    R2:
    enable
    config terminal
    host r2
    no ip domain-lookup
    int f0/0
    ip address 192.168.2.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.3.1 255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 192.168.2.0 
    network 192.168.3.0 
    exit
    
    R3:
    enable
    config terminal
    host r3
    no ip domain-lookup
    int f0/0
    ip address 192.168.3.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 10.0.2.2  255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 192.168.3.0 
    network 10.0.2.0 
    Exit

    3:配置结果与截图

    R1#show ip route

    R2#show ip route

    R3#show ip route

    PC1:

    PC2:过程同PC1

    展开全文
  • 学习笔记:动态路由协议,距离矢量路由协议RIP(原理及配置) 1.动态路由 基于某种路由协议实现 特点: 减少了管理任务 占用了网络带宽 1.1基础 动态路由协议概述 路由器之间用来交换信息的语言 度量值 跳数...

    学习笔记:动态路由协议,距离矢量路由协议RIP(原理及配置)


    1.动态路由

    • 基于某种路由协议实现

    特点:

    • 减少了管理任务
    • 占用了网络带宽

    1.1基础

    动态路由协议概述

    • 路由器之间用来交换信息的语言

    度量值

    • 跳数、带宽、负载、时延、可靠性、成本

    收敛

    • 是所有路由表都达到一致状态的过程

    静态路由和动态路由的比较

    • 网络中静态路由和动态路由互相补充

    1.2分类

    按照路由执行的算法分类 

    • 距离矢量路由协议 

    依据从源网络到目标网络所经过的路由器的个数选择路由 

    RIP(距离矢量路由协议)、IGRP(思科私有的内部网关路由协议) 

    • 链路状态路由协议 

    综合考虑从源网络到目标网络的各条路径的情况选择路由

     OSPF(开放式最短路径优先链路状态路由协议)、IS-IS(中间系统到中间系统路由协议)

    2.RIP路由协议工作原理

    • RIP是距离-矢量路由选择协议
    •  RIP的基本概念

           定期更新 (30s)

           邻居

           广播更新

           全路由表更新

    • 路由表的形成:

    • 度量值为跳数

    最大跳数为15跳,16跳为不可达

    • RIP更新时间

    每隔30s发送路由更新消息,UDP520端口

    • RIP路由更新消息

    发送整个路由表消息

    3.RIP的配置和验证

    思考题:简述水平分割的作用?

    •       水平分割是在距离矢量路由协议中最常用的避免环路发生的解决方案之一。
    •       产生环路的一种情况是:路由器A将从路由器B学习到的路由信息又告诉给了路由器B。最终,路由器B认为通过路由器A能够到达目标网络,路由器A认为通过路由器B能够到达目标网络。路由数据包的时候,数据将在两个路由器间不停地循环,直至TTL的值为0,将此数据包丢弃。
    • 水平分割的思想就是:在路由信息传送过程中,不再把路由信息发送到接收到此路由信息的接口上。从而在一定程度上避免了环路的产生。

    启用水平分割:ip split-horizon

    禁用水平分割:no ip split-horizon

    附:上述命令在接口模式下配置。

     

    这里的配置选择v2并且关闭了路由自动汇总

     

     

     

     

     

     

    展开全文
  • 距离矢量路由协议——RIP

    千次阅读 2018-03-27 20:49:00
    距离矢量路由协议RIP:   众所周知,RIP(Routing Information Protocol),即路由信息协议,是一种距离矢量路由协议,它与IGRP,OSPF等一样都是属于IGP(Interior Gateway Protocol)——内部网关协议,它是一种...

    距离矢量路由协议RIP: 

      众所周知,RIP(Routing Information Protocol),即路由信息协议,是一种距离矢量路由协议,它与IGRP,OSPF等一样都是属于IGP(Interior Gateway Protocol)——内部网关协议,它是一种历史很悠久的协议,但是迄今为止,RIP还在小型网络中很流行,因为它是基于跳数来对路径进行度量的(仅仅只靠跳数来进行度量也成为了RIP为人所诟病的地方),这样使得RIP相比之下显得最简单,并且大多数的路由器也都支持RIP。 RIP路由更新周期为30秒,无效时间是180秒,也就是说在180秒之内没有收到路由更新,将把路由置为无效,RIP把每经过一个路由器称为经过了一跳,而每经过一跳,RIP就会将它的度量值(metric)加1,这样的话,跳数越多则路径越长,而RIP会优先选择一条到达目标网络跳数少的路径,它支持的最大跳数是15跳,超过15跳则被认为是不可达。RIP用两种数据包传输更新:请求和更新,每个有RIP 功能的路由器默认情况下每隔30 秒利用UDP 的520 端口向与它直连的网络邻居广播(RIP v1)或组播(RIP v2)路由更新。因此路由器不知道网络的全局情况,如果路由更新在网络上传播慢,将会导致网络收敛较慢,造成路由环路。为了避免路由环路,RIP 采用水平分割、路由毒化和毒性逆转、定义最大跳数、触发更新、抑制计时器5个机制来避免路由环路。

    RIP 协议分为版本1 和版本2。不论是版本1 或版本2,都具备下面的特征:

      1. 是距离矢量路由协议;

      2. 使用跳数(Hop Count)作为度量值;

      3.默认路由更新周期为30 秒;

      4. 管理距离(AD)为120;

      5. 支持触发更新;

      6. 最大跳数为15 跳;

      7. 支持等价路径,默认4 条,最大6 条;

      8. 使用UDP 520 端口进行路由更新。

     

    RIPv2的特性:基于RIPv1,在本质上是具有内建路由选择增强的距离向量协议,RIPv2使用组播而不是广播,支持触发更新,是无类的协议,还支持认证,支持不连续的子网和VLSM,可以关闭自动汇总,支持手动汇总。

     

    RIPV1和RIPV2的区别:

     

         

    RIP的路由环路:

    原因:

           假设R1,R2是邻居。因为路由表每30s从邻居收到信息更新一次。如果R2向某网络地址的端口坏掉(R2路由表中直接删掉这条信息),但还没到30s它就不会向它的直接邻居R1发通告说:我这边已经走不通了。此时R1带着网口坏掉以前的路由表来告诉R2。R2查找自身,R1路由表中原来从R2获取到的信息现在R2没有了,R2就将这条路由信息加入进来,形成环路。

    解决办法:

      1. 定义最大跳计数  

      2. 水平分割(Split Horizon)

      3. 路由中毒(Router Poisoning)和毒性反转

      4. 触发更新(Triggered Updates)

      5. 抑制定时器

    RIP的基本命令:

      Router0(config)#router rip (启动动态路由协议RIP)

      Router0(config-router)#network [网络号] (通告有类网络)

      Router0#show ip route (查看路由表信息)

      Router1(config)#router rip

      Router1(config-router)#passive-interface fa0/0(配置被动接口,该接口不再向外发送路由更新包,但仍然会接收其它路由器发过来的路由更新包。)

     

    RIPV1不支持不连续的子网实验:

          

      上图路由器均用RIP配置的话,那么RIPv1默认自动路由聚合,那么不同子网的192.168.1.1/25和192.168.1.129/25就会自动聚合成192.168.1.0/24从而在R2的路由表中就会有通向192.168.1.0/24的两条地址。

    RIPV2支持不连续的子网:

      

      Router(config)# router rip

      Router(config-router)# version 2         配置RIP v2版本

      Router(config-router)# no auto-summary  关闭自动汇总,路由器在主类网络的边

      

    展开全文
  • 浅谈距离矢量路由协议与链路路由协议的区别!!!
  • 一:三层交换机和路由器上都使用RIP动态路由协议version 1; 二:把网段192.168.3.0/24的网段改为10.1.1.0/24,网段192.168.5.0/24的网段改为10.1.2.0/24,计算机和路由接口地址都相应变化,看看可达性情况; 三:...
  • 一:三层交换机和路由器上都使用RIP动态路由协议version 1; 二:把网段192.168.3.0/24的网段改为10.1.1.0/24,网段192.168.5.0/24的网段改为10.1.2.0/24,计算机和路由接口地址都相应变化,看看可达性情况; 三:...
  • 距离矢量路由协议和链路状态路由协议 距离矢量路由协议: 运行距离矢量协议的路由器,会与邻居共享它知道的所有路由信息,但只是与它的直连邻居共享。距离是根据度量值来计算的。方向是根据下一跳路由来定义的。...
  • 距离矢量路由协议 VS 链路状态路由协议 什么是距离向量路由协议? 什么是距离向量路由协议? 距离向量路由协议是为小型网络环境设计的.在大型网络环境下,这类协议在学习路由及保持路由将产生较大的流量,占用过多的...
  • RIP距离矢量路由协议

    2021-06-01 11:46:41
    ARP(Addiress Eesolution ...距离矢量协议 度量值(metric):跳数。跳数超过15不可达(半径)。 每30秒收敛一次。 V1使用广播更新,V2使用组播,组播地址224.0.0.9 管理距离(路由协议优先级):120 RI...
  • 距离矢量路由协议(一)

    千次阅读 2019-07-24 15:03:20
    距离矢量路由协议(一)---相关概念简介 距离矢量路由协议包括 RIP、IGRP 和 EIGRP。 RIP RIP(路由信息协议)最初在 RFC 1058 中定义。主要有以下特点: .使用跳数作为选择路径的度量。 .如果某...
  • 距离矢量路由协议主要会产生2个问题,无限计数和路由环路问题。当然也有相应的解决办法。1.无限计数问题及解决方法请看下列拓扑图:假设初始状态R0、R1、R2构成的网络已经收敛,当10.4.0.0这个网络出现问题时,R2...
  • 距离矢量路由协议中路由环路问题的解决方法:.txt距离矢量路由协议中路由环路问题的解决方法:.txt距离矢量路由协议中路由环路问题的解决方法:.txt
  • 距离矢量路由协议和链路状态路由协议相比,前者是依照“传闻”来进行路由选择,而后者是每台路由器独立地计算最优路径。 详细地说,每台运行了链路状态路由协议的路由器会和它的邻居建立邻接关系并且互相给自己的每...
  • 距离矢量路由协议-RIP详解

    千次阅读 2020-06-05 11:29:31
    距离矢量路由协议概述: 路由信息协议RIP(Routing Information Protocol)的简称,它是一种基于距离矢量(Distance-Vector)算法的协议,使用跳数作为度量来衡量到达目的网络的距离。RIP主要应用于规模较小的网络中...
  • 动态路由 概述:路由器之间用来交换信息的语言。动态路由能够自动地建立自己的路由表,并且能够根据实际情况的变化(根据具体...1.距离矢量路由协议:(主要根据跳数) 传说路由,一个告诉一个。 依据从源网络到目标网
  • 华为培训课件:HC110113002 距离矢量路由协议-RIP.ppt
  • distanc_vector 数据网络中的距离矢量路由协议根据距离确定数据包的最佳路由。
  • RIP是一种距离矢量路由协议,属于IGP协议。 1.2 适用范围 RIP协议适用于中小型网络,有RIPv1和RIPv2两种。 1.3 端口 使用UDP进行路由信息的交互,端口号为520. 二、特性 RIP支持水平分割,毒性逆转和触发更新。 2.1 ...
  • 动态路由距离矢量路由协议RIP

    千次阅读 2015-03-02 20:03:28
    动态路由距离矢量路由协议RIP R1连接R2连接R3 R1 ip192.168.12.1 R2 ip192.168.12.2,192.168.23.2 R3 ip192.168.23.3,lo:3.3.3.3 R1(config)#int s0/0 R1(config-if)#ip add 192.168.12.1 255.255.255.0 R1...
  • 距离矢量路由协议RIP

    2012-06-19 20:03:17
    距离矢量路由协议RIP RIP 动态路由协议 版本1 版本2 版本1---有类路由协议----更新时不带掩码---不支持可变长子网掩码,不支持不连续的网络---发送与接收原则 版本2---无类路由协议----更新时带掩码----...
  • 什么是路由环路? 路由环路是指数据包在一系列路由器之间不断传输却始终无法到达其预期目的网络的一种现象。当两台或多台路由器的路由信息中存在错误地指向不可达...距离矢量路由协议的工作方式比较简单。其简单...
  • 新的基于优先级的混合距离矢量路由协议 (PBHDV) 是基于优先级的上述两种协议的混合。 PBHDV 的新方法提高了数据包交付率,最大限度地减少了端到端延迟并提高了吞吐量。 所提出的方法已在 NS2 中实现和测试,并与...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,720
精华内容 3,088
关键字:

典型的距离矢量路由协议是