精华内容
下载资源
问答
  • 交换机VLAN接口IP地址配置

    千次阅读 2011-03-08 22:16:00
    交换机VLAN接口IP地址配置 一、交换机VLAN接口静态IP地址配置 交换机VLAN接口静态IP地址配置 功能 需求及组网说明 『配置环境参数』 1. SwitchA 三层交换机 2. PC1 连接到 SwitchA 的...

    交换机VLAN接口IP地址配置

    一、交换机VLAN接口静态IP地址配置

    交换机VLAN接口静态IP地址配置 功能 需求及组网说明

    『配置环境参数』

    1. SwitchA 为三层交换机

    2. PC1 连接到 SwitchA 的以太网端口 E0/1 ,属于 VLAN10

    3. PC2 连接到 SwitchA 的以太网端口 E0/2 ,属于 VLAN20

    4. SwitchA VLAN 接口 10 IP 地址为 10.1.1 .1/24 VLAN 接口 20 IP 地址为 20.1.1.1/24 ,分别作为 PC1 PC2 的网关

    『组网需求』

    PC1 PC2 可以通过 SwitchA 进行互通数据配置步骤

    VLAN 接口静态 IP 地址配置流程』

    创建 VLAN 接口,并配置 IP 地址。

    SwitchA 相关配置】

    1. 创建(进入) VLAN10

    [SwitchA]vlan 10

    2. E0/1 加入到 VLAN10

    [SwitchA-vlan10]port Ethernet 0/1

    3. 创建(进入) VLAN 接口 10

    [SwitchA]interface Vlan-interface 10

    4. VLAN 接口 10 配置 IP 地址

    [SwitchA-Vlan-interface10]ip address 10.1.1 .1 255.255.255.0

    5. 创建(进入) VLAN20

    [SwitchA]vlan 20

    6. E0/2 加入到 VLAN20

    [SwitchA-vlan20]port Ethernet 0/2

    7. 创建(进入) VLAN 接口 20

    [SwitchA]interface Vlan-interface 20

    8. VLAN 接口 20 配置 IP 地址

    [SwitchA-Vlan-interface20]ip address 20.1.1 .1 255.255.255.0

    【补充说明】

    交换机的 VLAN 虚接口承载在物理端口之上,即某 VLAN 所包含的物理端口 UP 之后,该 VLAN 虚接口才会 UP 。 对于三层交换机,可以为多个 VLAN 接口配置 IP 地址,而且默认情况下各个 VLAN 接口之间可以访问;对于二层交换机来说,为 VLAN 接口配置的 IP 地址只能用于管理。

     

    二、VLAN接口动态获取IP地址配置

    『配置环境参数』

    1.SwitchA为二层交换机,管理VLANVLAN10

    2.SwitchA的以太网端口E0/1Trunk端口,连接到SwitchB,同时SwitchB提供DHCP Server功能

    『组网需求』

    SwitchAVLAN接口10动态获取IP地址数据

    配置步骤

    VLAN接口动态获取IP地址配置流程』

    VLAN接口上配置动态获取IP地址。

    SwitchA相关配置】

    1.E0/1端口设为trunk,并允许所有的vlan通过

    [SwitchA-Ethernet0/1]port link-type trunk

    [SwitchA-Ethernet0/1]port trunk permit vlan all

    2.创建(进入)VLAN10

    [SwitchA]vlan 10

    3. 创建(进入)VLAN接口10

    [SwitchA]interface Vlan-interface 10

    4. VLAN接口10配置IP地址

    [SwitchA-Vlan-interface10]ip address dhcp-alloc

    【补充说明】

    虽然交换机的VLAN接口动态获取了IP地址,但是不能获得网关地址,因此还需要在交换机上手工添加静态默认路由。

     

    展开全文
  • Cisco 交换机 VLAN接口IP地址配置

    千次阅读 2012-06-19 13:36:20
    一、交换机VLAN接口静态IP地址配置 交换机VLAN接口静态IP地址配置 功能 需求及组网说明 『配置环境参数』 1. SwitchA 三层交换机 2. PC1 连接到 SwitchA 的以太网端口 E0/1 ,属于 VLAN10 3. PC2 连接到 ...
    交换机VLAN接口静态IP地址配置 功能 需求及组网说明
    『配置环境参数』
    1. SwitchA 为三层交换机
    2. PC1 连接到 SwitchA 的以太网端口 E0/1 ,属于 VLAN10
    3. PC2 连接到 SwitchA 的以太网端口 E0/2 ,属于 VLAN20
    4. SwitchA 的 VLAN 接口 10 的 IP 地址为 10.1.1 .1/24 , VLAN 接口 20 的 IP 地址为 20.1.1.1/24 ,分别作为 PC1 和 PC2 的网关
    『组网需求』
    PC1 和 PC2 可以通过 SwitchA 进行互通数据配置步骤
    『 VLAN 接口静态 IP 地址配置流程』
    创建 VLAN 接口,并配置 IP 地址。
    【 SwitchA 相关配置】
    1. 创建(进入) VLAN10
    [SwitchA]vlan 10
    2. 将 E0/1 加入到 VLAN10
    [SwitchA-vlan10]port Ethernet 0/1
    3. 创建(进入) VLAN 接口 10
    [SwitchA]interface Vlan-interface 10
    4. 为 VLAN 接口 10 配置 IP 地址
    [SwitchA-Vlan-interface10]ip address 10.1.1 .1 255.255.255.0
    5. 创建(进入) VLAN20
    [SwitchA]vlan 20
    6. 将 E0/2 加入到 VLAN20
    [SwitchA-vlan20]port Ethernet 0/2
    7. 创建(进入) VLAN 接口 20
    [SwitchA]interface Vlan-interface 20
    8. 为 VLAN 接口 20 配置 IP 地址
    [SwitchA-Vlan-interface20]ip address 20.1.1 .1 255.255.255.0
    【补充说明】
    交 换机的 VLAN 虚接口承载在物理端口之上,即某 VLAN 所包含的物理端口 UP 之后,该 VLAN 虚接口才会 UP 。 对于三层交换机,可以为多个 VLAN 接口配置 IP 地址,而且默认情况下各个 VLAN 接口之间可以访问;对于二层交换机来说,为 VLAN 接口配置的 IP 地址只能用于管理。
    二、VLAN接口动态获取IP地址配置
    『配置环境参数』
    1.SwitchA为二层交换机,管理VLAN为VLAN10
    2.SwitchA的以太网端口E0/1为Trunk端口,连接到SwitchB,同时SwitchB提供DHCP Server功能
    『组网需求』
    SwitchA的VLAN接口10动态获取IP地址数据
    配置步骤
    『VLAN接口动态获取IP地址配置流程』
    在VLAN接口上配置动态获取IP地址。
    【SwitchA相关配置】
    1.将E0/1端口设为trunk,并允许所有的vlan通过
    [SwitchA-Ethernet0/1]port link-type trunk
    [SwitchA-Ethernet0/1]port trunk permit vlan all
    2.创建(进入)VLAN10
    [SwitchA]vlan 10
    3.创建(进入)VLAN接口10
    [SwitchA]interface Vlan-interface 10
    4.为VLAN接口10配置IP地址
    [SwitchA-Vlan-interface10]ip address dhcp-alloc
    【补充说明】
    虽然交换机的VLAN接口动态获取了IP地址,但是不能获得网关地址,因此还需要在交换机上手工添加静态默认路由。

    转载于:https://blog.51cto.com/cisco130/902688

    展开全文
  • 三层交换的原理以及DHCP的原理,作者在这里就不详细的解释了,在这里通过一个...1、在SW1上配置DHCP服务,能够以下四个不同部门分配不同网段的IP地址。 2、在SW1上配置VTP Server,在SW2和SW3上配置VTP Client,...

    三层交换的原理以及DHCP的原理,作者在这里就不详细的解释了,在这里通过一个案例来了解使用三层交换做DHCP服务器,并为不同网段分配IP地址。在生产环境中,使用路由器或交换机做DHCP服务器要常见一些。

    实验要求:

    1、在SW1上配置DHCP服务,能够为以下四个不同部门分配不同网段的IP地址。

    2、在SW1上配置VTP Server,在SW2和SW3上配置VTP Client,并将指定部门加入相关VLAN。

    3、注意:交换机和交换机之间使用中继链路,而与路由器之间则不需要

    详细配置信息如下:

    R1配置如下:

     1 #配置路由器内网接口IP和外网接口IP
     2 R1(config)#int f0/0
     3 R1(config-if)#ip add 10.0.0.2 255.0.0.0
     4 R1(config-if)#no sh
     5 R1(config-if)#no shutdown
     6 R1(config-if)#exit
     7 R1(config)#int f1/0
     8 R1(config-if)#ip add 202.106.123.1 255.255.255.248
     9 R1(config-if)#no sh
    10 R1(config-if)#no shutdown
    11 #配置到内网的静态路由条目
    12 R1(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1
    13 R1(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.1
    14 R1(config)#ip route 192.168.3.0 255.255.255.0 10.0.0.1
    15 R1(config)#ip route 192.168.4.0 255.255.255.0 10.0.0.1

    SW1配置如下:

     1 #配置到路由器接口的IP地址
     2 SW1(config)#ip routing
     3 SW1(config)#int f0/0
     4 SW1(config-if)#no switchport
     5 SW1(config-if)#ip add 10.0.0.1 255.0.0.0
     6 SW1(config-if)#no shutdown
     7 #配置交换机之间的接口链路为中继链路(trunk)
     8 SW1(config)#int range f0/1 -2
     9 SW1(config-if-range)#switchport mode trunk
    10 SW1(config-if-range)#no sh
    11 #配置VTP Server
    12 SW1#vlan database
    13 SW1(vlan)#vtp domain test
    14 SW1(vlan)#vtp server
    15 SW1(vlan)#vtp password 123
    16 SW1(vlan)#vtp pruning
    17 #创建vlan(为四个部门创建不同的vlan)
    18 SW1#vlan database
    19 SW1(vlan)#vlan 10
    20 SW1(vlan)#vlan 20
    21 SW1(vlan)#vlan 30
    22 SW1(vlan)#vlan 40
    23 #配置vlan虚拟接口地址
    24 SW1(config-if)#intvlan 10
    25 SW1(config-if)#ip add 192.168.1.1 255.255.255.0
    26 SW1(config-if)#no sh
    27 SW1(config-if)#exit
    28 SW1(config-if)#intvlan 20
    29 SW1(config-if)#ip add 192.168.2.1 255.255.255.0
    30 SW1(config-if)#no sh
    31 SW1(config-if)#exit
    32 SW1(config-if)#intvlan 30
    33 SW1(config-if)#ip add 192.168.3.1 255.255.255.0
    34 SW1(config-if)#no sh
    35 SW1(config-if)#exit
    36 SW1(config-if)#intvlan 40
    37 SW1(config-if)#ip add 192.168.4.1 255.255.255.0
    38 SW1(config-if)#no sh
    39 #注意:如果要配置DHCP中继服务,需要在vlan虚接口中添加一条DHCP服务器的地址SW1(config-if)#ip helper-address [DHCP服务器地址]
    40 #配置一条默认路由,使能够访问外网
    41 SW1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2
    42 #配置不同网段的DHCP地址池(因为有四个vlan,所以要配四个网段地址池)
    43 SW1(config)#ipdhcp pool vlan10
    44 SW1(dhcp-config)#network 192.168.1.0 255.255.255.0
    45 SW1(dhcp-config)#default-router 192.168.1.1
    46 SW1(dhcp-config)#dns-server 202.106.0.20
    47 SW1(dhcp-config)#lease 2
    48 SW1(dhcp-config)#exit
    49 SW1(config)#ipdhcp pool vlan20
    50 SW1(dhcp-config)#network 192.168.2.0 255.255.255.0
    51 SW1(dhcp-config)#default-router 192.168.2.1
    52 SW1(dhcp-config)#dns-server 202.106.0.20
    53 SW1(dhcp-config)#lease 2
    54 SW1(dhcp-config)#exit
    55 SW1(config)#ipdhcp pool vlan30
    56 SW1(dhcp-config)#network 192.168.3.0 255.255.255.0
    57 SW1(dhcp-config)#default-router 192.168.3.1
    58 SW1(dhcp-config)#dns-server 202.106.0.20
    59 SW1(dhcp-config)#lease 2
    60 SW1(dhcp-config)#exit
    61 SW1(config)#ipdhcp pool vlan40
    62 SW1(dhcp-config)#network 192.168.4.0 255.255.255.0
    63 SW1(dhcp-config)#default-router 192.168.4.1
    64 SW1(dhcp-config)#dns-server 202.106.0.20
    65 SW1(dhcp-config)#lease 2
    66 #注意:如果要设置保留地址可以配置ipdhcp excluded-address low-address [high-address]
    View Code

    SW2配置如下:

     1 #配置与三层交换的链路为中继链路(trunk)
     2 SW2(config)#int f0/0
     3 SW2(config-if)#switchport mode trunk
     4 SW2(config-if)#no sh
     5 #配置VTP client(配置完VTP client后能够学习三层交换上创建的vlan)
     6 SW2#vlan database
     7 SW2(vlan)#vtp domain test
     8 SW2(vlan)#vtp client
     9 SW2(vlan)#vtp password 123
    10 SW2(vlan)#vtp pruning
    11 #将指定的接口加入到相应的vlan中
    12 SW2(config)#int f0/1
    13 SW2(config-if)#switchport access vlan 10
    14 SW2(config-if)#no sh
    15 SW2(config-if)#exit
    16 SW2(config-if)#int f0/2
    17 SW2(config-if)#switchport access vlan 20
    18 SW2(config-if)#no sh

    SW3配置如下:

     1 #配置与三层交换的链路为中继链路(trunk)
     2 SW3(config)#int f0/0
     3 SW3(config-if)#switchport mode trunk
     4 SW3(config-if)#no sh
     5 #配置VTP client(配置完VTP client后能够学习三层交换上创建的vlan)
     6 SW3#vlan database
     7 SW3(vlan)#vtp domain test
     8 SW3(vlan)#vtp client
     9 SW3(vlan)#vtp password 123
    10 SW3(vlan)#vtp pruning
    11 #将指定的接口加入到相应的vlan中
    12 SW3(config)#int f0/1
    13 SW3(config-if)#switchport access vlan 30
    14 SW3(config-if)#no sh
    15 SW3(config-if)#exit
    16 SW3(config-if)#int f0/2
    17 SW3(config-if)#switchport access vlan 40
    18 SW3(config-if)#no sh

    配置完以上的所有配置后,在客户端将IP地址设置为DHCP自动获取,就可以获取相应的IP了,并且可以访问互联网了

    感谢投稿:皮百万

    如有问题请联系:

    转载于:https://www.cnblogs.com/Smbands/p/10148882.html

    展开全文
  • 在不同的IP地址段的路由选项设定对应VLAN的网关地址,那么不同VLAN就可以得到相应的IP二、核心交换机配置(三层交换Cisco 3560)1、建立VLANswitch(Config)#vlan 2switch(Config)#vlan 32、设...


    网络拓扑

    7d9fe52a0bb1500634ce90e47e56924c.png-wh_

     

     

    一、DHCP服务器配置(Windows2008)

    1、DHCP服务器上建立三个作用域

    spacer.gif 

    2DHCP服务器路由设定

      在不同的IP地址段的路由选项设定对应VLAN的网关地址,那么不同VLAN就可以得到相应的IP

    二、核心交换机配置(三层交换Cisco 3560)

    1、建立VLAN

    switch(Config)#vlan 2

    switch(Config)#vlan 3

    2、设置VLAN IP地址并指定DHCP服务器地址

    switch(Config)#interface vlan 

    switch(Config-if)#ip address IP地址”

    switch(Config)#ip helper-address "dhcp server IP"

    三、在接入式交换机设置端口全局参数

    switch(config)#interface range fa 0/1 - 24

    switch(config-if-range)#switchport mode access 

    switch(config-if-range)#spanning-tree portfast

                                 


    转载于:https://blog.51cto.com/422621/1977745

    展开全文
  • 在不同的IP地址段的路由选项设定对应VLAN的网关地址,那么不同VLAN就可以得到相应的IP二、核心交换机配置(三层交换Cisco 3560)1、建立VLANswitch(Config)#vlan 2switch(Config)#vlan 32、设置VLAN IP地址并指定DH....
  • 一台 DHCP 多个不同VLAN分配IP地址

    万次阅读 2013-05-16 22:14:17
    就需要用一个DHCP服务器(windows nt/2000/2003 或都三层Swith内置)同时多个VLAN分配IP地址.不同的子网分配不同的网关.本文本只说明方法,不具体操作,每个Swith 里操作不一样!  首先不要被应用需求误导.要对DH
  • GNS3划分vlan配置DHCP,让PC动态获取ip地址 拓扑图 主要配置 配置路由器R1、R2、R3的ip地址 三层交换机划分vlan 在交换机上配置不与PC相连接口trunk模式,与PC相连的设置access模式 在R1和R2上配置...
  • vlan3 IP地址 192.168.6.1(作用域vlan3网关) vlan4 IP地址 192.168.10.1(作用域vlan4网关) vlan5 IP地址 192.168.100.1(作用域vlan5网关) vlan6 IP地址 192.168.200.1(作用域vlan6网关) vlan3-5绑定mac...
  • eNspVlan配置

    2020-08-28 09:40:49
    二层交换机1-2口划分到VLAN 100;...PC1的IP地址为100.100.学号.1,PC2的IP地址为100.100.学号.2, PC3的IP地址为200.200.学号.1,PC4的IP地址为200.200.学号.2。 配置后实现PC1、PC2、PC3、PC4之间能够互通。
  • 利用三层交换机自带的DHCP功能实现多VLANIP地址自动分配 (一) 配置方法一 1.同时多个VLAN的客户机分配地址 2.VLAN内有部分地址采用手工分配的方式 3.客户指定网关、Wins服务器等 4.VLAN 2的地址租用有效...
  • vlan配置

    2018-08-30 20:57:45
    先配好IP地址如下图配置第1台交换机进路由器创建vlan命令system-view 进入系统视图Huawei]vlan 10 创建的vlan10 Huawei]vlan 5 创建的 vlan 5每个都是没人的vlan 1[Huawei]interface Ethernet. 进入接口 的命令后面...
  • 前言VLAN作为数通领域最基础的技术,项目中使用非常多,那么VLAN如何配置呢,下面以华为交换机例,大家介绍VLAN配置。1. 本拓扑包含两台交换机及四台PC; 2. 四台PC分别被规划到两个VLAN,VLAN10及VLAN20; 3. ...
  • 中兴交换机配置vlan地址

    千次阅读 2019-09-18 07:35:26
    中兴交换机配置vlan地址命令:config terswitch vlan configvlan XXXexitinterf vlan XXXip add 1.1.1.1 255.255.255.0 瑞士康达传输登录方式:网线接入SNMP口电脑配置为192.168.4.1/24Telnet 192.168.4.28raisecom/...
  • 之前讨论的都是思科的,今天咱们具体讨论内容包含VLAN级联的静态配置; 通过GVRP协议实现的VLAN级联的动态配置;...首先按照上图连接各实验设备,然后配置PCA IP地址为10.1.1.2/24,PCB IP地址为10....
  • 利用三层交换机自带的DHCP功能实现多VLANIP地址自动分配 (一) 配置方法一 1.同时多个VLAN的客户机分配地址 2.VLAN内有部分地址采用手工分配的方式 3.客户指定网关、Wins服务器等 4.VLAN 2的地址租用有效期限...
  • 基于IP地址划分VLAN

    万次阅读 2020-05-08 22:31:58
    1、当检测IP在192.168.10.0./24时,PC接入交换机时,将其划分为VLAN 10,且可以和VLAN 10的服务器通信 2、当检测IP在192.168.20.0/24时,PC接入交换机时,将其划分为VLAN 20,且可以和VLAN 20的服务器通信 SW1 <...
  • 交换机的 VLAN1 可以配置管理 IP,路由器的每一个接口都可以配置 IP 地址,基本思路如下: system-view //进系统视图 [ar1] interface g0/0/1 //进接口 g0/0/1 配置 [ar1-GigabitEthernet0/0/1] ip address 192.168...
  • 1.按图示PC配置IP地址 2.SW1和SW2上分别创建vlan10和vlan20,要求PC3和PC5属于vlan10,PC4和PV6属于vlan20 3.SW1和SW2相连的接口配置trunk类型,允许vlan10和vlan20通过 4.测试效果,同一vlan的PC可以互通,不同...
  • 华为路由器交换机VLAN配置实例使用4台PC(pc多和少,原理是一样的,所以这里我只用了4台pc),华为路由器...方案说明:四台PC的IP地址、掩码如下列表:P1192.168.1.1255.255.255.0网关IP192.168.1.5P2192.168.1.2255...
  • 华为交换机vlan配置

    2020-11-12 18:05:28
    Ip add 192.168.xxx.1 255.255.255.0 \为vlan2分配IP地址及子网掩码 Dhcp select global \dhcp选择全局开启 Q \退出 Dhcp enable \全局开启dhcp功能 Ip pool vlan2 \进入vlan2的ip地址池 Gateway-list
  • 目的:使PC-1和PC-3处于同一vlan中,pc-2和pc-4处于同vlan中,首先我们需要各个主机配置在同一网段的IP地址  接下来我们分别配置R1,R2保证他们的通信 R3配置  enable 进入特权模式  conft 进入全局配置...
  • VLAN配置实例

    2020-05-15 15:46:56
    1.PC2/4/5/6处于同一网段–DHCP下放IP地址 PC1/3–使用路由器子接口DHCP下放IP地址 2.满足实验要求: 将PC2划分到VLAN3、可以在同一VALN,也可以在不同VLAN,在这,我是把PC4/PC5都划分到VLAN4、PC6划分到VLAN5
  • 这是查到的一个实例,贴过来,供和我一样有相同在DHCP上疑问的人以参考。实例网络拓扑使用Cisco 3620作为IOS DHCPServer...在整个网络中有二个VLAN简化描述,假设每个VLAN都采用24位网络地址,其中VLAN1的IP地址...
  • DHCP Server多个vlan分配IP

    千次阅读 2017-11-29 14:05:13
    实验内容:1,vlan10和vlan20内的主机能够从远端的DHCP Server中获取IP地址。2,vlan10和vlan20之间能够互相通信。 实验拓扑 实验思路: 三层交换机中要有去往DHCP Server的路由,要创建三个vlan 10 20 1,其中把...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,324
精华内容 529
关键字:

为vlan配置ip地址