精华内容
下载资源
问答
  • 收集的华为系列交换机配置资料电子档,希望对大家有用。
  • 在进行网络设备系统维护时,如升级系统软件、备份配置文件等,均需要进行PC与设备之间的文件传输。通常选择使用FTP/TFTP进行文件传输。下面黄老师给大家介绍一下如何配置PC作为FTP server的方式来传输文件。FTP1.在...

    在进行网络设备系统维护时,如升级系统软件、备份配置文件等,均需要进行PC与设备之间的文件传输。通常选择使用FTP/TFTP进行文件传输。下面黄老师给大家介绍一下如何配置PC作为FTP server的方式来传输文件。

    b4350dce6d1ee87695446bff1452cb82.png

    FTP

    1.在FTP服务器端运行FTP软件,并设置FTP服务的相关信息。

    2.配置设备与FTP服务器之间的网络连接。

    a. 使用网线连接FTP Server与设备的GE0/0/0接口。

    b. 该设备上配置GE0/0/0的IP地址为192.168.0.1/24。

    c. 设置FTP服务器的IP地址为192.168.0.2/24。

    3.< Huawei> system-view

    4. [Huawei] interface gigabitethernet 0/0/0

    5. [Huawei-GigabitEthernet0/0/0] ip address 192.168.0.1 24

    6. [Huawei-GigabitEthernet0/0/0]quit

    7. 在设备上使用FTP登录到服务器(PC)上。

    8. ftp 192.168.0.2 //登陆到网络设备上

    9. User(192.168.0.2:(none)):admin //用户名

    10.Enter password: xxx //密码

    11. 使用put命令将文件上传到FTP Server(PC),或使用get命令从FTP Server下载文件到设备。

    [Huawei-ftp] put vrpcfg.zip

    12. [Huawei-ftp] binary

    13. 200 Type set to I.

    14. [Huawei-ftp] get devicesoft.cc

    bd71db71e14a44737f9c09747072a536.png

    学习更多网络知识,请订阅专栏学习

    展开全文
  • STelnet是Secure Telnet的简称,它通过对用户端的认证及双向数据加密,使网络终端访问提供安全的Telnet服务。 SSH是一个网络安全协议,通过对数据的加密,提供安全原创登录和其他安全服务。SSH数据加密传输,认证...

    STelnet 概述

    STelnet是Secure Telnet的简称,它通过对用户端的认证及双向数据加密,使网络终端访问提供安全的Telnet服务。

    SSH是一个网络安全协议,通过对数据的加密,提供安全原创登录和其他安全服务。SSH数据加密传输,认证机制保障安全,可以替代Telnet,已被广泛使用,是当前重要的网络协议之一。

    SSH基于TCP的22端口传输数据,支持密码认证,用户端向服务器发送密码认证请求,将用户名和密码加密后发送给服务器;服务器将该信息解密后得到用户名和密码的明文,与设备上保存的用户名和密码进行比较,并返回认证安全和失败的信息。

    SFTP全称SSH File Transfer Protocol,服务器通过对用户端的认证及双向的数据加密,为网络文件传输提供了安全的服务。

    SSH模拟实验

    路由器R1模拟PC,作为SSH的Client;路由器R2模拟SSH服务器,模拟远程用户端R1通过SSH协议原创登录到路由器R2上进行配置。

    实验拓扑

    在这里插入图片描述

    配置Stelnet登录实验

    R1

    配置Client客户端
    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]sys R1
    [R1]interface g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 10.1.1.1 24
    [R1-GigabitEthernet0/0/0]quit
    [R1]ssh client first-time enable  /先配置Server在配置客户端
    [R1]stelnet 10.1.1.254            /后连接
    

    R2

    SSH登录的首要操作是配置并产生本地rsa密钥对(保存后,重启也不会丢失),在vty界面,设置用户登录验证方式为aaa,指定vty类型用户界面只支持ssh协议(默认将telnet关闭),用local-user创建本地用户和密文形式密码admin /admin,本地用户接入类型为ssh,local-user本地用户的优先级为3(管理级,0~15),ssh默认关闭,使能ssh开启,

    配置Server
    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]sys R2
    [R2]interface g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 10.1.1.254 24
    [R2-GigabitEthernet0/0/0]quit
    #
    [R2]rsa local-key-pair create 
    [R2]display rsa local-key-pair public  /查看本地密钥的公钥信息
    #
    [R2]user-interface vty 0 4
    [R2-ui-vty0-4]authentication-mode aaa
    [R2-ui-vty0-4]protocol inbound ssh
    [R2-ui-vty0-4]quit
    #
    [R2]aaa
    [R2-aaa]local-user admin password cipher admin
    [R2-aaa]local-user admin service-type ssh
    [R2-aaa]local-user admin privilege level 3
    [R2-aaa]stelnet server enable
    #
    [R2]display ssh user-information admin /查看SSH用户配置
    [R2]display ssh server  status   /查看服务器全局配置
    
    客户端登录服务器
    [R1]stelnet 10.1.1.254
    

    stelnet 10.1.1.254
    在这里插入图片描述

    配置SFTP Server 与Client

    在R2 aaa视图下创建一个admin2/admin2的用户密码,配置本地接入类型ssh,本地优先级为3,指定ftp用户可访问目录(如不配置,默认为空,ftp用户无法登录),ssh user创建新用户admin2,认证方式password(密文认证),使能sftp

    [R2]aaa
    [R2-aaa]local-user admin2 password cipher admin2
    [R2-aaa]local-user admin2 service-type ssh
    [R2-aaa]local-user admin2 privilege level 3
    [R2-aaa]local-user admin2 ftp-directory flash:
    [R2]ssh user admin2 authentication-type password
    [R2]sftp server enable 
    

    在AR1登录,输入admin2/admin2
    在这里插入图片描述
    在R2查看SSH会话连接信息看到,admin2已登录。
    在这里插入图片描述

    参考华为HCNA实验指南

    展开全文
  • 华为网络设备基本配置

    千次阅读 2019-09-18 07:42:23
    本博文将围绕一个综合的网络拓扑图,把华为路由器、交换机的一些基本配置写下来。并且解释链路聚合的相关概念。 博文大纲: (一)华为网络设备的链路聚合的相关概念...(二)华为网络设备配置命令。 (三)总结 ...

    本博文将围绕一个综合的网络拓扑图,把华为路由器、交换机的一些基本配置写下来。并且解释链路聚合的相关概念。

    博文大纲:

    • (一)华为网络设备的链路聚合的相关概念总揽。
      1、链路聚合是什么?
      2、成员接口有什么限制?
      3、链路聚合的工作模式有哪些?
      4、活动接口与非活动接口的概念。
      5、主动端与被动端的概念。
      6、负载均衡模式有哪几种?
    • (二)华为网络设备配置命令。
    • (三)总结

    (一)华为网络设备的链路聚合的相关概念总揽:

    • 1、链路聚合是什么?
    • 2、成员接口有什么限制?
    • 3、链路聚合的工作模式有哪些?
    • 4、活动接口与非活动接口的概念。
    • 5、主动端与被动端的概念。
    • 6、负载均衡模式有哪几种?

    1、链路聚合是什么?

    链路聚合(link aggregation)是将多个物理接口当做一个逻辑接口,以增加带宽和提供线路冗余。链路聚合的带宽理论上相当于所包含的物理接口带宽总和,非常适用于企业核心网络中,同时参与捆绑的某个成员接口或链路损坏,不影响聚合链路的正常工作,提供了冗余性。华为设备支持的链路聚合协议是LACP(link aggregation control protocol)。在华为设备中,由多个物理接口捆绑成逻辑接口,该接口被称为Eth-Trunk接口。

    2、成员接口有什么限制?

    将成员接口加入Eth-Trunk时,需要注意以下问题:

    • 每个Eth-Trunk接口下最多可以包含8个成员接口;
    • 成员接口不能单独配置任何功能和静态MAC地址;
    • 成员接口加入Eth-Trunk时,必须为默认的hybrid类型接口(该类型是华为设备默认的接口类型);
    • Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk;
    • 一个以太网接口只能加入一个Eth-Trunk接口,如果需要加入其它Eth-Trunk接口,必须先退出原来的Eth-Trunk接口;
    • 一个Eth-Trunk接口中的成员接口必须是同一类型,即FE口和GE口不能加入同一个Eth-Trunk接口。
    • 可以将不同接口板上的以太网接口加入同一个Eth-Trunk。
    • 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,这样两端才能正常通信。
    • 当成员接口的速率不一致时,实际使用中速率小的接口可能会出现拥塞,导致丢包。
    • 当成员接口加入Eth-Trunk后,学习MAC地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习的。

    3、链路聚合的工作模式有哪些?

    华为网络设备支持的链路聚合模式有手工负载分担模式和静态LACP模式:

    • 手工负载分担模式:该模式中没有LACP协议报文的参与,所有的配置均由手工完成,如加入多个成员接口。该模式下所有接口均处于转发状态,实现链路的负载分担。它支持的负载分担方式宝库目的MAC、源MAC、源MAC异或目的MAC、源IP、目的IP、源IP异或目的IP。手工负载模式通常应用于对端设备不支持LSCP协议的情况下。
    • 静态LACP模式:该模式是线路两端利用LACP协议进行协商,从而确定活动接口和非活动接口的链路聚合方式,在该模式下,创建Eth-Trunk、加入Eth-Trunk成员接口需要手工完成,而确定活动接口和非活动接口由LACP协议进行协商。静态LACP模式也称为M : N模式。这种方式可以实现链路负载分担和冗余备份的双重功能。在链路聚合组中M条链路处于活动状态,转发数据并负载分担,而另外N条链路 处于非活动状态,不转发数据,当M条链路中有链路出现故障时,系统会自动从N条备份链路中选择优先级最高的接替故障链路,并开始转发数据。

    静态LACP模式与手工负载分担模式的主要区别为静态LACP模式可以有备份链路,而手工负载分担模式中所有成员接口均处于转发状态,分担负载流量,除非线路故障。

    4、活动接口与非活动接口的概念。

    处于活动状态并负责转发数据的接口称为活动接口。相反,处于非活动状态并禁止转发数据的接口被称为非活动接口。活动接口和非活动接口一般不需要人为干预,在静态LACP模式中可以配置活动接口数量的上限以及下限。

    根据配置的工作模式不同,角色分工如下:

    • 手工负载分担模式:正常情况下,所有接口都属于活动接口,除非这些接口出现链路故障。
    • 静态LACP模式:M条链路对应的接口为活动接口并负责转发数据,N条链路对应的接口为非活动接口并负责冗余备份。

    5、主动端与被动端的概念。

    在静态LACP模式下,聚合组两端的设备中,需要选择一端为主动端,而另一端为被动端。通常情况下,LACP优先级较高的一端为主动端,LACP优先级较低的一端为被动端。如果优先级一样,那么通常选择MAC地址小的一段为主动端。(优先级的数值越小,优先级越高)。

    区分主动端与被动端的目的是保证两端设备最终确认的活动接口一致,否则两端都按照本端各自的接口优先级来选择活动接口,最终两端所确定的活动接口很有可能不一致,聚合链路也就无法建立。如下所示:
    华为网络设备基本配置

    SwitchA选择上面的两个接口为活动接口,而SwitchB选择下面的两个接口为活动接口,因为SwitchA的优先级比较高,所以最终的活动接口两端都以SwitchA为准,因此应首先确定主动端,被动端按照主动端侧的接口优先级来选择活动接口。

    6、负载均衡模式有哪几种?

    链路聚合的主要作用是提高带宽以及增加冗余,而普遍的做法就是在多条物理链路上实行负载分担。

    常用的负载分担模式包括:

    • dst-ip(目的IP地址)模式:从目的IP地址、出端口的TCP/UDP端口号中分别选择指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • dst-mac(目的MAC地址)模式:从目的MAC地址、VLAN ID、以太网类型及入端口信息中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-ip(源IP地址)模式:从源IP地址、入端口的TCP/UDP端口号中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-mac(源MAC地址)模式:从源MAC地址、VLAN ID、以太网类型及入端口信息中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-dst-ip(源IP地址与目的IP地址的异或)模式:对目的IP地址、源IP地址两种负载分担模式的运算结果进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-dst-mac(源MAC地址与目的MAC地址的异或)模式:对目的MAC地址、源MAC地址、VLAN ID、以太网类型及入端口信息中分别选择指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。

    (二)华为网络设备配置命令:

    这里从一个大型的网络拓扑图的配置说起,将华为网络设备的基础配置命令写下来,可以下载我提供的拓扑图(提取码:ay6t ),该拓扑图不以实用性为目的,而是以涉及更多的配置命令及技术为目的。网络拓扑图如下:

    华为网络设备基本配置

    该拓扑图涉及的命令如下:

    • 链路聚合
    • vlan划分
    • 单臂路由及三层交换
    • OSPF及RIP的动态路由配置
    • 路由重分发
    • PAT及静态NAT的配置
    • 基本ACL及高级ACL配置

    网络拓扑分析:

    1)OSPF和RIP部分:
    R2为公司的网关路由器,R1模拟公网路由器,所以不可配置去往公司内部的路由。公司内网使用了两种动态路由协议,RIP和OSPF,R2的GE0/0/0、GE0/0/1两个接口和SW1、SW2使用了OSPF动态路由,属于area0。R2的GE0/0/2以及R3和R4 都是用了动态路由协议RIP。所以需要在R2路由器上进行路由重分发。从而使不同的路由协议相互学习。R2作为网关路由器,需要有一条默认路由指向公网,并且需要将这条默认路由重分发到OSPF及RIP协议里。

    2)链路聚合:

    SW1和SW2使用链路聚合将两条物理链路聚合成一条逻辑链路,用于实现负载分担和备份。设置SW1为LACP主动端,逻辑链路基于MAC方式进行负载分担。

    3)NAT及ACL:

    模拟内网中192.168.10.0/24和192.168.11.0/24这两个网段不可以连接公网,所以需要设置ACL。Windows server 2016搭建一个web服务器,使用静态NAT发布到公网,使win 7 客户端可以访问到web服务器。

    4)公司内部所有的网段都是192.168.X.0/24的网段。

    开始配置:

    网络拓扑比较大,我们分为多个部分来配置。

    第一部分的配置:

    第一部分首先从R2路由器的GE0/0/0和GE0/0/1开始往下配置,依次配置路由器接口IP地址、OSPF、三层交换机的接口、vlan、链路聚的配置、二层交换机的接口配置以及划分vlan,最终测试最下面的PC是否可以ping通路由器的GE0/0/0接口(需要在配置完OSPF后才可ping通)。

    R2路由器配置如下:
    <R2>un ter mo           <!--关闭日志提示消息(很烦人的一个东西)-->
    <R2>sys                     <!--进入系统视图-->
    [R2]ip route-static 0.0.0.0 0.0.0.0 200.0.0.2               <!--配置一个指向公网的默认路由-->
    [R2]int g0/0/0                   <!--进入该接口-->
    [R2-GigabitEthernet0/0/0]ip add 192.168.7.2 24 <!--配置接口IP,默认接口处于开启状态,所以不用开启接口-->
    [R2-GigabitEthernet0/0/0]int g0/0/1             <!--进入该接口-->
    [R2-GigabitEthernet0/0/1]ip add 192.168.8.2 24               <!--配置接口IP-->
    [R2-GigabitEthernet0/0/1]ospf 10                          <!--进入OSPF进程,指定进程号为10-->
    [R2-ospf-10]area 0                               <!--进入area0 区域-->
    [R2-ospf-10-area-0.0.0.0]net 192.168.7.0 0.0.0.255           <!--宣告相应网段-->
    [R2-ospf-10-area-0.0.0.0]net 192.168.8.0 0.0.0.255            <!--宣告相应网段-->
    [R2-ospf-10-area-0.0.0.0]quit              <!--退出area 0区域-->
    [R2-ospf-10]default-route-advertise         <!--注入一条默认路由(前提是该路由器有默认)-->
    SW1配置如下:
    <SW1>un ter mo              <!--关闭日志提示消息-->
    <SW1>sys                      <!--进入系统视图-->
    [SW1]vlan ba 2 to 8               <!--创建vlan2到vlan8-->
    [SW1]in vlan 7                        <!--进入vlan7-->
    [SW1-Vlanif7]ip add 192.168.7.1 24             <!--给vlan配置IP地址-->
    [SW1-Vlanif7]in vlan 2                           <!--进入vlan2-->
    [SW1-Vlanif2]ip add 192.168.2.254 24               <!--给vlan配置IP地址-->
    [SW1-Vlanif2]in vlan 3                                <!--进入vlan3-->
    [SW1-Vlanif3]ip add 192.168.3.254 24                   <!--给vlan配置IP地址-->
    [SW1-Vlanif3]in vlan 4                         <!--进入vlan4-->
    [SW1-Vlanif4]ip add 192.168.4.254 24                    <!--给vlan配置IP地址-->
    [SW1-Vlanif4]in g0/0/1                              <!--进入接口g0/0/1-->
    [SW1-GigabitEthernet0/0/1]port link-type access             <!--更改接口类型为access-->
    [SW1-GigabitEthernet0/0/1]port default vlan 7              <!--将接口添加到vlan 7-->
    <!--因为华为的三层交换机不可以直接在物理接口配置IP地址,
    所以只能把IP配在vlan,然后将物理接口添加到VLAN中-->
    [SW1-GigabitEthernet0/0/1]lacp pri 1000                  <!--更改该交换机的LACP优先级-->
    [SW1]int Eth-Trunk 12               <!--创建链路聚合逻辑接口,指定ID为12-->
    [SW1-Eth-Trunk12]mode lacp-static                <!--配置静态LACP模式-->
    [SW1-Eth-Trunk12]load-balance dst-mac          <!--配置负载均衡模式为目标MAC地址-->
    [SW1-Eth-Trunk12]trunkport g0/0/23                     <!--添加成员接口g0/0/23-->
    [SW1-Eth-Trunk12]trunkport g0/0/24                          <!--添加成员接口g0/0/24-->
    [SW1-Eth-Trunk12]port link-type trunk                    <!--配置链路聚合模式为trunk-->
    [SW1-Eth-Trunk12]port trunk allow-pass vlan all           
    <!--允许所有vlan通过,华为设备默认不允许除vlan1以外的所以vlan通过,所以要手动允许。-->
    [SW1-Eth-Trunk12]in g0/0/2                        <!--进入g0/0/2接口-->
    [SW1-GigabitEthernet0/0/2]port link-type trunk               <!--配置接口类型为trunk-->
    [SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all           <!--允许所有vlan通过-->
    [SW1-GigabitEthernet0/0/2]in g0/0/3           <!--进入g0/0/3接口-->
    [SW1-GigabitEthernet0/0/3]port link-type trunk            <!--配置接口类型为trunk-->
    [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all            <!--允许所有vlan通过-->
    [SW1]ospf 10                       <!--配置OSPF-->
    [SW1-ospf-10]area 0                  <!--进入area 0-->
    [SW1-ospf-10-area-0.0.0.0]net 192.168.2.0 0.0.0.255         <!--将所有直连网段声明-->
    [SW1-ospf-10-area-0.0.0.0]net 192.168.3.0 0.0.0.255
    [SW1-ospf-10-area-0.0.0.0]net 192.168.4.0 0.0.0.255
    [SW1-ospf-10-area-0.0.0.0]net 192.168.7.0 0.0.0.255
    SW2配置如下:
    <SW2>un ter mo                         <!--关闭日志消息-->
    <SW2>sys                      <!--进入系统视图-->
    [SW2]vlan ba 2 to 8            <!--创建vlan-->
    [SW2]in vlan 8                 <!--进入vlan8-->
    [SW2-Vlanif8]ip add 192.168.8.1 24                 <!--给vlan配置IP地址-->
    [SW2-Vlanif8]in vlan 6              <!--进入vlan6-->
    [SW2-Vlanif6]ip add 192.168.6.254 24                  <!--给vlan配置IP地址-->
    [SW2-Vlanif6]in vlan 5               <!--进入vlan5-->
    [SW2-Vlanif5]ip add 192.168.5.254 24                  <!--给vlan配置IP地址-->
    [SW2-Vlanif5]in g0/0/1                 <!--进入接口g0/0/1-->
    [SW2-GigabitEthernet0/0/1]port link-type access           <!--将接口类型改为access-->
    [SW2-GigabitEthernet0/0/1]port default vlan 8             <!--将接口添加到vlan8-->
    [SW2]int Eth-Trunk 12             <!--创建聚合链路,以便与SW1对应-->
    [SW2-Eth-Trunk12]mode lacp-static               <!--配置静态LACP模式-->
    [SW2-Eth-Trunk12]trunkport g0/0/23               <!--添加成员接口g0/0/23-->
    [SW2-Eth-Trunk12]trunkport g0/0/24               <!--添加成员接口g0/0/24-->
    [SW2-Eth-Trunk12]port link-type trunk                <!--将接口类型改为trunk-->
    [SW2-Eth-Trunk12]port trunk allow-pass vlan all        <!--允许所有vlan通过-->
    [SW2-Eth-Trunk12]in g0/0/2                  <!--进入g0/0/2接口-->
    [SW2-GigabitEthernet0/0/2]port link-type trunk           <!--配置接口类型为trunk-->
    [SW2-GigabitEthernet0/0/2]port trunk allow-pass vlan all           <!--允许所有vlan通过-->
    [SW2-GigabitEthernet0/0/2]in g0/0/3                     <!--进入g0/0/3接口-->
    [SW2-GigabitEthernet0/0/3]port link-type trunk              <!--配置接口类型为trunk-->
    [SW2-GigabitEthernet0/0/3]port trunk allow-pass vlan all          <!--允许所有vlan通过-->
    [SW2]ospf 10                           <!--配置OSPF-->
    [SW2-ospf-10]area 0                 <!--进入area 0-->
    [SW2-ospf-10-area-0.0.0.0]net 192.168.8.0 0.0.0.255                  <!--将所有直连网段声明-->
    [SW2-ospf-10-area-0.0.0.0]net 192.168.5.0 0.0.0.255
    [SW2-ospf-10-area-0.0.0.0]net 192.168.6.0 0.0.0.255
    
    SW4配置如下:
    SW4>undo ter mo                <!--关闭日志消息-->
    <SW4>sys                 <!--进入系统视图-->
    [SW4]vlan ba 2 to 8             <!--创建vlan,其实这里只创建vlan2和vlan3就可以了-->
    [SW4]in g0/0/1                   <!--进入该接口-->
    [SW4-GigabitEthernet0/0/1]port link-type trunk           <!--配置接口类型为trunk-->
    [SW4-GigabitEthernet0/0/1]port trunk allow-pass vlan all          <!--允许所有vlan通过-->
    [SW4-GigabitEthernet0/0/1]in g0/0/3          <!--进入该接口-->
    [SW4-GigabitEthernet0/0/3]port link-type access                <!--将接口类型改为access-->
    [SW4-GigabitEthernet0/0/3]port default vlan 2                 <!--将接口添加到vlan2-->
    [SW4-GigabitEthernet0/0/3]in g0/0/2                  <!--进入该接口-->
    [SW4-GigabitEthernet0/0/2]port link-type access                  <!--将接口类型改为access-->
    [SW4-GigabitEthernet0/0/2]port default vlan 3                 <!--将接口添加到vlan3-->
    SW5配置如下:
    <SW5>undo ter mo                <!--关闭日志消息-->
    <SW5>sys                      <!--进入系统视图-->
    [SW5]vlan 4                  <!--创建vlan4-->
    [SW5-vlan4]quit
    [SW5]in g0/0/1             <!--进入该接口-->
    [SW5-GigabitEthernet0/0/1]port link-type trunk         <!--配置接口类型为trunk-->
    [SW5-GigabitEthernet0/0/1]port trunk allow-pass vlan all             <!--允许所有vlan通过-->
    [SW5-GigabitEthernet0/0/1]in g0/0/2               <!--进入该接口--> 
    [SW5-GigabitEthernet0/0/2]port link-type access         <!--将接口类型改为access-->
    [SW5-GigabitEthernet0/0/2]port default vlan 4                 <!--将接口添加到vlan4-->

    由于SW6、SW7和SW5的配置相比起来没有太大的差别,都是改一下接口类型,创建相应的vlan,将接口添加到vlan中,trunk接口允许所有vlan的信息通过,所以,SW6和SW7就不写注释了,相应的注释可以参考SW5的配置。

    SW6配置如下:
    <SW6>undo ter mo
    <SW6>sys
    [SW6]vlan 5
    [SW6-vlan5]in g0/0/1
    [SW6-GigabitEthernet0/0/1]port link-type trunk 
    [SW6-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [SW6-GigabitEthernet0/0/1]in g0/0/2
    [SW6-GigabitEthernet0/0/2]port link-type access 
    [SW6-GigabitEthernet0/0/2]port default vlan 5
    SW7配置如下:
    <SW7>un ter mo
    <SW7>sys
    [SW7]vlan 6
    [SW7-vlan6]in g0/0/1
    [SW7-GigabitEthernet0/0/1]port link-type trunk 
    [SW7-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [SW7-GigabitEthernet0/0/1]in g0/0/2
    [SW7-GigabitEthernet0/0/2]port link-type access 
    [SW7-GigabitEthernet0/0/2]port default vlan 6

    经过以上配置,下面的网络部分已经通了,可以自行使用PC进行ping测试。
    华为网络设备基本配置

    第二部分的配置:

    第二部分开始配置R2路由器的GE0/0/2接口到R4路由器及下面的交换机,首先配置R2路由器的GE0/0/2接口IP并配置RIP,进行OSPF和RIP的路由重分发,配置R3的接口IP及RIP路由,最后配置R4的接口IP、单臂路由及RIP路由。

    R2路由器配置如下:
    [R2]in g0/0/2                    <!--进入该接口--> 
    [R2-GigabitEthernet0/0/2]ip add 192.168.12.1 24                 <!--配置接口IP-->
    [R2-GigabitEthernet0/0/2]rip                  <!--进入RIP-->
    [R2-rip-1]ver 2                     <!--开启RIP版本2-->
    [R2-rip-1]undo summary                     <!--关闭路由自动汇总-->
    [R2-rip-1]net 192.168.12.0                    <!--声明网段信息-->
    [R2-rip-1]import-route ospf 10                 <!--充分发OSPF路由信息-->
    [R2-rip-1]default-route originate              <!--注入默认路由,前提是本设备有默认路由-->
    [R2-rip-1]ospf 10                  <!--进入OSPF-->
    [R2-ospf-10]import-route rip 1                      <!--重分发RIP路由信息,默认RIP进程号为1-->
    R3路由器配置如下:
    <R3>undo ter mo                        <!--关闭日志信息-->
    <R3>sys              <!--进入系统视图-->
    [R3]in g0/0/0                   <!--进入该接口-->
    [R3i-GigabitEthernet0/0/0]ip add 192.168.12.2 24                     <!--配置接口IP-->
    [R3-GigabitEthernet0/0/0]in g0/0/1                         <!--进入该接口-->
    [R3-GigabitEthernet0/0/1]ip add 192.168.13.1 24                <!--配置接口IP-->
    [R3-GigabitEthernet0/0/1]rip             <!--进入RIP-->
    [R3-rip-1]ver 2                   <!--指定RIP版本为2-->
    [R3-rip-1]un sum                 <!--关闭路由自动汇总-->
    [R3-rip-1]net 192.168.12.0              <!--声明相应的直连网段-->
    [R3i-rip-1]net 192.168.13.0
    
    R4路由器配置如下:
    <R4>un ter mo           <!--关闭日志信息-->
    <R4>sys                    <!--进入系统视图-->
    [R4]in g0/0/1              <!--进入该接口-->
    [R4-GigabitEthernet0/0/1]ip add 192.168.13.2 24            <!--配置接口IP-->
    [R4-GigabitEthernet0/0/1]in g0/0/0.10                   <!--配置单臂路由-->
    [R4-GigabitEthernet0/0/0.10]ip add 192.168.10.1 24               <!--配置子接口的IP地址-->
    [R4-GigabitEthernet0/0/0.10]dot ter vid 10                    <!--子接口和vlan  10 关联-->
    [R4-GigabitEthernet0/0/0.10]arp bro ena                         <!--子接口打开ARP广播-->
    [R4-GigabitEthernet0/0/0.10]in g0/0/0.11                    <!--进入子接口g0/0/0.11-->
    [R4-GigabitEthernet0/0/0.11]ip add 192.168.11.1 24              <!--配置子接口的IP地址-->
    [R4-GigabitEthernet0/0/0.11]dot1q ter vid 11                   <!--子接口和vlan  11 关联-->
    [R4-GigabitEthernet0/0/0.11]arp broadcast enable                   <!--子接口打开ARP广播-->
    [R4]rip                            <!--进入RIP-->
    [R4-rip-1]ver 2                  <!--指定RIP版本为2-->
    [R4-rip-1]un sum                 <!--关闭路由自动汇总-->
    [R4-rip-1]net 192.168.13.0                 <!--声明直连网段-->
    [R4-rip-1]net 192.168.10.0
    [R4-rip-1]net 192.168.11.0
    
    SW3交换机配置如下:
    <SW3>un ter mo                     <!--关闭日志信息-->
    <SW3>sys                    <!--进入系统视图-->
    [SW3]vlan ba 10 to 11               <!--创建响应vlan-->
    [SW3]in g0/0/1                   <!--进入该接口-->                
    [SW3-GigabitEthernet0/0/1]port link-type trunk                   <!--将接口模式改为trunk-->
    [SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 to 11 <!--允许相应vlan通过,“10 to  11”也可换成“all”-->
    [SW3-GigabitEthernet0/0/1]in g0/0/2             <!--进入该接口-->
    [SW3-GigabitEthernet0/0/2]port link-type access                 <!--将接口模式改为access-->
    [SW3-GigabitEthernet0/0/2]port default vlan 10                   <!--将接口添加到vlan 10-->
    [SW3-GigabitEthernet0/0/2]in g0/0/3             <!--进入该接口-->
    [SW3-GigabitEthernet0/0/3]port link-type access                  <!--将接口模式改为access-->
    [SW3-GigabitEthernet0/0/3]port default vlan 11              <!--将接口添加到vlan 11-->

    经过上面的配置,下面这些网络就全部搞定了,可以自行使用PC机进行ping测试。

    华为网络设备基本配置

    第三部分的配置:

    现在就需要配置Internet部分了,从R2路由器的GE3/0/0接口开始配置,首先配置该接口的IP地址,然后在配置Internet路由器R1的相应接口IP地址,注意,Internet路由器R1不可配置路由表,但依然要求所有内网可以ping通win 7客户端,因为在实际中,公司内部的私网地址不可能在公网上进行路由,公网上的路由器也不可能配置路由表直接指向公司内部,这就需要用到了NAT。为了引出ACL的配置方法,就指定PC5和PC6不可以和公网进行通信,剩下的都可以。

    R2路由器配置如下:
    [R2]in g3/0/0                   <!--进入该接口-->
    [R2-GigabitEthernet3/0/0]ip add 200.0.0.1 24            <!--配置接口IP-->
    [R2-GigabitEthernet3/0/0]quit                      <!--退出该接口-->
    [R2]nat address-group 1 200.0.0.100 200.0.0.100                      <!--配置NAT组-->
    [R2]acl 2000                      <!--编写编号为2000的基本ACL-->
    [R2-acl-basic-2000]rule 0 per source any                      <!--允许所有源地址通过-->
    [R2-acl-basic-2000]quit                      <!--退出-->
    [R2]acl 3000                          <!--编写编号为3000的高级ACL-->
    [R2-acl-adv-3000]rule deny ip source 192.168.10.0 0.0.1.255 destination 200.0.0.0 0.0.0.255
    <!--拒绝某个地址访问指定地址,“192.168.10.0”是一个汇总后的地址,从反掩码可以看出-->
    [R2-acl-adv-3000]rule deny ip source 192.168.10.0 0.0.1.254 destination 201.0.0.0 0.0.0.255
    <!--拒绝某个地址访问指定地址-->
    [R2-acl-adv-3000]quit                      <!--退出-->
    [R2]in g3/0/0                      <!--进入连接Internet的接口-->
    [R2-GigabitEthernet3/0/0]nat outbound 2000 address-group 1   <!--NAT转换,2000为ACL-->
    [R2-GigabitEthernet3/0/0]nat server global 200.0.0.200 inside 192.168.2.10 
    <!--配置NAT映射,将内网服务器映射为公网IP“200.0.0.200”-->
    [R2-GigabitEthernet3/0/0]quit                      <!--退出-->
    [R2]in g0/0/2                      <!--进入该接口-->
    [R2-GigabitEthernet0/0/2]traffic-filter inbound acl 3000      <!--应用拒绝的ACL-->
    R1路由器配置如下:
    <!--只是给接口配相应的IP地址,耐心快消耗没了,就不注释了-->
    <R1>sys
    [R1]in g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 200.0.0.2 24
    [R1-GigabitEthernet0/0/0]in g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 201.0.0.1 24

    现在所有配置均以完成,自行配置win7和win server 2016进行测试吧,注意,win7和内网进行ping测试或访问Windows server 2016的服务时,需要ping内网映射出来的地址和服务器映射出的公网地址,而不是内网服务器的真实地址。原本打算将ACL的配置写的更详细些,但是这篇博文已经写了五个多小时了,实在没耐心了。

    附带一些用于排错的命令:

    [R2]display current-configuration              <!--查看当前设备的所有配置-->
    [R2]display ip routing-table               <!--查看路由表-->
    [SW1]display vlan               <!--查看vlan信息-->
    [SW1]display ip interface brief                              <!--查看接口状态-->
    [SW1]display current-configuration interface vlan 2 <!--查看某一个接口的当前配置信息-->
    [R2]display nat session all               <!--查看NAT转换条目-->
    [R2]display ospf peer brief                              <!--查看OSPF邻居信息-->
    [R2]display acl all                  <!--查看ACL信息-->
    [SW1]display eth-trunk 12                            <!--查看链路聚合信息-->

    (三)总结:

    该网络拓扑图需知道以下几个知识点:

    • 即使某些交换机上并没有相应vlan的客户端,但依然要创建相应vlan,如上面拓扑图中的SW1和SW2,因为当交换机收到来自某vlan的数据包时,如果他没有该vlan,那么将丢弃该数据包,但是如果中间经过了路由器,那就不一样了。
    • 华为的trunk通道默认不允许除vlan 1以外的所有vlan通信,而Cisco设备的trunk默认允许所有vlan通信,所以在配置华为设备时,在配置完基本的trunk配置后,一定要加上允许相关vlan通过trunk的命令。
    • 在配置链路聚合时,LACP的优先级值越小,优先级越高,默认情况下,系统LACP优先级为32768。在两端设备中选择LACP优先级较小的一端作为主动端,如果系统LACP优先级相同,则选择MAC地址较小的一端作为主动端。
    • 在配置OSPF是,如果想要指定router-id,可以在进入进程模式时追加router-id,如将R2的router-id设置为1.1.1.1 :“[R2]ospf 10 router-id 1.1.1.1”。
    • 华为三层交换机的二层接口没有直接提升为三层接口的命令,如Cisco中的“no switchport”,所以在和路由器直连时,只能配置vlan虚接口,然后将物理接口添加到vlan中。
    • 在华为中,只能以标准的方式宣告RIP网络,如网段进行子网划分后为“10.10.5.0/24”,在宣告网段时,也只能宣告为“10.0.0.0”,但是需要注意,如果网络中有经过子网划分的网络,那么一定要使用RIP的版本2(默认为1),并且关闭自动汇总。
    • 华为的NAT转换直接配置在外部接口模式下,需要转换的内部流量需要通过ACL来定义,而转换后的内部全局地址通过配置NAT组来实现。
    • 华为的ACL与Cisco基本相似,华为的ACL分为基本和高级两种,类似于Cisco的标准和扩展。其中基本的编号为2000~2999,高级的编号为3000~3999,rule命令字后面可以加编号,也可以省略,默认每个rule之间相隔5个数,因为ACL的规则是匹配即停,所以这样使为了方便以后更改rule时,可以插入到某个rule之前。
    展开全文
  • 华为综合的网络拓扑实验,结合华为路由器、交换机的一些基本配置华为设备的链路聚合概述 #什么是链路聚合? 链路聚合是将多条物理链路捆绑为一条逻辑...华为设备的链路聚合相当于思科网络设备的以太网通道; #...

    华为综合的网络拓扑实验,结合华为路由器、交换机的一些基本配置和华为设备的链路聚合概述

    #什么是链路聚合?
    链路聚合是将多条物理链路捆绑为一条逻辑链路;
    增强传输数据带宽和吞吐量;
    链路聚合成员故障自动切换其他链路转发数据;
    链路聚合将流量分散到不同成员链路进行转发数据,降低拥塞;
    #链路聚合的作用是什么?
    加快传输速度,提供网络负载均衡;
    华为设备的链路聚合相当于思科网络设备的以太网通道;
    #链路聚合的模式?
    1)手工模式
    简称手工负载分担模式;
    手动模式所有的链路聚合所有端口都参与转发数据和分担流量;
    参与链路状态聚合的端口管理员手动添加;
    手动模式链路状态聚合不会发送LACP链路状态聚合协议,只能手工负载分担;
    支持居于源目标MAC和IP地址的负载均衡;
    2)静态LACP模式
    运行链路状态聚合的设备都会发送LACP协议进行协商链路聚合参数;
    运行LACP协商选举活动端口和非活动端口;
    静态LACP模式也被称为M:N模式;
    M表示活动成员链路,N表示非活动链路冗余备份流量;
    活动成员链路故障自动切换到优先级高的非活动链路转发数据;
    3)手工模式和静态LACP模式的区别
    手工负载模式中所有端口都属于转发状态;
    静态LACP模式一部分端口为转发状态,一部分为备份状态;
    #负载均衡的模式?
    dst-ip(目的IP地址)模式:根据目标IP地址进行负载负担;
    dst-mac(目的MAC地址)模式:根据目标MAC地址进行负载分担;
    src-ip(源IP地址)模式:根据源IP地址进行负载分担;
    src-mac(源MAC地址)模式:根据源MAC地址进行负载分担;
    src-dst-ip(源IP地址与目的IP地址的异或)模式:根据源目标IP地址进行负载分担;
    src-dst-mac(源MAC地址与目的MAC地址的异或)模式:根据源目标MAC地址进行负载
    分担;

    链路聚合加入成员的注意事项

    • 每个Eth-Trunk接口下最多可以包含8个成员接口;
    • 成员接口不能单独配置任何功能和静态MAC地址;
    • 成员接口加入Eth-Trunk时,必须为默认的hybrid类型接口(该类型是华为设备默认的接口类型);
    • Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk;
    • 一个以太网接口只能加入一个Eth-Trunk接口,如果需要加入其它Eth-Trunk接口,必须先退出原来的Eth-Trunk接口;
    • 一个Eth-Trunk接口中的成员接口必须是同一类型,即FE口和GE口不能加入同一个Eth-Trunk接口;
    • 可以将不同接口板上的以太网接口加入同一个Eth-Trunk;
    • 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,这样两端才能正常通信;
    • 当成员接口的速率不一致时,实际使用中速率小的接口可能会出现拥塞,导致丢包;
    • 当成员接口加入Eth-Trunk后,学习MAC地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习的;
      华为网络设备拓扑图如下
      华为网络设备的基本配置
      配置步骤如下:
    • PC机按照拓扑配置IP地址和网关
    • SW1和SW2配置链路聚合和trunk
    • 在SW1和SW2分别创建vlan10、vlan20、vlan30,将接口加入vlan
    • R1配置单臂路由,不同vlan间通信
    • R1的G0/0/1接口配置IP地址和R2接口配置IP地址
    • PC7配置IP地址和网关
    • R2配置默认路由,R1配置静态路由,PC7可以访问所有vlan,全网互通
    • R1和R2配置浮动路由
    • PC7验证浮动路由全网互通
      开始配置
      华为网络设备的基本配置
      1.PC机按照拓扑配置IP地址和网关
      华为网络设备的基本配置

    华为网络设备的基本配置
    华为网络设备的基本配置
    华为网络设备的基本配置
    华为网络设备的基本配置
    华为网络设备的基本配置
    华为网络设备的基本配置

    2.SW1和SW2配置链路聚合和trunk
    1)SW1配置0/0/2、0/0/3、0/0/4接口为链路聚合
    [SW1]int Eth-Trunk 1        #创建聚合链路编号为1,范围是0~63
    [SW1-Eth-Trunk1]quit      #保存并退出
    [SW1]int eth 0/0/2            #进入到0/0/2接口
    [SW1-Ethernet0/0/2]eth-trunk 1       #加入到聚合链路1中
    [SW1-Ethernet0/0/2]quit               #保存并退出
    [SW1]interface Ethernet 0/0/3       #进入到0/0/3接口
    [SW1-Ethernet0/0/3]eth-trunk 1     #加入到聚合链路1中
    [SW1-Ethernet0/0/3]quit                #保存并退出
    [SW1]interface Ethernet 0/0/4        #进入到0/0/4接口
    [SW1-Ethernet0/0/4]eth-trunk 1      #加入到聚合链路1中
    [SW1-Ethernet0/0/4]quit                  #保存并退出
    2)将SW1链路聚合配置为trunk
    [SW1]int Eth-Trunk 1                     #进入聚合链路1
    [SW1-Eth-Trunk1]port link-type trunk           #聚合链路配置为trunk
    [SW1-Eth-Trunk1]port trunk allow-pass vlan all  #设置承载所有vlan
    (如果承载指定vlan的话把all换成vlan编号即可)
    [SW1-Eth-Trunk1]quit          #保存并退出
    3)将SW1连接路由器R1的Ethernet0/0/1接口配置为trunk
    [SW1]int eth 0/0/1              #进入0/0/1接口
    [SW1-Ethernet0/0/1]port link-type trunk      #接口配置为trunk
    [SW1-Ethernet0/0/1]port trunk allow-pass vlan all    #设置承载所有vlan
    [SW1-Ethernet0/0/1]quit                     #保存并退出
    4)SW2配置0/0/2、0/0/3、0/0/4接口为链路聚合
    [SW2]int Eth-Trunk 1       #创建聚合链路编号为1,范围0~63
    [SW2-Eth-Trunk1]quit       #保存并退出 
    [SW2]int eth 0/0/2               #进入到0/0/2接口
    [SW2-Ethernet0/0/2]eth-trunk 1       #加入到聚合链路1中
    [SW2-Ethernet0/0/2]quit                #保存并退出 
    [SW2]int eth 0/0/3                      #进入到0/0/3接口 
    [SW2-Ethernet0/0/3]eth-trunk 1    #加入到聚合链路1中
    [SW2-Ethernet0/0/3]quit            #保存并退出 
    [SW2]int eth 0/0/4                        #进入到0/0/4接口
    [SW2-Ethernet0/0/4]eth-trunk 1   #加入到聚合链路1中
    [SW2-Ethernet0/0/4]quit               #保存并退出 
    5)将SW2链路聚合配置为trunk
    [SW2]int Eth-Trunk 1                     #进入聚合链路1
    [SW2-Eth-Trunk1]port link-type trunk           #聚合链路配置为trunk
    [SW2-Eth-Trunk1]port trunk allow-pass vlan all  #设置承载所有vlan
    3.在SW1和SW2分别创建vlan10、vlan20、vlan30,将接口加入vlan
    1)在SW1创建vlan10 vlan20 vlan30,将接口加入vlan
    [SW1]vlan batch 10 20 30       #批量创建多个vlan
    2)在SW1将接口加入vlan
    [SW1]int eth 0/0/5          #进入0/0/5接口
    [SW1-Ethernet0/0/5]port link-type access      #设置为接入链路 
    [SW1-Ethernet0/0/5]port default vlan 10          #加入到vlan10
    [SW1-Ethernet0/0/5]quit                        #保存并退出
    [SW1]int eth 0/0/6                      #进入到0/0/6接口
    [SW1-Ethernet0/0/6]port link-type access      #设置为接入链路
    [SW1-Ethernet0/0/6]port default vlan 20           #加入到vlan20
    [SW1-Ethernet0/0/6]quit                   #保存并退出
    [SW1]int eth 0/0/7                             #进入到0/0/7接口
    [SW1-Ethernet0/0/7]port link-type access     #设置为接入链路
    [SW1-Ethernet0/0/7]port default vlan 30        #加入到vlan30
    [SW1-Ethernet0/0/7]quit          #保存并退出
    3)SW2创建vlan10 vlan20 vlan30,将接口加入vlan
    [SW2]vlan batch 10 20 30       #批量创建多个vlan
    4)在SW2将接口加入vlan
    SW2]int eth 0/0/5          #进入0/0/5接口
    [SW2-Ethernet0/0/5]port link-type access      #设置为接入链路 
    [SW2-Ethernet0/0/5]port default vlan 10          #加入到vlan10
    [SW2-Ethernet0/0/5]quit                        #保存并退出
    [SW2]int eth 0/0/6                      #进入到0/0/6接口
    [SW2-Ethernet0/0/6]port link-type access      #设置为接入链路
    [SW2-Ethernet0/0/6]port default vlan 20           #加入到vlan20
    [SW2-Ethernet0/0/6]quit                   #保存并退出
    [SW2]int eth 0/0/7                             #进入到0/0/7接口
    [SW2-Ethernet0/0/7]port link-type access     #设置为接入链路
    [SW2-Ethernet0/0/7]port default vlan 30        #加入到vlan30
    [SW2-Ethernet0/0/7]quit          #保存并退出
    4.R1配置单臂路由,不同vlan间通信
    1)R1开启子接口
    [R1]int g 0/0/0.10                #创建子接口0/0/0.10
    [R1-GigabitEthernet0/0/0.10]ip add 192.168.10.254 24  #子接口配置IP地址
    [R1-GigabitEthernet0/0/0.10]dot1q termination vid 10   #子接口为vlan10服务
    [R1-GigabitEthernet0/0/0.10]arp broadcast enable        #开启子接口ARP广播
    [R1-GigabitEthernet0/0/0.10]quit                   #保存并退出
    [R1]int g 0/0/0.20                         #创建子接口0/0/0.20
    [R1-GigabitEthernet0/0/0.20]ip add 192.168.20.254 24  #子接口配置IP地址
    [R1-GigabitEthernet0/0/0.20]dot1q termination vid 20    #子接口为vlan20服务
    [R1-GigabitEthernet0/0/0.20]arp broadcast enable     #开启子接口ARP广播
    [R1-GigabitEthernet0/0/0.20]quit           #保存并退出
    [R1]int g 0/0/0.30                   #创建子接口0/0/0.30
    [R1-GigabitEthernet0/0/0.30]ip add 192.168.30.254 24    #子接口配置IP地址
    [R1-GigabitEthernet0/0/0.30]dot1q termination vid 30     #子接口为vlan30服务
    [R1-GigabitEthernet0/0/0.30]arp broadcast enable       #子接口开启ARP广播
    [R1-GigabitEthernet0/0/0.30]quit        #保存并退出

    如上配置完成后不同vlan间可以互相通信,拿一台PC机ping其他vlan
    华为网络设备的基本配置

    接下来配置静态、默认、浮动路由,全网互通
    5.R1的G0/0/1接口配置IP地址和R2接口配置IP地址
    1)R1的G0/0/1接口配置IP地址
    [R1]int g 0/0/1        #进入0/0/1接口
    [R1-GigabitEthernet0/0/1]ip add 192.168.40.1 24    #配置IP地址
    [R1-GigabitEthernet0/0/1]undo shut      #激活接口
    [R1-GigabitEthernet0/0/1]quit       #保存并退出
    2)R2接口配置IP地址
    [R2]int g 0/0/1     #进入0/0/1接口
    [R2-GigabitEthernet0/0/1]ip add 192.168.40.2 24   #配置IP地址
    [R2-GigabitEthernet0/0/1]undo shut       #激活接口
    [R2-GigabitEthernet0/0/1]quit       #保存并退出
    [R2]int g 0/0/0     #进入0/0/0接口
    [R2-GigabitEthernet0/0/0]ip add 192.168.50.1 24    #配置IP地址
    [R2-GigabitEthernet0/0/0]undo shut     #激活接口
    [R2-GigabitEthernet0/0/0]quit             #保存并退出

    6.PC7配置IP地址和网关
    华为网络设备的基本配置

    7.R2配置默认路由,R1配置静态路由,PC7可以访问所有vlan,全网互通
    1)R2配置默认路由,下一跳地址为192.168.40.1
    [R2]ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet 0/0/1 192.168.40.1
                                                #配置默认路由,下一跳接口为0/0/1,下一跳IP地址为40.1
    2)R1配置静态路由,下一跳为192.168.40.2
    [R1]ip route-static 192.168.50.0 255.255.255.0 GigabitEthernet 0/0/1 192.168.40.2
                                                #配置静态路由,下一跳接口为0/0/1,下一跳IP地址为40.2

    3)PC7验证全网互通
    华为网络设备的基本配置

    8.R1和R2配置浮动路由
    1)配置R1和R2的G0/0/2接口的IP地址
    [R1]int g 0/0/2      #进入0/0/2接口
    [R1-GigabitEthernet0/0/2]ip add 192.168.60.1 24     #配置IP地址
    [R1-GigabitEthernet0/0/2]undo shut                   #激活接口
    [R1-GigabitEthernet0/0/2]quit              #保存并退出
    [R2]int g 0/0/2         #进入0/0/2接口
    [R2-GigabitEthernet0/0/2]ip add 192.168.60.2 24   #配置IP地址
    [R2-GigabitEthernet0/0/2]undo shut      #激活接口
    [R2-GigabitEthernet0/0/2]quit    #保存并退出 
    [R2]ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet 0/0/2 192.168.60.1 preference 70
                   #配置默认浮动路由,下一跳接口为G0/0/2  下一跳IP地址为60.1   优先级为70
    [R1]ip route-static 192.168.50.0 24 GigabitEthernet 0/0/2 192.168.60.2 preference 70
                        #配置静态浮动   下一跳接口为G0/0/2    下一跳IP地址为60.2   优先级为70
    2)关闭R1和R2的G0/0/1接口
    [R1]int g 0/0/1      #进入0/0/1接口
    [R1-GigabitEthernet0/0/1]shut   关闭接口

    华为网络设备的基本配置
    9.PC7验证浮动路由全网互通
    华为网络设备的基本配置

    展开全文
  • 华为网络设备与Cisco的网络设备原理上大致都是一样。不同就是华为有很多的私有的技术。有学过Cisco的网络设备,当然学习华为也不是什么费事的事情。目前很多企业的网络部署都是混合部署,就是多厂商设备混合使用。...
  • 一、实验目的掌握进入路由器各种模式,配置登陆 console 口密码,系统视图密码,保存配置,删除配置等等基本配置命令,这里不一一列举,请做下面的实验二、拓扑三、步骤1:以下为刚进入路由器时的默认模式--用户模式...
  • 华为网络设备综合配置实验

    千次阅读 2020-02-01 17:38:16
    1、LACP配置 1)创建Eth-Trunk1 interface Eth-Trunk 1 quit 2)将指定端口加入Eth-Trunk 1 interface GigabitEthernet 0/0/4 eth-trunk 1 quit interface GigabitEthernet 0/0/5 eth-trunk 1 quit 3)查看配置结果 ...
  • 华为网络设备配置与管理教学系列文章 第二章—— 单臂路由的配置示例 作者:杨佳佳 华为网络设备配置与管理教学系列文章: 第一章 利用三层交换机实现VLAN之间的路由配置实例 第二章 单臂路由的配置示例 文章...
  • 三、华为网络设备的模拟器及基础配置命令 一、华为产品分类: 目前华为网络产品有路由器、交换机、防火墙。 1、路由器 路由器主要分为AR系列和NE系列: AR系列路由器:AR系列是华为推出的新一代网络产品,主要...
  • 华为网络设备-DHCP基础配置实验 作者: 梁文婷    排版: 赖裕鑫    审核: 蔡宗唐 文章目录实验拓扑实验目的DHCP介绍实验背景实验配置实验验证 实验拓扑 实验目的 掌握DHCP接口...
  • 三、华为网络设备的模拟器及基础配置命令 一、华为目前所有产品线: 目前华为网络产品有路由器、交换机、防火墙 1、路由器 路由器主要分为AR系列和NE系列: AR系列路由器:AR系列是华为推出的新一代网络产品,主要...
  • 描述:华为网络设备交换机路由器查看用户配置命令 命令: system #进入系统视图 aaa #进入3A模式 display this #查看用户配置
  • 华为网络设备-生成树协议配置 作者:郑伟钦 文章目录原理概述实验目的实验内容实验拓扑图实验步骤基本配置根交换机的选举原则配置拓扑图中的根交换机理解根端口的选举理解指定端口与备份端口的选举 原理概述 STP...
  • FTP(File Transfer Protocol,文件传输协议)是在TCP/IP网络和Internet上最早使用的协议之一,在TCP/IP协议簇中属于应用层协议。 它是文件传输的Internet标准,主要向用户提供本地和远程主机的文件传输,尤其在进行...
  • 华为网络设备SSH方式登录配置

    千次阅读 2019-08-01 21:17:27
    配置通过SSH登录路由器: Server端配置: 1. 生成RSA主机密钥对: rsa local-key-pair create 2.进入VTY模式 user-interface vty 0 4 3.设置用户验证方式为AAA authentication-mode aaa 4.指定VT...
  • 华为网络设备-访问控制列表配置实验 作者: 赖裕鑫    排版: 赖裕鑫    审核: 蔡宗唐 文章目录实验介绍实验目的实验拓扑实验思路操作步骤实验验证任务总结 实验介绍 访问控制列表...
  • 华为网络设备配置与管理教学系列文章 第一章—— 利用三层交换机实现VLAN之间的路由配置实例 作者:何嘉愉 华为网络设备配置与管理教学系列文章: 第一章 利用三层交换机实现VLAN之间的路由配置实例 第二章 锐捷...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,111
精华内容 444
关键字:

华为网络设备配置