精华内容
下载资源
问答
  • HCIE华为路由交换精英培训PTT,HCIE华为路由交换精英培训PTT
  • Yeslab 华为路由交换实验手册 包含基础配置、ospf 、bgp、mstp等
  • 2021华为路由交换认证HCIP-R&S H12-221~223路由交换最新题库+考试模拟软件,刷题必备,一套题库就够。亲测有效,已经过啦嘿嘿 接近满分飘过 嘿嘿 华为 路由交换 HCIP 认证
  • 华为路由交换模拟器

    2014-01-27 14:11:08
    华为路由交换模拟器,可自由添加模拟设备、自行设置连接方式、有实验操作和代码、理论学习。
  • 华为路由交换配置实例,包括拓扑图等
  • 华为路由交换集成

    2019-09-01 16:14:49
    华为路由交换集成 ** 规划网段。 先配置交换机部份。 Lsw1 sys vlan 10 quit interface e0/0/1 port link-type access port default vlan 10 quit interface e0/0/2 port link-type trunk port trunk allow...

    **

    华为路由交换集成

    **

    1. 规划网段。
      

    在这里插入图片描述

    先配置交换机部份。
    Lsw1
    sys
    vlan 10
    quit
    interface e0/0/1
    port link-type access
    port default vlan 10
    quit
    interface e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    quit
    save
    lsw2
    sys
    vlan 20
    quit
    interface e0/0/1
    port link-type access
    port default vlan 20
    quit
    interface e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    quit
    save
    Lsw3
    lsw2
    sys
    vlan batch 10 20
    interface g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    interface g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    interface g0/0/3
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    quit
    save
    Lsw4
    lsw2
    sys
    vlan batch 10 20
    interface g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    interface vlan 10
    ip address 192.168.10.1 255.255.255.0
    quit
    interface vlan 20
    ip address 192.168.20.1 255.255.255.0
    quit
    quit
    save
    路由器部份(所有节点IP地址)。
    Lsw4(如何给三层交换机配置IP地址)
    方式一:
    [Huawei]interface GigabitEthernet 0/0/2
    [Huawei-GigabitEthernet0/0/2]undo portswitch (将二层接口配置三层接口,前提这种型的交换要要支持三层功能才可以)
    [Huawei-GigabitEthernet0/0/2]ip address 192.168.30.1 255.255.255.0
    方式二:
    [Huawei]
    [Huawei]vlan 100
    [Huawei-vlan100]
    [Huawei-vlan100]quit
    [Huawei]interface vlan 100
    [Huawei-Vlanif100]ip address 192.168.30.1 255.255.255.0
    [Huawei]interface GigabitEthernet 0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type access
    [Huawei-GigabitEthernet0/0/2]port default vlan 100
    AR1
    sys
    interface g0/0/0
    undo shutdown
    ip address 192.168.30.2 255.255.255.0
    quit
    interface g0/0/1
    undo shutdown
    ip address 192.168.40.1 255.255.255.0
    quit
    quit
    save
    AR2
    sys
    interface g0/0/1
    undo shutdown
    ip address 192.168.50.1 255.255.255.0
    quit
    interface g0/0/0
    undo shutdown
    ip address 192.168.40.2 255.255.255.0
    quit
    quit
    save
    所有三层设备配置路由协议:

    Lsw4

    [Huawei]

    [Huawei]rip 1

    [Huawei-rip-1]network 192.168.10.0

    [Huawei-rip-1]network 192.168.20.0

    [Huawei-rip-1]network 192.168.30.0

    Ar1

    sys

    [Huawei]rip 1

    [Huawei-rip-1]network 192.168.30.0

    [Huawei-rip-1]network 192.168.40.0

    Ar2

    [Huawei]

    [Huawei]rip 1

    [Huawei-rip-1]network 192.168.40.0

    [Huawei-rip-1]network 192.168.50.0

    展开全文
  • 华为路由交换精英培训课程,HCIE培训经典课程之RIP协议。
  • 一、华为路由交换技术 | 华为命令行简介 < >用户视图模式 权限稍低 [ ]系统视图模式 权限高 < >system-view 切换到系统视图 [ ]sysname R1 命名 [ ]quit 退出当前模式 ? 提示信息 命令支持简写 tab 键 ...

    #华为路由交换技术 | 远程登录 Telnet应用(eNSP模拟器)
    Telnet:远程登录,远程控制一些路由器和交换机等网络设备。四层使用TCP 23号端口。

    拓扑:
    在这里插入图片描述
    telnet 服务端配置:

    telnet server enable (华为默认开启)
    aaa
    local-user hcnp password cipher hcnp123 privilege level 3
    

    配置用户名和密码 权限级别3级

    local-user hcnp service-type telnet
    

    指定账号的服务类型是telnet

    user-interface vty 0 4 同时允许5 个人远程控制
    authentication-mode aaa 认证的模式采用aaa
    

    telnet客户端:
    在这里插入图片描述
    ② 客户端为PC
    在这里插入图片描述

    route print     显示PC的路由表
    

    在这里插入图片描述
    给PC 增加一条路由

    route add 34.1.1.0 mask 255.255.255.0 192.168.1.1
    

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    注:四层使用的 TCP 23号端口。
    缺点:密码是明文密码。

    一、华为路由交换技术 | 华为命令行简介

    < >用户视图模式 权限稍低
    [ ]系统视图模式 权限高
    < >system-view 切换到系统视图
    [ ]sysname R1 命名
    [ ]quit 退出当前模式
    ? 提示信息

    命令支持简写

    tab 键 补全命令

    <>language-mode Chinese 提示语言改为中文
    dis current-configuration 显示当前所有配置
    more:回车键 翻一行,空格翻一页 其他任意键退出
    ctrl + z 直接回退到用户模式

    给接口配置IP地址:

    int e0/0/0           #进入接口e0/0/0
    ip address 192.168.1.1 24         #给接口配置ip地址和子网掩码
    dis this            # 显示当前配置
    
    dis ip int brief       # 显示接口摘要
    

    在这里插入图片描述
    dis ip routing-table 显示路由表
    在这里插入图片描述
    路由表:路由器转发数据包的唯一依据,是路由器转发数据包的一张“地图”。
    在这里插入图片描述
    [ ]undo info-center enable 关闭信息中心 ,防止弹出日志

    直连路由 : direct route ,直接相连的路由,当路由器的接口配置好ip地址并up之后,会自动创建该路由。路由器默认情况下,只能
    到达直连的网段。
    在这里插入图片描述
    undo xxx 撤销某条指令
    例如:

    int e0/0/1
    undo ip address
    例如:
    undo sysname
    

    二、华为路由交换技术 | DHCP技术

    简介
    DHCP(dynamic host configuration protocol)动态主机配置协议是一个局域网的网络协议,使用UDP协议工作。

    优点
    效率高、灵活性强、易于管理。

    地址池分类
    1、 接口地址池
    2、 全局地址池

    DHCP报文类型
    在这里插入图片描述
    DHCP工作过程
    在这里插入图片描述
    DHCP租期更新
    在这里插入图片描述
    IP租约期限到了87.5%时,还没有收到服务器相应,则会申请重新绑定IP。

    IP地址释放
    在这里插入图片描述
    1、如果IP租约到期前没有收到DHCP服务器相应,客户端会停止使用此IP地址
    2、如果DHCP客户端不在使用分配的IP地址,可以主动向DHCP服务器发送DHCPrelease报文,释放改地址

    DHCP基本配置
    在这里插入图片描述

    [ router] dhcp enable
    [router-] int g0/0/0
    [router-g0/0/0 ] ip add 10.1.1.1  24
    [router-g0/0/0 ] dhcp  select  interface
    [router-g0/0/0 ] dhcp  server dns-list10.1.1.2
    [ router-g0/0/0] dchp  server excluded-ip-address10.1.1.2
    [router-g0/0/0 ] dhcp  server  lease day  3
    [ router] dispalay ip pool 查看DHCP绑定信息
    

    在这里插入图片描述

    router ]dhcp enable
    [router-] int g0/0/0
    [router-g0/0/0 ] ip add 10.1.1.1  24
    [ router] ip pool POOL1
    [router-ip-pool-POOL1 ] network 10.1.1.0 mask 24
    [router-ip-pool-POOL1 ] gateway-list 10.1.1.1
    [router-ip-pool-POOL1 ] lease day 10
    [router-g0/0/1 ] dhcp  select  global
    

    三、华为路由交换技术 | DHCP技术

    简介
    DHCP(dynamic host configuration protocol)动态主机配置协议是一个局域网的网络协议,使用UDP协议工作。

    优点
    效率高、灵活性强、易于管理。

    地址池分类
    1、 接口地址池
    2、 全局地址池

    DHCP报文类型
    在这里插入图片描述
    DHCP工作过程
    在这里插入图片描述
    DHCP租期更新
    在这里插入图片描述
    IP租约期限到了87.5%时,还没有收到服务器相应,则会申请重新绑定IP。

    IP地址释放
    在这里插入图片描述
    1、如果IP租约到期前没有收到DHCP服务器相应,客户端会停止使用此IP地址
    2、如果DHCP客户端不在使用分配的IP地址,可以主动向DHCP服务器发送DHCPrelease报文,释放改地址

    DHCP基本配置

    DHCP接口地址池
    在这里插入图片描述

    [ router] dhcp enable
    [router-] int g0/0/0
    [router-g0/0/0 ] ip add 10.1.1.1  24
    [router-g0/0/0 ] dhcp  select  interface
    [router-g0/0/0 ] dhcp  server dns-list10.1.1.2
    [ router-g0/0/0] dchp  server excluded-ip-address10.1.1.2
    [router-g0/0/0 ] dhcp  server  lease day  3
    [ router] dispalay ip pool 查看DHCP绑定信息
    

    在这里插入图片描述

    router ]dhcp enable
    [router-] int g0/0/0
    [router-g0/0/0 ] ip add 10.1.1.1  24
    [ router] ip pool POOL1
    [router-ip-pool-POOL1 ] network 10.1.1.0 mask 24
    [router-ip-pool-POOL1 ] gateway-list 10.1.1.1
    [router-ip-pool-POOL1 ] lease day 10
    [router-g0/0/1 ] dhcp  select  global
    

    四、华为路由交换技术 | 静态路由配置

    静态路由配置

    1.1 拓扑
    在这里插入图片描述
    去包路由:PC1—>PC2 (目标网段始终是:172.16.1.0/24)

    1.2 配置过程

    R1:
    ip route-static 172.16.1.0 24 12.1.1.2
    目标网段 下一跳
    下一跳:(next-hop) 下一个传递者,下一个承接者
    
    R2:ip route-s 172.16.1.0 24 23.1.1.3
    回包路由:PC2--->PC1(目标网段始终是:192.168.1.0/24)
    
    PC3:
    ip route-s 192.168.1.0 24 23.1.1.2
    
    PC2:
    ip route-s 192.168.1.0 24 12.1.1.1
    

    五、华为路由交换技术 | 路由优先级原理与配置

    路由优先级:(preference,思科:管理距离)衡量路由的优先程度,到达同一个目标有两种路由协议,此时优选路由优先级较小的路由协议。

    路由优先级范围:0-255
    常见路由协议默认的优先级:
    直连路由 0
    静态路由 60
    Rip 100
    ospf 10
    数字越小 越优先

    实验拓扑:
    在这里插入图片描述
    目标:想实现千兆Ge0/0/0 做为主链路,百兆E0/0/1 作为备份链路

    R1:
    ip route-s 210.1.1.0 24 12.1.1.2
    ip route-s 210.1.1.0 24 21.1.1.2 preference 50 配置静态路由并制定优先级为50
    
    R2:
    ip routes-s 192.168.1.0 24 12.1.1.1
    ip route-s 192.168.1.0 24 21.1.1.1 preference 50
    

    在这里插入图片描述

    华为路由交换技术 | 路由协议之RIP原理与配置

    RIP: 路由信息协议RIP(Routing Information Protocol)的简称,它是一种基于距离矢量(Distance-Vector)算法的协议,使用跳数作为度量来衡量到达目的网络的距离。RIP主要应用于规模较小的网络中。
    缺点:古老,收敛速度很慢!
    在这里插入图片描述
    实验拓扑:
    在这里插入图片描述
    配置命令:

    R1:
    rip 1
    undo summary 关闭自动汇总
    version 2 版本2
    network 192.168.1.0 宣告直连主类网络
    network 12.0.0.0 宣告 直连主类网络
    
    R2:
    rip 1
    undo summary
    version 2
    network 12.0.0.0
    network 23.0.0.0
    network 172.16.0.0
    
    R3:
    rip 1
    undo summary
    version 2
    network 23.0.0.0
    network 10.0.0.0
    

    RIP报文:
    在这里插入图片描述
    每隔30s 发送一次
    目标地址是:224.0.0.9 组播地址
    报文里面存放的是路由信息
    rip 只看距离远近,距离是以跳数(经过路由器的个数)来衡量。
    注:16跳不可达

    抑制接口:(静默接口)

    rip
    silent-interface e0/0/0 将接口e0/0/0 配置为静默接口,rip的路由更新不再从该接口发送。
    

    在这里插入图片描述

    六、华为路由交换技术 | OSPF原理与配置

    OSPF:开放式最短路径优先(Open Shortest Path First)协议是IETF定义的一种基于链路状态的内部网关路由协议。
    ospf 的优先级:10.

    ospf 的区域规划
    在这里插入图片描述
    area 0 :骨干区域 核心区域
    area 1、2 。。。:常规区域
    Area 0 是骨干区域,其他区域都必须与此区域相连。

    ospf配置
    在这里插入图片描述

    R1:
    ospf 1
    area 0
    network 192.168.1.0 0.0.0.255
    network 12.1.1.0 0.0.0.255
    
    R2:
    ospf 1
    area 0
    net 12.1.1.0 0.0.0.255
    net 23.1.1.0 0.0.0.255
    net 172.16.1.0 0.0.0.255
    
    R3:
    ospf 1
    area 0
    network 23.1.1.0 0.0.0.255
    network 10.10.10.0 0.0.0.255
    

    ospf 的报文:常见 5种
    hello:小巧,用来建立和维持邻居关系
    DBD 、LSR、LSU、LSack 刚开始发送
    < >reset ospf process 重置ospf 进程
    在这里插入图片描述
    显示ospf 的邻居表:
    在这里插入图片描述

    七、华为路由交换技术 | 网络地址转换技术NAT(Network Address Translation)详解与配置案例

    NAT:(Network Address Translation) 网络地址转换技术,作用是将内网私有地址转换成公网地址,使得内网的主机可以上外网。

    私有地址:任何人都可以使用
    A 10.0.0.0/8
    B 172.16.0.0-172.31.255.255
    C 192.168.0.0/16
    在这里插入图片描述
    基础配置:
    1、配置好ip地址
    2、出口缺省路由

    静态NAT :static NAT :一对一(一 一映射),一个私网地址对应一个公网地址,外网的用户可以访问内网的主机。

    • global:全局公网地址
    • local :内网私有地址
    • inside :内网 内部
    • outside:外部
    int gi 0/0/1 (在外网口配置)
    nat static global 12.1.1.2 inside 192.168.31.2 将私网地址31.2 和12.1.1.2 做一 对一的映射。
    

    调试:查看nat 的转换过程
    dis nat session protocol icmp
    在这里插入图片描述
    缺点:有多少个私网地址就需要多少个公网地址。

    NAT 之 easy IP :允许多个私网地址转换成一个公网ip,很常用。

    出口:
    先写acl 匹配内网私网地址段

    acl number 2000
    rule 5 permit source 192.168.31.0 0.0.0.255
    

    注:acl 用来做匹配范围时,没有默认隐含允许所有的规则。
    int gi 0/0/1 (公网接口)
    nat outbound 2000 (2000是acl 的表号)
    原理:内网私网地址出包时转换成公网接口gi 0/0/1 当前的ip地址。

    NAT 之 server NAT:可以将某服务器的某端口映射出去 (非常安全)
    在这里插入图片描述

    int gi 0/0/1
    nat server protocol tcp global 12.1.1.4 www inside
    192.168.31.254 www
    

    仅仅将服务器的80端口映射出去

    八、华为路由交换技术 | 文件传输协议 FTP原理以及配置(穿插讲解华为系统)

    FTP:file translate protocol, FTP是用来传送文件的协议。使用FTP实现远程文件传输的同时,还可以保证数据传输的可靠性和高效性。目前多数用其来传输安装操作系统。

    路由器 硬件组成:
    内存 + cpu + flash(类似硬盘) + 风扇 + I/O接口 + 主板

    查看路由器操作系统
    在这里插入图片描述
    华为操作系统:VRP:Versatile Routing Platform ve 5.x

    对flash 的操作:copy vrpcfg.zip aa
    在这里插入图片描述
    在这里插入图片描述
    reset recycle-bin 清空回收站

    配置ftp:

    aaa
    local-user aa password cipher aa123 privilege level 3 ftp-directory flash:
    local-user aa service-type ftp
    

    客户端访问:
    在这里插入图片描述
    get r4 复制文件

    PC 当客户端:
    在这里插入图片描述
    在这里插入图片描述
    升级操作系统
    在这里插入图片描述

    # 华为路由交换技术 | 虚拟局域网VLAN详解与配置
    VLAN(Virtual Local Area Network)即虚拟局域网。

    作用:在大型的企业内网,可以通过在交换机(二、三层交换机) 上部署vlan技术隔离广播域,缩小广播发送的范围,同时将安全威胁隔离到最小。以及方便管理员的管理。最终使得网络更加的健康和稳定。

    vlan 配置
    在这里插入图片描述

    vlan 10 创建vlan 10
    vlan 20
    vlan batch 20 30 40 同时创建三个vlan
    int gi 0/0/1
    port link-type access 将接口类型配置为access
    port default vlan 10 将接口划分到vlan 10 里面
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 10
    

    :vlan 1 属于默认vlan,默认情况下所有的接口都位于vlan 1里面 。
    在这里插入图片描述
    :vlan 隔离广播的同时,也会隔离arp,从而导致单播也无法通信。如果想让不同的vlan 单播可以通信,还需要三层设备(路由器、三
    层交换机)做路由。

    :默认情况下,交换机的一个接口只能从属于一个vlan,只允许该vlan的数据通过。

    Trunk:干道 主干链路 通常用于交换机和交换机之间,通过一个接口传输多个vlan 的数据包。

    trunk 配置:
    在这里插入图片描述
    access 口:接PC
    trunk 口:接交换机
    hybrid 口:混合口 既可以接PC也可以接交换机 (华为交换机的默认接口)
    在这里插入图片描述
    trunk 配置:

    int gi 0/0/x
    port link-ty trunk
    port trunk allow-pass vlan all
    

    在这里插入图片描述
    PC—>交换机 access口
    在这里插入图片描述
    :PC 不认识 vlan 标记,不认识tag ,只有通过交换机的trunk 接口发出的报文才具备vlan 的标记(802.1q tag)。

    :PC 发出的报文没有tag。

    交换机trunk-------trunk交换机
    在这里插入图片描述
    在这里插入图片描述
    PVID:本征vlan (native vlan ):该vlan的报文经过trunk接口时不打标记(tag)。默认情况下本征vlan 是vlan 1.
    在这里插入图片描述

    int gi0/0/4
    port trunk pvid vlan 20 将trunk 接口的pvid 改为vlan 20
    

    将交换机的接口属性更改时:例如由access–>trunk 或者由trunk–>access 必须重置接口的默认配置。
    在这里插入图片描述

    [ ]clear configuration int gi 0/0/2
    

    在这里插入图片描述
    vlan 间路由
    方法① 多层交换机–SVI (常用):switch virtual interface
    方法② 路由器–单臂路由
    注意:不同的vlan之间互相通信必须要有三层设备(路由器、多层交换机)做中转。

    vlan 间路由之 SVI
    在这里插入图片描述
    sw配置:

    vlan batch 10 20
    

    将接口划入vlan 配置略

    int vlan 10
    ip address 192.168.10.1 24 给vlan 10 配置ip地址10.1 作为vlan 10 用户的网关
    int vlan 20
    ip add 192.168.20.1 24
    

    调试:
    在这里插入图片描述
    在这里插入图片描述
    注意:vlan间路由:通过三层设备路由,使得不同vlan间可以互相通信。但是仅仅允许单播通信。不同vlan 之间广播帧依然被隔离既没有失去vlan原来的意义。

    vlan间路由之 单臂路由
    在这里插入图片描述
    配置:

    ① 交换机上联 配置trunk

    int gi 0/0/3
    

    配置trunk

    ② 路由器启用子接口

    interface Ethernet0/0/0.10
    dot1q termination vid 10
    ip address 192.168.10.1 255.255.255.0
    arp broadcast enable
    interface Ethernet0/0/0.20
    dot1q termination vid 20
    ip address 192.168.20.1 255.255.255.0
    arp broadcast enable
    

    九、华为路由交换技术 | 访问控制列表ACL(Access Control List )详解与配置案例

    ACL两种:
    基本ACL(2000-2999):只能匹配源ip地址。
    高级ACL(3000-3999):可以匹配源ip、目标ip、源端口、目标端口等三层和四层的字段。
    在这里插入图片描述
    ACL举例(1):拒绝PC1访问172.16.10.x 网段

    R2:

    acl number 2000 建立基本acl (表号2000)
    rule 5 deny source 192.168.10.1 0 拒绝源地址为192.168.10.1 的任何数据包。 5为自动生成的执行序号。
    int gi 0/0/0
    traffic-filter inbound acl 2000 在接口的入方向调用acl
    

    ACL举例(2):拒绝PC1 和PC2 ping server 1,但是允许其http 访问。
    R2:

    acl number 3000
    rule 5 deny icmp source 192.168.10.0 0.0.0.255 destination 172.16.10.2 0
    int gi 0/0/0
    traffic-filter inbound acl 3000
    

    ACL 举例(3):拒绝 PC2 telnet 访问12.1.1.2
    R2:

    acl number 3001
    rule 5 deny tcp source 192.168.10.2 0 destination 12.1.1.2 0 destination-port e q telnet
    int gi0/0/0
    traffic-filter inbound acl 3001
    

    注意:

    • 注1:一个接口的同一个方向,只能调用一个acl
    • 注2:一个acl里面可以有多个rule 规则,从上往下依次执行
    • 注3:数据包一旦被某rule匹配,就不再继续向下匹配
    • 注4:默认隐含放过所有(华为的acl 用来拒绝数据包时)
      ACL 举例(4):
      ACL3005
      ① 拒绝源地址是1.1.1.0/24 目标地址是2.2.2.2 ftp 的报文
      ② 允许源地址是1.1.1.0/24 的任何报文
      ③ 拒绝源地址是3.3.3.3 目标是7.7.7.7的任何ping 包
      ④ 拒绝任何telnet 的报文
      ⑤ 放过剩下的所有报文
    acl number 3005
    rule 5 deny tcp source 1.1.1.0 0.0.0.255 destination 2.2.2.2 0 destination-port
    eq ftp-data
    rule 10 deny tcp source 1.1.1.0 0.0.0.255 destination 2.2.2.2 0 destination-por
    t eq ftp
    rule 15 permit ip source 1.1.1.0 0.0.0.255
    rule 20 deny icmp source 3.3.3.3 0 destination 7.7.7.7 0
    rule 25 deny tcp destination-port eq telnet
    rule 30 permit ip
    

    # 华为路由交换技术 | 链路聚合/链路捆绑/端口聚合/eth-channel 详解与配置

      interface Serial4/0/0
    

    在这里插入图片描述
    没有配置链路捆绑之前
    在这里插入图片描述
    链路聚合:是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。链路聚合一般用来连接一个或多个带宽需求大的设备,例如连接骨干网络的服务器或服务器群。

    链路聚合或端口聚合技术:它是一个链路问题,解决的是多个物理链路组成一个逻辑链路,增加带宽和成为冗余备份。这个逻辑链路对于我们来说就是一条链路,它即可以是trunk口,也可以是access口。

    交换机:

    int eth-trunk 1    创建逻辑捆绑接口组1
    int gi 0/0/1      将接口加入接口组1
    eth-trunk 1
    int gi 0/0/2
    eth-trunk 1
    int gi 0/0/3
    eth-trunk 1
    

    在这里插入图片描述
    在这里插入图片描述

    参考链接 :
    华为路由交换技术 | 华为命令行简介 : https://mp.weixin.qq.com/s/xzp5SIFH3uJDiP46WkBgSA

    华为路由交换技术 | DHCP技术 : https://mp.weixin.qq.com/s/hqC3_mIgyM4lWHY-KjpC1Q

    华为路由交换技术 | 静态路由配置 : https://mp.weixin.qq.com/s/rdFVTYp8DTKbcX5p6ARlyg

    华为路由交换技术 | 路由优先级原理与配置 : https://mp.weixin.qq.com/s/MYZmZtKbu8wivhoTPPOR8A

    华为路由交换技术 | 路由协议之RIP原理与配置 : https://mp.weixin.qq.com/s/zIHE9C4ogq6SHkn7u6dJMg

    华为路由交换技术 | OSPF原理与配置 : https://mp.weixin.qq.com/s/nFIktNX1ycODAPqMJC-qhA

    华为路由交换技术 | DHCP技术 : https://mp.weixin.qq.com/s/hqC3_mIgyM4lWHY-KjpC1Q

    华为路由交换技术 | 文件传输协议 FTP原理以及配置(穿插讲解华为系统) : https://mp.weixin.qq.com/s/HZXEN432HuLWRb20BUAYIw

    华为路由交换技术 | 虚拟局域网VLAN详解与配置 :https://mp.weixin.qq.com/s/9Q2sdceDHW3zLUWBTX2XTA

    华为路由交换技术 | 远程登录 Telnet应用(eNSP模拟器) : https://mp.weixin.qq.com/s/2oQo6jdT2xjbyoxubBqTSg

    华为路由交换技术 | 网络地址转换技术NAT(Network Address Translation)详解与配置案例 :https://mp.weixin.qq.com/s/B96od6U2t35z6weJJrNWWg

    华为路由交换技术 | 访问控制列表ACL(Access Control List )详解与配置案例 :https://mp.weixin.qq.com/s/iOsQnyUqytKuXIhnTg-LZg

    华为路由交换技术 | 链路聚合/链路捆绑/端口聚合/eth-channel 详解与配置 :https://mp.weixin.qq.com/s/nRhAwXRiL_uR-0caJaOe1A

    展开全文
  • 华为模拟器,学习华为路由交换配置的非常棒的工具
  • 华为路由交换QOS配置

    千次阅读 2020-05-22 13:53:33
    转载来源 : 华为路由交换QOS配置: https://mp.weixin.qq.com/s/ZjUkOk3weIXd5jAObdGsVQ session 1 QOS基本概念 QoS:Quality of service 服务质量,是指网络通信中,允许用户业务在 丢包率、延迟、抖动和带宽等...

    转载来源 : 华为路由交换QOS配置: https://mp.weixin.qq.com/s/ZjUkOk3weIXd5jAObdGsVQ

    session 1 QOS基本概念

    QoS:Quality of service 服务质量,是指网络通信中,允许用户业务在 丢包率、延迟、抖动和带宽等方面获得预期的服务水平的数据包控制技术。其目标是:

    1、避免网络拥塞
    2、减少丢包率
    3、防止数据包抖动,即调控网络两端的流量速率趋于平缓、相等的速率进行传输,不会出现数据包与数据包之间传输时间的不一致
    4、为特定用户或服务提供专用带宽
    5、支撑网络上的实施业务

    IP QOS的三种模型:

    1、Best-Effort模型,尽力而为,主要技术是队列技术中默认的FIFO先进先出队列技术
    2、IntServ模型,在流量的沿途所有设备上预留资源通道来保障流量的服务,浪费较为严重,并且需要沿途设备都支持此功能。
    3、DiffServ模型,差分服务模型。区分不同的流量来进行不同的策略控制,并且只需要在本地设备或接口上配 置即可,本地有效,只作用于本地设备的转发,不需要沿途设备的资源预留,哪里需要就在哪里进行配 置,目前最常用和实用的QOS模型。

    下面是服务模型的QOS示意图:
    在这里插入图片描述
    DiffServ模型
    在这里插入图片描述

    session 2 QoS的基本元素

    一、流量的分类和标记

    流量的分类:

    使用ACL来区分流量

    流量的标记:

    使用以下

    1、802.1p,L2中vlan头部的字段的前3个bit,共8个分类,用于L2的交换机qos流量的标记,可以分8个队列(2的3次方,因为一个bit只能是0或1)
    在这里插入图片描述
    2、IP-precedence,ip报文中tos字段中的前3个bit的ip优先级,共8个分类,用于L3层路由器的qos,所以也是8个队列与802.1p一一对应。
    在这里插入图片描述
    3、dscp,ip报文中tos字段的前6个bit的dscp优先级,共64个分类,用于L3层路由器的qos。dscp也是使用的TOS的6个bit,前3个bit与ip-percedence一样,后2bit用于控制丢弃几率(称为dd),最后1bit固定为0,所以dscp使用了6个bit来定义队列,就是2的6次方=64个队列。
    在这里插入图片描述
    4、mpls_exp,ip报文的8个bit的最后2个bit,专门用于mpls的qos,用于L2.5层路由器的qos
    在这里插入图片描述
    QoS中的分类和标记都是用于定义对数据流量的进行规定动作(dorp、forward等)的对象,看具体使用的策略而定是使用使用分类还是使用标记来区分不同的流量。但是在网络中所有的厂商的设备都有默认的标记转发策略,也就是说分类和标记都可以管理员自定义流量,但是只有标记是有默认策略的,比如在标记技术ipp、dscp、802.1p、mpls_exp中,不同标记代码(数字或者代码)代表着不同的转发优先级,有默认的标记和策略的对照表可以对照下表看,所以管理员只需要将流量标记为对应的数字或者代码就可以使用设备默认的转发策略来进行qos转发了,当然在这些策略中一些流量也是默认标记好的,比如路由协议BGP、OSPF等流量就在DSCP中被标记为CS类型的流量,执行最优转发策略,而voice语音、视频等流量在dscp中被默认标记为EF和AF4执行快速转发(仅次于CS的优先级),默认的对应关系如图:
    在这里插入图片描述
    上图是默认优先级转发表(也对应了8个队列),但是都是802.1p和ipp的8种分类,DSCP的分类有默认的,只是更加细化了,如下表:

    <0-63>   Differentiated services codepoint value 
    af11     Match packets with AF11 dscp (001010) #对照上表dscp把AF1细化成了af11-af13更多的分类,丢包率递减
    af12     Match packets with AF12 dscp (001100) 
    af13     Match packets with AF13 dscp (001110) 
    af21     Match packets with AF21 dscp (010010) #对照上表dscp把AF1细化成了af11-af13更多的分类,丢包率递减
    af22     Match packets with AF22 dscp (010100) 
    af23     Match packets with AF23 dscp (010110) 
    af31     Match packets with AF31 dscp (011010) #对照上表dscp把AF1细化成了af11-af13更多的分类,丢包率递减
    af32     Match packets with AF32 dscp (011100) 
    af33     Match packets with AF33 dscp (011110) 
    af41     Match packets with AF41 dscp (100010) #对照上表dscp把AF1细化成了af11-af13更多的分类,丢包率递减
    af42     Match packets with AF42 dscp (100100) 
    af43     Match packets with AF43 dscp (100110) 
    cs1      Match packets with CS1(precedence 1) dscp (001000)
    cs2      Match packets with CS2(precedence 2) dscp (010000)
    cs3      Match packets with CS3(precedence 3) dscp (011000)
    cs4      Match packets with CS4(precedence 4) dscp (100000)
    cs5      Match packets with CS5(precedence 5) dscp (101000)
    cs6      Match packets with CS6(precedence 6) dscp (110000)
    cs7      Match packets with CS7(precedence 7) dscp (111000) #对照上表CS也分成了CS-CS6,丢包了递减
    default  Match packets with default dscp (000000) #默认的对应上表的BE,丢包了最高
    ef       Match packets with EF dscp (101110) #对应上表的EF
    

    但是总的丢包了依然与ipp、802.1p一致,丢包率从低到高依次是:cs<ef<af<be,至于对应的数字关系可以不用关系吗,用处不大,只要记住对应的丢包关系就可以了。

    强调一点关于DSCP中的PHB(per hop behavior)逐跳行为,是用来对分类或者标记的数据包执行的动作(比如forward、drop、重标记等),需要配置行为。

    Cisco推荐的几个业务使用DSCP值:

    • 路由协议 CS6
    • 交互式语音 EF
    • 交互式视频 AF41
    • 流式视频 CS4
    • 电话信令 AF31或CS3
    • 网络管理 CS2
    • 大块数据 AF11
    • 尽力服务 0

    流量分类与标记简单的实例配置

    1、使用流分类对流量进行分类

    [Huawei]traffic classifierboss operator and    //定义了一个名为boss的流分类,and参数表示完全匹配分类内定义的acl时才生效
    
    [Huawei-classifier-boss]if-match acl 3999      //这个分类匹配的是acl 3999内定义的数据包
    
    [Huawei-classifier-yuangong]quit
    
    [Huawei]traffic classifieryuangong operator and      //定义了一个名为yuangong的流分类,完全匹配acl3998时分类才生效
    
    [Huawei-classifier-yuangong]if-match acl 3998        //这个分类匹配的是acl 3998内定义的数据包
    
    [Huawei-classifier-yuangong]quit
    

    以上定义了2个流分类,分别为boss和员工,在acl3999和acl3998中可以分别匹配boss和员工的ip地址来区别流量。

    2、使用流行为对数据包进行标记(或者动作)

    [Huawei]traffic behaviorboss                                       //创建流行为名为boss
    
    [Huawei-behavior-boss]remark dscp af43                    //将boss的流量标记位dscp重要优先级af43
    
    [Huawei-behavior-boss]quit
    
    [Huawei]traffic behavioryuangong                           //创建流行为名为yuangong
    
    [Huawei-behavior-yuangong]remark dscp default     //将员工的流量标记位默认优先级的BE
    
    [Huawei-behavior-yuangong]quit
    

    3、在流策略中将流分类与流行为进行关联

    [Huawei]traffic policyboss-prority                                                                  //创建流策略名为boss-prority
    
    [Huawei-trafficpolicy-boss-prority]classifierboss behaviorboss                       //将boss的流分类和流行为关联
    
    [Huawei-trafficpolicy-boss-prority]classifieryuangong behavioryuangong     //将yuangong的流分类和流行为关联
    
    [Huawei-trafficpolicy-boss-prority]quit
    

    以上三步就完成了boss的流量标记位af43,而员工的流量被标记位默认的be,从而达到让boss的流量优先转发的目的。

    补充:最后要使用默认的优先级策略的话,需要再设备对应的接口(出、入) 配置信任相应的qos协议(802.1p、ipp、dscp等)

    4、最后在设备的接口上应用流策略就可以

    [Huawei-Serial4/0/0]traffic-policyboss-prority outbound      //将流策略boss-prority应用在上行接口的出方向上
    
    [Huawei-Serial4/0/0]quit
    

    方向的话自己可以根据上、下行接口自行定义,只要能达到流量管理的效果就可以了。最后可以使用:

    [Huawei-Serial4/0/0]display traffic ?                    命令来查看配置是否正确
    
      behavior    Traffic behavior configuration information
      classifier  Traffic classifier configuration information
      policy      <Group> policy command group
    

    二、流量的管制(监管)和整形

    管制(car),即限速技术,利用令牌桶的概念来完成。大致就是流量在进入设备接口准备转发之前,让在一定的时间内(一般为1s)有多少(数量)流量能够从令牌桶里得到允许转发的令牌(令牌数量的多少是根据令牌桶的容量大小来放置的),能够拿到令牌的流量就给予转发,没有拿到令牌的流量就给予丢弃,或者重新标记或者转发(可以根据需要自行设定对于没有拿到令牌的流量的处理方式)。在管制里最多有2个令牌桶的存在,第一个桶叫做cbs桶,第二个桶叫做pbs桶(至于三种颜色,那都是根据自己的需要进行配置的,默认是绿色是拿到第一个令牌桶cbs里的令牌的流量,黄色是只拿到第二个令牌桶pbs里的令牌,而红色的就是没有拿到任何一个令牌桶里的流量,也就是一般所说的超出规定的流量,默认策略是丢弃,但是也可以自行修改)

    流量管制的实例配置

    1、接口下配置流量管制

    [Huawei]interface s4/0/0
    
    [Huawei-Serial4/0/0]qos car outbound acl 3999 cir 8000 pir 10000 cbs 1000000 pbs 1250000 green  pass  yellow  pass  red  discard
    
    [Huawei-Serial4/0/0]quit
    

    在s4/0/0接口出方向配置了流量管制(限速),匹配acl3999的流量将会执行car限速管理,保证速率cir=8000kbps=8Mbps/s,允许最大速率pir=10Mbps/s,cbs桶大小=1000000byte=8000kbit(对应了cir的8Mbps/s=cbs/1s=8Mkbit/1s=8Mkbps/s),第二个令牌桶pbs桶大小 =1250000byte=10kbit(同样对应了pir的10Mbps/s),后面的green、yellow、red三种颜色分别对应了小于cbs桶的流量为允许、大于cbs<pbs桶的流量为允许、大于pbs桶的流量为丢弃等动作,也可以自定义这些颜色的动作(是否丢弃、重新标记等)。

    查看接口配置命令:

    [Huawei]display current-configuration interface s4/0/0
    [V200R003C00]
    #
    interface Serial4/0/0
     link-protocol ppp
     qos car outbound acl 3999 cir 8000 pir 10000 cbs 1000000 pbs 1250000 green pass yellow pass red discard
    #
    return
    [Huawei]
    

    以上就是接口上直接配置管制的配置实例,采用了双令牌桶的配置(cbs、pbs的大小可以不用配置,系统会根据定义的cir和pir的值自动计算,比如上面的命令等价于qos car outbound acl 3999 cir 8000 pir 10000),如果要采用单令牌桶的严格控制配置,那么将pir峰值速率参数去掉只配置cir保证速率就可以了,就会严格按照cir中的速率进行匹配,超出的丢弃,而不再有允许的最大值了,具体配置可以改为:

    [Huawei-Serial4/0/1]qos car outbound cir 8000         //只定义保证速率cir=8Mbps/s就可以了
    

    2、使用全局流配置接口应用的方式配置流量管制(与流量分类和标记的配置步骤一样)

    2.1、使用流分类匹配感兴趣的流量

    [Huawei]traffic classifier car operator and                            创建流分类名为car
    
    [Huawei-classifier-car]if-match acl 3999
    
    [Huawei-classifier-car]quit
    

    2.2、使用流行为来对数据做流量管制

    [Huawei]traffic behavior car                                                  创建流行为名为car
    
    [Huawei-behavior-car]car cir 8000 pir 10000 
    
    [Huawei-behavior-car]quit
    

    2.3、使用流策略关联流分类和流行为

    [Huawei]traffic policy car                                                      创建流策略名为car
    
    [Huawei-trafficpolicy-car]classifier car behavior car           在流策略中关联流分类和流行为
    [Huawei-trafficpolicy-car]quit
    

    2.4、在接口上应用流策略

    [Huawei]interface s4/0/1
    
    [Huawei-Serial4/0/1]traffic-policy car outbound                在接口的出方向上调用流策略
    [Huawei-Serial4/0/1]quit
    

    查看流策略的配置,可以看到流策略中所关联的流分类和流行为:

    [Huawei]display traffic policy user-defined car
      User Defined Traffic Policy Information:
      Policy: car
       Classifier: car
        Operator: AND
         Behavior: car
          Committed Access Rate:
            CIR 8000 (Kbps), PIR 10000 (Kbps), CBS 1000000 (byte), PBS 1250000 (byte
    )
            Color Mode: color Blind 
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
    [Huawei]
    

    流量的整形,分为GTS(Generic traffic shaping)通用流量整形和LR(Line Rate)物理接口限速,用来均衡流量两端设备的速率,使速率达到一致,使流量的速率趋于平稳的发送,防止出现数据包的抖动,流量整形通常使用接口的缓冲区或队列和令牌桶来完成,当流出某一网络的报文速度过快时,将出向的报文放入出接口的缓冲区或队列进行缓存,在令牌桶的控制下进行均匀的发送这些被缓存的报文,所以整形只是用于调整网络速率达到一致而并非关注对于超出报文的丢弃,也只能用于接口出方向,这是与管制最大的两点区别。

    流量整形的配置实例:

    1、基于接口的流量整形(路由器和交换机上具体命令不一样)

    1.1、在交换机上基于接口的流量在整形配置

    [Huawei]interface g0/0/2
    
    [Huawei-GigabitEthernet0/0/2]qos lr outbound cir 8000 cbs 1000000   配置接口的总速率为8Mbps/s,令牌桶大小为1Mbyte
    
    [Huawei]quit
    

    1.2、在交换机上基于接口队列的流量整形配置

    [Huawei]interface g0/0/2
    
    [Huawei-GigabitEthernet0/0/3]qos queue 6 shaping cir 8000 pir 10000  配置队列6整形的速率为8Mbps/s,桶1Mbyte
    
    [Huawei-GigabitEthernet0/0/3]quit
    

    1.3、在路由器上配置基于接口的流量整形

    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]qos gts cir 8000          配置接口的发送数据的速率为8Mbps/s
    [Huawei-GigabitEthernet0/0/1]quit 
    

    1.4、在路由器上配置基于队列的流量整形

    [Huawei]qos queue-profile gts                                                   创建队列模板,名为gts
    
    [Huawei-qos-queue-profile-gts]queue 5 to 6 gts cir 5000           配置队列56使用gts整形,速率为5Mbps/s
    
    [Huawei-qos-queue-profile-gts]quit
    
    [Huawei]interface g0/0/1                                                           进入流量出接口
    
    [Huawei-GigabitEthernet0/0/1]qos queue-profile gts                 将队列整形策略应gts用在出接口
    
    [Huawei-GigabitEthernet0/0/1]quit
    

    2、队列流量整形的配置实例,交换机。

    组网需求

    Switch通过接口GE0/0/2与路由器互连,来自Internet的业务有语音、视频、数据,携带的
    802.1p优先级分别为6、5、2,这些业务可经由路由器和Switch到达用户,如图3-4所
    示。由于来自网络侧的流量速率大于LSW接口的速率,出接口GE0/0/1处可能会发生带
    宽抖动。为减少带宽抖动,同时保证各类业务带宽要求,现要求如下:
    l 端口保证带宽为10000kbit/s。
    l 语音保证带宽为3000kbit/s,峰值带宽为5000kbit/s。
    l 视频保证带宽为5000kbit/s,峰值带宽为8000kbit/s。
    l 数据保证带宽为2000kbit/s,峰值带宽为3000kbit/s。
    在这里插入图片描述

    配置思路

    (图例与配置思路也可以用于上面的流量管制,只是管制的配置比较模块化,很好配置,匹配也很灵活就不配图例了)
    采用如下的思路配置流量整形:

    创建VLAN,并配置各接口,使用户能够通过Switch访问网络。
    配置接口信任报文的802.1p优先级。
    配置端口整形功能,限制端口带宽。
    配置端口队列整形功能,限制语音、视频、数据三类业务的带宽。

    操作步骤

    步骤1 创建VLAN并配置各接口

    创建VLAN 10。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    

    将接口GE0/0/1、GE0/0/2的接入类型分别配置为trunk,并分别将接口GE0/0/1、GE0/0/2加入VLAN 10。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    创建VLANIF10,并配置网段地址10.10.10.1/24[Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.10.10.1 255.255.255.0
    [Switch-Vlanif10] quit
    

    说明请在Router上的与Switch对接的接口上配置IP地址10.10.10.2/24。
    步骤2 配置接口信任报文的类型

    配置接口信任报文的802.1p优先级。

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] trust 8021p inner      配置接口信任802.1p内层优先级(外层vlan是outer参数,用于QinQ的外层的vlan优先级)
    [Switch-GigabitEthernet0/0/2] quit
    

    步骤3 配置端口整形

    在Switch上配置端口整形,将端口速率限制在10000kbit/s。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos lr outbound cir 10000
    

    步骤4 配置端口队列整形

    在Switch上配置端口队列整形,使语音、视频、数据业务的保证带宽分别为3000kbit/s、5000kbit/s、2000kbit/s,峰值带宽分别为5000kbit/s、8000kbit/s、3000kbit/s。

    [Switch-GigabitEthernet0/0/1] qos queue 6 shaping cir 3000 pir 5000             将语音流量整形为3Mbps/s
    [Switch-GigabitEthernet0/0/1] qos queue 5 shaping cir 5000 pir 8000             将视频流量整形为8Mbps/s
    [Switch-GigabitEthernet0/0/1] qos queue 2 shaping cir 2000 pir 3000             将数据业务流量整形为2Mbps/s
    [Switch-GigabitEthernet0/0/1] quit
    

    步骤5 验证配置结果

    配置成功后,从接口GE0/0/1发出的报文保证速率为10000kbit/s;语音业务保证速率为3000kbit/s,不超过5000kbit/s;视频业务保证速率为5000kbit/s,不超过8000kbit/s;数据业务保证速率为2000kbit/s,不超过3000kbit/s。

    三、流量的拥塞避免与拥塞管理

    流量的拥塞避免和拥塞管理使用的环境是因为网络出口的带宽有限,而流量过大造成重要业务数据包被为丢弃,如下图就是造成拥塞发生2种环境:

    下图中企业边界路由器CE的出入接口的流量不一致,会导致在出接口发生拥塞:
    在这里插入图片描述
    下图中边界路由器入向流量总和大于出口带宽没造成出接口网络拥塞:
    在这里插入图片描述
    流量的拥塞避免,就是对于流量数据包的丢弃策略技术,用于控制对数据包进行如何丢弃的技术。一般有四种对于数据包的丢弃策略,分别为:

    1、Tail-drop为丢弃,接口默认的丢弃策略,用于将超出接口带宽速率的流量进行尾部丢弃,无区分丢弃。

    2、RED(Random Early Detection)随机早期检测,通过设置队列的最小和最大阈值来控制丢弃,超过最大阈值的流量会随机丢弃。

    3、SRED(simple RED)简单随机早期检测

    4、WRED(weight RED)加权随机早期检测,通过设置队列的最小和最大阈值来控制丢弃,超过最大阈值的流量会按照权重的大小来随机丢弃,权重越小的队列丢弃的包越多

    流量的拥塞管理,就是队列技术,用于将流量放入不同的队列中执行不同的转发策略,队列技术有很多种从技术发展的先后顺序来看分为下列几种队列技术:

    1、fifo,LAN网络接口默认的先进先出队列技术

    2、rr,轮询队列技术,每个队列公平的轮流发送数据。

    3、wrr,权重轮询队列技术,针对于rr队列有了队列的优先转发的特点,权重越大队列内数据被转发的几率越高。

    4、drr,差额轮询队列技术,与wrr类似,但是真正实现了流量按照报文大小的调度,略优于wrr的优先小报文的特性,是wrr的改良版。

    5、PQ,优先级队列技术,严格按照队列优先级转发,只有当优先级高的队列中没有数据时才会转发优先级低的队列,会造成优先级低的队列一直不能进行转发,而PQ也不能手动配置队列的优先级,它遵循系统默认8个队列的优先级,0-7队列优先级从高到低。

    6、CQ,定制队列,PQ的升级版,优于PQ的地方时可以自定义队列的优先级(PQ只能使用系统默认的7个队列优先级),而CQ有17个队列,其中队列0用于系统路由协议等优先级固定最高,剩下16个队列可以用户自定义优先级,然后采用优先级+轮询的方式进行队列的管理。

    7、WFQ,加权公平队列,按照队列的权重分配带宽,而不是转发几率。与wrr和drr相比,公平性更好使多种队列的流量更加公平的转发,防止某一种流量(权重大的)的数据独占整个链路的带宽,最多支持4096个队列,WFQ的队列是按照5元组来分的,并不能手动配置。wfq也是WAN网络接口默认的队列策略。

    说明:流量的拥塞管理和拥塞避免是相辅相成的,使用是一起使用的,单个没法使用,因为你定了一种队列的转发策略(拥塞管理)那么就必须定义对于这个队列流量满了后的丢包策略(拥塞避免),否则接口无法正常工作。

    拥塞避免和拥塞管理的配置实例:

    1、在交换机上的配置实例:

    交换机SW分别连接内网和互联网,来自Internet的流量有语音、视频、和用户数据流量,携带802.1p默认优先级6、5、2,对应队列为6、5、2(默认情况下优先级和队列的对应关系是一一对应的,优先级0-7对应了队列0-7),这些业务经过sw到达用户,为减轻网络拥塞造成的影响,保证用户对于高优先级、、低延迟业务的服务要求,需要在sw上配置拥塞避免和拥塞管理功能,配置如下:
    在这里插入图片描述
    第一步,在sw的g0/0/3接口上配置信任来自internet的带有qos优先级的流量(交换机默认不信任任何qos流量,需要对应的开启),在本例中因为使用wred丢弃机制(现在交换机貌似只能支持这一种丢弃机制,其他的RED、SRED淘汰了),wred配置中要求对流量进行着色区分,就必须要求交换机支持dscp(与8021p映射),所以必须进行802.1p到dscp的优先级映射并为队列标记颜色,所以交换机需要创建并信任一个DiffServ域的802.1p与dscp的映射关系。

    [Huawei]diffserv domain 8021p-dscp                                                   创建差分服务模型的映射域,名为8021p-dscp
    
    [Huawei-dsdomain-8021p-dscp]8021p-inbound 6 phb ef green   将入向的802.1p优先级6映射为dscp的优先级ef,并标为绿色
    
    [Huawei-dsdomain-8021p-dscp]8021p-inbound 5phb af4 yellow  将入向的802.1p优先级5映射为dscp的优先级af4,标为黄色
    
    [Huawei-dsdomain-8021p-dscp]8021p-inbound 2 phb af2 red      将入向的802.1p优先级2映射为dscp的优先级af2,标为红色
    
    [Huawei-dsdomain-8021p-dscp]quit
    
    [Huawei]interface g0/0/3                                                              进入接收internet流量的接口
    [Huawei-GigabitEthernet0/0/3]trust upstream 8021p-dscp            配置接口信任映射域中映射的优先级和标记的颜色
    [Huawei-GigabitEthernet0/0/3]quit
    

    第二步、配置拥塞管理队列,在下行入接口配置队列控制策略

    [Huawei]port-group 1                                                                   创建端口组1
    
    [Huawei-port-group-1]group-member g0/0/1 to g0/0/2               将g0/0/1和g0/0/2加入端口组1,进行批量配置
    
    [Huawei-port-group-1]qos drr                                                    在下行端口g0/0/1和g0/0/2中启用drr队列技术实现拥塞管理
    [Huawei-port-group-1]qos queue 6 drr weight 100                     指定队列6(优先级也为6)在drr队列调度中的权重为100
    
    [Huawei-port-group-1]qos queue 5 drr weight 80                       指定队列5(优先级也为6)在drr队列调度中的权重为80
    
    [Huawei-port-group-1]qos queue 2 drr weight 50                       指定队列2(优先级也为6)在drr队列调度中的权重为50
    
    [Huawei-port-group-1]quit
    

    第三步、为相应的队列配置拥塞避免丢包策略,并按照不同颜色设定最低阈值和最高阈值的丢弃门限和丢包率

    [Huawei]drop-profile wred_drop                                                 创建丢包策略模板,名为wred_drop
    
    [Huawei-drop-queue6] color green low-limit 80 high-limit 100 discard-percentage 10
    
    配置标记为绿色的队列(之前映射标记的队列6的流量)最低丢包门限为80,最高门限为100,丢弃率为10%,,这里达到80但是未超过100的话就开始丢包,丢包率10%,但是超过门限100的话就进行尾丢弃。下面的同理。
    
    [Huawei-drop-queue6] color yellow low-limit 60 high-limit 80 discard-percentage 20
    
    [Huawei-drop-queue6] color red low-limit 40 high-limit 60 discard-percentage 40
    
    [Huawei-drop-queue6] quit
    

    第四步、在下行流量入接口为相应的队列应用相应的丢弃策略

    [Huawei]port-group 1
    [Huawei-port-group-1]group-member g0/0/1 to g0/0/2                批量配置接口g0/0/1和g0/0/2
    
    [Huawei-port-group-1] qos wred wred_drop                           配置接口使用的拥塞避免丢包策略为wred,关联配置的丢包策略
    
    [Huawei-port-group-1] qos queue 6 wred wred_drop              指定队列6使用丢弃模板wred_drop中配置的策略进行丢包
    
    [Huawei-port-group-1] qos queue 5 wred wred_drop              指定队列5使用丢弃模板wred_drop中配置的策略进行丢包
    
    [Huawei-port-group-1] qos queue 2 wred wred_drop              指定队列2使用丢弃模板wred_drop中配置的策略进行丢包
    
    [Huawei-port-group-1] quit
    

    最后检查命令:

    [Huawei]display diffserv domain name 8021p-dscp             查看差分服务域的映射是否正确
    
    diffserv domain name:8021p-dscp
     8021p-inbound 0 phb be green
     8021p-inbound 1 phb af1 green
     8021p-inbound 2 phb af1 red
     8021p-inbound 3 phb af3 green
     8021p-inbound 4 phb af4 green
     8021p-inbound 5 phb af4 yellow
     8021p-inbound 6 phb ef green
     8021p-inbound 7 phb cs7 green
     8021p-outbound be green map 0
     8021p-outbound be yellow map 0
     8021p-outbound be red map 0
     8021p-outbound af1 green map 
    
    。。。。。。
    
    [Huawei]display drop-profile name wred_drop                   查看丢包策略的配置
    Drop-profile[1]: queue6
    Color     Low-limit   High-limit  Discard-percentage  
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Green     80          100         10                  
    Yellow    60          80          20                  
    Red       40          60          40                  
    Non-tcp   100         100         100                 
    -----------------------------------------------------------------
    [Huawei]
    

    2.在路由器上的配置实例

    还是以上图为例,将SW换成AR路由器,配置如下:

    第一步、配置拥塞避免的丢弃策略,使用丢弃模板

    [Huawei]drop-profile voice                                          创建丢包策略模板,名为voice
    
    [Huawei-drop-profile-voice]wred ip-precedence          指定丢弃策略将用于ip-percedence优先级队列
    
    [Huawei-drop-profile-voice] ip-precedence 6  low-limit 80 high-limit 100 discard-percentage 10
    
    //配置ip优先级为6的队列6的丢弃门限阈值为80-100,超过80而没有超过100的,丢包的丢弃概率10%,超过100的执行尾丢弃
    
    [Huawei-drop-profile-voice] ip-precedence 5  low-limit 70 high-limit 90 discard-percentage 20
    
    [Huawei-drop-profile-voice] ip-precedence 0 to 4 low-limit 60 high-limit 80 discard-percentage 40
    
    [Huawei-drop-profile-voice] quit
    

    第二步、配置拥塞管理队列策略,使用队列模板

    [Huawei] qos queue-profile voice                                                 创建队列模板,名为voice
    
    [Huawei-qos-queue-profile-voice] schedule wfq 0 to 7                 配置所有队列使用wfq队列调度技术
    
    [Huawei-qos-queue-profile-voice] queue 6 weight 100                 配置队列6的权重为100
    
    [Huawei-qos-queue-profile-voice] queue 5 weight 80                   配置队列5的权重为80
    
    [Huawei-qos-queue-profile-voice] queue 0 to 7 drop-profile voice        配置所有队列都使用丢弃模板voice 
    

    第三步、在拥塞发生的出接口G0/0/3上应用队列模板

    [Huawei]interface g0/0/1
    
    [Huawei-GigabitEthernet0/0/1]qos queue-profile voice                  将队列模板配置应用到出接口上
    
    [Huawei-GigabitEthernet0/0/1]quit
    

    检查配置命令:

    [Huawei]display drop-profile voice                    查看丢弃模板配置
    Drop-profile[1]: voice
    IP-Precedence      Low-limit   High-limit  Discard-percentage  
    -----------------------------------------------------------------
    0(routine)         60          80          40                  
    1(priority)        60          80          40                  
    2(immediate)       60          80          40                  
    3(flash)           60          80          40                  
    4(flash-override)  60          80          40                  
    5(critical)        70          90          20                  
    6(internet)        80          100         10                  
    7(network)         30          100         10                  
    -----------------------------------------------------------------
    [Huawei]
    
    [Huawei]display qos queue-profile voice             查看队列模板的配置
    Queue-profile: voice
    Queue  Schedule  Weight  Length(Bytes/Packets) GTS(CIR/CBS)
    -----------------------------------------------------------------
    0      WFQ       10                 -/-              -/-     
    1      WFQ       10                 -/-              -/-     
    2      WFQ       10                 -/-              -/-     
    3      WFQ       10                 -/-              -/-     
    4      WFQ       10                 -/-              -/-     
    5      WFQ       80                 -/-              -/-     
    6      WFQ       100                -/-              -/-     
    7      WFQ       10                 -/-              -/-     
    [Huawei]
    

    最后,至于上面设置的队列技术让那些流量去匹配,设备默认的应该就是queue6是语音流量、queue5是视频流量、queue0-4是普通的数据流量,如果有自定义需求或者想要改变流量对应的默认优先级和队列,那么可以在设备的下行接口处使用管制中的traffic流分类抓取自定义流量,在用流行为重新标记这些流量为自定义的优先级和队列,在使用流策略关联流分类和流行为,最后在下行2个接口上使用流策略,这样流量就会被重新标记为自定义的优先级和队列(队列和优先级是一一对应的)了,然后就可以根据G0/0/3出接口上配置的拥塞管理和拥塞避免策略进行流量的转发了。

    展开全文
  • 华为路由交换配置手册 全面的总结,很有用的东西
  • 一个有态度的优质教程集聚地 帮助过上万位网友解决教程需求问题 教程仅用于学习交流,禁止用于商业交易©猜您喜欢往期精选▼ 从零开始学习华为路由交换 | 配置telnet远程登陆管理 从零开始学习华为路由交换 | 配置...

    836cce9e431b0d2ce5cb312aa0b850b5.png

    首先了解一下ICMP协议:

    ICMP协议(英特网信息管理协议):在这个协议中提供了对网络运行状态进行检测的工具。

    我们可以通过这个协议提供的工具去收集网络的相关信息。

    1.ping:这个命令可以帮助我们检测网络中不同节点3的IP连通性在ping命令后面即可以跟IP地址,也可以跟上域名。ping同就能收到目标节点的应答

    2.traceroute(tracert):可以跟踪网络中从源节点到目标节点中间所经过的所有三层节点信息

    traceroute(tracert):后面可以跟IP或域名

    traceroute 是思科命令

    tracert:是微软,华为命令

    实验前准备

    1、电脑上安装华为ENSP模拟器

    2、添加两台路由器

    44e48bd1328a21c9fc9f33ab9a0c204d.png

    命令介绍

    1.配置R1接口IP
    2.查看R1接口IP:
    [R1]display ip interface brief
    3.查看R1路由表:
    [R1]display ip routing-table 

    (可以看到接口IP对应的直连路由)

    1.配置R2接口IP
    2.查看R2接口IP:
    [R2]display ip interface brief
    3.查看R2路由表:
    [R2]display ip routing-table 

    (可以看到接口IP对应的直连路由)

     5f8a13b20552c14b690a52dceca7cf1e.gif

     5f8a13b20552c14b690a52dceca7cf1e.gif

    1c27a37e0b6ffa515c49e4103ad4609c.png

    瑞哥建了一个微信群,不在群的朋友,可以加瑞哥微信(备注单位+姓名)

    进群前先转发本图文至朋友圈,添加后截图给瑞哥,立即拉群!

    一个有态度的优质教程集聚地

    帮助过上万位网友解决教程需求问题

    教程仅用于学习交流,禁止用于商业交易©

    猜您喜欢往期精选▼

    从零开始学习华为路由交换 | 配置telnet远程登陆管理

    从零开始学习华为路由交换 | 配置ssh远程管理

    b6e5b671938eda03b81c81466da25c80.png

    努力学习,勤奋工作,让青春更加光彩

    f0de76af850fa030820f3fa1debba8a8.png

    再长的路,一步步也能走完,再短的路,不迈开双脚也无法到达

    展开全文
  • 华为路由交换模拟器HW-RouteSim 华为路由交换模拟器HW-RouteSim
  • 华为路由交换实验模拟器,可以模拟各种实验,想要学习华为设备的朋友可以下载学习。
  • 实验前准备1、电脑上安装华为ENSP模拟器2、添加三台路由器配置命令AR1配置1.配置接口IP2.配置RIPv2协议3.配置RIPv2明文认证:[R1-GigabitEthernet0/0/0]rip authentication-mode simple cipher huawei123AR2配置1....
  • 智汇云校ICT人才培养与培训认证品牌华为路由交换工程师认证 HCIA-Routing & Switching V2.5(中文版) 自2019年5月22日起,正式在中国区发布。1发布概述华为认证是华为公司基于“平台+生态”战略,围绕“云-管-端...
  • 华为路由交换HCIE-R&S精英培训配套教材PPT全套
  • 华为na、np路由交换认证知识点总结,考试前可以看看。
  • 从零开始学习华为路由交换系列

    千次阅读 2020-06-05 15:36:52
    1、从零开始学习华为路由交换 | 模式切换 实验前准备 1、电脑上安装华为ENSP模拟器 2、添加一个路由器 命令介绍 1.实现配置模式的切换: 从用户模式进入系统模式 <Huawei>system-view [Huawei] 从系统模式...
  • 转载来源 :华为路由交换 | 配置ssh远程管理 :https://mp.weixin.qq.com/s/EIRUI78Q_yJPpo1Wtjrt4g https://mp.weixin.qq.com/s/1_2hBALYMnFYWDsw5kfmpQ 配置ssh远程管理 实验前准备 1、电脑上安装华为ENSP模拟器 2...
  • 华为路由交换STP/RSTP/MSTPSTP原理BPDU (网桥协议数据单元)根桥端口角色(指定、根、阻塞)端口状态STP拓扑发生变化RSTP端口角色 STP 原理 通过发送BPDU来确拓扑结构,根据互相交互的BPDU来选举出根桥和端口角色从而...
  • 【企业常见应用技术系列】第二期:华为路由交换由学习汇总
  • 华为路由交换笔记1-基础部分

    千次阅读 多人点赞 2018-05-18 09:42:17
    华为路由交换笔记1-基础部分一、企业网络基本架构核心层、汇聚层、接入层接入层:直接控制到桌面的网络连接,多使用低端的交换机、路由器汇聚层:完成接入层设备的连接,提供访问列表、数据包过滤及排序、安全和网络...
  • 借助于帮助系统,您可以了解到通用路由平台VRP(VRP5.10)所有命令帮助信息   命令 视图 参数 描述 举例
  • 华为链路聚合
  • 华为路由交换设备配置综合实验: 单臂路由、三层交换、动静路由、VRRP路由、DHCP中继、捆绑Etrunk链路(实验六合一) 实验拓扑图: 目的:实现全网各个PC之间的互联互通 全部实验脚本如下,以下脚本直接复制即可...
  • 2 华为路由交换的基本命令 [SwitchA-vlanx]isolate-user-vlan enable 设置主vlan [SwitchA]Isolate-user-vlan <x> secondary <list> 设置主vlan包括的子vlan [Quidway-Ethernet0/2]port hybrid pvid vlan <id> ...
  • 华为路由交换精讲系列22:BGP技术 肖哥视频课程 肖老师(肖哥),思科认证...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,306
精华内容 522
关键字:

华为路由交换