精华内容
下载资源
问答
  • ensp综合组网实验

    万次阅读 多人点赞 2020-04-30 17:58:44
    一、实验背景 本实验以某大学校区信息平台2号楼实验楼网络工程项目的应用需求为背景,规划一个6层楼,约30个机房1600多台计算机的实验教学网络。 二、概述 利用网络设计规划、地址分配、VLAN划分、路由协议、网络...

    一、实验背景

    本实验以某大学校区信息平台2号楼实验楼网络工程项目的应用需求为背景,规划一个6层楼,约30个机房1600多台计算机的实验教学网络。

    二、概述

    利用网络设计规划、地址分配、VLAN划分、路由协议、网络管理、组播协议、地址转换、访问控制等技术,实现网络设计。

    三、实验设计

    • Vlan划分及配置
    • DHCP协议配置
    • STP协议配置
    • 路由备份
    • VRRP协议配置
    • OSPF协议配置
    • PPP认证
    • 组播协议配置
    • 远程登录控制
    • SNMP协议配置

    四、实验拓扑

    在这里插入图片描述

    五、具体配置

    1、首先配置一楼(三楼与其配置类似,不再赘述);
    LSW5的配置如下:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info enable
    Info: Information center is disabled.
    [Huawei]sysname S5
    [S5]vlan 30
    [S5-vlan30]vlan 10
    [S5-vlan10]int e0/0/2
    [S5-Ethernet0/0/2]port link-type access
    [S5-Ethernet0/0/2]port default vlan 10
    [S5-Ethernet0/0/2]q
    [S5]int e0/0/1
    [S5-Ethernet0/0/1]port link-type trunk
    [S5-Ethernet0/0/1]port trunk allow-pass vlan all
    [S5-Ethernet0/0/1]q
    [S5]q
    

    LSW1的配置如下:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info enable
    Info: Information center is disabled.
    [Huawei]sysname S1
    [S1]vlan batch 2 10 20
    [S1]int vlan 2
    [S1-Vlanif2]ip add 192.168.1.1 24
    [S1-Vlanif2]q
    [S1]int g0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk
    [S1-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [S1-GigabitEthernet0/0/1]q
    [S1]int vlan 10
    [S1-Vlanif10]ip add 10.1.1.1 24
    [S1-Vlanif10]q
    [S1]int g0/0/2
    [S1-GigabitEthernet0/0/2]port link-type trunk
    [S1-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [S1-GigabitEthernet0/0/2]q
    [S1]int vlan 20
    [S1-Vlanif20]ip add 10.1.2.1 24
    [S1-Vlanif20]q
    [S1]int g0/0/3
    [S1-GigabitEthernet0/0/3]port link-type trunk
    [S1-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    [S1-GigabitEthernet0/0/3]q
    [S1]q
    

    2、配置二楼;
    LSW7的配置如下:

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info enable
    Info: Information center is disabled.
    [Huawei]sysname S7
    [S7]vlan 30
    [S7-vlan30]int vlan 30
    [S7-Vlanif30]ip add 10.2.1.1 24
    [S7-Vlanif30]q
    [S7]int e0/0/2
    [S7-Ethernet0/0/2]port link-type access
    [S7-Ethernet0/0/2]q
    [S7]int e0/0/1
    [S7-Ethernet0/0/1]port link-type trunk
    [S7-Ethernet0/0/1]port trunk allow-pass vlan all
    [S7-Ethernet0/0/1]q
    [S7]q
    <S7>sys
    Enter system view, return user view with Ctrl+Z.
    [S7]int e0/0/2
    [S7-Ethernet0/0/2]port default vlan 30
    [S7-Ethernet0/0/2]q
    [S7]q
    <S7>save
    

    LSW2的配置如下:

    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info enable
    Info: Information center is disabled.
    [Huawei]sysname S2
    [S2]vlan batch 3 30 40
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S2]int vlan 3
    [S2-Vlanif3]ip add 192.168.2.1 24
    [S2-Vlanif3]q
    [S2]int g0/0/1
    [S2-GigabitEthernet0/0/1]port link-type trunk
    [S2-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [S2-GigabitEthernet0/0/1]q
    [S2]int vlan 30
    [S2-Vlanif30]ip add 10.2.1.1 24
    [S2-Vlanif30]q
    [S2]int vlan 40
    [S2-Vlanif40]ip add 10.2.2.1 24
    [S2-Vlanif40]q
    [S2]int g0/0/2
    [S2-GigabitEthernet0/0/2]port link-type trunk
    [S2-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [S2-GigabitEthernet0/0/2]q
    [S2]int g0/0/3
    [S2-GigabitEthernet0/0/3]port link-type trunk
    [S2-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    [S2-GigabitEthernet0/0/3]q
    [S2]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [S2]int vlan 30
    [S2-Vlanif30]dhcp select int
    [S2-Vlanif30]dhcp server dns-list 10.2.1.1
    [S2-Vlanif30]dhcp server lease day 4
    [S2-Vlanif30]q
    [S2]int vlan 40
    [S2-Vlanif40]dhcp select int
    [S2-Vlanif40]dhcp server dns-list 10.2.2.1
    [S2-Vlanif40]dhcp server lease day 4
    [S2-Vlanif40]q
    [S2]q
    <S2>save
    

    其中包含了DHCP的配置。使用命令ipconfig查看PC3和PC4已被分配到IP地址。
    3、先为路由器配置虚接口
    以R2为例(其它类似,不再赘述):

    <Huawei>
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info enable
    Info: Information center is disabled.
    [Huawei]sysname R2
    [R2]int loop1
    [R2-LoopBack1]ip add 192.168.50.1 24
    [R2-LoopBack1]q
    [R2]int e0/0/1       
    [R2-Ethernet0/0/1]ip add 192.168.20.15 24
    [R2-Ethernet0/0/1]q
    [R2]int e0/0/0       
    [R2-Ethernet0/0/0]ip add 192.168.100.3 24
    [R2-Ethernet0/0/0]q
    [R2]q
    <R2>save
    

    4、配置静态路由
    静态路由:

    ip route-static 目的地址 子网掩码 下一跳地址
    

    5、链路聚合的配置方法
    因为本实验汇聚交换机与核心交换机之间只有一条链路,大家可增添两条链路,配置链路聚合.
    以LSW1为例,配置链路聚合:
    LACP模式下,需手工创建Eth-Trunk,手工加入Eth-Trunk成员接口。

    <S1>sys
    Enter system view, return user view with Ctrl+Z.
    [S1]int eth-trunk 1
    [S1-Eth-Trunk1]mode lacp-static
    [S1-Eth-Trunk1]int g0/0/2
    [S1-GigabitEthernet0/0/2]eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S1-GigabitEthernet0/0/2]int g0/0/3
    [S1-GigabitEthernet0/0/3]eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S1-GigabitEthernet0/0/3]int g0/0/4
    [S1-GigabitEthernet0/0/4]eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S1-GigabitEthernet0/0/4]q
    [S1]int eth-trunk 1
    [S1-Eth-Trunk1]max active-linknumber 2
    [S1-Eth-Trunk1]int g0/0/2
    [S1-GigabitEthernet0/0/2]lacp priority 100
    [S1-GigabitEthernet0/0/2]int g0/0/3
    [S1-GigabitEthernet0/0/3]lacp priority 100
    [S1-GigabitEthernet0/0/3]q
    

    6、配置OSPF协议
    将R1、R2、R3和LSW4围成的区域设为骨干区域并配置OSPF协议。
    以R3为例:

    <R3>sys
    Enter system view, return user view with Ctrl+Z.
    [R3]ospf 1
    [R3-ospf-1]ospf router 3.3.3.3
    Info: The configuration succeeded. You need to restart the OSPF process to validate the new router ID.
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 192.168.100.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]q
    [R3-ospf-1]q
    [R3]q
    <R3>save
    

    7、 配置NAT转换;
    NAT配置分为三个关键步骤:1.配置地址池:指出可使用的公网地址范围;2.配置访问控制列表:标识允许访问外网的的内部网络地址;3.在路由器的出接口上绑定访问控制列表和地址池。
    配置地址池的命令是:nat address-group n 公网起始地址 公网结束地址。
    配置访问控制列表ACL的命令是:1.acl number ACL编号(进入ACL视图),基本编号是从2000到2999。2.rule 规则编号 deny/permit(禁止/允许) source(指出禁止或允许的数据包源地址) 子网掩码(掩码按位取反)。注意,在规则列表中排在前面的先起作用,所以最后一条规则一般都是deny any。
    配置路由器出接口上的nat绑定的命令是:nat outbound ACL编号 address-group 地址池编号。
    最后,要在出口路由器上配置一条到外网的默认路由。
    在R5上配置:

    <R5>sys
    Enter system view, return user view with Ctrl+Z.
    [R5]nat address-group 1 200.202.10.1 200.202.10.100
    [R5]acl 2000
    [R5-acl-basic-2000]rule 5 permit source 10.0.0.0 0.255.255.255
    [R5-acl-basic-2000]q
    [R5]
    [R5]int e0/0/0
    [R5-Ethernet0/0/0]nat outbound 2000 address-group 1 no-pat
    [R5-Ethernet0/0/0]q
    [R5]q
    <R5>save
    

    8、ACL访问控制
    此实验中,我们设定禁止102机房访问外网,其只能内部通信。
    在LSW1上配置:

    <S1>sys
    Enter system view, return user view with Ctrl+Z.
    [S1]acl 2000
    [S1-acl-basic-2000]rule deny source 10.1.2.0 0.0.0.255
    [S1-acl-basic-2000]q
    [S1]int eth-trunk 1
    [S1-Eth-Trunk1]traffic-filter outbound acl 2000
    [S1-Eth-Trunk1]q
    [S1]q
    <S1>save
    

    9、配置STP协议(链路备份);

    以LSW1配置为例(将核心交换机配置为根桥,汇聚交换机配置为备份根桥):

    <S1>sys
    Enter system view, return user view with Ctrl+Z.
    [S1]stp mode rstp
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S1]stp root secondary
    [S1]stp enable
    [S1]int eth-trunk 1
    [S1-Eth-Trunk1]stp loop-protection   //开启环路保护功能
    [S1-Eth-Trunk1]q
    

    配置LSW4(核心交换机为根桥):

    <S4>sys
    Enter system view, return user view with Ctrl+Z.
    [S4]stp mode rstp  //运行rstp
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [S4]stp root primary  //指定LSW4为根桥
    [S4]stp enable   //使能stp
    [S4]int eth-trunk 1
    [S4-Eth-Trunk1]stp root-protection  //开启根保护功能
    [S4-Eth-Trunk1]q
    [S4]q
    

    10、VRRP配置(设备备份)
    R3的配置如下:

    <R3>sys
    Enter system view, return user view with Ctrl+Z.
    [R3]int e0/0/1
    [R3-Ethernet0/0/1]vrrp vrid 1 virtual-ip 192.168.100.254
    [R3-Ethernet0/0/1]vrrp vrid 1 priority 150
    [R3-Ethernet0/0/1]q
    [R3]q
    <R3>save
    

    R2的配置如下:

    <R2>sys
    Enter system view, return user view with Ctrl+Z.
    [R2]int e0/0/0
    [R2-Ethernet0/0/0]vrrp vrid 2 virtual-ip 192.168.100.254
    [R2-Ethernet0/0/0]vrrp vrid 2 priority 200
    [R2-Ethernet0/0/0]q
    [R2]q
    <R2>save
    

    路由器主备关系,R2为主路由器,R3为备份路由器。

    11、配置PPP认证

    配置R5和R6之间PPP的CHAP认证,R5为认证方,R6为被认证方,认证用户名为chaiying,密码为hhhxyy@222。
    R5配置如下:

    <R5>sys
    Enter system view, return user view with Ctrl+Z.
    [R5]aaa
    [R5-aaa]local-use chaiying password cipher hhhxyy@222
    Info: Add a new user.
    [R5-aaa]local-user chaiying service-type ppp
    [R5-aaa]int s0/0/1
    [R5-Serial0/0/1]link-protocol ppp
    [R5-Serial0/0/1]ppp authentication-mode chap
    [R5-Serial0/0/1]q
    [R5]q
    <R5>save
    

    R6配置如下:

    <R6>sys
    Enter system view, return user view with Ctrl+Z.
    [R6]int s0/0/0
    [R6-Serial0/0/0]link-protocol ppp
    [R6-Serial0/0/0]ppp chap user chaiying
    [R6-Serial0/0/0]ppp chap password cipher hhhxyy@222
    [R6-Serial0/0/0]q
    [R6]q
    <R6>save
    

    12、远程设备登录控制

    R5的配置如下:

    <R5>sys
    Enter system view, return user view with Ctrl+Z.
    [R5]user-interface console 0
    [R5-ui-console0]authentication-mode aaa
    [R5-ui-console0]user privileg level 15
    [R5-ui-console0]q
    [R5]aaa
    [R5-aaa]local-user admin1234 password cipher hhhxyy@222
    Info: Add a new user.
    [R5-aaa]local-user admin1234 privilege level 3
    [R5-aaa]local-user admin1234 service-type terminal
    [R5-aaa]q
    [R5]q
    <R5>save
    

    13、配置路由备份
    在LSW4上配置默认路由并为其设置优先级:

    <S4>sys
    Enter system view, return user view with Ctrl+Z.
    [S4]ip route-static 0.0.0.0 0.0.0.0 192.168.100.3 preference 30
    Info: Succeeded in modifying route.
    [S4]ip route-static 0.0.0.0 0.0.0.0 192.168.100.4 preference 40
    Info: Succeeded in modifying route.
    [S4]q
    <S4>save
    

    14、组播协议配置
    以LSW4为例:

    <S4>sys
    Enter system view, return user view with Ctrl+Z.
    [S4]multicast routing-enable
    [S4]int vlan 2
    [S4-Vlanif2]pim dm
    [S4-Vlanif2]q
    [S4]int vlan 3
    [S4-Vlanif3]pim dm
    [S4-Vlanif3]q
    [S4]int vlan 4
    [S4-Vlanif4]pim dm
    [S4-Vlanif4]q
    

    15、SNMP协议配置
    以R3为例配置SNMP协议:

    <R3>sys
    [R3]snmp-agent
    [R3]snmp-agent community read public
    [R3]snmp-agent community write private
    [R3]snmp-agent sys-info version v1 v3
    [R3]snmp-agent target-host trap address udp-domain 192.168.50.1 udp-port 161 params securityname public
    [R3]q
    

    六、实验总结

    本次实验中,我学会了如何去做一个工程项目,同时还将之前做过的所有实验进行总结学习,这次实验有效地培养了我的综合素养,提升了我的综合能力,在今后的实验学习中,我会更加努力,不断探索,不断学习!

    展开全文
  • eNSP组网--实验教程.pdf

    2020-05-25 14:11:50
    我用eNSP仿真器实现了两个网络的互联,其中涉及到了路由器的地址分配还有静态路由的配置,主机的地址分配就随性很多了,重要的是学会子网划分,本教程教你一步一步的划分子网并用eNSP完成实验实验用到的...
  • 综合组网实验

    2018-06-13 00:41:43
    计算机网络课程综合组网实验,内附配置方法和配置分析。
  • 综合组网实验 一、概述 本次实验模拟学校实验室的网络环境,通过虚拟环境进行组网,通过vlan、路由、访问控制等,实现不同实验室之间的通信,并且可以通过ACL控制某一个实验室的网络通信,进行简单的组网分析 二、...
  • 综合组网实验(eNSP)

    千次阅读 2021-01-26 10:07:31
    基于eNSP平台的综合组网实验 可作简单参考和了解


    一、实验平台

    华为虚拟仿真平台eNSP。

    二、实验要求

    某学校申请了一个前缀为211.69.4.0/22的地址块,准备将整个学校连入网络。该学校有4个学院,1个图书馆,3个学生宿舍。每个学院有20台主机,图书馆有100台主机,每个学生宿舍拥有200台主机。对这些主机进行组网,要求:
    (1) 学院之间可以相互访问;
    (2) 学生宿舍之间可以相互访问;
    (3) 学院和学生宿舍之间不能相互访问;
    (4) 学院和学生宿舍皆可访问图书馆。

    三、实验步骤

    1.网段划分

    在本次实验当中,第一个问题主要是IP地址的分配,以及设备的选择和拓扑图的设计。给的地址块211.69.4.0/22,前缀为22位,说明我们可以用来分配的位置还有1024位(2^10),可以理解为主要有4.0/245.0/246.0/247.0/24,四个网段,每网段各有256个位置,因为每个宿舍有200台主机,所以将5.0等之后的位置份给宿舍,而4.0分为两部分来交给图书馆以及学院使用,具体的划分为:
    图书馆:211.69.4.0/25,网关211.69.4.126
    图书馆子网掩码:255.255.255.128
    图书馆共127个地址

    学院1:211.69.4.128/27,网关211.69.4.158
    学院2:211.69.4.160/27,网关211.69.4.190

    学院3:211.69.4.192/27,网关211.69.4.222
    学院4:211.69.4.224/27,网关211.69.4.254
    学院子网掩码:255.255.255.224
    每个学院31个地址,学院公共前缀:211.69.4.128/25

    宿舍1:211.69.5.0/24,网关211.69.5.254
    宿舍1:211.69.6.0/24,网关211.69.6.254
    宿舍1:211.69.7.0/24,网关211.69.7.254
    宿舍子网掩码:255.255.255.0
    每个宿舍255个地址。

    2.拓扑图设计

    接下来进行设备的选择,为了连接方便快捷,所以选择了一个路由器以及两个交换机,两个交换机分别作为学院和宿舍的网关所用,具体使用如下图所示:

    拓扑图设计

    3.具体实现步骤

    1.进行网段划分和设备的选择
    2.先在空白拓扑图中拉入设备,再用文本标记好各个PC,交换机以及路由器的IP地址。
    3.根据我们写好的文本进行IP地址的设置以及路由器,交换机的端口vlan IP设置。
    4.交换机经过vlan设置之后不用进行过多操作,而对于路由器要进行ip下一跳设置,因为路由器只有一个,出口也只有三个,所以选择了静态路由配置,配置截图如下:
    路由器配置

    主要使用命令:

    ip route-static 192.168.2.0 255.255.255.0 192.168.4.2
    

    前部分为下一条地址。

    5.配置完之后进行PC测试,从网关至路由器再至每个PC,测试通行效果。
    6.最后进行ACL的规则配置和测试,配置截图如下:
    ACL配置

    主要使用命令:

    [AR2220-1] acl 3001 
    //新建一条高级acl 规则3000-3999 为高级规则,高级规则过滤内容更多,可以过滤源目的地址、协议、源目的端口等。
    [AR2220-1-acl-adv-3001] rule deny ip source 192.168.1.0 0.0.0.255 [destination192.168.2.0 0.0.0.255 ] 
    //增加规则内容,拒绝从192.168.1.0/24 到所有地址的数据;带destination,则是拒绝从192.168.1.0/24 到192.168.2.0/24 的数据
    [AR2220-1-acl-adv-3001] quit
    [AR2220-1]int g0/0/0 //在接口g/0/0/0 上应用acl 3001 规则
    [AR2220-1-GigabitEthernet0/0/1]traffic-filter inbound acl 3001 //在入方向上应用该规则
    

    4.结果测试

    1.从宿舍ping图书馆和学院
    测试图

    2.从学院ping图书馆和宿舍
    测试图

    3.从ping图当中,我们可以发现我们所设计的拓扑图能正常的实现相关的功能,图书馆和宿舍,学院能够互通,而宿舍与学院之后不能互通。且满足了实验要求当中实验设备尽量少的要求,只使用了一个路由器和两个交换机。


    总结

    1.虽然实验较为简单,但是目的主要是为了理解网段划分以及路由器,交换机的简单配置。因为网段不复杂,所以采用了静态路由配置,当网段复杂时可以使用OSPF或RIP动态路由配置。在eNSP中的主要命令为:

    //OSPF设置
    [AR2220-1]ospf 1 router-id 192.168.1.1 //启动1 号进行OSPF 学习,1 为进程号,192.168.1.1 为AR2220-1 的router-id,每个路由器的router-id 都必须不一样
    [AR2220-1-ospf-1]area 0 //创建区域0
    [AR2220-1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255 //设置区域0 包含网络
    [AR2220-1-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255 //设置区域0 包含网络
    [AR2220-1-ospf-1-area-0.0.0.0]quit
    
    //RIP设置
    [AR2220-1]rip //进入RIPv1 配置
    [AR2220-1-rip-1]network 192.168.1.0 //设置RIP 工作网络
    [AR2220-1-rip-1]network 192.168.4.0 //设置RIP 工作网络
    [AR2220-1-rip-1]quit
    

    2.第一次进行拓扑图绘画时,因为想的过于复杂,也产生了拓扑图过于冗余的问题:
    失败图3.实验的完整拓扑图也已上传至我的资源区。

    有任何问题都可以在评论区和我交流~~

    展开全文
  • ensp实验之BGP组网实验(详解)

    千次阅读 2020-05-15 12:32:35
    一、实验组网图 图1 实验组网拓扑图 二、设备配置命令 BR2: (1)配置端口IP [BR2]int GigabitEthernet0/0/0 [BR2-GigabitEthernet0/0/0]ip add 192.168.6.2 24 [BR2-GigabitEthernet0/0/0]int GigabitEthernet0/0...

    一、实验组网图
    在这里插入图片描述
    图1 实验组网拓扑图
    二、设备配置命令
    BR2:
    (1)配置端口IP
    [BR2]int GigabitEthernet0/0/0
    [BR2-GigabitEthernet0/0/0]ip add 192.168.6.2 24
    [BR2-GigabitEthernet0/0/0]int GigabitEthernet0/0/1
    [BR2-GigabitEthernet0/0/1]ip add 11.0.0.1 24
    (2)配置RIP
    [BR2]rip
    [BR2-rip-1]network 192.168.6.0
    [BR2-rip-1]network 11.0.0.0
    (3)配置IBGP
    [BR2]bgp 100
    [BR2-bgp]router-id 1.0.0.2
    [BR2-bgp]peer 192.168.6.1 as-number 100
    BR1:
    (1)配置端口IP
    [BR1]int GigabitEthernet0/0/1
    [BR1-GigabitEthernet0/0/1]ip add 192.168.5.2 24
    [BR1-GigabitEthernet0/0/1]int GigabitEthernet0/0/0
    [BR1-GigabitEthernet0/0/0]ip add 192.168.6.1 24
    (2)配置RIP
    [BR1]rip
    [BR1-rip-1]net 192.168.5.0
    [BR1-rip-1]net 192.168.6.0
    (3)配置EBGP
    [BR1]bgp 100
    [BR1-bgp]router-id 1.0.0.1
    [BR1-bgp]peer 192.168.5.1 as-number 200
    (4)配置IBGP
    [BR1]bgp 100
    [BR1-bgp]peer 192.168.6.2 as-number 100
    (5)引入
    [BR1-bgp]import-route rip 1
    [BR1-bgp]import-route direct
    (6)同步
    [BR1]rip
    [BR1-rip-1]import-route bgp
    AR1:
    (1)配置端口IP
    [AR1]int GigabitEthernet0/0/0
    [AR1-GigabitEthernet0/0/0]ip add 192.168.5.1 24
    [AR1-GigabitEthernet0/0/0]int GigabitEthernet0/0/1
    [AR1-GigabitEthernet0/0/1]ip add 192.168.1.1 24
    (2)配置OSPF
    [AR1]ospf
    [AR1-ospf-1]default-route-advertise
    [AR1-ospf-1]area
    [AR1-ospf-1-area-0.0.0.0]net 192.168.1.0 0.0.0.255
    [AR1-ospf-1-area-0.0.0.0]net 192.168.5.0 0.0.0.255
    [AR1-ospf-1-area-0.0.0.0]ip route-static 0.0.0.0 0.0.0.0 192.168.5.0
    (3)配置EBGP
    [AR1]bgp 200
    [AR1-bgp]router-id 0.0.0.1
    [AR1-bgp]peer 192.168.5.2 as-number 100
    (4)配置IBGP
    [AR1]bgp 200
    [AR1-bgp]peer 192.168.1.2 as-number 200
    (5)引入
    [AR1-bgp]import-route direct
    [AR1-bgp]import-route ospf 1
    (6)同步
    [AR1]ospf
    [AR1-ospf-1]import-route bgp
    AR2:
    (1)配置端口IP
    [AR2]int GigabitEthernet0/0/1
    [AR2-GigabitEthernet0/0/1]ip add 10.0.0.1 24
    [AR2-GigabitEthernet0/0/1]int GigabitEthernet0/0/0
    [AR2-GigabitEthernet0/0/0]ip add 192.168.1.2 24
    (2)配置OSPF
    [AR2]ospf
    [AR2-ospf-1]area 0
    [AR2-ospf-1-area-0.0.0.0]net 192.168.1.0 0.0.0.255
    [AR2-ospf-1-area-0.0.0.0]net 10.0.0.0 0.0.0.255
    (3)配置IBGP
    [AR2]bgp 200
    [AR2-bgp]router-id 0.0.0.2
    [AR2-bgp]peer 192.168.1.1 as-number 200
    **查看BGP:**如果在BGP邻居建立成功后,使用display bgp peer命令所查看到的邻居状态为Established。
    在这里插入图片描述
    图2 AR1的BGP邻居信息
    在这里插入图片描述
    图3 AR2的BGP邻居信息
    在这里插入图片描述
    图4 BR1的BGP邻居信息
    在这里插入图片描述
    图5 BR2的BGP邻居信息
    此时查看连通性:
    在这里插入图片描述
    图6 PC2 ping PC1结果展示
    三、抓包分析:(在BR1的GE0/0/1处抓包)
    在这里插入图片描述
    图7 抓包结果概览
    BGP通过四种报文来建立连接和交换路由更新消息:
    路由器之间通过TCP建立BGP连接时,发送OPEN报文
    连接建立后,如果有路由需要发送或路由变化时,发送UPDATE报文通告对端路由信息
    连接稳定后,要定时发送KEEPALIVE报文以保持BGP连接的有效性
    当本地BGP在运行中发现错误时,要发送NOTIFICATION报文通告BGP对端
    在这里插入图片描述
    图8 BGP的OPEN报文
    在这里插入图片描述
    图9 BGP的KEEPALIVE报文
    KEEPALIVE报文只有报文头。
    在这里插入图片描述
    图10 BGP的UPDATE报文

    当BGP检测到差错时,发送notification报文,关闭同对等体的连接。该报文携带各种错误信息,包括错误代码、辅助错误大码及错误信息。

    展开全文
  • 这是我制作的关于华为ENSP的MSTP和VRRP组网的基本配置文件
  • 1、项目背景 XX公司总部位于北京,在上海和深圳分别设有研究所与办事处,通过组建网络将三地连接起来:北京总部有员工100人,一级部门四个(划分Vlan,IP地址规划),服务器2台,服务器与交换机做链路聚合,总部...

    目录

    1、项目背景

    2、网络建设目标

    3、拓扑规划

    4、LAN规划(各部门局域网规划)

    5、网络设备选型和命名

    6、路由规划

    7、配置


    1、项目背景

            XX公司总部位于北京,在上海和深圳分别设有研究所与办事处,通过组建网络将三地连接起来:北京总部有员工100人,一级部门四个(划分Vlan,IP地址规划),服务器2台,服务器与交换机做链路聚合,总部路由协议使用ospf;深圳办事处有员工30人,上海研究所有员工40人,办事处与研究所不分部门,采用DHCP分配IP地址;总部与分支机构之间使用SDH线路连接,其中总部与深圳之间使用2M线路(ppp+chap),总部与上海之间使用2条2M线路(帧中继+路由备份)。

    2、网络建设目标

    • 网络带宽升级,达到千兆骨干,百兆到桌面
    • 增强网络的可靠性及可用性
    • 网络要易于管理、升级和扩展
    • 确保内网安全及同办事处之间交互数据的安全

    3、拓扑规划

    4、LAN规划(各部门局域网规划)

    部门

    VLAN

    IP网段/子网

    北京总部第1部门

    vlan 10

    192.168.10.0/24

    北京总部第2部门

    vlan 20

    192.168.20.0/24

    北京总部第3部门

    vlan 30

    192.168.30.0/24

    北京总部第4部门(服务器)

    vlan 40

    192.168.40.0/24

    深圳办事处

    ——

    192.168.50.0/24

    上海研究所

    ——

    192.168.60.0/24

    其它路由区域(广域网)

    ——

    192.168.1.0/24

    192.168.2.0/24

    192.168.3.0/24

    192.168.4.0/24

    5、网络设备选型和命名

    ① 北京总部:

    核心交换机         选型:S5700-28C-HI      命名:BJ-S5700-LSW1

    服务器区交换机     选型:S3700-26C-HI      命名:BJ-S3700-LSW2

    接入交换机         选型:S3700-26C-HI      命名:BJ-S3700-LSW3、LSW4、LSW5

    互连及出口路由器   选型:AR2240            命名:BJ-AR2240-AR1

    ② 深圳办事处:

    互连路由器         选型:AR1220            命名:SZ-AR1220-AR2

    接入交换机         选型:S3700-26C-HI      命名:SZ-S3700-LSW6

    ③ 上海研究所:

    互连路由器         选型:AR1220            命名:SH-AR1220-AR3

    接入交换机         选型:S3700-26C-HI      命名:SH-S3700-LSW7

    6、路由规划

    7、配置

    给交换机和路由器配置命名(这里以LSW1为例):

    分别将LSW1和LSW2的g0/0/1和g0/0/2配置为一个链路聚合口:
    
    ========================================================
    [BJ-S5700-LSW1]interface Eth-Trunk 12
    [BJ-S5700-LSW1-Eth-Trunk12]trunkport g0/0/1
    [BJ-S5700-LSW1-Eth-Trunk12]trunkport g0/0/2
    ========================================================
    [BJ-S3700-LSW2]interface Eth-Trunk 12
    [BJ-S3700-LSW2-Eth-Trunk12]trunkport g0/0/1
    [BJ-S3700-LSW2-Eth-Trunk12]trunkport g0/0/2
    ========================================================
    
    ========================================================
    
    在三层交换机LSW1上划分vlan,并给相应的vlanif虚拟口配置ip地址:
    
     划分端口VLAN,配置VLANIF的IP地址(即网关)
    [BJ-S5700-LSW1]vlan batch 10 20 30 40
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [BJ-S5700-LSW1]int g0/0/3
    [BJ-S5700-LSW1-GigabitEthernet0/0/3]port link-type access
    [BJ-S5700-LSW1-GigabitEthernet0/0/3]port default vlan 10
    [BJ-S5700-LSW1-GigabitEthernet0/0/3]int g0/0/4
    [BJ-S5700-LSW1-GigabitEthernet0/0/4]port link-type access
    [BJ-S5700-LSW1-GigabitEthernet0/0/4]port default vlan 20
    [BJ-S5700-LSW1-GigabitEthernet0/0/4]int g0/0/5
    [BJ-S5700-LSW1-GigabitEthernet0/0/5]port link-type access
    [BJ-S5700-LSW1-GigabitEthernet0/0/5]port default vlan 30
    [BJ-S5700-LSW1-GigabitEthernet0/0/5]int Eth-Trunk12
    [BJ-S5700-LSW1-Eth-Trunk12]port link-type access
    [BJ-S5700-LSW1-Eth-Trunk12]port default vlan 40
    [BJ-S5700-LSW1-Eth-Trunk12]int vlanif10
    [BJ-S5700-LSW1-Vlanif10]ip add 192.168.10.254 24
    [BJ-S5700-LSW1-Vlanif10]int vlanif20
    [BJ-S5700-LSW1-Vlanif20]ip add 192.168.20.254 24
    [BJ-S5700-LSW1-Vlanif20]int vlanif30
    [BJ-S5700-LSW1-Vlanif30]ip add 192.168.30.254 24
    [BJ-S5700-LSW1-Vlanif30]int vlanif40
    [BJ-S5700-LSW1-Vlanif40]ip add 192.168.40.254 24
    [BJ-S5700-LSW1-Vlanif40]display ip interface brief   查看已有Vlanif及其地址
    
    [BJ-S5700-LSW1]vlan 99   LSW1配置g0/0/24端口
    [BJ-S5700-LSW1-vlan99]int g0/0/24
    [BJ-S5700-LSW1-GigabitEthernet0/0/24]port link-type access
    [BJ-S5700-LSW1-GigabitEthernet0/0/24]port default vlan 99
    [BJ-S5700-LSW1-GigabitEthernet0/0/24]int vlanif99
    [BJ-S5700-LSW1-Vlanif99]ip add 192.168.1.2 24
    ========================================================
    
     配置DHCP、静态路由和IP地址池
    [BJ-AR2240-AR1]dhcp enable
    [BJ-AR2240-AR1]int g0/0/0
    [BJ-AR2240-AR1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
    [BJ-AR2240-AR1-GigabitEthernet0/0/0]dhcp select global
    [BJ-AR2240-AR1-GigabitEthernet0/0/0]q
    [BJ-AR2240-AR1]ip route-static 192.168.10.0 255.255.255.0 192.168.1.2
    [BJ-AR2240-AR1]ip route-static 192.168.20.0 255.255.255.0 192.168.1.2
    [BJ-AR2240-AR1]ip route-static 192.168.30.0 255.255.255.0 192.168.1.2
    [BJ-AR2240-AR1]ip route-static 192.168.40.0 255.255.255.0 192.168.1.2
    [BJ-AR2240-AR1]ip pool vlan10
    Info: It's successful to create an IP address pool.
    [BJ-AR2240-AR1-ip-pool-vlan10]gateway-list 192.168.10.254
    [BJ-AR2240-AR1-ip-pool-vlan10]network 192.168.10.0 mask 255.255.255.0
    [BJ-AR2240-AR1-ip-pool-vlan10]excluded-ip-address 192.168.10.100 192.168.10.253
    [BJ-AR2240-AR1-ip-pool-vlan10]dns-list 114.114.114.114
    [BJ-AR2240-AR1-ip-pool-vlan10]q
    [BJ-AR2240-AR1]ip pool vlan20
    Info: It's successful to create an IP address pool.
    [BJ-AR2240-AR1-ip-pool-vlan20]gateway-list 192.168.20.254
    [BJ-AR2240-AR1-ip-pool-vlan20]network 192.168.20.0 mask 255.255.255.0
    [BJ-AR2240-AR1-ip-pool-vlan20]excluded-ip-address 192.168.20.100 192.168.20.253
    [BJ-AR2240-AR1-ip-pool-vlan20]dns-list 114.114.114.114
    [BJ-AR2240-AR1-ip-pool-vlan20]q
    [BJ-AR2240-AR1]ip pool vlan30
    Info: It's successful to create an IP address pool.
    [BJ-AR2240-AR1-ip-pool-vlan30]gateway-list 192.168.30.254
    [BJ-AR2240-AR1-ip-pool-vlan30]network 192.168.30.0 mask 255.255.255.0
    [BJ-AR2240-AR1-ip-pool-vlan30]excluded-ip-address 192.168.30.100 192.168.30.253
    [BJ-AR2240-AR1-ip-pool-vlan30]dns-list 114.114.114.114
    [BJ-AR2240-AR1-ip-pool-vlan30]q
    [BJ-AR2240-AR1]dis ip pool 
    ========================================================
    //配置DHCP中继
    [BJ-S5700-LSW1]
    [BJ-S5700-LSW1]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [BJ-S5700-LSW1]int vlanif10
    [BJ-S5700-LSW1-Vlanif10]dhcp select relay
    [BJ-S5700-LSW1-Vlanif10]dhcp relay server-ip 192.168.1.1
    [BJ-S5700-LSW1-Vlanif10]q
    [BJ-S5700-LSW1]int vlanif20
    [BJ-S5700-LSW1-Vlanif20]dhcp select relay
    [BJ-S5700-LSW1-Vlanif20]dhcp relay server-ip 192.168.1.1
    [BJ-S5700-LSW1-Vlanif20]q
    [BJ-S5700-LSW1]int vlanif30
    [BJ-S5700-LSW1-Vlanif30]dhcp select relay
    [BJ-S5700-LSW1-Vlanif30]dhcp relay server-ip 192.168.1.1
    ========================================================
    ========================================================
    // AR2配置DHCP
    [SZ-AR1220-AR2]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [SZ-AR1220-AR2]int g0/0/0
    [SZ-AR1220-AR2-GigabitEthernet0/0/0]ip add 192.168.50.254 24
    [SZ-AR1220-AR2-GigabitEthernet0/0/0]dhcp select global
    [SZ-AR1220-AR2-GigabitEthernet0/0/0]q
    [SZ-AR1220-AR2]ip pool net50
    Info: It's successful to create an IP address pool.
    [SZ-AR1220-AR2-ip-pool-net50]gateway-list 192.168.50.254
    [SZ-AR1220-AR2-ip-pool-net50]network 192.168.50.0 mask 24
    [SZ-AR1220-AR2-ip-pool-net50]excluded-ip-address 192.168.50.201 192.168.50.253
    [SZ-AR1220-AR2-ip-pool-net50]dns-list 114.114.114.114
    ========================================================
    // AR3配置DHCP
    [SH-AR1220-AR3]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [SH-AR1220-AR3]int g0/0/0
    [SH-AR1220-AR3-GigabitEthernet0/0/0]ip add 192.168.60.254 24
    [SH-AR1220-AR3-GigabitEthernet0/0/0]dhcp select global
    [SH-AR1220-AR3-GigabitEthernet0/0/0]q
    [SH-AR1220-AR3]ip pool net60
    Info: It's successful to create an IP address pool.
    [SH-AR1220-AR3-ip-pool-net60]gateway-list 192.168.60.254
    [SH-AR1220-AR3-ip-pool-net60]network 192.168.60.0 mask 24
    [SH-AR1220-AR3-ip-pool-net60]excluded-ip-address 192.168.60.201 192.168.60.253
    [SH-AR1220-AR3-ip-pool-net60]dns-list 114.114.114.114
    ========================================================
    ========================================================
    // 配置AR1ppp-CHAP认证
    [BJ-AR2240-AR1]int s1/0/0
    [BJ-AR2240-AR1-Serial1/0/0]ip add 192.168.2.1 24
    [BJ-AR2240-AR1-Serial1/0/0]q
    [BJ-AR2240-AR1]ip route-static 192.168.50.0 255.255.255.0 192.168.2.2
    [BJ-AR2240-AR1]aaa
    [BJ-AR2240-AR1-aaa]local-user ar1 password cipher hello
    Info: Add a new user.
    [BJ-AR2240-AR1-aaa]local-user ar1 service-type ppp
    [BJ-AR2240-AR1-aaa]int s1/0/0
    [BJ-AR2240-AR1-Serial1/0/0]link-protocol ppp
    [BJ-AR2240-AR1-Serial1/0/0]ppp authentication-mode chap
    [BJ-AR2240-AR1-Serial1/0/0]shutdown
    [BJ-AR2240-AR1-Serial1/0/0]undo shutdown
    ========================================================
    // 配置AR2ppp-CHAP认证
    [SZ-AR1220-AR2]int s1/0/0
    [SZ-AR1220-AR2-Serial1/0/0]ip add 192.168.2.2 24
    [SZ-AR1220-AR2-Serial1/0/0]q
    [SZ-AR1220-AR2]ip route-static 192.168.1.0 255.255.255.0 192.168.2.1
    [SZ-AR1220-AR2]int s1/0/0
    [SZ-AR1220-AR2-Serial1/0/0]link-protocol ppp
    [SZ-AR1220-AR2-Serial1/0/0]ppp chap user ar1
    [SZ-AR1220-AR2-Serial1/0/0]ppp chap password cipher hello
    [SZ-AR1220-AR2-Serial1/0/0]shutdown
    [SZ-AR1220-AR2-Serial1/0/0]undo shutdown
    [SZ-AR1220-AR2-Serial1/0/0]display this
    ========================================================
    ========================================================
    // 配置AR1路由备份
    [BJ-AR2240-AR1]int s2/0/0
    [BJ-AR2240-AR1-Serial2/0/0]ip add 192.168.3.1 24
    [BJ-AR2240-AR1-Serial2/0/0]int s2/0/1
    [BJ-AR2240-AR1-Serial2/0/1]ip add 192.168.4.1 24
    [BJ-AR2240-AR1-Serial2/0/1]q
    [BJ-AR2240-AR1]ip route-static 192.168.60.0 255.255.255.0 192.168.3.2    //默认60
    [BJ-AR2240-AR1]ip route-static 192.168.60.0 255.255.255.0 192.168.4.2 preference 100
    ========================================================
    // 配置AR3路由备份
    [SH-AR1220-AR3]int s2/0/0
    [SH-AR1220-AR3-Serial2/0/0]ip add 192.168.3.2 24
    [SH-AR1220-AR3-Serial2/0/0]int s2/0/1
    [SH-AR1220-AR3-Serial2/0/1]ip add 192.168.4.2 24
    [SH-AR1220-AR3-Serial2/0/1]q
    [SH-AR1220-AR3]ip route-static 192.168.1.0 255.255.255.0 192.168.3.1    //默认60
    [SH-AR1220-AR3]ip route-static 192.168.1.0 255.255.255.0 192.168.4.1 preference 100
    ========================================================
    // AR1配置帧中继
    [BJ-AR2240-AR1]int s2/0/0
    [BJ-AR2240-AR1-Serial2/0/0]link-protocol fr
    Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
    [BJ-AR2240-AR1-Serial2/0/0]fr interface-type dce      //网络侧
    [BJ-AR2240-AR1-Serial2/0/0]fr dlci 100
    [BJ-AR2240-AR1-fr-dlci-Serial2/0/0-100]int s2/0/1
    [BJ-AR2240-AR1-Serial2/0/1]link-protocol fr
    Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
    [BJ-AR2240-AR1-Serial2/0/1]fr interface-type dce
    [BJ-AR2240-AR1-Serial2/0/1]fr dlci 100
    [BJ-AR2240-AR1-fr-dlci-Serial2/0/1-100]q
    ========================================================
    // AR3配置帧中继
    [SH-AR1220-AR3]int s2/0/0
    [SH-AR1220-AR3-Serial2/0/0]link-protocol fr
    Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
    [SH-AR1220-AR3-Serial2/0/0]fr interface-type dte     //用户侧
    [SH-AR1220-AR3-Serial2/0/0]fr dlci 100
    [SH-AR1220-AR3-fr-dlci-Serial2/0/0-100]q
    [SH-AR1220-AR3-Serial2/0/0]int s2/0/1
    [SH-AR1220-AR3-Serial2/0/1]link-protocol fr
    Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
    [SH-AR1220-AR3-Serial2/0/1]fr interface-type dte
    [SH-AR1220-AR3-Serial2/0/1]fr dlci 100
    [SH-AR1220-AR3-fr-dlci-Serial2/0/1-100]q
    ========================================================
    ========================================================
    // 配置AR1的OSPF
    [BJ-AR2240-AR1]int loopback0
    [BJ-AR2240-AR1-LoopBack0]ip add 1.1.1.1 32
    [BJ-AR2240-AR1-LoopBack0]q
    [BJ-AR2240-AR1]ospf 100 router-id 1.1.1.1
    [BJ-AR2240-AR1-ospf-100]area 0
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]authentication-mode md5 1 cipher huawei
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]network 1.1.1.1 0.0.0.0
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.0]area 1
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.1]authentication-mode md5 1 cipher hw123
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.1]network 192.168.1.0 0.0.0.255
    [BJ-AR2240-AR1-ospf-100-area-0.0.0.1]q
    [BJ-AR2240-AR1-ospf-100]import-route static  //OSPF引入静态路由
    [BJ-AR2240-AR1-ospf-100]peer 192.168.3.2  //手动指定邻居的接口,建立邻居关系。因为帧中继默认无法运行OSPF协议
    [BJ-AR2240-AR1-ospf-100]peer 192.168.4.2
    [BJ-AR2240-AR1-ospf-100]int g0/0/0
    ========================================================
    // 配置AR2的OSPF
    [SZ-AR1220-AR2]int loopback0
    [SZ-AR1220-AR2-LoopBack0]ip add 2.2.2.2 32
    [SZ-AR1220-AR2-LoopBack0]q
    [SZ-AR1220-AR2]ospf 100 router-id 2.2.2.2
    [SZ-AR1220-AR2-ospf-100]area 0
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.0]authentication-mode md5 1 cipher huawei
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.0]area 2
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.2]network 192.168.50.0 0.0.0.255
    [SZ-AR1220-AR2-ospf-100-area-0.0.0.2]q
    [SZ-AR1220-AR2-ospf-100]import-route static
    ========================================================
    // 配置AR3的OSPF
    [SH-AR1220-AR3]int loopback0
    [SH-AR1220-AR3-LoopBack0]ip add 3.3.3.3 32
    [SH-AR1220-AR3-LoopBack0]q
    [SH-AR1220-AR3]ospf 100 router-id 3.3.3.3
    [SH-AR1220-AR3-ospf-100]area 0
    [SH-AR1220-AR3-ospf-100-area-0.0.0.0]authentication-mode md5 1 cipher huawei
    [SH-AR1220-AR3-ospf-100-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [SH-AR1220-AR3-ospf-100-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    [SH-AR1220-AR3-ospf-100-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [SH-AR1220-AR3-ospf-100-area-0.0.0.0]area 3
    [SH-AR1220-AR3-ospf-100-area-0.0.0.3]network 192.168.60.0 0.0.0.255
    [SH-AR1220-AR3-ospf-100-area-0.0.0.3]q
    [SH-AR1220-AR3-ospf-100]import-route static
    [SH-AR1220-AR3-ospf-100]peer 192.168.3.1
    [SH-AR1220-AR3-ospf-100]peer 192.168.4.1
    [SH-AR1220-AR3-ospf-100]int s2/0/0
    [SH-AR1220-AR3-Serial2/0/0]ospf dr-priority 0  //OSPF优先级置零,使其不参与DR/BDR的选举(默认DR是1)
    [SH-AR1220-AR3-Serial2/0/0]int s2/0/1
    [SH-AR1220-AR3-Serial2/0/1]ospf dr-priority 0  //OSPF优先级置零,使其不参与DR/BDR的选举
    ========================================================
    // 配置LSW1的OSPF
    [BJ-S5700-LSW1]int loopback0
    [BJ-S5700-LSW1-LoopBack0]ip add 4.4.4.4 32
    [BJ-S5700-LSW1-LoopBack0]q
    [BJ-S5700-LSW1]ospf 100 router-id 4.4.4.4
    [BJ-S5700-LSW1-ospf-100]area 1
    [BJ-S5700-LSW1-ospf-100-area-0.0.0.1]authentication-mode md5 1 cipher hw123
    [BJ-S5700-LSW1-ospf-100-area-0.0.0.1]network 192.168.1.0 0.0.0.255
    [BJ-S5700-LSW1-ospf-100-area-0.0.0.1]network 4.4.4.4 0.0.0.0
    [BJ-S5700-LSW1-ospf-100-area-0.0.0.1]q
    [BJ-S5700-LSW1-ospf-100]import-route static
    [BJ-S5700-LSW1-ospf-100]int vlan99
    [BJ-S5700-LSW1-Vlanif99]ospf dr-priority 0  //OSPF优先级置零,使其不参与DR/BDR选举
    ========================================================
    ========================================================


    THE END.

    展开全文
  • 基于eNSP的计算机网络实验-----完结篇一、路由器基本配置和静态路由1.背景知识2.ENSP模拟过程3.实际网络设备操作二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】1.背景知识2.ENSP模拟过程3.实际网络...
  • 实验九:组网综合实验最新完整版,绝对正确,帮助很大。
  • ensp防火墙综合实验lab

    千次阅读 2020-12-20 23:39:21
    实验要求: 1.完成防火墙组网基础配置(IP,安全域,路由(可配置动态路由,只可宣告防火墙untrust所在网段)ISP路由器不能存在防火墙非untrust区域内路由),校本部和南校区防火墙管理地址分别为192.168.0.1/24,192...
  • 华为eNSP综合实验

    千次阅读 多人点赞 2020-05-28 16:26:25
    华为综合实验实验目标实验步骤SW2二层配置信息SW3二层配置信息SW1三层配置信息R3路由器配置信息AR1路由器配置信息R2路由器配置信息SW4二层交换机配置信息总结 实验目标 企业内网全网互通,R3配置DHCP服务为Vlan10和...
  • eNSP组网设计与配置实验

    万次阅读 多人点赞 2016-05-28 22:52:56
    eNSP组网设计与配置实验 实验个人说明 实验报告 实验分析 (1)实验个人说明 eNSP组网设计与配置实验是我大学课程《计算机网络》的课程实验,学习了局域网的组件。而且是6次实验中唯一的一个创作性实验,前5个实验...
  • 华为eNSP模拟[IPv6基础介绍]【视频教程+拓扑实验】.zip 配置IPv6基础功能思路如下: 1.使能RouterA的IPv6转发能力并配置IPv6地址,使路由器具有对IPv6报文的转发能力。 2.打开RouterA的RA报文发送开关。RouterB的GE1...
  • eNSP的静态综合实验

    2021-01-13 18:38:07
    一、实验相关要求 二、IP地址划分及相关实验基础配置 三、配置IP地址 四、写出下一跳,缺省路由 缺省路由从左向右依次编写 五、设置TELNET登录 在R5处进行端口映射 [r5-GigabitEthernet0/0/1]nat static ...
  • 计算机网络综合实训指导书-基于eNSP,适用于两周的综合实训内容,包括tcp/IP协议等,路由交换原理,vlsm子网划分,可分解可以综合
  • 网络安全综合实验(eNSP)(DHCP、OSPF、NAT、防火墙、ACL)

    千次阅读 多人点赞 2020-06-02 10:25:48
    网络安全综合实验 一、概述 1.1 实验背景及要求 配置ACL,过滤具有某种特点的分组。 配置NAT。在企业内部结构化分层使用NAT地址。 实验测试一种网络攻击,比如SYN_Flood、MAC泛洪攻击或ARP攻击。 配置防火墙,禁止...
  • 基于eNSP的计算机网络实验(三)   本次实验的一下两个内容: 使用单臂路由和两台二层交换机实现不同VLAN的互通 使用单个三层交换机实现不同VLAN的互通 背景知识     要进行下面的实验,我们需要首先...
  • 属于一个小型公司内网组网架构实训案例,使用了OSPF技术;ACL技术;NAT技术,局域网覆盖有限的地理范围,适用于公司、校园等有限范围内的计算机、终端与各类信息设备连网的需求。一般属于一个单位所有,组建方便、...
  • NAT(Network Address Translation,网络...Wireshark、ENSP 静态NAT实验 静态NAT的核心任务就是建立并维护一张静态地址映射表,地址映射表反映了共有IP与私有IP之间的一一对应关系。在进行NAT转换时,内部主机的IP地址
  • 一、实验环境 5台路由器,7台路交换机,1台服务器,7台电脑pc 连接成如下拓扑图。 蓝色部分为互联网(外网),红色部分为公司网络(内网),绿色方形部分为OSPF区域,浅蓝色椭圆形域为RIP区域。 二、实验目的 2.1 ...
  • eNSP之防火墙简单实验(一)

    千次阅读 2020-11-10 14:04:48
    eNSP之防火墙简单实验(一) 实验拓扑 图中,FW与ISP连接的网段仅仅是互联的作用,所以用私有地址段,而内部流量经过防火墙的G1/0/2访问外部流量时使用向运营商申请的公有地址段200.8.8.0/29。最后会针对这部分做一...
  • 华为eNSP两层架构综合网络配置

    千次阅读 2021-01-30 22:24:20
    华为ENSP两层架构综合实验 一、企业网划分多个VLAN,减少广播域大小,提高网络稳定性。 (一)配置接入交换机SW2接口。 (二)配置接入交换机SW3接口。 (三)配置核心交换机SW1接口。 二、在核心上配置DHCP地址段,...

空空如也

空空如也

1 2 3 4 5 6
收藏数 110
精华内容 44
关键字:

ensp综合组网实验