精华内容
下载资源
问答
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...

    思科交换机配置命令大全
    switch> 用户模式
    1:进入特权模式enable
    switch> enable
    switch#
    2:进入全局配置模式configure terminal
    switch> enable
    switch#c onfigure terminal
    switch(conf)#
    3:交换机命名hostname aptech2950 以aptech2950 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch-2950
    aptech2950(conf)#
    4:配置使能口令enable password cisco 以cisco 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable password cisco
    5:配置使能密码enable secret ciscolab 以cicsolab 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable secret ciscolab
    6:设置虚拟局域网vlan 1 interface vlan 1
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface vlan 1
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口ip 和子网掩

    aptech2950(conf-if)#no shut 是配置处于运行中
    aptech2950(conf-if)#exit
    aptech2950(conf)#ip default-gateway 192.168.254 设置网关地址
    7:进入交换机某一端口interface fastehernet 0/17 以17 端口为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface fastehernet 0/17
    aptech2950(conf-if)#
    8:查看命令show
    switch> enable
    switch# show version 察看系统中的所有版本信息
    show interface vlan 1 查看交换机有关ip 协议的配置信息
    show running-configure 查看交换机当前起作用的配置信息
    show interface fastethernet 0/1 察看交换机1 接口具体配置和统计信息
    show mac-address-table 查看mac 地址表
    show mac-address-table aging-time 查看mac 地址表自动老化时间
    9:交换机恢复出厂默认恢复命令
    switch> enable
    switch# erase startup-configure
    switch# reload
    10:双工模式设置
    switch> enable
    switch#c onfigure terminal
    switch2950(conf)#hostname aptch-2950
    aptech2950(conf)# interface fastehernet 0/17 以17 端口为例
    aptech2950(conf-if)#duplex full/half/auto 有full , half, auto 三个可选

    11:cdp 相关命令
    switch> enable
    switch# show cdp 查看设备的cdp 全局配置信息
    show cdp interface fastethernet 0/17 查看17 端口的cdp 配置信息
    show cdp traffic 查看有关cdp 包的统计信息
    show cdp nerghbors 列出与设备相连的cisco 设备
    12:csico2950 的密码恢复
    拔下交换机电源线。
    用手按着交换机的MODE 键,插上电源线
    在switch:后执行flash_ini 命令:switch: flash_ini
    查看flash 中的文件: switch: dir flash:
    把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old
    执行boot: switch: boot
    交换机进入是否进入配置的对话,执行no :
    进入特权模式察看flash 里的文件: show flash :
    把“config.old”文件改名为“config.text”: switch: rename flash: config.old flash: config.text
    把“ config.text ” 拷入系统的“ running-configure ”: copy flash: config.text system :
    running-configure
    把配置模式重新设置密码存盘,密码恢复成功。
    13:交换机telnet 远程登录设置:
    switch>en
    switch#c onfigure terminal
    switch(conf)#hostname aptech-2950
    aptech2950(conf)#enable password cisco 以cisco 为特权模式密码
    aptech2950(conf)#interface fastethernet 0/1 以17 端口为telnet 远程登录端口
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0
    aptech2950(conf-if)#no shut
    aptech2950(conf-if)#exit
    aptech2950(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆
    aptech2950(conf-line)#login
    aptech2950(conf-line)#password edge 以edge 为远程登录的用户密码
    主机设置:
    ip 192.168.1.2 主机的ip 必须和交换机端口的地址在同一网络

    netmask 255.255.255.0
    gate-way 192.168.1.1 网关地址是交换机端口地址
    运行:
    telnet 192.168.1.1
    进入telnet 远程登录界面
    password : edge
    aptech2950>en
    password: cisco
    aptech#
    14:交换机配置的重新载入和保存
    设置完成交换机的配置后:
    aptech2950(conf)#reload
    是否保存(y/n) y: 保存设置信息n:不保存设置信息
    1.在基于IOS 的交换机上设置主机名/系统名:
    switch(config)# hostname hostname
    在基于CLI 的交换机上设置主机名/系统名:
    switch(enable) set system name name-string
    2.在基于IOS 的交换机上设置登录口令:
    switch(config)# enable password level 1 password
    在基于CLI 的交换机上设置登录口令:
    switch(enable) set password
    switch(enable) set enalbepass
    3.在基于IOS 的交换机上设置远程访问:
    switch(config)# interface vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address
    在基于CLI 的交换机上设置远程访问:
    switch(enable) set interface sc0 ip-address netmask broadcast-address
    switch(enable) set interface sc0 vlan
    switch(enable) set ip route default gateway
    4.在基于IOS 的交换机上启用和浏览CDP 信息:
    switch(config-if)# cdp enable
    switch(config-if)# no cdp enable
    为了查看Cisco 邻接设备的CDP 通告信息:
    switch# show cdp interface [type modle/port]
    switch# show cdp neighbors [type module/port] [detail]
    在基于CLI 的交换机上启用和浏览CDP 信息:
    switch(enable) set cdp {enable|disable} module/port
    为了查看Cisco 邻接设备的CDP 通告信息:
    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
    5.基于IOS 的交换机的端口描述:
    switch(config-if)# description description-string
    基于CLI 的交换机的端口描述:
    switch(enable)set port name module/number description-string
    6.在基于IOS 的交换机上设置端口速度:
    switch(config-if)# speed{10|100|auto}
    在基于CLI 的交换机上设置端口速度:
    switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}
    7.在基于IOS 的交换机上设置以太网的链路模式:
    switch(config-if)# duplex {auto|full|half}
    在基于CLI 的交换机上设置以太网的链路模式:
    switch(enable) set port duplex module/number {full|half}
    8.在基于IOS 的交换机上配置静态VLAN:
    switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)# interface interface module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end
    在基于CLI 的交换机上配置静态VLAN:
    switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list
    9. 在基于IOS 的交换机上配置VLAN 中继线:
    switch(config)# interface interface mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于CLI 的交换机上配置VLAN 中继线:
    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]
    10.在基于IOS 的交换机上配置VTP 管理域:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    在基于CLI 的交换机上配置VTP 管理域:
    switch(enable) set vtp [domain domain-name]
    11.在基于IOS 的交换机上配置VTP 模式:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    switch(vlan)# vtp {sever|cilent|transparent}
    switch(vlan)# vtp password password
    在基于CLI 的交换机上配置VTP 模式:
    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password
    password]
    12. 在基于IOS 的交换机上配置VTP 版本:
    switch# vlan database
    switch(vlan)# vtp v2-mode
    在基于CLI 的交换机上配置VTP 版本:
    switch(enable) set vtp v2 enable
    13. 在基于IOS 的交换机上启动VTP 剪裁:
    switch# vlan database
    switch(vlan)# vtp pruning
    在基于CL I 的交换机上启动VTP 剪裁:
    switch(enable) set vtp pruning enable
    14.在基于IOS 的交换机上配置以太信道:
    switch(config-if)# port group group-number [distribution {source|destination}]
    在基于CLI 的交换机上配置以太信道:
    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
    15.在基于IOS 的交换机上调整根路径成本:
    switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于CLI 的交换机上调整根路径成本:
    switch(enable) set spantree portcost moudle/port cost
    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
    16.在基于IOS 的交换机上调整端口ID:
    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于CLI 的交换机上调整端口ID:
    switch(enable) set spantree portpri {mldule/port}priority
    switch(enable) set spantree portvlanpri {module/port}priority [vlans]
    17. 在基于IOS 的交换机上修改STP 时钟:
    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
    在基于CLI 的交换机上修改STP 时钟:
    switch(enable) set spantree hello interval[vlan]
    switch(enable) set spantree fwddelay delay [vlan]
    switch(enable) set spantree maxage agingtiame[vlan]
    18. 在基于IOS 的交换机端口上启用或禁用Port Fast 特征:
    switch(config-if)#spanning-tree portfast
    在基于CLI 的交换机端口上启用或禁用Port Fast 特征:
    switch(enable) set spantree portfast {module/port}{enable|disable}
    19. 在基于IOS 的交换机端口上启用或禁用UplinkFast 特征:
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
    在基于CLI 的交换机端口上启用或禁用UplinkFast 特征:
    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP 地址,然后使
    用下列命令: switch(config)# cluster enable cluster-name
    21. 为了从一条中继链路上删除VLAN,可使用下列命令:
    switch(enable) clear trunk module/port vlan-range
    22. 用show vtp domain 显示管理域的VTP 参数.
    23. 用show vtp statistics 显示管理域的VTP 参数.
    24. 在Catalyst 交换机上定义TrBRF 的命令如下:
    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
    25. 在Catalyst 交换机上定义TrCRF 的命令如下:
    switch (enable) set vlan vlan-num [name name] type trcrf
    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num
    26. 在创建好TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如
    下命令给VLAN 分配端口:
    switch(enable) set vlan vlan-num mod-num/port-num
    27. 命令show spantree 显示一个交换机端口的STP 状态.
    28. 配置一个ELAN 的LES 和BUS,可以使用下列命令:
    ATM (config)# interface atm number.subint multioint
    ATM(config-subif)# lane serber-bus ethernet elan-name
    29. 配置LECS:
    ATM(config)# lane database database-name
    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
    ATM(lane-config-databade)# name …
    30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
    ATM(config)# interface atm number
    ATM(config-if)# lane config database database-name
    ATM(config-if)# lane config auto-config-atm-address
    31. 将每个LEC 配置到一个不同的ATM 子接口上.命令如下:
    ATM(config)# interface atm number.subint multipoint
    ATM(config)# lane client ethernet vlan-num elan-num
    32. 用show lane server 显示LES 的状态.
    33. 用show lane bus 显示bus 的状态.
    34. 用show lane database 显示LECS 数据库可内容.
    35. 用show lane client 显示LEC 的状态.
    36. 用show module 显示已安装的模块列表.
    37. 用物理接口建立与VLAN 的连接:
    router# configure terminal
    router(config)# interface media module/port
    router(config-if)# description description-string
    router(config-if)# ip address ip-addr subnet-mask
    router(config-if)# no shutdown
    38. 用中继链路来建立与VLAN 的连接:
    router(config)# interface module/port.subinterface
    router(config-ig)# encapsulation[isl|dotlq] vlan-number
    router(config-if)# ip address ip-address subnet-mask
    39. 用LANE 来建立与VLAN 的连接:
    router(config)# interface atm module/port
    router(config-if)# no ip address
    router(config-if)# atm pvc 1 0 5 qsaal
    router(config-if)# atm pvc 2 0 16 ilni
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-mask
    router(config-if)# lane client ethernet elan-num
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-name
    router(config-if)# lane client ethernet elan-name
    router(config-if)# …
    40. 为了在路由处理器上进行动态路由配置,可以用下列IOS 命令来进行:
    router(config)# ip routing
    router(config)# router ip-routing-protocol
    router(config-router)# network ip-network-number
    router(config-router)# network ip-network-number
    41. 配置默认路由:
    switch(enable) set ip route default gateway
    42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
    router(config)# interface interface number
    router(config-if)# mls rp vlan-id vlan-id-num
    43. 在路由处理器启用MLSP:
    router(config)# mls rp ip
    44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP 域中:
    router(config)# interface interface number
    router(config-if)# mls rp vtp-domain domain-name
    45. 查看指定的VTP 域的信息:
    router# show mls rp vtp-domain vtp domain name
    46. 要确定RSM 或路由器上的管理接口,可以在接口模式下输入下列命令:
    router(config-if)#mls rp management-interface
    47. 要检验MLS-RP 的配置情况:
    router# show mls rp
    48. 检验特定接口上的MLS 配置:
    router# show mls rp interface interface number
    49. 为了在MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
    set mls flow [destination|destination-source|full]
    50. 为使MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:
    router(config)# mls rp ip input-acl
    51. 当某个交换机的第3 层交换失效时,可在交换机的特权模式下输入下列命令:
    switch(enable) set mls enable
    52. 若想改变老化时间的值,可在特权模式下输入以下命令:
    switch(enable) set mls agingtime agingtime
    53. 设置快速老化:
    switch(enable) set mls agingtime fast fastagingtime pkt_threshold
    54. 确定那些MLS-RP 和MLS-SE 参与了MLS,可先显示交换机引用列表中的内容再确定:
    switch(enable) show mls include
    55. 显示MLS 高速缓存记录:
    switch(enable) show mls entry
    56. 用命令show in arp 显示ARP 高速缓存区的内容。
    57. 要把路由器配置为HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:
    router(config-if)# standby group-number ip ip-address
    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
    router(config-if)# standy group-number preempt
    59. 访问时间和保持时间参数是可配置的:
    router(config-if)# standy group-number timers hellotime holdtime
    60. 配置HSRP 跟踪:
    router(config-if)# standy group-number track type-number interface-priority
    61. 要显示HSRP 路由器的状态:
    router# show standby type-number group brief
    62. 用命令show ip igmp 确定当选的查询器。
    63. 启动IP 组播路由选择:
    router(config)# ip muticast-routing
    64. 启动接口上的PIM:
    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
    65. 启动稀疏-稠密模式下的PIM:
    router# ip multicast-routing
    router# interface type number
    router# ip pim sparse-dense-mode
    66. 核实PIM 的配置:
    dallasr1># show ip pim interface[type number] [count]
    67. 显示PIM 邻居:
    dallasr1># show ip neighbor type number
    68. 为了配置RP 的地址,命令如下:
    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
    69. 选择一个默认的RP:
    dallasr1># ip pim rp-address
    通告RP 和它所服务的组范围:
    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
    为管理范围组通告RP 的地址:
    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
    设定一个RP 映像代理:
    dallasr1># ip pim send-rp-discovery scope ttl
    核实组到RP 的映像:
    dallasr1># show ip pim rp mapping
    dallasr1># show ip pim rp [group-name|group-address] [mapping]
    70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value 设定TTL 阀值:
    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
    71. 用show ip pim neighbor 显示PIM 邻居表。
    72. 显示组播通信路由表中的各条记录:
    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
    73. 要记录一个路由器接受和发送的全部IP 组播包:
    dallasr1> #debug ip mpacket [detail] [access-list][group]
    74. 要在CISCO 路由器上配置CGMP:
    dallasr1>(config-if)# ip cgmp
    75.配置一个组播路由器,使之加入某一个特定的组播组:
    dallasr1>(config-if)# ip igmp join-group group-address
    76. 关闭CGMP:
    dallasr1>(config-if)# no ip cgmp
    77. 启动交换机上的CGMP:
    dallasr1>(enable) set cgmp enable
    78. 核实Catalyst 交换机上CGMP 的配置情况:
    catalystla1>(enable) show config
    set prompt catalystla1>
    set interface sc0 192.168.1.1 255.255.255.0
    set cgmp enable
    79. CGMP 离开的设置:
    Dallas_SW(enable) set cgmp leave
    80. 在Cisco 设备上修改控制端口密码:
    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco
    81. 在Cisco 设备上设置控制台及vty 端口的会话超时:
    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2
    82. 在Cisco 设备上设定特权级:
    R1(config)# privilege configure level 3 username
    R1(config)# privilege configure level 3 copy run start
    R1(config)# privilege configure level 3 ping
    R1(config)# privilege configure level 3 show run
    R1(config)# enable secret level 3 cisco
    83. 使用命令privilege 可定义在该特权级下使用的命令:
    router(config)# privilege mode level level command
    84. 设定用户特权级:
    router(config)# enable secret level 3 dallas
    router(config)# enable secret san-fran
    router(config)# username student password cisco
    85. 标志设置与显示:
    R1(config)# banner motd ‘unauthorized access will be prosecuted!’
    86. 设置vty 访问:
    R1(config)# access-list 1 permit 192.168.2.5
    R1(config)# line vty 0 4
    R1(config)# access-class 1 in
    87. 配置HTTP 访问:
    Router3(config)# access-list 1 permit 192.168.10.7
    Router3(config)# ip http sever
    Router3(config)# ip http access-class 1
    Router3(config)# ip http authentication local
    Router3(config)# username student password cisco
    88. 要启用HTTP 访问,请键入以下命令:
    switch(config)# ip http sever
    89. 在基于set 命令的交换机上用setCL1 启动和核实端口安全:
    switch(enable) set port security mod_num/port_num…enable mac address
    switch(enable) show port mod_num/port_num
    在基于CiscoIOS 命令的交换机上启动和核实端口安全:
    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
    switch# show mac-address-table security [type module/port]
    90. 用命令access-list 在标准通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]
    91. 用命令access-list 在扩展通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source
    source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]
    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name in [type number]
    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process|
    autonomous-system-number
    94. set snmp 命令选项:
    set snmp community {read-only|ready-write|read-write-all}[community_string]
    95. set snmp trap 命令格式如下:
    set snmp trap {enable|disable}
    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
    set snmp trap rvcr_addr rcvr_community
    96. 启用SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable chassis
    97. 启用所有SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable
    …………以下由about 于2002 年12 月6 日增加…………
    98. 禁用SNMP chassis 陷阱:
    Console>(enable) set snmp trap disable chassis
    99. 给SNMP 陷阱接收表加一条记录:
    Console>(enable) set snmp trap 192.122.173.42 public
    100. show snmp 输出结果。
    101. 命令set snmp rmon enable 的输出结果。
    102. 显示SPAN 信息:
    Consile> show spanCISCO 交换机配置命令大全

    转载于:https://blog.51cto.com/hanzheng/883475

    展开全文
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • /用户模式hostname#/特权模式hostname(config)#/全局配置模式hostname(config-if)#/接口状态交换机口令设置:switch>enable/进入特权模式switch#configterminal/进入全局配置模式switch(config)#hostname/设置...

    交换机基本状态:

    hostname>/用户模式

    hostname#/特权模式

    hostname(config)#/全局配置模式

    hostname(config-if)#/接口状态

    交换机口令设置:

    switch>enable/进入特权模式

    switch#configterminal/进入全局配置模式

    switch(config)#hostname/设置交换机的主机名

    switch(config)#enablesecretxxx/设置特权加密口令

    switch(config)#enablepasswordxxa/设置特权非密口令

    switch(config)#lineconsole0/进入控制台口

    switch(config-line)#linevty04/进入虚拟终端

    switch(config-line)#login/允许登录

    switch(config-line)#passwordxx/设置登录口令xx

    switch#exit/返回命令

    交换机VLAN设置:

    switch#vlandatabase/进入VLAN设置

    switch(vlan)#vlan2/建VLAN

    2switch(vlan)#novlan2/删vlan

    2switch(config)#intf0/1/进入端口1

    switch(config-if)#switchportaccessvlan2/当前端口加入

    vlan2switch(config-if)#switchportmodetrunk/设置为干线

    switch(config-if)#switchporttrunkallowedvlan1,2/设置允许的

    vlanswitch(config-if)#switchporttrunkencapdot1q/设置vlan中继

    switch(config)#vtpdomain/设置发vtp域名

    switch(config)#vtppassword/设置发vtp密码

    switch(config)#vtpmodeserver/设置发vtp模式

    switch(config)#vtpmodeclient/设置发vtp模式

    交换机设置IP地址:

    switch(config)#interfacevlan1;进入vlan1

    switch(config-if)#ipaddress;设置IP地址

    switch(config)#ipdefault-gateway;设置默认网关

    switch#dirflash:;查看闪存

    交换机显示命令:

    switch#write/保存配置信息

    switch#showvtp/查看vtp配置信息

    switch#showrun/查看当前配置信息

    switch#showvlan/查看vlan配置信息

    switch#showinterface/查看端口信息

    switch#showintf0/0/查看指定端口信息

    补充:3层交换机多出的就是路由能力,体现在vlan的互相通信功能和端口的路由能力

    下面介绍:

    开启路由功能:iprouting进入vlan配置网段网关与路由配置接口相同

    interfacevlan1ip192.168.1.1255.255.255.0

    路由配置与路由器配置相同只是把接口换为VLAN+VLAN号,开启接口路由功能,进入接口配置:noswichport

    绿茶小编猜你还喜欢:

    无线路由器当交换机用:无线路由器做交换机设置教程

    交换机接无线路由器教程:交换机下接无线路由器步骤介绍

    展开全文
  • 21. 为了从一条中继链路上删除 VLAN,可使用下列命令:switch(enable) clear trunk module/port vlan-range22. 用 show vtp domain 显示管理域的 VTP 参数.23. 用 show vtp statistics 显示管理域的 VTP 参数.24. 在 ...
    f29aa7711dad537dfc6103dc534313b5.png

    21. 为了从一条中继链路上删除 VLAN,可使用下列命令:switch(enable) clear trunk module/port vlan-range

    22. 用 show vtp domain 显示管理域的 VTP 参数.

    23. 用 show vtp statistics 显示管理域的 VTP 参数.

    24. 在 Catalyst 交换机上定义 TrBRF 的命令如下:

    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

    25. 在 Catalyst 交换机上定义 TrCRF 的命令如下:

    switch (enable) set vlan vlan-num [name name] type trcrf

    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num

    26. 在创建好 TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如

    下命令给 VLAN 分配端口:

    switch(enable) set vlan vlan-num mod-num/port-num

    27. 命令 show spantree 显示一个交换机端口的 STP 状态.

    28. 配置一个 ELAN 的 LES 和 BUS,可以使用下列命令:

    ATM (config)# interface atm number.subint multioint

    ATM(config-subif)# lane serber-bus ethernet elan-name

    29. 配置 LECS:

    ATM(config)# lane database database-name

    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address

    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address

    ATM(lane-config-databade)# name …

    30. 创建完数据库后,必须在主接口上启动 LECS.命令如下:

    ATM(config)# interface atm number

    ATM(config-if)# lane config database database-name

    ATM(config-if)# lane config auto-config-atm-address

    31. 将每个 LEC 配置到一个不同的 ATM 子接口上.命令如下:

    ATM(config)# interface atm number.subint multipoint

    ATM(config)# lane client ethernet vlan-num elan-num

    32. 用 show lane server 显示 LES 的状态.

    33. 用 show lane bus 显示 bus 的状态.

    34. 用 show lane database 显示 LECS 数据库可内容.35. 用 show lane client 显示 LEC 的状态.

    36. 用 show module 显示已安装的模块列表.

    37. 用物理接口建立与 VLAN 的连接:

    router# configure terminal

    router(config)# interface media module/port

    router(config-if)# description description-string

    router(config-if)# ip address ip-addr subnet-mask

    router(config-if)# no shutdown

    38. 用中继链路来建立与 VLAN 的连接:

    router(config)# interface module/port.subinterface

    router(config-ig)# encapsulation[isl|dotlq] vlan-number

    router(config-if)# ip address ip-address subnet-mask

    39. 用 LANE 来建立与 VLAN 的连接:

    router(config)# interface atm module/port

    router(config-if)# no ip address

    router(config-if)# atm pvc 1 0 5 qsaal

    router(config-if)# atm pvc 2 0 16 ilni

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-mask

    router(config-if)# lane client ethernet elan-num

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-name

    router(config-if)# lane client ethernet elan-name

    router(config-if)# …

    40. 为了在路由处理器上进行动态路由配置,可以用下列 IOS 命令来进行:

    router(config)# ip routing

    router(config)# router ip-routing-protocol

    router(config-router)# network ip-network-number

    router(config-router)# network ip-network-number

    41. 配置默认路由:

    switch(enable) set ip route default gateway

    42. 为一个路由处理器分配 VLANID,可在接口模式下使用下列命令:

    router(config)# interface interface number

    router(config-if)# mls rp vlan-id vlan-id-num

    43. 在路由处理器启用 MLSP:

    router(config)# mls rp ip44. 为了把一个外置的路由处理器接口和交换机安置在同一个 VTP 域中:

    router(config)# interface interface number

    router(config-if)# mls rp vtp-domain domain-name

    45. 查看指定的 VTP 域的信息:

    router# show mls rp vtp-domain vtp domain name

    46. 要确定 RSM 或路由器上的管理接口,可以在接口模式下输入下列命令:

    router(config-if)#mls rp management-interface

    47. 要检验 MLS-RP 的配置情况:

    router# show mls rp

    48. 检验特定接口上的 MLS 配置:

    router# show mls rp interface interface number

    49. 为了在 MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:

    set mls flow [destination|destination-source|full]

    50. 为使 MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:

    router(config)# mls rp ip input-acl

    51. 当某个交换机的第 3 层交换失效时,可在交换机的特权模式下输入下列命令:

    switch(enable) set mls enable

    52. 若想改变老化时间的值,可在特权模式下输入以下命令:

    switch(enable) set mls agingtime agingtime

    53. 设置快速老化:

    switch(enable) set mls agingtime fast fastagingtime pkt_threshold

    54. 确定那些 MLS-RP 和 MLS-SE 参与了 MLS,可先显示交换机引用列表中的内容再确定:

    switch(enable) show mls include

    55. 显示 MLS 高速缓存记录:

    switch(enable) show mls entry

    56. 用命令 show in arp 显示 ARP 高速缓存区的内容。

    57. 要把路由器配置为 HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:

    router(config-if)# standby group-number ip ip-address

    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:router(config-if)# standy group-number preempt

    59. 访问时间和保持时间参数是可配置的:

    router(config-if)# standy group-number timers hellotime holdtime

    60. 配置 HSRP 跟踪:

    router(config-if)# standy group-number track type-number interface-priority

    61. 要显示 HSRP 路由器的状态:

    router# show standby type-number group brief

    62. 用命令 show ip igmp 确定当选的查询器。

    63. 启动 IP 组播路由选择:

    router(config)# ip muticast-routing

    64. 启动接口上的 PIM:

    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

    65. 启动稀疏-稠密模式下的 PIM:

    router# ip multicast-routing

    router# interface type number

    router# ip pim sparse-dense-mode

    66. 核实 PIM 的配置:

    dallasr1># show ip pim interface[type number] [count]

    67. 显示 PIM 邻居:

    dallasr1># show ip neighbor type number

    68. 为了配置 RP 的地址,命令如下:

    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

    69. 选择一个默认的 RP:

    dallasr1># ip pim rp-address

    通告 RP 和它所服务的组范围:

    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number

    为管理范围组通告 RP 的地址:

    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1

    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255

    设定一个 RP 映像代理:

    dallasr1># ip pim send-rp-discovery scope ttl

    核实组到 RP 的映像:

    dallasr1># show ip pim rp mappingdallasr1># show ip pim rp [group-name|group-address] [mapping]

    70. 在路由器接口上用命令 ip multicast ttl-threshold ttl-value 设定 TTL 阀值:

    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

    71. 用 show ip pim neighbor 显示 PIM 邻居表。

    72. 显示组播通信路由表中的各条记录:

    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

    73. 要记录一个路由器接受和发送的全部 IP 组播包:

    dallasr1> #debug ip mpacket [detail] [access-list][group]

    74. 要在 CISCO 路由器上配置 CGMP:

    dallasr1>(config-if)# ip cgmp

    75.配置一个组播路由器,使之加入某一个特定的组播组:

    dallasr1>(config-if)# ip igmp join-group group-address

    76. 关闭 CGMP:

    dallasr1>(config-if)# no ip cgmp

    77. 启动交换机上的 CGMP:

    dallasr1>(enable) set cgmp enable

    78. 核实 Catalyst 交换机上 CGMP 的配置情况:

    catalystla1>(enable) show config

    set prompt catalystla1>

    set interface sc0 192.168.1.1 255.255.255.0

    set cgmp enable

    79. CGMP 离开的设置:

    Dallas_SW(enable) set cgmp leave

    80. 在 Cisco 设备上修改控制端口密码:

    R1(config)# line console 0

    R1(config-line)# login

    R1(config-line)# password Lisbon

    R1(config)# enable password Lilbao

    R1(config)# login local

    R1(config)# username student password cisco

    81. 在 Cisco 设备上设置控制台及 vty 端口的会话超时:

    R1(config)# line console 0R1(config-line)# exec-timeout 5 10

    R1(config)# line vty 0 4

    R1(config-line)# exec-timeout 5 2

    82. 在 Cisco 设备上设定特权级:

    R1(config)# privilege configure level 3 username

    R1(config)# privilege configure level 3 copy run start

    R1(config)# privilege configure level 3 ping

    R1(config)# privilege configure level 3 show run

    R1(config)# enable secret level 3 cisco

    83. 使用命令 privilege 可定义在该特权级下使用的命令:

    router(config)# privilege mode level level command

    84. 设定用户特权级:

    router(config)# enable secret level 3 dallas

    router(config)# enable secret san-fran

    router(config)# username student password cisco

    85. 标志设置与显示:

    R1(config)# banner motd ‘unauthorized access will be prosecuted!’

    86. 设置 vty 访问:

    R1(config)# access-list 1 permit 192.168.2.5

    R1(config)# line vty 0 4

    R1(config)# access-class 1 in

    87. 配置 HTTP 访问:

    Router3(config)# access-list 1 permit 192.168.10.7

    Router3(config)# ip http sever

    Router3(config)# ip http access-class 1

    Router3(config)# ip http authentication local

    Router3(config)# username student password cisco

    88. 要启用 HTTP 访问,请键入以下命令:

    switch(config)# ip http sever

    89. 在基于 set 命令的交换机上用 setCL1 启动和核实端口安全:

    switch(enable) set port security mod_num/port_num…enable mac address

    switch(enable) show port mod_num/port_num

    在基于 CiscoIOS 命令的交换机上启动和核实端口安全:

    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]

    switch# show mac-address-table security [type module/port]90. 用命令 access-list 在标准通信量过滤表中创建一条记录:

    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

    91. 用命令 access-list 在扩展通信量过滤表中创建一条记录:

    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source

    source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name in [type number]

    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process|

    autonomous-system-number

    94. set snmp 命令选项:

    set snmp community {read-only|ready-write|read-write-all}[community_string]

    95. set snmp trap 命令格式如下:

    set snmp trap {enable|disable}

    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]

    set snmp trap rvcr_addr rcvr_community

    96. 启用 SNMP chassis 陷阱:

    Console>(enable) set snmp trap enable chassis

    97. 启用所有 SNMP chassis 陷阱:

    Console>(enable) set snmp trap enable

    …………以下由 about 于 2002 年 12 月 6 日增加…………

    98. 禁用 SNMP chassis 陷阱:

    Console>(enable) set snmp trap disable chassis

    99. 给 SNMP 陷阱接收表加一条记录:

    Console>(enable) set snmp trap 192.122.173.42 public

    100. show snmp 输出结果。

    101. 命令 set snmp rmon enable 的输出结果。

    102. 显示 SPAN 信息:

    Consile> show spanCISCO 交换机配置命令大全

    头条搜索,弱电智能邦,加关注,私信资料即可获取79G弱电学习资料。

    f0f96637704141dd91ec1437330e7bc9.png
    展开全文
  • 思科交换机配置命令大全,真的很全 CISCO, 大全, 交换机, 命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name...
    思科交换机配置命令大全,真的很全
    CISCO, 大全, 交换机, 命令
    1.在基于IOS的交换机上设置主机名/系统名:
    switch(config)# hostname hostname
    在基于CLI的交换机上设置主机名/系统名:
    switch(enable) set system name name-string
    2.在基于IOS的交换机上设置登录口令:
    switch(config)# enable password level 1 password
    在基于CLI的交换机上设置登录口令:
    switch(enable) set password
    switch(enable) set enalbepass
    3.在基于IOS的交换机上设置远程访问:
    switch(config)# interface vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address
    在基于CLI的交换机上设置远程访问:
    switch(enable) set interface sc0 ip-address netmask broadcast-address
    switch(enable) set interface sc0 vlan
    switch(enable) set ip route default gateway
    4.在基于IOS的交换机上启用和浏览CDP信息:
    switch(config-if)# cdp enable
    switch(config-if)# no cdp enable
    为了查看Cisco邻接设备的CDP通告信息:
    switch# show cdp interface [type modle/port]
    switch# show cdp neighbors [type module/port] [detail]
    在基于CLI的交换机上启用和浏览CDP信息:
    switch(enable) set cdp {enable|disable} module/port
    为了查看Cisco邻接设备的CDP通告信息:
    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
    5.基于IOS的交换机的端口描述:
    switch(config-if)# description description-string
    基于CLI的交换机的端口描述:
    switch(enable)set port name module/number description-string
    6.在基于IOS的交换机上设置端口速度:
    switch(config-if)# speed{10|100|auto}
    在基于CLI的交换机上设置端口速度:
    switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}
    7.在基于IOS的交换机上设置以太网的链路模式:
    switch(config-if)# duplex {auto|full|half}
    在基于CLI的交换机上设置以太网的链路模式:
    switch(enable) set port duplex module/number {full|half}
    8.在基于IOS的交换机上配置静态VLAN:
    switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)# interface interface module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end
    在基于CLI的交换机上配置静态VLAN:
    switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list
    9. 在基于IOS的交换机上配置VLAN中继线:
    switch(config)# interface interface mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于CLI的交换机上配置VLAN中继线:
    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]
    10.在基于IOS的交换机上配置VTP管理域:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    在基于CLI的交换机上配置VTP管理域:
    switch(enable) set vtp [domain domain-name]
    11.在基于IOS的交换机上配置VTP 模式:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    switch(vlan)# vtp {sever|cilent|transparent}
    switch(vlan)# vtp password password
    在基于CLI的交换机上配置VTP 模式:
    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
    12. 在基于IOS的交换机上配置VTP版本:
    switch# vlan database
    switch(vlan)# vtp v2-mode
    在基于CLI的交换机上配置VTP版本:
    switch(enable) set vtp v2 enable
    13. 在基于IOS的交换机上启动VTP剪裁:
    switch# vlan database
    switch(vlan)# vtp pruning
    在基于CL I 的交换机上启动VTP剪裁:
    switch(enable) set vtp pruning enable
    14.在基于IOS的交换机上配置以太信道:
    switch(config-if)# port group group-number [distribution {source|destination}]
    在基于CLI的交换机上配置以太信道:
    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
    15.在基于IOS的交换机上调整根路径成本:
    switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于CLI的交换机上调整根路径成本:
    switch(enable) set spantree portcost moudle/port cost
    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
    16.在基于IOS的交换机上调整端口ID:
    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于CLI的交换机上调整端口ID:
    switch(enable) set spantree portpri {mldule/port}priority
    switch(enable) set spantree portvlanpri {module/port}priority [vlans]
    17. 在基于IOS的交换机上修改STP时钟:
    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
    在基于CLI的交换机上修改STP时钟:
    switch(enable) set spantree hello interval[vlan]
    switch(enable) set spantree fwddelay delay [vlan]
    switch(enable) set spantree maxage agingtiame[vlan]
    18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
    switch(config-if)#spanning-tree portfast
    在基于CLI的交换机端口上启用或禁用Port Fast 特征:
    switch(enable) set spantree portfast {module/port}{enable|disable}
    19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
    在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name
    21. 为了从一条中继链路上删除VLAN,可使用下列命令:
    switch(enable) clear trunk module/port vlan-range
    22. 用show vtp domain 显示管理域的VTP参数.
    23. 用show vtp statistics显示管理域的VTP参数.
    24. 在Catalyst交换机上定义TrBRF的命令如下:
    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
    25. 在Catalyst交换机上定义TrCRF的命令如下:
    switch (enable) set vlan vlan-num [name name] type trcrf
    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num
    26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:
    switch(enable) set vlan vlan-num mod-num/port-num
    27. 命令show spantree显示一个交换机端口的STP状态.
    28. 配置一个ELAN的LES和BUS,可以使用下列命令:
    ATM (config)# interface atm number.subint multioint
    ATM(config-subif)# lane serber-bus ethernet elan-name
    29. 配置LECS:
    ATM(config)# lane database database-name
    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
    ATM(lane-config-databade)# name …
    30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
    ATM(config)# interface atm number
    ATM(config-if)# lane config database database-name
    ATM(config-if)# lane config auto-config-atm-address
    31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:
    ATM(config)# interface atm number.subint multipoint
    ATM(config)# lane client ethernet vlan-num elan-num
    32. 用show lane server 显示LES的状态.
    33. 用show lane bus显示bus的状态.
    34. 用show lane database显示LECS数据库可内容.
    35. 用show lane client显示LEC的状态.
    36. 用show module显示已安装的模块列表.
    37. 用物理接口建立与VLAN的连接:
    router# configure terminal
    router(config)# interface media module/port
    router(config-if)# description description-string
    router(config-if)# ip address ip-addr subnet-mask
    router(config-if)# no shutdown
    38. 用中继链路来建立与VLAN的连接:
    router(config)# interface module/port.subinterface
    router(config-ig)# encapsulation[isl|dotlq] vlan-number
    router(config-if)# ip address ip-address subnet-mask
    39. 用LANE 来建立与VLAN的连接:
    router(config)# interface atm module/port
    router(config-if)# no ip address
    router(config-if)# atm pvc 1 0 5 qsaal
    router(config-if)# atm pvc 2 0 16 ilni
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-mask
    router(config-if)# lane client ethernet elan-num
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-name
    router(config-if)# lane client ethernet elan-name
    router(config-if)# …
    40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:
    router(config)# ip routing
    router(config)# router ip-routing-protocol
    router(config-router)# network ip-network-number
    router(config-router)# network ip-network-number
    41. 配置默认路由:
    switch(enable) set ip route default gateway
    42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
    router(config)# interface interface number
    router(config-if)# mls rp vlan-id vlan-id-num
    43. 在路由处理器启用MLSP:
    router(config)# mls rp ip
    44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:
    router(config)# interface interface number
    router(config-if)# mls rp vtp-domain domain-name
    45. 查看指定的VTP域的信息:
    router# show mls rp vtp-domain vtp domain name
    46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:
    router(config-if)#mls rp management-interface
    47. 要检验MLS-RP的配置情况:
    router# show mls rp
    48. 检验特定接口上的MLS配置:
    router# show mls rp interface interface number
    49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
    set mls flow [destination|destination-source|full]
    50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:
    router(config)# mls rp ip input-acl
    51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:
    switch(enable) set mls enable
    52. 若想改变老化时间的值,可在特权模式下输入以下命令:
    switch(enable) set mls agingtime agingtime
    53. 设置快速老化:
    switch(enable) set mls agingtime fast fastagingtime pkt_threshold
    54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:
    switch(enable) show mls include
    55. 显示MLS高速缓存记录:
    switch(enable) show mls entry
    56. 用命令show in arp显示ARP高速缓存区的内容。
    57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:
    router(config-if)# standby group-number ip ip-address
    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
    router(config-if)# standy group-number preempt
    59. 访问时间和保持时间参数是可配置的:
    router(config-if)# standy group-number timers hellotime holdtime
    60. 配置HSRP跟踪:
    router(config-if)# standy group-number track type-number interface-priority
    61. 要显示HSRP路由器的状态:
    router# show standby type-number group brief
    62. 用命令show ip igmp确定当选的查询器。
    63. 启动IP组播路由选择:
    router(config)# ip muticast-routing
    64. 启动接口上的PIM:
    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
    65. 启动稀疏-稠密模式下的PIM:
    router# ip multicast-routing
    router# interface type number
    router# ip pim sparse-dense-mode
    66. 核实PIM的配置:
    dallasr1># show ip pim interface[type number] [count]
    67. 显示PIM邻居:
    dallasr1># show ip neighbor type number
    68. 为了配置RP的地址,命令如下:
    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
    69. 选择一个默认的RP:
    dallasr1># ip pim rp-address
    通告RP和它所服务的组范围:
    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
    为管理范围组通告RP的地址:
    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
    设定一个RP映像代理:
    dallasr1># ip pim send-rp-discovery scope ttl
    核实组到RP的映像:
    dallasr1># show ip pim rp mapping
    dallasr1># show ip pim rp [group-name|group-address] [mapping]
    70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:
    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
    71. 用show ip pim neighbor显示PIM邻居表。
    72. 显示组播通信路由表中的各条记录:
    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
    73. 要记录一个路由器接受和发送的全部IP组播包:
    dallasr1> #debug ip mpacket [detail] [access-list][group]
    74. 要在CISCO路由器上配置CGMP:
    dallasr1>(config-if)# ip cgmp
    75.配置一个组播路由器,使之加入某一个特定的组播组:
    dallasr1>(config-if)# ip igmp join-group group-address
    76. 关闭 CGMP:
    dallasr1>(config-if)# no ip cgmp
    77. 启动交换机上的CGMP:
    dallasr1>(enable) set cgmp enable
    78. 核实Catalyst交换机上CGMP的配置情况:
    catalystla1>(enable) show config
    set prompt catalystla1>
    set interface sc0 192.168.1.1 255.255.255.0
    set cgmp enable
    79. CGMP离开的设置:
    Dallas_SW(enable) set cgmp leave
    80. 在Cisco设备上修改控制端口密码:
    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco
    81. 在Cisco设备上设置控制台及vty端口的会话超时:
    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2
    82. 在Cisco设备上设定特权级:
    R1(config)# privilege configure level 3 username
    R1(config)# privilege configure level 3 copy run start
    R1(config)# privilege configure level 3 ping
    R1(config)# privilege configure level 3 show run
    R1(config)# enable secret level 3 cisco
    83. 使用命令privilege 可定义在该特权级下使用的命令:
    router(config)# privilege mode level level command
    84. 设定用户特权级:
    router(config)# enable secret level 3 dallas
    router(config)# enable secret san-fran
    router(config)# username student password cisco
    85. 标志设置与显示:
    R1(config)# banner motd ‘unauthorized access will be prosecuted!’
    86. 设置vty访问:
    R1(config)# access-list 1 permit 192.168.2.5
    R1(config)# line vty 0 4
    R1(config)# access-class 1 in
    87. 配置HTTP访问:
    Router3(config)# access-list 1 permit 192.168.10.7
    Router3(config)# ip http sever
    Router3(config)# ip http access-class 1
    Router3(config)# ip http authentication local
    Router3(config)# username student password cisco
    88. 要启用HTTP访问,请键入以下命令:
    switch(config)# ip http sever
    89. 在基于set命令的交换机上用setCL1启动和核实端口安全:
    switch(enable) set port security mod_num/port_num…enable mac address
    switch(enable) show port mod_num/port_num
    在基于CiscoIOS命令的交换机上启动和核实端口安全:
    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
    switch# show mac-address-table security [type module/port]
    90. 用命令access-list在标准通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]
    91. 用命令access-list在扩展通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]
    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name in [type number]
    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number
    94. set snmp命令选项:
    set snmp community {read-only|ready-write|read-write-all}[community_string]
    95. set snmp trap 命令格式如下:
    set snmp trap {enable|disable}
    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
    set snmp trap rvcr_addr rcvr_community
    96. 启用SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable chassis
    97. 启用所有SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable
    …………以下由about于2002年12月6日增加…………
    98. 禁用SNMP chassis 陷阱:
    Console>(enable) set snmp trap disable chassis
    99. 给SNMP陷阱接收表加一条记录:
    Console>(enable) set snmp trap 192.122.173.42 public
    100. show snmp 输出结果。
    101. 命令set snmp rmon enable 的输出结果。
    102. 显示SPAN信息:
    Consile> show spanCISCO交换机配置命令大全
     

    转载于:https://blog.51cto.com/netsky1/241305

    展开全文
  • switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置... enable switch#c onfigure terminal switch(conf)# 3:交换机命名 hostname aptech2950 以 aptech2950 为例 switch>...
  • 思科交换机配置命令大全

    千次阅读 2012-11-22 15:26:46
    1. 交换机支持的命令交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 ...
  • 交换机配置命令大全

    2012-03-03 09:54:51
    思科交换机配置命令大全\思科交换机配置命令大全
  • Cisco Packet Tracer 命令大全基本配置文件操作启动配置密码设置接口配置CDP路由RIPIGRPEIGRPOSPFACLNAT PAT 配置负载分发DHCPHDLCPPPFRARP(默认启用)ISDNIS-ISBGP路由优化异步连接QoS 转载自:...
  • 关注我,你的眼睛会怀孕(1)模式转换命令用户模式一-特权模式,使用命令"enable"特权模式一-全局配置模式,使用命令”ontfg"全局配置模式--接口模式,使用命令"interface接口类型#接口号”全局配置模--线控模式,使用...
  • (1)模式转换命令 用户模式一-特权模式,使用命令"enable" ...全局模式:配置所有信息、针对整个路由器或交换机的所有接口 接口模式:针对某一个接口的配置 线控模式:对路由器进行控制的接口配置 (...
  • 思科交换机和路由器配置命令对照大全
  • 1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机上设置登录口令: switch...
  • 思科2960交换机 - 配置命令大全

    千次阅读 2018-11-13 15:36:47
    今天给大家分享下思科2960交换机配置命令: 一、使能口令和使能密码 1、使能口令(enable password),口令以明文显示。 2、使能密码(enbale secret), 口令以密文显示。 Switch.> /*用户直行模式...
  • CISCO思科交换机3650G配置命令大全

    千次阅读 2011-08-17 22:19:39
    Cisco 交换机命令 1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机...
  • 11.配置VTP管理域 switch# vlan database switch(vlan)# vtp domain domain-name switch(enable) set vtp [domain domain-name] 12.配置VTP 模式 switch# vlan database switch(vlan)# vtp domain domain-name ...
  • 思科交换机

    2018-12-06 23:40:00
    思科交换机配置命令大全 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch...
  • switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal ...3:交换机命名 hostname...
  • 11:cdp相关命令 switch> enable switch# show cdp 查看设备的cdp全局配置信息 show cdp interface fastethernet 0/17 查看17端口的cdp配置信息 show cdp traffic 查看有关cdp包的统计信息 show cdp ...
  • 精品文档 思科交换机路由器命令大全 交换机命令: switch> 用户模式...#no ip address 配置交换机默认网关 switch(config)#ip default-gateway 192.168.0.1 16 17 查看交换机的 MAC 地址表 switch#sh mac-a 查看...
  • 思科命令大全

    2018-12-03 17:06:56
    思科交换机的基本配置命令学习 CISCO交换机基本配置:Console端口连接 用户模式hostname# ; 特权模式hostname(config)# ; 全局配置模式hostname(config-if)# ; 交换机口令设置: switch>enable ;进入特权模式 ...
  • 了解交换机的基本模式和命令(其他比如路由器基本相同) 常用: Switch> 用户模式 enable(简写en进特权模式;exit重新进入交换机命令界面) Switch# 特权模式(使能模式; exit返回特权模式) Switch(config# ...
  • 锐捷交换机的配置命令大全,部分命令适用于思科交换机
  • 思科配置大全

    2018-05-02 20:06:42
    思科配置交换机命令模式--Switch>--switch>:用户模式--switch>enable--switch#特权模式(一般用于查看配置信息)----switch#configure terminal全局配置模式(所做的配置信息对整个设备生效)--switch...
  • 交换机部分命令 一、交换机模式切换 Swith>enable //切换到特权 Swith#config t //切换到全局配置模式 Swith(config)# interface f0/1 //进入接口f0/0 Swith(config)# interface vlan 1 //进入VLAN 1中 Swith...
  • router(conf)#hostname routerA routerA(conf)# interface fastehernet 0/17 以17端口为例 ...routerA (conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口ip和子网掩码 routerA (con...

空空如也

空空如也

1 2
收藏数 34
精华内容 13
关键字:

思科交换机配置命令大全