精华内容
下载资源
问答
  • 通过交换机的基本配置VLAN配置,理解交换机的工作原理,理解VLAN的原理
  • 思科模拟器划分VLAN配置路由

    千次阅读 2020-07-07 12:19:32
    思科模拟器划分VLAN配置路由构建网络划分VLAN配置路由(选一种方法)静态路由动态路由rip协议ospf协议 构建网络 如上图所示,最终构建此网络。网络中PC1与PC2同VLAN 10,PC3与PC4同属VLAN 20,PC5与PC6同属VLAN ...

    在这里插入图片描述

    构建网络

    如上图所示,最终构建此网络。网络中PC1与PC2同VLAN 10,PC3与PC4同属VLAN 20,PC5与PC6同属VLAN 30,PC7与PC8同属VLAN 40。交换机接口不配置IP地址。

    1. 选择交换机3560 24PS 型号,拖动到中间幕布中,终端机选择台式机(8台);
    2. 选择 直连线 连接各端口;一般来说同种设备需要采用交叉线,不同设备之间要用直连线连接,但现在设备可以自适应,所以我这里都采用直连线也是没问题的。交换机连接的端口如下:

    SWitch0的个端口连接情况:

    在这里插入图片描述
    SWitch1的个端口连接情况:

    在这里插入图片描述
    SWitch2的个端口连接情况:

    在这里插入图片描述
    也可以自己选择交换机的任意端口,只要能区分开即可。因为划分VLAN要用到。

    1. 点击PC机,为它们添加IP地址与子网掩码,以及网关(网关也可以后面配)下面为PC1。
      网关地址为所在vlan的ip地址哈,这个要对应起来,不然就算有路由了主机也ping不通。在这里插入图片描述
    2. 交换机与交换机之间先连接一条线,并配置对应端口连接方式。如下图代码表示在交换机1的21端口配置(与交换机0的24端口相连接)连接方式。同理在交换机0、交换机2也需要配置。
      在这里插入图片描述

    划分VLAN

    1.点击交换机,进入命令行,hostname可以更改交换机命名。以交换机2为例,如下图定义vlan 20, 并为此vlan设置ip地址为192.168.20.253;同理再定义vlan 30,ip设为了192.168.30.253;
    在这里插入图片描述
    2.进入端口,配置其接入的vlan,如下图配置了f0/1接口接入vlan20
    在这里插入图片描述
    也可以成批配置,例如下图中,配置端口1-6都接入vlan 20
    在这里插入图片描述
    按照上面介绍的方法,将对应端口设置接入到对应vlan,此处要注意,switch0的vlan20与switch1的vlan20属于同一个vlan,那么名字与ip地址都有=要一致,这样PC3与PC4才算在同一个vlan下。同理PC5与PC6所在的vlan 30也是如此。全部配好后,连接点就会是绿色啦。
    此时,相同vlan的全部主机都是可以ping通的!但是不同vlan是不可以的!所以需要有路由!

    配置路由(选一种方法)

    静态路由

    配置方式如下:表示在交换机0中若要前往192.168.30.0网段要经由192.168.20.253vlan/端口
    在这里插入图片描述
    需要说明一下,按理说,应该在交换机上搭建路由器,这样路由器负责来找路由,交换机只负责vlan划分,这种情况下,经由的地址就是路由器端口IP地址,然而此处没有使用路由器,所以在交换机之间又连接一条线,这条线是普通线,不需要做设置,不要配置为trunk;也可以实现路由。
    按照上面的方式,把需要的路由都添加上,这样不同vlan的PC也可以ping通啦。

    动态路由

    rip协议

    静态路由需要一条一条配置,当路由较多时显然不方便,因此,动态路由必不可少。
    以sw0为例,如下图所示,表示把自己的192.168.10.0网络分享出去。
    在这里要继续配置,把全部网络都分享出去。其它交换机也同理配置哦。
    在这里插入图片描述

    ospf协议

    ospf协议比rip协议更精准好用,如下图配置,其中120表示分配的线程号,可随便设置,net后的地址表示要分享出去的网络号,要注意子网掩码是倒置的,最后的area 0只表示骨干区域。
    在这里插入图片描述
    同理全部交换机都要配置,可以使用命令sh ip route 查看路由列表
    在这里插入图片描述
    无论采用哪种方法,配置好路由后,各PC机之间就畅通无阻啦!

    展开全文
  • 思科模拟器VLAN配置与分析

    千次阅读 2020-05-29 14:09:34
    (5) 了解交换机web配置界面,并能进行部分操作。 (6)了解VLAN原理;(7)熟练掌握二层交换机VLAN的划分方法;(8)了解如何验证VLAN的划分。(9)了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法;...

    一、 实验目的

    (1) 了解什么是带内管理;
    (2) 熟练掌握如何使用telnet方式管理交换机;
    (3) 熟练掌握如何为交换机设置web方式管理;
    (4) 熟练掌握如何进入交换机web管理方式;
    (5) 了解交换机web配置界面,并能进行部分操作。
    (6)了解VLAN原理;
    (7)熟练掌握二层交换机VLAN的划分方法;
    (8)了解如何验证VLAN的划分。
    (9)了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法;
    (10)了解交换机借口的trunk模式和untagged模式;
    (11)了解交换机的tagged端口和untagged端口的区别。

    二、 应用环境

    telnet方式和web方式都是交换机的带内管理方式。
    提供带内管理方式可以使连接在交换机中的某些设备具备管理交换机的功能。当交换机的配置出现变更,导致带内管理失效时,必须使用带外管理对交换机进行配置管理。
    Web方式,也叫做http方式,和telnet方式一样都可以使管理员做到在办公室中调试全校所有的交换机。
    Web方式比较简单,如果你不习惯CLI界面的调试,就可以采用web方式调试。主流的调试界面还是CLI界面,推荐大家学习CLI界面。
    划分对应的VLAN,能保证不同VLAN之间的数据互不干扰,也不影响各自的通信效率。

    三、实验设备

    (1)DCS二层交换机2台
    (2)PC机2台
    (3)Console线1根
    (4)直通网线2根

    四、实验拓扑

    image.png
    image.png

    五、实验要求


    按照拓扑图连接网络;

    • (1)按照拓扑图连接网络;
    • (2)PC和交换机的24口用网线相连;
    • (3)交换机的管理IP为192.168.1.100/24
    • (4)PC网卡的IP地址为192.168.1.101/24

    六、实验步骤

    实验拓扑一:

    第一步:交换机恢复出厂设置

    首先输入 enable 进入特权用户配置模式,然后输入 delete vlan.dat清除配置文件:

    delete vlan.dat
    erase startup-config
    reload
    

    交换机刚开始只有一个 vlan,它的标识是1,这个 vlan 用户是不能创建的,这是默认的 vlan,这个时候 flash 是没有 vlan.dat 这个文件的。
    image.png
    用这种方式进入特权模式进行恢复出厂设置有一个前提,就是必须先能进入特权模式,也就是说如果忘记密码了就不行了,那么有没有解决办法?


    有:输入

    flash_init
    del flash:config.txt
    del vlan.dat
    boot
    

    然后重新输入密码即可。

    第二步:给交换机的默认 vlan 设置 IP 地址即管理 IP。

    configure terminal
    int vlan 1
    ip address 192.168.1.100 255.255.255.0
    no shutdown
    exit
    exit
    

    configure terminal的意思是进入配置模式。
    no shutdown的意思是将交换机的接口状态变为 up 状态,如果是 down 的状态说明这个端口是关闭的。
    image.png
    验证配置:
    image.png

    第三步:为交换机设置授权 Telnet 用户

    configure terminal
    
    # 同时打开了 5 个虚拟终端,用户可以通过这 5 个虚拟终端登录到 Telnet
    line vty 0 4
    
    # 用户在通过 Telnet 登陆交换机的时候要进行本地认证
    login local
    
    # 授权的用户名密码
    username admin password admin
    
    # 设置的是 enable 的密码,用户从用户模式进入特权模式需要密码
    enable secret admin
    
    enable secret admin
    

    image.png
    使用secret 进行设置的密码是通过加密的,而通过 password 设置的密码是明文显示的。


    验证配置:show run
    image.png

    第四步:配置主机的IP地址,在本实验中要与交换机的IP地址在一个网段。

    • 单击“PC0”,在弹出的对话框中选择”desktop“标签
      单击“IP configuration”,
    • 配置PC0的IP地址为192.168.1.101,掩码为255.255.255.0
    • PC 机的 ip 地址和交换机的 ip 地址必须在同一个网段,不然实验无法进行。

    image.png


    验证配置:在PC主机的DOS命令行中使用IPCONFIG命令查看IP地址配置
    image.png

    第五步:验证主机与交换机是否连通。


    验证方法1:在交换机中ping主机
    image.png
    验证方法2:在主机DOS命令行中ping交换机,出现以下显示表示连通。
    image.png

    第六步:使用 Telnet 登录。

    image.png
    这里使用我们之前配置的用户名和密码进行登录,然后想进入特权模式,也需要密码,输入之前配置的面即可登录。


    实验拓扑二:

    image.png

    第一步:换机恢复出厂设置

    erase startup-config
    delete vlan.dat
    reload
    

    image.png

    第二步:给交换机设置IP地址即管理IP

    configure terminal
    int vlan 1
    ip address 192.168.1.100 255.255.255.0
    no shutdown
    exit
    exit
    

    image.png

    第三步:创建 vlan100 和 vlan200

    vlan 100
    exit
    vlan 200
    exit
    

    image.png
    验证配置:

    show vlan
    

    image.png
    同时我们也可以看到,所有的端口都属于 vlan1,所以接下来我们要分配端口给其他的 vlan。

    第四步:给vlan100和vlan200添加端口。

    //给vlan100加入端口号1-8
    int range f0/1-8
    switchport access vlan 100
    exit
    
    //给vlan200 加入端口9-16
    int range f0/9-16
    switchport access vlan 200
    exit
    

    image.png
    检验配置:
    image.png
    我们和之前的那个 vlan 做一个对比:
    image.png
    这说明我们分配端口成功了。

    第五步:验证实验。

    PC1位置 PC2位置 动作 结果
    1-8端口 PC1 ping 192.168.1.11 不通
    9-16端口 PC1 ping 192.168.1.11 不通
    17-24端口 PC1 ping 192.168.1.11
    1-8端口 1-8端口 PC1 ping PC2
    1-8端口 9-16端口 PC1 ping PC2 不通
    1-8端口 17-24端口 PC1 ping PC2 不通


    首先设置一下 PC 的 IP 地址:
    image.png
    image.png

    第一个

    image.png


    image.png
    结果是 ping 不通的;


    原因:
    如果在一台交换机上划分了 vlan 那么就相当于在物理上划分了相互之间不连接的交换机,我们这里有 3 个vlan:

    • vlan1
    • vlan100
    • vlan200

    他们之间在物理上不连通,我们 ping 的是 vlan1 的地址,而 PC1 在 vlan100 上,所以 ping 不通。

    第二个

    image.png
    我连接了 10 号口,再去 ping。
    image.png
    同样也是 ping 不通的,因为目前相当于从 vlan200 去连接 vlan1;这是不同的 vlan,之间是不能直接通信的,肯定不通。

    第三个

    把 PC1 连接到 17-24 口:


    image.png
    再去 ping


    image.png


    这个时候我们发现成功了!


    因为连接到 17-24 相当于连接到了 vlan1,接口,这样同一个交换机之间肯定可以通信。

    第四个

    PC1 连接 1-8,PC2也连接 1-8:


    image.png
    我这里用 PC1 连接了 1 号口,PC2 连接了 2 号口,然后用 PC1 ping PC2。
    image.png
    这里是可以 ping 通的,因为他们都在 vlan1 这个交换机。

    第五个

    PC1 连接 1-8 好口,而 PC2 连接 9-16 号口:


    image.png
    这里 PC1 连接了 1 号口,PC2 连接了 9 号口。


    再用 PC1 去 ping PC2:
    image.png


    结果是 ping 不通的,因为不属于同一个交换机,一个是 vlan1,一个是 vlan100。

    第六个

    一个连接 1,一个连接 20;
    image.png
    也是 ping 不通的,因为不属于同一个交换机,一个是 vlan1,一个是 vlan200;
    image.png
    如果想 ping 通可以加个路由器将这些 vlan 连接起来。实际组网的时候用 3 层交换机来实现通信。

    展开全文
  • vlan间的路由: 二层隔离,三层互通 PC配置: 略 交换机配置: Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 //创建vlan10 20 Switch(config-...

    vlan间的路由:
    二层隔离,三层互通

    在这里插入图片描述
    PC配置:

    交换机配置:

    Switch>enable 
    Switch#configure terminal 
    Switch(config)#vlan 10							
    Switch(config-vlan)#vlan 20							//创建vlan10 20
    Switch(config-vlan)#exit
    Switch(config)#interface fastEthernet 0/1			
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 10			//配置f01接为access口并加入vlan10
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/3			
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 10			//配置f03口为access口并加入vlan10
    Switch(config)#interface fastEthernet 0/2
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/4
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20			//配置f02口,f04口为access口并加入vlan20
    

    路由器配置:

    Router(config)#interface fastEthernet 0/0
    Router(config-if)#ip address 192.168.1.254 255.255.255.0
    Router(config-if)#no shu
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    Router(config)#interface fastEthernet 0/1
    Router(config-if)#ip address 192.168.2.254 255.255.255.0
    Router(config-if)#no shutdown 
    

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 思科模拟器跨交换机配置vlan

    千次阅读 2018-10-14 22:45:49
    pc2——switch1/1 (vlan2)pc3——switch1/2(vlan3) 然后交换机之间使用交叉线联通了他们的第三个接口   最后实现就是   在switch0里的vlan2 可以跟switch的vlan2可以通讯 在switch0...

    网络拓扑图搭建

     

    如图所示,

    pc0——-switch0/1vlan2

    pc1——-switch0/2vlan3

    pc2——switch1/1 vlan2
    pc3——switch1/2vlan3

    然后交换机之间使用交叉线联通了他们的第三个接口

     

    最后实现就是  

     

    在switch0里的vlan2 可以跟switch的vlan2可以通讯

    在switch0里的vlan3 可以跟switch的vlan3可以通讯

     

     

     

    1. 先拉交换机

    在拉出4台电脑

     

    然后用交叉线连接2个交换机的3口

     

     

    然后用直连线把电脑和交换机连接起来

     

    PC0连接1口

    PC1连接2口

     

    PC2连接1口

    PC3连接2口

     

     

    0X01配置IP地址

    双击PC0

    然后相同方法配置其他三台电脑

     

     

     

    0X02配置交换机地址

    双击switch0进入CLI

    输入enable进入特权模式

    只要出现#就说明已经进入特权模式

    然后输入configure进入配置模式

    然后在回车

     

    创建vlan 2

    重命名vlan2的名字

    退出局域网配置模式

    然后把f0/1更改为access模式分配给vlan 2

    然后exit退出

    创建vlan3并重命名

    然后退出局域网配置模式

    把f0/2配置为access模式并分配给vlan3

    然后退出

     

    然后把f0/3配置成trunk口

     

    配置另一台交换机

     

    同样打开CLI并进入特权模式

    进入配置模式

    配置vlan2并重命名

    退出局域网配置模式

    把f0/1更改为access模式并分配给vlan2

    退出

    配置vlan3并重命名

    退出局域网配置模式

    把f0/2更改为access模式并分配给vlan3

    然后退出

    把f0/3配置成trunk口

     

     

     

    0X03测试网络

     

    用PC0     ping   PC2

    展开全文
  • 根据下面的拓扑图进行配置,保证全网互通,VLAN间能互通 S1上配置VTY登录,限制3台主机,保存运行配置到启动配置文件。 S1(config)#line vty 0 2 S1(config-line)#exit S1(config)#exit S1#copy running-config ...
  • 思科模拟器配置DHCP的几种方式

    千次阅读 多人点赞 2019-10-29 16:44:51
    思科模拟器配置DHCP的几种方式 第一种:基于三层交换机+路由器的DHCP拓扑图 1.知识点梳理: 二层交换机: 配置vlan 端口划分进vlan 连向三层的端口配置trunk模式 三层交换机: 配置vlan vlan端口配置ip 连向路由...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 180
精华内容 72
关键字:

思科模拟器配置vlan