精华内容
下载资源
问答
  • 第四章 多层交换机的路由实现神州数码网络有限公司前言 多层交换设备能否进行正常的网段间寻址的路径转发关键在于是否正确的进行了网段边界的设定以及路由表是否正确生成本章我们将分析有关如何使多层交换设备实现多...
  • 多层交换机配置模式

    2017-11-09 13:48:00
    多层交换机作用: 为每个VLAN配置一个网关IP,但是使用的而是逻辑接口。 每个VLAN都对应一个逻辑接口--interface vlan x 多层交换机作为网关: 1.开启路由功能: ...

        多层交换机作用:

                       为每个VLAN配置一个网关IP,但是使用的而是逻辑接口。

                       每个VLAN都对应一个逻辑接口--interface vlan x

       

       多层交换机作为网关:

                         1.开启路由功能: 

                          SW1(config)#:ip routing

                         2.创建/确保设备有对应的vlan:

                          SW1(config)#: vlan 12

                          SW1(config-vlan)#: name xixi

                         3.为每个VLAN配置网关IP地址:

                          SW1(config)#:interface vlan 12

                          SW1(config-if)#: no shutdown

                          SW1(config-if)#:ip address 192.168.5.2 255.255.255.0

                        4.配置多层交换与几联交换的互联链路--trunk

                         SW1(config)#: interface fastethernet 0/1

                         SW1(config-if)#: no shutdown

                         SW1(config-if)#: switchport trunk encapsulation dot1q (开启模式设置)

                         SW1(config-if)#: switchport mode trunk  

                     


                注意:当交换机收到一个带有标签(vlan-ID)的数据时,如果本地交换机上没有vlan,

                     则直接将其丢弃。

                     交换网络中的数据流所经过的每一个交换机,必须拥有相同的vlan数据库。

                     (即确保全网交换机的vlan数据库相同)

          

            

          vlan标记协议:

                   ISL--思科私有协议:

                                 为数据库增加的标签,长度为30个字节。

                   802.1q--公有标准,主流协议:

                                 为数据库增加的标签,长度为4个字节。

                                其中12个bit用来表示vlan,所有vlan的空间大小为:0--4095

                                共4096个。

                                一同保留vlan 1 , 1002--1005

                  查看:SW1#:show interface fastethernet 0/1 switchport                      

                    

               本文转自夜流璃雨 51CTO博客,原文链接:http://blog.51cto.com/13399294/1974959,如需转载请自行联系原作者



    展开全文
  • 河南工业大学化学工业职业学院神州数码网络工程师认证培训实验教材系列之交换实验 实验十七 多层交换机静态路由实验 一实验目的 1理解三层交换机进行路由的原理和具体实现拓扑 2 理解三层交换机静态路由的配置方法 ...
  • 实验二十二多层交换机静态路由实验 实验目的 理解三层交换机进行路由的原理和具体实现拓扑 理解三层交换机静态路由的配置方法 应用环境 当两台三层交换机相连时为了保证每台交换机上所连接的网段可以和另一台交换机...
  • 多层交换机的性能和连通排错
  • 多层交换机静态路由实验

    千次阅读 2018-04-10 21:36:46
    多层交换机静态路由实验一、 实验目的1、 理解三层交换机进行路由的原理和具体实现拓扑;2、 理解三层交换机静态路由的配置方法;二、 应用环境当两台三层交换机级联时,为了保证每台交换机上所连接的网段可以和...

    多层交换机静态路由实验

    一、       实验目的

    1  理解三层交换机进行路由的原理和具体实现拓扑;

    2、  理解三层交换机静态路由的配置方法;

    二、       应用环境

    当两台三层交换机级联时,为了保证每台交换机上所连接的网段可以和另一台交换机上连接的网段互相通信,最简单的方法就是设置静态路由。

    三、       实验设备

    1  DCRS-7604(或6804)交换机1台

    2  DCRS-5526S交换机1台

    3  PC机2-4台

    4  Console线1-2根

    5  直通网线2-4根

    四、       实验拓扑

     

    五、       实验要求

    1  在交换机A和交换机B上分别划分基于端口的VLAN:

    交换机

    VLAN 

    端口成员 

    交换机A

    10

    1~8

    20

    9~16

    100

    24

    交换机B

    30

    1~8

    40

    9~16

    101

    24

    2  交换机A和B通过的24口级联。

    3  配置交换机A和B各VLAN虚拟接口的IP地址分别如下表所示:

    VLAN10

    VLAN20

    VLAN30

    VLAN40

    VLAN100

    VLAN101

    192.168.10.1

    192.168.20.1

    192.168.30.1

    192.168.40.1

    192.168.100.1

    192.168.100.2

    4  PC1-PC4的网络设置为:

    设备

    IP地址

    gateway

    Mask

    PC1 

    192.168.10.101

    192.168.10.1

    255.255.255.0 

    PC2 

    192.168.20.101

    192.168.20.1

    255.255.255.0 

    PC3

    192.168.30.101

    192.168.30.1

    255.255.255.0 

    PC4 

    192.168.40.101 

    192.168.40.1

    255.255.255.0 

    5  验证:

    l         没有静态路由之前:

    PC1与PC2,PC3与PC4可以互通。

    PC1、PC2与PC3、PC4不通。

    l         配置静态路由之后:

    四台PC之间都可以互通。

    l         若实验结果和理论相符,则本实验完成。

    六、       实验步骤

    第一步:交换机全部恢复出厂设置,配置交换机的VLAN信息

    交换机A:

    DCRS-7604#conf

    DCRS-7604(Config)#vlan 10

    DCRS-7604(Config-Vlan10)#switchport interface ethernet 1/1-8

    Set the port Ethernet1/1 access vlan 10 successfully

    Set the port Ethernet1/2 access vlan 10 successfully

    Set the port Ethernet1/3 access vlan 10 successfully

    Set the port Ethernet1/4 access vlan 10 successfully

    Set the port Ethernet1/5 access vlan 10 successfully

    Set the port Ethernet1/6 access vlan 10 successfully

    Set the port Ethernet1/7 access vlan 10 successfully

    Set the port Ethernet1/8 access vlan 10 successfully

    DCRS-7604(Config-Vlan10)#exit

    DCRS-7604(Config)#vlan 20

    DCRS-7604(Config-Vlan20)#switchport interface ethernet 1/9-16

    Set the port Ethernet1/9 access vlan 20 successfully

    Set the port Ethernet1/10 access vlan 20 successfully

    Set the port Ethernet1/11 access vlan 20 successfully

    Set the port Ethernet1/12 access vlan 20 successfully

    Set the port Ethernet1/13 access vlan 20 successfully

    Set the port Ethernet1/14 access vlan 20 successfully

    Set the port Ethernet1/15 access vlan 20 successfully

    Set the port Ethernet1/16 access vlan 20 successfully

    DCRS-7604(Config-Vlan20)#exit

    DCRS-7604(Config)#vlan 100

    DCRS-7604(Config-Vlan100)#switchport interface ethernet 1/24

    Set the port Ethernet1/24 access vlan 100 successfully

    DCRS-7604(Config-Vlan100)#exit

    DCRS-7604(Config)#

    验证配置:

    DCRS-7604#show vlan

    VLAN Name         Type       Media     Ports

    ---------------------------------------------------------------------------

    1    default      Static     ENET      Ethernet1/17        Ethernet1/18

                                           Ethernet1/19        Ethernet1/20

                                           Ethernet1/21        Ethernet1/22

                                           Ethernet1/23        Ethernet1/25

                                           Ethernet1/26        Ethernet1/27

                                           Ethernet1/28

    10   VLAN0010     Static     ENET      Ethernet1/1         Ethernet1/2

                                           Ethernet1/3         Ethernet1/4

                                           Ethernet1/5         Ethernet1/6

                                           Ethernet1/7         Ethernet1/8

    20   VLAN0020     Static     ENET      Ethernet1/9         Ethernet1/10

                                           Ethernet1/11        Ethernet1/12

                                           Ethernet1/13        Ethernet1/14

                                           Ethernet1/15        Ethernet1/16

    100  VLAN0100     Static     ENET      Ethernet1/24

    DCRS-7604#

     

    交换机B:

    DCRS-5526S(Config)#vlan 30                         

    DCRS-5526S(Config-Vlan30)#switchport interface ethernet 0/0/1-8                                                              

    Set the port Ethernet0/0/1 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/2 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/3 access vlan 30 successfully                                                      

    Set the port Ethernet0/0/4 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/5 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/6 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/7 access vlan 30 successfully                                                     

    Set the port Ethernet0/0/8 access vlan 30 successfully                         

    DCRS-5526S(Config-Vlan30)#exit

    DCRS-5526S(Config)#vlan 40

    DCRS-5526S(Config-Vlan40)#switchport interface ethernet 0/0/9-16

    Set the port Ethernet0/0/9 access vlan 40 successfully

    Set the port Ethernet0/0/10 access vlan 40 successfully

    Set the port Ethernet0/0/11 access vlan 40 successfully

    Set the port Ethernet0/0/12 access vlan 40 successfully

    Set the port Ethernet0/0/13 access vlan 40 successfully

    Set the port Ethernet0/0/14 access vlan 40 successfully

    Set the port Ethernet0/0/15 access vlan 40 successfully

    Set the port Ethernet0/0/16 access vlan 40 successfully

    DCRS-5526S(Config-Vlan40)#exit

    DCRS-5526S(Config)#vlan 101

    DCRS-5526S(Config-Vlan101)#switchport interface ethernet 0/0/24

    Set the port Ethernet0/0/24 access vlan 101 successfully

    DCRS-5526S(Config-Vlan101)#exit

    DCRS-5526S(Config)#

    验证配置:

    DCRS-5526S#show vlan

    VLAN Name         Type       Media     Ports

    ----------------------------------- ---------------------------------------

    1    default      Static     ENET      Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23

    30   VLAN0030     Static     ENET      Ethernet0/0/1       Ethernet0/0/2

                                           Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

    40   VLAN0040     Static     ENET      Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

    101  VLAN0101     Static     ENET      Ethernet0/0/24

    DCRS-5526S#

     

    第二步:配置交换机各vlan虚接口的IP地址

    交换机A:

    DCRS-7604(Config)#int vlan 10                            

    DCRS-7604(Config-If-Vlan10)#ip address 192.168.10.1 255.255.255.0

    DCRS-7604(Config-If-Vlan10)#no shut

    DCRS-7604(Config-If-Vlan10)#exit

    DCRS-7604(Config)#int vlan 20

    DCRS-7604(Config-If-Vlan20)#ip address 192.168.20.1 255.255.255.0

    DCRS-7604(Config-If-Vlan20)#no shut

    DCRS-7604(Config-If-Vlan20)#exit

    DCRS-7604(Config)#int vlan 100

    DCRS-7604(Config-If-Vlan100)#ip address 192.168.100.1 255.255.255.0

    DCRS-7604(Config-If-Vlan100)#no shut

    DCRS-7604(Config-If-Vlan100)#

    DCRS-7604(Config-If-Vlan100)#exit

    DCRS-7604(Config)#

     

    交换机B:

    DCRS-5526S(Config)#int vlan 30

    DCRS-5526S(Config-If-Vlan30)#ip address 192.168.30.1 255.255.255.0

    DCRS-5526S(Config-If-Vlan30)#no shut

    DCRS-5526S(Config-If-Vlan30)#exit

    DCRS-5526S(Config)#interface vlan 40

    DCRS-5526S(Config-If-Vlan40)#ip address 192.168.40.1 255.255.255.0

    DCRS-5526S(Config-If-Vlan40)#exit

    DCRS-5526S(Config)#int vlan 101

    DCRS-5526S(Config-If-Vlan101)#ip address 192.168.100.2 255.255.255.0

    DCRS-5526S(Config-If-Vlan101)#exit

    DCRS-5526S(Config)#

     

    第三步:配置各PC的IP地址,注意配置网关

     

    设备

    IP地址

    gateway

    Mask

    PC1 

    192.168.10.101

    192.168.10.1

    255.255.255.0 

    PC2 

    192.168.20.101

    192.168.20.1

    255.255.255.0 

    PC3

    192.168.30.101

    192.168.30.1

    255.255.255.0 

    PC4 

    192.168.40.101 

    192.168.40.1

    255.255.255.0 

     

    第四步:验证PC之间是否连通?

    PC

    端口

    PC

    端口

    结果

    原因

    PC1

    A:1/1

    PC2

    A:1/9

     

    PC1

    A:1/1

    Vlan 100

    A:1/24

     

    PC1

    A:1/1

    Vlan 101

    B:0/0/24

    不通

     

    PC1

    A:1/1

    PC3

    B:0/0/1

    不通

     

     

    查看路由表,进一步分析上一步的现象原因。

    交换机A:

    DCRS-7604#show ip route

    Total route items is 3, the matched route items is 3

    Codes: C - connected, S - static, R - RIP derived, O - OSPF derived

           A - OSPF ASE, B - BGP derived, D - DVMRP derived

    Destination           Mask         Nexthop        Interface    Preference

    C  192.168.10.0     255.255.255.0    0.0.0.0        Vlan10            0

    C  192.168.20.0     255.255.255.0    0.0.0.0        Vlan20            0

    C  192.168.100.0    255.255.255.0    0.0.0.0        Vlan100           0

    DCRS-7604#

    (C代表直连的网段)

     

    交换机B:

    DCRS-5526S#show ip route

    Total route items is 3, the matched route items is 3

    Codes: C - connected, S - static, R - RIP derived, O - OSPF derived

           A - OSPF ASE, B - BGP derived, D - DVMRP derived

    Destination           Mask         Nexthop        Interface    Preference

    C  192.168.30.0     255.255.255.0    0.0.0.0          Vlan30          0

    C  192.168.40.0     255.255.255.0    0.0.0.0          Vlan40          0

    C  192.168.100.0    255.255.255.0    0.0.0.0          Vlan101         0

    DCRS-5526S#

     

    第五步:配置静态路由

    交换机A:

    DCRS-7604(Config)#ip route 192.168.30.0 255.255.255.0 192.168.100.2

    DCRS-7604(Config)#ip route 192.168.40.0 255.255.255.0 192.168.100.2

    验证配置:

    DCRS-7604#show ip route

    Total route items is 5, the matched route items is 5

    Codes: C - connected, S - static, R - RIP derived, O - OSPF derived

           A - OSPF ASE, B - BGP derived, D - DVMRP derived

    Destination            Mask         Nexthop      Interface       Preference

    C  192.168.10.0     255.255.255.0    0.0.0.0        Vlan10            0

    C  192.168.20.0     255.255.255.0    0.0.0.0        Vlan20            0

    S  192.168.30.0     255.255.255.0    192.168.100.2  Vlan100           1

    S  192.168.40.0     255.255.255.0    192.168.100.2  Vlan100           1

    C  192.168.100.0    255.255.255.0    0.0.0.0        Vlan100           0

    DCRS-7604#

    (S代表静态配置的网段)

     

    交换机B:

    DCRS-5526S(Config)#ip route 192.168.10.0 255.255.255.0 192.168.100.1

    DCRS-5526S(Config)#ip route 192.168.20.0 255.255.255.0 192.168.100.1

    验证配置:

    DCRS-5526S#show ip route

    Total route items is 5, the matched route items is 5

    Codes: C - connected, S - static, R - RIP derived, O - OSPF derived

           A - OSPF ASE, B - BGP derived, D - DVMRP derived

    Destination           Mask       Nexthop     Interface      Preference

    S  192.168.10.0     255.255.255.0    192.168.100.1    Vlan101         1

    S  192.168.20.0     255.255.255.0    192.168.100.1    Vlan101         1

    C  192.168.30.0     255.255.255.0    0.0.0.0          Vlan30          0

    C  192.168.40.0     255.255.255.0    0.0.0.0          Vlan40          0

    C  192.168.100.0    255.255.255.0    0.0.0.0          Vlan101         0

    DCRS-5526S#

     

    第六步:验证PC之间是否连通?

    PC

    端口

    PC

    端口

    结果

    原因

    PC1

    A:1/1

    PC2

    A:1/9

     

    PC1

    A:1/1

    Vlan 100

    A:1/24

     

    PC1

    A:1/1

    Vlan 101

    B:0/0/24

     

    PC1

    A:1/1

    PC3

    B:0/0/1

     

     

    七、       注意事项和排错

    1  PC机一定要配置正确的网关,否则不能正常通信;

    2  两台交换机级联的端口可以在同一vlan,也可以在不同vlan。

    八、       配置序列

    九、       共同思考

    1  如果把交换机B上的vlan30改成vlan10,请问两台交换机上的vlan10是同一个VLAN么?

    2  第四步中,PC1 ping vlan101以及PC1 ping PC3都不通,其原因各是什么?

    十、       课后练习

    1  在交换机A和交换机B上分别划分基于端口的VLAN:

    交换机

    VLAN 

    端口成员 

    交换机A

    10

    2~8

    20

    9~16

    100

    1

    交换机B

    10

    2~8

    40

    9~16

    100

    1

    2  交换机A和B通过的24口级联。

    3  配置交换机A和B各VLAN虚拟接口的IP地址分别如下表所示:

    VLAN10_A

    VLAN20

    VLAN10_B

    VLAN40

    VLAN100_A

    VLAN10_B

    10.1.10.1

    10.1.20.1

    10.1.30.1

    10.1..40.1

    10.1.100.1

    10.1.100.2

    4  PC1-PC4的网络设置为:

    设备

    IP地址

    gateway

    Mask

    PC1 

    10.1.10.2

    10.1.10.1

    255.255.255.0 

    PC2 

    10.1.20.2

    110.1.20.1

    255.255.255.0 

    PC3

    10.1.30.2

    10.1.30.1

    255.255.255.0 

    PC4 

    10.1.40.2 

    10.140.1

    255.255.255.0 

    5  要求PC之间都可以通信

    十一、   相关配置命令详解

    ip route

    命令:ip route <ip_address> <mask> <gateway> [<preference>]

          no ip route <ip_address> <mask> <gateway> [<preference>]

    功能:配置静态路由;本命令的no操作为删除静态路由。

    参数:<ip_address><mask>分别为目的IP地址和子网掩码,点分十进制格式; <gateway>为下一跳的IP地址,点分十进制格式;<preference>为路由优先级,取值范围为1~255,preference的值越小优先级越高。

    缺省情况:DCRS-7604三层交换机的静态路由缺省优先级为1。

    命令模式:全局配置模式

    使用指南:在配置静态路由的下一跳时,可采用指定路由数据包发送下一跳IP地址方式。

    DCRS-7604三层交换机的各种路由类型缺省的preference为:

    路由类型

    Preference值

    直连路由

    0

    静态路由

    1

    OSPF

    110

    RIP

    120

    IBEP

    200

    EBGP

    20

    在不改变各种路由优先级值的情况下,直连路由优先级最高,依次是静态路由、EBGP、OSPF、RIP、IBGP。

    举例:

    例1.添加一条静态路由。

    Switch(config)#ip route 1.1.1.0 255.255.255.0 2.1.1.1

    例2.添加缺省路由。

    Switch(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.1

    show ip route

    命令:show ip route [dest <destination>] [mask <destMask>] [nextHop <nextHopValue>] [protocol {connected | static | rip| ospf | ospf_ase | bgp | dvmrp}] [<vlan-id>] [preference <pref>] [count]

    功能:显示路由表。

    参数:<destination>为目标网络地址;<destMask>为目标网络的掩码;<nextHopValue>为下一跳IP地址;connected为直连路由;static为静态路由;rip 为RIP路由;ospf为OSPF路由;ospf_ase 为OSPF引入的路由;bgp 为BGP路由;dvmrp 为DVMRP路由;<vlan-id为Vlan标识符;<pref为路由优先级,取值范围为0~255;count为显示IP路由表项数量信息。

    命令模式:特权用户配置模式

    使用指南:显示核心路由表的内容,包括:路由类型、目的网络、掩码、下一跳地址、接口等。

     

    展开全文
  • Cisco 多层交换机配置层3接口!多谢大家支持!
  • VLAN间路由: -多层交换机 1、配置网关IP interface vlan 10 //配置 vlan 10 的网关IP; no shutdown ip address 192.168.10.254 255.255.255.0 ...

    VLAN间路由:

      -多层交换机

       1、配置网关IP

                      interface vlan 10   //配置 vlan 10 的网关IP;

                     no shutdown 

                     ip address 192.168.10.254       255.255.255.0

                 

                       interface vlan 20 

                     no shutdown 

                     ip address 192.168.20.254        255.255.255.0

                 

                        interface vlan 30 

                     no shutdown 

                     ip address 192.168.30.254         255.255.255.0

     

    网关的概念就是接口

     

     2、启用路由功能

            GW(config)# ip routing 

            

     3、配置多层交换机与普通交换机的级联链路 

                GW(config)#      interface    fas0/3 

              GW(config-if)#    switchport   trunk   encap   dot1q

              GW(config-if)#     switchport   mode   trunk 

              

              SW1(config)#interface fas0/3 

              SW1(config-if)#switchport mode trunk 

     

        4、验证与测试

               GW# show ip interface brief

                  GW# show ip route 

                  GW# show interface trunk 

     

    注意:

        任何一个 VLAN 都对应一个 SVI(交换虚拟端口);

           该VLAN中的所有的成员主机的网关IP地址都为该 SVI 

           口配置的 IP 地址;

     

    SVI:switch virtual interface ;

    转载于:https://www.cnblogs.com/pangcw/p/8379441.html

    展开全文
  • 多层交换机VLAN的划分和VLAN间路由
  • - 国内第一医疗信息化网站 ,业内最强大和中立的互联网共享交流平台 RG-S5750 系列安全智能的万兆多层交换机 产品介绍 福建星网锐捷网络有限公司 - 国内第一医疗信息化网站 ,业内最强大和中立的互联网共享交流平台 目...
  • 多层交换机VLAN的划分和VLAN间路由

    千次阅读 2018-04-10 21:35:31
    多层交换机VLAN的划分和VLAN间路由一、 实验目的1、 了解VLAN原理;2、 学会使用各种多层交换设备进行VLAN的划分;3、 理解VLAN之间路由的原理和实现方法;二、 应用环境软件实验室的IP地址段是192.168.10.0/24...

    多层交换机VLAN的划分和VLAN间路由

    一、       实验目的

    1、  了解VLAN原理;

    2、  学会使用各种多层交换设备进行VLAN的划分;

    3、  理解VLAN之间路由的原理和实现方法;

    二、       应用环境

    软件实验室的IP地址段是192.168.10.0/24,多媒体实验室的IP地址段是192.168.20.0/24,为了保证它们之间的数据互不干扰,也不影响各自的通信效率,我们划分了VLAN,使两个实验室属于不同的VLAN

    两个实验室有时候也需要相互通信,此时就要利用三层交换机划分VLAN

    三、       实验设备

    1  DCRS-7604(或6804或5526S)交换机1台

    2  PC机2台

    3  Console线1根

    4  直通网线若干

    四、       实验拓扑

     

    使用一台交换机和两台PC机,还将其中PC2作为控制台终端,使用Console口配置方式;使用两根网线分别将PC1和PC2连接到交换机的RJ-45接口上。

    五、       实验要求

    在交换机上划分两个基于端口的VLAN:VLAN100,VLAN200。

    VLAN 

    端口成员 

    100

    1/1~1/12

    200

    1/13~1/24

    使得VLAN100的成员能够互相访问,VLAN200的成员能够互相访问;VLAN100和VLAN200成员之间不能互相访问。

    PC1和PC2的网络设置为:

    设备

    端口

    IP 1

    网关1

    IP 2

    网关2

    Mask

    交换机A 

     

    192.168.1.1

    192.168.1.1

    255.255.255.0 

    Vlan100

     

    192.168.10.1

    255.255.255.0

    Vlan200

     

    192.160.20.1

    255.255.255.0

    PC1 

    1~12

    192.168.1.101

    192.168.10.101

    192.168.10.1

    255.255.255.0 

    PC2 

    13~24

    192.168.1.102

    192.168.20.101

    192.168.20.1

    255.255.255.0 

    各设备的IP地址首先按照IP1配置,使用pc1 ping pc2,应该不通;

    再按照IP2配置地址,并在交换机上配置vlan接口IP地址,使用pc1 ping pc2,则通,该通信属于vlan间通信,要经过三层设备的路由。

    若实验结果和理论相符,则本实验完成。

    六、       实验步骤

    第一步:交换机恢复出厂设置

    switch#set default

    switch#write 

    switch#reload 

    第二步:给交换机设置IP地址即管理IP。

    switch#config  

    switch(Config)#interface vlan 1        

    switch(Config-If-Vlan1)#ip address 192.168.1.1 255.255.255.0                                                                

    switch(Config-If-Vlan1)#no shutdown    

    switch(Config-If-Vlan1)#exit      

    switch(Config)#exit               

    第三步:创建vlan100和vlan200。

    switch(Config)#

    switch(Config)#vlan 100

    switch(Config-Vlan100)#exit

    switch(Config)#vlan 200

    switch(Config-Vlan200)#exit

    switch(Config)#

    验证配置:

    switch#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet1/1         Ethernet1/2

                                           Ethernet1/3         Ethernet1/4

                                           Ethernet1/5         Ethernet1/6

                                           Ethernet1/7         Ethernet1/8

                                           Ethernet1/9         Ethernet1/10

                                           Ethernet1/11        Ethernet1/12

                                           Ethernet1/13        Ethernet1/14

                                           Ethernet1/15        Ethernet1/16

                                           Ethernet1/17        Ethernet1/18

                                           Ethernet1/19        Ethernet1/20

                                           Ethernet1/21        Ethernet1/22

                                           Ethernet1/23        Ethernet1/24

                                           Ethernet1/25        Ethernet1/26

                                           Ethernet1/27        Ethernet1/28

    100  VLAN0100     Static     ENET

    200  VLAN0200     Static     ENET

    第四步:给vlan100和vlan200添加端口。

    switch(Config)#vlan 100             !进入vlan 100

    switch(Config-Vlan100)#switchport interface ethernet 1/1-12

    Set the port Ethernet1/1 access vlan 100 successfully

    Set the port Ethernet1/2 access vlan 100 successfully

    Set the port Ethernet1/3 access vlan 100 successfully

    Set the port Ethernet1/4 access vlan 100 successfully

    Set the port Ethernet1/5 access vlan 100 successfully

    Set the port Ethernet1/6 access vlan 100 successfully

    Set the port Ethernet1/7 access vlan 100 successfully

    Set the port Ethernet1/8 access vlan 100 successfully

    Set the port Ethernet1/9 access vlan 100 successfully

    Set the port Ethernet1/10 access vlan 100 successfully

    Set the port Ethernet1/11 access vlan 100 successfully

    Set the port Ethernet1/12 access vlan 100 successfully

    switch(Config-Vlan100)#exit

    switch(Config)#vlan 200              !进入vlan 200

    switch(Config-Vlan200)#switchport interface ethernet 1/13-24

    Set the port Ethernet1/13 access vlan 200 successfully

    Set the port Ethernet1/14 access vlan 200 successfully

    Set the port Ethernet1/15 access vlan 200 successfully

    Set the port Ethernet1/16 access vlan 200 successfully

    Set the port Ethernet1/17 access vlan 200 successfully

    Set the port Ethernet1/18 access vlan 200 successfully

    Set the port Ethernet1/19 access vlan 200 successfully

    Set the port Ethernet1/20 access vlan 200 successfully

    Set the port Ethernet1/21 access vlan 200 successfully

    Set the port Ethernet1/22 access vlan 200 successfully

    Set the port Ethernet1/23 access vlan 200 successfully

    Set the port Ethernet1/24 access vlan 200 successfully

    switch(Config-Vlan200)#exit

    验证配置:

    switch#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet1/25        Ethernet1/26

                                           Ethernet1/27        Ethernet1/28

    100  VLAN0100     Static     ENET      Ethernet1/1         Ethernet1/2

                                           Ethernet1/3         Ethernet1/4

                                           Ethernet1/5         Ethernet1/6

                                           Ethernet1/7         Ethernet1/8

                                           Ethernet1/9         Ethernet1/10

                                           Ethernet1/11        Ethernet1/12

    200  VLAN0200     Static     ENET      Ethernet1/13        Ethernet1/14

                                           Ethernet1/15        Ethernet1/16

                                           Ethernet1/17        Ethernet1/18

                                           Ethernet1/19        Ethernet1/20

                                           Ethernet1/21        Ethernet1/22

                                           Ethernet1/23        Ethernet1/24

    switch#

     

    第五步:验证实验。

    配置IP1的地址

        PC1位置

    PC2位置

    动作

    结果

    1/1-1/12端口

    1/13-1/24端口

    PC1 ping PC2

    不通

     

    第六步:添加vlan地址。

    switch(Config)#interface vlan 100

    switch(Config-If-Vlan100)#%Feb 13 15:47:45 2006 %LINK-5-CHANGED: Interface Vlan100, changed state to UP%Feb 13 15:47:45 2006 %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to UP

    switch(Config-If-Vlan100)#

    switch(Config-If-Vlan100)#ip address 192.168.10.1 255.255.255.0

    switch(Config-If-Vlan100)#no shut

    switch(Config-If-Vlan100)#exit

    switch(Config)#interface vlan 200

    switch(Config-If-Vlan200)#%Feb 13 15:48:06 2006 %LINK-5-CHANGED: Interface Vlan200, changed state to UPswitch(Config-If-Vlan200)#ip address 192.168.20.1 255.255.255.0

    switch(Config-If-Vlan200)#no shut

    switch(Config-If-Vlan200)#exit

    switch(Config)#

    验证配置:

    switch#show ip route

    Total route items is 3, the matched route items is 3

    Codes: C - connected, S - static, R - RIP derived, O - OSPF derived

           A - OSPF ASE, B - BGP derived, D - DVMRP derived

    Destination           Mask           Nexthop       Interface      Preference

     

    C  192.168.1.0      255.255.255.0    0.0.0.0        Vlan1             0

    C  192.168.10.0     255.255.255.0    0.0.0.0        Vlan100           0

    C  192.168.20.0     255.255.255.0    0.0.0.0        Vlan200           0

    switch#

     

    第七步:验证实验。

    配置IP2的地址

        PC1位置

    PC2位置

    动作

    结果

    1/1-1/12端口

    1/13-1/24端口

    PC1 ping PC2

     

    七、       注意事项和排错

    和二层交换机不同,三层交换机可以在多个VLAN接口上配置IP地址。

    八、       配置序列

    switch#show run              

    Current configuration:                     

    !

       hostname switch                 

    !

    Vlan 1     

       vlan 1        

    !

    Vlan 100       

       vlan 100          

    !

    Vlan 200       

       vlan 200          

    !

    Interface Ethernet1/1                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/2                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/3                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/4                    

       switchport access vlan 100                             

    !

    Interface Ethernet1/5                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/6                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/7                     

       switchport access vlan 100                            

    !

    Interface Ethernet1/8                    

       switchport access vlan 100                            

    !

    Interface Ethernet1/9                    

       switchport access vlan 100                             

    !

    Interface Ethernet1/10                     

       switchport access vlan 100                            

    !

    Interface Ethernet1/11                     

       switchport access vlan 100                            

    !

    Interface Ethernet1/12                     

       switchport access vlan 100                            

    !

    Interface Ethernet1/13                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/14                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/15                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/16                     

       switchport access vlan 200                             

    !

    Interface Ethernet1/17                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/18                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/19                      

       switchport access vlan 200                            

    !

    Interface Ethernet1/20                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/21                     

       switchport access vlan 200                             

    !

    Interface Ethernet1/22                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/23                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/24                     

       switchport access vlan 200                            

    !

    Interface Ethernet1/25                     

    !

    Interface Ethernet1/26                     

    !

    Interface Ethernet1/27

    !

    Interface Ethernet1/28

    !

    !

    interface Vlan1

       interface vlan 1

       ip address 192.168.1.1 255.255.255.0

    !

    interface Vlan100

       interface vlan 100

       ip address 192.168.10.1 255.255.255.0

    !

    interface Vlan200

       interface vlan 200

       ip address 192.168.20.1 255.255.255.0

    !

    Interface Ethernet0

    switch#

    九、       共同思考

    如果第二次配置IP地址的时候,没有给PC机配置网关,请问还会通信么?为什么?。

    十、       课后练习

    请给交换机划分多个vlan,验证vlan实验。

    十一、   相关配置命令详解

    vlan

    命令:vlan <vlan-id>

             no vlan <vlan-id>

    功能:创建VLAN并且进入VLAN配置模式,在VLAN模式中,用户可以配置VLAN名称和为该VLAN分配交换机端口;本命令的no操作为删除指定的VLAN。

    参数:<vlan-id>为要创建/删除的VLAN的VID,取值范围为1~4094。

    命令模式:全局配置模式

    缺省情况:交换机缺省只有VLAN1。

    使用指南:VLAN1为交换机的缺省VLAN,用户不能配置和删除VLAN1。允许配置VLAN的总共数量为4094个。另需要提醒的是不能使用本命令删除通过GVRP学习到的动态VLAN。

    举例:创建VLAN100,并且进入VLAN100的配置模式。

    DCRS-7604 (Config)#vlan 100

    DCRS-7604 (Config-Vlan100)#

    name

    命令:name <vlan-name>

             no name

    功能:为VLAN指定名称,VLAN的名称是对该VLAN一个描述性字符串;本命令的no操作为删除VLAN的名称。

    参数:<vlan-name>为指定的vlan名称字符串。

    命令模式:VLAN配置模式

    缺省情况:VLAN缺省名称为vlanXXX,其中XXX为VID。

    使用指南:交换机提供为不同的VLAN指定名称的功能,有助于用户记忆VLAN,方便管理。

    举例:为VLAN100指定名称为TestVlan。

    DCRS-7604 (Config-Vlan100)#name TestVlan

     

    switchport access vlan

    命令:switchport access vlan <vlan-id>

    no switchport access vlan

    功能:将当前Access端口加入到指定VLAN;本命令no操作为将当前端口从VLAN里删除。

    参数:<vlan-id>为当前端口要加入的vlan VID,取值范围为1~4094。

    命令模式:接口配置模式

    缺省情况:所有端口默认属于VLAN1。

    使用指南:只有属于Access mode的端口才能加入到指定的VLAN中,并且Access端口同时只能加入到一个VLAN里去。

    举例:设置某Access端口加入VLAN100。

    DCRS-7604 (Config)#interface ethernet 1/8

    DCRS-7604 (Config-ethernet1/8)#switchport mode access

    DCRS-7604 (Config-ethernet1/8)#switchport access vlan 100

    DCRS-7604 (Config-ethernet1/8)#exit

    switchport interface

    命令:switchport interface <interface-list>

    no switchport interface <interface-list>

    功能:给VLAN分配以太网端口的命令;本命令的no操作为删除指定VLAN内的一个或一组端口。

    参数:<interface-list> 要添加或者删除的端口的列表,支持”;” ”-” ,如:ethernet 1/1;2;5 或ethernet 1/1-6;8。

    命令模式:VLAN配置模式

    缺省情况:新建立的VLAN缺省不包含任何端口。

    使用指南:Access端口为普通端口,可以加入VLAN,但同时只允许加入一个VLAN。

    举例:为VLAN100分配百兆以太网端口1,3,4-7,8。

    DCRS-7604 (Config-Vlan100)#switchport interface ethernet 1/1;3;4-7;8

    switchport mode

    命令:switchport mode {trunk|access}

    功能:设置交换机的端口为access模式或者trunk模式。

    参数:trunk表示端口允许通过多个VLAN的流量;access为端口只能属于一个VLAN。

    命令模式:接口配置模式

    缺省情况:端口缺省为Access模式。

    使用指南:工作在trunk mode下的端口称为Trunk端口,Trunk端口可以通过多个VLAN的流量,通过Trunk端口之间的互联,可以实现不同交换机上的相同VLAN的互通;工作在access mode下的端口称为Access端口,Access端口可以分配给一个VLAN,并且同时只能分配给一个VLAN。

     

    举例:将端口5设置为trunk模式,端口8设置为access模式。

    DCRS-7604 (Config)#interface ethernet 1/5

    DCRS-7604 (Config-ethernet1/5)#switchport mode trunk

    DCRS-7604 (Config-ethernet1/5)#exit

    DCRS-7604 (Config)#interface ethernet 1/8

    DCRS-7604 (Config-ethernet1/8)#switchport mode access

    DCRS-7604 (Config-ethernet1/8)#exit

    switchport trunk allowed vlan

    命令:switchport trunk allowed vlan {<vlan-list>|all}

    no switchport trunk allowed vlan

    功能:设置Trunk端口允许通过VLAN;本命令的no操作为恢复缺省情况。

    参数:<vlan-list>为允许在该Trunk端口上通过的VLAN列表;all 关键字表示允许该Trunk端口通过所有VLAN的流量。

    命令模式:接口配置模式

    缺省情况:Trunk端口缺省允许通过所有VLAN。

    使用指南:用户可以通过本命令设置哪些VLAN的流量通过Trunk端口,没有包含的VLAN流量则被禁止。

    举例:设置Trunk端口允许通过VLAN1,3,5-20的流量。

    DCRS-7604 (Config)#interface ethernet 1/5

    DCRS-7604 (Config-ethernet1/5)#switchport mode trunk

    DCRS-7604 (Config-ethernet1/5)#switchport trunk allowed vlan 1;3;5-20

    DCRS-7604 (Config-ethernet1/5)#exit

    switchport trunk native vlan

    命令:switchport trunk native vlan <vlan-id>

    no switchport trunk native vlan

    功能:设置Trunk端口的PVID;本命令的no操作为恢复缺省值。

    参数:<vlan-id>为Trunk端口的PVID。

    命令模式:接口配置模式

    缺省情况:Trunk端口默认的PVID为1。

    使用指南:在802.1Q中定义了PVID这个概念。Trunk端口的PVID的作用是当一个untagged的帧进入Trunk端口,端口会对这个untagged帧打上带有本命令设置的native PVID的tag标记,用于VLAN的转发。

    举例:设置某Trunk端口的native vlan为100。

    DCRS-7604 (Config)#interface ethernet 1/5

    DCRS-7604 (Config-ethernet1/5)#switchport mode trunk

    DCRS-7604 (Config-ethernet1/5)#switchport trunk native vlan 100

    DCRS-7604 (Config-ethernet1/5)#exit

    vlan ingress disable

    命令:vlan ingress disable

          no vlan ingress disable

    功能:关闭端口的VLAN入口规则;本命令的no操作为打开入口准则。

    命令模式:接口配置模式

    缺省情况:系统缺省打开端口的VLAN入口准则。

    使用指南:当打开端口的VLAN入口规则,系统在接收数据时会检查源端口是否是该VLAN的成员端口,如果是则接受数据并转发到目的端口,否则丢弃该数据。

    举例:关闭端口的VLAN入口规则。

    DCRS-7604 (Config-Ethernet1/1)# vlan ingress disable

     

    展开全文
  • FH5210系列智能多层交换机软件配置手册V0.1b
  • 实验二十七、使用多层交换机实现二层交换机 VLAN 之间的路由 一、 实验目的 1、理解多层交换机的路由原理 2、 了解多层交换机在实际网络中的常用配置 3、 回顾二层交换机 VLAN 的划分方法 4、进一步理解 802.1Q...
  • VLAN间路由之多层交换机一、实验拓扑二、实验要求1.PC1属于vlan10,PC2属于vlan20,IP地址如图所示2.配置交换机使得pc1和pc2能正常通信三、实验配置sw1:vlan batch 10 20 900#interface Vlanif10给vlan10 的svi接口...
  • 多层交换机VLAN间通信 实验环境设备:PC1 192.168.1.1/24 VLAN10PC2 192.168.2.1/24 VLAN20PC3 192.168.3.1/24 VLAN30PC4 192.168.4.1/24 VLAN40SW1二交换机SW2二交换机SW3三层交换机实验目的:实现PC1-PC4之间的...
  • 多层交换机静态路由

    2010-11-01 16:57:43
    实验二十八、多层交换机静态路由实验 一、 实验目的 1、理解三层交换机进行路由的原理和具体实现拓扑; 2、理解三层交换机静态路由的配置方法; 二、 应用环境 当两台三层交换机级联时,为了保证每台交换机上所...
  • 实验名称:多层交换机 实现不同网段 互通 思路解析实验需求: ⑴三层交换 1,2,3,4 分别是vlan10,20,30,40的网关 (网关IP - 192.168.X.250/24) vlan 10 192.168.10.0/24 vlan 20 192.168.20.0/24 ...
  • 实用标准文案 密级公开 文档归属产品营销部 使用对象全员 RG-S5750系列安全智能的万兆多层交换机 产品介绍 V2.2 福建星网锐捷网络有限公司 版权所有 侵权必究 文档维护人叶芳 Tel 13305912800 精彩文档 实用标准文案...
  • 它支持在局域网上部署语音、视频和数据应用,并将高密度终端/服务器和IP语音通信...借助其灵活的配置选项和高容量性能,对于那些寻求可靠的模块化解决方案的中小型企业,C460还可作为分布层交换机或网络骨干来部署。
  • 实验名称:通过一个多层交换机实现不同网段主机互通实验需求:1、创建VLAN10\20\30,配置对应的IP地址;2、配置交换机之间的trunk链路:SW1-SW2是手动,SW2-SW3是自动;3、交换机之间的Trunk链路均进行捆绑;4、确保...
  • Avaya C460配备一个紧凑的模块化六槽机箱(四个有效载荷插槽和两个交换阵列插槽),可用于以高性价比配置多层冗余,包括管理引擎以及交换阵列、电源、链路及端口、路由、以及风扇组,以便提供没有单一故障点的融合平台...
  • 多层交换机与路由

    2021-06-15 21:12:48
    核心交换机msw1同上 测试PC0可以ping通PC1. 路由器配置: Router>en Router#conf t Router(config)#int f0/0 Router(config-if)#no shutdown Router(config-if)#ip add 192.168.1.1 255.255.255.0 Router(config-if...
  • 锐捷网络RG-S5750系列安全智能的万兆多层交换机产品培训.ppt
  • QoS(Quality of Service,服务质量)指一个网络能够利用各种基础技术,为指定的网络通信提供更好的服务能力,是网络的一种安全机制, 是用来解决网络延迟和阻塞等问题的一种技术。QoS的保证对于容量有限的网络来说...
  • 本文着重讨论一些多层交换机qos的基本概念,以后将有相关内容的后续补充,希望能够帮助大家理解交换机的qos功能。1. 理解qos多层交换机使用InternetEngineering Task Force (IETF) DiffServ体系结构标准来实现qos. ...
  • 多层交换机静态路由实验 一、 实验目的 1、 理解三层交换机进行路由的原理和具体实现拓扑; 2、 理解三层交换机静态路由的配置方法; 二、 应用环境 当两台三层交换机级联时,为了保证每台交换机上所连接的网段...
  • 实施多层交换机中的高可用选项

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,973
精华内容 2,389
关键字:

多层交换机