精华内容
下载资源
问答
  • 静态路由设置---静态路由设置
  • 静态路由配置

    2013-06-04 17:10:17
    静态路由配置
  • 华为静态路由配置

    万次阅读 多人点赞 2019-11-12 09:11:59
    静态路由是由管理员手动配置和管理的路由,静态路由配置简单,因此,被广泛应用于结构简单网络中,静态路由还可以实现负载均衡与路由备份。 拓扑 PC1位于192.168.1.0网段,它的IP是192.168.1.2,网关是192.168....

    静态路由

    静态路由(Static Router)是由管理员通过手动配置的方式创建的路由,可以让路由器便捷的获知到达目的网络的路由。在静态路由基础上也可使用负载均衡、路由备份等技术。

    本文分别对静态路由、负载均衡、路由备份进行实验配置及配置完之后如何验证。

    网络拓扑图
    在这里插入图片描述
    给PC1与PC2分配IP、网关、掩码

    PC1位于192.168.1.0网段,它的IP192.168.1.2,网关192.168.1.1,掩码255.255.255.0。
    PC2位于192.168.2.0网段,它的IP192.168.2.2,网关192.168.2.1,掩码255.255.255.0。
    在这里插入图片描述

    在一个192.168.1.xxx这个网段中,共有256个地址,可用地址是254个,其中网络地址与广播地址是保留的,网络地址:192.168.1.0、广播地址:192.168.1.255。

    路由器AR1:
    GE 0/0/2接口192.168.1.1(网关地址),右边出接口与下一跳。
    路由器AR2:
    GE 0/0/2接口192.168.2.1(网关地址)。

    配置命令

    路由器AR1

    <Huawei>system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname AR1
    [AR1]interface GigabitEthernet 0/0/2
    [AR1-GigabitEthernet0/0/2]ip address 192.168.1.1 24
    [AR1-GigabitEthernet0/0/2]quit
    [AR1]interface GigabitEthernet 0/0/0
    [AR1-GigabitEthernet0/0/0]ip address 10.0.0.1 24
    [AR1-GigabitEthernet0/0/0]quit
    [AR1]interface GigabitEthernet 0/0/1
    [AR1-GigabitEthernet0/0/1]ip address 20.0.0.1 24
    [AR1-GigabitEthernet0/0/1]quit
    [AR1]ip route-static 192.168.2.0 24 10.0.0.2
    

    路由器AR2

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname AR2
    [AR2]interface GigabitEthernet 0/0/2
    [AR2-GigabitEthernet0/0/2]ip address 192.168.2.1 24
    [AR2-GigabitEthernet0/0/2]quit
    [AR2]interface GigabitEthernet 0/0/0
    [AR2-GigabitEthernet0/0/0]ip address 10.0.0.2 24
    [AR2-GigabitEthernet0/0/0]quit
    [AR2]interface GigabitEthernet 0/0/1
    [AR2-GigabitEthernet0/0/1]ip address 20.0.0.2 24
    [AR2-GigabitEthernet0/0/1]quit
    [AR2]ip route-static 192.168.1.0 24 10.0.0.1  //静态路由配置,解释:将去往192.168.1.0网段的数据都交给10.0.0.1这条路由。
    
    配置完成,不妨使用ping,测试一下吧。

    PC>ping 192.168.2.2
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=126 time=16 ms
    From 192.168.2.2: bytes=32 seq=2 ttl=126 time=16 ms
    From 192.168.2.2: bytes=32 seq=3 ttl=126 time=31 ms
    From 192.168.2.2: bytes=32 seq=4 ttl=126 time=31 ms
    From 192.168.2.2: bytes=32 seq=5 ttl=126 time=16 ms

    [AR1]display ip routing-table  //查看路由表信息
    

    在这里插入图片描述
    通过display ip routing-table 命令,可以查看路由表信息,在图中,在接口0/0/0/中,Protocol 协议下 static 代表是 静态路由,192.168.2.0/24代表“目标网段”/“掩码”,Pre是优先级,设备默认优先级是60,它的下一跳是 10.0.0.2。

    负载均衡

    其实,静态路由的配置只需要使用到一条链路即可实现,使用G0/0/0接口的配置分别连接在AR1与AR2两个路由器上
    在这里插入图片描述
    负载均衡是配置在G0/0/1接口上,负载均衡也叫负载分担,同样的它也是一条等价路由,优先级相同的路由称之为等价路由。

    在配置完静态路由的基础上,添加以下一条命令即可实现负载均衡

    在路由器AR1配置:

    [AR1]ip route-static 192.168.2.0 24 20.0.0.2  
    

    在路由器AR2配置:

    [AR2]ip route-static 192.168.1.0 24 20.0.0.1
    

    负载均衡配置完,再通过display ip routing-table查看路由信息
    在这里插入图片描述
    从表中可知,代表静态路由条目的static路由有两条,且优先级都为60。

    路由备份

    路由备份配置也极为简单,一条命令就可以了,它与负载均衡一样,也是使用G0/0/1接口上, 如果配置了负载均衡,需要先取消负载均衡,再做路由备份。

    其实,负载均衡/路由备份都是在静态路由的基础之上,再进行实验配置的。

    取消路由AR1的负载均衡配置

    [AR1]undo ip router-static 192.168.2.0 24 20.0.0.2 
    

    取消路由器AR2的负载均衡

    [AR1]undo ip router-static 192.168.1.0 24 20.0.0.1 
    

    AR1路由备份配置:

    [AR1]ip router-staic 192.168.2.0 24 20.0.0.2 Preference 70 
    

    AR2路由备份配置

    [AR1]ip router-staic 192.168.1.0 24 10.0.0.2 Preference 70 
    

    很简单吧,路由备份也配置完了,但是它的验证可能与前两个实验有些不同,无法直接通过display ip-routing table查看路由表判断出是否配置成功,如图disp路由信息可以看到,并没有看到我们配置的路由备份条目,再直观点就是看Preference 70的条目有没有在列表中, Preference 70 代表的是优先级为70,如果不做设置,设备默认优先级是60,值越小,优先级越优,因此,pre为60路由会先启用,而70不启用,则作为备份。
    在这里插入图片描述

    路由备份验证

    假设G0/0/0链路断开了,看路由备份会否启用。

    需要手动配置命令关闭接口G0/0/0

    [AR1-GigabitEthernet0/0/0]shutdown  //关闭接口G0/0/0
    

    关闭之后,display ip routing-table查询AR1路由表
    在这里插入图片描述
    从图静态路由信息可知,G0/0/1接口已启用,且其优先级是70的静态路由。

    路由备份的机制是通过配置路由的优先级来决定谁优先启用,默认值60,值越小,路由便越优。

    如果要取消刚才所关闭的接口,回到路由器AR1 G0/0/0接口下,使用此命令

    undo shutdown 
    

    缺省路由

    缺省路由也叫默认路由,在路由器配置中可用0.0.0.0/0表示默认路由,作用是帮助路由器发送路由表中无法查询的包。如果设置了全零网络的路由,路由表中无法查询的包都将送到全零网络的路由中去。

    [AR1]ip router-static 0.0.0.0 0 10.0.0.2  //默认路由0.0.0.0 
    
    展开全文
  • 以太网静态路由配置实验报告 1. 目的与要求 掌握在路由器上配置静态路由的方法,掌握针对静态路由的常用查看和测试命令。 2. 实验内容 (1) 在指定拓扑结构的多个路由器上配置静态路由; (2) 使用静态路由的...
  • 等价静态路由、浮动静态路由、缺省静态路由配置 等价静态路由 等价静态路由:只有下一跳地址不一样的N条路由。 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。 等价路由的配置实验:  ...

    等价静态路由、浮动静态路由、缺省静态路由的配置


    等价静态路由

    • 等价静态路由:只有下一跳地址不一样的N条路由。
    • 等价静态路由在路由表中查看时,只显示一条路由但有N个不同下一跳。


      等价路由的配置实验:
      在这里插入图片描述
            根据该图,此实验R3与R2需要配置等价静态路由,R1与R4需要配置两条静态路由。
      R3路由的配置:
    interface  fa0/0
    no shutdown
    ip address 17.3.3.1 255.255.255.252
    exit
    interface fa1/0
    no shutdown
    ip address 17.3.3.14 255.255.255.252
    exit
    interface fa2/0
    no shutdown
    ip address 17.3.3.64 255.255.255.192
    exit
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
    show ip route
    

    上述配置过程中:
    ip route 17.3.3.128 255.255.255.192 17.3.3.2
    ip route 17.3.3.128 255.255.255.192 17.3.3.13
         例如该两条路由只有下一跳地址不相同,目的网络地址与子网掩码都相同的路由——称为等价路由。
    等价路由由于优先级相同,所以在转发数据时随机选择通过路由。

    R3路由配置结果:
    在这里插入图片描述
    由图可以看出有三条直连路由,一条静态路由,但含有两个不同的下一跳地址。

    浮动(备份)静态路由

    • 在一个链路中,优先级高的叫主静态路由,优先级低的叫浮动静态路由。
    • 浮动路由配置成功后,在路由表中查看时只显示主路由。
    • 当主路由失效(有故障)时,浮动路由加入路由表并起数据转发作用。
    • 数值越小,优先级越高

    缺省路由

    • 目的网络地址,子网掩码都是0的特殊路由
    • 缺省路由配置时,注意只有一个出口时可以配缺省路由,多出口不可以配缺省路由。
    • 如果报文的目的地址无法匹配路由表中任何一项,路由表将按照缺省路由转发。
    • 全0网络地址为 全网地址


      缺省路由的配置实验
      在这里插入图片描述
      R2路由配置代码:
    interface fa0/0 
    no shutdown
    ip address 10.0.12.1 255.255.255.0
    exit
    interface fa1/0
    no shutdown
    ip address 192.186.4.1 255.255.255.0
    exit
    ip route 0.0.0.0  0.0.0.0  10.0.12.2
    show ip route
    

    R2路由配置结果:
    在这里插入图片描述
        有图可以看出,有一条缺省路由S*,优先级为1。

    展开全文
  • 用户需求:某学校网络拓扑图如图所示,要求配置静态路由,实现计算机PC1、PC2和PC3互通。直连路由直连路由出现在路由表的条件(1)接口为“up/up”状态。(2)接口已经完成了IP地址的配置。直连路由的检查静态路由是指由...

    用户需求:

    某学校网络拓扑图如图所示,要求配置静态路由,实现计算机PC1、PC2和PC3互通。

    直连路由直连路由出现在路由表的条件

    (1)接口为“up/up”状态。

    (2)接口已经完成了IP地址的配置。直连路由的检查

    640.png

    静态路由是指由网络管理员手工配置的路由信息,用于定义去往目的网络的明确路径。静态路由的类型

    标准静态路由

    默认静态路由

    汇总静态路由

    浮动静态路由

    静态路由根据如何指定目标,又可以分为3种:如果仅指定下一跳IP地址,则为下一跳静态路由;如果仅指定路由器的送出接口,则为直连静态路由;如果指定下一跳IP地址和送出接口,则为完全指定静态路由。静态路由的配置方法

    (1)检查每台路由器中直连路由的条数。

    (2)分析网络拓扑,找到每台路由器需要配置的静态路由条目的数量。

    (3)用静态路由配置命令为网络中的每台路由器配置静态路由。查看路由表

    配置命令

    Router#showip route

    Router(config)#iproute network-addresssubnet-mask {ip-address|interface-typeinterface-number[ip-address]}[distance][namename][permanent][tagtag]

    network-address:要加入路由表的远程网络的目的网络地址。

    subnet-mask:要加入路由表的远程网络的子网掩码。此处子网掩码可修改,以便汇总一组网络。

    ip-address:将数据包转发到远程目的网络所用的相连路由器的IP地址,一般称为下一跳IP地址。

    interface-type interface-number:用于将数据包转发到下一跳的送出接口。

    distance:可选参数,静态路由的管理距离,当配置浮动静态路由时,通过修改该参数可实现路由的浮动。

    name:可选参数,可以指定下一跳的名称。

    permanent:可选参数,永久路由标识。

    tag:可选参数,静态路由的Tag值。

    管理距离

    管理距离是路由协议的可信度或优先级。每一种路由协议都会分配一个信任等级,这个信任等级就叫管理距离。管理距离是从0到255的整数值,数值越小路由的可信度(或优先级)越高,管理距离数值越大路由的可信度(或优先级)越低。如果从多个不同的路由来源获取到同一目的网络的路由信息,路由器会使用管理距离来选择最佳路径。

    设计方案

    640.png

    网络拓扑图中,3台路由器R1、R2和R3互连了5个网络,路由器R1有3个非直连网络,路由器R2有2个非直连网络,路由器R3有3个非直连网络,因为路由器R1、R2和R3没有去往非直连网络的路由,所以网络无法互通。要实现网络的互通,可以针对路由器R1、R2和R3的非直连网络配置标准静态路由。

    项目实施直连静态路由的配置

    640.png下一跳静态路由的配置

    640.png

    要求完成下一跳静态路由的配置,实现计算机PC1、PC2和PC3互通。完全指定静态路由的配置

    640.png

    要求完成完全指定静态路由的配置,实现计算机PC1、PC2和PC3互通。默认路由的配置

    640.png

    要求在路由器R1和路由器R2上配置标准静态路由,在路由器R3配置默认路由,实现计算机PC1、PC2和PC3互通。汇总静态路由的配置

    640.png

    要求在路由器R2配置标准静态路由,在路由器R1和R3配置汇总静态路由,实现计算机PC1、PC2和PC3互通。浮动静态路由的配置

    640.png

    网络由主校区和分校网络组成,主校区和分校的网络采用双链路互连,R1-R2为主路径,R1-R3为备用路径。

    要求:在路由器R2、R3、R4上配置标准静态路由,在路由器R1上配置浮动静态路由,实现分校去往主校区的数据在主线路和备用线路间自动切换。拓展训练

    640.png完成路由器接口和计算机IP地址的配置。

    完成路由器R1汇总静态路由的配置。

    完成路由器R2默认路由的配置,实现网络互通。

    640.jpeg

    640.jpeg

    640.jpeg

    展开全文
  • 静态路由设置

    2013-01-02 21:44:17
    静态路由设置(思科): 用到的部分命令行 Clock rate 设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率 Configure terminal 从终端进行手动配置 Enable 打开特许模式 Ip route 建立一条...
  • 7静态路由配置

    2012-04-23 23:03:52
    7静态路由配置
  • server 2003 静态路由配置server 2003 静态路由配置server 2003 静态路由配置
  • 静态路由配置》PPT

    2011-01-26 09:33:36
    静态路由配置》PPT学习文件。。可以下来看看。静态路由配置静态路由配置静态路由配置静态路由配置静态路由配置静态路由配置
  • 思科静态路由配置

    2013-08-15 13:05:07
    静态路由器配置 ,思科静态路由设定Cisco
  • 静态路由配置.doc

    2010-12-18 11:48:28
    静态路由配置.doc静态路由配置.doc静态路由配置.doc
  • IP路由原理-静态路由配置 IP路由原理-静态路由配置.ppt
  • 路由器静态路由设置

    2013-01-05 11:08:02
    路由器的静态路由设置,本文描述了静态路由的基本原理,以及配置方法,请需要的参考,评分
  • IPv6静态路由配置

    2011-08-31 20:54:51
    IPv6静态路由配置 pdf文档 讲述最基本的linux下ipv6静态路由配置

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 147,424
精华内容 58,969
关键字:

如何查看静态路由配置