精华内容
下载资源
问答
  • 安卓手机ADB刷机软件

    2014-10-08 17:43:57
    为了确保手机正确连接,可以运行adb devices 命令看看。 成功连接会显示recovery字样或者ZTE N790字样! 然后是,运行命令adb reboot bootloader,接着手机重启,并且卡在第一屏或者是recovery界面。 最后一步了,...
  • ' 找到图后可以做 点击,按键,输入文本等操作 ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell /system/bin/screencap -p /data/data/1.png”) ' 截图 ' 运行 (“D:\Program ...

    9f53ac3dae95398af31c1ccaed1476b4.png

    这个应该有很多人会用到,可以写个APP,群控,搬家一下就可以,我还是个菜鸟,还望大神指点,我想把这个屏幕显示弄成时时的,不知道用什么方法。

    ' KEYCODE列表

    ' 3 HOME 键

    ' 4 返回键

    ' 5 打开拨号应用

    ' 6 挂断电话

    ' 24 增加音量

    ' 25 降低音量

    ' 26 电源键

    ' 27 拍照(需要在相机应用里)

    ' 64 打开浏览器

    ' 82 菜单键

    ' 85 播放/暂停

    ' 86 停止播放

    ' 87 播放下一首

    ' 88 播放上一首

    ' 122 移动光标到行首或列表顶部

    ' 123 移动光标到行末或列表底部

    ' 126 恢复播放

    ' 127 暂停播放

    ' 164 静音

    ' 176 打开系统设置

    ' 187 切换应用

    ' 207 打开联系人

    ' 208 打开日历

    ' 209 打开音乐

    ' 210 打开计算器

    ' 220 降低屏幕亮度

    ' 221 提高屏幕亮度

    ' 223 系统休眠

    ' 224 点亮屏幕

    ' 231 打开语音助手

    ' 276 如果没有 wakelock 则让系统休眠

    ' 1.获取模拟器号后在多开的情况下不知道那个对应那个模拟器

    ' 在安装目录 Microvirt\MEmu\MemuHyperv VMs\MEmu\MEmu.memu 不同模拟器在不同目录,自己找. 用记事本打开

    ' 在里面搜索ADB hostport="21513" 对应的这个就是 127.0.0.1:21513

    ' 很多信息也可以在这里面修改,手机品牌型号,设备串号什么的.自己研究(新克隆的模拟器要启动过一次才会有手机号码,串号等信息)

    ' 2.就是想做后台操作的东西.不方便,这里自己测试了下, 我是用易语言

    ' 借鉴论坛大神的代码.

    ' 截图,然后移动到计算机某个目录.我用的超级模块识图的识图功能.(截取的图片需要转换一次,要不然识别不了.费了很长时间才弄好)

    ' 还有就是截图后是一整张,可以把大图截取一部分来做识别. 这样识别速度更快.

    ' 找到图后可以做 点击,按键,输入文本等操作

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell /system/bin/screencap -p /data/data/1.png”) ' 截图

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ pull /data/data/1.png d:\”) ' 拷贝截图

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell input text hello”)'输入文本

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell input keyevent 111”) ' 按键

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell input tap 250 250”) ' 鼠标点击

    ' 运行 (“D:\Program Files\Microvirt\MEmu\adb.exe -s ” + 模拟器号 + “ shell input swipe 250 250 300 300 500”) ' 鼠标滑动

    展开全文
  • 准备工作:确信 \android-sdk-windows\tools\下有 adb.exe AdbWinApi.dll AdbWinUsbApi.dll 三个文件,如果没有从\android-sdk-windows\platform-tools\ 下面拷贝到tools下(android sdk 3.0 以上版本一些工具默认不...

    准备工作:

    确信 \android-sdk-windows\tools\下有 adb.exe     AdbWinApi.dll     AdbWinUsbApi.dll 三个文件,如果没有从\android-sdk-windows\platform-tools\ 下面拷贝到tools下(android sdk 3.0 以上版本一些工具默认不放在tools下,作为可选配置放在platform-tools下)

    开始:

    安装apk到手机:

    adb install c:\HA_drocap2_JOY3G.apk

    0818b9ca8b590ca3270a3433284dd417.png

    启动所安装的程序,手机要是root权限并且进入到data\app目录下:

    # am start -n cn.vsp/cn.vsp.StartActivty

    0818b9ca8b590ca3270a3433284dd417.png

    查看相应的日志:

    adb logcat -s welcome:i

    0818b9ca8b590ca3270a3433284dd417.png

    【操作命令】

    1. 查看设备

    adb devices

    这个命令是查看当前连接的设备, 连接到计算机的android设备或者模拟器将会列出显示

    2.安装软件

    adb install

    adb install :这个命令将指定的apk文件安装到设备上

    3. 卸载软件

    adb uninstall

    adb uninstall -k

    如果加 -k 参数,为卸载软件但是保留配置和缓存文件.

    4. 进入设备或模拟器的shell:

    adb shell

    通过上面的命令,就可以进入设备或模拟器的shell环境中,在这个Linux Shell中,你可以执行各种Linux的命令,另外如果只想执行一条shell命令,可以采用以下的方式:

    adb shell [command]

    如:adb shell dmesg会打印出内核的调试信息。

    5. 发布端口

    可以设置任意的端口号,做为主机向模拟器或设备的请求端口。如:

    adb forward tcp:5555 tcp:8000

    6. 从电脑上发送文件到设备

    adb push

    用push命令可以把本机电脑上的文件或者文件夹复制到设备(手机)

    7. 从设备上下载文件到电脑

    adb pull

    用pull命令可以把设备(手机)上的文件或者文件夹复制到本机电脑

    8、查看bug报告

    adb bugreport

    9、记录无线通讯日志

    一般来说,无线通讯的日志非常多,在运行时没必要去记录,但我们还是可以通过命令,设置记录:

    adb shell

    logcat -b radio

    10、获取设备的ID和序列号

    adb get-product

    adb get-serialno

    adb shell

    sqlite3

    展开全文
  • Android adb

    2019-12-29 15:36:51
    adbAndroid Debug Bridge),安卓平台调试桥,是连接Android手机与PC端的桥梁,通过adb可以管理、操作模拟器和设备,如安装软件、查看设备软硬件参数、系统升级、运行shell命令等
  • 现在流行的安卓模拟器越来越多,大漠就连绑定也不能了,所有玩安卓模拟器中控台的开发只能使用adb命令。第一课时主要是了解什么是adb,adb有什么作用,如何操作。 视频链接: 511遇见安卓模拟器易语言adb模块制作...

    现在流行的安卓模拟器越来越多,大漠就连绑定也不能了,所有玩安卓模拟器中控台的开发只能使用adb命令。第一课时主要是了解什么是adb,adb有什么作用,如何操作。

    视频链接: 

    511遇见安卓模拟器易语言adb模块制作

    安卓模拟器adb易语言模块制作

    认识adb
    ADB全称Android Debug Bridge, 是android sdk里的一个工具,用这个工具可以直接操作管理android模拟器或者真实的andriod设备。

    在Android的开发中,安装的Android SDK工具包含了Adb这个工具,在platform-tools文件夹中。

    android sdk指的是Android专属的软件开发工具包。被软件开发工程师用于为特定的软件包、软件框架、硬件平台、操作系统等建立应用软件的开发工具的集合。

    下载好Android SDK后,开始安装,Android SDK采用了Java语言,所以需要先安装JDK 5.0及以上版本。直接下载jdk安装文件安装更为方便。

    adb工具包,总共包括4个文件,分别为adb.exe,AdbWinApi.dll,AdbWinUsbApi.dll和fastboot.exe
    扩充
    SDK:(software development kit)软件开发工具包。被软件开发工程师用于为特定的软件包、软件框架、硬件平台、操作系统等建立应用软件的开发工具的集合。
    ADK是Android Open Accessory Development Kit 的缩写。使用ADK使得不支持USB Host功能的Android设备也可以和其它USB设备交互。比如使用Android手机来控制步进电机,条码扫描仪,机器人等。
    ADB的全称为Android Debug Bridge,字面意思就是安卓调试桥接,简单点说,它是Android系统提供的一套工具,通过它,我们可以在电脑上建立一个连接到手机的通道,然后可以由电脑上向手机发送一些指令,完成一些我们需要做的工作 。

    相关功能

    adb.exe的主要功能有:
    * 运行设备的shell(命令行)
    * 管理模拟器或设备的端口映射
    * 计算机和设备之间上传/下载文件
    * 将本地apk软件安装至模拟器或android设备
    *开发过程中对模拟器的控制与错误检查,如查看logcat ,id等
    1、雷电模拟器
    安装目录的根目录
    2、逍遥模拟器
    安装目录的根目录
    3、天天模拟器
    Tools/adb.exe

        相关命令

    .版本 2
    
    .子程序 鼠标点击, , 公开, 执行完毕成功返回"Success“关键字.adb:adb shell input tap <坐标x> <坐标Y>
    .参数 索引, 整数型, 可空, 模拟器索引(index)。为空则为第一模拟器为0,第二个为1,第三个为2,以此类推
    .参数 x, 整数型, , x坐标
    .参数 y, 整数型, , y坐标
    .参数 信息, 文本型, 可空, 0.成功返回关键字"Success",失败返回所有信息.1.返回默认信息.设置为:0
    
    .如果真 (是否为空 (索引))
        索引 = 0
    .如果真结束
    信息 = 取dos命令 (“adb” + 取连接端口 (索引) + “shell input tap ” + 到文本 (x) + “ ” + 到文本 (y))
    返回 (“Success”)
    
    .子程序 鼠标滑动, , 公开
    .参数 索引, 整数型, 可空, 模拟器索引(index)。为空则为第一模拟器为0,第二个为1,第三个为2,以此类推
    .参数 x1, 整数型, , 第一点x坐标
    .参数 y1, 整数型, , 第一点y坐标
    .参数 x2, 整数型, , 第二点x坐标
    .参数 y2, 整数型, , 第二点y坐标
    .参数 时间, 整数型, , 鼠标拖动的时间(单位毫秒)
    
    .如果真 (是否为空 (索引))
        索引 = 0
    .如果真结束
    取dos命令 (“adb” + 取连接端口 (索引) + “shell input swipe ” + 到文本 (x1) + “ ” + 到文本 (y1) + “ ” + 到文本 (x2) + “ ” + 到文本 (y2) + “ ” + 到文本 (时间))
    
    .子程序 查看设备信息, 文本型, 公开, 返回设备信息
    .参数 索引, 整数型, 可空, 模拟器索引(index)默认为空既为第一模拟器为0,第二个为1,第三个为2,以此类推
    .局部变量 信息, 文本型
    
    .如果真 (是否为空 (索引))
        索引 = 0
    .如果真结束
    信息 = 取dos命令 (“adb” + 取连接端口 (索引) + “ shell getprop”)
    返回 (信息)
    

     

    1、查看当前运行的模拟器

    Cmd F:\ChangZhi2\dnplayer2

    adb.exe kill-server

    adb devices

    2、电脑上的文件或文件夹传到模拟器里面

    adb push f:/temp.txt  /data/   (重命令)

    3、模拟器里面的文件或文件夹传到电脑上

    adb push /data/ temp.txt   f:/yj.txt

    源码:511遇见安卓模拟器易语言adb模块制作

               安卓模拟器易语言adb模块制作-1-认识adb

               易语言大漠网游(雷电模拟器)手游系列

     

    展开全文
  • android使用adb命令安装软件

    千次阅读 2016-08-06 21:44:39
    确信 \android-sdk-windows\tools\下有 adb.exe AdbWinApi.dll AdbWinUsbApi.dll 三个文件,如果没有从\android-sdk-windows\platform-tools\ 下面拷贝到tools下(android sdk 3.0 以上版本一些工具默认不放在tools...

    准备工作:
    确信 \android-sdk-windows\tools\下有 adb.exe AdbWinApi.dll AdbWinUsbApi.dll 三个文件,如果没有从\android-sdk-windows\platform-tools\ 下面拷贝到tools下(android sdk 3.0 以上版本一些工具默认不放在tools下,作为可选配置放在platform-tools下)
    开始:
    安装apk到手机:

    adb install c:\HA_drocap2_JOY3G.apk
    

    启动所安装的程序,手机要是root权限并且进入到data\app目录下:

    # am start -n cn.vsp/cn.vsp.StartActivty
    

    查看相应的日志:

    adb logcat -s welcome:i
    

    【操作命令】

    查看设备

    adb devices
    

    这个命令是查看当前连接的设备, 连接到计算机的android设备或者模拟器将会列出显示

    安装软件

    adb install
    adb install <apk文件路径> :这个命令将指定的apk文件安装到设备上
    

    卸载软件

    adb uninstall <软件名>
    adb uninstall -k <软件名>
    

    如果加 -k 参数,为卸载软件但是保留配置和缓存文件.

    进入设备或模拟器的shell:

    adb shell
    

    通过上面的命令,就可以进入设备或模拟器的shell环境中,在这个Linux Shell中,你可以执行各种Linux的命令,另外如果只想执行一条shell命令,可以采用以下的方式:

    adb shell [command]
    

    如:adb shell dmesg会打印出内核的调试信息。

    发布端口
    可以设置任意的端口号,做为主机向模拟器或设备的请求端口。如:

    adb forward tcp:5555 tcp:8000
    

    从电脑上发送文件到设备
    adb push <本地路径> <远程路径>
    用push命令可以把本机电脑上的文件或者文件夹复制到设备(手机)
    7. 从设备上下载文件到电脑
    adb pull <远程路径> <本地路径>
    用pull命令可以把设备(手机)上的文件或者文件夹复制到本机电脑
    8、查看bug报告
    adb bugreport
    9、记录无线通讯日志
    一般来说,无线通讯的日志非常多,在运行时没必要去记录,但我们还是可以通过命令,设置记录:
    adb shell
    logcat -b radio
    10、获取设备的ID和序列号
    adb get-product
    adb get-serialno
    adb shell
    sqlite3

    展开全文
  • Android安卓adb指令

    2016-11-19 02:26:16
    第4天: adb是什么?...还可以进行很多手机操作,如安装软件、系统升级、运行shell命令等等。 adb怎么用? 1.eclipse 与手机连接时出现问题之一:[2014-01-08 14:00:07 - adb] ADB server didn't
  • ADB全称Android Debug Bridge, 是android sdk里的一个... 1、运行设备的shell(命令行) 2、计算机和设备之间上传/下载文件 3、将本地apk软件安装至模拟器或android设备   ADB是一个 【客户端-服务器端】程序, ...
  • 64位 centos 运行 android adb adb是32位的,所以运行时要使用32位体系,而google上的IDE没有考虑linux上有些库本身还没有。我的运行环境是CentOS6.3的liveCD版,其中最麻烦的是要找libncurses.so.5库,CensOS...
  • adb下载安装及使用

    万次阅读 多人点赞 2019-05-23 12:00:15
    adb介绍: Android Debug Bridge(安卓调试桥) tools。...命令行程序”adb”用于从shell或脚本中运行adb命令。首先,“adb”程序尝试定位主机上的ADB服务器,如果找不到ADB服务器,“adb”程序自动启动一个A...
  • adb的介绍与其运用场景 简介 adb工具即Android Debug Bridge(安卓...1.最简单的可以在刷机时使用,要是你的手机开不了机或者刷成砖了,这是可以通过电脑cmd下运行adb 2.调试程序时使用,我是在调试程序时用上的。...
  • android使用adb命令安装软件 2011-05-24 15:32:38| 分类: Android | 标签:adb shell android |字号大中小 订阅 . 准备工作: 确信 \android-sdk-windows\tools\下有 adb.exe AdbWinApi.dll AdbWinUsbApi.dll...
  • 安卓调试桥 android adb

    2014-05-08 16:27:43
    Android 调试桥(adb)是多种用途的工具,该工具可以帮助你你管理设备或模拟器 的状态。 可以通过下列几种方法加入adb: 在设备上运行shell命令 通过端口转发来管理模拟器或设备 从模拟器或设备上拷贝来或拷贝走...
  • android adb运行不起来

    2015-12-08 16:38:07
    有时程序时木有问题的,前一次还能运行,某天打开却发现控制台报这样的错误, 很多朋友都应该遇到过这样的问题吧,以下给出相关处理方法的总结,万试万灵 情况如下: The connection to adb is down, and a severe ...
  • 某天,使用adb shell连接手机时,提示以下...运行命令:adb nodaemon server 提示如下: cannot bind 'tcp:5037' 怪了,5037端口好像是被占用了 运行命令查看是哪个进程占用的: netstat -ano|findstr "5037
  • 如果出现The connection to adb is down, and a severe error has occured. [2016-11-28 11:49:56 - Test] You must restart adb and Eclipse. [2016-11-28 11:49:56 - Test] Please ensure that adb is correctly ...
  • 首先,我并没有运行任何手机助手软件,所以任务管理器里没有“adb.exe”程序存在,所以不存在adb占用的可能,所以网上大家提供的办法其实说来说去都是因为这一原因造成的,比如在DOS界面下,杀死adb程序再重新启动...
  • Android ADB

    2017-07-03 11:50:25
    Android 调试桥 本文内容 adb 的工作方式在您的设备上启用 adb 调试通过 WLAN 连接到设备查询设备将命令发送至特定设备安装应用设置端口转发将文件复制到设备/从设备复制文件停止 adb 服务器adb 命令...
  • 然后执行 : adb push classes.dex /data/local/tmp cd /data/local/tmp app_process -Djava.class.path=/data/local/tmp/classes.dex /system/bin shellService.Main 这时就能看到已经成功运行啦: 这里因为 utf8 ...
  • TCL Android 电视 adb

    2019-09-28 00:26:33
    ** 首先电脑与电视要连接同一个路由器(图片来自...因为电视系统隐藏了adb开关,需要用软件“TCPUDP调试工具”打开电视adb(后面运行adb命令需要android的adb工具包) 地址:http://pan.baidu.com/share/link?sha...
  • 当我们调用CMD执行adb命令时,回返回以下错误,本课视频教程通过初始化adb解决了这个bug. 1、解决:adb devices时显示的XXXXXXXX offline > adb devices List of devices attached emulator-5554 device ...
  • Android设备adb调试

    千次阅读 2018-04-13 21:19:57
    参考系统及开发软件:系统win10开发软件androidstudio1.adb的环境配置在android开发工具中会附带adb,为了能方便全局使用adb的命令,我们对adb进行全局的环境变量配置。1.1 复制adb所在文件路径1.2 配置环境变量1)...
  • Android实用adb命令

    2016-06-27 00:52:06
    ADB全称Android Debug Bridge,就是起到调试桥的...借助adb工具,我们可以进行很多手机操作,如设备连接、安装软件、卸载软件、文件拷贝、运行shell命令等进入设备的shell界面 adb shell 查看设备 adb devices List of
  • Android常用ADB命令

    2016-01-13 16:56:06
    其实简而言说,adb就是连接Android手机与PC端的桥梁,可以让用户在电脑上对手机进行全面的操作 2.adb作用: 借助adb工具,我们可以管理设备或手机模拟器的状态。还可以进行很多手机操作,如安装软件、系统升级...
  • Bluestacks的历史可以追溯到2011年,是最早在PC上实现流畅运行安卓系统的方案。Bluestacks的原理是把Android底层API接口翻译成Windows API,对PC硬件本身没有要求,在硬件兼容性方面有一定的优势。但Bluestacks需要...
  • Android adb命令工具

    2018-07-10 21:29:58
    Android adb命令工具,借助adb工具,我们可以管理...还可以进行很多手机操作,如安装软件、卸载软件、系统升级、运行shell命令等等。adb就是连接Android手机与PC端的桥梁,可以让用户在电脑上对手机进行全面的操作。
  • 将本地apk软件安装至模拟器或android设备 ADB是一个客户端-服务器端程序,其中客户端是你用来操作的电脑,服务器端是android设备。先说安装方法,电脑上需要安装客户端。客户端包含在SDK里。设备上不需要安装,只...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 21,325
精华内容 8,530
关键字:

安卓运行adb软件