精华内容
下载资源
问答
  • 解决vue.js+node.js安装SASS失败等问题 让我们直接看报错信息 ERROR Failed to compile with 1 errors 下午1:23:...

    解决vue.js+node.js安装SASS失败等问题

    让我们直接看报错信息

    ERROR  Failed to compile with 1 errors                                                                                                                    下午1:23:25
     error  in ./src/pages/home/index.vue?vue&type=style&index=0&lang=scss&
    
    Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
    ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
    Error: The module '\\?\C:\Users\Administrator\AppData\Roaming\npm-cache\node-sass\4.13.1\win32-x64-72_binding.node'
    was compiled against a different Node.js version using
    NODE_MODULE_VERSION 72. This version of Node.js requires
    NODE_MODULE_VERSION 83. Please try re-compiling or re-installing
    the module (for instance, using `npm rebuild` or `npm install`).
        at Object.Module._extensions..node (internal/modules/cjs/loader.js:1235:18)
        at Module.load (internal/modules/cjs/loader.js:1034:32)
        at Function.Module._load (internal/modules/cjs/loader.js:923:14)
        at Module.require (internal/modules/cjs/loader.js:1074:19)
        at require (internal/modules/cjs/helpers.js:72:18)
        at module.exports (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\node-sass\lib\binding.js:19:10)
        at Object.<anonymous> (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\node-sass\lib\index.js:14:35)
        at Module._compile (internal/modules/cjs/loader.js:1185:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:1205:10)
        at Module.load (internal/modules/cjs/loader.js:1034:32)
        at Function.Module._load (internal/modules/cjs/loader.js:923:14)
        at Module.require (internal/modules/cjs/loader.js:1074:19)
        at require (internal/modules/cjs/helpers.js:72:18)
        at getDefaultSassImplementation (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\sass-loader\dist\getDefaultSassImplementation.js:24:10)
        at getSassImplementation (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\sass-loader\dist\getSassImplementation.js:19:72)      
        at Object.loader (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\sass-loader\dist\index.js:40:61)
        at D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\webpack\lib\NormalModule.js:316:20
        at D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:367:11
        at D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:233:18
        at runSyncOrAsync (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:143:3)
        at iterateNormalLoaders (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:232:2)
        at iterateNormalLoaders (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:221:10)
        at D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:236:3
        at Object.context.callback (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\loader-runner\lib\LoaderRunner.js:111:13)
        at Object.module.exports (D:\Users\Administrator\Documents\HBuilderProjects\Cloudmeal_1\cloudy\node_modules\@dcloudio\vue-cli-plugin-uni\packages\webpack-preprocess-loader\index.js:60:8)
    
     @ ./src/pages/home/index.vue?vue&type=style&index=0&lang=scss& 1:0-839 1:855-858 1:860-1696 1:860-1696
     @ ./src/pages/home/index.vue
     @ ./src/main.js?{"page":"pages%2Fhome%2Findex"}
    

    上述问题是你没有安装 sass依赖

    解决办法: CMD进入你的项目根目录下 运行 如下代码
    npm install node-sass sass-loader --save

    展示
    执行结果 如下:成功

    在使用上诉安装依赖时 可能报错,且是大量的错误,那么可能是之前有安装过依赖且与现在安装的依赖冲突。

    解决办法: 找到我的电脑以下路径:

    C:\Users\Administrator\AppData\Roaming\npm-cache\node-sass
    

    例子

    1. 进来后你可能有 一个或者多个sass版本号文件,全部删除掉,相当于清理的缓存。
    2. 再cmd进入自己的项目根目录下运行
      安装依赖:
    npm install
    

    查看自己项目文件的 package.json文件
    例:在这里插入图片描述
    在这里插入图片描述
    查看是否安装上 node-sass 和 sass-loader
    例:在这里插入图片描述
    在这里插入图片描述
    如果没有这两个依赖 ,再运行一次 以下代码

    npm install node-sass sass-loader --save
    

    最终 安装成功 使用 scss语法进行编译

    例:
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 安装sass失败怎么解决

    2018-03-18 08:00:31
    Error installing sass: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb checking for ffi.h... *** extconf.rb failed *** ...
  • 话说我准备使用如下命令安装 sass gem install sass 执行到一半,结果提示我没权限,OK,那就sudo gem install sass吧。结果还是报错: Error installing sass: ERROR: Failed to build gem native extension. …… ...

    话说我准备使用如下命令安装 sass

    gem install sass

    执行到一半,结果提示我没权限,OK,那就sudo gem install sass吧。结果还是报错:

    Error installing sass:
    ERROR: Failed to build gem native extension.
    ……

    查了一下,大致是需要升级 ruby,OK,ruby 确实没更新过,那就升级吧,使用rvm来更新管理升级ruby,命令如下:

    curl -L https://get.rvm.io | bash -s stable --ruby

    运行到一半,又他妈的挂了,提示错误信息:you need to make "brew update" avalabile.

    于是更换 brew 源吧:看这里

    OK,源更新完了,执行 brew updte 之后。重新更新 ruby,然后在安装 sass。
    中途还出现过一个错误。就是要安装 command line tool ,执行 xcode-select --install

    最终 sass 安装成功了,执行 sass -v,可以看到如下信息:

     sass -v
    Ruby Sass 3.7.4

    ok 成功了。其实这么多一大堆问题说白了,SASS是Ruby语言写的,安装 SASS 就得安装 ruby,ruby 有问题就得先升级 ruby,然后就是 command line tool的问题。
    所以,如果你看了上的一大堆不太明白就可以这样检查:

    1. 你的 ruby 版本是否最新,不是就先更新一把吧。
    2. 如果是使用rvm管理 ruby 版本的话,这玩意依赖 brew,所以 brew 版本低的话也有问题,因此要 升级 brew(先替换 brew 源防止卡死,然后brew update)
    3. 在 ruby 版本 OK 的情况下,顺带把 gem 也更新了。
    4. 如果没有安装command line tool的话,执行 `xcode-select --install` 
    5. 以上步骤完成的话,就可以安装 sass 了。

    (题外话:其实不是安装 sass 麻烦,而是你(我)自己的开发环境都没有准备好,没有整成最新的,如果环境都是 OK 的,就相当于预先的工作完成了,也就不会碰到这么多乱七八糟的问题了。比方说 brew update卡死的问题,我早就知道需要替换源,只是我懒得弄而已,因为当我们执行 brew install xx卡死的时候,ctrl c 一下命令 install动作还是会继续的,不影响使用所有我就没更新。但是今天安装 sass 还是跑不掉,欠的债终究还是要还)

    typescript:
    查看版本:tsc -v
    安装:npm install -g typescript

    转载于:https://www.cnblogs.com/demingblog/p/11436682.html

    展开全文
  • mac安装sass失败,解决办法

    千次阅读 2018-07-22 13:13:31
    在windows下安装很顺利,然后在mac下...$ sudo gem install sass 如果安装无限等待尝试下面替换RubyGems镜像 第一步:移动默认的源 $ gem sources --remove https://rubygems.org/ 第二步:指定淘宝的源 $ ge...

    在windows下安装很顺利,然后在mac下找了好多帖子都未能安装成功,还安装了xcode。。。

    mac中默认有Ruby环境,执行以下命令

    $ sudo gem install sass

    如果安装无限等待尝试下面替换RubyGems镜像

    第一步:移动默认的源

    $ gem sources --remove https://rubygems.org/

    第二步:指定淘宝的源

    $ gem sources -a https://ruby.taobao.org/

    第三步:查看指定的源是不是淘宝源

    $ gem sources -l

    返回结果如下:

    *** CURRENT SOURCES ***
    https://ruby.taobao.org

    请确保只有 ruby.taobao.org。如果无误之后,执行下面的命令:

    $ sudo gem install sass

    如果出现下面错误
    ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/sass

    尝试下面方法
     

    $ sudo gem install -n /usr/local/bin sass

    安装完成尝试查看sass版本

    $ sass -v

     

    展开全文
  • 安装sass失败,解决方法

    千次阅读 2015-04-14 15:29:43
    因为sass依赖于ruby环境,所以装sass之前先确认装了ruby。先导官网下载个ruby 在安装的时候,请勾选Add Ruby executables to your PATH这个选项,添加环境变量,不然以后使用编译软件的时候会提示找不到ruby环境

    转载http://www.w3cplus.com/sassguide/install.html


    ruby安装

    因为sass依赖于ruby环境,所以装sass之前先确认装了ruby。先导官网下载个ruby

    在安装的时候,请勾选Add Ruby executables to your PATH这个选项,添加环境变量,不然以后使用编译软件的时候会提示找不到ruby环境

    ruby install

    sass安装

    安装完ruby之后,在开始菜单中,找到刚才我们安装的ruby,打开Start Command Prompt with Ruby

    Start Command Prompt with Ruby

    然后直接在命令行中输入

    gem install sass

    按回车键确认,等待一段时间就会提示你sass安装成功。最近因为墙的比较厉害,如果你没有安装成功,那么请参考下面的淘宝的RubyGems镜像安装sass,如果成功则忽略

    如果要安装beta版本的,可以在命令行中输入

    gem install sass --pre

    你还可以从sass的Git repository来安装,git的命令行为

    git clone git://github.com/nex3/sass.git
    cd sass
    rake install

    升级sass版本的命令行为

    gem update sass

    查看sass版本的命令行为

    sass -v

    你也可以运行帮助命令行来查看你需要的命令

    sass -h

    淘宝RubyGems镜像安装 sass

    由于国内网络原因(你懂的),导致 rubygems.org 存放在 Amazon S3 上面的资源文件间歇性连接失败。这时候我们可以通过gem sources命令来配置源,先移除默认的https://rubygems.org源,然后添加淘宝的源https://ruby.taobao.org/,然后查看下当前使用的源是哪个,如果是淘宝的,则表示可以输入sass安装命令gem install sass了,关于常用gem source命令可参看:常用的gem source

    $ gem sources --remove https://rubygems.org/
    $ gem sources -a https://ruby.taobao.org/
    $ gem sources -l
    *** CURRENT SOURCES ***
    
    https://ruby.taobao.org
    # 请确保只有 ruby.taobao.org
    $ gem install sass

    淘宝RubyGems镜像安装 sass

    由于国内网络原因(你懂的),导致 rubygems.org 存放在 Amazon S3 上面的资源文件间歇性连接失败。这时候我们可以通过gem sources命令来配置源,先移除默认的https://rubygems.org源,然后添加淘宝的源https://ruby.taobao.org/,然后查看下当前使用的源是哪个,如果是淘宝的,则表示可以输入sass安装命令gem install sass了,关于常用gem source命令可参看:常用的gem source

    $ gem sources --remove https://rubygems.org/
    $ gem sources -a https://ruby.taobao.org/
    $ gem sources -l
    *** CURRENT SOURCES ***
    
    https://ruby.taobao.org
    展开全文
  • 错误提示 [root@iz2ze6hzcn38yurhan7re4z ~]# sudo ...gem install sass" Building native extensions. This could take a while... ERROR: Error installing sass: ERROR: Failed to build gem native exten...
  • 文章来源:sass安装:webpack sass编译失败,node-sass安装失败的终极解决方 ...从sass刚刚开始出来开始,就遇到ruby安装sass失败问题。换淘宝gem库 gem sources --remove https://rubygems.org/ gem sources ...
  • Vue安装style-loader失败 原因和解决方法 当前sass的版本太高,webpack编译时出现了错误,这个时候只需要换成低版本的就行,下面说...Vue安装sass-loader,node-sass失败 # 安装 SASS 加载器 npm install sass-loa...
  • 安装sass

    2020-07-30 10:07:00
    安装sass失败问题使用淘宝镜像 作者:凌杰林 最近在安装gulp-sass总是报错,经过一番查询后才发现原来这个是依赖node-sass的,安装node-sass会访问github上下载文件,但是国内网络不肯定,经常会安装不成功,所以...
  • npm安装node-sass失败

    2018-12-19 16:58:07
    1、设置淘宝镜像 npm set sass_binary_site=https://npm.taobao.org/mirrors/node-sass/ 2、执行安装 npm i
  • yarn 安装node-sass失败

    2019-10-10 10:30:00
    yarn 安装node-sass失败 node版本:6.12.3 nvm版本:3.10.10 yarn版本:1.3.2 package.json yarn安装报错: 解决方法 yarn config set cache ~/.my-yarn-cache-dir
  • 使用Yarn安装gulp-sass或者node-sass失败解决方法 为sass设置淘宝镜像吗,亲测有效 yarn config set sass-binary-site http://cdn.npm.taobao.org/dist/node-sass -g 设置成功后,启动命令: yarn add gulp-...
  • 安装node-sass一直失败尝试了网友的多种办法最终以失败告终 最终解决的办法是用dart-sass替换node-sass npm install node-sass@npm:dart-sass 注意:在替换完Node Sass后,需要用::v-deep代替/deep/和>>>...
  • npm 安装node-sass失败

    千次阅读 2019-04-17 10:48:16
    npm 安装node-sass失败 0 info it worked if it ends with ok 1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’, 1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’, 1 verbose cli...
  • 当使用npm安装sass失败时我们可以进行如下配置 npm config set sass_binary_site https://npm.taobao.org/mirrors/node-sass/ 执行此命令后再次执行sass安装命令即可
  • nuxt 安装node-sass失败

    2019-05-13 14:38:18
    设置全局镜像源 npm config set sass_binary_site https://npm.taobao.org/mirrors/node-sass/, 之后再执行npm i node-sass --save就好了
  • windows安装fis-sass失败

    2015-10-13 18:00:00
    windows安装fis-sass失败 最近在使用fis3, 团队遇到各种安装问题, 归纳如下: 1. 先确保安装了vs2015 community,https://www.visualstudio.com/downloads/download-visual-studio-vs 2. 安装python ...
  • 使用npm安装node-sass失败的解决办法

    千次阅读 2018-06-07 13:54:31
    使用npm安装node-sass失败时,我们可以这样解决: 第一步(卸载之前安装失败的包): npm uninstall node-sass -D 第二步(使用淘宝镜像cnpm,先提前安装好cnpm): cnpm i node-sass -D ...
  • 问题:在编译nodejs项目的时候,使用npm install命令安装npm依赖包特别容易出现node-sass安装失败,报npm ERR! Failed at the node-sass@XXX postinstall script类似的错误。 原因:npm 安装 node-sass 依赖时,会...
  • node安装node-sass失败,配置淘宝源

    千次阅读 2019-04-03 16:41:10
    安装node-sass的时候总是会各种不成功,大部分安装不成功的原因都源自这里,因为 GitHub Releases 里的文件都托管在s3.amazonaws.com上面,而这个网址在国内总是网络不稳定,所以我们需要通过第三方服务器下载这个...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,037
精华内容 2,814
关键字:

安装sass失败