精华内容
下载资源
问答
  • 安装Solidworks 2018 SP5,一直出现PreReqs\VCRedist10\vcredist_x86.exe未成功安装问题 系统是WIN10 企业版 LTSC .NET Framework 3.5和4.7已经安装,网络已截断 1.尝试网上各种修改注册表方法,...

    安装Solidworks 2018 SP5,一直出现 PreReqs\VCRedist10\vcredist_x86.exe未成功安装 问题

    系统是64Bit WIN10 企业版 LTSC

    .NET Framework 3.5和4.7已经安装,网络已截断

    1.尝试网上各种修改注册表方法,"RegistrySizeLimit"="ffffff" ,重启扫描,无效

    2.直接打开安装目录下的PreReqs\VCRedist10文件夹,找到vcredist_x86,直接手动安装,提示组策略禁止安装,后面查看各种安装组策略/服务,更改后依旧无效,比较令人寒心的是VCRedist10下的vcredist_x64是能装成功的,唯独vcredist_x86不行,可是系统不是x64吗,不解一定要装x86这般为何。VCRedist12等文件夹里面的vcredist_x86/x64也可以成功安装

    3.再次检查断网、关闭防火墙等方面,依旧无效

    4.换用Solidworks 2019版本,依旧存在相同的vcredist_x86.exe未成功安装问题

    5.有资料说是系统更新后导致的2018版本无法兼容新补丁,遂卸载能卸载的2019年中旬+后期所有更新,但错误依旧

    6.网文推荐重装系统,我实在不想重装系统,因为现有系统有很多比Solidworks更难装的环境和设置

    7.去了微软官网下载了个en_visual_c_pp_2010_redistributable_package_x86_x64_ia64_508951.exe(12.Apr.2010),发现官网下载的2010 Redistributable居然可以直接安装成功,没有上面提到的组策略禁止问题

    8.既然已经安装好2010 Redistributable,就开开心心重新执行了Setup,结果vcredist错误依旧存在,Setup检测不到?

    9.思路来了,既然setup按照既定的ini(或者其他)安装指定位置的可执行文件,我把在官网下载的en_visual_c_pp_2010_redistributable_package_x86_x64_ia64_508951.exe重命名为vcredist_x86.exe,替换到了PreReqs\VCRedist10目录下

    10.再次开开心心执行Setup,关于vcredist_x86.exe 的这个错误消失了,Bingo~nice

    11.后续出现一个SQL相关的错误,提示命名太长,将安装包的路径命名改短改规范后再试,提示命名太长的错误消失,出现其他SQL相关的错误

    12.查找到该SQL错误跟electric组件有关,我仅想安安静静画个三维结构,不想处理这个SQL错误,electric这种事让Cadence来就好了,Solidworks搞一个By Altium这种究竟算啥神仙操作,取消electric组件的选择,再次Setup

    13.等待,安装成功,enjoy

     

    展开全文
  • 是因为32位库在64位机上执行不力。 可是装 ia32-libs,提示废弃。于是使用最后一条命令可以替代!! 一 先试试这条:$sudo apt-get install ia32-libs 二 不行的话再试试: $sudo apt-get install libc6:i386...


    
    是因为32位库在64位机上执行不力。 可是装 ia32-libs,提示废弃。于是使用最后一条命令可以替代!!
    
    
    
    
    一 先试试这条:
    $sudo apt-get install ia32-libs
    二  不行的话再试试:
    
    $sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386

    
    


    展开全文
  • Ubuntu16.04安装Windows可执行文件(QQ.exe)

    万次阅读 2017-09-25 02:34:22
    简述在Ubuntu系统下安装常用Windows软件(*.exe),本篇博文是安装QQ(使用的是TIM 可以理解为轻聊版QQ),网上好多教程都是安装国际版QQ或者是QQ2013,效果很差,有的根本无法正常使用,所以在次记录安装过程.安装winewine是...

    简述

    在Ubuntu系统下安装常用Windows软件(*.exe),本篇博文是安装QQ(使用的是TIM 可以理解为轻聊版QQ),网上好多教程都是安装国际版QQ或者是QQ2013,效果很差,有的根本无法正常使用,所以在次记录安装过程.

    安装wine

    wine是比较好的一个支持在Ubuntu运行Windows的软件,所以先安装wine.首先将wine加入到Ubuntu的源中,打开终端,切换到root用户输入以下命令

    add-apt-repository ppa:wine/wine-builds

    回车执行后根据提示回车确认,很快就执行完毕.
    这里写图片描述
    接着更新apt-get,终端输入以下命令(root用户模式下进行)

    apt-get update
    

    这里写图片描述
    这个截图仅供参考,每个人更新的不一样,由于我经常更新所以很快就结束了.
    系统软件更新默认的服务器在国外,下载速度很慢,强烈建议修改为中国境内的服务器,提高更新速度,方法如下
    系统设置–>软件和更新–>Ubuntu软件–>下载自–>中国服务器–>其他站点–>找到含有aliyun的网站就可以了
    这里写图片描述
    中间会有一个授权的对话框,输入用户密码就可以了.当然也可以选择其他境内服务器.个人推荐阿里云.

    现在开始使用apt-get命令安装wine,输入以下命令

    apt-get install --install-recommends winehq-devel

    中途遇到提示就输入y确认,直到安装成功.

    检查是否安装成功,终端输入命令

    wine --version
    

    这里写图片描述
    如图显示已经成功安装wine2.4,据说wine1.8比较稳定,也没试过,当前默认使用最新版没发现什么大问题.

    配置wine,终端输入

    winecfg

    紧接着会有一串英文出来,不用管,很快一个窗口就会弹出来
    这里写图片描述
    这个图形化界面真的很windows,不多做解释.

    安装QQ

    要安装QQ首先得下载一个安装包,当然是去QQ官网下载一个Windows平台的exe文件.
    QQ版本比较多一定要看仔细啦.
    这里写图片描述
    这是我下载的QQ8.94和TIM(QQ办公轻聊版),当安装了wine后exe可执行文件就会显示图标,和在Windows系统里面看到的一样.

    下载好之后就是安装了,双击就可以了,和在Windows里面一毛一样.
    接下里,你在Windows怎么安装就在Ubuntu里怎么装(静等进度条结束)
    是不是很简单?

    后期优化

    当然不是那么简单,事情还没完!
    安装完成后,你点击立即运行可能会提示你没有flash之类的,然后你根据提示点击下载,如果下载失败,就自己打开浏览器下载安装.两个文件如下
    这里写图片描述
    文件名:

    install_flash_player_ppapi.exe
    install_flash_player_ax.exe

    下载完成后,双击安装就可以,如果没有提示相关错误,这一步就跳过.

    此时打开QQ,出弹出熟悉的登录界面,开不开心?

    然而,你会发现账号或者密码鼠标点不进去,就是不能输入…….

    怎么办?右下角有个扫码登录啊,用手机QQ扫一扫就登陆了,开不开心?

    登录问题成功解决了,是不是得给好友发个消息嘚瑟一下了?

    你会惊奇的发现QQ聊天对话框不显示任何文字,你的输入会有内容,也可以发送,手机可以看到的,但是电脑上面就是不显示,有的好友的昵称也是□□类似的乱码.QQ截图也不能用,这可能是个假QQ,并不是你想要的.

    不会前功尽弃的,办法总是有的,划重点

    打开wine的设置窗口,找到函数库选项,新增函数库顶替一栏,搜索或者输入

    riched20
    riched32

    分别添加到已有函数库顶替,点击应用,确定.

    完成后如图所示
    这里写图片描述

    (不知道这个窗口在哪打开?自己向上翻)

    此时,所有设置已经完成,打开QQ试一下吧

    emmmmmm可是QQ安装到哪了?
    桌面没有快捷方式,软件里面也搜不到啊!

    既然没有,那就造一个出来
    打开归档管理器(和Windows系统的资源管理器差不多),在查看菜单下选中显示隐藏文件,就会有很多文件和文件夹出来
    这里写图片描述

    找到这个QQ的安装路径,参考我的路径

    /home/haofan/.wine/drive_c/Program Files (x86)/Tencent/QQ/Bin

    这里写图片描述

    在一大堆文件中找到QQ.exe,这个和Windows系统下面QQ的目录结构是一毛一样的

    双击QQ.exe,登录QQ上述问题全部解决,但是还是有些bug不能记住密码等问题,不影响正常使用,

    每次打开QQ.exe文件比较麻烦,可以创建快捷方式,或者安装playonlinux,更好的发挥wine的作用.
    这里写图片描述
    这里写图片描述

    使用wine建议安装playonlinux

    以上.

    展开全文
  • linux下可执行文件,如果是在/bin、/sbin、/usr/bin或者/usr/sbin 里头,就直接敲文件名就可以运行.(注意环境变量PATH是否包含了路径) 如果是在其他文件夹里,比如说运行/root里头的 time文件 你就 cd /root 再 ./...

    linux下可执行文件,如果是在/bin、/sbin、/usr/bin或者/usr/sbin 里头,就直接敲文件名就可以运行.(注意环境变量PATH是否包含了路径)

    如果是在其他文件夹里,比如说运行/root里头的 time文件 你就 cd /root 再 ./time。注意./与time之间没有空格。

    ./表示当前目录下,../表示上一级目录,../../表示上上一级目录。


    linux终端中,是用"sh"来运行文件,或者"./"

    比如你在/usr/temp文件夹中有一个可执行文件"flash"

    你可以在终端中输入 sh /usr/temp/flash

    或者进入文件夹 cd /usr/temp 然后运行: ./flash


    如果是别人发布的二进制包,可执行文件通常都安装到 /usr/bin 下面;

    如果是自己从源代码安装的,可执行文 件通常都在 /usr/local/bin 下面,除非配置时指定了安装位置。

    例如:

    rpm -ivh xxx1.rpm

    可执行文件通常都安装到 /usr/bin 下面

    ./configure (或者 ./configure --prefix=/usr/local)

    make

    make install

    可执行文件通常都在 /usr/local/bin 下面,因为默认参数就是 --prefix=/usr/local

    ./configure --prefix=/usr (或者 ./configure --prefix=/opt 也可以指定其他位置,如你的家目录--prefix=~,~就是 /home/xxx<即你的家目录>的缩写)

    make

    make install

    可执行文件通常都在 /usr/bin 下面(或者相应地位于 /opt/bin 下面,或者 /home/xxx/bin 下面,xxx 是你的家目录)

    无论那种方法,在 bash 控制台下只要输入可执行文件头几个字母,然后连续按两次 Tab 键,就可以列出可能的所有命令,如果只有一种可能,则自动显示该文件全名,这称为命令补全。想执行当前目录下的可执行文件,则必须使用 ./ 作为命令前导,例如:

    ./myprogram


    除此之外,一般的可执行文件都处在系统的搜 索路径里,只要在控制台直接输入命令名就可执行。例如你编译安装了一个叫 synaptic 的软件,只需要在 KDE 的 konsole 虚拟控制台下输入 synaptic 即可。

    如果不幸,你的可执行文件不在系统的搜索路径里,就会报告没有这个命令。那么你需要把 那个可执行文件的位置加入环境变量 PATH里,用冒号作分割符,例如:

    在你的家目录的 .profile 文件或 .bashrc 文件里添加如下命令

    PATH="~/bin:$PATH" 就可以把你的家目录的 bin 目录追加到搜索路径里。

    无论任何时候想知道系统里某个“命令文件”的位置,都可以使用which 命令,例如:

    $which pwd

    /usr/bin/pwd

    说明 pwd 命令位于 /usr/bin 下面。


    新的操作系统装好了,安装一些新的软件那是难免的。但是在Linux中,安装应用软件 和Windows下有些不同哦。而且对于Linux初学者来说,安装软件是一件很让人头疼的事情。由于很多Linux应用软件都是以源代码的形式发布的, 这就要求用户根据自己系统的实际情况和自身的需要来配置、编译源程序后,才能使用这些软件。

    大多数Linux初学者往往不知道该如何 进行配置和编译。下面笔者就简单介绍一下如何安装Linux应用软件。在安装应用软件之前,还要确保软件安装的编译环境,比如编译器GCC、必要的库文件 等。不过,用户不需要担心这些问题,因为大多数 Linux发行版本都已经默认安装了GCC编译器。

    目前流行的软件包有两种比较常 见的形式,一种是以 RPM、deb包为代表的智能软件包,另一种是file.tar.gz形式的压缩。本文将讨论file.tar.gz的安装方法以及智能软件包在文本环境 和图形环境下的安装方法。

    一、源代码安装

    应用软件的源代码一般是file.tar.gz或者 file.tgz格式,也就是说是以tar来打包,然后用gzip来压缩。

    以应用软件xfce-3.8.7.tar.gz为例,先 进入软件的当前目录,然后使用gzip解压:#gzip -dxfce-3.8.7.tar.gz(注:-d 代表解压)。然后用tar解包:#tar -xvfxfce-3.8.7.tar。由于tar和gzip经常一起使用,所以tar还提供了一个参数,它可以自动调用gzip来解压,即:# tar-xzvf xfce-3.8.7.tar.gz。

    进入解压完成之后新建立的目录,一般的应用软件中都有一个用来配置软件的可执行文件——configure,它的参数比较多,而且用法也非常灵活。当然,安装不同的软件参数也不相同,具体有些什么参数,可以用命 令:#./configure help取得详细的帮助。例如./configure--prefix=/usr/local/mysql(表示设置软件的安装目录为:/usr /local/mysql)

    在运行#./configure[options]配置软件后,它会根据你当前系统、编译、安装相关的 信息,生成一个安装配置文件Makefile。Makefile文件通常是用来编译和安装软件的,运行make命令时系统会自动根据Makefile文件 中的设置对软件进行编译和安装,如果编译能够顺利通过的话,运行#makeinstall命令来安装。

    二、智能包安装

    现在,以智能包形式提供的软件很多,像RedHatLinux的RPM、DebianLinux的DEB、KISS、BSD以及Slackware等。 RPM和Debian几乎统治着Linux包管理世界,它们是首先被大多数商业Linux发行版本所广泛采用的应用软件。下面就介绍一下如何安装以RPM 和Deb格式打包的软件。

    RPM是RedHat Package Manager的缩写,它只能使用在安装了RPM软件的系统中,不过好像目前大多数中文Linux发行版本都支持RPM软件包。

    1.用命令管理

    rpm

    例如安装python-1.5.2-35.i386.rpm软件时,可以使用如下命 令:#rpm –ivh python-1.5.2-35.i386.rpm。

    如果你想知道RPM软件包中的相关信息,可以使用命 令:#rpm ivh python-1.5.2-35.i386.rpm。

    如果想知道python- 1.5.2-35.i386.rpm会在系统里安装哪些文件,可以使用以下这个命令:rpm -qpl python-1.5.2-35.i386.rpm。

    由于RPM的参数很多,我们就不一一列举,想得到更多有关RPM的参数,可以 用命令:#man rpm取得详细的帮助信息。

    dpkg

    dpkg是Debian的中级软件包管理器,类似 RPM.

    dpkg是Debian软件包管理系统的中流砥柱,负责安全卸载软件包,配置,以及维护已安装的软件包.也是Debian系 统中众多软件包管理工具的后端.有关dpkg的更多介绍参阅:http://www.dpkg.org

    系统中所有packages的 信息都在/var/lib/dpkg/目录下,其中子目录”/var/lib/dpkg/info”用于保存各个软件包的配置文件列表.

    .conffiles 记录了软件包的配置文件列表

    .list 保存软件包中的文件列表,用户可以从.list的信息中找到软件包中文件的具体安装位置.

    .md5sums 记录了软件包的md5信息,这个信息是用来进行包验证的.

    .prerm 脚本在Debian报解包之前运行,主要作用是停止作用于即将升级的软件包的服务,直到软件包安装或升级完成.

    .postinst脚 本是完成Debian包解开之后的配置工作,通常用于执行所安装软件包相关命令和服务重新启动.

    /var/lib/dpkg /available文件的内容是软件包的描述信息,该软件包括当前系统所使用的Debian安装源中的所有软件包,其中包括当前系统中已安装的和未安装 的软件包.

    dpkg

    查询以安装的信息

    查询当前系统所有已安装的deb包

    dpkg –l 命令用于查询当前系统所有以安装的deb包的信息.,通过less和grep可以执行更复杂的查询工作.

    例如查找 跟vim有关的软件包,dpkg –l |grep –ivim

    (如发现iU 表示软件包未安装成功,ii表示安装成功)

    查看已安装软件包的详细情况

    dpkg –s 命令查看软件包的详细情况,包括版本,依赖之类的

    查询系统中所安 装软件包所安装的文件

    dpkg –L 命令用于查询系统中所安装软件包的安装的文件安装到系统的位置和安装了那些.

    小提示: 如何可以看软件包装到哪个地方?

    用apt-get install *

    如何可以看软件包装到哪个地 方?

    dpkg -L package-name|more

    查询系统中某个文件属于那个软件包

    dpkg –S 命令用于了解当前的软件属于那个软件包

    查询未安装的信息

    查询未安装软件包详细信息

    dpkg –I 命令用于查看未安装软件包的详细信息,以便了解该软件包是否需要安装.

    查询deb包文件中所包含的文件

    dpkg –c 显示未安装deb软件包所包含的文件列表,以及安装位置

    安装软件包

    安装deb软件包

    dpkg –i 手工安装deb包到系统中,不过有时会存在Dpends关系,建议使用apt-get 来安装.

    如果通过dpkg –i安装软件后由于Dpends关系没有安装成功,可通过apt-get –f install解决

    解决dpkg –i 安装deb包出现Dpends问题

    apt-get –f install 解决Dpends问题.

    例 如:dpkg –i lftp_3.1.3-1_i386.deb

    Selecting previously deselected package lftp.

    (Reading database … 20654 files and directories currently installed.)

    unpacking lftp (from lftp_3.1.3-1_i386.deb)…

    dpkg:dependency problems prevent configuration of lftp:

    ftp depends on libexpat1 (<=1.95.8);however

    dpkg : error processing lftp (--install)

    dependency problems –leaving unconfigured

    Errors were encountered while processing:

    lftp

    //lftp软件包安装失败

    dpkg –l |grep lftp

    iU lftp 3.1.3-1 Sophisticated

    command-line FTP/HTTP client p

    //”dpkg -l” 查询信息表示lftp软件包未安装成功

    (iU表示未安装成功,ii表示安装成功)

    使用apt-get –f install解决

    卸载deb软件包

    卸载deb包

    dpkg –r用于卸载指定的软件包,该命令只卸载软件包安装到系统中的文件,而不去删除软件包的配置文件,因此不是完全意义上的卸载.但是软件包保存在系统中,可 以提供给以后在安装软件包时使用.

    例如:dpkg –r prozilla 移除后再用dpkg –l |grep prozilla 查看

    会看到rc proc 1.3.6-3woody3 multi-thraded download accelerator

    表示软件包已经被卸载,但配置文件仍在“rc”带表配置文件仍在.

    卸载软件包并清除配置 文件

    dpkg –P 用于卸载软件包同时也删除配置文件,dpkg –P 不能解决Dpends问题,建议卸载时使用apt-get操作

    重新配置软件包

    对于Debian系统中的众多软件 包(尤其是系统和服务器软件包)来说,在第一次安装该软件包时候会显示对话框窗口,提示用户输入必要的配置信息.当用户需要再次对软件包配置的时候,可以 使用dpkg-reconfigure来对指定的软件包进行配置.

    比如dpkg-reconfigure locales

    用于配置语言

    alien包转换工具

    如果我们有很喜欢的RPM包,而又没有deb版本

    怎么 办~?

    可以同过alien来转换或者直接安装,这个小家伙可是个很方便的东西!

    基本命令如下:

    首先通过apt-get install alien来安装.

    然后alien -i name-of-the-pakage.rpm /*用来直接安装rpm包

    alien -d , --to-deb /*Make debian packages,This is the default

    例:alien –d package.rpm

    alien –r , --to-rpm /*Make rpm packages

    例:alien –r package.deb

    alien –p , --to-pkg /*Make Solaris pkg packages

    alien –-to-slp /*Make slp packages

    alien –t , --to-tgz /*Make tgz packages

    alien –T 检测

    alien –-patch=patch 设置patch


    展开全文
  • 就是eclipse无法运行,双击 eclipse.run 提示 没有为可执行文件 文件类型安装应用程序。, 'Microsoft Yahei' !important; text-shadow: rgb(153, 153, 153) 0.01em 0.01em 0.01em !important;" />各位朋友指点指点,...
  • 将Python项目打包成EXE可执行文件(单文件,多文件,包含图片) 解决 将Python项目打包成EXE可执行文件(单文件,多文件,包含图片) 1.当我们写了一个Python的项目时,特别是一个GUI项目,我们特备希望它能成为一...
  • Python程序打包成exe可执行文件

    万次阅读 多人点赞 2017-08-02 16:04:20
    .py文件:对于开源项目或者源码没那么重要的,直接提供源码,需要使用者自行安装Python并且安装依赖的各种库。(Python官方的各种安装包就是这样做的)。 .pyc文件:有些公司或个人因为机密或者各种原因,不愿意...
  • 刚学Python还没一个月,迫于急着要搞一个项目的demo演示程序,由于这个demo是有GUI界面,而且代码里用了好多模块,为了拿出去让别人演示的时候可以不用再次安装那么多的库包,将Python代码打包成exe可执行文件还是很...
  • 之前以为错误是中文路径的问题,或者编码的问题,多次尝试修改,shell里面依旧可以执行成功,但是用pyinstaller打包后,可执行文件时执行就失败了。网上查到说是因为pyinstaller不支持文件里面有中文,不知道是不是...
  • vs2017安装和使用教程(详细)

    万次阅读 多人点赞 2019-03-26 21:15:56
    vs2019 已于4月2日推出,用户不用卸载vs2017,因为这二者互相独立,项目也兼容,安装教程也是本篇的姊妹篇: vs2019安装和使用教程(详细) vs2017如此强大,不仅仅是C语言,Python,R,F#,ios,Android,Web,...
  • 一个项目开发完毕后总有一种想法,就是生成可执行文件,总不能一直用python xxx执行吧。 以下操作同时适用于windows和Linux下的Pycharm(我在Ubuntu下试验过,生成的是在Ubuntu下的可执行文件) 1、打开Pycharm。 2...
  • 可执行jar打包成exe文件

    万次阅读 多人点赞 2018-10-10 20:00:04
    title: 把可执行jar打包成exe文件 categories: MyApplications 截图文字识别 date: 2018-10-10 19:39:02 把可执行jar打包成exe文件 摘要 eclipse中导出可执行jar exe4j下载安装破解 使用exe4j把...
  • 《MySQL安装流程详解》及《MySQL安装一直失败,重新安装显示安装》 本文由博主经过查阅网上资料整理总结后编写,如存在错误或不恰当之处请留言以便更正,内容仅供大家参考学习。 MySQL安装流程(两种方式) ...
  • windows环境下C程序生成可执行文件

    千次阅读 2019-07-05 15:22:24
    windows环境下,编写C程序,生成.exe,用于操作某个文件。 1、搭建程序编写和编译环境 在windows下安装Git Bash(下载页面)。 安装完成后,可以在windows的任意文件夹下,空白处点击右键,选择“Git Bash here”...
  • 全局安装vue-cli之后,命令行执行vue -V,提示:“vue”不是内部或外部命令,也不是可执行的程序或批处理文件 : 第一步:安装nodejs : 第二步:全局安装vue-cli //全局安装vue-cli之后,命令行执行vue -V,提示:...
  • matlab程序如何生成可执行文件

    千次阅读 2010-03-16 13:21:00
    要将用Matlab语言编写的函数文件编译成可独立执行的*.exe文件(即可脱离Matalab环境的执行程序),首先要安装和配置好Matlab Compiler,一般来说,在安装Matlab时就已经安装了相应版本的Matlab Compiler。只是不同版本...
  • 3、确定安装成功之后,在终端中输入“pyinstaller -F -w 文件名”,回车后开始打包文件 -F 是用于将所有的支持文件全部都打包在一起,不显示其他的依赖文件(如果没有这个属性,你会发现所有生成的、所需支持的依赖...
  • 在我们开发的过程中,一个完整的程序,有时会因为进命令行运行不方便,会因为源码不希望被别人看到等等的原因,那么今天我们就要将我们的程序进行打包,生成一个可执行的EXE文件,是不是很酷炫,接下来我们就看看...
  • ubuntu16.04安装MATLAB R2017b步骤详解(附完整文件包)

    万次阅读 多人点赞 2018-03-23 22:34:29
    摘要:介绍在ubuntu16.04中从下载到安装成功的完整步骤。本文给出MATLAB R2017b(Linux系统)的完整安装包百度云盘下载地址,逐步介绍一种简单易行的安装方法,在桌面创建快捷方式,最终完整运行。 1. 前言 最近...
  •  其实刚装好的系统中已经有GCC了,但是这个GCC什么文件都不能编译,因为没有一些必须的头文件,所以要安装build-essential这个软件包,安装了这个包会自动安装上g++,libc6-dev,linux-libc-dev,libstdc++6-4.1-dev等...
  • 近期由于项目需要,需要把之前的matlab程序打包成exe可执行文件或者jar包,真的是,心,力,交,瘁,我把近两天打包遇到的各种奇葩问题在这里总结一下: 代码中尽量避免出现中文,无论是注释也好还是程序里,因为真...
  • 使用makeself创建安装文件

    千次阅读 2014-11-19 09:03:28
    该文档会解压自己到一个临时目录,并且执行一个选的任意命令(例如:一个安装脚本)。它非常类似于Windows中的Winzip自解压生成的文件。Makeself文档也包括校验和用于集成子验证(CRC或MD5校验和)。 Make
  • 原本以为javac一下,java一下就可以得到自己想要的结果,可是结果大跌眼镜,自己被一个问题卡主了:java文件成功编译,但当运行编译后的class文件却报一个异常:NoClassDefFoundError。 当时的具体情况是...
  • 网上搜索发现别人说是CMakeLists中catkin_package() 没有声明的问题,没有在/home/mgody/catkin_ws/devel/lib/package/下生成可执行文件,可是自己已经声明了的。 自己的CMakeLists中是这样的: cmake_minimum_...
  • centOS7安装nginx及nginx配置

    万次阅读 多人点赞 2019-05-09 14:59:19
    安装所需插件 1、安装gcc gcc是linux下的编译器在此不多做解释,感兴趣的小伙伴可以去查一下相关资料,它可以编译C,C++,Ada,Object C和Java等语言 命令:查看gcc版本 gcc -v 一般阿里云的centOS7里面是都...
  • 安装好JDK后还需要设置执行路径,否则在windows命令行中执行“java -version”命令会不成功,所谓执行路径是指操作系统搜索本地可执行文件的目录列表。
  • 保存点:Git的保存点可以追踪源码中的文件, 并能得到某一个时间点上的整个工程项目的状态;可以在该保存点将多人提交的源码合并, 也可以回退到某一个保存点上。 Git离线操作性:Git可以离线进行代码提交,因此它称...
  • Linux安装FastDFS+Nginx文件服务器

    千次阅读 2018-04-11 15:51:20
    环境准备安装gccFastDFS是C语言开发,建议在linux上运行,文档中使用Centos6.5作为安装环境。安装FastDFS需要先将官网下载的源码进行编译,编译依赖gcc...执行如下命令:yum -y install libevent安装libfastcommonl...
  • 分布式文件系统 FastDFS 5.0.5 & Linux CentOS 7 安装配置

    万次阅读 多人点赞 2016-09-26 09:27:09
    关于分布式文件系统FastDFS在Linux CentOS 7下的安装部署与测试~

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 536,916
精华内容 214,766
关键字:

安装显示可执行文件未成功安装