精华内容
下载资源
问答
  • 找到文件matplotlib-base-3.3.1-py37hba9282a_0.tar.bz2下载到 /Anaconda 3/pkgs 进入cmd命令行,跳转到相应位置。 输入命令conda install --use-local matplotlib-base-3.3.1-py37hba9282a_0.tar..

    到网址(题主电脑是windows64位,其他类型网址向前即可)https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main/win-64/
    找到文件matplotlib-base-3.3.1-py37hba9282a_0.tar.bz2下载到 /Anaconda 3/pkgs

    进入cmd命令行,跳转到相应位置。
    在这里插入图片描述
    输入命令conda install --use-local matplotlib-base-3.3.1-py37hba9282a_0.tar.bz2
    在这里插入图片描述
    如图所示成功。

    展开全文
  • 1、离线安装pip (1)在python的安装目录下,新建packages文件夹,例:C:\Python27\packages (2)https://pip.pypa.io/en/stable/installing/ 下载get-pip.py (3)Unofficial Windows Binaries for Python ...

    1、离线安装pip

    (1)在python的安装目录下,新建packages文件夹,例:C:\Python27\packages

    (2)https://pip.pypa.io/en/stable/installing/ 下载get-pip.py

    (3)Unofficial Windows Binaries for Python Extension Packages 下载pip-8.1.2-py2.py3-none-any.whl和wheel-0.29.0-py2.py3-none-any.whl

    python get-pip.py --no-index --no-setuptools --find-links=.\packages
    

    get-pip.py options
    –no-setuptools
    If set, don’t attempt to install setuptools
    –no-wheel
    If set, don’t attempt to install wheel

    2、查看pip 支持的whl类型

    pip debug --verbose
    https://blog.csdn.net/qq_38161040/article/details/103881372
    

    AMD64

    import pip._internal
    print(pip._internal.pep425tags.get_supported())
    

    WIN32

    import pip
    print(pip.pep425tags.get_supported())
    

    在这里插入图片描述
    在这里插入图片描述

    3、安装Matplotlib

    如果是whl包,安装方法如:

    pip install wheel-0.29......whl
    

    如果下载的不是whl包,在windows下解压的包里有setup.py,则安装方法为:
    先到解压包的目录,如
    在这里插入图片描述
    然后使用命令:

    python setup.py install
    

    (1)需要提前安装:https://pypi.python.org/pypi/six

    (2)需要提前安装:https://pypi.python.org/pypi/numpy

     依次用pip安装: pyparsing ; pytz; setuptools; six; cycler; pytz; python-deteutil; matplotlib;
    

    特别说明:matplotlib的各种依赖包可参考:https://www.lfd.uci.edu/~gohlke/pythonlibs/#matplotlib

    matplotlib的各种依赖库在:https://www.lfd.uci.edu/~gohlke/pythonlibs/ 下载,注意:下载的whl类型要和【2、查看Pip支持的whl类型】一致,否则会出现:
    Installing numpy from wheel format: “…is not a supported wheel on this platform”

    安装的时候出现的警告

    Could not fetch URL https://pypi.python.org/simple/fastnumbers/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host=‘pypi.python.org’, port=443): Max retries exceeded with url: /simple/fastnumbers/ (C
    aused by SSLError(SSLError(1, ‘_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version’),)) - skipping
    Could not find a version that satisfies the requirement fastnumbers (from versions: )
    No matching distribution found for fastnumbers

    https://superuser.com/questions/1336153/pip-cannot-fetch-url-because-of-an-error-with-the-ssl-certificate 介绍是由于python 2.7.6 SSL协议比较老导致的,python 2.7.15就没这问题。不过如果是whl包的形式,目测对安装过程无影响。

    4、验证是否安装成功

    # plot a sine wave from 0 to 4pi
    from pylab import *
    x_values = arange(0.0, math.pi * 4, 0.01)
    y_values = sin(x_values)
    plot(x_values, y_values, linewidth=1.0)
    xlabel('x')
    ylabel('sin(x)')
    title('Simple plot')
    grid(True)
    savefig("sin.png")
    show()
    

    参考网址:http://www.voidcn.com/article/p-djcdtooa-rd.html

    参考网址:https://www.lfd.uci.edu/~gohlke/pythonlibs/

    参考网址:https://segmentfault.com/a/1190000006027207

    参考网址:http://blog.csdn.net/sinat_26933727/article/details/68953193

    展开全文
  • python机器学习第三方插件 numpy matplotlib 及其依赖whl文件包 离线(在线)安装合集,内附安装顺序及执行命令代码
  • 1.linux+anaconda+pytorch离线安装tensorboard参考 其中第二步注意文件夹名字和自己解压缩后的相对应; 第四步安装tensorflow时报错缺少tensorflow-...2.离线安装matplotlib、pandas参考 上述内容全部所需包见 ...

    1.linux+anaconda+pytorch离线安装tensorboard参考

    其中第二步注意文件夹名字和自己解压缩后的相对应;

    第四步安装tensorflow时报错缺少tensorflow-estimator1.14.0,下载安装后仍然报错,暂未解决,但目前可以实现写log文件,只是tensorboard打开报错,解决后来更新

    2.离线安装matplotlib、pandas参考

    上述内容全部所需包

     

    安装成功后导入tensorboard使用:

    from tensorboardX import SummaryWriter

    不要使用

    from torch.utils.tensorboard import SummaryWriter

     

    展开全文
  • matplotlib和numpy离线与镜像下载安装

    千次阅读 2020-02-28 15:51:37
    在python中安装一些扩展包,可以让功能变得更加...第一种方法:离线安装 1、首先下载Numpy,MatplotLib这两个库,网址 https://www.lfd.uci.edu/~gohlke/pythonlibs/ ,我的是python3.5 64bit的,所以下载的就是num...

     

    在python中安装一些扩展包,可以让功能变得更加的强大。自己在刚开始安装的时候也是遇到了一些小问题,现在想记录下来,方便以后自己忘记了,可以翻看。

    第一种方法:离线安装

    1、首先下载Numpy,MatplotLib这两个库,网址  https://www.lfd.uci.edu/~gohlke/pythonlibs/   ,我的是python3.5  64bit的,所以下载的就是numpy-1.13.3+mkl-cp35-cp35m-win amd64.whl 

      如果版本下错了,安装的时候就会报错。

      

    2、cmd   ,然后cd到pip install numpy-1.13.3+mkl-cp35-cp35m-win amd64.whl 的路径,通过pip install numpy-1.13.3+mkl-cp35-cp35m-win amd64.whl进行安装(补充:前提是已经安装好了pip,并且设置好了环境变量,pip在python安装目录的scripts中)

    3、安装后测试是否安装成功

    安装matplotlib同上。

    第二种方法:在线安装(比较推荐,省事)

    1、确保已经安装好了pip

    2、因为直接使用国外的pip镜像安装,可能会失败,这时我们要使用国内的pip镜像,推荐清华大学的https://pypi.tuna.tsinghua.edu.cn/simple

      然后cmd ,接着pip install -i https://pypi.tuna.tsinghua.edu.cn/simple numpy即可,这样就会从清华这边的镜像去安装numpy库。。

      如果想下次使用更方便,直接在user目录中创建一个pip目录,如:C:\Users\xx\pip,新建文件pip.ini,内容如下

    [global]
     index-url = https://pypi.tuna.tsinghua.edu.cn/simple

     

    展开全文
  • apt-get install python3-tk apt install python3-pip pip3 install matplotlib
  • 万事开头难,弄好环境才能开始啊
  • 联网情况下在命令终端CMD中输入“pip install numpy”即可自动安装,pandas和matplotlib同理一样方法进行自动安装。...Python离线断网情况下安装numpy、pandas和matplotlib等常用第三方包的步骤如下: 1、输入...
  • Ubuntu 安装 matplotlib

    千次阅读 2018-04-17 09:46:00
    ubuntu16 安装matplotlib Ubuntu 安装 matplotlib sudo apt-get install libpng-dev libfreetype6-dev pkg-config pip install -i http://pypi.douban.com/simple configparser cd /usr/local/lib/python2.7/dist-...
  • window离线安装pip, wheel, numpy,matplotlib

    千次阅读 2016-04-13 20:26:31
    由于电脑无法联网,只能离线安装, 电脑里只有python 2.7, 下面是安装步骤, 所有的安装包都可以在下面的官网网站下载: http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy1. pip安装 下载对应版本的pip.whl后, 还要...
  • CentOS 7 安装matplotlib

    千次阅读 2016-04-16 22:31:16
    PROBLEMCentOS 7下 安装matplotlib。pip install matplotlib报错如下:[root@localhost Desktop]# pip install matplotlib Collecting matplotlib Using cached matplotlib-1.5.1.tar.gz Complete output from ...
  • 在Mac上面是自带Python的但版本是2.7 第一步:所以第一步就是下载并安装Python3 下载的Python:HTTPS://www.python.org/downloads/mac-osx/下载完成后一路安装就可以了 第二步:更改MAC默认的Python的版本:1,...
  • 说明:首先python与matplotlib就不多介绍了,可以百度。个人也是第一次接触的小白,在安装过程中遇到一些较为难以理解的问题,通过努力解决后,在此做为例子分享出来。工具包下载官网地址:安装环境:windows 7 旗舰...
  • 我装的是python2.7 然后pip的版本是18.1,最近使用pip install **安装包的时候总是会提示 You are using pip ...可以在python安装目录的Scripts文件夹下打开powershell,然后通过指令 easy_install.exe pip==19.1.1 ...
  • Python 安装matplotlib失败解决方法

    千次阅读 2019-11-28 19:53:17
    Python 安装matplotlib失败解决方法(命令提示符安装) 1.直接打开命令提示符(快捷键窗口+ r)2。若提示安装失败(Python - 您正在使用pip版本9.0.1,但版本10.0.1可用。),输入 python -m pip install -U pip ...
  • 安装matplotlib库过程中出现的各种问题以及解决办法,有详细说明。 在网上看见许多matplotlib安装教程都是正确的操作,不同的人安装报错也不一样,对于电脑基础不好的人来说可是一件头疼的事情,一些常见的错误...
  • Python3.6安装matplotlib

    万次阅读 多人点赞 2018-01-08 16:27:57
    Matplotlib 是一个 Python 的 2D绘图库,它以各种硬拷贝格式和跨平台的交互式环境生成出版质量级别的图形。 找到python3.6的安装目录,如C:\Users\admin\AppData\Local\Programs\Python\Python36 进而进入到...
  • https://blog.csdn.net/sundan93/article/details/62888068
  • Python 3.7安装matplotlib

    千次阅读 2019-12-05 23:12:03
    使用pip命令安装pip install matplotlib 下载的速度堪忧 或者在这个官网上面下载:https://pypi.org/project/matplotlib/#files 选择好版本,下图为Python3.7 window64 在官网下载的话,要切盘到你下载的文件夹的...
  • 安装matplotlib时subprocess32安装出错

    千次阅读 2017-10-18 15:52:14
    subprocess32模块现在已经被subprocess取代了,已经很久不更新,现在安装...这样导致matplotlib没法安装。 解决办法: 下载matplotlib源码,把setup.py中的setupext.Subprocess32(),这一行注释掉, 然后编译就好了。
  • Ubuntu 16.04安装Matplotlib

    万次阅读 2016-06-12 10:01:11
    直接pip安装报错:python setup.py egg_info” failed with error code 1 in /tmp/pip-build-B0c0uV/matplotlib/ 解决方案sudo apt-get install libfreetype6-dev libxft-dev sudo pip install matplotlib
  • 安装numpy和matplotlib

    2017-11-16 16:47:00
    看到其他博客总结的一篇,以此拿来学习: 安装numpy和matplotlib 在python中安装一些扩展包,可以...第一种方法:离线安装 1、首先下载Numpy,MatplotLib这两个库,网址 https://www.lfd.uci.edu/~gohlke/python...
  • Linux下安装matplotlib

    千次阅读 2018-10-10 21:03:30
    一:在Python编程从入门到实践这本书之中讲到linux下安装matplotlib 直接说是使用了一下命令   sudo apt-get install python3-matplotlib 如果是Python2.7则使用 sudo apt-get insta...
  • 在Pycharm中安装matplotlib

    千次阅读 2020-10-15 21:19:16
    一、在Pycharm中安装matplotlib 1、打开Anaconda Prompt ,输入 pip install matplotlib 输入 pip install matplotlib==3.3.0 限制下载的版本为3.3.0. 这是为了防止版本过新,之后在PyCharm运行时出现问题。 2、...
  • 一、matplotlib安装: 1、安装指令: pip3 install -U matplotlib 2、安装完成的提示如下: 二、终端测试 三、代码测试(这里直接使用官方给的样例:...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,103
精华内容 841
关键字:

安装离线matplotlib