精华内容
下载资源
问答
  • npm降级与解决npm降级出现的问题

    千次阅读 2020-05-23 23:41:03
    npm降级与解决npm降级出现的问题 **1.先进行降级测试** 执行 npm install nom@6.13.4 -g @6.13.4这是指版本号,更换一下就就好。运行完成后执行 npm -v 查看版本是否正确。正确即成功。 **2.**npm降级会出现卡死...

    npm降级与解决npm降级出现的问题

    1.先进行降级测试
    执行 npm install nom@6.13.4 -g
    @6.13.4这是指版本号,更换一下就就好。运行完成后执行 npm -v 查看版本是否正确。正确即成功。
    2.npm降级会出现卡死的情况
    今天博主出现了npm降级卡死,一个多小时无法运行,出现:
    rollbackFailedOptional: verb npm-session 32706576fcadeac0
    卡在这个行不动,下面是解决的问题
    2.1 查看npm的镜像

    npm config get registry
    

    2.2 查看cnpm的镜像

    cnpm config get registry
    

    我们在安装时都会装一个淘宝镜像,如果cnpm没有设置或者两个都没包含
    https://registry.npm.taobao.org
    那就是没有安装淘宝镜像。
    2.3 设置镜像

    npm install -g cnpm --registry=https://registry.npm.taobao.org
    

    设置cnpm为淘宝镜像

    npm config set registry https://registry.npm.taobao.org
    

    这是设置npm的镜像,无推荐意见。可不装不影响降级
    3.进行降级
    先检查一下自己的镜像,确认一下那个对应的淘宝镜像
    例如:cnpm

    cnpm install npm@6.13.4 -g
    

    需使用淘宝镜像进行降级操作。@6.13.4是版本!是版本!是版本!
    重要的事情说三遍!希望本文对大家有帮助!点个赞吧!
    淘宝镜像文章转自:https://blog.csdn.net/qq812858143/article/details/81775861

    展开全文
  • npm降级node不兼容报错

    千次阅读 2019-05-09 08:44:00
    You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.Please use either the version of npm that is bundled with Node.js, or a version of npm (>...

    You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.
    Please use either the version of npm that is bundled with Node.js, or a version of npm (> 5.5.1 or < 5.4.0) or node-tar (> 4.0.1) that is compa
    tible with Node.js 9 and above.

    --------------------------------------

    解决办法: 

    1.npm uninstall -g npm

    2.npm install -g npm

    转载于:https://www.cnblogs.com/tenghuiling/p/10836424.html

    展开全文
  • npm降级后损坏

    2021-08-03 09:16:24
    由于up主安装sass一直不成功又没用yarn看了一些博客说需要降级npm,于是敲了npm intsall -g npm@3.x 结果 依赖损坏,什么都用不了。 解决方法 大多数方法对我都没有效果。我的方案是删除一切与npmnode有关的东西,...

    起因

    由于up主安装sass一直不成功又没用yarn看了一些博客说需要降级npm,于是敲了npm intsall -g npm@3.x

    结果

    依赖损坏,什么都用不了。
    在这里插入图片描述

    解决方法

    大多数方法对我都没有效果。我的方案是删除一切与npmnode有关的东西,重新安装node就能恢复npm。但是其它的脚手架也要重装。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    删得干干净净,再从腾讯管家下载node.js安装,node -vnpm-v好起来了。
    记录一下问题,千万别随便轻信别人的教程,有可能是骇人鲸

    展开全文
  • 如何给npm降级

    万次阅读 2017-09-09 14:30:52
    最近一直在用npm v5,没什么问题。 直到今天玩 create-react-native-app 的时候发现,它们...于是想暴力解决问题——直接上网搜索,结果没找到什么有用的方法,最有用的居然是到node的文件夹里 npm install npm NO

    最近一直在用npm v5,没什么问题。

    直到今天玩 create-react-native-app 的时候发现,它们“强烈推荐”使用npm v3或者v4,因为v5还有些bug没解决,对于create-react-native-app不稳定。


    简单暴力的方法是:

    npm i npm@4 -g


    但感觉有点不安全。


    还是自己解决吧。


    首先,介绍一下nvm (node version manager),有了它,妈妈再也不用关心我的node版本管理问题了。

    *大提示:装nvm之前,建议把现有的所有nodejs版本全部删除,以后就让nvm全权管理就好了。保存着旧的node反而容易造成版本管理的困难。

    官网nvm安装指南:https://github.com/creationix/nvm#installation


    nvm有了后,直接去装对应版本的nodejs就好了。

    node 8 对应 npm v5.

    node 7 对应 npm v4


    如果需要npm v5, 则

    nvm install 8
    nvm use 8


    然后如果需要npm v4了,装上node 7就可以了

    nvm install 7
    nvm use 7

    这时再试试

    npm version
    { npm: '4.2.0',
      ares: '1.10.1-DEV',
      cldr: '30.0.3',
      http_parser: '2.7.0',
      icu: '58.2',
      modules: '51',
      node: '7.9.0',
      openssl: '1.0.2k',
      tz: '2016j',
      unicode: '9.0',
      uv: '1.11.0',
      v8: '5.5.372.43',
      zlib: '1.2.11' }

    *注意:只是"nvm use"的话,每次新开一个terminal都需要重新指引一下node的版本。

    如果你需要长期使用“另类”版本,可以把修改一下默认的版本,原理就是给“default”赋值:

    nvm alias default 7


    展开全文
  • node npm nrm nvm gnvm 相爱相杀

    千次阅读 2018-05-31 16:49:01
    写这篇文章之前我遇到了一个坑,为了一个坑我花了两天时间去搞懂里面的原理。 接下来我会围绕以下几点进行分析: ...npm降级 在 create-react-native-app 的时候发现,它们“强烈推荐”使用n...
  • npm 降级的时候npm报错的处理

    千次阅读 2018-07-24 14:10:17
    报错的原因是,在全局的node_modules找不到npm,此时需要打开node的cmd,重新全局安装    
  • 百度之后说给npm降级或者升级 降级 : npm install -g npm@5.4.0 升级 : npm install -g npm 升级到最新版 结果降级之后再尝试的时候就直接报版本跟node.js不兼容的问题,然后各种在升级都不好使,只能重新删掉在...
  • npm降级

    2019-04-09 18:28:00
    npm 降级 $ npm -v 6.4.1 $ sudo npm install npm@4 -g /usr/bin/npm -> /usr/lib/node_modules/npm/bin/npm-cli.js + npm@4.6.1 added 208 packages from 116 contributors, removed 296 packages and updated ...
  • 最近在npm install 的时候遇到一个奇怪的错误,找了很久都没找到原因,错误是: npm ERR! code 1 npm ERR! path D:\htz\web\htz_web_app\node_modules\node-sass npm ERR! command failed npm ERR! command C:\...
  • 百度说给npm降级或者升级 降级 : npm install -g npm@5.4.0 升级 : npm install -g npm 升级到最新版 npm报错以及卸载node C:\Users\Administrator\Desktop\vue>npm install WARNING: You are likely using a ...
  • node版本降级

    千次阅读 2020-04-06 20:42:13
    因为node版本太高,导致npm run dev报错。那么如何降级呢? (1)安装node版本管理模块n sudo npm install n -g 下边步骤请根据自己需要选择 (2)安装稳定版 sudo n stable (3)安装最新版 sudo n ...
  • 解决这一问题的办法一般采用将node版本降级。而nvm正是管理node版本的工具,使用对应命令行即可将自己的电脑node版本降级至指定版本。下面我来说下如何在mac上安装并nvm同时使node版本降级。 1、安装nvm curl -o-...
  • 通过brew安装nodenpm brew install node//此命令默认安装最新版本的node brew search node//查询可用的node版本 brew install node@10 //安装指定版本的node 若要进行node版本降级: 之前使用brew install ...
  • nodenpm不兼容

    千次阅读 2019-08-09 19:11:33
    电脑重装系统,node卒,从官网下载了node(v10.16.1)安装成功,通过npm下载模块时报错(没有截图) WARNING: You are likely using a version of node-tar or npm that is incompatible with this version of Node.js...
  • nodenpm不兼容的问题

    千次阅读 2019-05-08 21:59:16
    今晚手贱,升级了node的版本,结果在使用npm安装依赖包的时候出现了下面这样的错误,大概的意思就是nodenpm不兼容,刚开始百度,找到的办法是npm版本降级,执行命令以后,还是出现这样的问题,通过种种的解决办法...
  • 如果使用方法二,将nodejs路径链接到/usr/local/bin目录下,则每次npm -g安装插件都会安装在nodejs原路径下的node_modules(比如/home/ubuntu/node-v8.1.0-linux-x64/lib/node_modules),每次代码中引用插件也需要到...
  • node版本降级和升级

    千次阅读 2020-03-18 11:43:38
    n 是node 的简写,i 是install的简写 ... 第一步:sudo npm i-g n 第二步:sudo n10.16.0 即可降级到10.16版本 如何升级到最新版本? sudo n latest node -v 查看版本即可 ...
  • linux和window上node.js的安装/升级/降级, 以及cnpm代替npm 常用命令 n模块安装与管理切换node版本 npm升级降级
  • node版本降级(mac下)

    万次阅读 2019-06-20 11:28:54
    我有一个项目,因为node版本太高,导致npm run dev报错。那么如何降级呢? (1)安装node版本管理模块n sudo npm install n -g 下边步骤请根据自己需要选择 (2)安装稳定版 sudo n stable (3)安装最新...
  • node版本降级(mac)

    2021-05-26 10:53:42
    我有一个项目,因为node版本太高,导致npm run dev报错。那么如何降级呢? (1)安装node版本管理模块n sudo npm install n -g 下边步骤请根据自己需要选择 (2)安装稳定版 sudo n stable (3)安装最新版 ...
  • I just installed Node.js and npm (for additional modules).How can I update Node.js and the modules which I'm using to the latest versions?Can npm do it, or do I have to remove and reinstall Node.js an...
  • (1)安装node版本管理模块n sudo npm install n -g 下边步骤请根据自己需要选择 (2)安装稳定版 sudo n stable (3)安装最新版 sudo n latest (4) 版本降级/升级 sudo n 版本号 比如需要8.4.0版: (5)...
  • 公司入职需要对应的 node 版本,自己电脑无脑型最新版本,现需降到所需版本。 使用nvm来管理node nvm安装传送门 选择如下setup安装包 安装完成后,输入 nvm 指令,会出现如下相关帮助指令: 切换版本 使用 nvm ...
  • node升级&npm升级

    2017-03-11 18:43:21
    node升级: windows:https://github.com/Kenshin/gnvm linux: 先清除npm的cache:sudo npm cache clean -f  安装n模块:sudo npm install -g n  直接安装NodeJS的稳定版: sudo n stable  或...
  • MAC node降级,gitbook/Node.js文件拷贝

    千次阅读 2018-07-06 16:20:48
    事情源于之前写的两个gitbook插件都用到文件拷贝功能,当时...2. 使用Node.js内置的对象方法实现文件拷贝; 两个思路执行历程: 思路一,google了N久,只找到了在浏览器环境下的判断方法,如https://www.cnblogs.c...
  • nodenpm一行命令升级最新版本

    万次阅读 2018-05-28 11:14:28
    今天想搞搞nuxt,就按照官网的那样下载一个类似vue脚手架类似的 starter 模板。 ...注: 如果vue-cli 没有安装, 需先通过 npm install -g vue-cli 来安装。 # 然后安装依赖包 $ cd &amp;l...
  • node版本如何降级

    千次阅读 2019-11-08 19:09:04
    (1)安装node版本管理模块n sudo npm install n -g 下边步骤请根据自己需要选择 (2)安装稳定版 sudo n stable (3)安装最新版 sudo n latest (4) 版本降级/升级 sudo n 版本号//例如:sudo n 9.1.7 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,807
精华内容 1,122
关键字:

nodenpm降级