精华内容
下载资源
问答
  • nodejs降级为低版本

    2021-08-24 16:37:14
    这篇文章的起因是我想写一个js 的原生项目,讲解的视频用的是gulp3.9.1打包工具,安装完gulp3.9.1之后,打包时会报错,主要原因是nodejs版本过高,因而本文章主要介绍了windows如何把已安装的nodejs高版本降级为低...

    这篇文章的起因是我想写一个js 的原生项目,讲解的视频用的是gulp3.9.1打包工具,安装完gulp3.9.1之后,打包时会报错,主要原因是nodejs版本过高,因而本文章主要介绍了windows如何把已安装的nodejs高版本降级为低版本,本文分步骤通过图文并茂的形式给大家介绍的非常详细,对大家的学习或工作具有一定的参考借鉴价值,需要的朋友可以参考下:

    第一步:先清空本地安装的node.js版本

    1.不记得安装位置的话:按健win+R弹出窗口,键盘输入cmd,然后敲回车(或者鼠标直接点击电脑桌面最左下角的win窗口图标弹出,输入cmd再点击回车键),然后进入命令控制行窗口,并输入where node查看之前本地安装的node的路径;
    知道安装位置的话可以查看下一步。
    在这里插入图片描述2.进入安装位置,将node.exe所在的父目录里面的所有东西都删除;
    3.为了彻底删除之前安装的node.js,鼠标点击电脑左面最左下角的win窗口图标弹出,输入“控制面板”再点击回车键进入,进入控制面板后,找到所安装的node.js并卸载。

    第二步:安装nvm管理工具(先关掉360等软件,不然会弹出警告!)
    1.从官网下载安装包 https://github.com/coreybutler/nvm-windows/releases,下载红框里面的那个:
    在这里插入图片描述
    2.将下载下来的压缩包进行解压(随便解压到任一你喜欢的位置),解压文件夹里面是一个.exe文件;
    3.开始进行nvm安装:
    (1) 鼠标双击nvm-setup.exe文件,选择“我接受…”那一行,点击next
    (2) 可以根据自身情况自定义选择路径盘,路径不要出现空格或中文符号(路径最好是在路径盘的根目录下,如C盘、D盘下的根目录),我自己选择D盘根目录。选好后点击next;
    在这里插入图片描述
    (3) 选择node.js的安装位置,可以根据自身情况自定义选择路径盘,路径不要出现空格或中文符号(路径最好是在路径盘的根目录下新建一个文件夹,如C盘、D盘下的根目录),我自己在D盘根目录下新建一个nodejs文件夹。选好后点击next;
    在这里插入图片描述
    (4) 最后一步,点击install即可安装完成。
    2.nvm安装完成后,检验是否安装成功,进入命令控制行窗口,输入命令nvm v查看,如果出现版本号,即安装成功(如果安装不成功,查看之前自己安装的node.js有没有删除彻底、安装nvm工过程有没有漏掉什么!)。

    3.接下来就是安装node.js版本
    (1) 输入命令行nvm ls anaillable查看可用的node.js版本号(ls, 不是1s
    在这里插入图片描述
    (2) 输入命令行nvm install node版本号(例如:nvm install 12.17.0)即可安装对应版本以及自动安装对应的npm版本。除了上面显示的node.js版本,其他版本号也可以下载,只不过有些可以准确下载,有些会出现npm版本不会自动下载。
    安装过程中,我出现了另外一问题,就是在这里插入图片描述
    这个问题比较好解决,打开nvm的安装路径,找出settings.txt文件
    打开settings.txt文件,在此文件添加此下载包的包来源(建议直接复制粘贴)
    node_mirror: https://npm.taobao.org/mirrors/node/
    npm_mirror: https://npm.taobao.org/mirrors/npm/
    添加完毕之后,重新输入 nvm install 10.20.1 就可以顺利安装了。
    安装完成之后,按照提示,先输入一个 nvm use 10.20.1(10.20.1是之前安装的node的版本号,按照你安装的版本写就行),之后就可以输入 node -v 以及 npm -v 进行验证了。
    在这里插入图片描述
    (3) 输入命令行nvm ls查看你安装的所有node.js版本号,以及你当前所选择的node.js运行版本(我自己安装了两个版本号, “ * ”表示当前使用的版本是10.20.1版本),这也是为什么之前需要 nvm use 10.20.1的原因了,因为有两个版本,主要明确使用那个版本。
    在这里插入图片描述

    到这里,nodejs 降版本的安装过程就全部结束了,祝愿大家学习愉快!!!

    完整的安装流程我是参考的这个博文,有一丢丢的不一样的地方,已经改正,大家有问题可以留言交流参考链接

    不当之处,欢迎大家指正。

    展开全文
  • 如何nodejs 降级,安装低版本

    万次阅读 2018-06-24 17:00:54
    读在前面万恶的fis3,不能使用最新版本的node,既然改变不了它,那只能我们适应它了,所以我们要学习下如何对nodejs进行降级。使用的工具是nvm(Node Version Manager - Simple bash script to manage multiple ...

    读在前面

    万恶的fis3,不能使用最新版本的node,既然改变不了它,那只能我们适应它了,所以我们要学习下如何对nodejs进行降级。

    使用的工具是nvm(Node Version Manager - Simple bash script to manage multiple active node.js versions)

    ps:NVM支持OS X、Linux,但不支持windows(快换电脑吧)

    如何安装

    在终端里执行命令

    curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.33.0/install.sh | bash

    安装完后,看看安装成功没有

    command -v nvm

    若安装成功,会输出nvm;否则,请尝试重启shell。

    不过我执行上面的命令啥也没提示,运行nvm还告诉你

    nvm: command not found

    而且重启终端也没用!!那莫慌,如果你是OS X的系统,就执行一下

    touch ~/.bash_profile

    再执行上面的安装命令就好了。(啥,你是linux的,那你还是换苹果吧)

    装完就可以使用了

    常用命令

    列出所有版本:

    nvm ls-remote

    安装指定版本(如nvm install v4.4.7):

    nvm install <version>

    使用指定版本(修改PATH):

    nvm use <version>

    查看当前使用版本:

    nvm ls

    via: https://github.com/creationix/nvm



    作者:壮哉我大前端
    链接:https://www.jianshu.com/p/9db465d60325
    來源:简书
    简书著作权归作者所有,任何形式的转载都请联系作者获得授权并注明出处。
    展开全文
  • 现在Nodejs最新的版本已经是16+了,但用了最新的版本以后,会出现canvas和node-saas等组件安装不了的情况,还会报一堆莫名的错误,后来发现降至14+的版本就可以解决此问题,故将降级办法写下来,以备忘。 二、操作...

    一、需求背景

    现在Nodejs最新的版本已经是16+了,但用了最新的版本以后,会出现canvas和node-saas等组件安装不了的情况,还会报一堆莫名的错误,后来发现降至14+的版本就可以解决此问题,故将降级办法写下来,以备忘。

    二、操作步骤

    2.1 安装node版本管理模块 n

    sudo npm install n -g
    

    2.2 可以根据自己的需要选择安装版本[可选]

    2.2.1 安装稳定版

    sudo n stable
    

    2.2.2 安装最新版

    sudo n latest
    

    2.3 版本降级/升级

    sudo n 版本号
    

    版本号可以在此处查询:
    https://nodejs.org/en/download/
    在这里插入图片描述

    //例如:

    sudo n 14.1.7.3
    

    三、项目样例

    微服务项目,前端采用vue的方案:

    展开全文
  • C:\Users\Administrator\AppData\Local\npm-cache\_logs\2021-09-02T14_15_40_335Z-debug.log npm版本无需单独安装,卸载后重新下载对应版本的nodejs重新安装即可。 下载地址: ...
  • nodeJS如何快速升级降级

    千次阅读 2020-10-24 20:59:50
    我笔记本上的nodeJS是10版本的,在运行前端VUE项目时,报错,具体错误信息为: 咳咳咳,没有记录下来。。 总而言之,项目用的是8版本,我的是10版本,跑的时候有问题,所以需要降级。 具体的降级方法一共有3步: 1、...
  • I just installed Node.js and npm (for additional modules).How can I update Node.js and the modules which I'm using to the latest versions?Can npm do it, or do I have to remove and reinstall Node.js an...
  • ubuntu升级或降级nodejs

    千次阅读 2018-07-09 16:02:13
    2、通过n安装nodejs (stable 表示安装最新稳定版 根据下载源 安装需要的时间不同) $ n stable 安装制定版本使用n 版本号,如n 8.11.2 注意如果从高版本降到低版本,高版本会被删除;低版本到高版本都会存在 ...
  • linux 降级nodejs到9

    千次阅读 2019-07-05 16:16:47
    n 9
  • windows中如何将已安装的nodejs高版本降级为低版本

    千次阅读 多人点赞 2020-11-27 18:15:44
    选择node.js的安装位置,可以根据自身情况自定义选择路径盘,路径不要出现空格或中文符号(路径最好是在路径盘的根目录下新建一个文件夹,如C盘、D盘下的根目录),我自己在D盘根目录下新建一个nodejs文件夹。...
  • 一、安装 推荐使用方法一 如果是docker环境可能需要先执行: apt update apt install sudo apt install curl 方法1: curl -sL ...sudo apt-get install -y nodejs ...如果安装nodejs 9.x...
  • spawn C:\Program Files\nodejs\node.exe ENOENT

    千次阅读 2018-02-05 23:40:12
    nodejs开始安装的是7,然后重装系统后装了版本8,npm install时就报错,npm -v也报错,后来查了下,将nodejs 降级到版本7,在更新npm  npm rebuild node-sass npm update
  • 首先 node -v 查看当前版本,如果当前版本不合适可以安装指定版本的nodejs 清除sudo npm cache clean --force 升级之前需要安装n模块,sudo npm install -g n 安装n模块后,n -V查看版本 最后升级指定版本的...
  • nodejs修改版本

    千次阅读 2019-01-13 11:46:20
    有时候我们需要被迫的升级或者降级nodejs的版本,这个时候就问题来了,怎么弄呢,总结如下,一共发现两种,下面就这两种情况下变更nodejs的版本说一说,nvm跟n都是nodejs的版本管理库,都可以用看个人习惯。...
  • nodejs 面经

    2021-08-25 11:29:30
    都2021了,还有人找nodejs的工作,怕不是疯了吧。可能是运气好,面了很多家公司,也拿了不少offer,最终选择的公司,工作环境和福利都还不错。以下分享以下面经,答案自查。 由于很多公司的node都是前端同学转的,...
  • 1,下载node安装包https://github.com/electron/electronElectron 是 Github 发布跨平台桌面应用开发工具,支持 Web 技术开发桌面应用开发,其本身是基于 C++ 开发...mac 安装node 6.10.3.pkg https://nodejs.org/直接
  • nodejs安装总结

    2017-12-04 21:04:16
    nodejs以及express安装步骤:1.选定安装路径 假设安装在D盘test文件中2.命令行输入 D:3.命令行输入cd d:\test4.全局安装express 命令行输入: install express-generator5.命令行输入:npm install express6.创建...
  • nodejs(一) 简介

    2017-03-13 11:12:06
    nodejs 简介
  • nodejs npm 学习笔记

    2021-05-28 16:36:41
    文章目录基础安装npm安装卸载依赖RunScriptError: post install error, please remove node_modules before retry! 删除 node_modulesnodejs 清空 npm 缓存npm模块功能更新...nodejs就是js的运行环境 jvm npm就是包管
  • nodejs连接mysql的历程

    千次阅读 2018-07-09 23:28:24
    之后下载mysql,这里要注意版本问题,nodejs连接mysql只支持mysql5.7+的版本,之前先下载了最新版本8.0+,连接时调试多次,尝试过调整package.json等文件、密码等级降级等等,一直失败,后来看到一个帖子说版本过高...
  • 安装 nodejs & npm & yarn

    2019-12-02 09:59:56
    NVM  nvm就是nodejs version manage 叫做nodejs 版本管理,... 假设你正在开发的项目开始使用的nodejs版本是8.0,而现在因为某些原因,你需要升级 或者 降级 nodejs 版本,也可以使用 nvm 轻松切换 搭建步骤:  ...
  • Centos7安装Nodejs-v12.6.0

    2020-11-29 13:51:26
    安装Nodejs Nodejs官网下载 Nodejs列表 cd /opt wget https://nodejs.org/dist/v12.6.0/node-v12.6.0-linux-x64.tar.gz tar -zxvf node-v12.6.0-linux-x64.tar.gz mv node-v12.6.0-linux-x64 nodejs ln -s /opt/...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,925
精华内容 1,170
关键字:

nodejs降级