精华内容
下载资源
问答
  • OSPF中的nssastub

    2010-02-24 20:17:36
    OSPF中的nssastub 2007-06-15 17:29:33  标签:OSPF nssa stub [推送到技术圈] NSSA原理简介众所周知,OSPF路由协议是目前因特网中应用最为广泛一种IGP,而NSSA则是在该协议发展过程中产生的...
    OSPF中的nssa与stub
    2007-06-15 17:29:33
     标签: OSPF nssa stub    [ 推送到技术圈]

    NSSA原理简介
    众所周知,OSPF路由协议是目前因特网中应用最为广泛一种IGP,而NSSA则是在该协议发展过程中产生的一种新的属性,她的英文全称是"not-so-stubby" area,一个充满了幽默味道的名字。要想了解该属性的特征,我们先从路由协议的发展历程讲起。
    1.2   从D-V算法到链路状态算法
    RIP作为最古老的动态路由协议,使用D-V算法来计算路由。由于当时的网络环境非常简单,所以RIP协议的设计思想也是简洁为本,只求完成最基本的功能。这样在RIP应用于大型拓扑复杂的网络时,就会出现效率不高、收敛慢、路由自环等问题。其中尤以路由自环的危害最大。此时必须有新的路由协议来适应日益复杂的网络,而且新的路由协议必须要解决RIP遇到的所有问题。由于D-V算法对网络的理解是基于“平面的”——在运行RIP协议的路由器眼中,网络仅仅是由一个个直连的邻居和一条条由邻居通告的路由组成。这样在网络拓扑变化时难免会导致计算错误,产生自环。为了彻底解决这个问题,一种全新的算法——链路状态算法应运而生。该算法从“立体”的角度来看待网络,每一台路由器都理解全局网络的拓扑结构,并依据此来计算路由,由于每台路由器对网络的整体情况 “一切尽在掌握”,所以自环的问题被这彻底的解决。
    1.3   OSPF协议与区域
    基于链路状态算法的OSPF协议虽然彻底的解决了路由自环问题,但这种算法本身也有很多固有的缺陷:
    耗费更多内存资源:每台路由器都必须保存整个网络的拓扑结构(以LSDB的形态)
    耗费更多CPU资源:该算法的路由计算使用SPF算法,较D-V算法要复杂的多。
    计算更为频繁:只要网络中有任何一台路由器的拓扑方生变化,会导致网络中所有的路由器进行SPF计算,而且每台路由器都是将SPF算法重新执行一遍,以便找出变化的路由。
    而且,无论是D-V算法还是链路状态的路由协议都存在如下缺陷:
    没有从协议本身反映出网络的层次结构。因为实际应用中的一个网络是由各种级别的路由器组成的,有核心层的骨干路由器、汇聚层的高端路由器、接入层的低端路由器。这些路由器承担的任务不同,处理性能也不一样。但在路由协议中,所有的路由器都要完成几乎是相同的工作:发送已知的路由给邻居路由器,根据从邻居路由器获得的路由信息计算本地路由表。虽然每台路由器的接口数量不同,但最终计算得来的路由表的规模基本是一样的。

    为了彻底解决上述问题,OSPF提出了区域的概念(AREA),区域是将所有运行OSPF 的路由器人为的分成不同的组,以区域id来标示。在区域内路由计算的方法不变,由于划分区域之后,每个区域内的路由器不会很多,所有上述缺陷表现得并不严重,带来的后果可以忽略不计。而在区域之间计算路由时采用D-V算法,这样三个缺点就被成功的规避了。实际上区域概念的提出意义远不只这些,在划分为区域之后:

    网络的拓扑结构就与路由协议之间存在了一种对应关系,核心和高端的路由器由于处理能力强,可以规划在骨干区域之中。因为骨干区域的路由器要承担更多的路由计算任务。
    每个单独的区域实际上就是一个独立于网络中其他区域的系统,可以在不同的区域中试行不同的路由策略,使组网规划更为灵活方便。

    实际上OSPF 协议在当今的网络中广为流行,不是因为她使用了无环路的链路状态算法,而是因为她提出了区域的概念!

    1.4   STUB区域
    STUB区域就是一个对区域概念的最典型的应用。STUB区域的设计思想在于:在划分了区域之后,非骨干区域中的路由器对于区域外的路由,一定要通过 ABR(区域边界路由器)来转发,或者说对于区域内的路由器来说ABR是一个通往外部世界的必经之路。既然如此,对于区域内的路由器来说,就没有必要知道通往外部世界的详细的路由了,代之以由ABR向该区域发布一条缺省路由来指导报文的发送。这样在区域内的路由器中就只有为数不多的区域内路由和一条指向 ABR的缺省路由。而且无论区域外的路由如何变化,都不会影响到区域内路由器的路由表。由于区域内的路由器通常是由一些处理能力有限的低端路由器组成,所以处于STUB区域内的这些低端设备既不需要保存庞大的路由表,也不需要经常性的进行路由计算。有了STUB属性之后,网络的规划更符合实际的设备特点。

    以上描述的只是STUB区域的设计思想,在协议文本中,对STUB区域的精确定义是:STUB区域一定是非骨干区域和非转换区域(可以配置虚连接的区域),并且在该区域中不可传递Type 5类型的LSA。因为协议的设计者认为路由表中的绝大部分路由均是来自自治系统外部的引入的路由。(由于OSPF是链路状态算法的路由协议,LSA就是用来描述网络拓扑结构的一种数据结构。在OSPF 中将LSA分为5类:type1、2两种用来描述区域内的路由信息;type3用来描述区域间的路由信息;type4、5用来描述自治系统外部的路由信息。)

    需要注意的是定义中对于过滤TYPE5类型的LSA使用的描述语言是“不可传递”,这就意味着不仅区域外的ASE(自治系统外部)路由无法传递到STUB 区域中,同时STUB区域内部的ASE路由也无法传递到本区域之外。换一句更通俗的话来描述:STUB区域内的路由器都不可引入任何外部的路由(包括静态路由)。

    这样的定义未免太过严厉了。因为在实际的组网中,并不是所有的设备都会运行OSPF协议。例如:用户拨号上网时使用的接入服务器就需要连接路由器上因特网,但通常接入服务器上并不支持(也不需要)OSPF协议,而是通过配置静态路由实现路由功能。很多时候ISP为了保密或易于管理的需要,在连接用户侧的路由器时使用静态路由。总之:在一个网络中所有的路由器上都配置OSPF,而不使用静态路由的情况几乎是不存在的。——也就是说STUB区域的适用条件也是不存在的。

    1.5   NSSA区域
    STUB区域虽然为合理的规划网络描绘了美好的前景,但她在实际的组网中又不具备可操作性,未免遗憾。但此时的OSPF协议已经基本成型,不可能再做大的修改。为了弥补缺陷,协议设计者提出了一种新的概念NSSA,并且作为OSPF协议的一种扩展属性单独在RFC 1587中描述。

    NSSA需要完成如下任务:

    自治系统外的ASE路由不可以进入到NSSA区域中,但是NSSA区域内的路由器引入的ASE路由可以在NSSA中传播并发送到区域之外。即:取消了 STUB关于ASE的双向传播的限制(区域外的进不来,区域里的也出不去),改为单向限制(区域外的进不来,区域里的能出去)。
    由于是作为OSPF标准协议的一种扩展属性,应尽量减少与不支持该属性的路由器协调工作时的冲突和兼容性问题。

    为了解决ASE单向传递的问题,NSSA中重新定义了一种LSA——Type 7类型的LSA,作为区域内的路由器引入外部路由时使用,该类型的LSA除了类型标识与Type 5不相同之外,其它内容基本一样。这样区域内的路由器就可以通过LSA的类型来判断是否该路由来自本区域内。但由于Type 7类的LSA是新定义的,对于不支持NSSA属性的路由器无法识别,所以协议规定:在NSSA的ABR上将NSSA内部产生的Type 7类型的LSA转化为Type 5类型的LSA再发布出去,并同时更改LSA的发布者为ABR自己。这样NSSA区域外的路由器就可以完全不用支持该属性。

    从上述描述可以看出:在NSSA区域内的所有路由器必须支持该属性(包括NSSA的ABR),而自治系统中的其他路由器则不需要。

    由于NSSA是由STUB区域的概念改进得来,所以她的名字叫做: "not-so-stubby" area ,本意是:不是那么STUB的区域。
    第2章   NSSA相关配置
    NSSA的原理不复杂,配置更简单,相关命令只有一条:

    [Router-ospf]
    area area-id nssa  [ default-route-advertise ] [ no-import-route ] [ no-summary ]
    area-id:是需要配置成NSSA的区域的区域号。“[]”内的参数只有在该路由器是ABR时才会生效。
    关键字default-route-advertise用来产生缺省的Type-7 LSA,应用了该参数后,在ABR上无论路由表中是否存在缺省路由0.0.0.0,都会产生Type-7 LSA缺省路由;而在ASBR上当路由表中存在缺省路由0.0.0.0,才会产生Type-7 LSA缺省路由。

    关键字no-import-route用在ASBR上,使得OSPF通过import-route命令引入的路由不被通告到NSSA区域。如果NSSA的路由器既是ASBR也是ABR,一般选用该参数选项。

    为了进一步减少发送到NSSA区域中的链路状态发布(LSA)的数量,可以在ABR上配置no-summary属性,禁止ABR向NSSA区域内发送 summary_net LSAs(Type-3 LSA)。配置该参数后,ABR会将Type3类型的LSA也过滤掉,即:NSSA区域中也不会出现区域间路由,路由表进一步精简。既然有缺省路由,那么其他指向区域外的具体路由都是没有必要的了。该参数推荐配置。

    即:如果路由器只是一台区域内路由器,只需配置area area-id nssa即可。如果是ABR,根据实际需要,选择添加三个可选参数。

    转载于:https://blog.51cto.com/wirless/278412

    展开全文
  • OSPF NSSA-NSSA Totally Stub

    2010-05-02 14:27:17
    注:<1>key-id的取值范围是0-255,password可由数字字母组成的最长16个字符的密码;  配置多个MD5密钥需要切换时,在接口配置使用命令  ip ospf authentication message-digest  ip ospf message-digest-key ...
    实验目的:
    1、掌握多区域的OSPF配置:
        在OSPF中,路由器可以属于多个区域,但是路由器的一个接口只能属于一个区域。
    2、区别不同区域的路由:
            区域内的路由:在路由选择表中用大写字母 O 表示;
            区域间路由:在路由选择表中用 IA 表示;
            默认路由:在路由选择表中用 O*IA 表示;
      
    3、掌握OSPF的路由汇总配置:
        在路由配置模式下,使用命令
             area area-id range summary-address summary-mask
        其中area-id是指被汇总地址所在的区域
    4、身份验证:
               (1)OSPF接口认证:
                   明文的:在接口配置模式下,使用命令
                           ip ospf authentication
                           ip ospf authentication-key [password]
                    MD5的:在接口配置模式下,使用命令
                           ip ospf authentication message-digest
                           ip ospf message-digest-key [key-id] md5 [password]
              (2)区域认证的配置方法:
                    明文的:在路由配置模式下,使用命令
                            area [area-id] authentication
                            在接口配置模式下,使用命令
                            ip ospf authentication-key [password]
                  
                    MD5的:在路由配置模式下,使用命令
                            area [area-id] authentication message-digest
                           在接口配置模式下,使用命令
                            ip ospf message-digest-key [key-id] md5 [password]

    注:<1>key-id的取值范围是0-255,password可由数字和字母组成的最长16个字符的密码;
        <2>配置多个MD5密钥需要切换时,在接口配置使用命令
              ip ospf authentication message-digest
              ip ospf message-digest-key [new key-id] md5 [password]
             
           路由器将发送同一个分组的多个拷贝,每个拷贝使用
           不同的密钥进行身份认证,当检测到所有邻居都采用了新的密钥后,路由器将不再发
           送分组的多个拷贝。但必须注意:但所有邻居都切换到使用新的密钥后,应将原来的
           密钥删除,以防路由器继续同知道旧密钥的恶意系统通信。
              删除旧密钥,在接口配置模式下,使用命令
               no ip ospf message-digest-key [old key-id] md5 [password]
         <3>注意:在show run中key-string是以明文显示的,需要在配置模式下,
            使用service password-encryption进行加密。
    实验拓扑;
                    ABR            ABR
            Area1      |   Area0        |  Area2
         R1----------R2------------R3----------R4
          |                                   |
        10.1.1.1                        172.16.1.1
        10.1.2.1                        172.16.2.1
    Router1 E0/0 [10.1.1.1/24] area 1<----> VPCS V0/1 [10.1.1.2/24]
    Router1 E0/1 [10.1.2.1/24] area 1<----> VPCS V0/2 [10.1.2.2/24]
    Router1 S1/0 [192.168.1.1/30] area 1<----> Router2 S1/0 [192.168.1.2/30] area 1
    Router2 S1/1 [192.168.1.5/30] area 0<----> Router3 S1/1 [192.168.1.6/30] area 0
    Router3 S1/0 [192.168.1.9/30] area 2<----> Router4 S1/0 [192.168.1.10/30] area 2
    Router4 E0/0 [172.16.1.1/24] area 2<----> VPCS V0/3 [172.16.1.2/24]
    Router4 E0/1 [172.16.2.1/24] area 2<----> VPCS V0/4 [172.16.2.1/24]

    转载于:https://blog.51cto.com/blueskey/308416

    展开全文
  • totally stub area ------T-stub 完全末节 nssa area 次末节 nssa totally area ------T-nssa 完全次末节 这四大区域作用都是优化路由表 优化路由表的好处 如果一台路由器的它路由表条目非常非常多有什么影响...

    Ospf 四大特殊区域

    • stub area 末节
    • totally stub area ------T-stub 完全末节
    • nssa area 次末节
    • nssa totally area ------T-nssa 完全次末节
    • 这四大区域作用都是优化路由表
    • 优化路由表的好处
      • 如果一台路由器的它路由表条目非常非常多有什么影响,数据包到本路由要去查表,那么数据包查表的过程是需要时间的,如果时间越长会造成网络延迟比较大,所以就需要优化路由表来减小影响
    • 路由重发布
      • RIP 和OSPF路由协议本质不通的问题是由于:不同路由协议之间不能够相互学习路由条目.
      • 基于这个背景:路由重分布(路由重发布)
      • 路由重分布:解决不同路由协议之间相互学习路由条目的.
      • 配置的位置:不同路由协议相交换路由器上进行配置.
    • 默认路由:0.0.0.0 0.0.0.0 下一跳(静态默认路由) 0代表的的任意网段
    • OIA的路由表示:这条路由是由OSPF区域之间经过的路由
    • Stub区域:
      • Stub——末节
        • 作用:优化路由表
        • 优化区域:只优化stub区域内的所有路由器:将到达外部路由协议(rip)优先成默认路由。
        • 优化条目:是将非OSPF区域路由条目优化成O*IA的默认路由
        • 就是与骨干区域相邻的区域
          • 1相邻后面没有接其它区域
            • 例图:

          • 2.如果相邻后面接了其的OSPF区域,先择最后一个区域作为stub区域.
            • 例图:

      • Stub的配置
        • 拓扑图:
        • 1、规划网段
        • 2、配置每个节点的IP地址
          • R0:
            • en
            • conf t
            • int s0/3/0
            • no shutdown
            • ip address 172.16.255.1 255.255.255.252
            • exit
            • interface loopback0
            • ip address 172.16.1.1 255.255.255.0
            • end
            • wr
          • R1:
            • enable
            • conf t
            • interface s0/3/0
            • no shutdown
            • ip address 172.16.255.2 255.255.255.252
            • exit
            • interface s0/3/1
            • no shutdown
            • ip address 172.16.255.5 255.255.255.252
            • exit
          • R2:
            • enable
            • conf t
            • interface s0/3/1
            • no shutdown
            • ip address 172.16.255.6 255.255.255.252
            • exit
            • interface s0/3/0
            • no shutdown
            • ip address 172.16.255.9 255.255.255.252
            • exit
            • interface s0/1/0
            • no shutdown
            • ip address 192.168.1.1 255.255.255.0
            • exit
          • R3:
            • enable
            • conf t
            • interface loopback0
            • ip address 172.16.2.1 255.255.255.0
            • exit
            • interface s0/3/0
            • no shutdown
            • ip address 172.16.255.10 255.255.255.252
            • exit
          • R4:
            • enable
            • conf t
            • interface loopback0
            • ip address 10.1.1.1  255.0.0.0
            • exit
            • interface s0/3/0
            • no shutdown
            • ip address 192.168.1.2 255.255.255.0
            • exit
        • 3、配置路由协议
          • R0:
            • Router(config)#routerospf 1
            • Router(config-router)#network172.16.1.0 0.0.0.255 area 1
            • Router(config-router)#network172.16.255.0 0.0.0.3 area 1
          • R1:
            • Router(config)#router ospf1
            • Router(config-router)#network172.16.255.0 0.0.0.3 area 1
            • Router(config-router)#network172.16.255.4 0.0.0.3 area 0
          • R2:
            • Router(config)#routerospf 1
            • Router(config-router)#network172.16.255.4 0.0.0.3 area 0
            • Router(config-router)#network172.16.255.8 0.0.0.3 area 0
            • Router(config)#routerrip
            • Router(config-router)#network192.168.1.0
          • R3:
            • Router(config)#routerospf 1
            • Router(config-router)#network172.16.2.0 0.0.0.255 area 2
            • Router(config-router)#network172.16.255.8 0.0.0.3 area 0
          • R4:
            • Router(config)#routerrip
            • Router(config-router)#network10.0.0.0
            • Router(config-router)#network192.168.1.0
        • 4、路由重发布(R2)
          • 将OSPF路由条目导入到RIP路由表.
          • Router(config)#routerrip
          • Router(config-router)#redistributeospf 1 metric 1
          • 将RIP路由条目导入到OSPF路由表.
          • Router(config)#routerospf 1
          • Router(config-router)#redistributerip subnets
        • 5、设置Stub区域(area1)
          • R1:
            • Router(config)#routerospf 1
            • Router(config-router)#area1 stub
          • R0:
            • Router(config)#routerospf 1
            • Router(config-router)#area1 stub
    • T-Stub
      • 优化区域:外部路由协议(RIP)和OIA(OSPF区域间的所有路由)优化成一条默认路由
      • 优化条目:是将非OSPF区域路由条目以及区域间的路由(OIA路由条目)优化成O*IA的默认路由。
      • 配置:
        • 在stub的基础上
        • 添加T-stub
          • R1:
            • R1(config)# router ospf 1
            • R1(config-router)# area 1 stub  no- summary
            • R1(config-router)# exit
          • R0:
            • R0(config)# router ospf 1
            • R0(config-router)# area 1 stub
            • R0(config-router)# exit
            • R0(config)# ex
    • NSSA
      • 拓扑图:
      • NSSA区域就是接其它路由协议的区域.(但是前提这个区域不是area 0)
      • 优化区域:NSSA区域路由器以及NSSA相连的其它协议的路由器
      • 优化条目:是将与AREA0相连的非OSPF区域路由条目优化成O*N2的默认路由
      • 配置:
        • 拓扑图:
        • NSSA区域所有的路由器都要进行配置
        • 1、规划网段
        • 2、配置每个节点IP地址
        • 3、配置路由协议
        • 4、路由重发布
        • 5、添加NSSSA
          • R8:
            • R8(config)# router ospf 1
            • R8(config-router)# area 1 nssa default- - information- - originate
            • R8(config-router)#exit
          • R7:
            • R8(config)# route r ospf 1
            • R8(config-router)# area 1 nssa
            • R7(config-router)# exit
    • T-NSSA
      • 优化区域:
        • NSSA区域路由器以及NSSA相连的其它协议的路由器
        • 将OSPF区域间的路由条目和将骨干区域相连的外部路由协议的条目.并且将:t-NSSA连接其它路由协议的路由器上将除了NSSA区域的路由和本路由协议内部路由条目其它全部优化成一条默认路由
      • 优化条目:是将与AREA0相连的非OSPF区域路由条目以及区域间的路由(OIA)优化成O*IA的默认路由
      • 配置:
        • 在NSSSA的基础上
        • 添加T-NSSA(进一步简化NSSA区域的路由表)
          • R8:(只需要在R8添加)
            • R8(config)# router ospf 1
            • R8(config-router)# area  1 nssa no- - summary
            • R8(config-router)#exit
    展开全文
  • Stub区域和NSSA区域比较

    千次阅读 2016-06-14 11:26:42
    Stub区域STUB区域就是一个对区域概念的最典型的应用。STUB区域的设计思想在于:在划分了区域之后,非骨干区域中的路由器对于区域外的路由,一定要通过ABR(区域边界路由器)来转发,或者说对于区域内的路由器来说ABR...

    Stub区域

     

      STUB区域就是一个对区域概念的最典型的应用。STUB区域的设计思想在于:在划分了区域之后,非骨干区域中的路由器对于区域外的路由,一定要通过ABR(区域边界路由器)来转发,或者说对于区域内的路由器来说ABR是一个通往外部世界的必经之路。既然如此,对于区域内的路由器来说,就没有必要知道通往外部世界的详细的路由了,代之以由ABR向该区域发布一条缺省路由来指导报文的发送。这样在区域内的路由器中就只有为数不多的区域内路由和一条指向ABR的缺省路由。而且无论区域外的路由如何变化,都不会影响到区域内路由器的路由表。由于区域内的路由器通常是由一些处理能力有限的低端路由器组成,所以处于STUB区域内的这些低端设备既不需要保存庞大的路由表,也不需要经常性的进行路由计算。有了STUB属性之后,网络的规划更符合实际的设备特点。

      以上描述的只是STUB区域的设计思想,在协议文本中,对STUB区域的精确定义是:STUB区域一定是非骨干区域和非转换区域(可以配置虚连接的区域),并且在该区域中不可传递Type 5类型的LSA。由于OSPF是链路状态算法的路由协议,LSA就是用来描述网络拓扑结构的一种数据结构。在OSPF中将LSA分为5类:type1、2两种用来描述区域内的路由信息;type3用来描述区域间的路由信息;type4、5用来描述自治系统外部的路由信息。因为协议的设计者认为路由表中的绝大部分路由均是来自自治系统外部的引入的路由。

       需要注意的是定义中对于过滤TYPE5类型的LSA使用的描述语言是“不可传递”,这就意味着不仅区域外的ASE(自治系统外部)路由无法传递到STUB区域中,同时STUB区域内部的ASE路由也无法传递到本区域之外。换一句更通俗的话来描述:STUB区域内的路由器都不可引入任何外部的路由(包括静态路由)。这样的定义未免太过严厉了。因为在实际的组网中,并不是所有的设备都会运行OSPF协议。例如:用户拨号上网时使用的接入服务器就需要连接路由器上因特网,但通常接入服务器上并不支持(也不需要)OSPF协议,而是通过配置静态路由实现路由功能。很多时候ISP为了保密或易于管理的需要,在连接用户侧的路由器时使用静态路由。总之:在一个网络中所有的路由器上都配置OSPF,而不使用静态路由的情况几乎是不存在的。——也就是说STUB区域的适用条件也是不存在的

     

    NSSA区域

      

        STUB区域虽然为合理的规划网络描绘了美好的前景,但她在实际的组网中又不具备可操作性,未免遗憾。但此时的OSPF协议已经基本成型,不可能再做大的修改。为了弥补缺陷,协议设计者提出了一种新的概念NSSA,并且作为OSPF协议的一种扩展属性单独在RFC 1587中描述。

    NSSA需要完成如下任务:


        自治系统外的ASE路由不可以进入到NSSA区域中,但是NSSA区域内的路由器引入的ASE路由可以在NSSA中传播并发送到区域之外。即:取消了STUB关于ASE的双向传播的限制(区域外的进不来,区域里的也出不去),改为单向限制(区域外的进不来,区域里的能出去)。
        由于是作为OSPF标准协议的一种扩展属性,应尽量减少与不支持该属性的路由器协调工作时的冲突和兼容性问题。为了解决ASE单向传递的问题,NSSA中重新定义了一种LSA——Type 7类型的LSA,作为区域内的路由器引入外部路由时使用,该类型的LSA除了类型标识与Type 5不相同之外,其它内容基本一样。这样区域内的路由器就可以通过LSA的类型来判断是否该路由来自本区域内。但由于Type 7类的LSA是
    新定义的,对于不支持NSSA属性的路由器无法识别,所以协议规定:在NSSA的ABR上将NSSA内部产生的Type 7类型的LSA转化为Type 5类型的LSA再发布出去,并同时更改LSA的发布者为ABR自己。这样NSSA区域外的路由器就可以完全不用支持该属性。从上述描述可以看出:在NSSA区域内的所有路由器必须支持该属性(包括NSSA的ABR),而自治系统中的其他路由器则不需要。由于NSSA是由STUB区域的概念改进得来,所以她的名字叫做:"not-so-stubby" area ,本意是:不是那么STUB的区域。


    转载于:https://blog.51cto.com/songe/1789058

    展开全文
  • StubNSSA特殊区域实验

    千次阅读 2018-12-06 11:46:02
    配置StubNSSA特殊区域 1.组网需求 如图所示,所有的路由器都运行OSPF,整个自治系统划分为3个区域。其中AR1 AR2作为ABR来转发区域之间的路由, AR4作为ASBR引入了外部路由(静态路由)。要求Area1配置为 Stub区域,...
  • OSPF Stub区域与NSSA区域

    千次阅读 2019-09-03 17:44:32
    Stub:OSPFSTUB区域是一个末梢区域,当一个OSPF区域处于整个自治系统边界时,而又不含其他路由协议,这时就可以配置OSPF Stub区域。 NSS:OSPF路由协议是目前因特网中应用最为广泛一种IGP,而NSSA则是在该协议...
  • 实验任务一:STUB区域配置 建立物理连接 RTA,RTB,RTC,RTD配置ospf [RTA-ospf-1-area-0.0.0.1]network 10.0.0.0 0.0.0.255 [RTA-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0 [RTB-ospf-1-area-0.0.0.1]network ...
  • 华为的Stub和NSSA区域基本配置

    千次阅读 2017-11-23 15:08:00
    在AR2显示路由表,学到的外部路由是由NSSA这个区域通告的,7类的LSA 在AR4上学到的路由不是的,它还是以5类LSA通告的  这是因为 NSSA 只对属于它区域里的成员通告外部的路由,也就是将 5 类的 LSA 翻译成...
  • Stub区域是整个OSPF的边界,同时也是拓扑的边界。区域中不能存在ASBR。Stub区域不接收LSA5的链路状态信息;以一条缺省路由代替。...NSSA区域是stub区域的扩展。整个OSPF的边界,但不是整个拓扑的边界。区域中存...
  • ospf stub nssa 特殊区域

    2021-01-26 16:37:07
    在这里插入图片描述
  • 实验配置stub和nssa区域 routerA(config)#router ospf 10 routerA(config-router)#area 1 stub routerB(config)#router ospf 10 routerB(config-router)#area 1 stub routerC(config)#router ospf 10 ...
  • OSPF特殊区域(stubstub no-summary、nssa)

    千次阅读 2019-12-14 21:50:00
    OSPF特殊区域(stubstub no-summary、nssa) 拓扑图 1.1.1.1、2.2.2.2为模拟外部路由 正常宣告直连网段 将1.1.1.1、2.2.2.2作为外部网络重分布进OSPF。 R9#show run | sec ospf router ospf 1 redistribute ...
  • ** Ospf中的stub域、nssa域、虚链路地址汇总** Stub实验A. 实验需求:在R5上,链接 R6,并配置 192.168.100.0/24的接口;在R5上,将 192.168.100.0/24 通过 import-route方式,宣告进入到 OSPF ; 为了保护区域 ...
  • stub R1 [RT1]ospf 1 [RT1-ospf-1]area 1 [RT1-ospf-1-area-0.0.0.1]stu [RT1-ospf-1-area-0.0.0.1]stub   R2 [RT2]ospf 1 [RT2-ospf-1]ar [RT2-ospf-1]area 1 [RT2-ospf-1-area-0.0.0.1]st [RT2-ospf-1-area-0.0....
  • 接着,91华为网将介绍华为ospf协议区域配置,包括ospf Stub和NSSA区域。 1、配置OSPF的STUB区域 请根据需求,在相应的华为路由器、华为交换机上进行以下配置。 步骤 1 执行命令system-view,进入系统视...
  • stub过滤4,5类lsa,ABR会产生缺省的3类lsa,区域内不能引入外部路由 total stub过滤3,4,5类lsa,ABR会产生缺省的3类lsa,区域内不能引入外部路由 nssa过滤4,5类lsa,ABR会产生缺省的7类lsa,该区域能引入外部路由...
  • OSPF:STUBNSSA区别

    2010-09-26 12:59:29
    STUB区域的设计思想在于:在划分了区域之后,非骨干区域中的路由器对于区域外的路由,一定要通过 ABR(区域边界路由器)来转发,或者说对于区域内的路由器来说ABR是一个通往外部世界的必经之路。既然如此,对于...
  • OSPF(七)OSPF特殊区域之NSSA和Totally NSSA详解及配置

    千次阅读 多人点赞 2020-03-17 21:25:14
    文章目录前言Stub和Totally Stub区域存在的问题NSSA和Totally NSSA区域NSSA配置Totally NSSA配置整体实验配置过程及命令步骤一:搭建拓扑步骤二:配置路由器接口IP地址步骤三:OSPF区域以及邻居配置步骤三:检测OSPF...
  • 关于ospf的stub: OSPF Stub是一个末梢区域,当一个OSPF区域处于整个自治系统边界时,而又不含其他路由协议,这时就可以配置OSPF Stub区域。当配置OSPF Stub区域后,Stub区域中的路由器会增加一条至ABR的默认路由...
  • ospf学习-----LSA类型以及stubnssa区域

    千次阅读 2019-09-15 10:34:01
     1、Router LSA:每台路由器都会产生,描述该路由器所有OSPF直连接口的状态Cost,只在接口所属的Area中洪泛。此类LSA的通告者的Router Id是自己本身。可以帮助其他路由器知道本区域的Router ID网段,绘制拓扑...
  • NSSA区域Totally NSSA区域

    千次阅读 2019-08-22 13:55:40
  • 传输区域:除了承载本区域发起的流量访问本区域的流量外,还承载了源IP目的IP都不属于本区域的流量,即“穿越型流量”,如Area 0。 末端区域:只承载本区域发起的流量访问本区域的流量,如Area 1。 对于...
  • i) 把area3配置为NSSA区域 j) 在R6上配置到达192.168.0.0/24网段的静态路由,并以7类LSA引入到OSPF内部 3. 解法 a) 略 b)略 c)在R3R4的area 1视图下:vlink...
  • area 1 stub no-summary //完全末节区域 ,在stub区域边界上,过滤3类LSA,仅保留3类缺省LSA,过滤4,5类LSA area 1 range 172.16.32.0 255.255.224.0 network 172.16.0.129 0.0.0.0 area 0 network 172.16.32.0 ...
  • 将R3配置4个LoopBack口并配置以下地址,将Area 1区域设为Stub区域。验证:R1设备路由表是否有其他区域路由信息,以及R1的LSDB链路状态数据库是否仅存在一条默认路由指向ABR设备。 拓扑图 基础配置如下: sys...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,529
精华内容 1,011
关键字:

nssa和stub