精华内容
下载资源
问答
  • OSPF实例操作

    2014-01-03 15:24:34
    OSPF实例操作.jpg CCNA中的单域配置
  • ospf实例

    2010-03-16 15:23:13
    R5(config-router)#redistribute ospf 10 metric 15 Router> Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#no ip do ...
    <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    Router>

    Router>en

    Router#conf t

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R1

    R1(config)#interface f0/0

    R1(config-if)#ip address 192.168.20.1 255.255.255.0

    R1(config-if)#no shu

    R1(config-if)#interface f1/0

    R1(config-if)#ip address 192.168.40.1 255.255.255.0

    R1(config-if)#no shu

    R1(config-if)#interface loo 1

    R1(config-if)#ip address 192.168.1.1 255.255.255.0

    R1(config-if)#interface loo 2

    R1(config-if)#ip address 192.168.2.1 255.255.255.0

    R1(config-if)#interface loo 3

    R1(config-if)#ip address 192.168.3.1 255.255.255.0

    R1(config-if)#interface loo 4

    R1(config-if)#ip

    R1(config-if)#ip address 192.168.4.1 255.255.255.0

    R1(config-if)#router ospf 1

    R1(config-router)#router-id 1.1.1.1

    R1(config-router)#net 192.168.40.0 0.0.0.255 a 0

    R1(config-router)#net 192.168.20.0 0.0.0.255 a 0

    R1(config-router)#net 192.168.1.0 0.0.0.255 a 0

    R1(config-router)#net 192.168.2.0 0.0.0.255  a 0

    R1(config-router)#net 192.168.3.0 0.0.0.255 a 0

    R1(config-router)#net 192.168.4.0 0.0.0.255 a 0

    Router>

    Router>en

    Router#conf t

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R2

    R2(config)#interface f0/0

    R2(config-if)#ip address 192.168.20.2 255.255.255.0

    R2(config-if)#no shu

    R2(config-if)#interface f1/0

    R2(config-if)#ip address 192.168.50.1 255.255.255.0

    R2(config-if)#no shu

    R2(config-if)#interface f2/0

    R2(config-if)#ip address 192.168.30.1 255.255.255.0

    R2(config-if)#no shut

    R2(config-if)#router ospf 1

    R2(config-router)#router-id 2.2.2.2

    R2(config-router)#net 192.168. 5 0.0 0.0.0.255 a 0

    R2(config-router)#net 192.168.20.0 0.0.0.255 a 0

    R2(config-router)#net 192.168.30.0 0.0.0.255 a  2

    R2(config-router)#area 2 stub no-summary

    Router>

    Router>en

    Router#conf t

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R3

    R3(config)#interface f0/0

    R3(config-if)#ip address 192.168.30.2 255.255.255.0

    R3(config-if)#no shu

    R3(config-if)#interface loo 1

    R3(config-if)#ip address 192.168.5.1 255.255.255.0

    R3(config-if)#interface loo 2

    R3(config-if)#ip address 192.168.6.1 255.255.255.0

    R3(config-if)#interface loo 3

    R3(config-if)#ip address 192.168.7.1 255.255.255.0

    R3(config-if)#interface loo 4

    R3(config-if)#ip ad

    R3(config-if)#ip address 192.168.8.1 255.255.255.0

    R3(config-if)#router ospf 1

    R3(config-router)#router-id 3.3.3.3

    R3(config-router)#net 192.168.30.0 0.0.0.255

    R3(config-router)#net 192.168.30.0 0.0.0.255 a 2

    R3(config-router)#net 192.168.8.0  0.0.0.255 a 2

    R3(config-router)#net 192.168.5.0  0.0.0.255 a 2

    R3(config-router)#net 192.168.6.0  0.0.0.255 a 2

    R3(config-router)#net 192.168.7.0  0.0.0.255 a 2

    R3(config-router)#area 2 stub no-summary

    Router>

    Router>en

    Router#conf t

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R4

    R4(config)#interface f0/0

    R4(config-if)#ip address 192.168.40.2 255.255.255.0

    R4(config-if)#no shu

    R4(config-if)#interface f1/0

    R4(config-if)#ip address 192.168.60.1 255.255.255.0

    R4(config-if)#no shu

    R4(config-if)#interface f2/0

    R4(config-if)#ip address 192.168.50.2 255.255.255.0

    R4(config-if)#no shu

    R4(config-if)#router ospf 1

    R4(config-router)#router-id 4.4.4.4

    R4(config-router)#net 192.168.40.0 0.0.0.255 a 0

    R4(config-router)#net 192.168.50.0 0.0.0.255 a 0

    R4(config-router)#net 192.168.60.0 0.0.0.255 a 1

    R4(config-router)#area 1 nssa no-summary

    Router>

    Router>en

    Router#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R5

    R5(config)#interface f0/0

    R5(config-if)#ip address 192.168.60.2 255.255.255.0

    R5(config-if)#no shu

    R5(config-if)#interface f1/0

    R5(config-if)#ip address 192.168.70.1 255.255.255.0

    R5(config-if)#no shu

    R5(config-if)#interface loo 1

    R5(config-if)#ip address 192.168.9.1 255.255.255.0

    R5(config-if)#interface loo 2

    R5(config-if)#ip address 192.168.10.1 255.255.255.0

    R5(config-if)#interface loo 3

    R5(config-if)#ip address 192.168.11.1 255.255.255.0

    R5(config-if)#interface loo 4

    R5(config-if)#ip address 192.168.12.1 255.255.255.0

    R5(config-if)#router ospf 1

    R5(config-router)#router-id 5.5.5.5

    R5(config-router)#net 192.168.12.0 0.0.0.255 a 1

    R5(config-router)#net 192.168.60.0 0.0.0.255 a 1

    R5(config-router)#net 192.168.9.0  0.0.0.255 a 1

    R5(config-router)#net 192.168.10.0 0.0.0.255 a 1

    R5(config-router)#net 192.168.11.0 0.0.0.255 a 1

    R5(config-router)#router r

    R5(config-router)#no au

    R5(config-router)#ver 2

    R5(config-router)#net 192.168.70.0

    R5(config-router)#router ospf 1

    R5(config-router)#area 1 nssa no-summary

    R5(config-router)#redistribute rip  metric 100 subnets metric-type 1

    R5(config-router)#router rip

    R5(config-router)#redistribute ospf 10 metric 15

    Router>

    Router>en

    Router#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#no ip do loo

    Router(config)#line con 0

    Router(config-line)#exec-t 0 0

    Router(config-line)#logging sync

    Router(config-line)#exit

    Router(config)#host R6

    R6(config)#interface f0/0

    R6(config-if)#ip address 192.168.70.2 255.255.255.0

    R6(config-if)#no shu

    R6(config-if)#interface loo 1

    R6(config-if)#ip address 172.16.1.1 255.255.255.0

    R6(config-if)#interface loo 2

    R6(config-if)#ip address 172.16.2.1 255.255.255.0

    R6(config-if)#interface loo 3

    R6(config-if)#ip address 172.16.3.1 255.255.255.0

    R6(config-if)#interface loo 4

    R6(config-if)#ip address 172.16.4.1 255.255.255.0

    R6(config-if)#router r

    R6(config-router)#no auto

    R6(config-router)#ver 2

    R6(config-router)#net 192.168.70.0

    R6(config-router)#net 172.16.1.0

    R6(config-router)#net 172.16.2.0

    R6(config-router)#net 172.16.3.0

    R6(config-router)#net 172.16.4.0

    转载于:https://blog.51cto.com/313264505/284321

    展开全文
  • OSPF 实例配置
  • 华为设置ospf实例

    2012-07-25 15:26:17
    华为设置ospf实例,介绍华为和思科配置ospf的实例配置文档,可以参考
  • 华为路由器配置OSPF实例

    千次阅读 2018-07-05 17:43:30
    华为路由器配置OSPF实例 session 1 ospf ospf 开放式最短路径优先路由协议,是一种状态链路协议,采用Dijkstra算法计算路由。 ospf的进程,每个ospf的进程都是单独的,并且地址族也是每一个进程一个。 ospf的...

    华为路由器配置OSPF实例

    session 1 ospf

       ospf 开放式最短路径优先路由协议,是一种状态链路协议,采用Dijkstra算法计算路由。
    
       ospf的进程,每个ospf的进程都是单独的,并且地址族也是每一个进程一个。
    
       ospf的区域划分,area 0是骨感区域,有且只有一个;其他区域为非骨干区域,并且必须与骨干区域直接相连或者通过虚链路相连,非骨干区域分为一般区域、末梢区域(只有lsa1、2、3)、完全末梢区域(只有lsa1、2)、非纯末梢区域(lsa1、2、3、7)、完全非纯末梢区域(lsa1、2、7)
    
       ospf的接口类型:广播(选举DR、BDR)、NBMA(不选举DR、BDR)、P2P(不选举DR、BDR)、P2MP(不选举DR、BDR)
    
       ospf的LSA类型:lsa1=路由器lsa,由路由器产生宣告直连。lsa2=网络lsa,由DR/BDR产生宣告网段。lsa3=网络汇总lsa,由ABR产生宣告不同区域的路由。                                                                   lsa4=ASBRlsa,由ABR产生宣告到达ASBR的路由。lsa5=外部lsa,由asbr产生宣告外部路由。lsa7=NSSA外部lsa,由asbr产生宣告nssa区域的外部路由
    
       ospf的角色:ABR区域边界路由器,连接不同区域并宣告不同区域路由。ASBR区域边界路由器,连接区域和外部网络宣告外部网络到ospf中。
    
       ospf的邻居建立过程:down(接口down)、init(选举DR/BDR)、2-way(邻居关系完成)、exstart/exchange(交换链路状态数据库DBD信息)、loading(LSA更新)、full(邻接关系建立)
    
       ospf的组播地址:224.0.0.5(所有路由器发送hello选举DR/BDR,后DB统一下发LSU给其他路由器)、224.0.0.6(DR监听其他路由器发的LSU)
    
       ospf中DR/BDR不具备抢占机制,为了稳定性已经成为DR的路由器不会因为优先级比其他路由器小而失去DR/BDR资格,除非ospf协议重启重新选举DR/BDR
    
       ospf中DR/BDR的选举规则:优先级>r-id>环回口最大ip>接口最大ip
    
       ospf的DR/BDR是以网段选举的而不是区域,宣告也是以接口进行的*(也支持宣告网络)

    session 2 ospf的配置实例

    一、ospf的基本功能配置
    华为路由器配置OSPF实例

       按照拓扑图上配置ospf的三个区域,相互学习到路由并查看每个路由器的LSDB和相关LSA信息,AR4与AR6分别扮演ASBR角色并将自己的环回接口网络重分布进ospf网络中,AR6的外部路由使type1(AR4的使用默认的type2)分布进ospf,并查看LSA5

    AR1的配置

    interface GigabitEthernet0/0/0
    ip address 12.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 13.1.1.1 255.255.255.0
    #

    ospf 1 router-id 1.1.1.1 ospf的r-id
    area 0.0.0.0 创建area0
    network 12.1.1.1 0.0.0.0 在area0中宣告属于area0区域的接口(允许该接口在area0收发ospf报文)

    area 0.0.0.1 创建area1
    network 13.1.1.1 0.0.0.0 在area1中宣告属于area1区域的接口
    #

    AR2的配置

    interface GigabitEthernet0/0/0
    ip address 12.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 25.1.1.2 255.255.255.0
    #

    ospf 1 router-id 2.2.2.2
    area 0.0.0.0
    network 12.1.1.2 0.0.0.0
    area 0.0.0.2
    network 25.1.1.2 0.0.0.0
    #

    AR3的配置

    interface GigabitEthernet0/0/0
    ip address 13.1.1.3 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 34.1.1.3 255.255.255.0
    #

    ospf 1 router-id 3.3.3.3
    area 0.0.0.1
    network 13.1.1.3 0.0.0.0
    network 34.1.1.3 0.0.0.0
    #

    AR4的配置

    interface GigabitEthernet0/0/0
    ip address 34.1.1.4 255.255.255.0
    #

    interface LoopBack0
    ip address 4.4.4.4 255.255.255.255
    #
    ospf 1 router-id 4.4.4.4
    import-route direct 重分布直连路由到ospf中,类型为默认的type2(cost固定为1)
    area 0.0.0.1
    network 34.1.1.4 0.0.0.0
    #

    AR5的配置

    interface GigabitEthernet0/0/0
    ip address 25.1.1.5 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    ip address 56.1.1.5 255.255.255.0
    #

    ospf 1 router-id 5.5.5.5
    area 0.0.0.2
    network 25.1.1.5 0.0.0.0
    network 56.1.1.5 0.0.0.0
    #

    AR6上的配置

    interface GigabitEthernet0/0/0
    ip address 56.1.1.6 255.255.255.0
    #

    interface LoopBack0
    ip address 6.6.6.6 255.255.255.255
    #

    ospf 1 router-id 6.6.6.6
    import-route direct type 1 重分布直连路由到ospf中,类型为type1(类型区别在于路由的metric不同,type1的cost大)
    area 0.0.0.2
    network 56.1.1.6 0.0.0.0
    #

    查看ospf的LSDB数据库,在AR1上查看,做为ABR应该有2个区域的lsa1-3信息以及外部重分布的lsa5和到达asbr的lsa4

    [Huawei]display ospf 1 lsdb
    OSPF Process 1 with Router ID 1.1.1.1
    Link State Database
    Area: 0.0.0.0 区域0的lsa
    Type LinkState ID AdvRouter Age Len Sequence Metric
    Router 2.2.2.2 2.2.2.2 878 36 80000013 1
    Router 1.1.1.1 1.1.1.1 823 36 80000015 1
    Network 12.1.1.1 1.1.1.1 1565 32 8000000E 0
    Sum-Net 56.1.1.0 2.2.2.2 208 28 8000000C 2
    Sum-Net 34.1.1.0 1.1.1.1 634 28 8000000D 2
    Sum-Net 25.1.1.0 2.2.2.2 868 28 8000000D 1
    Sum-Net 13.1.1.0 1.1.1.1 803 28 8000000D 1
    Sum-Asbr 34.1.1.4 1.1.1.1 611 28 8000000C 2
    Sum-Asbr 6.6.6.6 2.2.2.2 208 28 8000000B 2
    Area: 0.0.0.1 区域1的lsa
    Type LinkState ID AdvRouter Age Len Sequence Metric
    Router 34.1.1.4 34.1.1.4 754 36 8000000F 1
    Router 13.1.1.3 13.1.1.3 638 48 80000014 1
    Router 1.1.1.1 1.1.1.1 716 36 80000011 1
    Network 34.1.1.3 13.1.1.3 638 32 8000000E 0
    Network 13.1.1.1 1.1.1.1 716 32 8000000E 0
    Sum-Net 12.1.1.0 1.1.1.1 803 28 8000000D 1
    Sum-Net 56.1.1.0 1.1.1.1 207 28 8000000C 3
    Sum-Net 25.1.1.0 1.1.1.1 803 28 8000000D 2
    Sum-Asbr 6.6.6.6 1.1.1.1 207 28 8000000B 3
    AS External Database 外部重分布的lsa5和到达asbr的lsa4
    Type LinkState ID AdvRouter Age Len Sequence Metric
    External 6.6.6.6 6.6.6.6 235 36 8000000C 1
    External 4.4.4.4 34.1.1.4 754 36 8000000C 1
    External 34.1.1.0 34.1.1.4 754 36 8000000C 1
    External 56.1.1.0 6.6.6.6 235 36 8000000C 1
    [Huawei]

    在AR4上查看lsa信息库

    [Huawei]display ospf 1 lsdb
    OSPF Process 1 with Router ID 34.1.1.4
    Link State Database
    Area: 0.0.0.1 area1的lsa信息
    Type LinkState ID AdvRouter Age Len Sequence Metric
    Router 34.1.1.4 34.1.1.4 1078 36 8000000F 1
    Router 13.1.1.3 13.1.1.3 964 48 80000014 1
    Router 1.1.1.1 1.1.1.1 1044 36 80000011 1
    Network 34.1.1.3 13.1.1.3 964 32 8000000E 0
    Network 13.1.1.1 1.1.1.1 1044 32 8000000E 0
    Sum-Net 12.1.1.0 1.1.1.1 1132 28 8000000D 1
    Sum-Net 56.1.1.0 1.1.1.1 531 28 8000000C 3
    Sum-Net 25.1.1.0 1.1.1.1 1132 28 8000000D 2
    Sum-Asbr 6.6.6.6 1.1.1.1 531 28 8000000B 3
    AS External Database 外部lsa信息
    Type LinkState ID AdvRouter Age Len Sequence Metric
    External 4.4.4.4 34.1.1.4 1078 36 8000000C 1
    External 34.1.1.0 34.1.1.4 1078 36 8000000C 1
    External 6.6.6.6 6.6.6.6 560 36 8000000C 1
    External 56.1.1.0 6.6.6.6 560 36 8000000C 1
    [Huawei]

    在AR1上查看AR4上重分布的type2路由和AR6上重分布的type1的路由的cost(metric)的区别

    [Huawei]display ip routing-table protocol ospf
    Route Flags: R - relay, D - download to fib

    Public routing table : OSPF
    Destinations : 5 Routes : 5
    OSPF routing table status : <Active>
    Destinations : 5 Routes : 5
    Destination/Mask Proto Pre Cost Flags NextHop Interface
    4.4.4.4/32 O_ASE 150 1 D 13.1.1.3 GigabitEthernet0/0/1 默认的type2,cost固定为1
    6.6.6.6/32 O_ASE 150 4 D 12.1.1.2 GigabitEthernet0/0/0 非默认的type1真实的cost值
    25.1.1.0/24 OSPF 10 2 D 12.1.1.2 GigabitEthernet0/0/0
    34.1.1.0/24 OSPF 10 2 D 13.1.1.3 GigabitEthernet0/0/1
    56.1.1.0/24 OSPF 10 3 D 12.1.1.2 GigabitEthernet0/0/0
    OSPF routing table status : <Inactive>
    Destinations : 0 Routes : 0

    转载于:https://blog.51cto.com/9821049/2136792

    展开全文
  • 自己设计的ospf企业内网组网架构,比较基础的设计,ensp拓扑图。可以供初学者参考。
  • ospf实例分析 (子网掩码实战) Router1: interface ethernet 0 ip address 192.1.0.129 255.255.255.192 ! interface serial 0 ip address 192.200.10.5 255.255.255.252 ! router ospf 100 network 192.200.10.4 ...
    ospf实例分析 (子网掩码实战)

    Router1:
    interface ethernet 0
    ip address 192.1.0.129 255.255.255.192
    !
    interface serial 0
    ip address 192.200.10.5 255.255.255.252
    !
    router ospf 100
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1

    !
    Router2:
    interface ethernet 0
    ip address 192.1.0.65 255.255.255.192
    !
    interface serial 0
    ip address 192.200.10.6 255.255.255.252
    !
    router ospf 200
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.64 0.0.0.63 area 2
    !
    Router3:
    interface ethernet 0
    ip address 192.1.0.130 255.255.255.192
    !
    router ospf 300
    network 192.1.0.128 0.0.0.63 area 1
    !
    Router4:
    interface ethernet 0
    ip address 192.1.0.66 255.255.255.192
    !
    router ospf 400
    network 192.1.0.64 0.0.0.63 area 1

    配置命令中用红色标记的IP地址是哪里产生的?????????

    给你祥解
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1
    我来了
    告诉你哈听好了
    正常的ospf的网络通告是这样的:
    network 192.200.10.0 0.255.255.255 area 0
    network 192.1.0.0 0.255.255.255 area 1
    我知道你不明白什么:
    你不明白的是子网掩码是怎么掩的
    给你用口语简单讲一下::
    如果你在一个路由器上这么定义:ip address 10.1.1.1 255.255.255.0
    那说明你把这个网段给了你定义的端口,比如说s0
    那只有s0下的端口可以用10.1.1.0-10.1.1.256这个段
    也就是默认路由是整个段。
    还是给你个掩码表吧
    子网数目        占用主机号位数        子网掩码        子网中可容纳的主机数

    2        1        255.255.255.128        126

    4        2        255.255.255.192        62

    8        3        255.255.255.224        30

    16        4        255.255.255.240        14

    32        5        255.255.255.248        6

    64        6        255.255.255.252        2
    (随时都看一下上面的表)
    为什么会有这样的掩码设置呢?
    因为你每台交换机都用10.1.1.1 255.255.255.0的话 那在他所在的这个广播域内只有他的下面的机器能用10.1.1.0-10.1.1.256这里面的ip 而他下面只有10台机器那不是浪费了200多个地址
    所以有了掩码
    交换机这样设定10.1.1.1 255.255.255.240 这样就有16个地址可以被交换机和它下面的设备用了

    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1
    这个ip通告则是
    192.200.10.4-192.200.10.8(router1的s0在这个段里)
    192.1.0.128-192.1.0.256(router1的e0在这个段里)
    为什么呢?
    因为
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1
    中的子网掩码 0.0.0.3和0.0.0.63是反向掩码
    他们代表的是子网掩码255.255.255.252和255.255.255.192
    而上面2个掩码所掩的的是/30和/25
    掩码表
    子网数目        占用主机号位数        子网掩码        子网中可容纳的主机数

    2        1        255.255.255.128        126

    4        2        255.255.255.192        62

    8        3        255.255.255.224        30

    16        4        255.255.255.240        14

    32        5        255.255.255.248        6

    64        6        255.255.255.252        2
    所以说
    network 192.200.10.4 0.0.0.3 area 0
    network 192.1.0.128 0.0.0.63 area 1
    这样的写法是正确的
    而且是明智的......

    转载于:https://blog.51cto.com/xxgbblog/47846

    展开全文
  • 当EIGRP外部路由(ad:170)重分发进OSPF后,边界路由会有两条选择,一条是EIGRP内部到达目的,另一条是从OSPF学到的往同样目的去的路由,这条路由是由另外一台重分发路由器从EIGRP分发过来的。这时,ASBR会选择OSPF的...
    我们无论在实际应用,还是CCIE实验中,路由重分发、路由过滤一向会是一个难点,现把几点需要注意的地方总结如下:
     
    一、路由过滤的方法:(三种)
    1、distribute-list
    2、route-map
    3、summary
     
    下面分别简单举例,只允许10.10.0.0/16条目进入路由表
    1、distribute-list
    ip prefix-list cracker permit 10.10.0.0/16
     
    router eigrp 10
       distribute-list prefix-list cracker in s0/0
     
     
    2、route-map
    ip prefix-list cracker permit 10.10.0.0/16
     
    route-map cracker permit 10
      match ip address prefix-list cracker
     
    router ospf 10
      redis eigrp 10 metric 100 subnets route-map cracker
    3、summary
    有时我们可以用summary来汇总路由,并且由于汇总对精细路由条目抑制的本能,我们相当于又多加了一条过滤语句,但也有特例,那就是RIP和BGP。
     
    int s0/0
      ip summary-address eigrp 10 10.10.0.0 255.255.0.0
     
    从s0/0发出的路由将在汇总的同时被过滤。
     
    如果是RIP:
    int s0/0
      ip summary-address rip 10.10.0.0 255.255.0.0
    仅这一句是不够的,我们还要另做过滤
     
    ip prefix-list cracker permit 10.10.0.0 255.255.0.0
     
    router rip
      distribute-list prefix-list cracker out s0/0
    二、路由过滤
    路由过滤仅对Distance-vector 路由协议有效,OSPF这类link-status协议无视路由过滤,当然除非我们在路由进程下去做。
     
    这也是我们为什么经常在其它路由协议向OSPF重分发时,看不到路由过滤语句distribute-list存在的原因。但这不代表使用route-map的方法不可以。
     
    下面我们分两种情况讨论
     
    1、EIGRP RIP 这两种路由协议,无论你在in out方向均可做,不用过多考虑,直接distribute-list上。
    例:禁止10.10.0.0/16汇总路由进入EIGRP/RIP
    router rip
      distribute-list prefix-list cracker in s0/0
     
    ip prefix-list cracker deny 10.10.0.0/16
    ip prefix-list cracker permit 0.0.0.0/0 le 32
     
    router eigrp 10
      distribute-list prefix-list cracker in s0/0
    2、OSPF 路由过滤
     
    例:禁止10.10.0.0/16汇总路由进入OSPF
    router os 10
      redis eigrp 10 metric 100 subnets route-map cracker
     
    ip prefix-list cracker permit 10.10.0.0/16
     
    route-map 22817747 deny 10
      match ip addr prefix-list cracker
    route-map 22817747 permit 20
    三、重分发
    重分发的METRIC设置方法就不提了,重要的是他的原理。我们不讲单点单向重分发,单点双向重分发,双点重分发,双点双向重分发。
     
    1、单点重分发我们只提一点,所有的情况你都可以自已推断:
     
    重分发,分发的是当前路由器“路由表”中的内容,注意,一定是路由表,路由协议数据库中的条目不管。OSPF数据库中的内容,redistribute程序是不会知道的。
     
    这样也就解决了单点双向重分发为什么不会产生路由回溃的原因。发往一个方向的路由不会被重分发回来,因为在分发点上是看不到被分发后的路由的。
     
    2、而双点双向重分发,也只需记住一点:
    AD值的路由协议向AD值 的路由协议中重分发, 产生次优路径、路由环路等问题,需要加以过滤或对AD值进行更改。 注意:错误只发生在边界路由器上!
     
    AD值的路由协议向AD值的路由协议中重分发, 不会产生次优路径、路由环路等问题,无需考虑。
     
    结合你自已的拓扑,仔细研究一下,相信很快问题就会清楚的。
    四、双点双向重分发中次优路径问题
    解决方法,这里提一下,两种:
    1、路由过滤。
    不让产生环路的路由条目进入我这台路由器,这样也就不会产生次优路径了,因为路由器根本就没有两条路可走。
     
    2、AD值更改
    我们可以把次优路由条目的AD值调高,高到路由器即便看到两条路由条目去往同一目的的,也不会选择这条次优路径。
     
    例:
    当EIGRP外部路由(ad:170)重分发进OSPF后,边界路由会有两条选择,一条是EIGRP内部到达目的,另一条是从OSPF学到的往同样目的去的路由,这条路由是由另外一台重分发路由器从EIGRP分发过来的。这时,ASBR会选择OSPF的,因为其AD为110,小于EIGRP DEX 的170。
     
    我们可以把这个学来的条目的AD值调高到超过EIGRP DEX 170的值,这里我们调到250。呵呵,简直就是二百五
    router ospf 10
      distance 250 10.10.1.1 0.0.0.0 44
     
    access-list 44 permit 100.100.100.100/32
     
     
     
     
    OK,今天总结到这里,抽时间把OSPF认证的所有内容放上来。
     
    谢谢大家看完这篇文章,祝所有看过的人工作顺利,出门捡钱包,买彩票中大奖!









    本文转自 ciscodocu51CTO博客,原文链接:http://blog.51cto.com/ciscodocu/52755,如需转载请自行联系原作者
    展开全文
  • OSPF综合实例
  • OSPF实例配置

    2010-07-29 16:00:27
    OSPF实例配置 大家来观摩一下有用的话大家就看看
  • OSPF协议配置实例

    2013-09-09 11:12:19
    OSPF协议配置实例
  • 华为ospf路由配置实例操作
  • OSPF配置实例

    2018-03-29 16:08:16
    配置ospf使得pc1和pc2能互通接口的基本配置 R1:R1(config)#int f0/0R1(config-if)#ip address 192.168.2.1 255.255.255.0 R1(config-if)#no shutdownR1(config)#int s1/0R1(config-if)#ip address 172.16.0.1 255....
  • H3C OSPF配置实例

    2012-03-22 11:11:12
    OSPF配置实例,这是基于H3C(华三)路由器的OSPF基本配置,希望对各位有用。
  • 今天给大家带来一道很有趣的OSPF题目,本文通过构造一个很特殊的OSPF环境,体现出OSPF网络类型的妙用。从而加深对[外链图片转存中…(img-XZFgjQXk-1626871469063)] 一、题目拓扑及要求 二、解题分析及相关配置命令 ...
  • OSPF协议的配置实例

    2018-08-30 11:05:13
    OSPF协议的配置实例 ,可以作为参考, OSPF协议的配置方法。
  • OSPF实例培训.ppt

    2015-11-12 21:47:16
    OSPF多进程特点: 一台路由器上使能多个OSPF 每个OSPF有自己的接口 每个进程维护自己的邻居和数据库 在UPDATE数据库时也只描述自己进程所属的数据库 共享同一张路由表
  • 思科OSPF配置实例

    万次阅读 2015-06-18 19:21:49
    指定使用OSPF协议 router ospf process-id1 指定与该路由器相连的网络 network address wildcard-mask area area-id2 指定与该路由器相邻的节点地址 neighbor ip-address ...
  • 华为ospf实验配置实例

    千次阅读 2019-10-26 21:05:48
    ospf配置实例 ospf OSPF 开放式最短路径优先协议 目前使用范围最广泛的IGP协议;无类别链路状态路由协议; OSPF协议最大的缺点,在于基于拓扑收敛产生巨大的更新量; 故设计者在设计ospf协议过程中,使用了很多的...
  • ospf配置实例

    2012-06-06 18:27:49
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP ...
  • OSPF是一种基于链路状态(link-state)的路由协议,而RIP则是一种基于距离矢量的路由协议,这是二者最根本的区别。 RIP协议中,路由器之间是以一种“传话”的方式来传递有关路由的信息。OSPF协议中,路由器之间可以...
  • 思科OSPF配置实例(转)

    万次阅读 2018-07-09 15:41:29
    任务命令指定使用OSPF协议router ospf process-id1指定与该路由器相连的网络network address wildcard-mask area area-id2指定与该路由器相邻的节点地址neighbor ip-address 注:1、OSPF路由进程process-id...
  • OSPF实例路由防环检测功能介绍普通OSPF防环功能新的改变,引入新的问题BGP/MPLS/VPN组网环境1、 Domain ID什么是Domain ID?BGP传这个值有什么用?这个值如何得来?2、 OSPF 路由类型(1) 区域(Area)号: 4字节...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,598
精华内容 2,239
关键字:

ospf实例