精华内容
下载资源
问答
  • PPPOE中的PAP与CHAP

    千次阅读 2015-06-01 16:13:46
    PPPOE中的PAP与CHAP 2010年09月04日 星期六 07:33   一般情况下,我们讨论PAPCHAP都是讨论的NAS和用户之间的验证方式。当用户上网时,NAS决定对用户采用何种验证方法。下面分别在本地验证...
    PPPOE中的PAP与CHAP
    2010年09月04日 星期六 07:33

     

    一般情况下,我们讨论PAP和CHAP都是讨论的NAS和用户之间的验证方式。当用户上网时,NAS决定对用户采用何种验证方法。下面分别在本地验证和Radius验证两种情况下介绍用户与NAS之间的PAP和CHAP验证方式。
    1)NAS本地认证
    PAP 验证(Password Authentication Protocol:密码验证协议):用户以明文的形式把用户名和密码传递给NAS。 NAS根据用户名在NAS端查找本地数据库,如果存在相同的用户名和密码表明验证通过,否则表明验证未通过。
    CHAP 验证(Challenge Handshake Authentication Protocol:挑战握手验证协议): 当用户请求上网时,服务器产生一个16字节的随机码(challenge)给用户(同时还有一个ID号,本地路由器的 host name)。用户端得到这个包后使用自己独用的设备或软件对传来的各域进行加密,生成一个Secret Password传给NAS。NAS根据用户名查找自己本地的数据库,得到和用户端进行加密所用的一样的密码,然后根据原来的16字节的随机码进行加密,将其结果与Secret Password作比较,如果相同表明验证通过,如果不相同表明验证失败。
    Secret Password = MD5(Chap ID + Password + challenge)
    Radius认证
    2)RADIUS认证
    如果用户配置了RADIUS验证而不是本地验证,过程略有不同。
    PAP验证:用户以明文的形式把用户名和他的密码传递给NAS,NAS把用户名和加密过的密码放到验证请求包的相应属性中传递给RADIUS服务器。RADIUS服务器对NAS上传的帐号进行验证并返回结果来决定是否允许用户上网。
    Secret password =Password XOR MD5(Challenge + Key)
    (Challenge就是Radius报文中的Authenticator)
    CHAP验证:当用户请求上网时,NAS产生一个16字节的随机码给用户(同时还有一个ID号,本地路由器的 host name)。用户端得到这个包后使用自己独有的设备或软件对传来的各域进行加密,生成一个Secret Password传给NAS。NAS把传回来的CHAP ID和Secret Password分别作为用户名和密码,并把原来的16字节随机码传给RADIUS服务器。RADIUS根据用户名在服务器端查找数据库,得到和用户端进行加密所用的一样的密码,然后根据传来的16字节的随机码进行加密,将其结果与传来的Password作比较,如果相同表明验证通过,如果不相同表明验证失败。另外如果验证成功,RADIUS服务器同样可以生成一个16字节的随机码对用户进行挑战询问(魔术字),该部分内容由于应用较少,此处略。
    Secret password = MD5(Chap ID + Password + challenge)
    从上面的过程看得出来,如果NAS到用户端都是一个用户一个PVC,或者一个用户一个VLAN,这时,BAS到用户端(MODEM)设置为PAP和CHAP都是无所谓的。但是如果BAS到用户端如果不是一个独立的链路,例如是一个VLAN下来到很多用户,这时,最好设置为CHAP。因为对用户的用户名和密码,CHAP是加密传送,而PAP是明文传送的的。但是,现在有些MODEM或系统不支持CHAP,也有NAS不支持,这时就没有选择了。

     

     

    先由服务器端给客户端发送一个随机码challenge,客户端根据challenge,对自己掌握的口令、challenge、会话ID进行单向散例,即md5(password1,challenge,ppp_id),然后把这个结果发送给服务器端。服务器端从数据库中取出库存口令password2,进行同样的算法,即md5(password2,challenge,ppp_id),最后,比较加密的结果是否相同。如相同,则认证通过。

    优点:安全性较SPAP有了很大改进,不用将密码发送到网络上。
    缺点:安全性还不够强健,但也不错、单向加密、单向认证、通过认证后不支持Microsoft点对点加密(MPPE)。

    4、MS-CHAP

    微软版本的CHAP,和CHAP基本上一样,区别我也不太清楚。认证后支持MPPE,安全性要较CHAP好一点。

    5、MS-CHAP V2

    微软版本的CHAP第二版,它提供了双向身份验证和更强大的初始数据密钥,而且发送和接收分别使用不同的密钥。如果将VPN连接配置为用 MS-CHAP v2作为唯一的身份验证方法,那么客户端和服务器端都要证明其身份,如果所连接的服务器不提供对自己身份的验证,则连接将被断开。

    优点:双向加密、双向认证、安全性相当高。
    缺点:不太清楚。

    6、EAP:可扩展的认证协议

    EAP可以增加对许多身份验证方案的支持,其中包括令牌卡、一次性密码、使用智能卡的公钥身份验证、证书及其他身份验证。最安全的认证方法就是和智能卡一起使用的“可扩展身份验证协议—传输层安全协议”,即EAP-TLS认证。

    优点:安全性最好。
    缺点:需要PKI(公钥基础设施)支持。(目前PKI还没有真正建立起来)

    总结:协议是一个非常复杂的内容,不是三言两语就能说清楚。但是,只要知道了这些基本内容了,就足够我们在搭建VPN时使用了。如果想了解更多内容,请查看RFC。






    展开全文
  • 一、实验目的:掌握PAP与CHAP认证配置 二、拓扑图: 三、具体步骤配置: (1)R1路由器配置: Router>enable --进入特权模式 Router#configure terminal --进入全局配置模式 Enter configuration ...

    一、实验目的:掌握PAPCHAP认证配置

    二、拓扑图:

    三、具体步骤配置:

    (1)R1路由器配置:

    Router>enable  --进入特权模式

    Router#configure terminal  --进入全局配置模式

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R1  --修改路由器名为R1

    R1(config)#interface l0  --进入回环端口

    R1(config-if)#ip address 192.168.1.254 255.255.255.0  --配置ip地址

    R1(config-if)#no shutdown  --激活端口

    R1(config-if)#exit  --返回上一级

    R1(config)#interface s0/0/0  --进入端口

    R1(config-if)#ip address 192.168.12.1 255.255.255.0  --为端口配置ip地址

    R1(config-if)#clock rate 64000  --设置时钟同步速率

    R1(config-if)#no shutdown  --激活端口

    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

    R1(config-if)#exit  --返回上一级

    R1(config)#route rip  --开启rip服务

    R1(config-router)#version 2  --版本2

    R1(config-router)#no auto-summary  --关闭路由自动汇总

    R1(config-router)#network 192.168.1.0  --添加直连网段到rip

    R1(config-router)#network 192.168.12.0

    R1(config-router)#exit  --返回上一级

    R1(config)#username abc1 password 456  --在中心路由器R1上为远程路由器R2设置用户名和密码

    R1(config)#interface s0/0/0  --进入端口

    R1(config-if)#encapsulation ppp  --封装端口为ppp

    R1(config-if)#ppp authentication pap  --在R1上,配置PAP 验证

    R1(config-if)#ppp pap sent-username abc password 123  --在中心路由器R1上为远程路由器R2设置用户名和密码

    R1(config-if)#end  --返回特权模式

    %LINK-5-CHANGED: Interface Loopback0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

    R1#

    %SYS-5-CONFIG_I: Configured from console by console

    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

     

    (2)R2路由器配置 

    Router>enable  --进入特权模式

    Router#configure terminal  --进入全局配置模式

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R2  --修改路由器名为R2

    R2(config)#interface l0  --进入回环端口

    R2(config-if)#ip address 192.168.2.254 255.255.255.0  --配置ip地址

    R2(config-if)#no shutdown  --激活端口

    R2(config-if)#exit  --返回上一级

    R2(config)#interface s0/0/0  --进入端口

    R2(config-if)#ip address 192.168.12.2 255.255.255.0  --为端口配置ip地址

    R2(config-if)#no shutdown  --激活端口

    R2(config-if)#interface s0/0/1  --进入端口

    R2(config-if)#ip address 192.168.24.2 255.255.255.0  --为端口配置ip地址

    R2(config-if)#clock rate 64000  --设置时钟同步速率

    R2(config-if)#no shutdown  --激活端口

    %LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

    R2(config-if)#exit  --返回上一级

    R2(config)#route rip  --开启rip协议

    R2(config-router)#version 2  --版本2

    R2(config-router)#no auto-summary  --关闭路由自动汇总

    R2(config-router)#network 192.168.2.0  --添加直连网段到rip

    R2(config-router)#network 192.168.12.0

    R2(config-router)#network 192.168.24.0

    R2(config-router)#exit  --返回上一级

    R2(config)#username abc password 123  --在R2上为R1设置用户名和密码

    R2(config)#username R3 password cisco  --在R2上为R3设置用户名和密码(注意两端密码要相同)

    R2(config)#interface s0/0/0  --进入端口

    R2(config-if)#encapsulation ppp  --封装端口为PPP协议

    R2(config-if)#ppp authentication pap  --配置PAP验证

    R2(config-if)#ppp pap sent-username abc1 password 456  --在R2上为R1设置用户名和密码

    R2(config-if)#interface s0/0/1  --进入端口

    R2(config-if)#encapsulation ppp  --封装端口为ppp协议

    R2(config-if)#ppp authentication chap  --配置chap验证

    R2(config-if)#end  --返回特权模式

    R2#

    %LINK-5-CHANGED: Interface Loopback0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

    %SYS-5-CONFIG_I: Configured from console by console

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

    R2#

    %LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

     

    (3)R3路由器配置:

    Router>enable  --进特权模式

    Router#configure terminal  --进入全局配置模式

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R3  --修改路由器名为R3

    R3(config)#interface l0  --进入回环端口

    R3(config-if)#ip address 192.168.3.254 255.255.255.0  --为端口配置ip地址

    R3(config-if)#no shutdown  --激活端口

    R3(config-if)#exit  --返回上一级

    R3(config)#interface S0/0/0  --进入端口

    R3(config-if)#ip address 192.168.24.1 255.255.255.0  --为端口配置ip地址

    R3(config-if)#no shutdown  --激活端口

    R3(config-if)#exit  --返回上一级

    R3(config)#route rip  --开启rip协议

    R3(config-router)#version 2  --版本2

    R3(config-router)#no auto-summary  --关闭路由自动汇总

    R3(config-router)#network 192.168.3.0  --添加直连网段到rip

    R3(config-router)#network 192.168.24.0

    R3(config-router)#exit  --返回上一级

    R3(config)#username R2 password cisco  --在R3上为R2设置用户名和密码

    R3(config)#interface s0/0/0  --进入端口

    R3(config-if)#encapsulation ppp  --封装端口为ppp协议

    R3(config-if)#ppp authentication chap  --配置chap验证

    R3(config-if)#end  --返回特权模式

    %LINK-5-CHANGED: Interface Loopback0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

    R3#

    %SYS-5-CONFIG_I: Configured from console by console

     

    四、验证测试:

    1、测试是否开启ppp认证

    (1)R1:

    (2)R2:

    (3)R3:

     

    2、查看R1S0/0/0端口信息

    如图,红色标记处表示是PPP认证

     

    3、测试全网是否互通:

    (1)R1R2

     

    (2)R2R3

     

    (3)R3R1

     

    结果:全网互通成功!!!

    转载于:https://www.cnblogs.com/evolve/p/9263741.html

    展开全文
  • PAP与CHAP对比

    千次阅读 2017-08-27 21:09:48
    在PPP验证阶段 可以支持PAP方式和CHAP方式 PAP的验证方式,是明文传输,验证中只发送2个包 CHAP的验证方式是加密传输,验证是发送3个包  1.发送Challenge报文其中包括Idchallenge字符串  2‘.MD5加密{Id +密码+...

    在PPP验证阶段 可以支持PAP方式和CHAP方式

    PAP的验证方式,是明文传输,验证中只发送2个包

    CHAP的验证方式是加密传输,验证是发送3个包

      1.发送Challenge报文其中包括Id与challenge字符串

      2‘.MD5加密{Id +密码+Challenge字符串}

      3.收的加密的报文解密对比密码结果,给对方ACK反馈


    PPP两端可以使用不同的验证方式,但对端必须支持此方法。

    展开全文
  • PAP与CHAP认证

    千次阅读 2020-02-07 18:04:59
    3、 扩展协议簇:CHAP(Challenge-Handshake Authentication Protocol)挑战握手认证协议和PAP(Password Authentication Protocol)密码认证协议,主要用于网络安全方面的验证,保证链路中协商过程的安全性,从而...

    一、PPP介绍

       PPP(point-to-point protocol)是一种点到点链路层协议,主要用于在全双工的同异步链路上进行点到点的数据传输。
    

    ##在PPP中主要由三类协议簇组成
    1、链路控制协议簇(Link Control protocol):主要用来建立、拆除和监控PPP链路。
    2、网络层控制协议簇(Network control protocol):主要用来协商在该链路上传输的数据包的格式与类型。
    3、 扩展协议簇:CHAP(Challenge-Handshake Authentication Protocol)挑战握手认证协议和PAP(Password Authentication Protocol)密码认证协议,主要用于网络安全方面的验证,保证链路中协商过程的安全性,从而保证数据传输的安全性。

    1、PPP基本配置

    PAP认证为两次握手验证、发送的用户名和密码均为明文。
    在这里插入图片描述
    如图所示,在R1、R2之间采用PPP链路连接,首先在接口下封装PPP,并且配置好IP地址。
    R1、R2:
    interface Serial2/0
    ip address 12.0.0.2 255.255.255.0 //配置IP地址
    encapsulation ppp //封装PPP协议

    2、从抓包过程看待PPP协商过程

    配置完成后链路自动进行协商,协商过程如下:
    在这里插入图片描述
    1、 在配置好PPP链路封装后,在抓包过程中可以看出,PPP链路通过LCP协议进行协商连接,LCP协商通过发送configuration Request消息进行,协商链路配置信息,通过configuration ack消息进行响应。
    消息内容中主要关注options现象字段,此字段用来说明在PPP协商过程中启用的功能,包括认证选项。
    PPP LCP协商消息
    在这里插入图片描述
    2、LCP协商完成后进行IPCP的协商,IPCP的协商通过发送IPCP相关的配置消息实现,并且通过IPCP的配置消息进行应答,在此消息中会将自身的一些配置信息发送至对方,其中最主要的信息为自身配置的IP地址信息,通过PPP IPCP协商完成后可以在自己本地看到通往对方的32位掩码的路由,如下图所示。

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    3、通过PPP CDPCP消息进行PPP邻居发现,并通过LCP Echo request消息定期发送进行维系PPP链路的连接关系,在互联网中,所有协商消息基本都是通过request,relay消息进行,PPP协商过程也不例外,由configuration request和configuration ack组成。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    二、认证阶段

    缺省情况下,PPP链路不进行验证。如果要求验证,在链路建立阶段必须指定验证协议。
    PPP验证主要是用于主机和设备之间,通过PPP网络服务器交换电路或拨号接入连接的链路,偶尔也用于专用线路。
    PPP提供密码验证协议PAP(Password Authentication Protocol)和质询握手验证协议CHAP(Challenge-Handshake Authentication Protocol)两种验证方式。
    单向验证是指一端作为验证方,另一端作为被验证方。双向验证是单向验证的简单叠加,即两端都是既作为验证方又作为被验证方。在实际应用中一般只采用单向验证。

    三、PAP认证

    1、认证流程说明

    PAP验证协议为两次握手验证,口令为明文。
    在这里插入图片描述

    1. 被验证方把本地用户名和口令发送到验证方。
    2. 验证方根据本地用户表查看是否有被验证方的用户名
    3. 若有,则查看口令是否正确,若口令正确,则认证通过;若口令不正确,则认证失败。
    4. 若没有,则认证失败。

    2、认证配置信息介绍

    选择在R1中开启PAP认证
    R1:
    interface Serial2/0
    ip address 12.0.0.1 255.255.255.0
    encapsulation ppp
    ppp authentication pap
    开启认证后在抓包信息中可以看出,LCP在协商过程中会告诉给对方,自身已开启认证。请求对方进行验证,并告诉对方自身开启的认证的类型。
    在这里插入图片描述
    在R2中接口下配置用于认证使用的用户名和密码
    R2:
    interface Serial2/0
    ip address 12.0.0.2 255.255.255.0
    encapsulation ppp
    ppp pap sent-username R2 password 0 cisco
    在这里插入图片描述
    在这里插入图片描述
    通过抓包可以发现,R2在接口下配置好pap认证的用户名和密码后,会首先发起验证请求,并且携带配置的用户名和密码首先发起。故可以看出配置了开启认证指令ppp authentication pap的一方是作为验证方存在,作为配置了用户名和密码ppp pap sent-username R2 password 0 cisco指令的一方作为被验证方存在。
    接下来在验证方R1全局下配置用户名和密码,让验证方可以通过被验证方的认证。
    R1:
    username R2 password cisco
    最终可以看到认证通过过程。
    在这里插入图片描述
    双向PAP认证需要将在两边同步开启认证,接口下配置发送的用户名和密码,在全局下配置用户名和密码确保认证可以通过。

    四、CHAP认证

    1、认证流程说明

    CHAP验证协议为三次握手验证协议。它只在网络上传输用户名,而并不传输用户密码,因此安全性要比PAP高。
    在这里插入图片描述
    CHAP单向验证过程分为两种情况:验证方配置了用户名和验证方没有配置用户名。推荐使用验证方配置用户名的方式,这样可以对验证方的用户名进行确认。
    验证方配置了用户名的验证过程(思科中username优先于接口的password)
    1) 验证方主动发起验证请求,验证方向被验证方发送一些随机产生的报文(Challenge),并同时将本端的用户名附带上一起发送给被验证方。
    2) 被验证方接到验证方的验证请求后,先检查本端接口上是否配置了ppp chap password命令,如果配置了该命令,则被验证方用报文ID、命令中配置的用户密码和MD5算法对该随机报文进行加密,将生成的密文和自己的用户名发回验证方(Response)。如果接口上未配置ppp chap password命令,则根据此报文中验证方的用户名在本端的用户表查找该用户对应的密码,用报文ID、此用户的密钥(密码)和MD5算法对该随机报文进行加密,将生成的密文和被验证方自己的用户名发回验证方(Response)。
    3) 验证方用自己保存的被验证方密码和MD5算法对原随机报文加密,比较二者的密文,若比较结果一致,认证通过,若比较结果不一致,认证失败。
    Ø 验证方没有配置用户名的验证过程(思科中无此过程)
    1) 验证方主动发起验证请求,验证方向被验证方发送一些随机产生的报文(Challenge)。
    2) 被验证方接到验证方的验证请求后,利用报文ID、ppp chap password命令配置的CHAP密码和MD5算法对该随机报文进行加密,将生成的密文和自己的用户名发回验证方(Response)。
    3) 验证方用自己保存的被验证方密码和MD5算法对原随机报文加密,比较二者的密文,若比较结果一致,认证通过,若比较结果不一致,认证失败。

    2、认证配置信息介绍

    选择在R1中开启CHAP认证
    R1:
    interface Serial2/0
    ip address 12.0.0.1 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    在R1中通过ppp authentication chap指令开启认证过后,本路由器将作为验证方存在,对方路由器将作为被验证方存在,由验证方首先发起验证请求,最开始没有由于没有配置用户名和密码等相关信息,所以会将自己的主机名作为用户名向对方发送验证请求。如果对方
    在这里插入图片描述在这里插入图片描述
    选择在R2接口下配置用户名和密码
    R2:
    interface Serial2/0
    ip address 12.0.0.2 255.255.255.0
    encapsulation ppp
    ppp chap hostname R2
    ppp chap password 0 cisco
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    从抓包中可以看出,首先由验证方发起验证请求,以自己的主机名作为用户名进行发送,在被验证方接口下配置了用户名和密码后,被验证方会采用本地接口下配置的用户名和密码进行回应,然后由验证方在本地查找被验证方发送的用户名进行匹配,确认验证是否可以通过。
    本地配置用户和密码方式完成验证
    在配置认证过程中,可以选择在接口下配置用户名和密码的方式,也可选择在本地配置用户和密码的方式完成认证:
    R1:
    interface Serial2/0
    ip address 12.0.0.1 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    R1(config)#do show run | s username
    username R2 password 0 cisco
    R2:
    R2(config)#do show run | s username
    username R1 password 0 cisco
    在这里插入图片描述
    在全局下配置用户名和密码方法同样可以完成CHAP的认证需求,过程同接口下配置相同,cisco下全局优先于接口下的配置。

    展开全文
  • PAP与CHAP认证原理

    2017-07-01 13:39:03
    一、PAP认证协议(PasswordAuthenticationProtocol,口令认证协议): PAP认证过程非常简单,二次握手机制。 使用明文格式发送用户名和密码。 发起方为被认证方,可以做无限次的尝试(暴力破解)。 只在链路建立...
  • pap与chap协议

    2014-01-06 14:36:00
    1.pap:直接在网络上发送密码明文 2.chap: 网络上发送的是密码的密文;server给client发一段随机数(challenge),client利用随机数对密码进行加密,将用户名和加密后的密码发送给server;server根据用户名在数据库中...
  • 多链路下PAP与CHAP认证的配置 PPP协议支持用户的认证,是广域网接入使用最广泛的协议 PPP协议支持两种认证协议 1, PAP(Password Authentication Protocol,口令认证协议) 2, CHAP(Challenge Handshake ...
  • PAP与CHAP认证过程详解

    千次阅读 2015-07-22 12:00:39
    一、PAP认证协议(PasswordAuthenticationProtocol,口令认证协议):PAP认证过程非常简单,二次握手机制。使用明文格式发送用户名和密码。发起方为被认证方,可以做无限次的尝试(暴力破解)。只在链路建立的阶段...
  • R1(config-if)#ppp authentication pap //使用pap认证方式 R1(config-if)#ppp pap sent-username Router1 password 123 //传输用户名和密码 Router4的配置 Router>en Router#conf t Router(config)#hostname ...
  • H3C(27)——PAP与CHAP

    2020-10-18 20:29:22
    1.PAP的单向认证 【R1】 <RouterA> system-view [RouterA] local-user userb class network [RouterA-luser-network-userb] password simple passb [RouterA-luser-network-userb] service-type ppp ...
  • PPP的PAP与CHAP

    千次阅读 2010-01-10 16:49:00
     CHAP认证比PAP认证更安全,因为CHAP不在线路上发送明文密码,而是发送经过摘要算法加工过的随机序列,也被称为" 挑战字符串 ".如图1所示。 同时,身份认证可以随时进行,包括在双方正常通信过程中 。因此,非法...
  • PAP与CHAP验证的区别

    2010-05-25 23:24:13
    PAP 验证为两次握手验证,口令为明文,PAP 验证的过程如下: 被验证方发送用户名和口令到验证方;验证方根据用户配置查看是否有此用户以及口令是否正确,然后返回不同的响应(Acknowledge or Not Acknowledge)。 如...
  • PAP与CHAP认证简介

    千次阅读 2006-11-02 17:07:00
    PAP(口令验证协议 Password Authentication ...很明显,这种验证方式的安全性较差,第三方可以很容易的获取被传送的用户名和口令,并利用这些信息NAS建立连接获取NAS提供的所有资源。所以,一旦用户密码被第三方窃
  • 认证方在本地将s和c作为输出,用同一散列函数计算散列值A2,并A1进行比较。若A2=A1,说明被认证方拥有正确的共享秘密,通过认证返回Success,否则返回Failure。 转载于:...
  • 三、PPP之PAP与CHAP经典验证案例 1、HDLC   由于CISCO设备默认封装为HDCL协议,此协议优点是简单,也因此决定了其不支持认证,不能保证安全性。   R1#show int s1/0    #可查看到接口S1/0默认封装的...
  • ADSL拨号的PAP与CHAP验证的区别

    千次阅读 2010-06-25 10:50:00
    PAP 验证为两次握手验证,口令为明文,PAP 验证的过程如下: 被验证方发送用户名和口令到验证方; 验证方根据用户配置查看是否有此用户以及口令是否正确,然后返回不同的响应 (Acknowledge or Not Acknowledge...
  • 学习-PPP的PAP与CHAP

    2007-06-10 23:35:01
     CHAP认证比PAP认证更安全,因为CHAP不在线路上发送明文密码,而是发送经过摘要算法加工过的随机序列,也被称为" 挑战字符串 ".如图1所示。 同时,身份认证可以随时进行,包括在双方正常通信过程中 。因此,非法...
  • PAP与CHAP的比较 。CHAP的优点是由验证方发出挑战报文才开始认证过程,可以保护验证方资源,防止拒绝服务***。MD5算法不可逆,口令即使被捕获到也无法破解,并且,在链接过程中也会做验证,验证方发送的随机字符串...
  • PAPCHAP的配置实现应用实例.docx
  • PPP协议PAPCHAP认证实验 PPP协议PAPCHAP认证实验
  • papchap交叉认证:R1启动pap,R2启动chap。R1上的配置:Router>enRouter#config tRouter(config)#enable s ciacoRouter(config)#line c 0Router(config-line)#pass ciacoRouter(config-line)#loginRouter...
  • PAP,CHAP协议数据包

    2017-11-17 14:05:10
    包含PAP协议过程,CHAP协议过程的具体数据包。可以供给各个协议分析人员做协议分析学习使用。也可以用于验证网络协议相关学习。
  • 广域网链入HDLC、PPP PAPCHAP、MP实验报告,包含实验过程、截图,采用华三设备进行实验的,最后对整个实验进行了总结
  • PAPCHAP认证

    2017-01-02 13:50:35
    实验名称:PPP PAPCHAP)认证实验目的:掌握PPP PAPCHAP)认证的过程及配置PPP 协议位于 OSI 七层模型的数据链路层,PPP 协议按照功能划分为两个子层:LCP、NCP。LCP 主要负责链路的协商、建立、回拨、认证、数据...
  • PAPCHAP认证的区别

    千次阅读 2019-06-21 11:22:47
    昨天客户反馈了一个问题,portalrudis服务器弹出的portal是个错误界面,各种排查问题,看portal字段,看日志没找到问题,最后一个一个去看portalrudis服务器的配置,发现有一个认证字段PAP/CHAP,不太了解,百度了...
  • PAPCHAP的区别

    千次阅读 2018-11-01 16:03:20
    PAPCHAP的区别: 区别在于认证过程,PAP是简单认证,明文传送,客户端直接发送包含用户名/口令的认证请求,服务器端处理并回应。而CHAP是加密认证,先由服务器端给客户端发送一个随机码challenge,客户端根据challenge...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,837
精华内容 2,334
关键字:

pap与chap