精华内容
下载资源
问答
  • 主要为大家介绍了华为S5700交换机配置VLAN的方法,不知道如何配置的朋友可以进来学习一下,内容简单易懂,很容易上手,需要的朋友可以参考下
  • H3C交换机怎么划分VLAN

    千次阅读 2016-03-24 14:57:37
    H3C交换机怎么划分多个VLAN,如何给将交换机接口加入VLAN并设置VLAN的接口IP呢。 首先通过CONSOLE口或Telnet连接交换机,连接成功后,进入用户视图模式“",如图所示: 在用户模式下输入”sys“,进入系统...

    H3C交换机怎么划分多个VLAN,如何给将交换机接口加入VLAN并设置VLAN的接口IP呢。

    首先通过CONSOLE口或Telnet连接交换机,连接成功后,进入用户视图模式“<H3C>",如图所示:

    <H3C>

    在用户模式下输入”sys“,进入系统视图模式”[H3C]“,如图所示:

    <H3C>sys
    [H3C]

    在系统视图模式下创建两个VLAN,一个VLAN 20,一个VLAN 30,如图所示:

    [H3C]vlan 20
    [H3C-vlan20]quit
    [H3C]vlan 30
    [H3C-vlan30]quit
    [H3C]

    接下来将交换机的接口加入到相应的VLAN中,将g1/0/5加入到VLAN 20,将g1/0/6加入到VLAN 30,如图所示:

    [H3C]vlan 20
    [H3C-vlan20]port g1/0/5
    [H3C-vlan20]quit
    [H3C]vlan 30
    [H3C-vlan30]port g1/0/6
    [H3C-vlan30]quit
    [H3C]

    最后再设置VLAN的接口IP地址,VLAN 20设置为192.168.20.1/24,VLAN 30设置为192.168.30.1/24,如图所示:

    [H3C]
    [H3C]int vlan 20
    [H3C-Vlan-interface20]ip add 192.168.20.1       255.255.255.0
    [H3C]int vlan 30
    [H3C-Vlan-interface30]ip add 192.168.30.1   255.255.255.0
    [H3C]
    [H3C]int vlan 30
    [H3C-Vlan-interface30]ip add 192.168.30.1       255.255.255.0
    展开全文
  • 怎么划分Vlan?(转)

    2007-08-12 15:40:36
    怎么划分Vlan?(转)[@more@]我们知道,传统的局域网Ethernet 使用具有冲突检测的载波监听多路访问( CSMA / CD )方法。在CSMA / CD 网络中,节点可以在它们有数据需要发送的任何时候使用网络。在节...
    怎么划分Vlan?(转)[@more@]我们知道,传统的局域网Ethernet 使用具有冲突检测的载波监听多路访问( CSMA / CD )方法。在CSMA / CD 网络中,节点可以在它们有数据需要发送的任何时候使用网络。在节点传输数据之前,它进行"监听"以了解网络是否很繁忙。如果不是,则节点开始传送数据。如果网络正在使用,则节点等待。如果两个节点进行监听,没有听到任何东西,而开始同时使用线路,则会出现冲突。在发送数据时,它如果使用广播地址,那么在此网段上的所有PC都将收到数据包,这样一来如果该网段PC众多,很容易引起广播风暴。而冲突和广播风暴是影响网络性能的重要因素。为 解 决这一问题,引入了虚拟局域网(VLAN的概念。
      虚拟网络是在整个网络中通过网络交换设备建立的虚拟工作组。虚拟网在逻辑上等于OSI模型的第二层的广播域,与具体的物理网及地理位置无关。虚拟工作组可以包含不同位置的部门和工作组,不必在物理上重新配置任何端口,真正实现了网络用户与它们的物理位置无关。虚拟网技术把传统的广播域按需要分割成各个独立的子广播域,将广播限制在虚拟工作组中,由于广播域的缩小,网络中广播包消耗带宽所占的比例大大降低,网络的性能得到显著的提高。我们结合下面的图来看看讲下。图1所表示的是两层楼中的相同性质的部门划分到一个VLAN中,这样,会计的数据不会向市场的机器上广播,也不会和市场的机器发生数据冲突。所以VLAN有效的分割了冲突域和广播域。

      我们可以在交换机的某个端口上定义VLAN ,所有连接到这个特定端口的终端都是虚拟网络的一部分,并且整个网络可以支持多个VLAN。VLAN通过建立网络防火墙使不必要的数据流量减至最少,隔离各个VLAN间的传输和可能出现的问题,使网络吞吐量大大增加,减少了网络延迟。在虚拟网络环境中,可以通过划分不同的虚拟网络来控制处于同一物理网段中的用户之间的通信。这样一来有效的实现了数据的保密工作,而且配置起来并不麻烦,网络管理员可以逻辑上重新配置网络,迅速、简单、有效地平衡负载流量,轻松自如地增加、删除和修改用户,而不必从物理上调整网络配置。既然VLAN有那么多的优点,我们为什么不了解它从而把VLAN技术应用到我们的现实网络管理中去呢。好的让我们通过实际的在Catalyst 1900交换机上来配置静态VLAN的例子来看看如何在交换机上配置VLAN。



    图1 在Catalyst 1900 上的两个VLAN

      设置好超级终端,连接上1900交换机后(可以参考《1900系列以太网交换机快速入门指南》或其他的CISCO参考资料),会出现如下的主配置界面:

    -------------------------------------------------

    1 user(s) now active on Management Console.

    User Interface Menu

    [M] Menus

    [K] Command Line

    [I] IP Configuration

    Enter Selection:

      我们简单介绍下,这儿显示了三个选项,[M] Menus 是主菜单,主要是交换机的初始配置和监控交换机的运行状况。[K] Command Line 是命令行,很象路由器里面用命令来配置和监控路由器一样,主要是通过命令来操作。[I] IP Configuration 是配置IP地址、子网掩码和默认网管的一个选项。这是第一次连上交换机显示的界面,如果你已经配置好了IP Configuration,那么下次登陆的时候将没有这个选项。因为用命令配置简洁明了,清晰易懂,所以我们通过 [K] Command Line 来实现VLAN的配置的。

    设置好超级终端,连接上1900交换机后(可以参考《1900系列以太网交换机快速入门指南》或其他的CISCO参考资料),会出现如下的主配置界面:

    -------------------------------------------------

    1 user(s) now active on Management Console.

    User Interface Menu

    [M] Menus

    [K] Command Line

    [I] IP Configuration

    Enter Selection:

      我们简单介绍下,这儿显示了三个选项,[M] Menus 是主菜单,主要是交换机的初始配置和监控交换机的运行状况。[K] Command Line 是命令行,很象路由器里面用命令来配置和监控路由器一样,主要是通过命令来操作。[I] IP Configuration 是配置IP地址、子网掩码和默认网管的一个选项。这是第一次连上交换机显示的界面,如果你已经配置好了IP Configuration,那么下次登陆的时候将没有这个选项。因为用命令配置简洁明了,清晰易懂,所以我们通过 [K] Command Line 来实现VLAN的配置的。

    我们选择 [K] Command Line ,进入命令行配置

    Enter Selection:K 回车

    CLI session with the switch is open.

    To end the CLI session,enter [Exit ].

    >

      现在我们进入到了交换机的普通用户模式, 就象路由器一样,这种模式只能查看现在的配置,不能更改配置,并且能够使用的命令很有限。我们输入enable,进入特权模式:

    >enable

    #config t

    Enter configuration commands,one per line.End with CNTL/Z

    (config)#

    为了安全和方便起见,我们给这个交换机起个名字,并且设置登陆密码。

    (config)#hostname 1900Switch

    1900Switch(config)# enable password level 15 goodwork

    1900Switch(config)#

    注意:密码必须是4-8位的字符。交换机密码的设置和路由器稍微不同,交换机用 level 级别的大小来决定密码的权限。Level 1 是进入命令行界面的密码,也就是说,设置了 level 1 的密码后,你下次连上交换机,并输入 K 后,就会让你输入密码,这个密码就是 level 1 设置 的密码。而 level 15 是你输入了enable命令后让你输入的特权模式密码。路由器里面是使用 enable password 和 enable screet做此区分的。

    好拉,我们已经设置好了名字和密码这样就足够安全了,让我们设置VLAN。VLAN的设置分以下2步:

    1. 设置VLAN名称

    2. 应用到端口

       我们先设置VLAN的名称。使用 vlan vlan号 name vlan名称。 在特权配置模式下进行配置:

    1900Switch (config)#vlan 2 name accounting

    1900Switch (config)#vlan 3 name marketing

       我们新配置了2个VLAN,为什么VLAN号从2开始呢?这是因为默认情况下,所有的端口否放在VLAN 1上,所以要从2开始配置。1900系列的交换机最多可以配置1024个VLAN,但是,只能有64个同时工作,当然了,这是理论上的,我们应该根据自己网络的实际需要来规划VLAN的号码。配置好了VLAN名称后我们要进入每一个端口来设置VLAN。在交换机中,要进入某个端口比如说第4个端口,要用 interface Ethernet 0/4,好的,结合上面给出的图我们让端口2、3、4和5属于VLAN2 ,端口17---22属于VLAN3 。命令是 vlan-membership static/ dynamic VLAN号 。 静态的或者动态的两者必须选择一个,后面是刚才配置的VLAN号。好的,我们看结果:

    1900Switch(config)#interface ethernet 0/2

    1900Switch(config-if)#vlan-membership static 2

    1900Switch(config-if)#int e0/3

    1900Switch(config-if)#vlan-membership static 2

    1900Switch(config-if)#int e0/4

    1900Switch(config-if)#vlan-membership static 2

    1900Switch(config-if)#int e0/5

    1900Switch(config-if)#vlan-membership static 2

    1900Switch(config-if)#int e0/17

    1900Switch(config-if)#vlan-membership static 3

    。。。。。。

    1900Switch(config-if)#int e0/22

    1900Switch(config-if)#vlan-membership static 3

    1900Switch(config-if)#

       好的,我们已经把VLAN都定义到了交换机的端口上了。这儿,我们只是配置的静态的,关于动态的,我们在后面会有提及的。到现在为止,我们已经把交换机的VLAN配置好了,怎么样,没有你想象的那么复杂吧:)。为了验证我们的配置,我们在特权模式使用 show vlan命令。输出如下:

    1900Switch(config)#show vlan

    VLAN Name Status Ports

    --------------------------------------

    1 default Enabled 1,6-16,22-24,AUI,A,B

    2 acconting Enabled 2-5

    3 marketing Enabled 17-22

    1002 fddi-default Suspended

    1003 token-ring-defau Suspended

    1004 fddinet-default Suspended

    1005 trnet-default Suspended

      这是一个24口的交换机,并且带有AUI和两个100兆端口(A、B),可以看出来,我们的设置已经正常工作了,什么,还要不要保存running configure?当然不用了,交换机是即时自动保存的,所以不用我们使用命令来保存设置了。当然了,你也可以使用 show vlan vlan号 的命令来查看某个VLAN,比如show vlan 2 , show vlan 3. 还可以使用show vlan-membership ,改命令主要是显示交换机上的每一个端口静态或动态的属于哪个VLAN。

      以上是给交换机配置静态VLAN的过程,下面我们看看动态的VLAN。动态的V L A N 形成很简单,由端口自己决定它属于哪个V L A N 时,就形成了动态的V L A N 。不过,这并不意味着就一层不变了,它只是一个简单的映射,这个映射取决于网络管理员创建的数据库。分配给动态V L A N 的端口被激活后,交换机就缓存初始帧的源M A C 地址,随后,交换机便向一个称为VMPS (V L A N 管理策略服务器)的外部服务器发出请求,V M P S 中包含一个文本文件,文件中存有进行V L A N 映射的M A C 地址。交换机对这个文件进行下载,然后对文件中的M A C 地址进行校验。如果在文件列表中找到M A C 地址,交换机就将端口分配给列表中的V L A N 。如果列表中没有M A C 地址,交换机就将端口分配给默认的V L A N (假设已经定义默认了V L A N )。如果在列表中没有M A C 地址,而且也没有定义默认的V L A N ,端口不会被激活。这是维护网络安全一种非常好的的方法。从表面上看,动态V L A N 的优势很大,但它也有致命的缺点,即创建数据库是一项非常艰苦而且非常繁琐的工作。如果网络上有数千个工作站,则有大量的输入工作要做。即使有人能胜任这项工作,也还会出现与动态的V L A N 有关的很多问题。另外,保持数据库为最新也是要随时进行的非常费时的工作。所以不经常用到它,这里我们就不做详细的讲解,可以参考相关的CISCO的文档资料。

      这么样,没有你想象的那么复杂吧。我们已经把VLAN配置好了,那么VLAN的另一部分不容忽视的工作,就是前期的对网络的规划。就是说,哪些机器在一个VLAN中,各自的IP地址、子网掩码如何分配,以及VLAN之间互相通讯的问题。只有规划计划好了,才能够在配置和以后的使用维护过程中轻松省事。

    来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/10617731/viewspace-950416/,如需转载,请注明出处,否则将追究法律责任。

    转载于:http://blog.itpub.net/10617731/viewspace-950416/

    展开全文
  • 由于没有做过linux主机划分VLAN的操作,因此去查了一下,需要利用vconfig这个命令。 但是纠结的是,系统源中没有这个包。(很坑爹的一件事,找了很久才知道) 最后解决的办法是找到了第三方源: rpm -e epel-...

    前几天公司一台物理机需要连接公网,但是公网需要网卡打标签上去。

    由于没有做过linux主机划分VLAN的操作,因此去查了一下,需要利用vconfig这个命令。

    但是纠结的是,系统源中没有这个包。(很坑爹的一件事,找了很久才知道)

    最后解决的办法是找到了第三方源:

    rpm -e epel-release
    #首先卸载以前装的epel 以免影响
    wget -P /etc/yum.repos.d/  http://mirrors.aliyun.com/repo/epel-6.repo
    # 下载阿里提供的epel 
    yum makecache
    #更新缓存
    yum -y install vconfig

     利用这个顺利的装上了vconfig这个命令。

     

    打标签的话也很简单,分为这几步:

    1.安装vlan(vconfig)和加载8021q模块
    #aptitude install vlan
    #modprobe 8021q
    或:
    #yum install vconfig
    #modprobe 8021q
    #lsmod |grep -i 8021q
    2.先将VLAN划分出来,注意这个是在物理网卡上做的
    #vconfig add eth0 100
    #vconfig add eth0 200 在eth0接口上配置两个VLAN
    #vconfig set_flag eth0.100 1 1
    #vconfig set_flag eth0.200 1 1
    #设置VLAN的REORDER_HDR参数,默认就行了。 可以使用cat /proc/net/vlan/eth0.100查看eth0.100参数 配置网络信息
    #ifconfig eth0 0.0.0.0
    #ifconfig eth0.100 192.168.100.50 netmask 255.255.255.0 up
    #ifconfig eth0.200 192.168.200.50 netmask 255.255.255.0 up
    删除VLAN命令
    #vconfig rem eth0.100 #vconfig rem eth0.200 

     

    转载于:https://www.cnblogs.com/sexiaoshuai/p/7171449.html

    展开全文
  • <Huawei>system-view 进入配置模式 Enter system view, return user view with Ctrl+Z. [Huawei]sysname center_switch 更改交换机名 创建vlan [center_switch]vlan 40...

    <Huawei>system-view                         进入配置模式

    Enter system view, return user view with Ctrl+Z.

    [Huawei]sysname center_switch            更改交换机名

    创建vlan

    [center_switch]vlan 40                           

    [center_switch-vlan40]quit

    给vlan配置IP地址           

    [center_switch]interface Vlanif 40       

    [center_switch-Vlanif40]ip address 10.10.40.1 255.255.255.0

    将某个端口加入到vlan中

    [center_switch] interface port GigabitEthernet 0/0/24

    [center_switch-GigabitEthernet0/0/24]port link-type access

    [center_switch-GigabitEthernet0/0/24]port default vlan40

    将交换机中一组端口加入到一个VLAN中

    创建vlan

    [center_switch]vlan 42

    [center_switch-vlan42]quit

    给vlan 配置IP地址

    [center_switch]interface Vlanif 42

    [center_switch-Vlanif42]ip add

    [center_switch-Vlanif42]ip address 10.10.42.1 255.255.255.0

    创建端口组

    [center_switch]port-group port1to8forvlan40

    将相应的端口加入组中

    [center_switch]port-group port1to8forvlan40]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/8

    设置端口方式

    [center_switch-port-group-port1to8forvlan42]port link-type access

    设置端口组默认vlan(即之前创建好的vlan ID 42)

    [center_switch-port-group-port1to8forvlan42]port default vlan 42

    [center_switch]display vlan

    <center_switch>save

    [Quidway] display version

    显示VRP版本号 

    [Quidway] display current-configuration

    显示系统运行配置信息

    [Quidway] display saved-configuration

    显示保存的配置信息

    [Quidway] display interfaces brief

    显示接口配置信息

    [Quidway]display ip routing-table

    显示路由表 

    [Quidway]display systname 

    命令用来显示路由器的名称

    以上就是华为S5700交换机配置VLAN的方法,谢谢阅读,希望能帮到大家,请继续关注脚本之家,我们会努力分享更多优秀的文章。

     

    如果是配置trunk口,则如下:

    port link-type trunk
     port trunk allow-pass vlan all

    转载于:https://www.cnblogs.com/jeamlu/p/9261598.html

    展开全文
  • 用配置线通过console口进入交换机配置网管IP方法:interface vlan 1 //进入vlan 1接口ip address 192.168.1.1 255.255.255.0 //设置IP以后便可以远程telnet此IP进入交换机了。配置telnet方法:思科交换机下:...
  • VLAN是一种比较新的'技术,工作在OSI参考模型的第2...那么在思科交换机上怎么划分vlan,一起来看看吧!//添加vlanSwitch>enableSwitch#vlan dataSwitch(vlan)#vlan 10 name v1VLAN 10 added:Name: v1Switch(vlan)#...
  • 交换机已划分vlan 从左到右为1,2,3,怎么从pc1经过交换机和路由器访问到vlan2的服务器和vlan3的服务器![图片说明](https://img-ask.csdn.net/upload/202002/27/1582769312_923341.png)
  • 交换机 VLAN划分

    2019-08-09 19:04:00
    交换机怎么划分VLAN?本次的实验很简单,就是通过VLAN的划分,使不同VLAN之间无法通信,但是相同VLAN不受影响。 实验拓扑 在一台交换机下连接三台VPC,划分VLAN,地址规划如下: 名称 接口 VLAN 地址 PC1 ...
  • 如下图所示: 5 在jisjsw交换机上创建VLAN 10、VLAN20、VLAN30、VLAN40、VLAN99,配置命令如下: jisjsw#enable jisjsw#conf t Enter configuration commands, one per line. End with CNTL/Z. jisjsw(config)#int ...
  • 跨两台交换机划分VLAN

    2016-05-14 05:35:30
    两台PC机在同一个vlan10,但一台为控制机并又建了vlan20,求着两台机子怎么通信
  • 本次学习:华为S5700怎么划分VLAN? 把vlan划分到端口上大概思路:①创建VLAN②进入端口中,改变端口模式③将端口划入到VLAN中④查看是否成功把端口加入到VLAN 里 打开eNSP模拟器 选择交换机拖动S5700到拓扑图上,...
  • 2950划分VLAN的问题

    2009-03-27 21:36:27
    无论怎么配就只有VLAN 1有地址 其他的VLAN 都配不上 在网上查了一下 2950是二层交换 可以划多个VLAN,也可以配置多个IP地址 但是只有VLAN 1 是UP 的其他的都是DOWN的 模拟器失真也有可能 没有真实设备 明天...
  • 2 划分子网和在交换机设VLAN 从原理上来说应该是一样的吧 但是设置VLAN在交换机比较好设置 划分子网不好划分 这两个子网段在同一个交换机下 我该怎么设置主机的IP呢?不可能每台电脑设置一个固定IP吧?这样有点麻烦 ...
  • 华为二层交换机VLAN常用命令华为二层交换机怎么划分VLAN,划分VLAN常用命令有哪些?下面yjbys小编为大家分享最新的华为二层交换机划分VLAN常用命令,希望对大家学习有帮助!现有一台华为s5700交换机和普通交换机数台,...
  • 简单的VLAN划分

    2019-09-03 19:33:21
    怎么快乐地进行简单的VLAN划分 ** 前期准备 首先给自己搞一个ENSP,华为官网上捋一个装好,就可以快乐地看下面的内容了 实验设备 两台华为5700交换机,4台PC(PC可以用路由器代替),跳线若干条。 ...
  • 怎么解决广播风暴分割广播域1.物理分割2.逻辑分割 vlan-----------------------------------------------------------------------------------------------------------------------------------------------------...
  • vlan

    2010-12-10 09:21:29
    最近公司要网络整改,以前用的是域管理的,现在要根据不通的部门划分不通的VLAN,但是客户端还想用域管理,改怎么做?划分VLAN后除了开放端口外还要做什么配置吗?下面是我要划分VLAN VLANVLAN名称 IP网段 ...
  • system-view [Switch] interface vlan-interface 1 [Switch-Vlan-interface1] ip address 172.16.1.1 255.255.255.0 [Switch-Vlan-interface1] ip address 172.16.2.1 255.255.255.0 sub # 在 172.16.1.0/24 网段中...
  • WiFi怎么划分VLAN(房间) 思科模拟器:信息嵌入 交换机(switch):是一种用于电光信号转发的网络设备,可以接入交换机的任意两个网络节点提供独享的电信号通路,最常见的交换机是以太网交换机。 单模:支持几百...
  • 一、VLAN 间路由在交换机上划分 VLAN 后,VLAN 间的计算机就无法通信了。VLAN 间的通信需要借助第三层设备,我们可以使用路由器来实现这个功能,如果使用路由器通常会采用单臂路由模式。实践上,VLAN 间的路由大多是...
  • 一、VLAN 间路由在交换机上划分 VLAN 后,VLAN 间的计算机就无法通信了。VLAN 间的通信需要借助第三层设备,我们可以使用路由器来实现这个功能,如果使用路由器通常会采用单臂路由模式。实践上,VLAN 间的路由大多是...
  • VLAN怎么做到缩小广播域的?

    千次阅读 2018-11-08 15:21:18
    关于VLAN(Virtual Loacl Area Network,虚拟局域网)...正如之前的文章所提到,主机有可能并不感知VLAN的存在,对各个主机进行VLAN划分的是交换机以及其他管理系统,那么缩小广播域的工作也是在交换机上进行。连接...
  • vlan是什么?逻辑的划分成一个个...怎么建立vlan?通过vconfig建立vlan 什么是vconfig?工具用来配置vlan 使用vconifg配置vlan之前要加载一个模块8021q模块 modprobe 8021q lsmod |grep -i 8021q 创建和删除 ...
  • 2. 划分VLAN优点? 管理方便;安全。 3. 怎么创建VLAN? 交换机进入到conf t模式后,直接在命令行输入vlan 2.....就可以创建了 4. 怎么把创建的VLAN改名字? 输入过vlan 2之后,在后面接着输入name teaher,就可以...
  • VLAN Tag,PVID

    2020-02-02 20:56:00
    但是就上述而言,对VLAN划分就是以交换机为主语的,也就是说,主机并不感知VLAN的存在,那么关于报文中VLAN的标签到底是怎么回事呢? 首先,我们先来说一下交换机的端口。 交换机的端口以三种分类: Acces...

空空如也

空空如也

1 2 3 4 5 6
收藏数 101
精华内容 40
关键字:

怎么划分vlan