精华内容
下载资源
问答
  • 思科模拟器三种命令模式

    千次阅读 2020-01-12 21:36:03
    一:前言 IOS(InternetWork Operating System互联网操作系统)...为了安全,IOS提供了三种命令行模式,分别是User Mode(用户模式),Privileged Mode(特权模式),GlobalMode(全局模式),不同模式下,用户具有不同的配...

    一:前言

    IOS(InternetWork Operating System 互联网操作系统)是Cisco网络设备的核心系统软件,IOS用户界面是命令行接口界面,用户可以通过输入命令实现对网络设备的配置和管理。

    为了安全,IOS提供了三种命令行模式,分别是User Mode(用户模式),Privileged Mode(特权模式),Global Mode(全局模式),不同模式下,用户具有不同的配置和管理网络设备的权限

    二:用户模式

    用户模式是权限最低的命令行模式,用户只能通过命令查看一些网络设备的状态,没有配置网络设备的权限,也不能修改网络设备状态和控制信息。

    用户登录网络设备后,立即进入用户模式,如下图所示:

    其中Router是默认的主机名,全局模式下可以通过hostname修改默认的主机名

    在用户模式下可以输入命令提示符,显示一些命令

    三:特权模式

    用户可以在用户模式下,输入enable进入特权模式,如下图所示

    为了安全,可以在全局模下通过命令enable  passward abc 设置进入特权模式的口令abc ,此时从用户模式进入特权模式,需要输入密码,如下图所示

    此时Router也是默认的主机名

    特权模式下,用户可以修改网络设备的状态和控制信息,如交换机转发表,但不能配置网络设备

    输入命令提示符,也可以查看一些命令

    四:全局模式

    可以在特权模式下输入命令configure terninal 或者使用简写config 进入全局模式,如下图所示

    同样Router是默认的主机名称

    全局模式下用户可以对网络设备进行配置,如配置路由器的路由协议和参数,对交换机基于端口划分VLAN

    全局模式下,用户可以完成对整个网络设备的有效配置,如果需要完成对网络设备部分功能块的配置,如路由器接口的配置,需要从全剧模式下进入这些功能块的配置模式,从全局模式进入路由器接口GigabitEthernet 0/0 的接口配置模式需要输入的命令以及路由器接口配置模式的命令提示符如下

    输入命令提示符可以查看命令

    五:总结

    1.用户模式下最主要用来查看网络设备的状态

    2.特权模式下最主要用来修改网络设备的状态和控制信息、

    3.全局模式最主要用来进行网络设备的配置

    展开全文
  • cisco三种模式

    2019-10-08 00:35:01
    *最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令 *要到达全局配置模式,你必须先得处在特权执行模式 *而要配置具体的东东就得从全局配置模式下进入到相应的子配置...

     

    *最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令

    *要到达全局配置模式,你必须先得处在特权执行模式

    *而要配置具体的东东就得从全局配置模式下进入到相应的子配置模式下。比如:
      Router(config-if)# //具体的接口配置
      Router(config-line)# //line模式配置,比如console和vty这些哈
      Router(config-router)# //路由器模式,比如配置路由协议时

     
     
     

     

     

    转载于:https://www.cnblogs.com/hyit/articles/4907330.html

    展开全文
  • 摘要:VLAN中继协议,VTP,VLAN TRUNKING PROTOCOL,是CISCO专用协议,大多数交换机都支持该协议。VTP负责在VTP域内同步VLAN信息,这样就不必在每个交换上配置相同的VLAN信息。VTP还提供一映射方案,以便通信流能...

    摘要:

    VLAN中继协议,VTP,VLAN TRUNKING PROTOCOL,是CISCO专用协议,大多数交换机都支持该协议。VTP负责在VTP域内同步VLAN信息,这样就不必在每个交换上配置相同的VLAN信息。VTP还提供一种映射方案,以便通信流能跨越混合介质的骨干。VTP最重要的作用是,将进行变动时可能会出现在的配置不一致性降至最低。不过,VTP也有一些缺点,这些缺点通常都与生成树协议有关.

    简述:

    如果两台以及两台以上的交换机,具有相同的区域,相同的vlan,那么我们必须在所有的交换机上创建那些区域,vlan,这对于大型企业局域网来说是相当麻烦的:

    ①网络管理员,对于交换机的配置相当烦杂;

    ②网络管理员,对于交换机的管理相当烦杂,如果任意一台出现故障,就必须重新配置vlan,因此维护相当困难。

    VTP的概念描述:

    Vtp就是能够实现在多台交换机上共享vlan信息的协议。

    它是通过以下方式来实现这一功能的:

    ①交换机之间必须用trunk模式的线路连接(前提)

    ②采用“域(domain)”来组织多个交换机;

    ③采用服务器/客户机模式管理多个交换机vlan;

    ④根据vtp配置版本号的大小,同步vlan信息。

    如何配置VTP域(Domain)

    问题:何为“域”?

    “域“可以理解为一个区域,只有域名相同的交换机才能共享vlan信息,才可以实现VTP共享;

    命令:

    方法1:在全局模式下,直接输入vtp   domain  domain-name  //domain-name为域名

    方法2:

    ①在特权模式下,进入vlan数据库vlan database

    ②指定域名vtp domain domain-name //domain-name为域名

    VTP有三种模式:

    6d27afabe8be213ce623efb1c485f47a.gif

    1.Server(默认)服务器模式:

    交换机被配置成服务器模式时,该交换机能够创建、删除、修改vlan;并且它配置的vlan信息能够传输到其他处于server或client模式下的交换机。交换 机默认处于服务器模式,即server。

    2.Client-客户端模式:

    交换机被配置成客户机模式时,该交换机不允许创建、删除、修改vlan;它只能够接受其他处于服务器 模式或透明模式的vlan信息,并更新自己的数据库。处于该模式的交换机在断电后,vlan信息自动消失。

    3.Transparent-透明模式

    交换机被配置成透明模式时,该交换机只转发其他交换机的vlan信息,不通告自己信息,也不根据别人信息更新自己的信息。

    如何配置VTP服务器/客户模式:

    命令:

    1.配置交换机为服务器模式vtp mode server

    2.配置交换机为客户机模式vtp mode client

    3.配置交换机为透明模式vtp mode transparent

    查看交换机vtp信息命令:show vtp status  //特权模式输入

    为vtp区域创建密码:

    说明:配置vtp密码有助于防止非法交换机任意接入vtp域,带来不安全隐患 ;但是此时,密码必须在所有交换机配置。

    命令:

    在任意交换机上,配置一下命令vtp password xxx

    注意:vtp密码为明文,配置时,应配置尽可能复杂的密码

    查看vtp域密码命令:show vtp password

    实验案例:

    6d27afabe8be213ce623efb1c485f47a.gif

    感谢您的支持,我会继续努力的!

    6d27afabe8be213ce623efb1c485f47a.gif

    扫码打赏,你说多少就多少

    6d27afabe8be213ce623efb1c485f47a.gif

    6d27afabe8be213ce623efb1c485f47a.gif

    打开支付宝扫一扫,即可进行扫码打赏哦

    展开全文
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢? 在小型网络中直接将DHCP服务直接配置在核心层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省...

    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?

    在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省网络设备的性能,另外图形界面,也方便查看。

    业务需求:
    将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段
    人事部、财务部、生产部、采购部分别属于VLAN10、VLAN20、VLAN30、VLAN40
    VLAN10: 192.168.10.0/24       网关:192.168.10.1
    VLAN20: 192.168.20.0/24       网关:192.168.20.1
    VLAN30: 192.168.30.0/24       网关:192.168.30.1
    VLAN40: 192.168.40.0/24       网关:192.168.40.1
    注意:创建DHCP地址池要将网关地址做排除。Switch5和Switch8的F0/4端口已经被管理性关闭了,开启的话会使SW0/SW5/SW8产生网络回路,引起网络风暴,下一篇博客我会写打开这个端口而如何避免这样的问题。

     

    网络拓扑:

    网络配置:

    Switch5:
    SW5#conf t
    SW5(config)#vlan 10					        //创建两个VLAN
    SW5(config-vlan)#vlan 20
    SW5(config-vlan)#int f0/2					//给端口分别划分VLAN
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 10
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/3
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/1					        //设置端口为trunk模式
    SW5(config-if)#switchport mode trunk
    SW5(config-if)#switchport trunk allowed vlan 10,20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    
    Switch8:
    SW8#conf t
    SW8(config)#vlan 30
    SW8(config-vlan)#vlan 40
    SW8(config-vlan)#int f0/2
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 30
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/3
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/1
    SW8(config-if)#switchport mode trunk
    SW8(config-if)#switchport trunk allowed vlan 30,40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    
    Switch0
    SW0#conf t
    SW0(config)#vlan 10					//创建4个VLAN
    SW0(config-vlan)#vlan 20
    SW0(config-vlan)#vlan 30
    SW0(config-vlan)#vlan 40
    SW0(config-vlan)#int f0/1
    SW0(config-if)#switchport mode trunk			//设置端口1为trunk模式,允许VLAN10,20,30,40的流量通过
    SW0(config-if)#switchport trunk allowed vlan 10,20,30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/2
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 10,20
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/3
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    
    Multilayer Switch2
    SW2#conf t
    SW2(config)#vlan 10						//创建4个VLAN
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config-vlan)#vlan 40
    SW2(config-vlan)#int f0/1					//设置f0/1的端口模式
    SW2(config-if)#switchport trunk allowed vlan 10,20,30,40	//三层交换机不用先配置为trunk模式
    SW2(config-if)#exit
    SW2(config)#ip dhcp excluded-address 192.168.10.1		//对DHCP地址池地址做排除
    SW2(config)#ip dhcp excluded-address 192.168.20.1
    SW2(config)#ip dhcp excluded-address 192.168.30.1
    SW2(config)#ip dhcp excluded-address 192.168.40.1
    SW2(config)#int vlan 10						//设置VLAN10的IP地址。三层交换机与路由器的不同之处,不能用单臂路由,划分子端口,所以用此方法分别设置VLAN的地址作为每个DHCP地址池的网关地址
    SW2(config-if)#ip address 192.168.10.1 255.255.255.0
    SW2(config-if)#ip routing					//开启VLAN间路由的功能
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 10					//创建DHCP地址池10
    SW2(config-dhcp)#network 192.168.10.0 255.255.255.0		//设置DHCP地址池网段
    SW2(config-dhcp)#default-router 192.168.10.1			//设置默认网关地址。这里设置为VLAN10的IP地址,所有VLAN10的主机通过这个网关地址获取IP
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 20						
    SW2(config-if)#ip address 192.168.20.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 20					//创建DHCP地址池20
    SW2(config-dhcp)#network 192.168.20.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.20.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 30
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 30					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.30.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.30.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 40
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 40					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.40.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.40.1
    SW2(config-dhcp)#exit

    本文原创,转载请注明出处。

     

    展开全文
  • 思科Cisco的十三种私有协议

    千次阅读 2020-08-17 21:58:37
    13项思科非标准协议技术(即私有协议)清单 ** 1. IGRP(Interior Gateway Routing Protocol 内部网关路由协议) ** 是基于D-V(贝尔曼-福特算法(Bellman-Ford))算法的动态路由协议,它通过和相邻路由器之间交换...
  • enable //从用户模式进入特权模式 R1# R1#disable //从特权模式退回用户模式 R1> 3、全局模式 (config)# R1#configure terminal //从特权模式进入全局配置模式 R1(config)# 接口模式 R1(config)#interface ...
  • 思科交换机提供的三种交换模式

    千次阅读 2015-12-24 11:29:39
    交换机在交换数据帧时可以选择不同的模式来满足网络和用户的需要,思科的交换机提供三种交换模式:  存储转发模式  存储转发(Store-and-forward)模式是指交换机收完整个数据帧,并在CRC校验通过之后,才能...
  • 思科可配置的三种路由模式

    千次阅读 2014-06-18 13:29:31
    路由是指导IP数据包发送的路径信息;路由器提供了异构网互联的机制,实现将一个网络的数据包发送到另一个网络;路由协议就是在路由指导IP数据包发送过程中... 思科Cisco路由器上可以配置三种路由:  (1)静态路由  (2
  • 随着交换技术的发展,层交换机在网络汇聚层与核心层的应用越来越多。在内网中子网与子网之间的通讯越来越少依赖于路由(几乎见不到了),而是使用带有路由功能的层交换机,这对于内网中子网之间的通信效率的提高...
  • 所谓典型局域网就是指由一台具备层交换功能的核心交换机接几台分支交换机(不一定具备层交换能力)。我们假设核心交换机名称为:com;分支交换机分别为:par1、par2、par3,分别通过port 1的光线模块与核心...
  • 思科 cisco 7945 7965 sip模式固件 需要通过CME 或CUCM 升级
  • 主要为大家介绍了双线策略路由的三种实现方式总结和端口映射方面的问题,双线比单线要复杂多了,但把策略路由的原理弄明白了,就会发现其实并不难,需要的朋友可以参考下
  • cisco ios三种模式: R1>:用户模式 R1#:特权模式 R1(config)#:全局配置模式 从用户模式到特权模式:enable 从特权模式到全局配置模式:configure terminal 注:使用exit退出当前模式 ...
  • 版权声明:如果对大家有帮助,大家可以自行转载的。 1.技术原理: 层交换机具备网络层的功能,实现 VLAN 相互访问的原理是:...采用 SVI(交换虚拟接口)的方式实现 VLAN 间互连。SVI 是指为交换机中的VLAN 创建...
  • Switch(config-line)#login //登陆方式变为login Switch(config-line)#password quwei Switch(config-line)#end 3)登陆时不需要验证 Switch(config)#line c 0 Switch(config-line)#no login  Switch...
  • Cisco 2600接adsl的两种方式Cisco 2600接adsl的两种方式
  • 2、熟练掌握层交换机vlan路由的定义。 3、熟练掌握层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和三层交换机,并最终验证网络的连通性。 、实验...
  • 思科Cisco BGP 专题 ()BGP选路原则 回顾: 我们先对上个BGP专题的内容进行简单的回顾,具体详细内容可回看上个专题 1、用loopback环回口建立BGP邻居的方法 2、BGP同步功能(系统默认关闭,现今主要使用mpls技术...
  • Cisco路由器的6种模式

    千次阅读 2019-03-18 16:25:19
    Cisco路由器的6种模式 普通模式 router> 路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容。 特权模式 router# 在router>提示符下...
  • 思科模拟器配置DHCP的几种方式

    万次阅读 多人点赞 2019-10-29 16:44:51
    思科模拟器配置DHCP的几种方式 第一:基于层交换机+路由器的DHCP拓扑图 1.知识点梳理: 二层交换机: 配置vlan 端口划分进vlan 连向层的端口配置trunk模式 层交换机: 配置vlan vlan端口配置ip 连向路由...
  • cisco思科路由器

    2014-09-13 23:14:54
    cisco思科路由器,学习,思科路由器配置手册 一、基本设置方式 一般来说,可以用5种方式来设置路由器
  • Cisco路由器几种模式的区别

    万次阅读 2012-02-16 17:23:04
    思科的路由器的用户界面有以下几: 1.用户执行模式(User EXEC Mode) 2.特权执行模式(Privileged EXEC Mode) 3.全局配置模式(Global Configuration Mode) 4.监控模式(ROM Monitor Mode) 5.安装模式...
  • 最近在研究公司的一个层交换机,配置的过程中发现一些问题,总结在这里。 1、com接口 交换机的com接口笔记本上没有,我又懒得开台式机,就从淘宝上买了根usb转com的线,装上驱动就能用了。win7下面没有超级终端...
  • cisco三层交换机vlan间通信

    千次阅读 2019-10-12 09:46:55
    cisco三层交换机vlan间通信 实验拓扑如上 首先,将二层交换机的基本配置配好,添加vlan2,3,并且将端口划分到vlan下面。不要忘记这一步 然后配置层交换机的基本配置,添加vlan2,3 但是这里有个问题,直接配置...
  • 思科三层交换机配置步骤

    千次阅读 2020-04-08 13:34:09
    思科三层交换机配置图如下: 配置的过程如下: 首先,设置各个PC的ip地址,子网掩码,网关 设置完成之后,进行二层交换机的设置: 在层交换机的配置实验中 二层交换机设置的主要是vlan的设置,vlan接口的设置和...
  • 思科路由器修复教程, 本文主要给大家介绍了思科路由器如何改动启动方式从而修复路由器故障,并且主要给介绍了思科路由器的启动方式和顺序,相信看过此文会对你有所帮助。当然,要使用这个功能的话,必须对路由器的...
  • Cisco设备三种密码配置方法及解释

    千次阅读 2020-07-30 11:32:31
    enable 配置密码 1.enable password xxxx 出来后就是以明文的形式存在 当你写入:server password-... 2.enable secret xxxxxx 使用md5加密 ... ...关于上两个语句区别: 二者配置的密码都是特权模式的密码,但是paswo
  • 思科三层vlan设备简介

    2011-05-11 10:54:26
    将端口分配给VLAN的方式有两,分别是静态的和动态的. 形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP (VLAN Trunking Protocol)Server上建立VLAN,然后将每个端口分配给相应的VLAN的过程...
  • 提示:文章写完后,目录可以自动生成,如何生成可参考...示例:pandas 是基于NumPy 的一工具,该工具是为了解决数据分析任务而创建的。 二、使用步骤 1.引入库 代码如下(示例): import numpy as np impo...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 66,830
精华内容 26,732
关键字:

思科三种模式