精华内容
下载资源
问答
  • Cisco思科交换机配置STP(生成树)协议

    万次阅读 多人点赞 2020-01-31 15:31:12
    首先说说为什么需要STP协议。一个大型的网络中势必会用到许许多多的交换机交换机交换机之间连接起来构成一个复杂的网络,这样就形成了一个物理环路。 如图中的三台交换机: 那为什么形成了物理环路就会产生...

    首先说说为什么需要STP协议。一个大型的网络中势必会用到许许多多的交换机,交换机与交换机之间连接起来构成一个复杂的网络,这样就形成了一个物理环路。

    如图中的三台交换机:

    那为什么形成了物理环路就会产生网络风暴呢?

    这要从交换机的工作原理说起了,由于交换机的工作原理是储存转发,当交换机收到报文后,根据MAC-IP对应关系把数据包转发出去,如果MAC地址表里没有这样的对应关系,就会把报文通过广播的方式发送到链路中,一个报文到达链路末端后没有找到地址会被丢弃。但是如果是环路的话,报文就无法达到链路末端,一直在环路里循环转发,形成网络风暴,浪费交换机性能。

    而STP协议就是通过设置交换机的优先级,人为的控制流量的路径,将环状的网络拓扑修剪成树状结构,防止网络风暴,配置多个生成树(MSTP)还可以达到网络负载均衡的效果。

    再来看看我们设计的实验拓扑,先确定主根和次根,我们将Switch5设计为VLAN10,VLAN20的主根,VLAN30,VLAN40的次根。所以VLAN10,20的流量优先走Switch5交换机。将Switch8设计为VLAN30,40的主根,VLAN10,20的次根,所以VLAN30,40的流量优先走Switch8交换机。

    配置:

    Switch5:
    SW5(config)#spanning-tree vlan 10 priority 0
    SW5(config)#spanning-tree vlan 20 priority 0
    SW5(config)#spanning-tree vlan 30 priority 4096
    SW5(config)#spanning-tree vlan 40 priority 4096
    SW5(config)#int f0/4
    SW5(config-if)#no shutdown
    
    Switch8:
    SW8(config)#spanning-tree vlan 30 priority 0
    SW8(config)#spanning-tree vlan 40 priority 0
    SW8(config)#spanning-tree vlan 10 priority 4096
    SW8(config)#spanning-tree vlan 20 priority 4096
    SW8(config)#int f0/4
    SW8(config-if)#no shutdown

    注意:配置生成树时设置它的优先级,默认的优先级是32768,优先级越小越靠谱,优先级必须是4096的倍数。

    本文原创,转载请注明出处。

    展开全文
  • 华为三层交换机STP配置

    千次阅读 2015-10-20 09:12:28
    STP配置学习目的掌握启用和关闭STP的方法了解不同的STP模式的差异掌握修改网桥优先级影响根网桥选举的方法掌握修改端口优先级影响根端口与指定端口选举的方法掌握配置边缘的方法拓扑图 650) this.width=650;...

    STP配置

    学习目的

    • 掌握启用和关闭STP的方法

    • 了解不同的STP模式的差异

    • 掌握修改网桥优先级影响根网桥选举的方法

    • 掌握修改端口优先级影响根端口与指定端口选举的方法

    • 掌握配置边缘的方法

    拓扑图

            wKioL1O4uGDRBVxDAAD3Jf4JCYE119.jpg

    场景

             你是公司的网络管理员。公司的网络使用了两层网络结构,核心层和接入层。采用了冗余网络,为避免存在的环路问题,决定使用STP来进行环路控制。STP有不同的模式,也可以对STP的根桥等进行控制。同样为了加快边缘网络的收敛速度,也可以使用一些特殊特性来配置STP

    学习任务

             步骤一.STP配置及验证

    实验之前,关闭S3的接口E0/0/1,以避免对实验的影响。

    请保证设备以空配置启动。如果设备默认生成树没有开启,使用stp enable命令开启。

    本次实验我们使用传统生成树。

    [Huawei]sysname S1

    [S1]stp mode stp

    [S1]stp root secondary

    [S1]

     

    [Huawei]sysname S2

    [S2]stp mode stp

    [S2]stp root primary

     

    [Huawei]sysname S3

    [S3]stp mode stp

     

    [Huawei]sysname S4

    [S4]stp mode stp

    使用display stpbrief 命令查看各接口简要STP状态。

    [S1]display stp brief

     MSTID Port                       Role  STP State     Protection

      0    GigabitEthernet0/0/9        ROOT FORWARDING      NONE

      0    GigabitEthernet0/0/10       ALTE DISCARDING      NONE

      0    GigabitEthernet0/0/13       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/14       DESI FORWARDING      NONE

     

    [S2]display stp brief

     MSTID Port                       Role  STP State     Protection

      0    GigabitEthernet0/0/9        DESI FORWARDING      NONE

      0    GigabitEthernet0/0/10       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/21       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/22       DESI FORWARDING      NONE

     

    [S3]display stp brief

     MSTID Port                       Role  STP State     Protection

      0    Ethernet0/0/13              ALTE  DISCARDING      NONE

      0    Ethernet0/0/21              ROOT  FORWARDING      NONE

     

    [S4]display stp brief

     MSTID Port                       Role  STP State     Protection

      0    Ethernet0/0/14              ALTE  DISCARDING      NONE

      0    Ethernet0/0/22              ROOT  FORWARDING      NONE

    使用display stpinterface命令查看某接口详细STP状态。

    [S1]displstp interface gi0/0/10

    -------[CISTGlobal Info][Mode STP]-------

    CISTBridge         :4096 .4c1f-cce0-2efa

    ConfigTimes        :Hello 2s MaxAge 20s FwDly15s MaxHop 20

    ActiveTimes        :Hello 2s MaxAge 20s FwDly15s MaxHop 20

    CISTRoot/ERPC      :0    .4c1f-ccee-152e / 1

    CISTRegRoot/IRPC   :4096 .4c1f-cce0-2efa / 0

    CISTRootPortId     :128.9

    BPDU-Protection     :Disabled

    CISTRoot Type      :Secondary root

    TCor TCN received  :149

    TCcount per hello  :0

    STPConverge Mode   :Normal

    Timesince last TC  :0 days 0h:26m:58s

    Numberof TC        :18

    LastTC occurred    :GigabitEthernet0/0/9

    ----[Port10(GigabitEthernet0/0/10)][DISCARDING]----

     Port Protocol       :Enabled

     Port Role           :Alternate Port

     Port Priority       :128

     Port Cost(Dot1T )   :Config=auto / Active=1

     Designated Bridge/Port   :0.4c1f-ccee-152e / 128.10

     Port Edged          :Config=default / Active=disabled

     Point-to-point      :Config=auto / Active=true

     Transit Limit       :147 packets/hello-time

     Protection Type     :None

     Port STP Mode       :STP

     Port Protocol Type  :Config=auto / Active=dot1s

     BPDU Encapsulation  :Config=stp / Active=stp

     PortTimes           :Hello 2s MaxAge 20s FwDly 15sRemHop 0

     TC or TCN send      :32

     TC or TCN received  :52

     BPDU Sent           :87            

              TCN: 0, Config: 87, RST: 0, MST: 0

     BPDU Received       :853            

              TCN: 0, Config: 853, RST: 0, MST: 0

    步骤二.根桥选举控制

             使用display STP命令查看当前根桥信息

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :0   .4c1f-ccee-152e

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :0   .4c1f-ccee-152e / 0

    CIST RegRoot/IRPC   :0   .4c1f-ccee-152e / 0

    CIST RootPortId     :0.0

    BPDU-Protection     :Disabled

    CIST Root Type      :Primary root

    TC or TCN received  :190

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:30m:30s

    Number of TC        :17

    Last TC occurred    :GigabitEthernet0/0/22

    ………………….

             实验中特别定义了S2为主根网桥,S1为备份根网桥。如上输出CISTBridgeCIST Root/ERPC字段值相同的即为根桥。

    桥优先级数值越小的优先级越高,因此将S1的桥优先级改为4096,将S2的桥优先级修改为8192S1的优先级高于S2S1将选举为根桥。

    [S1]undo stp root

    [S1]stp priority 4096

     

    [S2]undo stp root

    [S2]stp priority 8192

    使用display stp命令查看新的根桥信息。

    [S1]displ stp

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :4096 .4c1f-cce0-2efa

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :4096 .4c1f-cce0-2efa / 0

    CISTRegRoot/IRPC   :4096 .4c1f-cce0-2efa / 0

    CIST RootPortId     :0.0

    BPDU-Protection     :Disabled

    TC or TCN received  :179

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:1m:12s

    Number of TC        :28

    Last TC occurred    :GigabitEthernet0/0/9

    ……………………..

     

    [S2]disp stp

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :8192 .4c1f-ccee-152e

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :4096 .4c1f-cce0-2efa / 1

    CIST RegRoot/IRPC   :8192 .4c1f-ccee-152e / 0

    CIST RootPortId     :128.9

    BPDU-Protection     :Disabled

    TC or TCN received  :245

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:1m:31s

    Number of TC        :22

    Last TC occurred    :GigabitEthernet0/0/9

    由以上输出可以看出,S1成为新的根桥。

    关闭S1G0/0/90/0/10G0/0/13G0/0/14四个接口达到隔离S1的目的。

    S1]interface gi0/0/9

    [S1-GigabitEthernet0/0/9]shutdown

    [S1-GigabitEthernet0/0/9]interface gi0/0/10

    [S1-GigabitEthernet0/0/10]shutdown

    [S1-GigabitEthernet0/0/1]interface gi0/0/13

    [S1-GigabitEthernet0/0/13]shutdown

    [S1-GigabitEthernet0/0/13]interfacegi0/0/14

    [S1-GigabitEthernet0/0/14]shutdown

     

    [S2]displ stp

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :8192 .4c1f-ccee-152e

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :8192 .4c1f-ccee-152e / 0

    CIST RegRoot/IRPC   :8192 .4c1f-ccee-152e / 0

    CIST RootPortId     :0.0

    BPDU-Protection     :Disabled

    TC or TCN received  :259

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:2m:30s

    Number of TC        :25

    Last TC occurred    :GigabitEthernet0/0/22

    ………..

    由以上红色突出部分可以看出,在S1失效的情况下,S2由备份根桥成为了根桥。

    开启S1之前关闭的接口。

    [S1]interface g0/0/9

    [S1-GigabitEthernet0/0/9]undo shutdown

    [S1-GigabitEthernet0/0/9]interface g0/0/10

    [S1-GigabitEthernet0/0/10]undo shutdown

    [S1-GigabitEthernet0/0/10]interface g0/0/13

    [S1-GigabitEthernet0/0/13]undo shutdown

    [S1-GigabitEthernet0/0/13]interface g0/0/14

    [S1-GigabitEthernet0/0/14]undo shutdown

     

    [S1]display stp

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :4096 .4c1f-cce0-2efa

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :4096 .4c1f-cce0-2efa / 0

    CIST RegRoot/IRPC   :4096 .4c1f-cce0-2efa / 0

    CIST RootPortId     :0.0

    BPDU-Protection     :Disabled

    TC or TCN received  :183

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:0m:21s

    Number of TC        :34

    Last TC occurred    :GigabitEthernet0/0/13

     

    <S2>display stp

    -------[CIST Global Info][Mode STP]-------

    CIST Bridge         :8192 .4c1f-ccee-152e

    Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop20

    CIST Root/ERPC      :4096 .4c1f-cce0-2efa / 1

    CIST RegRoot/IRPC   :8192 .4c1f-ccee-152e / 0

    CIST RootPortId     :128.9

    BPDU-Protection     :Disabled

    TC or TCN received  :346

    TC count per hello  :0

    STP Converge Mode   :Normal

    Time since last TC  :0 days 0h:0m:39s

    Number of TC        :32

    Last TC occurred    :GigabitEthernet0/0/9

    由以上输出可以看出,当S1恢复后,S1重新被选举成为根桥。

    步骤三.根端口选举控制

             S2上使用displaystp brief 查看当前接口的角色信息。

    <S2>display stp brief

     MSTID Port                       Role  STP State     Protection

      0    GigabitEthernet0/0/9        ROOT FORWARDING      NONE

       0    GigabitEthernet0/0/10       ALTE DISCARDING      NONE

      0    GigabitEthernet0/0/21       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/22       DESI FORWARDING      NONE

    此时,G0/0/9为根端口,G0/0/10为替代端口。将下面通过修改S1的端口优先级的方式实现S2的端口G0/0/10成为根端口,G0/0/9成为替代端口。

             修改S1接口G0/0/9G0/0/10的端口优先级。

             端口的优先级默认值为128,数值越小,因此在下面实验中我们将S1的接口G0/0/9端口优先级设置为32G0/0/10端口优先级设置为16,。这样S1的接口G0/0/10优先级高于G0/0/9S2的接口G0/0/10将选举为新的根端口。

    [S1]interface g0/0/9

    [S1-GigabitEthernet0/0/9]stp port pri    

    [S1-GigabitEthernet0/0/9]stp port priority32

    [S1-GigabitEthernet0/0/9]interface g0/0/10

    [S1-GigabitEthernet0/0/10]stp port priority16

    提示:此处是修改S1的端口优先级,而不是修改S2的端口优先级。

    [S1]display stp interface gi0/0/9

    …….

    ----[Port9(GigabitEthernet0/0/9)][FORWARDING]----

     PortProtocol       :Enabled

     PortRole           :Designated Port

     Port Priority       :32

     PortCost(Dot1T )   :Config=auto / Active=1

     Designated Bridge/Port   :4096.4c1f-cce0-2efa / 32.9

     PortEdged          :Config=default /Active=disabled

     Point-to-point      :Config=auto / Active=true

     Transit Limit       :147 packets/hello-time

     Protection Type     :None

     PortSTP Mode       :STP

     PortProtocol Type  :Config=auto /Active=dot1s

     BPDUEncapsulation  :Config=stp / Active=stp

     PortTimes           :Hello 2s MaxAge 20s FwDly 15sRemHop 20

     TCor TCN send      :70

     TCor TCN received  :1

     BPDUSent           :545            

             TCN: 0, Config: 545, RST: 0, MST: 0

     BPDUReceived       :2            

             TCN: 1, Config: 1, RST: 0, MST: 0

     

    [S1]display stp interface gi0/0/10

    ……..

    ----[Port10(GigabitEthernet0/0/10)][FORWARDING]----

     PortProtocol       :Enabled

     PortRole           :Designated Port

     Port Priority       :16

     PortCost(Dot1T )   :Config=auto / Active=1

     Designated Bridge/Port   :4096.4c1f-cce0-2efa / 16.10

     PortEdged          :Config=default /Active=disabled

     Point-to-point      :Config=auto / Active=true

     Transit Limit       :147 packets/hello-time

     Protection Type     :None

     PortSTP Mode       :STP

     PortProtocol Type  :Config=auto /Active=dot1s

     BPDUEncapsulation  :Config=stp / Active=stp

     PortTimes           :Hello 2s MaxAge 20s FwDly 15sRemHop 20

     TCor TCN send      :52

     TCor TCN received  :1

     BPDUSent           :544            

             TCN: 0, Config: 544, RST: 0, MST: 0

     BPDUReceived       :2            

             TCN: 1, Config: 1, RST: 0, MST: 0

    S2上使用display stp brief 查看当前接口的角色信息。

    <S2>display stp brief

     MSTID Port                       Role  STP State     Protection

       0   GigabitEthernet0/0/9       ALTE  DISCARDING      NONE

       0   GigabitEthernet0/0/10      ROOT  FORWARDING      NONE

      0    GigabitEthernet0/0/21       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/22       DESI FORWARDING      NONE

    有上输出可以看出,S2的接口G0/0/10被选举成为了新的根端口。G0/0/9成为了替代端口。

    关闭S2上的根端口G0/0/10,观察替代端口选举为新的根端口的情况。

    [S2]interface g0/0/10

    [S2-GigabitEthernet0/0/10]shutdown

     

    [S2]display stp brief

     MSTID  Port                        Role  STP State    Protection

       0    GigabitEthernet0/0/9        ROOT FORWARDING      NONE

      0    GigabitEthernet0/0/21       DESI FORWARDING      NONE

      0    GigabitEthernet0/0/22       DESI FORWARDING      NONE

    此时G0/0/9被选举成为了新的根端口。

    步骤四.边缘端口设置

             将连接用户终端设备如计算机的端口配置成边缘端口,可以使用该端口无需经历STP计算过程快速进入转发状态。本任务中,仅作示例将S3接口E0/0/3-4配置成边缘端口,实际网络中可以根据需要配置。

    [S3]interface e0/0/3

    [S3-Ethernet0/0/3]stp edg      

    [S3-Ethernet0/0/3]stp edged-port en     

    [S3-Ethernet0/0/3]stp edged-port enable

    [S3-Ethernet0/0/3]interface e0/0/4

    [S3-Ethernet0/0/4]stp edged-port enable

    配置完成后可以将计算机网线接入到S3的接口E0/0/3,在S3上使用dispalay stp brief命令查看端口的状态。由于E0/0/3是边缘端口就立即转变到“forwarding”状态了。

    而连接其它没有配置边缘端口的E0/0/5接口则在链路UP之后要等待约30S才能达到Forwarding“状态。

     


    本文出自 “思科实验linux” 博客,请务必保留此出处http://1054054.blog.51cto.com/1044054/1434973

    展开全文
  • 一、交换机配置方式1、Console将配置电缆的DB-9(或DB-25)孔式插头 接到要对交换机进行配置的微机或终端的串口上。首先启动超级终端,点击windows的开始→程序→附件→通讯→超级终端,启动超级终端。根据提示输入...

    一、交换机的配置方式

    1、Console

    将配置电缆的DB-9(或DB-25)孔式插头 接到要对交换机进行配置的微机或终端的串口上。

    首先启动超级终端,点击windows的开始→程序→附件→通讯→超级终端,启动超级终端。

    根据提示输入连接描述名称后确定,在选择连接时使用相应的COM口(可通过设备管理器查看COM口)后单击"确定"按钮,在弹出的COM1属性窗口中单击"还原为默认值"按钮后单击"确定"按钮。

    17fd4bab69b29ea3dfe54963cd296490.png
    f04b0fe0c9417e1e4a1505d3c1c2ea5f.png
    fd993fad6f43eebffd74f54fda4ba811.png

    2、telnet

    switch>enable

    switch#configure terminal

    switch(conf)#enable password cisco //以cisco为特权模式密码(使用telnet必须配置特权密码)

    switch(conf)#line vty 0 4 //设置0-4个用户可以telnet远程登陆

    switch(conf-line)#login

    switch(conf-line)#password 123456

    //以123456为远程登录的用

    户密码

    以上命令打开交换机telnet功能,至此可以通过telnet命令访问并管理此交换机。

    二、设备管理

    1、配置交换机名称

    switch(conf)#hostname CoreSwitch

    CoreSwitch(conf)#

    2、保存配置

    switch#write

    或 //特权模式保存配置

    switch#copy run start

    3、交换机重启

    switch#reload

    4、恢复出厂默认恢复命令

    switch#write erase

    switch#reload

    三、端口配置

    1、端口配置

    switch (conf)#interface g1/1 //以第1块板卡的1号端口为例

    switch (conf-if)#duplexfull/half/auto //更改双工模式

    switch (conf-if)#speed 10/100/1000 //更改端口速率、

    switch (conf-if)#shutdown //关闭端口

    switch (conf-if)#no shutdown //启用端口

    2、端口聚合

    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group,这样交换机会认为这个逻辑通道为一个端口,同时提高链路带宽。

    Switch#config

    Switch (Config)#interface range g1/2-3 //进入第1块板卡的2、3号端口

    Switch (Config-Port-Range)#port-group 1 mode on //设置端口聚合方式为手动

    Switch (Config-Port-Range)#exit

    Switch (Config)#interface port-channel 1 //进入聚合端口

    Switch (Config-If-Port-Channel1)#swithport mode trunk //配置聚合端口为trunk

    Switch (Config-If-Port-Channel1)#no shutdown //启用聚合端口

    四、VLAN虚拟局域网

    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的数据交换技术。注意:如果交换机接口处于no switchport状态属于三层接口,无法加入到vlan中,需要进入端口执行switchport命令。

    例:switch(config)# interface g1/1

    switch(config-if)# switchport

    1、配置VLAN

    switch# configure terminal //进入全局配置模式

    switch(config)# vlan 10 //配置VLAN 10

    switch(config-vlan)# name JK // VLAN命名为JK

    switch(config-vlan)#exit

    switch(config)# interface g1/1 //进入指定端口

    switch(config-if)# switchprot access vlan 10 //将端口划入VLAN

    端口选择技巧:

    switch(config)# interface range g1/1–5 //选择连续多个端口

    switch(config)# interface range g1/6-8,1/9-11,1/22  //将不连续多个端口加入到Vlan中

    2、配置TRUNK透传模式

    switch(config)# interface g1/1 //进入指定端口

    switch(config-if)# switchport mode trunk //配置接口为TRUNK模式

    //默认配置完trunk后,允许所有VLAN ID通过

    switch(config-if)# switchport trunk allowed vlan remove 20

    //配置移除trunk允许通过的VLAN ID

    switch(config-if)# switchport trunk allowed vlan add 20

    //配置添加trunk允许通过的VLAN ID

    五、IP协议配置

    1、为VLAN配置IP地址

    switch(config)#interface VLAN 233 //进入VLAN虚拟接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //配置IP地址及掩码

    switch(config-if)#no shutdown //启用接口

    2、添加静态路由

    switch(config)#ip route 目的地址网段 目的网络子网掩码 下一条地址

    //配置视图下配置

    例:switch(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.2

    六、组播

    1、PIM-SM

    PIM-SM(Protocol Independent Multicast,Sparse Mode)即与协议无关的组播稀疏模式,属于稀疏模式的组播路由协议。PIM-SM主要用于组成员分布相对分散、范围较广、大规模的网络。

    与密集模式的扩散/剪枝不同,PIM-SM协议假定所有的主机都不需要接收组播数据包,只有主机明确指定需要时,PIM-SM路由器才向它转发组播数据包。

    PIM-SM协议中,通过设置汇聚点RP(Rendezvous Point)和自举路由器BSR(Bootstrap Router),向所有PIM-SM路由器通告组播信息,并利用路由器的加入/剪枝信息,建立起基于RP的共享树RPT(RP-rooted shared tree)。从而减少了数据报文和控制报文占用的网络带宽,降低路由器的处理开销。组播数据沿着共享树流到该组播组成员所在的网段,当数据流量达到一定程度,组播数据流可以切换到基于源的最短路径树SPT,以减少网络延迟。PIM-SM不依赖于特定的单播路由协议,而是使用现存的单播路由表进行RPF检查。

    运行PIM-SM协议,需要配置候选RP和BSR,BSR负责收集候选RP发来的信息,并把它们广播出去。

    2、PIM-DM

    PIM-DM(Protocol Independent Multicast,Dense Mode)属于密集模式的组播路由协议。PIM-DM适用于小型网络,在这种网络环境下,组播组的成员相对比较密集。PIM-DM的工作过程可以概括为:邻居发现、扩散、剪枝过程、嫁接阶段。

    3、配置举例

    1、使能组播路由

    switch(conf)#ip multicast-routing

    2、进入接口

    switch(conf)#interface Vlan233

    3、在接口上启动PIM SM或DM

    switch(conf-if)# ip pim sparse-dense-mode //稀疏密集模式

    ip pim sparse-mode//稀疏模式

    ip pim dense-mode//密集模式

    如果是二层交换机,则只需在系统视图下配置igmp-snooping即可

    七、双机热备

    switch(conf)#redundancy //进入热备配置视图

    switch(conf-red)#main-cpu //配置同步配置文件

    switch(conf-red)mode sso //配置热备模式为SSO

    八、查看交换机信息及排错常用命令

    1、Show

    switch(conf)#show run //查看当前运行配置信息

    switch(conf)#show vlan brief //显示VLAN配置信息

    switch(conf)#show ip route //显示路由表

    switch(conf)#show interface XX //显示指定端口信息

    switch(conf)#Show interfaces //显示设置在路由器和访问服务器上所有接口的统计信息

    switch(conf)#Show ip interface //列出一个接口的IP信息和状态的小结

    switch(conf)#Show version //显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像

    switch(conf)#Show memory //显示路由器内存的大小,包括空闲内存的大小

    switch(conf)# Show processes //显示路由器的进程

    switch(conf)#Show flash //显示闪存的布局和内容信息

    2、debug

    对于路由器和交换机的故障诊断,只用一个 show 命令是远远不够的。而 debug 命令往往能够帮助我们看清楚背后的故障原因。

    Switch#debug // 显示所有可用的debug指令及简短的说明

    Switch #show debugging //显示当前各个调试开关的状态

    Switch #debug all //打开系统所有的调试开关

    Switch #undebug all //关闭所有的调试开关

    Switch #debug arp //打开ARP调试开关

    Switch #debug igmp //打开IGMP调试开关

    Switch #debug ip //打开IP调试开关

    Switch #debug multicast //打开多播数据流调试开关

    Switch #debug pim //打开PIM调试开关

    Switch #debug vlan //打开VLAN调试开关

    展开全文
  • 带拓扑图,完整版交换机路由工程配置,谢谢支持,大家多多指教。
  • 思科交换机基本配置命令 switch>enable 进入特权模式 switch#config terminal 进入全局模式 switch(config)#hostname+xxx 设置主机名 switch(config)#enable password 明文密码 switch(config)#enable ...

    【欢迎关注微信公众号:厦门微思网络】

    微思网络(官网):https://www.xmws.cn/


    思科交换机基本配置命令

    switch>enable    进入特权模式
    
    switch#config terminal    进入全局模式
    
    switch(config)#hostname+xxx    设置主机名
    
    switch(config)#enable password   明文密码
    
    switch(config)#enable secret     密文密码
    
    switch(config)#ip default-gateway  设置网关
    
    switch#show mac-address-table  查看MAC地址
    
    switch(config)#logging synchronous     阻止控制台信息覆盖命令行上的输入
    
    switch(config)#no ip domain-lookup          关闭DNS查看功能
    
    switch(config)#exec-timeout 0 0                阻止会话退出

    使用telnet远程式管理

    switch(config)#line vty 0 4    进入虚拟终端
    
    switch(config-line)#password xx    设置登录口令
    
    switch(config-line)#login     要求口令验证

    控制台口令

    switch(config)#line console 0   进入控制台口
    
    switch(config-line)#password xx  
    
    switch(config-line)# 设置登录口令login     允许登录

    cisco发现协议(cdp)

    switch(config)#show cdp    显示cisco设备全局配置信息
    
    switch(config)#show cdp interface端口    查看cdp配置下端口信息
    
    switch(config)#show cdp neighbors          显示直连cisco设备信息
    
    switch(config)#show cdp neighbors detail  查看邻居详细信息 

    思科交换机恢复出厂配置

    witch#erase startup-config
    
    switch#delete flash: vlan.dat

    配置接口标识(区分路由器的各个接口)

    switch(config)#interface fastethernet0/1
    
    switch(config)#description this is a fast ethernet port used to connecting the company's intranet!

    vtp配置

    switch(config)#vtp domain  设置VTP域名
    
    switch(config)#vtp password xx  设置VTP密码
    
    switch(config)#vtp mode server/client/transparent  设置VTP服务模式
    
    switch(config)#vtp version     设置VTP版本
    
    switch(config)#vtp pruning   设置VTP修解  
    vlan基本配置
    switch#vlan database                       进入vlan配置模式
    
    switch(vlan)#vlan 号码 name 名称       创建vlan及vlan名
    
    switch(vlan)#vlan 号码 mtu 数值         修改MTU大小 
    
    switch(vlan)#exit                          更新vlan数据并退出
    
    switch#show vlan                           查看vlan
    
    switch#copy running-config startup-config       保存配置
    vlan中添加删除端口
    switch#conf t
    
    switch(config)#interface fastethernet0/1     进入要分配的端口
    
    switch(config-if)#switchport mode access        定义二层端口
    
    switch(config-if)#switchport access vlan号码        把端口发给一个vlan
    
    switch(config-if)#switchport mode trunk                   设置为干线
    
    switch(config-if)#switchport trunk encapsulation dotlq     设置vlan中继协议
    
    switch(config-if)#no switchport mode 或 (switchport mode access)  禁用干线
    
    switch(config-if)#switchport trunk allowed vlan add 1,2      从trunk中添加vlans
    
    switch(config-if)#switchport trunk allowed vlan remove1,2       从trunk中删除vlan
    
    switch(config-if)#switchport trunk pruning vlan remove1,2          

    配置接口为动态协商模式

    switch(config)#interface 接口号
    
    switch(config)#switchport mode dynamic desirable/auto

    生成树stp

    switch(config)#spanning-tree vlan   启用stp生成树(基于vlan)
    
    switch(config)#spanning-tree vlan root primary  指定交换机(基于vlan)
    
    switch(config)#spanning-tree vlan root secondary  指定备用根交换机(基于vlan)
    
    switch(config)#spanning-tree vlan priority<0-65535>  指定交换机优先继(基于vlan)
    
    switch(config)#no spanning-tree vlan priority      将交换机的优先级恢复默认值(基于vlan)
    
    switch(config-if)#spanning-tree vlan cost<0-200000000>   指定端口成本(起用trunk的端口模式下)
    
    switch(config-if)#spanning-tree vlan port-prioty<0-255>    指定交换机端口优先级(基于vlan)
    
    switch(config-if)#spanning-tree portfast    配置速端口(连接终端设备的端口状态)如pc机
    
    switch(config)#spanning-tree uplinkfast   配置上行速端口

    注:在配置上行速端口前要先将基于vlan上的网桥优先级,网桥成本恢复默认值。起用了该命令后在进行优先级更改。

    注:vlan为可选参数,当没有该参数时将修改所有vlan网桥的优先级\及所有的vlan端口成本

    switch#show spanning-tree summery        检测vlan生成树配置
    
    switch#show spanning-tree vlan detail    浏览详细生成树配置信息
    
    switch#show spanning-tree interface detail    浏览详细生成树端口配置信息

    以太网通道配置

    switch(config)#interface range fastemet0/1-2  将fastemet0/1和0/2口捆绑
    
    switch(config-if)#change-group 1 mode on     配置以太通道模式
    
    switch(config-if)#port-channel load-batance{dst-mac|src-mac}在链路间实现负载均衡
    
    switch#show etherchannel 1 summary      查看通道信息
    
    switch#show etherchannel load-balance    查看通道信息

    交换机显示命令

    switch#show vtp status  查看vtp配置信息 
    
    switch#show running-config  查看当前配置信息
    
    switch#show vlan     查看vlan配置信息
    
    switch#show interface  查看端口信息
    
    switch#show int f0/0  查看指定端口信息 
    
    switch#dir flash:  查看闪存
    
    switch#show version  查看当前版本信息
    
    switch#show cdp cisco  设备发现协议(可以查看聆接设备)
    
    switch#show cdp traffic  查看接收和发送的cdp包统计信息
    
    switch#show interface f0/1 switchport  查看有关switchport的配置
    
    switch#show cdp neighbors  查看与该设备相邻的cisco设备

    CISCO交换机巡检命令

    1、show interface stats  ;查看交换机所有接口当前接口流量

    2、show running-config ;查看当前设备配置

    3、show version ;查看IOS版本信息及设备正常运行时间

    4、show clock ;查看设备时钟信息

    5、show vtp status ;查看交换机vtp配置模式

    6、show vtp password ;查看交换机vtp配置口令

    7、show env all ;查看设备温度,电源和风扇运转参数及是否报警

    8、show inventory ;调取设备内部板卡出厂模块型号及序列号

    9、show spanning-tree root ;查看交换机生成树根位置

    10、show cdp neighbors ;查看邻接cisco设备基本信息

    11、show cdp neighbors detail ;查看邻接cisco设备详细信息

    12、show interface status ;查看交换机接口状态是否存在errordisable接口disable接口

    13、show interface summary` ;查看交换机所有接口当前接口流量

    14、show interface | i errors|FastEthernet|GigabitEthernet ;查看接口是否存在大量input或output errors包错误

    15、show processes cpu ;查看设备cpu负载

    16、show processes mem ;查看设备mem负载

    17、show access-list ;查看访问控制列表配置及匹配数据包数量

    18、show logging ;查看本机内部日志记录情况

    19、show ip route ;查看路由表

    20、show firewall                  ;检查防火墙的工作模式

    21、show conn count               ;检查防火墙并发数

    22、show xlate count                ;检查防火墙nat工作状态

    展开全文
  • ㈠网络设备的初始化配置可网管交换机(三层交换机除外)无需配置即可作为傻瓜交换机使用,但是没有配置交换机将不能发挥其功能和安全性。没有配置的路由器无法实现网络之间的通信。2,网络设备的管理方式外置配置源...
  • 思科的CatOS交换机 上, 有一条命令 – set port host对连接 到 终端的端口进行优化配置 。这 条命令 会将端口的 channel模式关闭;在端口上激活生成树(spanning tree)的快速启动(portfast)特性 – ...
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • CISCO交换机STP详细说明及配置,STP(生成树协议)是一个二层管理协议。在一个扩展的局域网中参与STP的所有交换机之间通过交换桥协议数据单元bpdu(bridge protocol data unit)来实现
  • 二、三层交换机STP配置

    千次阅读 2019-05-09 20:37:15
    二层交换配置STP 目标: 二层网络中有可能出现因为线路故障而导致的通信故障,通过冗余线路可以消除因为某一线路故障而导致的网络中断。 但是因为冗余线路的存在,又可能会出现广播风暴、相同帧的不断复制和MAC地址...
  • 配置MST的基本参数 启用MST的过程需要多不操作,它需要将一定的范围的VLAN映射到单个MSTI。 因为MST适用于多个VLAN的情况,所以它就比PVST+或RPVST+要求更多的其他配置。当用户通过命令:spanning-tree mode mst...
  • 思科交换机配置命令

    2009-03-09 19:59:00
    思科交换机配置命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机上设置...
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...
  • 思科交换机 DHCP 服务配置

    万次阅读 2019-01-12 15:16:04
    说明:有 3 个 VLAN,...服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。 地址规划 VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253 VLAN 3:30.1.1.0/24...
  • 近期有多位读者问到Cisco交换机中利用STP配置负载均衡的方法,其实这在我的新书《Cisco/H3C交换机配置与管理完全手册》(第二版)(该书目前在当当网、卓越网和京东网等书店中全面热销中)中都有详细的配置步骤和...
  • 思科交换机

    2018-12-06 23:40:00
    思科交换机配置命令大全 switch&gt; 用户模式 1:进入特权模式 enable switch&gt; enable switch# 2:进入全局配置模式 configure terminal switch&gt; enable switch#c onfigure terminal switch...
  • cisco思科交换机-常用命令及配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc
  • 思科交换机领命

    2019-06-28 14:09:51
    思科交换机的基本配置命令学习小结 【火热量贩】半价囤好货 大包装 超实惠 思科交换机的基本配置命令学习 CISCO交换机基本配置:Console端口连接 用户模式hostname# ; 特权模式hostname(config)# ; 全局配置模式...
  • 9.3.6思科交换机Portfast和Uplinkfast配置 本实验的步骤很简单,只是通过反复的ping测试来验证在思科交换机上启用Portfast(端口快速)和UplinkFast(上行快速)技术前后的不同的链路状态,以达到加深对这两种技术...
  • 思科交换机配置命令大全!

    千次阅读 2012-11-22 15:26:46
    1. 交换机支持的命令: 交换机基本状态: switch: ;ROM状态, 路由器是rommon> ...全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式
  • 思科交换机配置命令大全,真的很全 CISCO, 大全, 交换机, 命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name...
  • 思科STP简单配置

    千次阅读 2019-04-25 19:35:43
    #实验名称:stp 配置 # 实验拓扑图: 实验步骤: 第一步:#分别配置pc的ip地址,以及给每个交换机创建vlan10,vlan20,vlan30,vlan40 # PC11 ip address 192.168.10.1 255.255.255.0 gateway 192....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,068
精华内容 827
关键字:

思科交换机stp配置