精华内容
下载资源
问答
  • 可以让不论在什么地方的电脑,只要连接上局域网之后,就可以通过自动获取Ip地址的方式获取Ip地址网关,这样的做法能够大大的节省网络成本以及网络资源,下面我们来具体的了解一下思科服务器配置dhcp服务器的方法。...

    因为现在生活中网络的流行以及广泛的使用,但企业和学校都会配备思科服务器,因为在配备了服务器之后,可以让不论在什么地方的电脑,只要连接上局域网之后,就可以通过自动获取Ip地址的方式获取Ip地址网关,这样的做法能够大大的节省网络成本以及网络资源,下面我们来具体的了解一下思科服务器配置dhcp服务器的方法。

    15872803644018.jpg

    首先各位小伙伴需要先打开思科模拟器软件,然后找出一台2811类型的路由器,以及两台2960类型的交换机和4台PC电脑,并且使用正确的电线,将每一个设备互相连接在一起。连接完成之后,需要将所有的设备重新命名,路由器命名为r1,交换机命名为sw1,另外一台交换机命名为sw2。

    命名完成之后先配置r1,配置时的命令为r1(config)#int f0/0、r1(config-if)#no sh;之后再配置路由器设备的远程登录以及密码保护,命令为r1(config)#lin vty 0 4、r1(config-line)#login local、r1(config-line)#username admin password cisco、r1(config-line)#exit、r1(config)#enable secret cisco、r1(config)#service password-encrption。

    r1路由器配置完成之后再配置交换机sw1,配置时的命令为sw1(config)#int vlan 1、sw1(config-if)#ip add 192.168.1.2 255.255.255.0、sw1(config-if)#no sh、sw1(config-if)#ex、sw1(config)#ip default-gateway 192.168.1.1。之后使用相同的方法配置sw2。

    完成之后配置vlan设定,首先需要在sw1上划分vlan2、3,然后将相应的端口加入其中,配置时的命令为sw1#conf t、Enter configuration commands, one per line. End with CNTL/Z、sw1(config)#vlan 2、sw1(config-vlan)#ex、sw1(config)#vlan 3、sw1(config-vlan)#ex、sw1(config)#int f0/4、sw1(config-if)#switchport mode access、sw1(config-if)#switchport access vlan 2、sw1(config-if)#int f0/5、sw1(config-if)#switchport mode access、sw1(config-if)#switchport access vlan 3、sw1(config-if)#ex。使用相同的方法,在sw3上面划分为lan,并且将相应的端口加入其中。

    完成之后配置单臂路由器,配置的命令为sw1(config)#int f0/1、sw1(config-if)#switchport  mode  trunk、sw1(config-if)#no  sh。

    之后在路由器r1上进行封装,配置命令为r1#conf t、Enter configuration commands, one per line.  End with CNTL/Z.、r1(config)#int f0/0、r1(config-if)#no shut、r1(config)#int f0/0.1、r1(config-subif)#encapsulation dot1Q 1、r1(config-subif)#ip add 192.168.1.1 255.255.255.0、r1(config-subif)#ex、r1(config)#int f0/0.2、r1(config-subif)#encapsulation dot1Q 2、r1(config-subif)#ip add 192.168.2.1 255.255.255.0、r1(config-subif)#ex、r1(config)#int f0/0.3、r1(config-subif)#encapsulation dot1Q 3、r1(config-subif)#ip add 192.168.3.1 255.255.255.0、r1(config-subif)#no sh、r1(config-subif)#ex。

    之后需要配置dhcp服务器,也就是配置路由器r1,命令为r1#enable、r1#conf t、r1(config)#ip dhcp excluded-address 192.168.2.1、r1(config)#ip dhcp pool vlan2、r1(dhcp-config)#net 192.168.2.0 255.255.255.0、r1(dhcp-config)#default-router 192.168.2.1、r1(dhcp-config)#dns-server 100.1.1.2、r1(config)#ip dhcp excluded-address 192.168.3.1、r1(config)#ip dhcp pool vlan3、r1(dhcp-config)#net 192.168.3.0 255.255.255.0、r1(dhcp-config)#dns-server 100.1.1.2、r1(dhcp-config)#ex。

    所有的操作步骤完成之后,配置就结束了。

    展开全文
  • 思科3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名为server。IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows 2003 ...

    思科3750交换机配置DHCP服务器实例网络环境:

    一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名为server。IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows 2003 advance server。

    同时兼作DNS服务器,IP地址为192.168.2.10,vlan3为客户机1所在网络,IP地址段为192.168.3.0,子网掩码:255.255.255.0,网关:192.168.3.1命名为work01,vlan4为客户机2所在网络,命名为work02,IP地址段为192.168.4.0,子网掩码:255.255.255.0,网关:192.168.4.1,3750作DHCP服务器,端口1-8划到VLAN 2,端口9-16划分到VLAN 3,端口17-24划分到VLAN 4.

    06ac13c246f5570727ef1548c5773fd7.png

    思科交换机

    DHCP服务器实现功能:

    各VLAN保留2-10的IP地址不分配置,例如:192.168.2.0的网段,保留192.168.2.2至192.168.2.10的IP地

    址段不分配.

    安全要求:

    VLAN 3和VLAN 4 不允许互相访问,但都可以访问服务器所在的VLAN 2,

    默认访问控制列表的规则是拒绝所有包。

    配置命令及步骤如下:

    第一步:创建VLAN:

    Switch>en

    Switch#Vlan Database

    Switch(Vlan)>Vlan 2 Name server

    Switch(Vlan)>Vlan 3 Name work01

    Switch(vlan)>Vlan 4 Name work02

    第二步:设置VLAN IP地址:

    Switch#Config T

    Switch(Config)>Int Vlan 2

    Switch(Config-vlan)Ip Address 192.168.2.1 255.255.255.0

    Switch(Config-vlan)No Shut

    Switch(Config-vlan)>Int Vlan 3

    Switch(Config-vlan)Ip Address 192.168.3.1 255.255.255.0

    Switch(Config-vlan)No Shut

    Switch(Config-vlan)>Int Vlan 4

    Switch(Config-vlan)Ip Address 192.168.4.1 255.255.255.0

    Switch(Config-vlan)No Shut

    Switch(Config-vlan)Exit

    /*注意:由于此时没有将端口分配置到VLAN2,3,4,所以各VLAN会DOWN掉,待将端口分配到各VLAN后,VLAN会起来*/

    第三步:设置端口全局参数

    Switch(Config)Interface Range Fa 0/1 - 24

    Switch(Config-if-range)Switchport Mode Access

    Switch(Config-if-range)Spanning-tree Portfast

    第四步:将端口添加到VLAN2,3,4中

    /*将端口1-8添加到VLAN 2*/

    Switch(Config)Interface Range Fa 0/1 - 8

    Switch(Config-if-range)Switchport Access Vlan 2

    /*将端口9-16添加到VLAN 3*/

    Switch(Config)Interface Range Fa 0/9 - 16

    Switch(Config-if-range)Switchport Access Vlan 3

    /*将端口17-24添加到VLAN 4*/

    Switch(Config)Interface Range Fa 0/17 - 24

    Switch(Config-if-range)Switchport Access Vlan 4

    Switch(Config-if-range)Exit

    /*经过这一步后,各VLAN会起来*/

    第五步:配置3750交换机作为DHCP服务器

    /*VLAN 2可用地址池和相应参数的配置,有几个VLAN要设几个地址池*/

    Switch(Config)Ip Dhcp Pool Vlan12

    /*设置可分配的子网*/

    Switch(Dhcp-Config)Network 192.168.2.0 255.255.255.0

    /*设置DNS服务器*/

    Switch(Config-pool)Dns-server 192.168.2.10

    /*设置该子网的网关*/

    Switch(Config-pool)Default-router 192.168.2.1

    /*配置VLAN 3所用的地址池和相应参数*/

    Switch(Config)Ip Dhcp Pool Test02

    Switch(Config-pool)Network 192.168.3.0 255.255.255.0

    Switch(Config-pool)Dns-server 192.168.2.10

    Switch(Config-pool)Default-router 192.168.3.1

    /*配置VLAN 4所用的地址池和相应参数*/

    Switch(Config)Ip Dhcp Pool Test03

    Switch(Config-pool)Network 192.168.4.0 255.255.255.0

    Switch(Config-pool)Dns-server 192.168.2.10

    Switch(Config-pool)Default-router 192.168.4.1

    第六步:设置DHCP保留不分配的地址

    Switch(Config)Ip Dhcp Excluded-address 192.168.2.2 192.168.2.10

    Switch(Config)Ip Dhcp Excluded-address 192.168.3.2 192.168.3.10

    Switch(Config)Ip Dhcp Excluded-address 192.168.4.2 192.168.4.10

    第七步:启用路由

    /*路由启用后,各VLAN间主机可互相访问*/

    Switch(Config)Ip Routing

    第八步:配置访问控制列表

    Switch(Config)access-list 103 permit ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255

    Switch(Config)access-list 103 permit ip 192.168.3.0 0.0.0.255 192.168.2.0 0.0.0.255

    Switch(Config)access-list 103 permit udp any any eq bootpc

    Switch(Config)access-list 103 permit udp any any eq tftp

    Switch(Config)access-list 103 permit udp any eq bootpc any

    Switch(Config)access-list 103 permit udp any eq tftp any

    Switch(Config)access-list 104 permit ip 192.168.2.0 0.0.0.255 192.168.4.0 0.0.0.255

    Switch(Config)access-list 104 permit ip 192.168.4.0 0.0.0.255 192.168.2.0 0.0.0.255

    Switch(Config)access-list 104 permit udp any eq tftp any

    Switch(Config)access-list 104 permit udp any eq bootpc any

    Switch(Config)access-list 104 permit udp any eq bootpc any

    Switch(Config)access-list 104 permit udp any eq tftp any

    第九步:应用访问控制列表

    /*将访问控制列表应用到VLAN 3和VLAN 4,VLAN 2不需要*/

    Switch(Config)Int Vlan 3

    Switch(Config-vlan)ip access-group 103 out

    Switch(Config-vlan)Int Vlan 4

    Switch(Config-vlan)ip access-group 104 out

    第十步:结束并保存配置

    Switch(Config-vlan)End

    Switch#write memory

    展开全文
  • 近期有许多读者朋友在读者QQ...其中列出了在Cisco路由器上配置DHCP服务器的必需和可选任务,以及各种功能配置的具体步骤和大量示例。在下一篇中将给出DHCP服务中继的配置与示例。 4.1 Cisco IOS DHCP服务器配置概述...

    近期有许多读者朋友在读者QQ群中路由器上DHCP服务器配置方面的,在此把笔者编著的《路由器配置与管理完全手册——Cisco篇》一书中的相关内容节选给大家。其中列出了在Cisco路由器上配置DHCP服务器的必需和可选任务,以及各种功能配置的具体步骤和大量示例。在下一篇中将给出DHCP服务中继的配置与示例。

    4.1 Cisco IOS DHCP服务器配置概述

           运行Cisco IOS系统的路由器包括DHCP服务器和中继代理软件。Cisco IOS DHCP服务器功能包括一个从路由器中指定的地址池中为DHCP客户端分配和管理IP地址的全功能平台。还可以配置附加参数(如通常所说的选项82),如DNS服务器IP地址和默认路由。但不同的IOS版本所支持的DHCP功能并不完全一样,具体大家可以参见Cisco官方网站以下链接中的表4:http://www.cisco.com/en/US/docs/ios/ipaddr/configuration/guide/iad_dhcp_svr_cfg_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1145658,或者具体路由器产品用户手册。

    本节将介绍在DHCP服务器配置过程中所涉及到的以下几项任务:

    n 配置DHCP数据库代理或禁止冲突日志(必需)

    n 配置DHCP地址池(必需)

    n 配置IP地址排除(可选)

    n 配置手动绑定(可选)

    n 配置DHCP静态映射(可选)

    n 自定义DHCP服务器选项(可选)

    n 中心DHCP服务器选项导入到DHCP服务器的配置(可选)

    n 使用选项82配置DHCP地址(可选)

    n 配置以从DHCP服务器中动态获得的地址作为下一跳的静态路由(可选)

    n 清除DHCP服务器变量(可选)

    【经验之谈】以上这些功能的配置,我们在学习Windows Server 2003或者RHEL Linux 5服务器系统下的DHCP服务器配置中都有涉及,大家在学习本节内容时最好能在心中对原来所学内容进行回顾,对比,这样更容易理解。具体可以参见笔者编著的全实战战型教材《金牌网管师》系列。

    4.2 DHCP数据库代理或禁止冲突日志配置

    在正式把Cisco路由器配置成DHCP服务器之前,首先要考虑两个方面:一是是否要配置DHCP数据库代理,二是是否要开启冲突日志功能。

    如果路由器的闪存空间不够,通常是把DHCP服务器的数据库中的地址绑定数据存放在另一台PC主机上,然后通过FTP、TFTP或者RCP服务器进行存取。这时这些存储DHCP服务器数据库的主机就称之为“DHCP数据库代理”了。你可以配置多个DHCP数据库代理,也可以为每个代理配置数据库更新和传输的时间间隔。强烈建议使用DHCP数据库代理,但是Cisco IOS DHCP服务器也可以在无数据库代理的情况下正常运行。

    在DHCP数据库代理中存放的是用户的地址绑定条目,其中包括由DHCP服务器自动建立的自动绑定、和由管理员手动建立的手动绑定。自动绑定条目中的自动绑定信息(如租用期、接口索引、VPN路由和转发(VPN routing and forwarding,VRF)名称)是存储在DHCP数据库代理中的。而且,这个绑定信息是以纯文本方式记录的,易于维护。

    另外,当有多个主机使用同一个IP地址时就会发生地址冲突。在DHCP服务器分配IP地址给客户端的过程中,DHCP服务器会使用ping和强制的ARP功能检测冲突。如果检测到有冲突,则该地址会从地址池中删除,不会分配给客户端,直到冲突解除。如果你没有配置DHCP数据库代理,则一定要通过“no ip dhcp conflict logging”全局配置模式命令禁止DHCP服务器上的地址冲突日志功能,否则路由器上的闪存空间很快就会被冲突日志耗尽。

    4.2.1 DHCP数据库代理或者禁止冲突日志的配置步骤及示例

    DHCP数据库代理和冲突日志功能的配置可按表4-1所示步骤自全局配置模式开始进行。配置过程很简单,所用的命令主要是两个:配置DHCP数据库代理是用“ip dhcp database”全局配置模式命令,禁用冲突日志功能是用“no ip dhcp conflict logging”全局配置模式命令。当然如果要启用冲突日志功能,则要直接用“ip dhcp conflict logging”全局配置模式命令了。

    表4-1 DHCP数据库代理或冲突日志的配置步骤

    步骤

    命令

    说明

    Step 1 

    enable

    例如:

    Router> enable

    进入特权模式。如果配置了特权模式密码,则要按提示输入正确的特权模式密码才能进入。

    Step 2 

    configure terminal

    例如:

    Router# configure terminal

    进入全局配置模式。

    Step 3 

    ip dhcp database url [timeoutseconds | write-delay seconds]

    例如:

    Router(config)# ip dhcp database ftp://winda:123456@172.16.1.1/router-dhcp timeout 80

    或者

    no ip dhcp conflict logging

    例如:

    Router(config)# no ip dhcp conflict logging

    配置DHCP服务器在远程主机(数据库代理)中保存自动绑定信息。这里要输入远程主机的URL(通常是FTP或者TFTP服务器),要注意的是要同时指定有权向远程主机写入文件的用户帐户和密码。

    如果不配置数据库代理,则要用“no ip dhcp conflict logging”命令来禁止DHCP服务器地址冲突日志功能。

    示例中是把172.16.1.1的FTP服务器作为DHCP数据库代理,自动绑定信息保存在根目录的router-dhcp文件中。所使用的远程主机帐户为winda,密码为123456。

    在以上步骤中涉及到两条主要命令:“ip dhcp database”和“ip dhcp conflict logging”全局配置模式命令。下面对这两个命令进行详细介绍。

    1. ip dhcp database命令

    “ip dhcp database”的完整命令格式如下:

    ip dhcp database url [timeout seconds | write-delay seconds]

    它是用来配置IOS DHCP服务器和中继代理在一个称之为“数据库代理”远程主机(如FTP、TFTP、RCP服务器或者网络磁盘)上保存自动绑定关系。你可以配置多个DHCP数据库代理,而且你可以为每个数据库代理设置数据库更新的时间间隔。要删除数据库代理,则可用“no ip dhcp database url”命令。命令中的可选项和参数说明如下:

    clip_image001 url:指定用于存储自动绑定关系的远程文件名。它可以有以下几种URL格式:

    ? tftp://host/filename

    ? ftp://user:password@host/filename

    ? rcp://user@host/filename

    ? flash://filename

    ? disk0://filename

    clip_image001[1] timeout seconds:(可选)指定在放弃一个数据库传输前应该等待的时间(以秒为单位)。超出这个设置的时间限制,则传输将放弃。默认情况下,DHCP服务器是等待300秒时间,如果设为0,则相当于可以无限等待。

    clip_image001[2] write-delay seconds:(可选)指定多久时间后DHCP服务器应当发送一次更新。默认情况下,DHCP服务器是每300秒发送一次更新,最小时间为60秒。

    以下示例指定DHCP停止向数据库传输前等待的时间为80秒,远程存储的数据库文件名为ftp://user:password@172.16.1.1/router-dhcp。

    ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

    以下示例显示“tftp://172.16.1.1/router-dhcp”DHCP数据库更新时间间隔为100秒。

    ip dhcp database tftp://172.16.1.1/router-dhcp write-delay 100

    2. ip dhcp conflict logging命令

    ip dhcp conflict logging”全局配置模式命令用来启动在DHCP服务器上的冲突日志功能。要禁用冲突日志功能,则要使用“no ip dhcp conflict logging”全局配置模式命令。一般情况下是会使用至少一个DHCP服务器代理的,所以默认会启用冲突日志功能。如果没有使用数据库代理,则要禁止冲突日志功能,因为在路由器上没有这么大的闪存空间可用来存储这些日志。

    4.2.2 DHCP数据库代理的配置示例

    以下示例显示如何把绑定存储在IP地址为172.16.4.253的主机的router-dhcp目录中,使这台主机成为DHCP数据库代理。代理与DHCP服务器之间是通过FTP协议进行文件传输的。示例中,在重写数据库并且更新前,DHCP服务器将等待2分钟时间。所用的用户帐户和密码就是winda,123456

    Router> enable

    Router# configure terminal

    Router(config)#ip dhcp database ftp://winda:123456@172.16.4.253/router-dhcp write-delay 120

    4.3 DHCP服务器IP地址排除配置

    DHCP服务器是假设在DHCP地址池中的所有地址都是可以分配给DHCP客户端的。如果有些地址必须静态分配给某个主机(如各种服务器),而该地址又在DHCP地址池中,这时你必须把那些在IP地址池中不能分配给DHCP客户端的IP地址排除在外。还有一种情况,如果在同一个网络或者子网中配置了两台地址池所对应的网段完全一样的DHCP服务器用于冗余或均衡,并且允许两台DHCP服务器同时工作,而不是在一台服务器时才接替原来那台服务器的工作,这时这两台DHCP服务器的地址池一定得用排除功能来排除在另一台DHCP服务器地址池中的地址,否则就会发生冲突。

    4.3.1 IP地址排除的配置步骤及示例

    配置排除IP地址的步骤如表4-2所示。也很简单,主要就一个命令,那就是“ip dhcp excluded-address”全局配置模式命令,用来排除不能给DHCP客户端分配的IP地址,或者一个IP地址范围。

    表4-2 排除IP地址的配置步骤

    步骤

    命令

    说明

    Step 1 

    enable

    例如:

    Router> enable

    如果配置了特权模式密码,则要按提示输入正确的特权模式密码才能进入。

    Step 2 

    configure terminal

    例如:

    Router# configure terminal

    进入全局配置模式。

    Step 3 

    ip dhcp excluded-address low-address [high-address]

    例如:

    Router(config)# ip dhcp excluded-address172.16.1.100 172.16.1.103

    指定DHCP服务器不能分配给客户端的地址或者地址段。示例中指定是172.16.1.00~172.16.1.103这四个地址不能分配给客户端。为了管理上的方便,通常是把一个连续的地址段保留下来用于一些服务器静态使用,而不是零散的单个IP地址,否则需要运用本步命令多次排除这些单个的IP地址。

    以上配置步骤中的“ip dhcp excluded-address low-address [high-address] ”全局配置模式命令是用来指定DHCP服务器不分配给客户端的地址池中的地址或地址范围的。如果要排除一个地址,则只用low-address参数来指定;如果要排除的是一个连续的IP地址范围,则还要使用high-address参数,这时low-address参数用来指定要排除地址范围中的最低IP地址,而参数high-address是用来指定要排除地址范围中最高的IP地址。可使用最前面加“no”关键字选项的该命令来删除原来所做的相应地址排除。

    以下示例显示如何配置排除一个从172.16.1.100到172.16.1.199,共包含100个IP地址的地址范围。

    Router> enable

    Router# configure terminal

    Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.199

    4.3.2 IP地址排除的配置示例

    本示例中,有Server A和Server B两个服务器,且都是在10.0.20.0/24这个子网中。现在通过DHCP服务器的IP地址排除功能把这个子网均匀地地划分到这两个DHCP服务器上,Server A配置可分配的IP地址范围为10.0.20.1~10.0.20.125,而Server B配置可分配的IP地址范围为10.0.20.126 ~10.0.20.254。

    Server A上的配置:

    ip dhcp excluded-address 10.0.20.126 10.0.20.255

    !

    ip dhcp pool A

    network 10.0.20.0 255.255.255.0

    Server B上的配置:

    ip dhcp excluded-address 10.0.20.0 10.0.20.125

    !

    ip dhcp pool B

    network 10.0.20.0 255.255.255.0

    4.4 DHCP服务器IP地址池配置

    DHCP服务器上的最基本配置就是DHCP地址池的创建与配置了。你可以一个字符串(如“engineering”)或者整数(如“0”)命名DHCP地址池。配置地址池的同时就进入了路由器DHCP地址池配置模式(提示符为“(dhcp-config)#”),为地址池配置各种所需的参数,如IP子网号和默认路由列表等。

    4.4.1 DHCP地址池的选择及配置准备

    DHCP服务定义了一个过程,判定由哪个DHCP服务器识别DHCP客户端所在子网,然后从一个有效的IP地址池为客户端子网分配IP地址。这个过程是通过DHCP服务器来标识用哪个DHCP地址池用于响应客户端请求。

    DHCP服务器是按照以下规则来确定用哪个DHCP地址池来响应DHCP客户端请求的:

    n 如果DHCP客户端不是直接连接DHCP服务器的(此时DHCPDISCOVER广播包消息中的网关地址为非零),则DHCP服务器用DHCP地址池中的网关地址部分所对应的子网与DHCPDISCOVER广播包中网关地址进行匹配,然后确定最终由哪个DHCP地址池来响应DHCP客户端的请求。

    n 如果DHCP客户是直接连接DHCP服务器的(此时DHCPDISCOVER广播包消息中的网关地址为零),则DHCP服务器用DHCP地址池所连接接口的接口地址所对应的子网与DHCPDISCOVER广播包中网关地址进行匹配,然后确定最终由哪个DHCP地址池来响应DHCP客户端的请求。如果所连接口有第二个IP地址,则在与第一个IP地址相匹配的DHCP地址池中地址用完后,就会采用与第二个地址匹配的DHCP地址池进行响应。

    在配置DHCP地址池之前,你需要:

    n 标识DHCP选项(包括默认引导映像文件名、默认路由器、DNS服务器、NetBIOS名称服务器、主子网、第二个子网和指定子网的默认路由器列表)

    n 确定NetBIOS节点类型(B、P、M或者H)

    n 确定DNS域名

    【说明】NetBIOS 名称解析成 IP 地址的确切机制取决于为 NetBIOS 节点配置的节点类型。RFC 1001“TCP/UDP 传输上的 NetBIOS 服务的协议标准:概念和方法”定义了 NetBIOS 节点类型,具体如下所示。

    B-节点(广播):B-节点使用广播NetBIOS名称来注册和解析名称。B-节点有两个主要问题:(1)广播将干扰网络上的每个节点,(2)路由器通常不转发广播,所以只能解析本地网络上的NetBIOS名称。

    P-节点(端对端):P-节点使用NetBIOS名称服务器(NBNS),如WINS服务器来解析NetBIOS名称。P-节点不使用广播,而是直接查询名称服务器。

    M-节点(混合):M-节点是B-节点和P-节点的组合。默认情况下,M-节点作为B-节点使用。如果M-节点无法通过广播解析名称,则使用P-节点查询NBNS服务器。

    H-节点(混合):H-节点是P-节点和B-节点的组合。默认情况下,H-节点作为P-节点使用。如果H-节点无法通过NBNS解析名称,则使用广播解析名称。

    运行Windows Server 2003 的计算机默认是 B-节点,配置WINS服务器时变成H-节点。这些计算机也可以使用本地数据库文件(Lmhosts)来解析远程NetBIOS名称。Lmhost文件存储在 systemroot\System32\Drivers\Etc文件夹中。

    4.4.2 DHCP地址池的配置步骤及示例

    DHCP地址池的配置过程比较长,使用的命令比较多,因为它涉及到许多选项的配置。具体配置步骤如表4-3所示:

    表4-3 DHCP地址池的配置步骤

    步骤

    命令

    说明

    Step 1 

    enable

    例如:

    Router> enable

    进入特权模式。如果配置了特权模式密码,则要按提示输入正确的特权模式密码才能进入。

    Step 2 

    configure terminal

    例如:

    Router# configure terminal

    进入全局配置模式。

    Step 3 

    ip dhcp pool name

    例如:

    Router(config)# ip dhcp pool 1

    创建一个DHCP服务器地址池,进入DHCP地址池配置模式。示例中创建的DHCP地址池名字为1(DHCP地址池名称可以是数字,或者字符串)。

    Step 4 

    utilization mark high percentage-number[log]

    例如:

    Router(dhcp-config)# utilization mark high 80 log

    (可选)配置当前地址池中地址数允许最高的利用率(也就是利用率的上限阈值,是由percentage-number参数指定的)。如果选择了“log”关键字,则启用系统消息日志功能,在地址池中已使用的地址比例超过上面所设置的比例时,系统就会发出一条消息,并记录这个事件。

    示例中设置的是利用率阈值为80%。

    Step 5 

    utilization mark low percentage-number [log]

    例如:

    Router(dhcp-config)# utilization mark low 70 log

    (可选)配置当前地址池中允许最低的利用率(也就是利用率的下限阈值,是由percentage-number参数指定的)。如果选择了“log”关键字,则启用系统消息日志功能,在地址池中已使用的地址比例低于上面所设置的比例时,系统就会发出一条消息,并记录这个事件。示例中设置的是最低利用率阈值为70%。

    Step 6 

    networknetwork-number[mask |/prefix-length]

    例如:

    Router(dhcp-config)# network172.16.0.0 /16

    指定DHCP地址池中地址所在子网号和掩码。可以是传统的网络地址(network-number)+子网掩码(mask)方式表示,如192.168.1.0 255.255.255.0,也可以网络地址+/地址前缀(/prefix-length)方式表示,如192.168.1.0/24。示例中是以地址前缀方式表示的,指定的是172.16.0.0/16这样一个标准的B类网络。

    Step 7 

    domain-name domain

    例如:

    Router(dhcp-config)# domain-name lycb.com

    指定DHCP客户端域名(domain)。如果客户端已是域网络中,则要键入对应的域网络域名,如果客户端是在一个工作组网络中,则在这里配置了域名后,自动为DHCP客户端主机名加上这个指定的域名后缀。示例中指定的域名是lycb.com。

    Step 8 

    dns-server address [address2 ... address8]

    例如:

    Router(dhcp-config)# dns server 172.16.1.103 172.16.2.103

    DHCP客户端指定可用的一个或多个个(最多8个)DNS服务器地址(address[address2 ... address8])。至少指定一个,在指定多个时,各地址中间以空格分隔。DNS服务器应以优先级顺序排列。示例中指定了两个DNS服务器:172.16.1.103,172.16.2.103。

    Step 9 

    bootfilefilename

    例如:

    Router(dhcp-config)# bootfile xllboot

    (可选)指定DHCP客户端所默认使用的DHCP服务器上引导映象。

    Step 10 

    next-server address [address2 ... address8]

    例如:

    Router(dhcp-config)# next-server 172.17.1.103 172.17.2.103

    (可选)为DHCP客户端指定在启动进程中使用的下一个DHCP服务器地址(address [address2 ... address8])。这当然是在配置了多个DHCP服务器,并且想轮流使用这DHCP服务器时才需要设置。如果没有配置这个命令,则DHCP服务器会通过“ip helper address”命令使用指定的服务器作为启动时用的DHCP服务器。

    Step 11 

    netbios-name-server address [address2 ... address8]

    例如:

    Router(dhcp-config)# netbios-name-server 172.16.1.103 172.16.2.103

    (可选)为Microsoft DHCP客户端指定基于NetBIOS协议的WINS服务器地址(address [address2 ... address8]),最多指定8个,且按优先级排列,中间以空格分隔。

    Step 12 

    netbios-node-type type

    例如:

    Router(dhcp-config)# netbios-node-type h-node

    (可选)为Windows DHCP客户端指定NetBIOS节点类型。型包括:broadcas(广播)、 peer-to-peer(点对点)、mixed(混合)或者hybrid(混杂)。

    Step 13 

    default-router address [address2 ... address8]

    例如:

    Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101

    (可选)为DHCP客户端指定默认路由器IP地址(address [address2 ... address8])。这个路由器应当是与客户端处于同一子网中(其实就是这些路由器连接客户端所在子网的接口的IP地址)。至少指定一个默认路由器,最多可以指定8个,也是按优先级顺序排列的。当一个DHCP客户端请求一个IP地址时,担当DHCP服务器的路由器会访问这个默认的路由器列表,并从中选择另一个路由器作为DHCP客户端用于转发消息的第一跳。在DHCP客户端启动时,客户端就会把数据包发送到这个默认的路由器,使用这个默认路由器连接其他网络。示例中指定了两个默认路由器:172.16.1.100和172.16.1.101。

    Step 14 

    option code [instance number] {ascii string | hex stringip-address}

    例如:

    Router(dhcp-config)# option 19 hex 01

    (可选)配置DHCP服务器选项。DHCP选项定义一个传送配置信息到DHCP客户端的框架,配置参数和其他控制信息是装载在存储在DHCP消息选项字段中的特征数据项目。命令中的参数和选项说明如表4-4所示。示例中配置的是代码为19的选项,启用IP数据包转发。

    Step 15 

    lease {days [hours] [minutes]| infinite}

    例如:

    Router(dhcp-config)# lease 30

    (可选)指定客户端租约IP地址的期限。默认为一天。“infinite”关键字指定客户端IP地址的租约期为不受限制。示例中指定的租约期为30天。

    Step 16 

    end

    例如:

    Router(config-dhcp-subnet-secondary)# end

    退出DHCP地址池配置模式,返回到全局配置模式。

    表4-4 option命令参数和选项说明

    参数和选项

    说明

    code

    指定DHCP选项代码,取值范围为0~254。代码是指定给选项的唯一数字,选项类别中的其他任何选项都不能使用相同的代码。代码必须适用于选项类别:

    clip_image001[3] 供应商选项-对于每个供应商类,代码值为 1~254

    clip_image001[4] 站点选项-代码值为 128~54

    clip_image001[5] 扩展选项-代码值为 77~27

    instancenumber

    (可选)指定一个示例号,取值范围为0~255,默认为0。

    asciistring

    指定一个NVI(Network Virtual Terminal,网络虚拟终端)ASCII字符串。如果包含空格则一定要用引号括住整个字符串。

    hexstring

    指定点分十六进制数据(以字符串表示)。在十六进制字符串中每个字节是两个十六进制数字,每个字节可以用句点、冒号或者空格分隔。值勤为0时表示禁止IP数据包转发,值为1时表示启用IP数据包转发,其他值对应不同的类型,具体参见相关DHCP详细的选项说明。如下面的示例配置的是代码为19的选项,启用IP数据包转发(因为十六进制为1)。

    Router(dhcp-config)# option 19 hex 01

    ipaddress

     

    指定DHCP客户端所用的Web服务器IP地址或主机名,可以指定多个。如下面的示例配置的是代码为72的选项,其中指定了DHCP客户端可以使用的Web服务器地址有两个:172.16.3.252172.16.3.253。Router(dhcp-config)#option 72 ip 172.16.3.252 172.16.3.253

     

    4.4.3 DHCP地址池的配置示例

    在以下示例中,创建了三个DHCP地址池:一个是在172.16.0.0/16网络中(名称为pool 0),一个是在172.16.1.0/24子网中(名称为pool 1),第三个是在172.16.2.0/24子网中(名称为pool 2)。pool 0地址池中配置了域名、DNS服务器、NetBIOS名称服务器和NetBIOS节点类型,pool 和pool 2地址池继承了pool 0地址池中的这些属性配置。在这三个DHCP地址池中,客户端的IP地址租用期均为30天,并且在每个子网中的所有地址,除了排除地址均可以由DHCP服务器分配给客户端。表4-5列出了在这三个DHCP地址池中的设备所用的IP地址(这些地址是需要排除的)。

    表4-5 三个地址池的设备地址分配

    Pool 0 Network 172.16.0.0)

    Pool 1 (Subnetwork 172.16.1.0)

    Pool 2 (Subnetwork 172.16.2.0

    设备

    IP Address

    设备

    IP Address

    设备

    IP Address

    默认路由器

    默认路由器

    172.16.1.100

    172.16.1.101

    默认路由器

    172.16.2.100

    172.16.2.101

    DNS服务器

    172.16.1.102

    172.16.2.102

    NetBIOS名称服务器

    172.16.1.103

    172.16.2.103

    NetBIOS节点类型

    h-node

    ip dhcp database ftp://winda:123456@172.16.4.253/router-dhcp write-delay 120 !---这是设置DHCP数据库代理,参见本章前面介绍

    ip dhcp excluded-address 172.16.1.100 172.16.1.103

    ip dhcp excluded-address 172.16.2.100 172.16.2.103

    !--- 以上两条语句是用来排除设备所用的静态IP地址的

    !

    ip dhcp pool 0

    network 172.16.0.0 /16

    domain-name cisco.com

    dns-server 172.16.1.102 172.16.2.102

    netbios-name-server 172.16.1.103 172.16.2.103

    netbios-node-type h-node

    !

    ip dhcp pool 1

    network 172.16.1.0 /24

    default-router 172.16.1.100 172.16.1.101

    lease 30

    !

    ip dhcp pool 2

    network 172.16.2.0 /24

    default-router 172.16.2.100 172.16.2.101

    lease 30

    4.5 带辅助子网的DHCP地址池配置

    使用DHCP地址池的辅助子网功能,则每一个DHCP地址池就可以配置一个主子网,和任意多个辅助子网,但这些子不能相交。每个辅助子网都可以用于DHCP服务器向DHCP客户端分配IP地址。DHCP服务器多子网功能可以使得只需向IOS DHCP服务器地址池添加额外地址到现有地址池中,而不用使用一个独立的地址池来管理。像上节最后的示例中,配置了三个地址池,如果使用本节介绍的这个功能,就不用这么复杂了。具体在本节后面的示例中有体现。

    4.5.1 DHCP地址池辅助子网的应用环境和IP地址分配规则

    配置辅助子网是在DHCP辅助子网配置模式下进行的,提示符为“(config-dhcp-subnet-secondary)#”。你可以为辅助子网指定一个默认的地址列表,也可以指定辅助子网的利用率。这里的设置将覆盖全局利用率设置。

    在一个DHCP地址池中可以配置多个不相交子网,应用在以下任一网络拓扑结构中:

    n IP地址池——DHCP客户端和服务器在同一个子网中。

    n DHCP中继——DHCP客户端和DHCP服务器不在同一子网中,需要通过DHCP中继代理进行通信。在DHCP中继代理设备的中继代理接口上需要配置辅助IP地址,主IP用于连接DHCP客户端所在子网,而辅助IP地址用于连接DHCP服务器。

    n 分级DHCP——DHCP服务器配置作为DHCP子网分配服务器,而DHCP客户端和DHCP子网分配服务器通过一个配置了按需地址池(On-Demand Address Pool)的路由器进行通信。

    如果一个DHCP服务器包含多个子网,则可以按照以下规则来从子网中分配IP地址:

    (1)当DHCP服务器接收到一个地址分配请求,首先会从主子网中查找可用地址;

    (2)当主子网中的IP地址已用完,DHCP服务器自动在任一由DHCP服务器维护的辅助子网中,按照优先级顺序查找可用地址,即使DHCP请求客户端的网关地址不与辅助子网匹配。

    (3)如果请求客户端的网关与地址池中的某个辅助子网匹配,则DHCP服务器从这个子网中为客户分配一个IP地址。

    4.5.2 带辅助子网DHCP地址池的配置步骤及示例

    带辅助子网的DHCP地址池的配置与上节介绍的单一子网DHCP地址池的配置方法基本一样,不同的只是在这里要创建所需的辅助DHCP子网,然后再配置一些必要的选项,如辅助子网所对应的默认路由器、利用率等。具体步骤如表4-6所示。

    表4-6 带辅助子网的DHCP地址池配置步骤

    步骤

    命令

    说明

    Step 1 

    enable

    例如:

    Router> enable

    进入特权模式。如果配置了特权模式密码,则要按提示输入正确的特权模式密码才能进入。

    Step 2 

    configure terminal

    例如:

    Router# configure terminal

    进入全局配置模式。

    Step 3 

    ip dhcp pool name

    例如:

    Router(config)# ip dhcp pool 1

    为DHCP服务器地址池命名,进入DHCP地址池配置模式。示例中创建的是一个名为pool1的地址池。

    Step 4 

    utilization mark highpercentage-number [log]

    例如:

    Router(dhcp-config)#utilization mark high80 log

    (可选)配置当前地址池中地址数允许最高的利用率(也就是利用率的上限阈值)。如果选择了log”关键字,则启用系统消息日志功能,在地址池中已使用的地址比例超过上面所设置的比例时,系统就会发出一条消息,并记录这个事件。示例中最高利用率阈值为80%。

    Step 5 

    utilization mark low percentage-number [log]

    例如:

    Router(dhcp-config)#utilization mark low 70 log

    (可选)配置当前地址池中最低的利用率(也就是利用率下限阈值)。如果选择了log”关键字,则启用系统消息日志功能,在地址池中已使用的地址比例低于上面所设置的比例时,系统就会发出一条消息,并记录这个事件。示例中设置的是最低利用率阈值为70%。

    Step 6 

    network network-number [mask |/prefix-length]

    例如:

    Router(dhcp-config)#network 172.16.0.0 /16

    指定DHCP地址池中地址所在子网号和掩码。可以传统的网络地址+子网掩码方式表示,如192.168.1.0 255.255.255.0,也可以地址前缀方式表示,如192.168.1.0/24。示例中是以地址前缀方式表示的,指定的是172.16.0.0/16这样一个标准的B类网络。

    Step 7 

    domain-name domain

    例如:

    Router(dhcp-config)#domain-name lycb.com

    指定客户端域名。如果客户端已是域网络中,则要键入对应的域网络域名,如果客户端是在一个工作组网络中,则在这里配置了域名后,自动为DHCP客户端主机名加上这个指定的域名后缀。示例中指定的域名是lycb.com。

    Step 8 

    dns-serveraddress [address2 ... address8]

    例如:

    Router(dhcp-config)# dns server172.16.1.103 172.16.2.103

    DHCP客户端指定可用的DNS服务器。至少指定一个,也呆以指定多个(最多8个),中间以空格分隔。DNS服务器应以优先级顺序排列。示例中指定了两个DNS服务器:172.16.1.103,172.16.2.103。

    Step 9 

    bootfile filename

    例如:

    Router(dhcp-config)# bootfile xllboot

    (可选)为DHCP客户端指定使用的DHCP服务器上默认的引导映象名称。

    Step 10 

    next-serveraddress [address2 ... address8]

    例如:

    Router(dhcp-config)#next-server172.17.1.103 172.17.2.103

    (可选)为DHCP客户端指定在启动进程中使用的下一个DHCP服务器。这当然是在配置了多个DHCP服务器,并且想轮流使用这DHCP服务器时才需要设置。如果没有配置这个命令,则DHCP服务器会通过“ip helper address”命令使用指定的服务器作为启动时用的DHCP服务器。

    Step 11 

    netbios-name-serveraddress [address2 ... address8]

    例如:

    Router(dhcp-config)#netbios-name-server172.16.1.103 172.16.2.103

    (可选)为Microsoft DHCP客户端指定基于NetBIOS协议的WINS服务器,也可以最多指定8个,且按优先级排列,中间以空格分隔。

    Step 12 

    netbios-node-type type

    例如:

    Router(dhcp-config)#netbios-node-type h-node

    (可选)为Microsoft DHCP客户端指定NetBIOS节点类型。这个节点类型包括:broadcas(广播)、 peer-to-peer(点对点)、mixed(混合)或者hybrid(混杂)。

    Step 13 

    default-router address[address2 ... address8]

    例如:

    Router(dhcp-config)#default-router 172.16.1.100 172.16.1.101

    (可选)为DHCP客户端指定默认路由器IP地址。这个路由器应当是与客户端处于同一子网中(其实就是这些路由器连接客户端所在子网的接口的IP地址)。至少指定一个默认路由器,最多可以指定8个,也是按优先级顺序排列的。当一个DHCP客户端请求一个IP地址时,担当DHCP服务器的路由器会访问这个默认的路由器列表,并从中选择另一个路由器作为DHCP客户端用于转发消息的第一跳。在DHCP客户端启动时,客户端就会把数据包发送到这个默认的路由器,使用这个默认路由器连接其他网络。示例中指写定了两个默认路由器:172.16.1.100和172.16.1.101。

    Step 14 

    option code [instancenumber] {ascii string |hex string |ip-address}

    例如:

    Router(dhcp-config)#option 19hex 01

    (可选)配置DHCP服务器选项。

    Step 15 

    lease {days[hours] [minutes]| infinite}

    例如:

    Router(dhcp-config)# lease 30

    (可选)指定客户端租约IP地址的期限。默认为一天。“infinite”关键字指定客户端IP地址的租约期为不受限制。示例中指定的租约期为30天。

    Step 16 

    network network-number [{mask |/pre- fix-length} [secondary]]

    例如:

    Router(dhcp-config)#network 10.10.0.0 255.255.0.0 secondary

    (可选)为辅助DHCP服务器子网指定网络地址和掩码,可以添加任意多个辅助子网到地址池中。当主子网中的地址用完后,就会按自动在这些辅助子网中查找可用的地址。可以为客户端配置指向这些辅助子网的默认路由器。

    Step 17 

    override default-routeraddress [address2 ... address8]

    例如:

    Router(config-dhcp-subnet-secondary)# override default-router10.10.0.100 10.10.0.101

    (可选)当从辅助子网中分配IP地址时,为这些客户端指定可用的默认路由器列表。它将覆盖在前面第13步设置的全局默认路由器列表设置。这时第13步设置的全局默认路由器列表设置仅用于地址池中的主子网。示例中设置的两个辅助子网默认路由器为:10.10.0.100,10.10.0.101。

    Step 18 

    override utilization mark high percentage-num- ber

    例如:

    Router(config-dhcp-subnet-secondary)# override utilization mark high 60

    (可选)为辅助子网专门设置最高的地址利用率,这里的设置将覆盖在前面第4步所做的最高利用率设置,使得第4步所做的设置仅用于地址中的主子网。

    Step 19 

    override utilization mark low percentage-number

    例如:

    Router(config-dhcp-subnet-secondary)# override utilization mark low 40

    (可选)(可选)为辅助子网专门设置最低的地址利用率,这里的设置将覆盖在前面第5步所做的最低利用率设置,使得第5步所做的设置仅用于地址中的主子网。

    Step 20 

    end

    例如:

    Router(config-dhcp-subnet-secondary)# end

    退出DHCP辅助子网配置模式,返回到特权模式。

    4.5.3 带辅助子网DHCP地址池的配置示例

    在以下的示例中,创建了一个名为pool3的DHCP地址池。主子网为172.16.0.0/16,两个辅助子网分别为172.16.1.0/24和172.16.2.0/24。当在主子网中的IP地址用完后,DHCP服务器会按在地址池添加的顺序检测辅助子网。当DHCP服务器分配在172.16.1.0/24辅助子网中的一个IP地址时,DHCP服务器就会使用包含了172.16.1.100和172.16.1.101这两个IP地址(它们都是这个子网所用的默认路由器IP地址)的指定子网默认路由器列表;而DHCP服务器在分配172.16.2.0/24子网中的地址时,DHCP服务器就会使用包含172.16.0.100 ~172.16.0.103这四个地址(它们都是这个子网所用的默认路由器IP地址)的默认路由器列表。因为在这个子网中使用了主子网中所有的默认路由器,所以在下面的配置中并没有使用“override default-router”命令为这个子网指定所用的默认路由器。

    两个辅助子网的其他属性都是继承主子网172.16.0.0/16的配置,如域名、DNS服务器、NetBIOS名称服务器和NetBIOS节点类型。DHCP客户端的IP地址租用期均为30天,每个子网中的所有地址,除了排除地址外都可以用于DHCP服务器为客户端分配。

    表4-7列出了在DHCP地址池中所包含的三个不相交子网中设备所用IP地址。

    表4-7 poo 3地址池三个不相交子网中设备地址分配

    主子网:172.16.0.0/16

    辅助子网:172.16.1.0/24

    辅助子网:172.16.2.0/24

    设备

    IP Address

    设备

    IP Address

    设备

    IP Address

    默认路由器

    172.16.0.100

    172.16.0.101

    172.16.0.102

    172.16.0.103

    默认路由器

    172.16.1.100

    172.16.1.101

    默认路由器

    172.16.0.100

    172.16.0.101

    172.16.0.102

    172.16.0.103

    DNS服务器

    172.16.1.102

    172.16.2.102

    NetBIOS名称服务器

    172.16.1.103

    172.16.2.103

    NetBIOS节点类型

    h-node

    ip dhcp database ftp://winda:123456@172.16.4.253/router-dhcp write-delay 120 !---配置DHCP数据库代理

    ip dhcp excluded-address 172.16.0.100 172.16.1.103

    ip dhcp excluded-address 172.16.1.100 172.16.1.101

    !

    ip dhcp pool pool3

    network 172.16.0.0 /16

    default-router 172.16.0.100 172.16.2.101 172.16.0.102 172.16.0.103

    domain-name cisco.com

    dns-server 172.16.1.102 172.16.2.102

    netbios-name-server 172.16.1.103 172.16.2.103

    netbios-node-type h-node

    lease 30

    !

    network 172.16.1.0 /24 secondary

      override default-router 172.16.1.100 172.16.1.101

      exit

    !

    network 172.16.2.0 /24 secondary

    本文转自王达博客51CTO博客,原文链接http://blog.51cto.com/winda/521598如需转载请自行联系原作者


    茶乡浪子

    展开全文
  • C3550配置作为DHCP服务器工程实例网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在网络,命名为server,IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows2000 ...

    C3550配置作为DHCP服务器工程实例

    网络环境:

    一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在网络,命名为server,IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows2000 advance server,

    同时兼作DNS服务器,IP地址为192.168.2.10,vlan3为客户机1所在网络,IP地址段为192.168.3.0,

    子网掩码:255.255.255.0,网关:192.168.3.1命名为work01,vlan4为客户机2所在网络,

    命名为work02,IP地址段为192.168.4.0,子网掩码:255.255.255.0,网关:192.168.4.1,

    3550作DHCP服务器,端口1-8划到VLAN 2,端口9-16划分到VLAN 3,端口17-24划分到VLAN 4.

    DHCP服务器实现功能:

    各VLAN保留2-10的IP地址不分配置,例如:192.168.2.0的网段,保留192.168.2.2至192.168.2.10

    的IP地址段不分配.

    安全要求:

    VLAN 3和VLAN 4 不允许互相访问,但都可以访问服务器所在的VLAN 2,默认访问控制列表的规则是拒绝所有包.

    配置命令及步骤如下:

    第一步:创建VLAN:

    Switch>en

    Switch#VlanDatabase

    Switch(Vlan)>Vlan2 Name server

    Switch(Vlan)>Vlan3 Name work01

    Switch(vlan)>Vlan 4 Name work02

    第二步:设置VLAN IP地址:

    Switch#Config T

    Switch(Config)>IntVlan 2

    Switch(Config-vlan)IpAddress 192.168.2.1 255.255.255.0

    Switch(Config-vlan)NoShut

    Switch(Config-vlan)>IntVlan 3

    Switch(Config-vlan)IpAddress 192.168.3.1 255.255.255.0

    Switch(Config-vlan)NoShut

    Switch(Config-vlan)>IntVlan 4

    Switch(Config-vlan)IpAddress 192.168.4.1 255.255.255.0

    Switch(Config-vlan)NoShut

    Switch(Config-vlan)Exit

    /*注意:由于此时没有将端口分配置到VLAN2,3,4,所以各VLAN会DOWN掉,待将端口分配到各VLAN后,VLAN会起来*/

    第三步:设置端口全局参数

    Switch(Config)InterfaceRange Fa 0/1 - 24

    Switch(Config-if-range)SwitchportMode Access

    Switch(Config-if-range)Spanning-treePortfast

    第四步:将端口添加到VLAN2,3,4中

    /*将端口1-8添加到VLAN 2*/

    Switch(Config)InterfaceRange Fa 0/1 - 8

    Switch(Config-if-range)SwitchportAccess Vlan 2

    /*将端口9-16添加到VLAN 3*/

    Switch(Config)InterfaceRange Fa 0/9 - 16

    Switch(Config-if-range)SwitchportAccess Vlan 3

    /*将端口17-24添加到VLAN 4*/

    Switch(Config)InterfaceRange Fa 0/17 - 24

    Switch(Config-if-range)Switchport Access Vlan 4

    Switch(Config-if-range)Exit

    /*经过这一步后,各VLAN会起来*/

    配置3550作为DHCP服务器

    /*VLAN 2可用地址池和相应参数的配置,有几个VLAN要设几个地址池*/

    Switch(Config)IpDhcp Pool Test01

    /*设置可分配的子网*/

    Switch(Config-pool)Network192.168.2.0 255.255.255.0

    /*设置DNS服务器*/

    Switch(Config-pool)Dns-server192.168.2.10

    /*设置该子网的网关*/

    Switch(Config-pool)Default-router192.168.2.1

    /*配置VLAN3所用的地址池和相应参数*/

    Switch(Config)IpDhcp Pool Test02

    Switch(Config-pool)Network192.168.3.0 255.255.255.0

    Switch(Config-pool)Dns-server 192.168.2.10

    Switch(Config-pool)Default-router192.168.3.1

    /*配置VLAN4所用的地址池和相应参数*/

    Switch(Config)IpDhcp Pool Test03

    Switch(Config-pool)Network192.168.4.0 255.255.255.0

    Switch(Config-pool)Dns-server192.168.2.10

    Switch(Config-pool)Default-router 192.168.4.1

    第六步:设置DHCP保留不分配的地址

    Switch(Config)IpDhcp Excluded-address 192.168.2.2 192.168.2.10

    Switch(Config)Ip Dhcp Excluded-address 192.168.3.2 192.168.3.10

    Switch(Config)Ip Dhcp Excluded-address 192.168.4.2 192.168.4.10

    第七步:启用路由

    /*路由启用后,各VLAN间主机可互相访问*/

    Switch(Config)IpRouting

    第八步:配置访问控制列表

    Switch(Config)access-list103 permit ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255

    Switch(Config)access-list 103 permit ip 192.168.3.0 0.0.0.255 192.168.2.00.0.0.255

    Switch(Config)access-list 103 permit udp any any eq bootpc

    Switch(Config)access-list 103 permit udp any any eq tftp

    Switch(Config)access-list 103 permit udp any eq bootpc any

    Switch(Config)access-list 103 permit udp any eq tftp any

    Switch(Config)access-list 104 permit ip 192.168.2.0 0.0.0.255 192.168.4.00.0.0.255

    Switch(Config)access-list 104 permit ip 192.168.4.0 0.0.0.255 192.168.2.00.0.0.255

    Switch(Config)access-list 104 permit udp any eq tftp any

    Switch(Config)access-list 104 permit udp any eq bootpc any

    Switch(Config)access-list 104 permit udp any eq bootpc any

    Switch(Config)access-list 104 permit udp any eq tftp any

    第九步:应用访问控制列表

    &n bsp; /*将访问控制列表应用到VLAN3和VLAN 4,VLAN 2不需要*/

    Switch(Config)Int Vlan 3

    Switch(Config-vlan)ip access-group 103 out

    Switch(Config-vlan)Int Vlan 4

    Switch(Config-vlan)ip access-group 104 out

    第十步:结束并保存配置

    Switch(Config-vlan)End

    Switch#Copy Run Start

    以上测试并获通过

    展开全文
  • Cisco 3750交换机配置DHCP服务器实例

    千次阅读 2014-11-12 16:43:19
    Cisco 3750交换机配置DHCP服务器实例 分类: 系统运维 今天发表了>一文,深得各位兄弟支持,更有多人询问如何配置3550作DHCP服务器,因为当时在配置3550作为DHCP中继代理时顺便测试了一把将3550配置DHCP...
  • CISCO 3550交换机配置DHCP步骤 http://network.51cto.com 2010-09-29 16:15 佚名 IT168 我要评论(0) 下面我们就针对CISCO 3550交换机配置DHCP的内容进行一下具体的讲解。给出了网络环境以及配置步骤。...
  • 配置DHCP服务器

    2011-06-23 10:05:13
    运行 Cisco IOS 软件的 Cisco 路由器完全支持路由器充当 DHCP 服务器的角色...将路由器配置DHCP 服务器步骤如下: 步骤 1. 定义 DHCP 在分配地址时的排除范围。这些地址通常是保留供路由器接口、交换机管理 ...
  • Cisco 3550配置dhcp,网络上多有讨论,按照网上介绍的配置一句"IP HELPER-ADDRESS DHCP服务器地址"后,工程当中发现客户机不能从DHCP服务器获取IP地址,本人最近也刚好配置了3550作为DHCP服务器中继代理,最初也曾...
  • 本文参考:Cisco 3550交换机配置DHCP服务器实例。原文链接为:http://www.vlan9.com/cisco-tech/p003003766.html。主要是用于自己以后的复习参考。 网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在...
  • cisco dhcp服务器设置 内容精选换一换通过云服务器或者外部镜像文件创建私有镜像时,如果云服务器或镜像文件所在虚拟机的网络配置是静态IP地址时,您需要修改网卡属性为DHCP,以使私有镜像发放的新云服务器可以动态...
  • 网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在网络,命名为server,IP地址段为192。168。2。0,子网掩码:255。255。255。0,网关:192。168。2。1,域服务器为windows 2000 advance server,同时...
  • Cisco 3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名 为server,IP地址段  为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows...
  •  vlan1为服务器所在vlan,命名为Servers,IP地址段为192.168.1.0,子网掩码:255.255.255.0,网关:192.168.1.254, 域服务器为windows 2003 server,同时兼作DHCP服务器,DNS服务器,IP地址为192.168.1.1 vlan2为客户机...
  • Cisco 3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名 为server,IP地址段  为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows ...
  • Cisco 3550配置dhcp,网络上多有讨论,按照网上介绍的配置一句"IP HELPER-ADDRESS DHCP服务器地址"后,工程当中发现客户机不能从DHCP服务器获取IP地址,本人最近也刚好配置了3550作为DHCP服务器中继代理,最初也曾...
  • 思科 DHCP服务器配置及DHCP中继

    千次阅读 2018-01-15 14:00:26
    思路:1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1 # 创建 VLAN 10 , 20 # 将相关的端口,放入到对应的 VLAN ; # 配置交换机之间的互联链路 - Trunk ;3、配置 SW # 创建 VLAN 10 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,617
精华内容 1,046
关键字:

思科配置dhcp服务器步骤