精华内容
下载资源
问答
  • 思科端口聚合

    2012-07-30 15:47:27
    思科端口聚合
  • Cisco端口聚合

    2013-10-21 10:44:38
    端口聚合有两种方式,一种是手动的方式,一个是自动协商的方式。(1)手动方式这种方式很简单,设置端口成员链路两端的模式为“on”。命令格式为: channel-group <number组号> mode on(2)自动方式自动方式有...

    端口的聚合有两种方式,一种是手动的方式,一个是自动协商的方式。
    (1)
    手动方式
    这种方式很简单,设置端口成员链路两端的模式为on。命令格式为:
    channel-group <number
    组号> mode on

    (2)
    自动方式
    自动方式有两种协议:PAgP(Port Aggregation Protocol)LACP(Link aggregation Control Protocol)
    PAgPCisco设备的端口聚合协议,有autodesirable两种模式。
    auto模式在协商中只收不发,desirable模式的端口收发协商的数据包。



    LACP:标准的端口聚合协议802.3ad,有activepassive两种模式。

    active相当于PAgPauto,而passive相当于PAgPdesirable
    1:在(config)#模式下,输入int port-channel ID164

    2
    :假设要把F0/23F0/24聚合,那么分别在起端口配置里面输入:
    switchport trunk
    encapsulation dot1q
    switchport mode trunk
    (假设有多个VLAN)
    duplex full
    speed 100
    no cdp enable
    channel-group 1 mode on(这里的1就是开始创建的数字),
    或者直接在需要做端口聚合的端口上执行下面命令
    int port-ch 10
    channel-g 10 mode ac
    channel-g p lacp(panp)

    然后只要在对端交换机也做同样配置就可以了.


    交换机连接拓扑图如下:

    spacer.gif


    步骤:

    一、两台三层交换机上创建vlan

    Sw0#conf t

    Sw0(configure)#vlan 10

    Sw0(configure-vlan)#exit

    Sw0(configure)#vlan 11

    Sw0(configure-vlan)#exit

    二、在Sw0交换机上将端口fa0/1-2加入到vlan10中,端口fa0/3加入到vlan 11

    Sw0(configure)#int range fa0/1-2

    Sw0(configure-if-range)#switchport access vlan 10

    Sw0(configure-if-range)#exit

    Sw0(configure)#int fa0/3

    Sw0(configure-if)# switchport access vlan 11

    Sw0(configure)#exit

    三、在Sw1交换机上将fa0/1-2号端口加入到vlan 10中,将fa0/3号端口加到vlan 100

    Sw1#conf t

    Sw1(configure)#int range fa0/1-2

    Sw1(configure-if-range)#switchport access vlan 10

    Sw1(configure-if-range)#exit

    Sw1(configure)#int fa0/3

    Sw1(configure-if)#switchport access vlan 100

    Sw1(configure-if)#exit

    四、在Sw0Sw1交换机上为每个vlan 配置虚拟ip地址

    Sw0#conf t

    Sw0(configure)#int vlan 10

    Sw0(configure-if-vlan)#ip address 192.168.10.253 255.255.255.0

    Sw0(configure-if-vlan)#no shutdown

    Sw0(configure-if-vlan)#exit

    Sw0(configure)#int vlan 11

    Sw0(configure-if-vlan)#ip addresss 192.168.11.254 255.255.255.0

    Sw0(configure-if-vlan)#no shutdown

    Sw0(configure-if-vlan)#exit


    Sw1#conf t

    Sw1(configure)#int vlan 10

    Sw1(configure-if-vlan)#ip address 192.168.10.254 255.255.255.0

    Sw1(configure-if-vlan)#no shutdown

    Sw1(configure-if-vlan)#exit

    Sw1(configure)#int vlan 100

    Sw1(configure-if-vlan)#ip address 192.168.100.254 255.255.255.0

    Sw1(configure-if-vlan)#no shutdown

    Sw1(configure-if-vlan)#exit

    五、将Sw0Sw1交换机相连的fa0/1-2口进行聚合

    Sw0#conf t

    Sw0(configure)#int range fa0/1-2

    Sw0(configure-if-range)#channel-group 1 mode desirable

    Sw0(configure-if-range)#exit


    Sw1#conf t

    Sw1(configure)#int range fa0/1-2

    Sw1(configure-if-range)#channel-gropu 1 mode desirable

    Sw1(configure-if-range)#exit

    【可选做】//六、在Sw0Sw1交换机上将聚合端口设置为trunk

    Sw0#conf t

    Sw0(configure)#int port-channel 1

    Sw0(configure-if)#switchport mode trunk

    Sw0(configure-if)#switchport trunk native vlan 10

    Sw0(configure-if)#exit


    Sw1#conf t

    Sw1(configure)#int port-channel 1

    Sw1(configure-if)#switchport mode trunk

    Sw1(configure-if)#switchport trunk native vlan 10

    Sw1(configure-if)#exit

    //

    七、在Sw0Sw1交换机上设置默认路由(当然你也可以设置能实现路由功能的协议)

    Sw0#conf t

    Sw0(configure)#ip route 0.0.0.0 0.0.0.0 192.168.10.254

    Sw0(configure)#exit


    Sw1#conf t

    Sw1(configure)#ip route 0.0.0.0 0.0.0.0 192.168.10.253

    Sw1(configure)#exit

    八、测试

    PC0客户端设置其ip地址为:192.168.11.1,子网掩码为:255.255.255.0,网关地址为:192.168.11.254

    PC1客户端设置其ip地址:192.168.100.1,子网掩码为:255.255.255.0,网关地址为:192.168.100.254

    利用PC0客户端去pingPC1客户端的ip,检查是否能够ping 即可!!!

    *[注意]在对Sw0Sw1交换机上进行端口聚合后,如果没有设置聚合端口为trunk时,交换机两边是不能够被ping 通的。即使设置了trunk口,如果没有设置三层交换机的路由功能时,也只能实现交换机两端设置了trunk口的端口ip 能够ping 通。所以,在设置了trunk口后,还要记得开启三层交换机的路由功能,即:默认路由、静态路由或动态路由。



    转载于:https://blog.51cto.com/luwang/1312512

    展开全文
  • cisco端口聚合.

    2010-09-20 15:18:44
    关于cisco端口聚合。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
  • cisco端口聚合配置

    千次阅读 2020-04-17 11:05:16
    理解端口聚合基本原理; 掌握一般交换机端口聚合的配置方法; 实验背景 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端...

    实验目标

    • 理解端口聚合基本原理;
    • 掌握一般交换机端口聚合的配置方法;

    实验背景

    端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并提供冗余链路。

    技术原理

    • 端口聚合使用的是EtherChannel特性,在交换机到交换机之间提供冗余的高速的连接方式。将两个设备之间多条FastEthernet或GigabitEthernet物理链路捆在一起组成一条设备间逻辑链路,从而增强带宽,提供冗余。
    • 两台交换机到计算机的速率都是100M,SW1和SW2之间虽有两条100M的物理通道相连,可由于生成树的原因,只有100M可用,交换机之间的链路很容易形成瓶颈,使用端口聚合技术,把两个100M链路聚合成一个200M的逻辑链路,当一条链路出现故障,另一条链路会继续工作。
    • 一台S2000系列以太网交换机只能有1个汇聚组,1个汇聚组最多可以有4个端口。组内的端口号必须连续,但对起始端口无特殊要求。
    • 在一个端口汇聚组中,端口号最小的作为主端口,其他的作为成员端口。同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。
    • 所有参加聚合的端口都必须工作在全双工模式下,且工作速率相同才能进行聚合。并且聚合功能需要在链路两端同时配置方能生效。
    • 端口聚合主要应用的场合:
      1. 交换机与交换机之间的连接:汇聚层交换机到核心层交换机或核心层交换机之间。
      2. 交换机与服务器之间的连接:集群服务器采用多网卡与交换机连接提供集中访问。
      3. 交换机与路由器之间的连接:交换机和路由器采用端口聚合解决广域网和局域网连接瓶颈。
      4. 服务器和路由器之间的连接:集群服务器采用多网卡与路由器连接提供集中访问
    • 视图:全局配置模式下
    • 命令:

    interface range interface_name1 to interface_name2

    Switchport mode trunk

    channel-group 1 mode on 加入链路组1并开启

    • 参数:
      • interface_name1:聚合起始端口
      • interface_name2:聚合结束端口。
      • trunk表示端口可以转发所有Vlan包
      • 将2个或多个物理端口组合在一起成为一条逻辑的路径 ,即链路channel-group,同时也形成了一个逻辑端口port-channel(一个整体)
    • switchport mode access是直接接主机的,所属VLAN中的接口,都是access
    • switchport mode trunk  trunk mode 的接口可以同时传输多个VLAN信息的。
    • trunk mode 常用在两个SWITCH and  ROUTER ,  switch and switch
    • 特权模式下
    • Switch#show etherchannel summary:显示相关汇聚端口组的信息;

    实验设备

    Switch_2960 2台;PC 4台;直连线

    1.设置交换机Switch0

    
     
    1. Switch>enable
    2. Switch #config t
    3. Switch(config) #interface range fa 0/1-2 //同时选择端口fa0/1 fa0/2
    4. Switch(config- if-range) #switchport mode trunk //设置端口模式为trunk
    5. Switch(config- if-range) #channel-group 1 mode on //加入链路组1并开启
    6. Switch(config- if-range) #exit
    7. Switch(config) #port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现负载平衡
    8. Switch(config) #exit
    9. Switch #show etherchannel summary //显示以太信道概况

    2.使用相同的方式配置交换机switch1

    
     
    1. Switch>enable
    2. Switch #config t
    3. Switch(config) #interface range fa 0/1-2 //同时选择端口fa0/1 fa0/2
    4. Switch(config- if-range) #switchport mode trunk //设置端口模式为trunk
    5. Switch(config- if-range) #channel-group 1 mode on //加入链路组1并开启
    6. Switch(config- if-range) #exit
    7. Switch(config) #port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现负载平衡
    8. Switch(config) #exit
    9. Switch #show etherchannel summary //显示以太信道概况

    3.配置PC0

        IP地址:192.168.1.2

        子网掩码:255.255.255.0

    4.设置PC1

        IP地址:192.168.1.3

        子网掩码:255.255.255.0

    5.实验验证

    PC0 ping PC1,ping通

    PC1 ping PC0,ping通

    本实验主要目的是为了让我们能够学会如何使用交换机的端口聚合功能。

    展开全文
  • cisco 端口聚合配置

    2010-04-26 22:58:27
    很完善的思科端口配置方法! 端口聚合(Aggregate-port)又称链路聚合,是指两台交换 机之间在物理上将多个端口连接起来,将多条链路合成一条逻辑 链路。从而增大链路带宽,解决交换网络中因带宽引起的网络瓶 颈问题...
  • 步骤2:选择欲配置为EtherChannel的物理端口.PAgP EtherChannel(端口聚合协议)CISCO私有,每组最多支持8条  链路汇聚.LACP EtherChannel(链路聚合控制协议)IEEE802.3ad定义,每组最多支持16条链路汇聚(但只有  8...

    转裁于:https://www.cnblogs.com/fatt/p/4401470.html

     

    冗余连接及其实现

      无论什么设备都无法保障运行的绝对稳定性,即使再优秀的产品也无法保证24×7不间断的工作。除去设备或模块损坏、传输线路中断等硬件故障原因以外,还可能由于网络流量过载、任务负荷过大而导致核心交换机瘫痪。因此,若欲保障网络的稳定性,保证重要服务不被中断,就必须采取必要的应对措施。通常情况下,这种措施就是冗余连接,即在核心交换机与骨干交换机之间,以及交换机与服务器之间创建多个连接。

      1. EtherChannel

      EtherChannel也叫聚合端口(Aggregate port AP)和Port Trunking(多干路冗余连接)技术,将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大带宽的端口,组成一个干路,既可以增加交换机之间,以及交换机与服务器之间的连接带宽,实现均衡负载,又可提供冗余连接。当所有端口都正常工作时,绑定的带宽为所有端口带宽之和。当某个端口宕掉后,其他端口仍能维持正常连接。Cisco的EtherChannel有两个级别,即Fast EtherChannel和Giga Etherchannel,最大带宽分别为400Mbps和4Gbps。

      2. Spanning Tree

      Spanning Tree实现冗余连接的工作方式是Stand By。在交换机之间创建两条链路,由于交换机之间存在两条链路时会导致拓扑环,因此,借助于Spanning Tree技术使得除了一条链路工作外,其余链路实际上是处于待机(Stand By)状态,这显然影响传输的效率

     

          聚合端口它可将多物理连接当作一个单一的逻辑连接来处理,它允许两个交换器之间通过多个端口并行连接同时传输数据以提供更高的带宽、更大的吞吐量和可恢复性的技术,并且实现成员端口上的流量平衡.(流量平衡具体有3种方法:根据源MAC地址,目的MAC地址或源IP地址/目的IP地址)
    一般来说,两个普通交换器连接的最大带宽取决于媒介的连接速度(100BAST-TX双绞线为200M),而使用Trunk技术可以将4个200M的端口捆绑后成为一个高达800M的连接。这一技术的优点是以较低的成本通过捆绑多端口提高带宽,而其增加的开销只是连接用的普通五类网线和多占用的端口,它可以有效地提高子网的上行速度,从而消除网络访问中的瓶颈。另外Trunk还具有自动带宽平衡,即容错功能:即使Trunk只有一个连接存在时,仍然会工作,这无形中增加了系统的可靠性。

    etherchannel特性在switch到switch、switch到router、主机(服务器)到switch或router之间提供冗余的、高速的连接,简单说就是将两个设备间多条FE或GE物理链路捆在一起组成一条设备间逻辑链路,从而达到增加带宽,提供冗余的目的。

    端口聚合的注意事项:

    1.AP成员端口的端口速率必须一致

    2.AP成员端口必须属于同一个VLAN

    3.AP成员端口使用的传输介质应相同

    4.缺少情况下创建的AP是二层AP

    5.二层端口只能加入二层AP,三层端口只能加入三层AP

    6.AP不能设置端口安全功能

    7.当配置layer 2端口作etherchannel时只要在成员端口配置模式下用channel-group n命令指定该端口要加入的channel-group组,这时switch会自动创建port-channel接口,而当配置layer 3端口作etherchannel时,还需现在全局配置模式下用 interface port-channel n 命令手工创建port-channel接口。

    8.一个端口加入AP,端口的属性将被AP的属性所取代

    9.一个端口从AP中删除,则端口的属性将恢复为其加入AP前的属性

    10.当一个端口加入AP后,不能在该端口上进行任何配置,直到该端口退出AP

     

    1. 创建EtherChannel

    创建EtherChannel的具体操作步骤如下。

    步骤1:进入全局配置模式.

          Switch#configure terminal

    步骤2:选择欲配置为EtherChannel的物理端口.PAgP EtherChannel(端口聚合协议)CISCO私有,每组最多支持8条

          链路汇聚.LACP EtherChannel(链路聚合控制协议)IEEE802.3ad定义,每组最多支持16条链路汇聚(但只有

          8条工作,其余备份)

          Switch(config)#interface interface-id

    步骤3:将所有端口指定为同一VLAN内的静态访问端口或者配置为Trunk.如果配置为静态端口,只能指定至

          一个VLAN,VLAN取值范围为1-4094.

          Switch(config-if)#switchport mode {access | trunk }

          Switch(config-if)#switchport access vlan vlan-id

    步骤4:将端口指定至EtherChannel组,并指定PAgP或LACP模式.EtherChannel端口组的取值范围为1-48.

          Switch(config-if)#channel-gropu port_channel_number mode { {auto[non-silent] |

                            desirable[non-silent] | on} | {active | passive}}

    对于使用PAGP的四种模式

    Auto:当侦测到PAgP设备时(将只启用PAgP)将端口置于被动协商状态,可以对接收到的PAgP作出响应,但是,

         不能主动发送PAgP包进行协商。

    Desirable:无条件启用PAgP。将端口置于主动协商状态,通过发送PAgP包,主动与其他端口进行协商。

    On:不协商(不用PAgP协议,强制开启).将端口强行指定(加入)至EtherChannel。只有两个on模式端口组连接

        时EtherChannel才可用。

    non-silent:参数主要用于检测链路是否单向失败.默认条例下被设置为auto或desirable参数并参加通道协商

                的接口不用周期性接收到对方的PAgP帧,也可以参加PAgP的计算.(如果链路单向通信的情况

                下,本端发出PAgP帧,链路(本端)却无法接收对方的数据,但此端口(本端口)也参与了

                Etherchannel通信).加入non-silent参数后(非安静模式),本端会要求周期性的接收到对端

              的PAgP帧后再使端口参加EtherChannel的通信,如果没有接收到对端的PAgP帧则会通知STP

               此端口为down的状,导致端口无法参加Etherchannel和STP的计算.

         如果交换机连接到有PAgP能力的伙伴,可以将端口配置为non silent(非安静模式)运行。如果没有为auto或desirable模式指定non-silent关键字,默认为silent。安静模式设置被用于连接到文件服务器或包分析仪(无PAgP能力的伙伴,即单向通信.因为文件服务器或包分析仪不会产生PAgP帧)。该设置允许PAgP将端口添加至Channel组,并使用端口进行传输.

     对于使用LACP的两种模式

    active:当侦测到LACP设备时(将只启用LAC),激活端口的主动协商状态,通过发送LACP包,与其他端口进行主动协商。

    passive:当侦测到LACP设备时(将只启用LACP),将端口置于被动协商状态,可以对接收到的LACP作出响应,但是,不能主动发送LACP包进行协商。

     

    采用PAgP协议时(所以无ON模式),以下几种模式可以构建EtherChannel:

    一个端口为desirable模式,另一个端口为desirable或auto模式。

    一个端口为auto模式,另一个端口为desirable模式。

    采用LACP协议时,以下几种模式可以构建EtherChannel:

    一个端口为active模式,另一个端口为active或passive模式。

    一个端口为active模式,另一个端口为passive模式。

    2. 配置EtherChannel负载均衡

    EtherChannel还具有负载分担和线路备份的作用。

    http://www.visualland.net.cn/view.php?cid=1729&protocol=EtherChannel&title=1. EtherChannel basics 负载均衡FLASH动画.

    所谓负载分担:是指当交换机之间或交换机与服务器之间在进行通信时,EtherChannel的所有链路将同时参与数据的传输,从而使所有的传输任务都能在极短的时间内完成,线路占用的时间更短,网络传输的效率更高。

    etherchannel在作数据转发时,是基于数据包的源或目的MAC地址随机选择etherchannel中的一条物理link进行数据转发的。我们可以通过全局配置命令port-channel load-balance选择是根据源MAC地址还是根据目的MAC地址进行数据转发来实现负载平衡。
      例如:当有两台switch,它们之间有几条link互联作etherchannel,switchA一端连接一台server,switchB一端连接多台clientPC,这时swithA一端的数据流是同一源MAC地址的数据包通过etherchannel转发向不同目的MAC地址。这时,为了充分利用etherchannel中的所有的物理link,在swithA一端就应该配置为基于数据包的目的MAC地址方式.switchB一端的数据流是不同源MAC地址的数据包通过etherchannel转发向同目的MAC地址。在swithB一端就应该配置为基于数据包的源MAC地址方式

    所谓线路备份:是指当部分EtherChannel链路出现故障时,并不会导致连接的中断,其他链路将能够不受影响地正常工作,从而增强了网络的稳定性和安全性。我们可以通过接口配置命令 pagp port-priority 改变优先级设定哪条物理link主用,哪条备用,一旦主用物理link上产生阻塞,备用link立即启用

    具体操作步骤如下。

    步骤1:进入全局配置模式.

          Switch#configure terminal

    步骤2:配置Etherchannel负载均衡

          Switch(config)#port-channel load-balance {dst-mac | src-mac | src-dst-ip | src-dst-mac

                         | dst-ip | src-ip }

          dst-mac:根据输入报文的目的MAC地址进行流量分配。AP各链路中,目的MAC地址相同的报文被送到相

                   同的端口,目的MAC不同的报文分配到不同的端口。  

         src-mac:根据输入报文的源MAC地址进行流量分配。在AP各链路中,来自不同MAC地址的报文分配到不

                 同的端口,来自相同的MAC地址的报文使用相同的端口。

         src-dst-ip:根据源IP与目的IP进行流量分配。不同的源IP——目的IP对的流量通过不同的端口转发,同

                      一源IP——目的IP对通过相同的链路转发。在三层条件下,建议采用此流量平衡的方式。

         src-dst-mac:根据源MAC与目的MAC进行流量分配。不同的源MAC——目的MAC对的流量通过不同的端口转

                       发,同一源MAC——目的MAC对通过相同的链路转发。

         dst-ip:根据输入报文的目的IP地址进行流量分配。在AP各链路中,目的IP地址相同的报文被送到相同的端

                 口,目的IP不同的报文分配到不同的端口。

         src-ip:根据输入报文的源IP地址进行流量分配。在AP各链路中,来自不同IP地址的报文分配到不同的端

                 口,来自相同的IP地址的报文使用相同的端口。

    步骤3:校验配置

          Switch#show etherchannel load-balance

    3. 从EtherChannel中移除端口

    从EtherChannel中移除端口的具体操作步骤如下。

    步骤1:进入全局配置模式.

          Switch#configure terminal

    步骤2:指定欲配置的物理端口.

          Switch(config)#interface interface-id

    步骤3:从EtherChannel中移除端口

          Switch(config-if)no channel-group

    4. 移除整个EtherChannel端口

    移除EtherChannel的具体操作步骤如下。

    步骤1:进入全局配置模式.

          Switch#configure terminal

    步骤2:移除Channel端口

          Switch(config)#no interface port-channel port_channel_number

    其他一些命令

    创建以太通道组:
    (config)#interface port-channel EtherChannel_number
    定义以太通道组的聚合协议
    (config-if)#channel-protocol { pagp | lacp }
    查看通道接口配置信息:
    #show running-config interface port-channel port-channel_interface_number
    查看接口配置信息:
    #show running-config interface **
    查看配置后的通道信息:
    #show etherchannel ** port-channel
    核实PAGP和LACP
    #show interface *** etherchannel
    查看EtherChannel配置情况

    #show eherchannel summary 

    Po1(SU) //SU表示EtherChannl正常.(S-Layer2,U-in use) Fa0/1(P) Fa0/2(P) //P表示Fa0/1和Fa0/2都加入了EthernetChannel,并正常运行.(P-in port-channel)

     

    通常
    Switch(config)#hostname SW2
    SW2 (config)#int fa0/23-24
    SW2(config-if-range)#switchport trunk encapsulation dot1q
    SW2(config-if-range)#switchport trunk allowed vlan2
    SW2(config-if-range)#channel-group 1 mod on
    SW2(config-if-range)#exit

    port-channel可以设成trunk!!!常用
    要想做trunk则必须封装成dot1Q! 否则会提示信息

    具体配置:
      
      Switch# configure terminal
      
      Switch(config)# interface range fastethernet0/4 -5
      
      Switch(config-if-range)# switchport mode access
      
      Switch(config-if-range)# switchport access vlan 10
      
      Switch(config-if-range)# channel-group 5 mode desirable|auto|on
      
      Switch(config-if-range)# end
      
      
      以上配置将F0/4、F0/5端口加入channel-group 5,作etherchannel的端口可以为access端口也可为trunk端口(中继端口)

    在将两个swith间的link作etherchannel与两个swith间的link作trunk有一点相似的地方就是:

      1.配置trunk时两端的端口有几种模式:trunk、auto、desirable,

      2.配置etherchannel时两端的端口有desirable|auto|on(使用PAGP)或active|passive(使用LACP)几种模式.

        所不同的是trunk端口间协商是使用DTP(dynamic trunking protocol);而etherchannel端口间协商是使用PAGP(Port Aggregation Protocol,cisco专有)或LACP (Link Aggregation Control Protocol,802.3AD )

       
      
    注意:在技术领域中把TRUNK翻译为中文是"主干,干线,中继线,长途线",不过一般不翻译,直接用原文.而且这个词在不同场合也有不同的解释:  

    1、在网络的分层结构和宽带的合理分配方面,TRUNK被解释为“端口汇聚”,是带宽扩展和链路备份的一个重要途径。TRUNK把多个物理端口捆绑在一起当作一个逻辑端口使用,可以把多组端口的宽带叠加起来使用。TRUNK技术可以实现TRUNK内部多条链路互为备份的功能,即当一条链路出现故障时,不影响其他链路的工作,同时多链路之间还能实现流量均衡,就像我们熟悉的打印机池和MODEM池一样。 

      2、在电信网络的语音级的线路中,Trunk指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它能够在两端之间进行转接,并提供必要的信令和终端设备。

      3、 但是在最普遍的路由与交换领域,VLAN的端口聚合也有的叫TRUNK不过大多数都叫TRUNKING ,如CISCO公司。所谓的TRUNKING是用来在不同的交换机之间进行连接,以保证在跨越多个交换机上建立的同一个VLAN的成员能够相互通讯。其中交换机之间互联用的端口就称为TRUNK端口。与一般的交换机的级联不同,TRUNKING是基于OSI第二层.如果你在2个交换机上分别划分了多个VLAN(VLAN也是基于Layer2的),那么分别在两个交换机上的VLAN10和VLAN20的各自的成员如果要互通,就需要在A交换机上设为VLAN10的端口中取一个和交换机B上设为VLAN10的某个端口作级联连接。VLAN20也是这样。那么如果交换机上划了10个VLAN就需要分别连10条线作级联,端口效率就太低了。当交换机支持TRUNKING的时候,事情就简单了,只需要2个交换机之间有一条级联线,并将对应的端口设置为Trunk,这条线路就可以承载交换机上所有VLAN的信息。这样的话,就算交换机上设了上百个个VLAN也只用1个端口就解决了。

    如果是不同台的交换机上相同id的vlan要相互通信,那么可以通过共享的trunk端口就可以实现,如果是同一台不同id的vlan/不同台不同id的vlan它们之间要相互通信,需要通过第三方的路由来实现;vlan的划分有两个需要注意的地方:一是划分了几个不同的vlan组,都有不同的vlan id号;分配到vlan 组里面的交换机端口也有port id.比如端口1,2,3,4划分到vlan10,5,6,7,8划分到vlan20,我可以把1,3,4的端口的port id设置为10,而把2端口的 port id设置为20;把5,6,7端口的port id设置为20,而把8端口的port id设置为10.这样的话,vlan10中的1,3,4端口能够和vlan20中8端口相互通信;而vlan10中的2端口能够和vlan20中的5,6,7端口相互通信;虽然vlan id不同,但是port id相同,就能通信同样vlan id相同,port id不同的端口之间却不能相互访问,比如vlan10中的2端口就不能和1,3,4端口通信。


      配置EtherChannel
    以太通道捆绑几个以太端口为一个独立的逻辑链路。如4006交换机,你可以捆绑在4006任何模块上最多8个兼容的具有相同速率的端口。每个以太通道具有一个port-channel端口号。要捆绑一个以太通道时,会产生一个逻辑port-channel端口,逻辑端口下的配置可影响与之捆绑的物理端口,但物理端口下的配置不能影响逻辑端口的配置。
    1) 三层以太通道(逻辑port-channe)的配置
    Switch# configure terminal
    Switch(config)# interface port-channel 1 // 创建一个逻辑端口
    Switch(config-if)# ip address 172.32.52.10 255.255.255.0
    Switch(config-if)# end

    2) 三层物理端口配置
    Switch# configure terminal
    Switch(config)# interface range fastethernet 5/4 – 5 (注意: 空格是必需的)
    Switch(config-if)# no switchport // 改变该端口为三层接口
    Switch(config-if)# no ip address // 确认接口没有配置IP地址
    Switch(config-if)#  channel-group 1 mode desirable
    Switch(config-if)# end

    附: Switch(config-if)# channel-group port_channel_number mode {auto | desirable | on} // 将该物理端口加入一个以太通道中,并确定PagP模式。

    3) 二层以太通道配置
    Switch# configure terminal
    Switch(config)# interface range fastethernet 5/6 - 7 (注意: 空格是必需的)
    Switch(config-if-range)# channel-group 2 mode desirable
    Switch(config-if-range)# end
    Switch# show running-config interface port-channel 2
    Building configuration...
    Current configuration:
    !
    interface Port-channel2
    switchport access vlan 10
    switchport mode access
    end 
    Switch#

    ? 如何作端口聚合
    如果要配置二台6509之间的Trunk联接,首先将二6509用千兆光纤相联好,然后分别配置二相联端口的trunk,可以是只用一双光纤,或用二对光纤做port channel,配置如下:
    一双光纤相联时,分别在二台65上进行以下的配置:

    interface GigabitEthernet1/1
    no ip address
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 1

    二对光纤相联时,必须要做port channel,分别在二台65上进行以下的配置:
    interface port-channe1
    no ip address
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 1
    !
    interface GigabitEthernet1/1
    no ip address
    duplex full
    speed 1000
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 1
    channel-group 1 mode on
    !
    interface GigabitEthernet1/2
    no ip address
    duplex full
    speed 1000
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 1
    channel-group 1 mode on
    4、指导原则
    有很多关于配置以太通道的指导原则,这些原则涉及trunk、动态VLANSTP和其他方面,如果配置不当,某些以太通道接口会自动停用,以避免出现网络环路或者其他的问题。为了减少花在以太通道故障排除上的时间,需要采纳以下建议:

    *将以太通道内的所有端口指定到同一个VLAN,或者将其都配置为trunk端口;
    *如果将以太通道配置为trunk,在以太通道内所有的端口上配置相同的trunk模式。在以太通道内的各端口上配置不同的trunk模式会引起意想不到的结果; 
    *在trunking以太通道内,通道内所有端口上支持的VLAN的范围相同。如果各个端口支持的VLAN范围不相同,即使设为Auto或者Desirable模式,端口也不会形成以太通道; 
    *不要将以太通道内的端口置为动态VLAN端口,这会严重影响交换机的性能; 
    *GARP,GVRP或者QOS配置不同的端口不会形成以太通道; 
    *如果在端口上配置了对广播的限制,将广播限制配作以通道内所有端口百分比为单位的限制。如果使用“包每秒”形式的广播限制,则在超过广播限制的1秒钟内,单播数据包可能丢失; 
    *启动了安全策略的端口不能形成以太通道,对于以太通道内的端口,不能启动端口上的安全功能; 
    *如果以太通道内的端口被IGMP组播过滤使用,则必须将PAG和LACP中的以太通道模式设置为OFF。不能使用其他的模式; 
    *配置为交换端口分析器(SPAN,switchde port analyzer)目的的端口不能形成以太通道; 
    *如果其中任何一个端口的协议过滤设置不同,就无法形成以太通道; 
    *每个以太通道最多能能包含8个配置兼容的以太接口; 
    *同一个以太通道内的所有接口的速率和双工模式要求相同; 
    *启动以太通道内的所有接口。如果你关闭了以太通道内的一个接口,它会被作为链路状态故障处理,其上通信会转移到以太通道内剩余的接口上; 
    *STP端口开销值不同的接口只要配置兼容就能形成以太通道。在端口上配置不同的STP端口开销本身不会导致接口由于不兼容而无法形成以太通道。但是,在一个以太通道内的所有接口上,最好将STP端口开销配置为一样;

    除了以上列举的限制,还有一个需要关注的问题就是你允许那些端口用于以太通道的配置。

    5、思路:
    1、先划分vlan,并将相应的端口加入到vlan中
    2、将要合并的相邻的端口置为trun模式
    3、设定相连的两台交换机的端口的工作方式(即物理特性)相同。
    4、开启以太网通道
    1.交换机相连的端口必须为相邻的端口,以及物理特性必须相同。 
    交换机1:
    Router>en
    Router#vlan d
    Router(vlan)#vl 2
    VLAN 2 added:
    Name: VLAN0002
    Router(config)#interface range f0/1 - 2
    Router(config-if-range)#switchport mode trunk [l1]
    Router(config)#interface range f0/1 – 2
    Router(config-if-range)#switchport access vlan 2
    [l2]Router(config-if-range)#duplex full [l3]
    Duplex will not be set until speed is set to non-auto value
    Duplex will not be set until speed is set to non-auto value
    Router(config-if-range)#speed 100 [l4]
    *Mar 1 00:07:06.315: %DTP-5-TRUNKPORTON: Port Fa0/1-2 has become dot
    *Mar 1 00:07:06.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    nged state to up
    Router(config)#interface range f0/1 - 2
    Router(config-if-range)#channel-group 1 mode on [l5] 
    Creating a port-channel interface Port-channel1
    Router#show etherchannel 1 summary
    Flags: D - down P - in port-channel
    I - stand-alone s - suspended
    R - Layer3 S - Layer2
    U - in use
    Group Port-channel Ports
    -----+------------+-------------------------
    1 Po1(SU) Fa0/1(P) Fa0/2(P)

    转载于:https://www.cnblogs.com/qzqdy/p/10682227.html

    展开全文
  • 端口聚合又称链路聚合,是指两台交换机之间在物理上将多个端口连接起来,将多条链路合成一条逻辑链路。从而增大链路带宽,解决交换网络中因带宽引起的网络瓶颈问题。多条物理链路之间能够相互冗余备份,其中任意一条...

            端口聚合又称链路聚合,是指两台交换机之间在物理上将多个端口连接起来,将多条链路合成一条逻辑链路。从而增大链路带宽,解决交换网络中因带宽引起的网络瓶颈问题。多条物理链路之间能够相互冗余备份,其中任意一条链路断开,不会影响其他链路的正常转发数据。

             以下是实验拓扑:

     

     

     

    S1 3560 fa0/1<-------------------->     fa0/1 3560  S2

    S1 3560 fa0/2<-------------------->     fa0/2 3560  S2

     S1 3560 fa0/24<-------------------->     pc1 vlan 20 

     S2 3560 fa0/24<-------------------->     pc2 vlan 20

    1、基本配置

    s1:

     

     

    S1(config)#vlan 20

     

    S1(config-vlan)#name vlan20

    S1(config-vlan)#exit

    S1(config)#interface fastethernet 0/24

    S1(config-if)#switchport access vlan 20

     

    s2:

     

     

     

     

    S2(config)#vlan 20

    S2(config-vlan)#name vlan20

    S2(config-vlan)#exit

    S2(config)#interface fastethernet 0/24

    S2(config-if)#switchport access vlan 20

     

     

     

    2、s1上配置聚合端口(s2配置相同)

     

     

    S1(config)#interface range fastethernet 0/1-2

     

    S1(config-if-range)#channel-group 1 mode desirable(on)

    S1(config-if)#switchport mode trunk
    S1(config-if)#switchport trunk encap dot1q

    转载于:https://blog.51cto.com/ciscowu/538412

    展开全文
  • 2950与3560交换机进行2端口端口汇聚1)出现故障内容:由于布线的问题,由于资金的问题,一台2950(全是100M端口)交换机,一台3750(全是千兆端口)交换机,2950与3560交换机进行2端口端口汇聚?是否可以?是可以...
  • 步骤:1、思科交换机的配置在特权模式下新建链路聚合channel 端口,并将端口加入Vlansw2960(config)#intport-channel 1(根据实际情况填写channel号)sw2960(config)#switchport access valn 20配置要加入链路聚合...
  • 网络拓扑:****************基本配置****************SW1>en;进入特权模式SW1#conft;进入全局配置模式SW1(config)#hostnameSW1;...设置特权加密口令SW1(config)#enablepasswordcisco;设置特权非密口令SW1...
  • 思科交换机端口聚合

    千次阅读 2020-10-27 20:32:33
    端口聚合 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个...
  • 就我个人而言,常常需要去协调网络组同事配合我完成对Vcenter做多端口聚合的配置。必须两端完成捆绑配置才可以生效,今天就给大家讲解一下如何对交换机完成端口聚合配置操作。 1、创建Channel Group 2、将对应端口...
  • 在计算机网络的某些配置中我们常常需要用到端口聚合,将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并提供冗余链路。但是提到端口聚合不得不提到另一...
  • cisco交换机怎么配置聚合口?有时交换机和交换机,交换机和路由器之间的端口速率,不能满足实际的速率,就需要将两个以上的端口绑在一起,实现均很负载,这就需要聚合口配置,下面我们一起来看看
  • 思科交换机端口聚合 端口聚合,顾名思义,就是将多个端口聚合在一起,使其看起来就好像是一个端口,链路的带宽是原来端口的总和。虽然,聚合在一起的端口在逻辑上属于一个channel-group,但是它们又是相互独立的。...
  • Cisco交换机端口聚合(EtherChannel)

    千次阅读 2020-01-02 19:01:17
     端口聚合,英文简称EtherChannel(以太通道)是由Cisco研发的,应用于交换机之间的多链路捆绑技术。它的基本原理是: 将两个设备间多条物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的(这条逻辑链路带...
  • Cisco 交换机端口聚合技术(EtherChannel)

    千次阅读 2020-03-18 15:37:37
    端口聚合:英文简称EtherChannel(以太通道)是由Cisco研发的,应用于交换机之间的多链路捆绑技术。它的基本原理是:将两个设备间多条物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的(这条逻辑链路带宽...
  • 今天听老师讲端口聚合,为了方便日后复习故此有 了本篇随笔。 0x01准备工具: cisco模拟器 0x02:目录 为什么要用端口聚合? 广播风暴? 扩展:SMTP 0x03正文: 为什么要用端口聚合? 有时候因为数据包过...
  • cisco端口聚合

    千次阅读 2017-04-15 21:27:05
    实验环境:Cisco 交换机3560 两台 实验拓扑: 基本配置: Switch>en Switch#conf t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#int range f0/1-2 (进行范围选取) ...
  • 思科模拟器端口聚合配置实验

    千次阅读 2019-12-04 21:12:40
    端口聚合使用的是 EtherChannel 特性,在交换机到交换机之间提供冗余的高速的连接方式。将两个设备之间多条 FastEthernet 或 GigabitEthernet 物理链路捆在一起组成一条设备间逻辑链路,从而增强带宽,提供冗余。 ...
  • 端口聚合使用的是 EtherChannel 特性,在交换机到交换机之间提供冗余的高速的连接方式。将两个设备之间多条 FastEthernet 或 GigabitEthernet 物理链路捆在一起组成一条设备间逻辑链路,从而增强带宽,提供冗余。 两...
  • 配置ESXi的端口聚合配置ESXi6.0的端口聚合由于本人只有华为S5700-48TP-SI的交换机,所以请根据实际情况配置交换机,本例中ESXi服务器的网卡3连接交换机的3端口,网卡4连接交换机的4端口。交换机配置创建聚合端口组,...
  • 经常有网友问我端口聚合是指链路聚合还是VLAN trunking啊?为什么老师给他们讲的都是这个名称呢,是老师讲错了,还是书上有错。  我学网络这么久了,也一直实际使用中在把这两个词混用,其实这完全不是一回事。 ...
  • 学习目标:理解和掌握交换机端口聚合的基本原理和配置方法 1.定义:端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并...
  • 交换机和交换机,交换机和路由器之间的端口速率,不能满足实际的速率,就需要将两个以上的端口绑在一起,实现负载均衡,防止出现单点故障。1.选择交换机SW2960 进行配置 将f0/1和f0/2端口模式配置成truck#conf ...
  • 端口聚合 将两个设备间多条物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的(这条逻辑链路带宽相当于物理链路带宽之和)。 除了增加带宽外,端口聚合还可以在多条链路上均衡分配流量,起到负载分担的...
  • cisco-N3K端口聚合

    千次阅读 2019-08-06 11:23:26
    N3K端口聚合配置: feature lacp ##开启lacp(Link Aggregation Control Protocol,链路汇聚控制协议,802.3ad聚合. interface port-channel 2 ##命令进入链路聚合通道 no switchport ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,092
精华内容 1,636
关键字:

思科端口聚合