精华内容
下载资源
问答
  • 基本的路由交换配置命令cisco) 序言 从本章开始会陆续的更新关于数通,即路由交换的配置命令,想要学习关于网络数通的可以持续关注。 环境需求 由于是初入配置,采用思科的PT(Cisco Packet Tracer Student)即可...

    基本的路由交换配置命令(cisco)

    序言

    从本章开始会陆续的更新关于数通,即路由交换的配置命令,想要学习关于网络数通的可以持续关注。

    环境需求

    由于是初入配置,采用思科的PT(Cisco Packet Tracer Student)即可,本实验采用的是6.2版本的。

    基本命令

    1.是否进入向导模式 :no
    2.从用户模式进入特权模式:enable
    3.从特权模式进入全局模式:configzore termianal
    4.查看接口摘要信息:show ip interface brief
    5.查看设备信息:show version
    6.查看当前配置文件:show running-config
    7.查看启机配置文件:show startup-config
    8.查看flash:内容:show flash
    9.返回上一级:exit
    10.直接返回特权模式:end
    11.修改设备名称:hostname R1
    12.进入某个接口:interface fastEthernet 0/0
    13.为接口配置IP:ip address 192.168.1.1 255.255.255.0
    14.删除接口IP:no ip address

    远程控制路由器(TELNET)

    在我们需要对路由器进行配置的时候,不可能每次都拿console线去直接连接路由器配置,在大多的情况下,我们都是远程的配置相关的命令,远程连接的方法有很多,本次先简单的讲解一下telnet的配置命令。
    1.配置环境,一台PC(192.168.1.2),一台路由器(192.168.1.10 //接口IP),确保PC可以ping通路由器。
    在这里插入图片描述
    2、远程登陆实验:使用三种认证方式。
    第一种认证:线下密码认证。
    进入vty0-4号虚拟链路:line vty 0 4
    设置链路密码: password cisco(密码)
    启用线下密码认证:login
    在这里插入图片描述
    使用这种配置命令,当PC telnet路由器时,会直接提示输入密码,输入成功后进入用户模式

    第二种:本地用户数据库。
    进入vty0-4号虚拟链路:line vty 0 4
    设置链路密码: password cisco(密码)
    启用本地用户数据库认证:login local
    明文形式显示用户和密码:username ccie(用户) password cisco (密码)
    在这里插入图片描述
    使用这种配置命令,当PC telnet路由器时,则会需求输入用户名和密码,输入成功后进入用户模式。

    第三种:本地用户数据库并授权15级别。
    进入vty0-4号虚拟链路:line vty 0 4
    设置链路密码: password cisco(密码)
    启用本地用户数据库认证:login local
    密文形式显示密码,并授权15级别:username csdn(用户) privilege 15 secret 123(密码)
    在这里插入图片描述
    这种与第二种一样,区别在于,当输入用户和密码后,是直接进入特权模式的。

    便捷命令

    关闭域名查找:no ip domain-lookup 防止敲错命令等待(模拟器可以按crtl+shift+6 关闭等待)
    光标跟随:logging synchronous 防止输入命令时被跳出信息打断。

    结尾

    最后,今天的网络配置命令就到这里了,后续的内容会持续更新,内容也会适当的增加难度,希望能够帮助到你,当然大佬的不喜的话勿喷,有错的欢迎指教,共同探讨,谢谢观看。

    展开全文
  • 思科路由交换,一个大型企业网络的网络拓扑,在这里,有所有的配置,你可以更详细的了解路由交换
  • Cisco路由器交换机防火墙配置命令详解1、交换机支持的命令 交换机基本状态 switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname...

    Cisco路由器交换机防火墙配置命令详解 

    1、交换机支持的命令

      交换机基本状态

      switch: ;ROM状态, 路由器是rommon>

      hostname> ;用户模式

      hostname# ;特权模式

      hostname(config)# ;全局配置模式

      hostname(config-if)# ;接口状态

      交换机口令设置

      switch>enable ;进入特权模式

      switch#config terminal ;进入全局配置模式

      switch(config)#hostname ;设置交换机的主机名

      switch(config)#enable secret xxx ;设置特权加密口令

      switch(config)#enable password xxa ;设置特权非密口令

      switch(config)#line console 0 ;进入控制台口

      switch(config-line)#line vty 0 4 ;进入虚拟终端

      switch(config-line)#login ;允许登录

      switch(config-line)#password xx ;设置登录口令xx

      switch#exit ;返回命令

      交换机VLAN设置

      switch#vlan database ;进入VLAN设置

      switch(vlan)#vlan 2 ;建VLAN 2

      switch(vlan)#no vlan 2 ;删vlan 2

      switch(config)#int f0/1 ;进入端口1

      switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

      switch(config-if)#switchport mode trunk ;设置为干线

      switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

      switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

      switch(config)#vtp domain ;设置发vtp域名

      switch(config)#vtp password ;设置发vtp密码

      switch(config)#vtp mode server ;设置发vtp模式

      switch(config)#vtp mode client ;设置发vtp模式

      交换机设置IP地址

      switch(config)#inte***ce vlan 1 ;进入vlan 1

      switch(config-if)#ip address ;设置IP地址

      switch(config)#ip default-gateway ;设置默认网关

      switch#dir flash: ;查看闪存

      交换机显示命令

      switch#write ;保存配置信息

      switch#show vtp ;查看vtp配置信息

      switch#show run ;查看当前配置信息

      switch#show vlan ;查看vlan配置信息

      switch#show inte***ce ;查看端口信息

      switch#show int f0/0 ;查看指定端口信息

      2. 路由器支持的命令

      路由器显示命令

      router#show run ;显示配置信息

      router#show inte***ce ;显示接口信息

      router#show ip route ;显示路由信息

      router#show cdp nei ;显示邻居信息

      router#reload;重新起动 

    路由器口令设置

      router>enable ;进入特权模式

      router#config terminal ;进入全局配置模式

      router(config)#hostname ;设置交换机的主机名

      router(config)#enable secret xxx ;设置特权加密口令

      router(config)#enable password xxb ;设置特权非密口令

      router(config)#line console 0 ;进入控制台口

      router(config-line)#line vty 0 4 ;进入虚拟终端

      router(config-line)#login ;要求口令验证

      router(config-line)#password xx ;设置登录口令xx

      router(config)#(Ctrl+z) ; 返回特权模式

      router#exit ;返回命令

      路由器配置

      router(config)#int s0/0 ;进入Serail接口

      router(config-if)#no shutdown ;激活当前接口

      router(config-if)#clock rate 64000 ;设置同步时钟

      router(config-if)#ip address ;设置IP地址

      router(config-if)#ip address second ;设置第二个IP

      router(config-if)#int f0/0.1 ;进入子接口

      router(config-subif.1)#ip address ;设置子接口IP

      router(config-subif.1)#encapsulation dot1q ;绑定vlan中继协议

      router(config)#config-register 0x2142 ;跳过配置文件

      router(config)#config-register 0x2102 ;正常使用配置文件

      router#reload ;重新引导

      路由器文件操作

      router#copy running-config startup-config ;保存配置

      router#copy running-config tftp ;保存配置到tftp

      router#copy startup-config tftp ;开机配置存到tftp

      router#copy tftp flash: ;下传文件到flash

      router#copy tftp startup-config;下载配置文件

      ROM状态

      Ctrl+Break ;进入ROM监控状态

      rommon>confreg 0x2142 ;跳过配置文件

      rommon>confreg 0x2102 ;恢复配置文件

      rommon>reset;重新引导

      rommon>copy xmodem: flash: ;从console传输文件

      rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP

      rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码

      rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP

      rommon>TFTP_FILE=c2600.bin ;指定下载的文件

      rommon>tftpdnld ;从tftp下载

      rommon>dir flash: ;查看闪存内容

      rommon>boot ;引导IOS


    转载于:https://blog.51cto.com/zhuyilong/1931942

    展开全文
  • Cisco交换路由配置命令【交换机命令总结】【交换机口令设置】:switch>enable进入特权模式switch#configterminal进入全局配置模式switch(config)#hostname<hostname>设置交换机的主机名switch(config)#...

    Cisco交换路由配置命令

    【交换机命令总结】

    【交换机口令设置】:
    switch>enable    进入特权模式       
    switch#config terminal    进入全局配置模式
    switch(config)#hostname <hostname>    设置交换机的主机名
    switch(config)#enable secret xxx    设置特权加密口令
    switch(config)#enable password xxa    设置特权非密口令

    使用Telnet远程式管理
    switch(config)#interface vlan 1    进入vlan 1
     switch(config-if)#ip address <IP> <mask>    设置IP地址
    switch(config-if)#ip default-gateway <IP>    设置默认网关
    switch(config)#line vty 0  4    进入虚拟终端
    switch(config-line)#login    允许登录
    switch(config-line)#password xx    设置登录口令
    switch#exit    返回命令
     控制台口令
    switch(config)#line console 0    进入控制台口
    switch(config-line)#login    允许登录
    switch(config-line)#password xx    设置登录口令
    switch#exit    返回命令
     基本接口配置
    switch(config)#interface f0/1    进入f0/1接口
    switch(config-if)#duplex full    配置全双工模式
    switch(config-if)#speed 100    配置速率
    switch(config-if)#description to *****    接口描述
    switch(config)#ip domain-name  ***.com    设置或名服务器
    switch(config)#mac-address-table aging-time <10-1000000>    设置mac表超时时间
    switch#write    保存配置信息
    switch#copy running-config startup-config    保存当前配置nvram
     switch#erase startup-config    清除配置文件
     交换机VLAN设置:
    switch#vlan database    进入VLAN设置
    switch(vlan)#vlan 2    建VLAN 2
     switch(vlan)#name 名字    建VLAN 2的名称
    switch(vlan)#no vlan 2    删vlan 2
    注:删除vlan时原属于此vlan的端口处于非激活状态,直到重新分配为止
    switch(config)#int f0/1    进入端口1
     switch(config-if)#switchport mode access    当前端口工作莫试
    switch(config-if)#switchport access vlan 2    当前端口加入vlan 2
     switch(config-if)#switchport mode trunk    设置为干线
    switch(config-if)#switchport trunk encapsulation dot1q    设置vlan 中继协议
    switch(config-if)#no switchport mode 或 ( switchport mode access)    禁用干线
    switch(config-if)#switchport trunk allowed vlan add 1,2 ;  从Trunk中添加vlans
     switch(config-if)#switchport trunk allowed vlan remove 1,2 ;从Trunk中删除vlans
     switch(config-if)#switchport trunk pruning vlan remove 1,2 ;从Trunk中关闭局部修剪
     以太网通道配置
    switch(config)#interface range fasternet0/1 - 2    将fasternet0/1和0/2 口捆绑 (成双不成单)
    switch(config-if)#channel-group 1 mode on    配置以太通道模式
    switch(config-if)#port-channel load-balance {dst-mac | src-mac}在链路间实现负载均衡
    switch#show etherchannel  1  summary    查看通道信息
    switch#show etherchannel  load-balance    查看通道信息
    vtp配置
    switch(config)#vtp domain <name>    设置vtp域名
    switch(config)#vtp password <word>    设置vtp密码
    switch(config)#vtp mode server    设置vtp服务器模式
    switch(config)#vtp mode client    设置vtp客户机模式
    switch(config)#vtp mode transparent    设置vtp 透明模式
    switch(config)#vtp version <1>  <2>    设置vtp版本
    switch(config)#vtp pruning    启用vtp修解
    switch(config)#no vtp pruning    关闭vtp修解
     注:要想从vtp中减少一台交换机只需将该交换机vtp 名更改
     生成树stp:
    switch(config)#spanning-tree vlan <vlan-list>    启用stp生成树(基于vlan)
    switch(config)#spanning-tree vlan <vlan-list> root primary    指定根交换机(基于vlan)
    switch(config)#spanning-tree vlan <vlan-list> root secondary    指定备用根交换机(基于vlan)
    switch(config)#spanning-tree vlan <vlan-list> priority <0-65535> 指定交换机优先级(基于vlan)
    switch(config)#no spanning-tree vlan <vlan-list> priority    将交换机的优先级恢复默认值(基于vlan)
    switch(config-if)#spanning-tree vlan <vlan-list> cost <0-200000000> 指定端口成本(起用trunk的端口模式下)
    switch(config-if)#spanning-tree vlan <vlan-list> port-prioty <0-255> 指定交换机端口优先级(基于vlan)
    switch(config-if)#spanning-tree portfast    配置速端口(连接终端设备的端口状态)如pc机
    switch(config)#spanning-tree uplinkfast    配置上行速端口
     注:在配置上行速端口前要先将基于vlan上的网桥优先级,网桥成本恢复默认值。起用了该命令后在进行优先级更改,
    switch(config)#spanning-tree vlan <vlan-list> hello-time <1-10> 配置交换机hello时间(基于vlan)
    switch(config)#spanning-tree vlan <vlan-list> forward-time <4-30> 修改转发延迟计时器(基于vlan)
    switch(config)#spanning-tree vlan <vlan-list> max-time <6-40>    修改最大老化时间(基于vlan)
     注:vlan为可选参数,当没有该参数时将修改所有vlan网桥的优先级\及所有的vlan端口成本
    switch#show spanning-tree summery    检测vlan生成树配置
    switch#show spanning-tree vlan <vlan-id> detail    浏览详细生成树配置信息
    switch#show spanning-tree interface <int-id> detail    浏览详细生成树端口配置信息
     交换机显示命令:
    switch#show vtp status    查看vtp配置信息
    switch#show running-config    查看当前配置信息
    switch#show vlan    查看vlan配置信息
    switch#show interface    查看端口信息
    switch#show int f0/0    查看指定端口信息
    switch#dir flash:    查看闪存
    switch#show version    查看当前版本信息
    switch#show mac-address-table aging-time    查看mac超时时间
    switch#show cdp    cisco设备发现协议  (可以查看聆接设备)
    switch#show cdp traffic    杳看接收和发送的cdp包统计信息
    switch#show cdp neighbors    查看与该设备相邻的cisco设备
    switch#show interface f0/1 switchport                                    查看有关switchport的配置
    switch#show cdp neighbors                              查看与该设备相邻的cisco设备

    【2950交换机密码恢复】
     拨下交换机的电源线
     用手按在mode按键上,插上电源线。
     看到出现  flash_init  load_helper  boot    switch:  画面时松开mode键
     在switch:后执行flash_init命令查看flash中的文件
     把config.text 文件改名为"config.old    rename flash:config.text flash:config.old
    执行boot命令启动交换机
     交换机出现是否进入配置的对话, 执行no命令
     进入特权模式查看flash文件      执行enable  在switch#show flash:
    把config.old改为config.text            rename flash:config.old flash:config.text 
    把config.text考入系统的running-config
     copy flash:config.text system:running-config
    重新设置密码并存盘



    【路由器命令总结】

    路由器命令状态:
    >>  路由器处于rxboot状态,开机60秒内按ctrl+break可进入此状态用于软件升级和手工引导.
    router>用户命令状态,只能查看一些基本信息
    router#特权命令状态
    router(config)#全局设置状态
    router(config-if)#接口设置状态
     路由器口令设置:
    router>enable    进入特权模式
    router#config terminal    进入全局配置模式
    router(config)#hostname <hostname>    设置交换机的主机名
    router(config)#enable secret xxx    设置特权加密口令
    router(config)#enable password xxx    设置特权非密口令
     控制台口令
    router(config)#line console 0    进入控制台口
    router(config-line)#login    要求口令验证
    router(config-line)#password xx    设置登录口令
     使用Telnet远程式管理
    router(config)#line vty 0 4    进入虚拟终端
    router(config-line)#login    要求口令验证
    router(config-line)#password xx    设置登录口令

    路由器基本配置:
    router(config)#int s0/0  <f0/1>    进入Serail接口
    router(config-if)#ip address <ip> <netmask>    设置IP地址
    router(config-if)#ip address <ip><netmask> second      设置第二个IP
     router(config-if)#description to *****    接口描述
    router(config-if)#no shutdown    激活当前接口
    router(config-if)#clock rate 64000    设置同步时钟 (仅用于串口)
    router(config-if)#clock rate 64    设置带宽    (仅用于串口)
    router(config-if)#ip ospf authentication-key 口令    为ospf设置认证(不加密)
    router(config-if)#ip ospf message-digest-key <钥匙号>md5 口令          为ospf设置md5认证
    router(config-if)#no ip ospf message-digest-key <钥匙号>md5 口令        为ospf设置md5认证
    router(config)#int f0/0.1                进入子接口
    router(config-subif.1)#ip address <ip><netmask>      设置子接口IP
     router(config-subif.1)#encapsulation dot1q <isl>序号    绑定vlan中继协议 (vlan三层路由)
    注:  dot1q 为IEEE802.1Q标准          isl为 思科专用
    router#write          保存配置信息
    router#copy running-config startup-config    保存当前配置nvram
     router#debug ip rip<events>        监测配置
    router#no debug ip all        关闭监测配置
    router#reload    重新起动
    router#erase startup-config    清除配置文件
     路由器显示命令:
    router#show run        显示配置信息
    router#show interface        显示接口信息
    router#show ip route    显示路由信息
    router#show ip arp    显示arp缓存
    router#show cdp nei    显示邻居信息
     静态路由:
    router(config)#ip route <ip-address> <subnet-mask> <下一跳><distance>        命令格式
     注: distance 改变默认管理开销
    router(config)#ip route 0.0.0.0 0.0.0.0 <下一跳>      默认路
    router(config)#ip classless    数据包不能转发时匹配给默认路由
    router(config)#no ip classless    数据包不能转发时弃掉
     动态路由rip:
    router(config)#ip routing                          启动路由转发
    router(config)#router rip                      启动RIP路由协议。
    router(config-router)#network <net-id>    设置发布路由
    router(config-router)#version <1-2>    设置rip版板
    router(config-router)#no auto-summary    禁用自动聚合(当子网不连续时)v2版本
    router(config-if)#ip rip send version 1    允许v2给v1发送报文(运行v2的接口模式下)
    router(config-if)#ip rip receive version 1    允许v2接收v1的报文(运行v2的接口模式下)
    router(config-if)#ip rip send version 1 2    同时发送v1, v2报文(在运行v2的接口模式下)
     注: 当运行rip version 2 的路由器和运行rip version 1的路由器相联时,可以通过接口兼容性开关来实现
     也可以在一个接口上同时发送和接收v1, v2 两个版本
     动态路由ospf:
    router(config)#router ospf <process-id>    启用ospf进程
    router(config-router)#network <net-id> <返掩码>area <area-id>    启用ospf进程
     例: network 192.168.10.2  0.0.0.0 area 0只在某一接口上启用sopf
       network 192.168.0.0  0.0.255.255 area 0将属于192.168.0.0网段的所有接口启用ospf
     router(config-router)#network redistribute rip metric <n>    将rip路由重分发到ospf区域
    router(config-router)#area <area-id> authentication message-digest    在区域中启用md5认证
    router(config-router)#area <area-id> authentication    在区域中启用认证(不加密)
    router(config-router)#area <area-id> stub    使该区域成为stub区域
    router(config-router)#area <area-id> default-cost <n>    改变ABR通告的默认路由(默认为1)
     router(config-router)#area <area-id> stub no-summary    使该区域成为完全stub区域(在ABR上配置)
    router(config-router)#area <area-id> nass    使该区域成为nass区域
    router(config-router)#area <area-id> nass no-summary    使nass区域不接收lsa3,lsa4(在ABR上配置)
    router(config-router)#area <area-id> stub no-redistribution default-information-originate
    注: 使nass区域不接收lsa5,lsa7    但接收lsa3,lsa4,(在ABR上配置)
    router(config-router)#area <area-id> stub no-redistribution no-summary   
    注: 使nass区域不接收lsa3,lsa4,lsa5,lsa7(在ABR上配置)
    router(config-router)#area <area-id> range <net-id><正掩码>            区域间汇总
    router(config-router)#area <area-id> range <net-id><正掩码>        null0    防止汇总过大而导至错误
     注: 地址汇总可以减少LSA泛滥的数量,屏蔽一些网络不稳定的细节,从而节省资源
    router(config-router)#summary-address <net-id> <正掩码>            外部路由汇总(不同自治系统间汇总)
    router(config-router)#area <area-id> virtual-link <route-id>            虚链路配置(中间区域两个ASB上配置
    router(config-router)#summary-address
     router#show ip interface <interface-id>    查看指定接口信息
    router#show ip interface <interface-id>    查看指定接口信息
    router#show ip ospf neighbor <router-id>    查看邻居结构信息
    router#show ip ospf database router <router-id>    查看路由器
    router#show ip interface <interface-id>    查看指定接口信息
    router#show ip ospf neighbor <router-id>    查看邻居结构信息
    router#show ip ospf database router <router-id>    查看路由器lsa1通告
    router#show ip ospf database network <router-id>    路由器网络lsa2通告(所有于DR相连的route)
     router#show ip ospf database summary <router-id>    查看路由器lsa3汇总通告
    router#show ip ospf database asbr-summary    查看路由器lsa4(通告ASBR主机地址)
    router#show ip ospf database external <router-id>    查看lsa5通告(在整个ospf区中泛滥)
    router#show ip ospf database nass-summary    查看路由器lsa7(在nass区中泛滥)
    router#show ip ospf database border-rourters    路由器条目(只显示到达ABR和ASBR的路由)
    router#show ip ospf virtual-link    查看虚链路配置
    router#show ip route    查看网络条目(数据包要转发的目的网络)
     注: 区域内( i )  区域间( I ) (IA)  类型1的外部路由(E1 )计算到达asbr的价值)      类型2外部路由(E2 忽略) 
    router#debug ip adj    查看邻接关系的建立
     热备份路由协议HRSP:
    router(config-if)#standby <number> ip <virtual-ip-address>    将接口加入备份组
    router(config-if)#no standby <number> ip <virtual-ip-address>    将接口从备份组中脱离
     注: 需要加入备份组的所有接口起用相同的virtual-ip-address 且在同一网段内
    router(config-if)#standby <number> priority <0-255>    设置优先级(默认为100)
    router(config-if)#standby <number> preempt    设置占先权
    router(config-if)#standby <number> time <hello-interval> <holdtime>    更改hello消息计时器
     注: hello间隔默认为3秒  保持时间最少应该为hello时间的3倍 可以在(1-255之间变化)
    router(config-if)#standby <number> track <type> <type-id> <interface-priority>   
    注: 利用端跟踪,活跃路由器的优先级可以基于路由器端口的可用性自动进行调整,当跟踪的端口不可用时活跃路由器的优先级将被降低 (默认为10)  例:standby 48 track interface <serial> fastethernet 0/1 100
     router#show standby    查看备份组状态
     基本访问控制列表:
    router(config)#ip access-list { standard | extended } name    命名访问列表
    router(config)#access-list <1-99> permit <source-net-id> <返掩码>
    router(config)#access-list <1-99> deny  <主机> <返掩码>
    注: 0.0.0.0 255.255.255.255 简写为any    允许或拘绝所有网络
      0.0.0.0 简写为host    允许或拘绝某个主机返掩码
    router(config-if)#ip access-group <1-99> in/out    在接口上定义access-list的方向 
    router(config-if)#ip access-group  name  in/out    在接口上定义命名access-list的方向           
    扩展访问控制列表:
    router(config)#access-list <number> {permit|deny } protocol <SourceIP| wild> <destinationIP|wild>[precedence<0-7>][tos<0-15><log>          基于ip的访问列表
     注: 扩展列表范围为100-199之间。protocol是个变量包括(eigrp  gre  icmp  igrp  ip  ipinip  nos  ospf  tcp  udp)
     precedence和tos 是可选变量,它们可以在ip报头的优先级字段和服类类型字段建寻找匹配。
    router(config)#access-list <number> {permit|deny }tcp <SourceIP| wild>[operator port] <destinationIP|wild> [operator port] [established] [precedence<0-7>] [tos<0-15> <log>        基于tcp的访问列表
     注: operaor是指定逻辑操作,可选项是(eq等于 neq不等于 gt 大于lt 小于range指明包括的端口范围
    port指明端口号,常用端口号telnet(23) ftp(20 21) smtp(25) snmp(169) dns(53) tftp(69) www(80)
     established 检查ack 和 rst标记
    router(config)#access-list <number> {permit|deny }udp <SourceIP| wild>[operator port] <destinationIP|wild> [operator port] [precedence<0-7>] [tos<0-15> <log>        基于udp的访问列表
    router(config)#access-list <number> {permit|deny }icmp<SourceIP| wild> <destinationIP|wild> [icmp-type] [icmp-code] [precedence<0-7>] [tos<0-15> <log>        基于icmp的访问列表
     注: 多个接口可以调用相同的访问列表,但是在任意一个接口上,对每种协议仅能有一个进入和离开的访问列表。
     安全过滤通常是做为入站过滤,流量过滤通常是出站过滤。标准访问列表尽可能被放置在靠近目标的地方,扩展访问列表应该放置在靠近源点的地方。
    router(config)#no access-list 102    删除访问控制例表:
    router(config-if)#no ip access-group 101 in    删除访问控制例表
     路由器的nat配置
    Router(config-if)#ip nat inside              ;当前接口指定为内部接口
    Router(config-if)#ip nat outside              ;当前接口指定为外部接口
    Router(config)#ip nat inside source static <私有IP> <公网IP>    静态nat配置
    Router(config)#access-list <1> permit 192.168.100.0 0.0.0.255 定义访问列表(动态nat)
     Router(config)#ip nat pool <name> <起始地址><中止地址> netmask<子网掩码>定义合法ip地址池(动态nat)
     Router(config)#ip nat inside destination list <1> pool <name>      访问列表与地址池邦定(动态nat)
     Router(config)#ip nat inside source list <2> interface <serial0/0> overload  复用外部接口地址
    tcp负载均衡配置
    Router(config)#access-list <1> permit <虚拟主机ip>    定义访问列表
    Router(config)#ip nat pool <name> <起始地址><中止地址> prefix-length <24> type rotary
    注: <起始地址><中止地址>需要实现负载的几个主机地址
    Router(config)#ip nat inside destination list <1> pool <name>      访问列表与地址池邦定
    Router#show ip nat translation
     rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
    overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。
     配置PPP验证:
    RouterA(config)#usename <RouterB> password <word>
     RouterA(config)#int s0
     RouterA(config-if)#ppp authentication {chap|pap}
    【路由器认证】:
     步骤:
     定义一个带名字的钥匙链
     定义在钥匙链上的钥匙
     在接口上启动认证并指定使用的钥匙链
     指定这个接口合用名文还是MD5认证
     可选地配置钥匙的管理
    config)#key chain 钥匙链名
    config-keychain)#key 1
     config-keychain-key)#key-string 口令
    config-keychain-key)#interface ethernet 0
     config-if)#ip rip authentication key-chain 钥匙链名
    config-if)#ip rip authentication mode md5

    【cisco2600路由器密码恢复】
     重启路由器,在启动过程中按下ctrl+break键,使路由器进入rom monitor模式
     在提示符下输入命令修改配置寄存器的值,然后重器路由器
        router>confreg 0x2142    跳过配置文件
        router>reload    重新引导
     重新起动后为了路由器恢复密码后配置不变,把startup-config保存到running-config中然后重新设置密码。
     将配置寄存器的值改回来router(config)#config-register 0x2102
    保存当前配置文件到startup-config

    【路由交换存储设备简介】
    RAM/DRAM动态内存,主要运配置文件,存放路由表,ARP缓存,快速交换缓存,数据包缓冲区和数据包队列,关机后该内容消失
    NVRAM非易失RAM,存储了路由器的备份和启动配置文件
    FLASH MEMORY 闪存,保存操作系统IOS,同一台机可以存放多个版本
    ROM 只读存储器,存放开机自检程序,及一个最原始的IOS
    使用TFTP软件进行IOS的备份和配置文件的上传与下载
     备份IOS
    安装TFTP server
    配置TFTP服务器根目录到指定位置
     用TELNET登陆到路由器  switch#copy flash tftp(从路由器考到服务器)
    输入源文件名  如:IOS的文件名 (输入show version 可以看到源文件名)
    输入目标主机(服务器)IP
    输入目标文件名(可以不改)直接回车
     升级IOS
    把要升级的IOS文件放在TFTP服务器根目录的指定位置
     用TELNET登陆到路由器  switch#copy tftp flash (从服务器考到路由器)
    输入目标主机(服务器)IP
    输入源文件名        ( 要升级的IOS文件名 )
    输入目标文件名(可以不改)直接回车
     注: 保证网络的连通性      (升级时要在重起前完成否则IOS将不能起动)
    配置文件的上传和下载同理copy running-config tftp    copy startup-config tftp
    路由交换文本编辑键的使用

    编辑键    说明                          编辑键              说明     
    ctrl+A        移动光标至行首        ctrl+E                移到光标到行尾     
    ctrl+F      光标向前移一个字符      ctrl+B          光标向后移一个字符     
    ctrl+x        删除光标左边的内容      ctrl+k            删除光标右边的内容     
    ctrl+u        删除一行                          ctrl+r          刷新命令和此前输入的肉容   

     


    【OSI模型七个层的功能】

    【物理层】(第1层)
    • 提供传输介质(如电缆)
    • 将数据转换为与传输介质相应的传输信号
    • 在传输介质中发送信号
    • 包括网络的物理布局
    • 监视传输错误
    • 确定数据信号传输的电压级并同步传输
    • 确定信号类型是数字信号还是模拟信号
     【数据链路层】(第2层)
    • 使用网络适当的格式构造数据帧
    • 创建C R C信息
    • 使用C R C信息检查错误
    • 如果出现错误就重新传输数据
    • 初始化通信链接,并且为了结点到结点的可靠性,要保证链接不被中断
    • 检验设备地址
    • 确认接收到了帧
     【网络层】(第3层)
    • 确定路由包的网络路径
    • 帮助减少网络阻塞
    • 建立虚拟电路
    • 将帧路由到其他网络,在需要时对包的传输进行重新排序
    • 在协议间转换
     【传输层】(第4层)
    • 确保结点与结点间包传输的可靠性
    • 确保数据发送和接收时顺序相同
    • 当包接收到后,给出确认信息
    • 监控包传输错误,再发坏了的包
    • 将大的数据单元分割成小的单元,对于采用不同协议的网络,需要在接收端重新构造这些单元
     【会话层】(第5层)
    • 初始化通信链接
    • 确保通信链接受到维护
    • 确定在各个点上,要哪个结点及时传输数据。例如,哪一个结点首先传输
    • 通信会话结束后,断开连接
    • 转换结点地址
     【表示层】(第6层)
    • 将数据转换为接收结点理解的格式,如从E B C D I C转换为A S C I I
    • 执行数据加密
    • 执行数据压缩
     【应用层】(第7层)
    • 使得可以共享远程驱动器
    • 使得可以共享远程打印机
    • 处理电子邮件消息
    • 提供文件传输服务
    • 提供文件管理服务
    • 提供终端仿真服务

     

     

     

    转载于:https://blog.51cto.com/ableww/1285336

    展开全文
  • 思科路由交换基础命令

    千次阅读 2019-07-21 17:17:14
    一、基本命令 ...configure terminal(全局配置模式)---->interface FastEthernet 0/1(接口模式) FastEthernet 0/1 "0"代表模块号,“1”代表接口号 常用命令 hostname 名字 #改名 show running-conf...

    一、基本命令

    命令行模式

    用户模式---->enable(特权模式)---->configure terminal(全局配置模式)---->interface FastEthernet 0/1(接口模式)
    FastEthernet 0/1   "0"代表模块号,“1”代表接口号
    

    常用命令

    hostname  名字  #改名           show running-config(特权模式)   #查看当前配置
    保存:write(特权)  或者copy  running-config   startup-config
    

    配置密码

     SW1(config)#enable password 123
     SW1(config)#no enable password             #取消密码
    

    恢复出厂设置

     SW1#erase startup-config---->SW1# reload(重启)
    

    禁用DNS查询

    SW1(config)#no ip domain-lookup 
    

    打断命令输入

    *   配置输出日志同步
             SW1(config)#line console 0
             SW1(config-line)#logging synchronous      #实现输入同步,不被系统信息干扰
    

    修改控制台会话时间(默认10分钟)

     SW1(config-line)#exec-timeout 0 0         #从不关闭
    

    二、交换机

    查看MAC地址表:SW1#show mac-address-table

    VLAN操作

    VLAN数量默认允许4096个,vlan1是默认存在的

    一个接口至少要在一个VLAN中

    配置VLAN的步骤:

    创建VLAN
        SW1(config)#vlan 2
        SW1(config-vlan)#name student       #修改名字
        SW1#show vlan brief             #查看VLAN信息
    将接口加入到相应的VLAN中
        SW1(config-if)#interface fastEthernet 0/1
        SW1(config-if)#switchport access vlan 2或者
        Switch(config)#interface range fastEthernet 0/5-6       #进入组接口,可以同时配置多个接口
        
    配置Trunk(中继链路)接口:
        SW2(config-if)#switchport mode trunk
        Switch#show interfaces fastEthernet 0/9 switchport          #查看接口是哪种类型
    

    以太通道:

        Switch(config)#interface range fastEthernet 0/1-2
        Switch(config-if-range)#channel-group 1 mode on
        Switch(config-if)#shutdown                  #关掉接口
        Switch(config-if)#no    shutdown          #打开接口
        Switch#show etherchannel summary        #查看以太通道汇总信息
    

    三层交换机

    SW1(config)#ip routing          #开启路由功能
    SW1(config)#interface vlan 1        #进入VLAN1的虚拟接口
    注意:只有VLAN1接口配置IP后需要开启该接口
    SW1(config-if)#switchport trunk encapsulation dot1q                 #配置Trunk之前需确定封装类型
    把交换接口变为路由接口:
        SW1(config-if)#no switchport
    

    三、路由器

    配IP地址

    R1(config-if)#ip address 192.168.1.254 255.255.255.0
    R1(config-if)#no shutdown
    R1#show ip route        #查看路由表
    R1(config-if)#no  ip address    #删除IP地址
    SW1#show ip interface brief     #查看所有IP接口状态
    

    配静态路由

    ip  route   目标网络  子网掩码  下一跳
    R1(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
    

    配默认路由

    SW1(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.2
    

    OSPF

    SW1(config)#router ospf 1           #开启服务
    SW1(config-router)#network   192.168.1.0   0.0.0.255(反掩码)  area  0           #宣告网络
    

    默认路由注入

        R1(config-router)#default-information originate
    

    四、传输层

    标准ACL

    Router(config)#access-list 1 deny 192.168.2.1 0.0.0.0(精确匹配)           #拒绝192.168.2.1(精确匹配)
    Router(config)#interface gigabitEthernet 0/1                #进入看门的端口
    Router(config-if)#ip access-group 1 in                          #确定看门的方向
    Router(config)#access-list 1 permit any                        #允许所有人访问-
    Router#show access-lists                                             #查看ACL列表
    

    扩展ACL

    Router(config)#access-list 100 deny tcp 192.168.2.1 0.0.0.0 192.168.1.1 0.0.0.0 eq 21           
    					#拒绝192.168.2.1访问192.168.1.1的FTP
    Router(config)#access-list 100 permit ip any any        #放行其他所有数据
    

    NAT地址转换

    静态:一对一,服务器发布服务时才使用,外网可以访问内网

     Router(config)#ip nat inside source static 192.168.1.1 100.0.0.2            #192.168.1.1转换为100.0.0.2
     Router(config)#in g0/0
     Router(config-if)#ip nat inside         #g0/0是里面的接口
     Router(config-if)#in g0/1
     Router(config-if)#ip nat outside        #g0/1是外面的接口
    

    PAT:一对多,端口多路复用,通常只用来访问外网,只能自己访问别人

    Router(config)#access-list 1 permit any         #设置ACL列表允许所有人
    Router(config)#ip nat inside source list 1 interface g0/1 overload(允许所有人)       
    				#NAT转换为接口g0/1的IP地址
    

    五、STP

    Switch(config)#no  spanning-tree vlan 1         #关闭STP协议
    Switch(config)#spanning-tree vlan 1 priority 28672      #修改优先级
    Switch#show spanning-tree           		#查看所有VLAN的生成树信息
    Switch#show spanning-tree  vlan  1          #查看VLAN1的生成树信息
    Switch(config)#spanning-tree vlan 1 root primary            #设置为主根
    

    PVST+实现网络的负载分担

    创建VLAN
    全网配置Trunk
    

    六、HSRP

    MS1(config)#in vlan 1
    MS1(config-if)#standby 1 ip 192.168.1.254(虚拟IP地址)   (先配活跃)
    MS1#show standby brief         				 #查看信息
    MS2(config-if)#standby 1 priority 150        #修改优先级为150
    MS1(config-if)#standby 1 preempt            #抢占为活跃设备
    优先级越大越优先
    

    七、命令简写

    sw  a  v  3  		#将接口加入到VLAN3
    en p 1   		    #修改密码为1
    in f0/1     	    #进入接口
    sw  m  t    		#配置Trunk类型
    ip  add     	    #配置IP
    no  sh       		#打开端口
    
    展开全文
  • CISCO思科)路由器交换机配置视频教程,共分上下两个压缩包,共7GB
  • Switch>...Switch#configureterminal进入配置模式 Switch(config)#hostname主机名 Switch(config)#enable password明文密码 Switch(config)#enable secret密文密码 Switch(config)#ex...
  • cisco路由交换命令

    2009-08-18 18:02:16
    好用,真的.压缩包里有路由交换配置,觉得好用就来顶啊
  • 路由交换-基础配置命令 实验目的 学习基于思科模拟器的各类网络设备的基础配置命令,熟悉命令行配置环境。
  • PVST 的配置 EthernetChannel(以太网通道) 配置VLAN的IP地址 等常用命令
  • Cisco路由配置命令

    千次阅读 2011-09-23 22:08:57
    Cisco路由配置命令 交换机命令总结 交换机口令设置: switch>enable 进入特权模式  switch#config terminal 进入全局配置模式 switch(config)#hostname 设置交换机的主
  • Cisco中字母大小没区别,但是正则表达式需要注意大小写 路由表查询机制:1.最长匹配原则、2.递归查询 路由器开始键入no/yes,no是进入用户模式,yes是进入初始化配置 1、模式 设备的三层模式 a.用户模式(>) ...
  • 网络学习----无非就是交换路由命令是工具。 CCNA视频下载,可以看看这个:http://download.huanwen.net/download.asp    交换部分  我们记命令,不必记全,可以使用“tab”键补全。  实验一:主机名,...
  • Technorati 标签:CCNA,思科,路由器,交换机 为更好学习CCNA,列出详细实验表。 任务一:交换机基本配置 1.配置主机名 (config)#hostnamehostname 2.查看交换机的配置 #show running-config 3.使能口令 (config)#...
  • 1. switch配置命令(1)模式转换命令用户模式----特权模式,使用命令"enable"特权模式----全局配置模式,使用命令"config t"全局配置模式----接口模式,使用命令"interface+接口类型+接口号"全局配置模式----线控模式,...
  • 路由交换系统测试命令 通用测试命令:ping X.X.X.X :标准ping命令,用于测试设备间的物理连通性ping :扩展ping命令,也用于设备间的物理连通性,扩展ping命令还支持灵活定义ping命令的参数,比如ping 的包的数量...
  • 任务一:交换机基本配置 1.配置主机名 (config)#hostnamehostname 2.查看交换机的配置 #show running-config 3.使能口令 (config)#enable passworedpassword 4.加密保存的使能口令 (config)#enable secretpassword 5...
  • 路由器交换机基本配置、iso管理 Enable模式密码设置 (config)#enable password XXXXXXXXX (设置enable密码,配置文件中以明文形式显示) (config)#enable secret XXXXXXXXXXXXXX (设置enable密码,配置文件中,以MD...
  • 每次配置路由交换的时候都会配置的一些通用的命令,也是根据个人需求进行的,具体如下: Router(config)#no ip do lookup 防止DNS解析的命令 Router(config)#line console 0 进入console口 Router(config)#no exec-...
  • 所有基本CISCO配置命令。很适合初学者和从事网络工程的人员。希望能给大家带来好处!谢谢~!
  • 在《三层交换技术原理》中我们提到三层交换(也称多层交换技术,或IP交换技术)是相对于传统交换概念而提出的。众所周知,传统的交换技术是在OSI网络标准模型中的第二层――数据链路层进行操作的,而三层交换技术在...
  • 网工路由交换相关配置 思科2950交换机相关配置 基本操作 2950(config)#int vlan1 2950(config-if)#ip address 192.168.1.100 255.255.255.0 (VLAN1里面设置IP地址) 2950(config)#ip default-gateway 192.168.1.1...
  • 之前的文章就使用了华为...(2)在交换机Switch0上配置命令如下: Switch#en Switch#config t Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch(config)#int fa0/1 Switch(config
  • 在实际工作中我们的路由和交换机总是放置于机房为了方便我们的工作我们需要对路由和交换机进行配置让我们可以在办公室或者家中对路由器和交换机完成配置。这是一个简单的网络拓扑图,计算机连接路由跨网段对交换机...
  • Cisco路由由交交换换设设备备之之IOS故故障障排排除除 IOS是路由器交换机设备的核心IOS全称internet operate system中文是网络操作系统的意思他就好比计算机的操 作系统windows 样虽然是软件但出现问题就无法进行...
  • 静态路由需要管理员手动配置,思想是,想让路由知道某个网络,手动输入路径,特点是,简单,高效,可靠,优先级最高。 静态路由配置方法有两种: 1.R1(config):ip route (目标网段IP,目标子网掩码,送出接口) 2....
  • 工作模式: >:用户模式 #:特权模式 (config)#:全局模式 (config-if)#:接口模式 ...v用户模式下大多都是对设备IOS系统进行操作配置的一些命令。...v接口模式下大多都是对于接口的配置命令。 CS...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,747
精华内容 3,898
关键字:

思科路由交换配置命令