精华内容
下载资源
问答
  • 拓扑图 网络组建
    2021-06-22 22:13:36

    绘制网络拓扑图1

    第二讲:绘制网络拓扑图

    嗓宠掘权徐饱位恰趋虫牟瓤素甩邢恨功溉蒲春畏咱个苛酞凡篮问犁抽吩壕绘制网络拓扑图1绘制网络拓扑图1

    课程引入

    拍秀帛哩项只箕撮防戒户果魂绊亮扯渍诧翅恢诗控晃渡删起赣拔叼阑囤仕绘制网络拓扑图1绘制网络拓扑图1

    本次课的任务

    一:讨论网络的商业和工业价值

    二:用Visio软件绘制网络拓扑结构图

    三:了解网络方案设计

    蜗氯浚稀龋宫绊丁窟处谨格刷洲政凑缘褂见节湘柜巢偷汽助畦硷悔吐抄糙绘制网络拓扑图1绘制网络拓扑图1

    任务一

    讨论网络的商业和工业价值(如网络外包、工业现场的网络控制等)

    顽坚占恃查膊宿薯戎帆畏笆曝烁湖捆蛮以诽牧搔仙蔑贤焚首烙讼婉蠢侨功绘制网络拓扑图1绘制网络拓扑图1

    网络的重要性

    人类社会已进入信息时代

    世界各国积极建设信息高速公路

    计算机网络是信息高速公路的基础

    Internet最终改变我们的生活方式, 21世纪人类进入以网络为核心的信息时代

    撤枣乃慑掐孙溅呀结傈扰叶霸稻频线速蔑布墒晚新芋芳直促宇笺踞望季读绘制网络拓扑图1绘制网络拓扑图1

    任务二

    用Visio软件绘制网络拓扑结构图

    福靛啤亥昌闺茄浆抉酒幢向魂旅培瞪侍雕吞铁乍捧切叼桔人骤工购岭朋门绘制网络拓扑图1绘制网络拓扑图1

    相关支撑知识

    网络拓扑结构

    Visio软件的使用

    鸯但肯眶登陇婶弘邵兵册迈躬忍兵昆瓢搽浚吗逛颊淮缆拜跌抑集蕉雍喻掖绘制网络拓扑图1绘制网络拓扑图1

    计算机网络的组成

    计算机网络从资源构成分为网络软件和网络硬件

    网络软件

    网络协议(软件)

    一系列规则和约定的规范性描述,它控制了网络中的设备之间如何进行信息交换。

    网络操作系统

    网络中软硬件设备的控制程序

    网络管理及网络应用软件

    对网络资源进行管理维护的软件

    叭峦盐累挡肆旷龋谈屡贤贰仰廉党志耀企网乓挂线饮鲜神栖绿酪顾洒焙铭绘制网络拓扑图1绘制网络拓扑图1

    计算机网络的组成

    网络硬件(三部分)

    端节点:计算机等

    转接节点:交换机、集中器、路由器、通信处理机等

    通信链路:电缆、光缆、无线(卫星、微波、红外)

    概煤藉婚网豆艘刁耽募衫哑耍苫假名鳖廖眯初齐砸集砚肩息尾剪浓强楚卢绘制网络拓扑图1绘制网络拓扑图1

    计算机网络的组成

    计算机网络从逻辑功能上分为通信子网和资源子网

    计算机网络的基本任务可分为数据处理和数据通信。因此,对应的结构也可以分为两部分,为通信子网和资源子网。

    脸蛤齿扣在田辆秤氟终型格脑掌臻凶缄倡整揉奖朝挛碌抓惮宾见桌居獭睡绘制网络拓扑图1绘制网络拓扑图1

    资源子网的概念

    资源子网由主计算机系统、终端、终端控制器、联网外设、各种软件资源与信息资源组成。资源子网负责处理全网的数据处理业务,向网络用户提供各种网络资源与网络服务。

    袭妮过嵌交杠喀浚冲吏赦徘卢醋千至铭纠诸住卖乡酸区掷曼庆抹仟丢尧苫绘制网络拓扑图1绘制网络拓扑图1

    资源子网的概念

    1. 主机系统

    主计算机系统简称主机(Host),它可以是大型机、中型机、小型机、工作站或微机。

    2. 终端

    终端是用户访问网络的界面。终端可以是简单的输入、输出终端,也可以是带有微处理的智能终端。智能终端除具有输入、输出信息的功能外,本身还具有存储与处理信息的能力。终端可以通过主机连入网内,也可以通过终端控制器、报文分组组装与拆装装置可通过处理机连入网内。

    简瞪甩补推羚噪屉挪裙叁吾粱万属凳合令暖滚怀钩捐鹅磕凄滥司此着疾蕊绘制网络拓扑图1绘制网络拓扑图1

    通信子网的概念

    通信子网由通信控制处理机、通信线路与其他通信设备组成,完成网络数据传输、转发等通信处理任务

    1. 通信控制处理机

    通信控制处理机在网络拓扑结构中被称为网络节点。它一方面作为与资源子网的主机、终端连接的接口,将主机和终端连入网内;另一方面它又作为通信子网中的分组存储转发节点,完成分组的接收、校验、存储和转发等功能,实现将原主机报文准确发送到目的主机的作用。

    2. 通信线路

    通信线路为通信控制处理机与通信控制处理机、通信控制处理机与主机之间提供通信信道。计算机网络采用多种通信线路,例如,电话线、双绞线、同轴电缆、光缆、光纤、无线通信信道、微波与卫星通信信道等。

    湖萌觉耗这智握坚带煤纪斌鞋泰娥签乔漳虹挛挡豌篮圃到慌塘年众嵌钒釜绘制网络拓扑图1绘制网络拓扑图1

    计算机网络的拓扑结构

    1. 计算机网络拓扑定义

    计算机网络设计的第一步就是要解决在给定计算机的位置,并保证一定的网络响应时间,吞吐量和可靠性的条件下,通过选择适当的线路、线路容量与连接方式,使整个网络结构合理与成本低廉。

    计算机网络拓扑是通过网中节点或节点与通信线路之间的几何关系表示网络结构,反映同网络中各实体的结构关系。

    大辛声烂摸淡涂迷漂镇拼扛盈垒刀见踪纫恋粘喻凿概避单剩噶捧弥峦年父绘制网络拓扑图1绘制网络拓扑图1

    计算机网络的拓扑结构

    2. 计算机网络拓扑的分类

    计算机网络中常见的拓扑结构主要有:星形、总线形、环形、

    更多相关内容
  • 中小企业的网络组建-局域网的组建
  • 网络中小企业网络组建局域网组建网络组建与规划网络结构拓扑图1.doc.pdf
  • 内置45台PC机 二层交换机15台 三层交换机10台 路由器5台 已完成接线功能 无配置,适用思科交换机初学者学习VLAN 划分 SMMP协议配置,RIP配置,OSPF配置等等
  • 网络拓扑图

    2018-04-15 10:54:19
    网络拓扑 网络拓扑网络形状,或者是网络在物理上的连通性。网络拓扑结构是指用传输媒体互连各种设备的物理布局
  • 大三计算机网络的课程设计项目 报告中相关命令代码写的很清楚了,拓扑图用思科模拟器直接打开就行,拓扑图都不用自己搭建
  • 计算机网络课程设计_中小企业的网络组建_局域网的组建_网络的组建与规划_网络结构拓扑图分享.pdf
  • 计算机网络课程设计_中小企业的网络组建_局域网的组建_网络的组建与规划_网络结构拓扑图实用.pdf
  • 计算机网络课程设计_中小企业的网络组建_局域网的组建_网络的组建与规划_网络结构拓扑图.rar
  • 计算机网络课程设计_中小企业的网络组建_局域网的组建_网络的组建与规划_网络结构拓扑图.pdf
  • 酒店接入网络拓扑图

    2013-05-13 23:08:25
    接入,希望对有用的人 有帮助 学习 学习
  • 教育资料
  • 练习华为大型公司网络构建拓扑图

    千次阅读 2022-03-21 15:18:21
    此次练习的网络拓扑图,用于自己做笔记。 配置思路: 从下到上 先配置PC1-PC4、服务器的IP 地址、子网掩码、网关。 创建所需vlan(所有交换机配置相同) 配置链路状态(trunk、access)、加入所属vlan 配置各...

    转载于:https://blog.51cto.com/13555524/2065007

    此次练习的网络拓扑图,用于自己做笔记。

    配置思路:

    1. 从下到上
    2. 先配置PC1-PC4、服务器的IP 地址、子网掩码、网关。
    3. 创建所需vlan(所有交换机配置相同)
    4. 配置链路状态(trunk、access)、加入所属vlan
    5. 配置各端口IP地址
    6. 配置VRRP(这里是三个网关相互冗余)
    7. 配置动态路由(ospf)把R1-R4 、SW7设置为骨干区域

    这是我大体思路。接下来是配置

    1*首先配置各个PC和服务器的IP地址等。

    PC1地址:192.168.10.1/24 网关:192.168.10.254

    PC2地址:192.168.20.1/24 网关:192.168.20.254

    PC3地址:192.168.10.2/24 网关:192.168.10.254

    PC4地址:192.168.20.2/24 网关:192.168.20.254

    服务器地址:192.168.70.1/24 网关:192.168.70.254

    如图:

    其它同理

    2*在SW1-SW7上全部创建vlan10、vlan20

    [SW1]vlan batch 10 20

    其它同理

    3*配置链路状态(trunk、access)、加入所属vlan

    通常交换机与交换机之间用trunk,交换机与非交换机之间用access

    先配置SW1:

    [SW1]port-group group-member e0/0/13 e0/0/11
    [SW1-port-group] port link-type trunk
    [SW1-port-group] port trunk allow-pass vlan all

    [SW1]int e0/0/1 
    [SW1-Ethernet0/0/1]port link-type access 
    [SW1-Ethernet0/0/1]port default vlan 10

     SW2:

    [SW2]port-group group-member e0/0/11 e0/0/14
    [SW2-port-group] port link-type trunk
    [SW2-port-group] port trunk allow-pass vlan all

    [SW2]int e0/0/1 
    [SW2-Ethernet0/0/1]port link-type access 
    [SW2-Ethernet0/0/1]port default vlan 20

    SW3:

    [SW3]port-group group-member e0/0/13 e0/0/11
    [SW3-port-group] port link-type trunk
    [SW3-port-group] port trunk allow-pass vlan all

    [SW3]int e0/0/1 
    [SW3-Ethernet0/0/1]port link-type access 
    [SW3-Ethernet0/0/1]port default vlan 10

    SW4:

    [SW4]port-group group-member e0/0/11 e0/0/14
    [SW4-port-group] port link-type trunk
    [SW4-port-group] port trunk allow-pass vlan all

    [SW4]int e0/0/1 
    [SW4-Ethernet0/0/1]port link-type access 
    [SW4-Ethernet0/0/1]port default vlan 20

    SW5:

    [SW5]port-group group-member g0/0/12 to g0/0/14   
    [SW5-port-group]port link-type trunk 
    [SW5-port-group]port trunk allow-pass vlan all

     

     

    [SW5]port-group group-member g0/0/1 to g0/0/3
    [SW5-port-group]port link-type access
    [SW5-port-group]port default vlan 10

     SW6:

    [SW6]port-group group-member g0/0/12 to g0/0/14   
    [SW6-port-group]port link-type trunk 
    [SW6-port-group]port trunk allow-pass vlan all

    [SW6]port-group group-member g0/0/1 to g0/0/3
    [SW6-port-group]port link-type access
    [SW6-port-group]port default vlan 20

    SW1-SW7创建vlan30 40 50 60 70:

    [SW1]vlan batch 30 40 50 60 70(其它同理)

    SW7:

    [SW7]int e0/0/1
    [SW7-Ethernet0/0/1]port link-type access
    [SW7-Ethernet0/0/1]port default vlan 30

    [SW7]int e0/0/2
    [SW7-Ethernet0/0/2]port link-type access
    [SW7-Ethernet0/0/2]port default vlan 40

    [SW7]int e0/0/3
    [SW7-Ethernet0/0/3]port link-type access
    [SW7-Ethernet0/0/3]port default vlan 50

    [SW7]int e0/0/4
    [SW7-Ethernet0/0/4]port link-type access
    [SW7-Ethernet0/0/4]port default vlan 60

    4*配置各端口IP地址

    R1:

    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.10.253 24

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.20.252 24

    [R1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip address 192.168.30.1 24

    R2:

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.10.251 24

    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 192.168.20.251 24

    [R2]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip address 192.168.40.1 24

    R3:

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip address 192.168.10.252 24

    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip address 192.168.20.253 24

    [R3]int g0/0/2
    [R3-GigabitEthernet0/0/2]ip address 192.168.50.1 24

    SW7:

    [SW7]int Vlanif 30
    [SW7-Vlanif30]ip address 192.168.30.2 24

    [SW7]int Vlanif 40
    [SW7-Vlanif40]ip address 192.168.40.2 24

    [SW7]int Vlanif 50
    [SW7-Vlanif50]ip address 192.168.50.2 24

    [SW7]int Vlanif 60
    [SW7-Vlanif60]ip address 192.168.60.2 24

    R4:

    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip address 192.168.70.254 24

    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip address 192.168.60.1 24

    5*配置VRRP(虚拟网关)

    R1:

    [R1]interface GigabitEthernet0/0/0
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254    //指定虚拟网关为192.168.10.254
    [R1-GigabitEthernet0/0/0]vrrp vrid 1 priority 150  //设置优先级150优先级越大越好

    [R1]interface GigabitEthernet0/0/1
    [R1-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254    //指定虚拟网关为192.168.20.254
    [R1-GigabitEthernet0/0/1]vrrp vrid 2 priority 130  //设置优先级130优先级越大越好

    R2:

    [R2]interface GigabitEthernet0/0/0
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254   
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 priority 110  

    [R2]interface GigabitEthernet0/0/1
    [R2-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254   
    [R2-GigabitEthernet0/0/1]vrrp vrid 2 priority 110  

    R3:

    [R3]interface GigabitEthernet0/0/0
    [R3-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.254   
    [R3-GigabitEthernet0/0/0]vrrp vrid 1 priority 130  

    [R3]interface GigabitEthernet0/0/1
    [R3-GigabitEthernet0/0/1]vrrp vrid 2 virtual-ip 192.168.20.254   
    [R3-GigabitEthernet0/0/1]vrrp vrid 2 priority 150  

    此时查看下Master选举情况

    R1:

    [R1]dis vrrp brief 

     R2:

    [R2]dis vrrp brief 

    R3:

    [R3]dis vrrp brief 

     7*配置动态路由(ospf)把R1-R4 、SW7设置为骨干区域

    R1:

    [R1]ospf 1
    [R1-ospf-1]area 0 
    [R1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R1-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R1-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255 

    R2:

    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R2-ospf-1-area-0.0.0.0]network 192.168.40.0 0.0.0.255 

    R3:

    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255 
    [R3-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 
    [R3-ospf-1-area-0.0.0.0]network 192.168.50.0 0.0.0.255

    R4:

    [R4]ospf 1
    [R4-ospf-1]area 0
    [R4-ospf-1-area-0.0.0.0]network 192.168.60.0 0.0.0.255 
    [R4-ospf-1-area-0.0.0.0]network 192.168.70.0 0.0.0.255 

    SW7:

    [SW7]ospf 1  
    [SW7-ospf-1]area 0
    [SW7-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.40.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.50.0 0.0.0.255
    [SW7-ospf-1-area-0.0.0.0]network 192.168.60.0 0.0.0.255

    此时全网互通!

     

     

    展开全文
  • 绘制网络组建拓扑图方法分享

    千次阅读 2018-12-24 09:58:09
    什么是网络组建拓扑图?  网络拓扑图是指用传输媒体互连各种设备的物理布局,即用什么方式把网络中的计算机等设备连接起来。拓扑图画出网络服务器、工作站的网络配置和相互间的连接。网络的拓扑结构有很多种,主要...

      什么是网络组建拓扑图?

      网络拓扑图是指用传输媒体互连各种设备的物理布局,即用什么方式把网络中的计算机等设备连接起来。拓扑图画出网络服务器、工作站的网络配置和相互间的连接。网络的拓扑结构有很多种,主要有星型结构、环型结构、总线结构、分布式结构、树型结构、网状结构、蜂窝状结构等。

      用网络拓扑图的有点和缺点

      网络拓扑图往往是由网络拓扑图软件绘制,网络拓扑图软件可以让使用者方便地对网络拓扑图进行添加,修改、保存、复制等操作。这些事情如果是由手工绘制来操作的话,会麻烦许多。但对于网络拓扑图软件来说,都不是问题。另外对于有条件上网的使用者来说,以软件形式存在的网络拓扑图无疑能够更方便地与他人共享。

      绘制网络拓扑图用什么软件?

      对于初学者来说,市面上众多的思维导图工具,在选择工具的时候很难选择,如果你想选择免费的在线思维导图工具,这里,小编认为迅捷画图是一款很不错的软件,如果你需要素材多,模板多的,这款很适合你,该软件操作简单,只需简单拖动、摆放和点击,就可轻松制作精美的流程图和思维导图,方便好用,同时可以支持多种格式的保存导出等。

      如何绘制一个网络拓扑图?

      1.进入迅捷画图官网,点击进入迅捷画图,这时将跳转到另一个页面,在这里我们需要绘制的流程图,点击新建文件夹-流程图即可:

      2.在页面的四周我们可以看到有很多的工具栏,这些都是可以使用的,需要给流程图添加新的图形可以在左边基础图形里面拖动图形至右边空白处即可:

      3.新的图形添加之后,我们做的就是对里面的内容进行修改,双击文本框即可;

      4.插入栏目中可以将链接、图片等进行添加,丰富流程图的内容:

      5.这时一个完整的流程图就制作完成了,点击右上角导出,选择导出的格式即可:

      以上就是绘制网络组建拓扑图,希望可以帮助到大家。

    展开全文
  • 2.网络划分多个vlan 3交换机之间配置trunk,两台核心交换机链路捆绑 4.在两台核心交换机上配置MSTP-VRRP(多生成树协议) 5.部分主体交换机配置了OSPF协议 6.所有用户从DHCP服务器动态获取ip地址。 7.服务器的路由器...
  • 网络拓扑结构 网络拓扑结构是抛开网络物理连接来讨论网络系统的连接形式,网络中各站点相互连接的方法和形式称为网络拓扑
  • 计算机网络的定义、网络拓扑结构、计算机网络的参数、协议和标准

    1、计算机网络的定义

    在这里插入图片描述

    计算机网络(连接分散计算机设备以实现信息传递的系统)。计算机网络是指将地理位置不同的具有独立功能的多台计算机及其外部设备,通过通信线路连接起来,在网络操作系统,网络管理软件及网络通信协议的管理和协调下,实现资源共享和信息传递的计算机系统。

    1.1 计算机网络的基本功能

    • 资源共享
    • 分布式处理和负载均衡
    • 实现数据信息的快速传递
    • 提高可靠性
    • 集中管理以及综合信息服务

    1.2 计算机网络的演进

    在这里插入图片描述

    Internet的最早起源于美国国防部高级研究计划署DARPA(Defence Advanced Research Projects Agency)的前身ARPAnet,该网于1969年投入使用。由此,ARPAnet成为现代计算机网络诞生的标志。

    主机互联
    二十世纪60年代初期,基于主机之间的低速串行连接的联机系统是计算机的网络最初雏形。这种网络早期借助电话线路访问计算机,由于计算机发送接收的为电话数字信号,电话专线是模拟信号,这就要求在终端和主机之间加入光猫(调制解调器),进行数/模间的转换

    局域网

    二十世纪70年代,随着计算机体积价格的下降,出现了以个人计算机为主的商业计算模式。商业计算的复杂性要求大量终端设备的资源共享和协同操作,导致对本地大量计算机设备进行网络化连接的需求,由此局域网就此而来

    互联网
    二十世纪70年代后期,广域网技术逐渐发展起来,以便将分布在不同地域的局域网互联起来

    因特网
    二十世纪80年代到90年代是网络互联发展时期,由于网络规模不断扩大,将全球无数的公司、校园、运营商和个人用户接入intent

    1.3 计算机网络的类型

    • 局域网(LAN,Local Area Network)。由⽤户⾃⾏建设,使⽤私有地址组建的⽹络
      局域网基本原理:https://blog.csdn.net/Jivove/article/details/123420447
      虚拟局域网VLAN:https://blog.csdn.net/Jivove/article/details/123422887

    • 城域网(MAN,Metropolitan Area Network)。由运营商或⼤规模企业建设,连接城市范围的⽹络

    • 广域网(WAN,Wide Area Network),⼜称⻣⼲⽹、核⼼⽹、传输⽹。由运营商建设,连接全国各个城域⽹的⽹络
      广域网基本原理:https://blog.csdn.net/Jivove/article/details/123421134

    1.4 计算机网络的参考模型

    OSI和TCP/IP网络参考模型:https://blog.csdn.net/Jivove/article/details/123419989

    2、网络拓扑结构

    计算机网络拓扑(Computer Network Topology)是指由计算机组成的网络之间设备的分布情况以及连接状态,把它两画在图上就成了拓扑图,一般在图上要标明设备所处的位置,设备的名称类型,以及设备间的连接介质类型,它分为物理拓扑和逻辑拓扑两种。即是指网上计算机或设备与传输媒介形成的结点与线的物理构成模式。网络的结点有两类:一类是转换和交换信息的转接结点,包括结点交换机、集线器和终端控制器等;另一类是访问结点,包括计算机主机和终端等。线则代表各种传输媒介,包括有形的和无形的。

    2.1 网络拓扑结构的组成

    • 结点:又称为网络单元,它是网络系统中的各种数据处理设备、数据通信控制设备和数据终端设备。常见的结点有服务器、工作站、集线路和交换机等设备。
      交换机端口安全技术:https://blog.csdn.net/Jivove/article/details/123423665

    • 链路:两个结点间的连线,可分为物理链路和逻辑链路两种,前者指实际存在发通信线路,后者指在逻辑上起作用的网络通路。

    • 通路:是指从发出信息的结点到接受信息的结点之间的一串结点和链路,即一系列穿越通信网络而建立起的结点到结点的链。

    2.2 网络拓扑结构的选择性

    拓扑结构的选择往往与传输媒体的选择及媒体访问控制方法的确定紧密相关。在选择网络拓扑结构时,应该考虑的主要因素有下列几点:

    • 可靠性。尽可能提高可靠性,以保证所有数据流能准确接收;还要考虑系统的可维护性,使故障检测和故障隔离较为方便。
    • 费用。建网时需考虑适合特定应用的信道费用和安装费用。
    • 灵活性。需要考虑系统在今后扩展或改动时,能容易地重新配置网络拓扑结构,能方便地处理原有站点的删除和新站点的加入。
    • 响应时间和吞吐量。要为用户提供尽可能短的响应时间和最大的吞吐量。

    2.3 网络拓扑结构的基本类型

    2.3.1 星型结构

    星型拓扑是由中央节点和通过点到点通信链路接到中央节点的各个站点组成。中央节点执行集中式通信控制策略,因此中央节点相当复杂,而各个站点的通信处理负担都很小。星型网采用的交换方式有电路交换和报文交换,尤以电路交换更为普遍。这种结构一旦建立了通道连接,就可以无延迟地在连通的两个站点之间传送数据。流行的专用交换机PBX (Private Branch exchange)就是星型拓扑结构的典型实例
    在这里插入图片描述

    星型拓扑结构的优点

    • 结构简单,连接方便,管理和维护都相对容易,而且扩展性强。
    • 网络延迟时间较小,传输误差低。
    • 在同一网段内支持多种传输介质,除非中央节点故障,否则网络不会轻易瘫痪。
    • 每个节点直接连到中央节点,故障容易检测和隔离,可以很方便地排除有故障的节点。 因此,星型网络拓扑结构是应用最广泛的一种网络拓扑结构。

    星型拓扑结构的缺点

    • 安装和维护的费用较高
    • 共享资源的能力较差
    • 一条通信线路只被该线路上的中央节点和边缘节点使用,通信线路利用率不高
    • 对中央节点要求相当高,一旦中央节点出现故障,则整个网络将瘫痪。 星型拓扑结构广泛应用于网络的智能集中于中央节点的场合。

    从趋势看,计算机的发展已从集中的主机系统发展到大量功能很强的微型机和工作站,在这种形势下,传统的星型拓扑的使用会有所减少

    2.3.2 总线型结构

    树型拓扑可以认为是多级星型结构组成的,只不过这种多级星型结构自上而下呈三角形分布的,就像一颗树一样,最顶端的枝叶少些,中间的多些,而最下面的枝叶最多。树的最下端相当于网络中的边缘层,树的中间部分相当于网络中的汇聚层,而树的顶端则相当于网络中的核心层。它采用分级的集中控制方式,其传输介质可有多条分支,但不形成闭合回路,每条通信线路都必须支持双向传输。

    总线拓扑结构的优点

    • 总线结构所需要的电缆数量少,线缆长度短,易于布线和维护。
    • 总线结构简单,又是元源工作,有较高的可靠性。传输速率高,可达1~100Mbps。
    • 易于扩充,增加或减少用户比较方便,结构简单,组网容易,网络扩展方便
      -多个节点共用一条传输信道,信道利用率高。

    总线拓扑结构的缺点

    • 总线的传输距离有限,通信范围受到限制。
    • 故障诊断和隔离较困难。
    • 分布式协议不能保证信息的及时传送,不具有实时功能。站点必须是智能的,要有媒体访问控制功能,从而增加了站点的硬件和软件开销。

    2.3.3 环型结构

    在环型拓扑中各节点通过环路接口连在一条首尾相连的闭合环型通信线路中,环路上任何节点均可以请求发送信息。请求一旦被批准,便可以向环路发送信息。环型网中的数据可以是单向也可是双向传输。由于环线公用,一个节点发出的信息必须穿越环中所有的环路接口,信息流中目的地址与环上某节点地址相符时,信息被该节点的环路接口所接收,而后信息继续流向下一环路接口,一直流回到发送该信息的环路接口节点为止。
    在这里插入图片描述

    环型拓扑结构的优点

    • 电缆长度短。环型拓扑网络所需的电缆长度和总线拓扑网络相似,但比星形拓扑网络要短得多。
    • 增加或减少工作站时,仅需简单的连接操作。
    • 可使用光纤。光纤的传输速率很高,十分适合于环型拓扑的单方向传输。

    环型拓扑结构的缺点

    • 节点的故障会引起全网故障。这是因为环上的数据传输要通过接在环上的每一个节点,一旦环中某一节点发生故障就会引起全网的故障。
    • 故障检测困难。这与总线拓扑相似,因为不是集中控制,故障检测需在网上各个节点进行,因此就不很容易。
    • 环型拓扑结构的媒体访问控制协议都采用令牌传递的方式,在负载很轻时,信道利用率相对来说就比较低。

    2.3.4 树型结构

    树型拓扑可以认为是多级星型结构组成的,只不过这种多级星型结构自上而下呈三角形分布的,就像一颗树一样,最顶端的枝叶少些,中间的多些,而最下面的枝叶最多。树的最下端相当于网络中的边缘层,树的中间部分相当于网络中的汇聚层,而树的顶端则相当于网络中的核心层。它采用分级的集中控制方式,其传输介质可有多条分支,但不形成闭合回路,每条通信线路都必须支持双向传输。
    在这里插入图片描述

    树型拓扑的优点

    • 易于扩展。这种结构可以延伸出很多分支和子分支,这些新节点和新分支都能容易地加入网内。
    • 故障隔离较容易。如果某一分支的节点或线路发生故障,很容易将故障分支与整个系统隔离开来。

    树型拓扑的缺点

    • 各个节点对根的依赖性太大,如果根发生故障,则全网不能正常工作。从这一点来看,树型拓扑结构的可靠性有点类似于星型拓扑结构。

    2.3.5 网状结构

    网型拓扑。又分为全网状和部分网状。这种结构在广域网中得到了广泛的应用,它的优点是不受瓶颈问题和失效问题的影响。由于节点之间有许多条路径相连,可以为数据流的传输选择适当的路由,从而绕过失效的部件或过忙的节点。这种结构虽然比较复杂,成本也比较高,提供上述功能的网络协议也较复杂,但由于它的可靠性高,仍然受到用户的欢迎。 网型拓扑的一个应用是在BGP协议中。为保证IBGP对等体之间的连通性,需要在IBGP对等体之间建立全连接关系,即网状网络。假设在一个AS内部有n台路由器,那么应该建立的IBGP连接数就为n(n-1)/2个。
    在这里插入图片描述

    网型拓扑的优点

    • 节点间路径多,碰撞和阻塞减少。
    • 局部故障不影响整个网络,可靠性高。

    网型拓扑的缺点

    • 网络关系复杂,建网较难,不易扩充。
    • 网络控制机制复杂,必须采用路由算法和流量控制机制。

    3、计算机网络的参数

    3.1衡量网络性能的指标

    网络性能指标,是衡量网络性能的指标,包括带宽、时延。

    带宽

    • 定义:单位时间内能够传输的数据总量
    • 单位:bps
    • 带宽越大,网络质量越好

    时延

    • 定义:数据从一个节点到达另一个节点消耗的时间
    • 单位:ms
    • 延迟越低,网络质量越好

    3.2 数据单位

    1Gb=1024Mb
    1Mb=1024Kb
    1Kb=1024b
    Byte:字节,一个数字或字母占用1字节,一个汉字占用2字节
    bit:比特,1Byte=8bit

    4、协议和标准

    4.1 协议

    4.1.1 协议的定义

    网络协议指的是计算机网络中互相通信的对等实体之间交换信息时所必须遵守的规则的集合。

    4.1.2 网络协议三要素

    • 语义:语义是解释控制信息每个部分的意义。它规定了需要发出何种控制信息,以及完成的动作与做出什么样的响应。
    • 语法:语法是用户数据与控制信息的结构与格式,以及数据出现的顺序。
    • 时序:时序是对事件发生顺序的详细说明。(也可称为“同步”)。

    人们形象地把这三个要素描述为:语义表示要做什么,语法表示要怎么做,时序表示做的顺序。

    4.1.3 网络协议的分类

    物理层

    以太网、调制解调器、电力线通信(PLC)、SONET/SDH、G.709、光导纤维、同轴电缆、双绞线等数据链路层:Wi-Fi(IEEE802.11)、WiMAX(IEEE802.16)、ATM、DTM、令牌环、以太网、FDDI、帧中继、GPRS、EVDO、HSPA、HDLC、PPP、L2TP、PPTP、ISDN、STP、CSMA/CD等

    STP生成树协议:https://blog.csdn.net/Jivove/article/details/123423136

    网络层协议

    IP(IPv4、IPv6)、ICMP、ICMPv6、IGMP、IS-IS、IPsec、ARP、RARP、RIP等

    IP基本原理:https://blog.csdn.net/Jivove/article/details/123421229

    传输层协议

    TCP、UDP、TLS、DCCP、SCTP、RSVP、OSPF等

    TCP/UDP原理:https://blog.csdn.net/Jivove/article/details/123421423
    应用层协议

    DHCP、DNS、FTP、Gopher、HTTP、IMAP4、IRC、NNTP、XMPP、POP3、SIP、SMTP、SNMP、SSH、TELNET、RPC、RTCP、RTP、RTSP、SDP、SOAP、GTP、STUN、NTP、SSDP、BGP等

    DNS域名解析:https://blog.csdn.net/Jivove/article/details/123423842

    4.2 标准

    4.2.1 网络标准的定义

    公认的,所有厂商所共同遵守的协议规则

    4.2.2 标准化组织

    制定定义国际公认参考标准的组织团体
    常见国际标准组织

    • ISO:国际标准化组织
    • IOS:思科设备操作系统
    • IEEE:电子电器工程师协会
    展开全文
  • 文章目录搭建拓扑图路由器上接口不够如何添加接口?如何快速配置路由器接口的ip信息?互联网主干部分网络配置DNS服务器的ip配置和DNS解析地址1、为每个路由器接口配置ip地址和子网掩码这时候我们可以ping一下相连的...
  • NETWORK06 - 企业网络拓扑图

    千次阅读 2018-06-01 22:09:23
    为路由器与三层交换机相连的接口配置 ip 配置动态路由协议,使所有内网互通。 在 ms1 中开启 ospf 动态路由,并宣告直连网段 Switch(config)#routerospf 1 Switch(config-router)#network192.168.10.0 0.0.0.255...
  • 大型公司网络构建拓扑图(华为)

    万次阅读 2018-01-25 14:25:47
    今天简单了解一下,大型公司的网络搭建。 对于很多大型公司来讲,网络的稳定性,会直接影响到公司的收益,比如,双十一的阿里巴巴,京东,等等。如果这个时候网络出现问题,对于公司的损失将会是不可估量的。可见...
  • 电子商务网络组建方案.doc
  • ENSP基本配置校园网络
  • 多种较大型拓扑,可以学习借鉴。 网络组建规划、拓扑结构、企业学校网络

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,595
精华内容 3,038
关键字:

拓扑图 网络组建