精华内容
下载资源
问答
  • 大学计算机科学与技术本科的计算机组网实验报告。
  • Intranet组网技术 1、服务器镜像获取与安装 ed2k://|file|cn_win_srv_2003_r2_enterprise_with_sp2_vl_cd1_X13-46432.iso|637917184|284DC0E76945125035B9208B9199E465|/ 激活序列号:DF74D-TWR86-D3F4V-M8D8J-WTT...

    Intranet组网技术

    1、服务器镜像获取与安装

    ed2k://|file|cn_win_srv_2003_r2_enterprise_with_sp2_vl_cd1_X13-46432.iso|637917184|284DC0E76945125035B9208B9199E465|/
    
    激活序列号:DF74D-TWR86-D3F4V-M8D8J-WTT7M
    

    2、服务器镜像安装

    新建虚拟机向导

    图1

    在这里插入图片描述

    图2

    在这里插入图片描述

    图3
    输入序列号,密码,可以勾选自动登录

    在这里插入图片描述

    图4

    在这里插入图片描述

    图5

    在这里插入图片描述

    图6

    在这里插入图片描述

    图7

    在这里插入图片描述

    图8
    输入姓名和单位

    在这里插入图片描述

    图9
    安装完成后有一个storePWD.exe报错,不必理会,右下角完成即可,然后上图中选择是

    在这里插入图片描述

    图10
    虚拟机中使用Ctrl+Alt+Delete,笔记本可能还需要同时按下Fn键,根据自己笔记本来

    在这里插入图片描述

    图11
    到这里windows2003服务器就安装完成了

    3、前期配置与IIS安装

    ①前期配置

    在这里插入图片描述

    图12
    首先需要挂载系统镜像

    在这里插入图片描述

    图13

    在这里插入图片描述

    图14

    在这里插入图片描述

    图15
    到这一步说明系统镜像已经挂载好了,接下来配置服务器

    在这里插入图片描述

    图16

    在这里插入图片描述

    图17

    在这里插入图片描述

    图18

    在这里插入图片描述

    图19

    在这里插入图片描述

    图20

    在这里插入图片描述

    图21

    在这里插入图片描述

    图22

    在这里插入图片描述

    图23

    在这里插入图片描述

    图24
    到这里系统就配置好了基本的域控,DNS,DHCP

    在这里插入图片描述

    图25
    桌面空白处右键,属性,进入桌面选项卡

    在这里插入图片描述

    图26
    把四个桌面图标勾选上,这一步非必须但是可以方便之后的操作

    ②IIS配置

    在这里插入图片描述

    图27
    配置好之后的桌面

    在这里插入图片描述

    图28
    开始/控制面板/添加或删除程序

    在这里插入图片描述

    图29
    添加或删除Windows组件

    在这里插入图片描述

    图30
    双击“应用程序服务器”,勾选图示所选,然后确定

    在这里插入图片描述

    图31
    等待安装完成

    在这里插入图片描述

    图32
    安装完成

    在这里插入图片描述

    图33
    桌面的管理面板多了一项“应用程序服务器”
    IIS,DNS,DHCP全都安装好了,后续还会加入SMTP

    在这里插入图片描述

    图34
    开始/控制面板/管理工具/Internet信息服务(IIS)管理器

    在这里插入图片描述

    图35
    进入到IIS服务器

    在这里插入图片描述

    图36
    有一个默认网站,右键/浏览

    在这里插入图片描述

    图37
    显示图示界面,说明IIS搭建成功
    接下来创建自己的网站

    在这里插入图片描述

    图38
    按照图示操作,网站/新建/网站

    在这里插入图片描述

    图39
    下一步

    在这里插入图片描述

    图40
    输入网站描述,我这里输入的liao

    在这里插入图片描述

    图41
    下拉选择本机IP(其实不选也可),指定端口8090(可自由设置)

    在这里插入图片描述

    图42
    创建网站根目录并选择

    在这里插入图片描述

    图43
    给定网站权限

    在这里插入图片描述

    图44
    打开网站目录

    在这里插入图片描述

    图45
    IIS默认首页文件是default.htm,右键创建文本文件然后修改文件名

    在这里插入图片描述

    图46
    写入图示内容
    <html>
    		<head>
    			<meta HTTP-EQUIV="Content-Type" Content="text/html; charset=gb2312">
    			<title ID=titletext>liao</title>
    		</head>
    		<body bgcolor=white>
    			liao
    		</body>
    </html>
    

    在这里插入图片描述

    图47
    浏览器输入http://192.168.0.1:8090,显示“liao”

    在这里插入图片描述

    图48
    修改default.htm,“liao”修改为”zwsj“

    在这里插入图片描述

    图49
    关闭浏览器并重新访问http://192.168.0.1:8090,出现”zwsj“,IIS配置完成
    这里还是IP访问,因为没有配置DNS

    4、DNS配置

    在这里插入图片描述

    图50
    配置一下网络,作为一台DNS服务器,最基本的素养就是静态IP

    在这里插入图片描述

    图51
    属性

    在这里插入图片描述

    图52
    如果是按照我的操作来,其实默认就可了

    在这里插入图片描述

    图53
    管理此DNS服务器

    在这里插入图片描述

    图54
    新建区域

    在这里插入图片描述

    图55

    在这里插入图片描述

    图56

    在这里插入图片描述

    图57

    在这里插入图片描述

    图58

    在这里插入图片描述

    图59

    在这里插入图片描述

    图60

    在这里插入图片描述

    图61
    新建主机

    在这里插入图片描述

    图62
    IP设为本机IP或者127.0.0.1

    在这里插入图片描述

    图63
    创建成功

    在这里插入图片描述

    图64
    浏览器访问:http://www.jxufe.edu.cn:8090/,看到之前我们创建的网站

    5、FTP搭建

    在这里插入图片描述

    图65
    添加或删除程序

    在这里插入图片描述

    图66
    如图安装FTP服务

    在这里插入图片描述

    图67

    在这里插入图片描述

    图68

    在这里插入图片描述

    图69
    进入FTP站点

    在这里插入图片描述

    图70
    新建FTP站点

    在这里插入图片描述

    图71
    输入名称

    在这里插入图片描述

    图72
    端口改成8021,避免与系统默认FTP冲突

    在这里插入图片描述

    图73

    在这里插入图片描述

    图74
    创建FTP服务目录

    在这里插入图片描述

    图75

    在这里插入图片描述

    图76
    设置读取/写入

    在这里插入图片描述

    图77
    可以登录到我们创建的FTP,拷贝与下载均可
    接下来实现宿主机与FTP的传输

    宿主机与服务器FTP传输的设置

    在这里插入图片描述

    图78
    虚拟机编辑/虚拟网络编辑器

    在这里插入图片描述

    图79
    一次查询到网关地址,记录下来

    在这里插入图片描述

    图80
    当然需要确保虚拟机是NAT模式

    在这里插入图片描述

    图81
    网络连接/属性

    在这里插入图片描述

    图82
    TCP/IP里面设置IP地址,与网关在同一C段,网关地址是图79查询到的网关地址,最后一位设为100即可,DNS首选本地,再加一个114的DNS
    修改之后我们的IIS和DNS服务器也需要做出修改

    在这里插入图片描述

    图83
    服务器命令提示符中输入 ipconfig,确保IP修改成功

    在这里插入图片描述

    图84

    在这里插入图片描述

    图85

    在这里插入图片描述

    图86

    在这里插入图片描述

    图87

    在这里插入图片描述

    图88
    修改为我们修改后的IP,其实127.0.0.1更方便(哈哈哈要被打了)

    在这里插入图片描述

    图89

    在这里插入图片描述

    图90
    宿主机ping一下,可以通

    在这里插入图片描述

    图91
    浏览器输入服务器FTP地址,可以看到我们之前放的文件(服务器时间设置有问题,请忽略)

    在这里插入图片描述

    图92
    工具连接

    在这里插入图片描述

    图93
    互相拷贝文件

    6、SMTP邮件搭建

    在这里插入图片描述

    图94

    在这里插入图片描述

    图95

    在这里插入图片描述

    图96
    跟着图中操作安装好POP3

    在这里插入图片描述

    图97

    在这里插入图片描述

    图98
    安装SMTP

    在这里插入图片描述

    图99
    启动POP3

    在这里插入图片描述

    图100(撒花)
    新建邮件域

    在这里插入图片描述

    图101
    我这里建一个pop3.jxufe.edu.cn(这个随心了)

    在这里插入图片描述

    图102
    添加两个邮箱

    在这里插入图片描述

    图104

    在这里插入图片描述

    图105
    密码太简单了会有这个,要求数字+特殊符号+大写字母+小写字母,六位及以上,例如1q2w#E$R

    在这里插入图片描述

    图106
    添加user1,user2同理

    在这里插入图片描述

    图107

    在这里插入图片描述

    图108
    应用程序服务器里面看到有一个默认的SMTP服务器了,右键属性

    在这里插入图片描述

    图109

    在这里插入图片描述

    图110
    设置IP地址为本机IP

    在这里插入图片描述

    图111
    还需要设置中继,不然不能收到邮件

    在这里插入图片描述

    图112
    还是设置为自己的IP

    在这里插入图片描述

    图113
    添加允许访问

    在这里插入图片描述

    图114
    确定

    在这里插入图片描述

    图115
    打开自带的Outlook Express

    在这里插入图片描述

    图116
    工具/账户

    在这里插入图片描述

    图117
    添加/邮件

    在这里插入图片描述

    图118
    名字就user1吧

    在这里插入图片描述

    图119
    输入我们之前设置的user1@pop3.jxufe.edu.cn

    在这里插入图片描述

    图120
    收发邮件都是本机IP,因为两个账户都在本机上

    在这里插入图片描述

    图121
    账户名切记填写邮箱:user1@pop3.jxufe.edu.cn !!!!

    在这里插入图片描述

    图122
    同理加入user2

    在这里插入图片描述

    图123
    可以看到两个192的账户,即一个是user1,一个是user2

    在这里插入图片描述

    图124
    此时默认登录了user1

    在这里插入图片描述

    图125
    来写一个邮件,雷布斯同学经典

    在这里插入图片描述

    图126
    发送

    在这里插入图片描述

    图127
    账户这里切换默认账户到user2

    在这里插入图片描述

    图128

    在这里插入图片描述

    图129

    在这里插入图片描述

    图130
    切换到发邮件

    在这里插入图片描述

    图131
    切换到发邮件

    在这里插入图片描述

    图132

    在这里插入图片描述

    图133
    切换回user1

    在这里插入图片描述

    图134
    看到未读邮件

    在这里插入图片描述

    图135
    收到了哈哈哈
    完结撒花!!!
    展开全文
  • 组网技术综合实验报告 组网技术综合实验报告
  • 局域网技术组网工程实验教程
  • 吉林大学局域网技术组网工程实验试题参考.docx
  • 组网技术实训实验

    2016-04-14 11:39:20
    网页设计与制作教程课件,适用于初学者
  • 版权声明:本文为博主原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接和本声明。 本文链接:https://blog.csdn.net/weixin_43876357/article/details/108660877

    版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

    本文链接:https://blog.csdn.net/weixin_43876357/article/details/108660877

     

    1. VLAN含义?
    把地理位置不在一起的设备逻辑上划分到一起。

    2. 划分VLAN优点?
    管理方便;安全。

    3. 怎么创建VLAN?
    交换机进入到conf t模式后,直接在命令行输入vlan 2.....就可以创建了

    4. 怎么把创建的VLAN改名字?
    输入过vlan 2之后,在后面接着输入name teaher,就可以把vlan2的名字改成teacher

    5. 通过do show vlan命令可以看到当前的vlan配置(do代表强制执行)

    6. 如果将指定端口加入VLAN?
    Switch(config)#int f0/2
    Switch(config-if)#switchport mode access
    Swicth(config-if)#switchport access vlan 2
    (把0/2接口加入到vlan 2里面)

    这里要注意只有在一个局域网上才可以ping通。

    7. 为什么跨交换机出现VLAN1之间能ping通,其他VLAN之间ping不通?
    默认只能有一个局域网ping通,所以就算两个终端在同一vlan(比如vlan2)也是ping不通的。

    8. 怎么解决上面的问题?
    Switch(config)#int f0/2
    Switch(config-if)#switchport mode trunk
    (设置中继链路trunk)

    9. 中继链路设置完后重要的查看命令:
    Switch#show interfaces trunk

    10. 如何限制某些VLAN不可以通过trunk链路?
    Switch(config-if)#switchport trunk allowed vlan 1,2

    11. 本征VLAN的含义?
    不打标记的VLAN,如果交换机的本征VLAN是vlan 1,那么vlan1上的终端在ping的过程中发送的包是不被标记的,同理当另一个交换机收到不被标记的包也是自动发送给该交换机的本征VLAN。
    有标记的按照标记走,没有标记就按照本征走。

    12. 一台交换机有3个VLAN,分别是1,2,3.本征VLAN一端设置成1,另外一端为2,请问哪些VLAN可以ping通?哪些不通?分析原因。
    VLAN1之间不通;VLAN2之间不通;VLAN3之间通。VLAN1和VLAN2其中一个可以ping通

    13. 怎么一次性设置多端口加入VLAN?
    用range命令,具体语句为:interface range fastethernet 0/1 – 5

    展开全文
  • 华为定义了4种接口的链路类型:Access、Trunk、Hybrid和QinQ,以适应不同的连接和组网。 ------------------------------- 二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN的划分...
    • 交换机

    1. eNSP 510版本中包含三种类型交换机:S5700,S3700和CE6800
    2. 由于交换机连接的每个网段都是一个独立的冲突域(collision domain),因此可以通过增加网段数,减少每个网段的用户数量,来减少冲突的产生。
    3. 传统的交换机工作在OSI参考模型数据链路层(第二层)的网络设备,它通过MAC地址在接口间转发数据帧。
    4. 交换机的主要功能包括:
      1. 地址学习
        • 交换机维护一个MAC地址表(又称转发表、交换表),收到帧后将发送方的MAC地址(即源MAC地址)和接收接口对应起来添加到MAC地址表中。接收方的响应帧返回到交换机后,将接收方响应帧中的源地址(即接收方的MAC地址)和接收接口对应起来添加到MAC地址表中。最终,通过不断学习,交换机获得了一份完整的MAC地址表
      2. 转发/过滤
        • 如果接收到的帧的目的MAC地址已经保存在其MAC地址表中,则只对MAC地址表中该地址对应的接口转发数据帧。
        • 如果帧中的目的地址为广播地址和组播地址时,交换机将此帧从除了入口外的所有接口转发出去
      3. 消除环路
        • 以太网交换机通过生成树协议避免环路,同时允许存在多条备用路径。
    5. 交换机转发模式
      1. 直通转发
        • 交换机收到帧头(通常只检查14个字节)后立刻获取目的MAC地址进行转发。它极大地减少了延迟、加快了交换速度,缺点是不提供错误检测能力,无法检查所传送的帧是否有误。
      2. 存储转发
        • 交换机收到完整的帧后再读取目的MAC地址进行转发,并进行循环冗余校验,丢弃错误的帧。
        • 支持不同速率接口的交换机必须使用存储转发模式,它通过缓存来保证高速接口和低速接口的正确通信。
        • 缺点是延时较大。
      3. 无碎片转发
        • 交换机读取前64个字节后开始转发。由于冲突一般发生在前64个字节之内,通过读取前64个字节,交换机能过滤掉由冲突产生的帧碎片。无碎片转发不提供数据校验
    6. 交换机在分级网络设计模型中的应用

               

     

                 S3700系列交换机作为接入层设备,S5700交换机作为核心层设备

    • 交换机配置

      1. Console口配置交换机
        • 配置时需要使用以太网交换机随机附送的配置电缆连接交换机Console口和主机的串口。它的最大物理距离(电缆长度)和最大直接传输距离都是15m,也就是它只适用于本地环境的配置。
      2. 通过Telnet配置交换机
        • 在以太网交换机的设计中,Telnet服务器是提供远程管理功能的必备部件。
        • 使用Telnet方式访问交换机的前提条件是首先必须对交换机进行初始化配置,否则用户无法正确登录和访问。初始化配置是为交换机配置正确的网段和IP地址以及Telnet登陆密码。初始化配置需要使用Console口进行。
    1. 用户配置
      1. 从用户使用的登录接口来划分,可将用户分为两类:
        • CON用户, CON用户是指通过console口接入的用户。
        • VTY用户,是指通过Telnet接入的用户。S3700和S5700系列交换机最多只能有16VTY用户,默认为5个。
    2. 解决/消除环路
      1. STP(Spanning Tree Protocol)是生成树协议的英文缩写,该协议的原理是按照树的结构来构造网络拓扑,消除网络中的环路,避免由于环路的存在而造成广播风暴以及MAC地址表不稳定等问题。交换机在规定的间隔内(默认2秒),通过网桥协议数据单元(BPDU)的组播帧与其他交换机交换配置信息 ,完成生成树的构建
      2. STP工作过程:
        • 选举根桥(Root):通过比较网桥优先级选取根网桥。给定广播域内只有一个根网桥。
        • 选举根端口(RP):在非根桥的不同端口之间选举出一个到根桥“最近”的端口。每个非根桥都会有且仅有一个根端口。根桥没有根端口。
        • 选举指定端口(DP):在每一个物理网段(非IP网段,指一个冲突域或者一条线)的不同端口之间选举一个指定端口。根桥的所有端口都是指定端口。
        • 阻塞端口(AP):阻塞非根端口和非指定端口。
    3. STP工作过程中的5种状态
    • Disabled:禁用状态,端口不能转发BPDU报文,不能转发用户流量。
    • Blocking:阻塞状态,端口仅可接收并处理BPDU报文,不能转发用户流量。
    • Listening:监听状态,设备正在确定端口角色,将选举出根桥、根端口和指定端口,过度状态。
    • Learning:学习状态,设备根据收到的用户流量构建MAC地址表,但是不转发用户流量。过度状态。
    • Forwarding:转发状态,端口转发用户流量也转发BPDU报文。只有根端口或指定端口才能进入该状态。

         4. 交换机端口配置

    • interface 命令                  

    功能:进入端口配置视图。

    例如:interface GigabitEthernet 0/0/1,可简写为: int g0/0/1

    • negotiation 命令

    功能:缺省情况下,以太网端口工作在协商模式下。在协商模式下,端口的工作模   式(半双工/全双工)和端口的速率(10/100/1000M), 自动与对端协商确定。

    启动自协商模式:negotiation auto(命令视图:端口视图)

    关闭自协商模式:undo negotiation auto(命令视图:端口视图)

    • duplex 命令

    功能:对以太网端口的双工状态(全双工、半双工)进行设置。

    格式:duplex { full | half }(命令视图:端口视图)

       full:使端口处于全双工状态;

           half:使端口处于半双工状态

           非协商模式下,默认状态为full

    取消:undo duplex(恢复至默认状态full)

    注:缺省情况下,以太网端口的双工状态为自协商模式,若要使用duplex命令进 行设置,必须要先关闭协商模式;

    • speed 命令

    功能:用于根据需要设置合适的端口速率。注意两端速率应该设为一致。若要使用   speed命令进行设置,必须要先关闭协商模式。

    格式:speed { 10 | 100 | [1000] }(10表示端口速率10Mb/s,其余类推)

    取消:undo speed

    • flow-control命令

    功能:用于启动或关闭以太网端口的流量控制功能

    • shutdown命令

    功能:关闭以太网端口。

    打开端口:undo shutdown

    命令视图:端口视图

    • observe-port 命令

    功能:配置本地观察端口

    格式:observe-port observe-port-index interface interface-type interface-num

                   observe-port-index:S3700和S5700系列,只能是整数1~2;

                   interface-type :可以是Ethernet或者GigabitEthernet(简写e或g)

                   interface_num:采用“槽位号/子卡号/接口序号”的格式。

    示例:[S1] observe-port 1 interface g 0/0/10

    取消:undo observe-port observe-port-index  

    • port-mirroring 命令

    功能:配置镜像端口

    格式:port-mirroring to observe-port observe-port-index {both|inbound|outbound}

           observe-port-index:S3700和S5700系列,只能是整数1~2;

           both:同时监控端口的入和出两个方向报文;

           inbound:仅监控入方向上的报文

           outbound:仅监控出方向上的报文

    取消:

    undo port-mirroring [to observe-port observe-port-index] {both|inbound|outbound}

      5. 端口绑定

    概述:端口绑定是指MAC地址与端口绑定的功能。用户可以通过配置,只允许某些授权的设备通过该端口访问网络,而非授权设备不能通过该端口访问网络。

    原理:

    1. 取消该端口的MAC地址学习功能。

    mac-address learning disable action discard

    1. 将授权设备的MAC地址添加到该端口的静态MAC地址表项中。

    mac-address static Mac_address interface-type interface_num vlan vlan-id

         Mac_address:设备的MAC地址,格式H-H-H

         interface-type :可以是Ethernet或GigabitEthernet(简写e或g)

         interface_num:采用“槽位号/子卡号/接口序号”的格式

         vlan-id:端口所在的vlan-id

    1. 注:静态MAC地址表项的优先级高于动态MAC地址表项,如果通过MAC地址自动学习功能创建的MAC地址表项与原来的静态MAC地址表项相冲突,则该报文会被丢弃。

    ---------------------------------------------------------------------------------------------------------------------------------

    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术,可以把一个LAN划分成多个逻辑的VLAN,每个VLAN是一个广播域,VLAN内的主机间通信就和在一个LAN内一样,而VLAN间则不能直接互通,这样,广播报文就被限制在一个VLAN内。

    VLAN技术主要有以下优势:

    1.限制广播域:广播域被限制在一个VLAN内,节省了带宽,提高了网络处理能力。

    2.增强局域网的安全性:不同VLAN内的报文在传输时是相互隔离的,即一个VLAN内的用户不能和其它VLAN内的用户直接通信。

    3.提高了网络的健壮性:故障被限制在一个VLAN内,本VLAN内的故障不会影响其他VLAN的正常工作。

    4灵活构建虚拟工作组:用VLAN可以划分不同的用户到不同的工作组,同一工作组的用户也不必局限于某一固定的物理范围,网络构建和维护更方便灵活。

    IEEE 802.1Q协议规定,在以太网数据帧的目的MAC地址和源MAC地址字段之后、协议类型字段之前加入4个字节的VLAN标签(又称VLAN Tag,简称Tag),用以标识VLAN信息。

    交换机利用VLAN标签中的VID来识别数据帧所属的VLAN,广播帧只在同一VLAN内转发这就将广播域限制在一个VLAN内。

    在一个VLAN交换网络中,以太网帧主要有以下两种形式:

    有标记帧(Tagged帧),加入了4字节VLAN标签的帧;

    无标记帧(Untagged帧),原始的、未加入4字节VLAN标签的帧。

    根据接口连接对象以及对收发数据帧处理的不同。华为定义了4种接口的链路类型:Access、Trunk、Hybrid和QinQ,以适应不同的连接和组网。

    -------------------------------

    二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN的划分、VLAN内部的二层交换和VLAN间路由的功能。

    一次路由,多次交换

    二层交换机用于小型的局域网络。小型局域网中,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低廉价格为小型网络用户提供了很完善的解决方案。

    三层交换机最重要的功能是加快大型局域网络内部数据的快速转发,加入路由功能也是为这个目的服务的。

    路由器适合用于大型网络间的路由。

    ----------------------------

    静态路由是指由管理员手动配置和维护的路由

    在串行接口上,可以通过指定下一跳地址或出接口来配置静态路由。

    在以太网接口上配置静态路由时,必须要指定下一跳地址。

    静态路由支持到达同一目的地的等值负载分担。

     

    路由备份

    浮动静态路由在网络中主路由失效的情况下,会加入到路由表中。

    在链路正常的情况下,只有主路由会出现在路由表中。

    在主链路出现故障时,浮动静态路由会被激活并加入到路由表中。

     

    缺省路由

    缺省路由是目的地址和掩码都为全0的特殊路由。

    如果报文的目的地址无法匹配路由表中的任何一项,路由器将依照缺省路由来转发报文。

    --------------------------------------------------------

    以太网数据帧的发送和接收

    当主机接收到的数据帧所包含的目的MAC地址是自己时,会把以太网封装剥掉后送往上层协议。

    -----------------

    动态路由协议

    按寻径算法划分

    距离矢量算法(贝尔曼-福特算法)

    RIP协议

    BGP协议

    链路状态算法

    OSPF协议

    IS-IS协议

     

    动态路由协议是做什么的

    自动地维护路由表。计算某个路由器到网络中其它目的地的最佳路径。

     

    如何做到这一点

    路由器将自己已知的路由信息发给其相邻的路由器,收到信息的路由器将此信息和自己当前的路由信息进行比较、整合,然后运行某种算法,从而计算出新的到每个目的地的最佳路径,进而更新其路由表。网络中所有的路由器都这样做,最终每台路由器都会了解到网络中所有的路由信息,并形成完整的路由表。

     

    衡量指标

    正确性

    能够正确找到最优的路由,并且不应该有环路。

    快收敛

    当网络的拓扑结构发生变化之后,全体路由器能够迅速了解该变化,并且重算最佳路由达到稳定。

    低开销

    协议自身的开销(内存、CPU、网络带宽)尽量小。

    安全性

    协议自身不易受攻击,有安全机制。

    普适性

    适应各种拓扑结构和规模的网络。

     

    -------------------------

    距离矢量路由协议

    路由器定期广播自己所掌握的路由信息, 包括所能到达的目的地以及到每个目的地的距离(比如用跳数来衡量).收到报文的路由器将此信息和自己当前路由信息相比较,从中计算出一张新的路由表,并继续发送出去。

     

    RIP

    每个运行RIP的路由器管理一个路由数据库,该路由数据库包含了到网络中所有可达目的网络的路由项,这些路由项包含下列信息:

    目的地址:指主机或网络的地址。

    下一跳地址:指为到达目的地,本路由器要经过的下一个路由器地址。

    接口:指转发报文的接口。

    路由权值:指本路由器到达目的地的跳数,是一个0~15之间的整数。

    路由时间:从路由项最后一次被修改到现在所经过的时间,路由项每次被修改时,路由时间重置为0。

    路由标记:区分路由为内部路由协议的路由还是引入外部路由协议的路由的标记。

     

    防止路由环路

    水平分割:从接口X发出的路由更新中,不能包括那些出口也为X的路由信息;

    触发更新:当路由失效时,不再等待下一个更新周期,而是立即触发,发布毒化路由更新;

    毒性反转:当学到一条失效路由时,对这条路由忽略水平分割规则,并通告毒化路由。

    抑制:当某条路由被认为失效后,路由器会让这条路由保持down状态一段时间,以确保每台路由器都学到这个信息。

     

    路由毒化

    路由毒化:路由毒化是路由广播的一个实例,但是它的度量值是特殊的,被叫做无穷大。路由器认为度量值为无穷大的路由广播代表失效。

    每种距离矢量路由协议都使用一个明确的度量值来表示无穷大。RIP定义的无穷大为16。

    距离矢量路由协议使用毒化路由的方法传播关于路由失效的坏消息。

     

     

    ----------------------------

    链路状态路由协议

    链路状态路由协议是根据路由区域中所有链路的信息来计算到达目的地的最佳路由。

        每个路由器都通过链路状态公告(LSA)将自己的链路信息告诉给它的邻居节点,这样不断地传播后,每台路由器都会了解到网络中所有链路信息,形成链路状态数据库,然后利用这些信息计算出到网络中任意目的地的最佳路径。

    链路状态路由算法,也称为最短路径优先(SPF)算法,利用网络的拓扑结构图来有效地计算节点间的最短路径——网络中的路由器是图中的节点,链路是连接节点的边,每台路由器计算后,生成一个SPF树,具有最优性的同时,也有效的避免了路由环路的问题。

     

    OSPF

    OSPF 是Open Shortest Path First(开放最短路由优先协议)的缩写。它是IETF组织在1998年开发的一个基于链路状态的内部网关协议。目前使用的是版本2(RFC2328)

     

    一台路由器如果要运行OSPF协议,必须存在Router ID。

     

    缺省情况下,OSPF认为以太网是广播类型,PPP、HDLC是点到点类型

     

    建立完全邻接关系

    LSR用于向对方请求所需的LSA

    LSU用于向对方发送其所需要的LSA

    LSACK用于向对方发送收到LSA的确认

     

     

    OSPF报文有5种:

    Hello报文

    发现、维持邻居关系,选举DR、BDR

    DD(Database Description)报文

        用于形成LSDB

    LSR(LSA Request)报文

       请求LSA

    LSU(LSA Update)报文

       收到LSR后,应答LSA

    LSACK(Link State Acknowledgement)报文

       收到LSU后,对LSU确认。

    展开全文
  • 组网技术(三)---实验1.RIP和BFD联动实验2.动态路由OSPF实验3.动态路由IS-IS实验 1.RIP和BFD联动实验 1.1 BFD:双向转发检测,可以提供毫秒级的检测,可以实现链路的快速检测,BFD通过与上层路由协议联动。当主链路...

    1.RIP和BFD联动实验

    1.1 BFD:双向转发检测,可以提供毫秒级的检测,可以实现链路的快速检测,BFD通过与上层路由协议联动。当主链路发生故障时,业务流量会快速切换到另一条路径进行传输。
    在这里插入图片描述

    第一步:配置各接口IP:R1、R2、R3参考如下。

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R1
    [R1]
    Jan  7 2021 17:28:43-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 1, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1]interface g 0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.1.2 24
    [R1-GigabitEthernet0/0/1]
    Jan  7 2021 17:29:45-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    [R1-GigabitEthernet0/0/1]
    Jan  7 2021 17:29:53-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 2, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1-GigabitEthernet0/0/1]quit
    [R1]interface g 0/0/2
    [R1-GigabitEthernet0/0/2]ip address 192.168.2.2 24
    [R1-GigabitEthernet0/0/2]
    Jan  7 2021 17:30:48-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP 
    on the interface GigabitEthernet0/0/2 has entered the UP state.
    [R1-GigabitEthernet0/0/2]
    Jan  7 2021 17:30:53-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 3, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1-GigabitEthernet0/0/2]quit
    [R1]
    

    第二步:配置RIP协议:R1、R2、R3参考如下。

    [R1]rip 1
    [R1-rip-1]version 2
    [R1-rip-1]
    Jan 15 2021 09:26:01-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 5, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1-rip-1]network 192.168.1.0
    [R1-rip-1]network 192.168.2.0
    

    第三步:配置R1上BFD联动,R2参考配置如下。

    [R1]bfd
    [R1-bfd]quit
    [R1]rip 1
    [R1-rip-1]
    [R1-rip-1]bfd all-interfaces enable						//启用bfd功能
    [R1-rip-1]
    Jan 15 2021 09:31:23-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 9, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1-rip-1]bfd all-interfaces min-rx-interval 100 min-tx-interval 100 detect-mult
    iplier 10									//配置最小发送、时间间隔
    

    第四步:验证配置结果。

    dis ip routing:
    

    在这里插入图片描述

    dis rip 1 neighbor:
    

    在这里插入图片描述

    dis rip 1 bfd session all:
    

    在这里插入图片描述

    Shutdown.

    2.动态路由OSPF实验

    2.1 OSPF:开放路由最短路径协议,链路状态。路由器之间通过网络接口状态LSA来建立链路状态数据库(邻居表),使用迪杰斯特拉Dijkstra算法,来计算最短路径(拓扑表),每个路由器使用这些最短路径构造(路由表)。
    2.2 简化原理:发送Hello报文建立邻接关系(邻居表)-形成链路状态数据库(拓扑表)-SPF算法形成路由表(路由表)
    2.3 OSPF采用触发更新和30分钟周期更新。支持不连续子网和CIDR。管理距离:10、150。
    2.4 OSPF实验拓扑图。
    在这里插入图片描述

    第一步:配置R1接口IP:R2、R3、R4参考配置。

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R1
    [R1]
    [R1]un in en
    Info: Information center is disabled.
    [R1]int e0/0/0
    [R1-Ethernet0/0/0]ip add 192.1.0.129 26
    [R1-Ethernet0/0/0]int s0/0/0
    [R1-Serial0/0/0]ip add 192.200.10.5 30
    [R1-Serial0/0/0]
    <R1>dis cu
    #
    sysname R1
    #
    undo info-center enable
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password cipher OOCM4m($F4ajUn1vMEIBNUw#
     local-user admin service-type http
    #
    firewall zone Local
     priority 16
    #
    interface Ethernet0/0/0
     ip address 192.1.0.129 255.255.255.192
    #
    interface Ethernet0/0/1
    #
    interface Serial0/0/0
     link-protocol ppp
     ip address 192.200.10.5 255.255.255.252
    #
    interface Serial0/0/1
     link-protocol ppp
    #
    interface Serial0/0/2
     link-protocol ppp
    #
    interface Serial0/0/3
     link-protocol ppp
    #
    interface GigabitEthernet0/0/0
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    wlan
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    user-interface vty 16 20
    

    第二步:配置R1的OSPF:R2、R3、R4参考配置如下。

    [R1]ospf
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]net 192.200.10.4 0.0.0.3
    [R1-ospf-1-area-0.0.0.0]area 1
    [R1-ospf-1-area-0.0.0.1]net 192.1.0.128 0.0.0.63
    [R1-ospf-1-area-0.0.0.1]return
    <R1>dis cu
    #
    sysname R1
    #
    undo info-center enable
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password cipher OOCM4m($F4ajUn1vMEIBNUw#
     local-user admin service-type http
    #
    firewall zone Local
     priority 16
    #
    interface Ethernet0/0/0
     ip address 192.1.0.129 255.255.255.192
    #
    interface Ethernet0/0/1
    #
    interface Serial0/0/0
     link-protocol ppp
     ip address 192.200.10.5 255.255.255.252
    #
    interface Serial0/0/1
     link-protocol ppp
    #
    interface Serial0/0/2
     link-protocol ppp
    #
    interface Serial0/0/3
     link-protocol ppp
    #
    interface GigabitEthernet0/0/0
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    wlan
    #
    interface NULL0
    #
    ospf 1
     area 0.0.0.0
      network 192.200.10.4 0.0.0.3
     area 0.0.0.1
      network 192.1.0.128 0.0.0.63
    #
    user-interface con 0
    user-interface vty 0 4
    user-interface vty 16 20
    #
    return
    

    第三步:验证。

    ping
    

    在这里插入图片描述

    dis ip routing
    

    在这里插入图片描述

    3.动态路由IS-IS实验

    3.1 IS-IS:中间系统-中间系统,路由器称为中间系统IS。和OSPF协议很类似。
    3.2 Net-Entity:网络实体,运行IS-IS的路由器必须配置一个网络实体地址。格式为:SEL服务访问点。
    在这里插入图片描述

    例如:4A.2000.00E0.008C.00十六进制表示。
    3.3 IS-IS在路由域内采用两级的分层结构。骨干区域与非骨干区域。并定义了路由器的三种角色:区域内Level-1、区域间的Level-2、同属于Level-1-2。默认的路由器接口为Level-1-2。
    3.4 IS-IS的实验拓扑图。
    在这里插入图片描述

    第一步:配置R1的接口IP。R2、R3参考配置如下。

    <Huawei>sys 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname R1
    [R1]
    [R1]
    Jan 15 2021 10:27:24-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 1, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1]
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 10.0.12.2 24
    [R1-GigabitEthernet0/0/0]
    Jan 15 2021 10:27:44-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
    on the interface GigabitEthernet0/0/0 has entered the UP state.
    [R1-GigabitEthernet0/0/0]quit
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 10.0.23.2 24
    [R1-GigabitEthernet0/0/1]
    Jan 15 2021 10:28:14-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP 
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    Jan 15 2021 10:28:14-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 3, the ch
    ange loop count is 0, and the maximum number of records is 4095.
    [R1-GigabitEthernet0/0/1]
    [R1-GigabitEthernet0/0/1]quit
    [R1]
    

    第二步:配置R1的IS-IS:R2、R3参考配置如下。

    <R1>
    <R1>sys
    Enter system view, return user view with Ctrl+Z.
    [R1]
    [R1]un in en
    Info: Information center is disabled.
    [R1]
    [R1]isis
    [R1-isis-1]network-entity 10.0000.0000.0001.00
    [R1-isis-1]quit
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]
    [R1-GigabitEthernet0/0/0]isis enable
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]isis enable
    [R1-GigabitEthernet0/0/1]
    

    第三步:验证

    Ping 10.0.12.1
    

    在这里插入图片描述

    Dis ip routing
    

    在这里插入图片描述

    Dis isis peer、
    <R1>dis cu
    #
    sysname R1
    #
    undo info-center enable
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password cipher OOCM4m($F4ajUn1vMEIBNUw#
     local-user admin service-type http
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    firewall zone Local
     priority 16
    #
    interface Ethernet0/0/0
    #
    interface Ethernet0/0/1
    #
    interface Serial0/0/0
     link-protocol ppp
    #
    interface Serial0/0/1
     link-protocol ppp
    #
    interface Serial0/0/2
     link-protocol ppp
    #
    interface Serial0/0/3
     link-protocol ppp
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.12.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 10.0.23.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    wlan
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    user-interface vty 16 20
    #
    Return
    
    dis isis route
    
    展开全文
  • 组网实验

    2021-01-07 21:11:44
    3.1.1综合运用交换机组网技术、路由器组网技术及网络安全技术等知识; 3.1.2掌握网络中典型问题的综合解决方法; 3.1.3尝试独立根据技术需求,配置实现网络。 二、实验内容 基于实验拓扑,按以下技术需求,配置实现...
  • 实验目的: 了解同一交换机和不同交换机连接下,不同局域网的终端是否能相互ping通 实验器材: 两台交换机、六台路由器 完成图如下图: 实验步骤: 布置一台交换机、三台路由器,用直通线分别将f0/1,f0/2,...
  • 组网实验

    2021-01-07 20:59:31
    路由器组网技术 一、实验目的 2.1.1掌握静态路由、RIP、OSPF的路由配置; 2.1.2掌握全网使用多种路由协议的配置方法。 二、实验内容 配置静态路由、RIP路由和OSPF路由,实现不同网络的互通。 三、实验步骤 2.6.1按照...
  • 1、 单臂路由实验步骤 1) 设置交换机 : 创建两个VLAN,并将接口加入VLAN 2) 设置电脑: IP 掩码 网关地址(网关地址很重要!!!---网关地址其实就是一条默认路由) 3) 设置交换机 将连接路由器线路的接口...
  • spanning-tree vlan 1 root second(该交换机设置为VLAN1下的备用根桥) switch(config) spanning-tree vlan 1 priority 0(该交换机在VLAN 1下的priority设置为0,具备最高优先级) 今天的课关于生成树实验,为了...
  • 大连飞翔科技有限公司开发的物联网实验平台定位于高校物联网专业应用和物联网实验室建设,该套平台是FES-IoT-A-II的裁剪版。该开发系统包括硬件设备、实验例程两大部分。硬件设备集成一块STM32W108无线控制节点、...

空空如也

空空如也

1 2 3 4 5 ... 14
收藏数 265
精华内容 106
关键字:

组网技术实验