精华内容
下载资源
问答
  • VRRP实验

    2021-04-04 12:47:56
    VRRP实验 文章目录VRRP实验实验环境实验目的具体步骤测试、结果分析与问题解决总结 实验环境 实验目的 实现网关的备份,又解决多个网关之间互相冲突的问题。 具体步骤 1.规划网络配置IP R1 <Huawei>sys ...

    VRRP实验

    实验环境

    在这里插入图片描述

    实验目的

    实现网关的备份,又解决多个网关之间互相冲突的问题。

    具体步骤

    1.规划网络配置IP

    R1

    <Huawei>sys
    [Huawei]sys R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip ad 10.1.10.2 24
    [R1-GigabitEthernet0/0/1]ip ad 10.1.11.1 24
    [R1-GigabitEthernet0/0/1]q
    [R1]int lo 0
    [R1-LoopBack0]ip ad 1.1.1.1 32
    [R1-LoopBack0]q
    [R1]ospf 1 router-id 1.1.1.1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 10.1.11.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 10.1.10.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
    

    R2

    <Huawei>sys
    [Huawei]sy R2
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip ad 10.1.11.3 24
    [R2-GigabitEthernet0/0/1]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip ad 192.168.1.3 24
    [R2]ospf router-id 2.2.2.2	
    [R2-ospf-1]area 0	
    [R2-ospf-1-area-0.0.0.0]network 10.1.11.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    

    R3

    <Huawei>sys
    [Huawei]sys R3
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip ad 10.1.10.4 24
    [R3-GigabitEthernet0/0/1]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip ad 192.168.1.4 24 
    [R3-GigabitEthernet0/0/0]q
    [R3]ospf router-id 3.3.3.3	
    [R3-ospf-1]area 0	
    [R3-ospf-1-area-0.0.0.0]network 10.1.10.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    

    PC1

    IP:192.168.1.1 掩码 24 网关:192.168.1.254
    

    PC2

    IP:192.168.1.2 掩码 24 网关:192.168.1.254
    

    2.配置VRRP

    R2

    [R2]int g0/0/0	
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254    //创建虚拟IP
    [R2-GigabitEthernet0/0/0]vrrp vrid 1 priority 130    //默认100
    

    R3

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254
    

    测试、结果分析与问题解决

    • 基本配置(主备)后测试与结果分析

      PC1 ping 1.1.1.1
      在这里插入图片描述

      查看主备情况

      <R2>dis vrrp
        GigabitEthernet0/0/0 | Virtual Router 1
          State : Master
          Virtual IP : 192.168.1.254
          Master IP : 192.168.1.3
          PriorityRun : 130
          PriorityConfig : 130
          MasterPriority : 130
          Preempt : YES   Delay Time : 0 s
      
      <R3>dis vrrp
        GigabitEthernet0/0/0 | Virtual Router 1
          State : Backup
          Virtual IP : 192.168.1.254
          Master IP : 192.168.1.3
          PriorityRun : 100
          PriorityConfig : 100
          MasterPriority : 130
          Preempt : YES   Delay Time : 0 s
      

      对R2到R1之间抓包
      在这里插入图片描述

      综合以上结果可得,R2为主备网关(虚拟)的主路由器,由PC1到1.1.1.1的流量经由R2发往R1最终到达1.1.1.1

    • 负载分担问题解决

      再添加一个虚拟的网关,该虚拟网关的主备情况与上面相反,再将PC2的网关改为该地址,从而实现负载分担。

      配置一个新的虚拟网关

      //路由器R3上的vrid 2配置
      [R3]int g0/0/0
      [R3-GigabitEthernet0/0/0]vrrp vrid 2 virtual-ip 192.168.1.253
      [R3-GigabitEthernet0/0/0]vrrp vrid 2 priority 130
      //路由器R2上的vrid 2配置
      [R2]int g0/0/0
      [R2-GigabitEthernet0/0/0]vrrp vrid 2 virtual-ip 192.168.1.253
      

      查看主备情况

      [R2-GigabitEthernet0/0/0]dis vrrp
        GigabitEthernet0/0/0 | Virtual Router 1
          State : Master
          Virtual IP : 192.168.1.254
          Master IP : 192.168.1.3
          PriorityRun : 130
          PriorityConfig : 130
          MasterPriority : 130
        GigabitEthernet0/0/0 | Virtual Router 2
          State : Backup
          Virtual IP : 192.168.1.253
          Master IP : 192.168.1.4
          PriorityRun : 100
          PriorityConfig : 100
          MasterPriority : 130
      
      [R3-GigabitEthernet0/0/0]dis vrrp
        GigabitEthernet0/0/0 | Virtual Router 1
          State : Backup
          Virtual IP : 192.168.1.254
          Master IP : 192.168.1.3
          PriorityRun : 100
          PriorityConfig : 100
          MasterPriority : 130
        GigabitEthernet0/0/0 | Virtual Router 2
          State : Master
          Virtual IP : 192.168.1.253
          Master IP : 192.168.1.4
          PriorityRun : 130
          PriorityConfig : 130
          MasterPriority : 130
      

      PC2 ping 1.1.1.1
      在这里插入图片描述

      对R3到R1之间抓包
      在这里插入图片描述
      综合以上结果可得,PC2到1.1.1.1的流量经由R3转发到R1最终到达1.1.1.1.由此实现了负载的分担。

    • Master的上行端口Down后的通信问题

      主路由器(R2 vrid 1)上行接口Down后,由于其为主路由器,PC1到1.1.1.1的请求仍会到达R2,但R2无法转发,所以PC1的请求会失败。为解决问题,在主路由器上实时检测上行端口状态,以使得接口Down后请求得以由备份路由器转发。

      注意:由于路由器间配置了OSPF会影响实验结果,所以要将R2和R3在192.168.1.0网段的接口静默。

      [R2-ospf-1]silent-interface g0/0/0
      
      [R3-ospf-1]silent-interface g0/0/0
      

      Down R2 的 g0/0/1后,PC1 ping 1.1.1.1
      在这里插入图片描述

      主路由器(R2)配置状态检测

      [R2]int g0/0/0
      [R2-GigabitEthernet0/0/0]vrrp vrid 1 track int g0/0/1 reduced 40
      

      结果(Down g0/0/1后主备情况)

      [R2-GigabitEthernet0/0/1]dis vrrp
        GigabitEthernet0/0/0 | Virtual Router 1
          State : Backup
          Virtual IP : 192.168.1.254
          Master IP : 192.168.1.4
          PriorityRun : 90
          PriorityConfig : 130
          MasterPriority : 100
      

      PC1再次ping1.1.1.1
      在这里插入图片描述
      在Down g0/0/1后,PC1的请求仍可以被转发到1.1.1.1,由此可知问题得到解决。

    总结

    通过实验学习到如何解决单一网关可能断网的问题,对VRRP协议有了一定的了解,加深了对OSPF协议工作的理解。在实验中验证了备路由器由于某些原因立即抢占主路由器后,由于OSPF的收敛时间(备路由器无路由)而导致网络短暂无法通信的情况。

    展开全文
  • vrrp 实验

    2020-11-19 22:30:14
    实验拓扑 实验需求 交换机之间配置 Trunk 链路 , 交换机与路由器之间配置静态路由。 SW2 主vlan 10 从vlan 20 ;SW3 主vlan 20 从vlan 10 SW2 和SW3 开启检测端口分别在vlan10 和vlan 20 开启 环回地址测试和跨...

    实验拓扑

    在这里插入图片描述

    实验需求

    1. 交换机之间配置 Trunk 链路 , 交换机与路由器之间配置静态路由。
    2. SW2 主vlan 10 从vlan 20 ;SW3 主vlan 20 从vlan 10
    3. SW2 和SW3 开启检测端口分别在vlan10 和vlan 20 开启
    4. 环回地址测试和跨网段回包

    实验过程

    先进行SW2 SW3与SW4的trunk链路配置

    
    SW2
    [H3C]int g1/0/2
    [H3C-GigabitEthernet1/0/2]port link-type trunk
    [H3C-GigabitEthernet1/0/2]port trunk permit vlan 10 20
    
    
    [sw3]int g1/0/2
    [sw3-GigabitEthernet1/0/2]port link-type trunk
    [sw3-GigabitEthernet1/0/2]port trunk  permit vlan 10 20
    
    
    [sw4]int g1/0/1
    [sw4-GigabitEthernet1/0/1]port link-type trunk
    [sw4-GigabitEthernet1/0/1]port trunk permit vlan 10 20
    [sw4-GigabitEthernet1/0/1]int g1/0/2
    [sw4-GigabitEthernet1/0/2]port link-type trunk
    [sw4-GigabitEthernet1/0/2]port trunk permit vlan 10 20
    [sw4-GigabitEthernet1/0/3]dis this
    #
    interface GigabitEthernet1/0/3
     port link-mode bridge
     port access vlan 10
     combo enable fiber
    #
    interface GigabitEthernet1/0/4
     port link-mode bridge
     port access vlan 20
     combo enable fiber
    
    

    配置SW2 和SW3 vrrp SW2 的vlan 10 为主 vlan20 为备
    SW3 : vlan 10 为备 vlan 20 为主

    SW2
    [H3C]dis ip interface  brief
    *down: administratively down
    (s): spoofing  (l): loopback
    Interface                Physical Protocol IP Address      Description
    MGE0/0/0                 down     down     --              --
    Vlan10                   up       up       192.168.1.2     --
    Vlan20                   up       up       192.168.2.2   
    
    SW3
    [sw3]dis ip int br
    *down: administratively down
    (s): spoofing  (l): loopback
    Interface                Physical Protocol IP Address      Description
    MGE0/0/0                 down     down     --              --
    Vlan10                   up       up       192.168.1.3     --
    Vlan20                   up       up       192.168.2.3     --
    
    
    
    SW2
    [H3C-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.1.10
    [H3C-Vlan-interface10]vrrp vrid 1 priority 120
    [H3C-Vlan-interface10]vrrp vrid 1 preempt-mode delay 2
    [H3C-Vlan-interface10]int vlan 20
    [H3C-Vlan-interface20]vrrp vrid 2 virtual-ip 192.168.2.10
    [H3C-Vlan-interface20]vrrp vrid 2 priority 100
    [H3C-Vlan-interface20]vrrp vrid 2 preempt-mode delay 2
    
    
    
    SW3
    [sw3]int vlan 10
    [sw3-Vlan-interface10]vrrp vrid 1 virtual-ip 192.168.1.10
    [sw3-Vlan-interface10]vrrp vrid 1 preempt-mode delay 2
    [sw3-Vlan-interface10]vrrp vrid 1 priority 100
    [sw3-Vlan-interface10]int vlan 20
    [sw3-Vlan-interface20]vrrp vrid 2 virtual-ip 192.168.2.10
    [sw3-Vlan-interface20]vrrp vrid 2 priority 120
    [sw3-Vlan-interface20]vrrp vrid 2 preempt-mode
    
    

    查看SW2 和SW3 的状态
    SW2
    在这里插入图片描述
    在这里插入图片描述
    进入端口监控在SW2和SW3

    [sw3]track 1 interface g1/0/1
    [sw3-track-1]qu
    [sw3]int vlan 20
    [sw3-Vlan-interface20]vrrp vrid 2 track 1 priority reduced  30
    [sw2]track 1 interface g1/0/1
    [sw2-track-1]qu
    [sw2]int vlan 10
    [sw2-Vlan-interface10]vrrp vrid 1 track 1 priority reduced  30
    [route 1]int lo0
    [route 1-LoopBack0]ip add 192.168.3.1 24
    [route 1-LoopBack0]int g0/0
    [route 1-GigabitEthernet0/0]ip add 192.168.5.1 24
    [route 1-GigabitEthernet0/0]int g0/1
    [route 1-GigabitEthernet0/1]ip add 192.168.4.1 24
    
    在SW2 和SW3 分别配置VLAN 30 vlan 40
    SW2 g1/0/1 ip 192.168.5.2 24
    sw3  g1/0/1 ip 192.168.4.2 24
    

    配置ACCESS 链路放行vlan 30 和40

    [sw2-Vlan-interface30]int g1/0/1
    [sw2-GigabitEthernet1/0/1]port link-type access
    [sw2-GigabitEthernet1/0/1]port access vlan 30
    [sw3-Vlan-interface40]int g1/0/1
    [sw3-GigabitEthernet1/0/1]port link-type access
    [sw3-GigabitEthernet1/0/1]port access vlan 40
    

    配置SW2和SW3静态

    [sw2]ip route-static 192.168.3.0 24 192.168.5.1
    [route 1]ip route-static 192.168.1.0 24 192.168.5.2
    [sw3]ip route-static 192.168.3.0 24 192.168.4.1
    [route 1]ip route-static 192.168.2.0 24 192.168.4.2
    [route 1]ip route-static 192.168.0.0 23 192.168.4.2
    

    查看route 静态配置
    在这里插入图片描述

    PC5测试ping route 1
    在这里插入图片描述
    PC6 测ping route 1
    在这里插入图片描述
    PC6进行跨网段ping SW2
    在这里插入图片描述
    讲SW2 G1/0/1 down ,查看信息

    在这里插入图片描述
    在这里插入图片描述
    进行Ping 测试
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 内附VRRP实验文档,VRRP.PPT,VRRP .pdf,以及实验拓展内容。。
  • VRRP实验记录

    2020-07-29 19:57:28
    VRRP实验记录实验拓扑图实验准备实验背景设置VRRP设置备份路由组设置备份组计时器设置抢占延迟:联动功能: 实验拓扑图 实验准备 PC1配置 交换机配置 <Huawei>sy [Huawei]sy sw1 [sw1]int g0/0/1 [sw1-...

    实验拓扑图

    实验准备

    1. PC1配置
      在这里插入图片描述
    2. 交换机配置
    <Huawei>sy
    [Huawei]sy sw1
    [sw1]int g0/0/1
    [sw1-GigabitEthernet0/0/1]stp ed	//tab键补全命令
    [sw1-GigabitEthernet0/0/1]stp edged-port enable    //启用边缘接口
    [sw1-GigabitEthernet0/0/1]int g0/0/2
    [sw1-GigabitEthernet0/0/2]stp ed	
    [sw1-GigabitEthernet0/0/2]stp edged-port e	
    [sw1-GigabitEthernet0/0/2]stp edged-port enable 
    [sw1-GigabitEthernet0/0/2]int g0/0/3
    [sw1-GigabitEthernet0/0/3]stp ed	
    [sw1-GigabitEthernet0/0/3]stp edged-port enable
    
    1. 路由器配置

    AR1:

    <Huawei>sy
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sy r1
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ip addr 192.168.1.251 24
    [r1-GigabitEthernet0/0/0]
    [r1-GigabitEthernet0/0/0]int g0/0/1
    [r1-GigabitEthernet0/0/1]ip addr 10.1.13.1 24
    [r1-GigabitEthernet0/0/1]
    

    AR2:

    <Huawei>sy
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sy r2
    [r2]int g0/0/0
    [r2-GigabitEthernet0/0/0]ip addr 192.168.1.252 24
    [r2-GigabitEthernet0/0/0]
    [r2-GigabitEthernet0/0/0]int g0/0/1
    [r2-GigabitEthernet0/0/1]ip addr 10.1.23.2 24
    [r2-GigabitEthernet0/0/1]
    

    AR3:

    <Huawei>sy
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sy r3
    [r3]int loo0
    [r3-LoopBack0]ip addr 100.1.1.1 32
    [r3-LoopBack0]
    [r3-LoopBack0]int g0/0/0
    [r3-GigabitEthernet0/0/0]ip addr 10.1.13.3 24
    [r3-GigabitEthernet0/0/0]
    [r3-GigabitEthernet0/0/0]int g0/0/1
    [r3-GigabitEthernet0/0/1]ip addr 10.1.23.3 24
    [r3-GigabitEthernet0/0/1]
    
    1. 配置完接口后获取动态路由

    AR1:

    [r1]ospf 1 r 1.1.1.1
    [r1-ospf-1]area 0
    [r1-ospf-1-area-0.0.0.0]network 0.0.0.0 0.0.0.0
    [r1-ospf-1-area-0.0.0.0]q
    [r1-ospf-1]silent-int	
    [r1-ospf-1]silent-interface g0/0/0
    [r1-ospf-1]q
    [r1]
    

    AR2:

    [r2]ospf 1 r 2.2.2.2
    [r2-ospf-1]area 0
    [r2-ospf-1-area-0.0.0.0]network 0.0.0.0 0.0.0.0
    [r2-ospf-1-area-0.0.0.0]q
    [r2-ospf-1]silent-int	
    [r2-ospf-1]silent-interface g0/0/0
    [r2-ospf-1]q
    [r2]
    

    AR3:

    [r3]ospf 1 r 3.3.3.3
    [r3-ospf-1]area 0
    [r3-ospf-1-area-0.0.0.0]network 0.0.0.0 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]q
    
    1. PC1访问AR3
      在这里插入图片描述

    实验背景

    关闭AR1的接口:

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]shutdown
    

    PC1无法访问AR3:
    在这里插入图片描述
    由拓扑图可见,PC1在AR1关闭接口后,并没有与选择经过AR2来与AR3通信。在没有设置VRRP的情况下需要用户手动改变网关。

    设置VRRP

    设置备份路由组

    AR1:

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254   //vrid是备份组
                                                                    //virtual-ip是虚拟IP
    [r1-GigabitEthernet0/0/0]
    [r1-GigabitEthernet0/0/0]dis vrrp
    
      GigabitEthernet0/0/0 | Virtual Router 1   //备份组编号
        State : Master                //备份组状态:主用路由
        Virtual IP : 192.168.1.254    //虚拟IP
        Master IP : 192.168.1.251
        PriorityRun : 100             //优先级默认100
        PriorityConfig : 100
        MasterPriority : 100
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2020-07-29 17:28:04 UTC-08:00
        Last change time : 2020-07-29 17:28:07 UTC-08:00
    
    [r1-GigabitEthernet0/0/0]
    
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 pri	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 priority 120  //修改该接口在备份组中的优先级(高为优先)
    [r1-GigabitEthernet0/0/0]dis vrrp
    
      GigabitEthernet0/0/0 | Virtual Router 1
        State : Master
        Virtual IP : 192.168.1.254
        Master IP : 192.168.1.251
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2020-07-29 17:28:04 UTC-08:00
        Last change time : 2020-07-29 17:28:07 UTC-08:00
    
    [r1-GigabitEthernet0/0/0]
    

    AR2:

    [r2]int g0/0/0
    [r2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254  //使用同一个备份组
    [r2-GigabitEthernet0/0/0]
    [r2-GigabitEthernet0/0/0]dis vrrp
    
      GigabitEthernet0/0/0 | Virtual Router 1
        State : Backup                //备份组状态:备用
        Virtual IP : 192.168.1.254
        Master IP : 192.168.1.251
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2020-07-29 17:38:00 UTC-08:00
        Last change time : 2020-07-29 17:38:00 UTC-08:00
    
    [r2-GigabitEthernet0/0/0]
    

    PC1中修改网关:
    在这里插入图片描述
    PC1持续pingAR3,现在由于AR1优先级高(数据优先经过AR1),所以关闭AR1的g0/0/0接口来模拟故障情景:

    [r1-GigabitEthernet0/0/0]shutdown
    

    在这里插入图片描述
    此时PC1连通AR3的情况:
    在这里插入图片描述

    可见关闭接口后丢了几个数据包,但是依旧能连通AR3,原因是设置了备份,在数据包无法到达AR1的情况下,PC1自动选择AR2继续传输数据。
    此时把AR1的g0/0/0接口打开

    [r1-GigabitEthernet0/0/0]undo shutdown
    

    在这里插入图片描述
    由于设置AR1的VRRP备份优先级是120,高于AR2默认的优先级100,所以接口开放后PC1优先选择AR1来进行数据传输,丢包发生在切换路由后。
    由于AR2优先级低,所以此时关闭AR2的接口并不会引起切换路由而丢包情况。

    丢包的原因在下面抢占中解释。

    设置备份组计时器

    当主用路由无法使用后,设置备份路由启用时间(默认1s)

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 timer adver	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 timer advertise 5  //设置响应时间,5s后切换备份路由
    [r1-GigabitEthernet0/0/0]dis vrrp
    
      GigabitEthernet0/0/0 | Virtual Router 1
        State : Master
        Virtual IP : 192.168.1.254
        Master IP : 192.168.1.251
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 5 s
        TimerConfig : 5 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2020-07-29 17:28:04 UTC-08:00
        Last change time : 2020-07-29 17:44:53 UTC-08:00
    

    设置抢占延迟:

    如AR1故障后恢复,会出现丢包。原因是AR1恢复后需要时间重新收集路由表,此时如果立刻抢占成为主用路由,但是路由表还没有收集到数据包需要的路径,就会丢弃数据包。

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 pre	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode tim	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer d	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer delay ?
      INTEGER<0-3600>  Value of timer, in seconds(default is 0)        //默认0s后进行抢占
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode timer delay 60   //设置60s后进行抢占
    [r1-GigabitEthernet0/0/0]
    

    或者关闭抢占功能:

    [r1-GigabitEthernet0/0/0]vrrp vrid 1 preempt-mode disable
    

    联动功能:

    当AR1的g0/0/1接口故障(或者AR3的g0/0/0接口故障)时,数据无法发送到AR3,但是AR1仍在正常运行,此时由于AR1和AR2的g0/0/0接口都在备份组里,但这两个接口都没有故障,所以没有进行抢占,维持故障状态。
    在这里插入图片描述
    这时需要让AR1的g0/0/0接口监视g0/0/1接口的连通性:

    [r1-GigabitEthernet0/0/0]vrrp vrid 1 track ?     //track指监视
      bfd-session  Specify BFD session
      interface    Interface information       //接口信息
      ip           Specify IP protocol
      nqa          Specify NQA test class
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 track int	
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 track interface g0/0/1 ?   //指定监视接口g0/0/1
      increased  Increase priority             //提高优先级
      reduced    Reduce priority               //降低优先级
      <cr>       Please press ENTER to execute command 
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 track interface g0/0/1 reduce 30 
                    //当接口出现连通性问题时降低该路由在备份组中的优先级,使备份路由抢占从而维持数据传输
    [r1-GigabitEthernet0/0/0]
    [r1-GigabitEthernet0/0/0]
    

    关闭AR1的g0/0/1接口:

    [r1-GigabitEthernet0/0/1]shutdown
    [r1-GigabitEthernet0/0/1]
    [r1-GigabitEthernet0/0/1]dis vrrp
      GigabitEthernet0/0/0 | Virtual Router 1
        State : Backup                    //此时作为了备用路由
        Virtual IP : 192.168.1.254
        Master IP : 192.168.1.252
        PriorityRun : 90                  //监视到g0/0/1发生故障后主动降低了优先级
        PriorityConfig : 120
        MasterPriority : 100
        Preempt : YES   Delay Time : 60 s
        TimerRun : 1 s
        TimerConfig : 5 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track IF : GigabitEthernet0/0/1   Priority reduced : 30
        IF state : DOWN
        Create time : 2020-07-29 17:28:04 UTC-08:00
        Last change time : 2020-07-29 18:23:16 UTC-08:00
    
    [r1-GigabitEthernet0/0/1]
    

    此时AR2:

    [r2-GigabitEthernet0/0/0]dis vrrp
      GigabitEthernet0/0/0 | Virtual Router 1
        State : Master                      //由于AR1降低了自身优先级,所以AR2现在是主用路由
        Virtual IP : 192.168.1.254
        Master IP : 192.168.1.252
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 100
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2020-07-29 17:38:00 UTC-08:00
        Last change time : 2020-07-29 18:23:16 UTC-08:00
    
    [r2-GigabitEthernet0/0/0]
    
    展开全文
  • 云计算专业VRRP实验

    2021-02-06 20:03:52
    VRRP实验: 拓扑图如图所示: 相关路由器的配置命令: AR2: system-view interface g0/0/2 ip address 99.99.99.254 24 interface g0/0/0 ip address 6.6.6.2 24 interface g0/0/1 ip address 3.3.3.2 24 ospf ...

    VRRP实验:
    拓扑图如图所示:
    在这里插入图片描述
    相关路由器的配置命令:

    AR2:
    system-view
    interface g0/0/2
    ip address 99.99.99.254 24
    interface g0/0/0
    ip address 6.6.6.2 24
    interface g0/0/1
    ip address 3.3.3.2 24
    ospf 
    area 0
    network 99.99.99.0 0.0.0.255
    network 6.6.6.0 0.0.0.255
    network 3.3.3.0 0.0.0.255
    
    AR3:
    system-view
    interface g0/0/1
    ip address 6.6.6.1 24
    interface g0/0/0
    ip address 9.9.9.252 24
    ospf
    area 0
    network 6.6.6.0 0.0.0.255
    network 9.9.9.0 0.0.0.255
    
    interface g0/0/0
    vrrp vrid 1 virtual-ip 9.9.9.254
    vrrp vrid 1 priority 200
    vrrp vrid 1 track interface g0/0/1 reduced 150
    
    AR4:
    system-view
    interface g0/0/1
    ip address 3.3.3.1 24
    interface g0/0/0
    ip address 9.9.9.253 24
    ospf
    area 0
    network 3.3.3.0 0.0.0.255
    network 9.9.9.0 0.0.0.255
    
    interface g0/0/0
    vrrp vrid 1 virtual-ip 9.9.9.254
    vrrp vrid 1 priority 100
    

    菜菜的代码,希望能够帮助到你哟!

    展开全文
  • VRRP实验配置步骤

    万次阅读 多人点赞 2019-12-13 22:58:01
    VRRP:虚拟网关冗余协议,三层网关冗余技术,对用户的网关做冗余 PC1(IP地址) IP地址:192.168.10.2 子网:255.255.255.0 网关:192.168.10.1 AR1主(设置iP地址) <Huawei>system-view //进入系统视图 ...
  • vrrp实验.docx

    2020-06-13 08:35:54
    虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议,1998年已推出正式的RFC2338协议标准。VRRP广泛应用在边缘网络中,它的设计...
  • IPV6 VRRP实验.docx

    2019-08-21 20:46:58
    该文档描述了怎样用IPv6来实现VRRP的功能,以及解决IPV6 VRRP的虚拟网关ping不通的问题.
  • VRRP实验01

    2021-05-31 10:33:48
    二、实验说明 1、根据图示,在R1、R2的E1端口配置VRRP,VRID为111,E0端口配置VRRP,VRID为222. 2、在R1的E1端口配置VRRP优先级为250,E0端口配置VRRP优先级为50. 3、从PC1上 PING PC3,查看流量的走向(PC1-R1-PC3-...
  • VRRP实验2

    2021-05-31 10:36:40
    二、实验说明 1、根据图示,在R1、R2的E1端口配置VRRP,VRID为111,E0端口配置VRRP,VRID为222. 2、在R1的E1端口配置VRRP优先级为250,E0端口配置VRRP优先级为50. 3、从PC1上 PING PC3,查看流量的走向(PC1-R1-PC3-...
  • VRRP实验 2

    2021-04-12 16:41:06
    R1和R2上的g0/0/0配置接口 使得pc1和pc2能ping通3.3.3.3 是R1和SW1中间的线路故障,依然可以ping通3.3.3.3 路由器R1的配置 vlan batch 10 20 interface GigabitEthernet0/0/0.1 ... vrrp vrid 1 prio
  • CCNA VRRP 实验

    2018-05-07 20:11:10
    其实就是把HSRP no掉,然后变成vrrp就好了,毫无技术可言Router2(config-if)#no standby 1Router2(config-if)#vrrp 1 ip 192.168.1.254Router2(config-if)#vrrp 1 priority 120show vrrp brief跟踪上游接口,进入...
  • ensp VRRP实验搭建

    千次阅读 2020-11-21 20:47:55
    VRRP的概述 VRRP(虚拟网关冗余协议)主要解决网络中因为网关出现故障,而导致主机不能够访问外网出现的问题,VRRP主要是通过在网络中多添加几台路由器虚拟出来一台虚拟路由器,以此达到备份的效果,然后把主机的...
  • 华为——VRRP实验

    千次阅读 2019-12-18 12:30:56
    虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议,1998年已推出正式的RFC2338协议标准。VRRP广泛应用在边缘网络中,它的设计...
  • Mst p + Vr r p 实验 Mstp+Vrrp双核心网络架构: 在这个双核心的网络架构中所应用到的技术 1 Mstp在交换机层开启 Mstp创建实例instance 一个实例就是一棵树使用 Mstp来 实现数据分流和备份链路 2 Mstp+Vrrp Vrrp是...
  • VRRP实验1 拓展

    2021-04-12 19:11:11
    交换机配置mstp+vrrp,SW1作为vlan10的主,vlan20的备,sw2相反,使得pc1和pc2可以互通 SW1的配置 [SW1]vlan batch 10 20 [SW1]int vlanif 10 [SW1-Vlanif10]ip add [SW1-Vlanif10]ip address 192.168.1.252 24 ...
  • 神州数码交换机

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,838
精华内容 2,335
关键字:

vrrp实验