精华内容
下载资源
问答
  • Cisco NAT 配置合集

    2013-09-18 00:49:48
    Cisco NAT 配置合集
  • CISCO NAT配置详解

    2011-09-23 13:29:24
    CISCO路由器NAT功能介绍,具体配置讲解。
  • Cisco NAT转换

    2020-12-28 21:38:52
    Cisco NAT地址转化 实验环境: 公司网络拓扑图如图所示,网关路由器连接三层交换机组成公司核心部分,按照部门划分vlan并通过二层交换机连接到各部门主机 PC1 为vlan10 PC2为vlan20 PC3为vlan30 三层交换机和路由器...

    Cisco NAT地址转化

    实验环境:
    公司网络拓扑图如图所示,网关路由器连接三层交换机组成公司核心部分,按照部门划分vlan并通过二层交换机连接到各部门主机
    PC1 为vlan10 PC2为vlan20 PC3为vlan30
    三层交换机和路由器地址为14.0.0.0网段
    R4路由器和R5路由器为45.0.0.0网段
    L1设置dhcp使其pc自动获得IP地址
    要求将公司pc1采用静态NAT转换为公网地址
    将pc2 pc3 采用动态地址转换为公网地址 访问外部网络 (internet)

    在这里插入图片描述
    在sw2,sw3上添加vlan10,20,30
    在这里插入图片描述
    在这里插入图片描述

    Sw2上分配vlan10
    在这里插入图片描述

    Sw3上分配vlan20,30
    在这里插入图片描述

    Sw2上做trunk
    在这里插入图片描述

    Sw3上做trunk
    在这里插入图片描述

    三层交换机上添加vlan10,20,30
    在这里插入图片描述

    三层交换机上F1/14 -15做trunk
    在这里插入图片描述

    设置三层交换机F1/13 IP地址
    在这里插入图片描述

    设置R4两个接口的IP地址
    在这里插入图片描述
    在这里插入图片描述

    设置R5接口的IP地址
    在这里插入图片描述

    设置L1和R4的默认路由,使其互通
    在这里插入图片描述
    在这里插入图片描述

    Pc做dhcp使其pc自动获得IP地址,再测试通信
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    测试看看pc能不能自动获得IP地址
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    用pc1pingR4上的14.0.0.4IP地址
    内部地址可以通信
    在这里插入图片描述
    做NAT地址转换可以用pc ping通R5 (R5IP地址为公网地址)
    在R4上设置NAT,F0/0为入接口,F0/1为出接口
    在这里插入图片描述
    在这里插入图片描述
    设置PC1的地址静态转换
    在这里插入图片描述
    设置pc2,pc3的IP地址为动态转换
    定义内部网络允许访问外部网络的ACL
    在这里插入图片描述
    在全局配置模式中,将access-list 指定的内部局部地址与指定的内部全局地址池进行转换
    (overload表示使用地址复用)
    在这里插入图片描述
    测试用pc访问外部地址上网
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 思科NAT基础配置

    千次阅读 2020-07-05 16:34:45
    要求配置nat技术server1 ping通server0 server0访问server1布置的web 步骤二: 1)server1配置 IP:192.168.1.8/24 网关:192.168.1.252 2)三层设备ms1配置 ms1(config)#int vlan 1 ms1(config-if)#ip add 192.168...

    步骤一:
    如图拓扑设备,
    要求配置nat技术server1 ping通server0
    server0访问server1布置的web
    在这里插入图片描述
    步骤二:
    1)server1配置
    IP:192.168.1.8/24
    网关:192.168.1.252

    2)三层设备ms1配置
    ms1(config)#int vlan 1
    ms1(config-if)#ip add 192.168.1.252 255.255.255.0
    ms1(config-if)#int f0/5
    ms1(config-if)#no switchport
    ms1(config-if)#ip add 192.168.2.1 255.255.255.0
    ms1(config-if)#no shutdown
    ms1(config-if)#exit
    ms1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2 //设置静态路由
    ms1(config)#ip routing //开启路由条目

    3)路由器r1配置
    r1(config)#int f0/0
    r1(config-if)#ip add 192.168.2.2 255.255.255.0
    r1(config-if)#no shutdown
    r1(config-if)#int f0/1
    r1(config-if)#ip add 61.159.62.129 255.255.255.248
    r1(config-if)#no shutdown
    r1(config-if)#exit
    r1(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

    4)server0配置
    IP:61.159.62.134
    掩码:255.255.255.248

    步骤三:
    1)r1 NAT配置 server1 ping通server0
    r1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
    r1(config)#ip nat inside source list 1 interface f0/1 overload
    r1(config)#int f0/1 //对外接口
    r1(config-if)#ip nat outside
    r1(config-if)#int f0/0 //对内接口
    r1(config-if)#ip nat inside

    如图结果
    在这里插入图片描述

    2)r1 IP映射配置 server0访问server1布置的web
    r1(config-if)#ip nat inside source static tcp 192.168.1.8 80 61.159.62.129 80

    如图结果

    在这里插入图片描述

    展开全文
  • Cisco NAT 配置指南

    万次阅读 多人点赞 2018-08-05 14:26:20
    NAT的基本知识 NAT(Network Address Translation )技术提供了一种完全将内部网络和Internet网隔离的方法,让内部网络中的计算机通过少数几个甚至一个合法IP地址(已申请的一个公网IP)访问Internet资源,从而节省...

    NAT的基本知识

    NAT(Network Address Translation )技术提供了一种完全将内部网络和Internet网隔离的方法,让内部网络中的计算机通过少数几个甚至一个合法IP地址(已申请的一个公网IP)访问Internet资源,从而节省了IP地址,并得到广泛的应用。


    NAT常见的三种类型:


    类型名解释
    静态转换指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的,是一成不变的,某个私有IP地址只转换为某个公有IP地址。借助于静态转换,可以实现外部网络对内部网络中某些特定设备(如服务器)的访问
    动态转换指将内部网络的私有IP地址转换为公用IP地址时,IP地址是不确定的,是随机的,所有被授权访问上Internet的私有IP地址可随机转换为指定的合法IP地址集
    端口多路复用指改变外出数据包的源端口并进行端口转换,即端口地址转换(PAT,Port Address Translation).采用端口多路复用方式。内部网络的所有主机均可共享一个合法外部IP地址实现对Internet的访问,从而可以最大限度地节约IP地址资源。

    类型一:静态地址转换

    • 常用命令及步骤 
      设置静态IP地址转换,需完成下列步骤: 
      1) 在路由器上配置IP地址和IP路由; 
      2) 配置静态地址转换。全局配置模式下,使用如下格式命令: 
      “ip nat inside source static 内部专用地址 内部合法地址”。 
      其中,内部专用地址为内部网络的私有地址,内部合法地址为向因特网管理机构申请到的全球合法地址。 
      3) 进入接口配置模式,启用NAT。命令格式为: 
      “ip nat inside/outside”。其中,内网接口使用inside,外部接口使用outside。

    • 任务背景 
      某小型公司组建了一个局域网,欲对外提供WWW服务和FTP服务。企业从ISP处得到的公网IP地址段是191.1.1.32/28,ISP给企业出口路由器分配的地址是200.10.10.13/30。另外,企业还有若干主机需要上因特网,但从ISP处得到的地址数不够

    • 任务分析 
      因为公司从ISP处得到的合法IP地址数不够,因此应考虑使用NAT方法。另外,根据公司需要,公司内部的两台服务器要对外提供服务,需要有固定且合法的IP地址,因此,此处应使用静态地址转换方式。此处,我们暂且忽略其它方式的转换。 
      IP地址分配如图所示:


    这里写图片描述


    • 配置命令 
      R1配置如下: 
      Router>en 
      Router#config t 
      Enter configuration commands, one per line. End with CNTL/Z. 
      Router(config)#int f0/0 //进入连接内网的接口 
      Router(config-if)#ip addr 172.16.1.254 255.255.255.0 
      Router(config-if)#no shut 
      Router(config-if)#int f0/1 
      Router(config-if)#ip addr 200.10.10.13 255.255.255.252 
      Router(config-if)#no shut 
      Router(config-if)#exit 
      Router(config)# 
      Router(config)#ip route 0.0.0.0 0.0.0.0 200.10.10.14 //配置默认路由 
      Router(config)# 
      Router (config)#ip nat inside source static 172.16.1.1 191.1.1.33 
      Router (config)#ip nat inside source static 172.16.1.2 191.1.1.34 
      Router (config)#int f0/0 
      Router (config-if)#ip nat inside 
      Router (config-if)#int f0/1 
      Router (config-if)#ip nat outside 
      Router (config-if)# 
      R2配置如下: 
      Router>en 
      Router#config t 
      Enter configuration commands, one per line. End with CNTL/Z. 
      Router(config)#int f0/0 
      Router(config-if)#ip addr 200.10.10.14 255.255.255.252 
      Router(config-if)#no shut 
      Router(config-if)#int f0/1 
      Router(config-if)#ip addr 211.82.14.254 255.255.255.0 
      Router(config-if)#no shut 
      Router(config-if)#exit 
      Router(config)#ip route 191.1.1.32 255.255.255.240 200.10.10.13 
      Router(config)#

    可自行用命令“show ip nat statistics”查看NAT转换信息。


    类型二:动态地址转换

    • 常用命令及步骤 
      设置动态IP地址转换,需完成下列步骤: 
      1) 在路由器上配置IP地址和IP路由; 
      2) 为内部网络定义一个标准的IP访问控制列表,使用如下格式命令: 
      “access–list access-list-number permit{deny} local-ip-address”。 
      3) 为内部定义一个NAT地址池,命令格式为: 
      “ip nat pool pool-name start-ip end-ip netmask 掩码”。 
      4) 将访问控制列表映射到NAT地址集,命令格式为: 
      “ip nat inside source list access-list-number pool pool-name”。 
      5) 进入接口配置模式,启用NAT。命令格式为“ip nat inside/outside”。此处应至少在一个内部接口或外部接口上启用NAT。

    • 任务背景 
      某小型公司组建了一个局域网,欲对外提供WWW服务。企业从ISP处得到的公网IP地址段是191.1.1.32/28,ISP给企业出口路由器分配的地址是200.10.10.13/30。另外,企业还有若干主机需要上因特网,但从ISP处得到的地址数不够。

    • 任务分析 
      因为公司从ISP处得到的合法IP地址数不够,因此应考虑使用动态NAT方法使内网172.16.1.0/24网段的主机可以访问因特网。另外,根据公司需要,公司内部的WWW服务器要对外提供服务,应该分配一个固定且合法的IP地址,这里使用静态NAT转换来达到目的。IP地址分配如图所示:


    这里写图片描述


    • 配置命令 
      Router>enable 
      Router#configure terminal 
      Enter configuration commands, one per line. End with CNTL/Z. 
      Router(config)#interface FastEthernet0/0 
      Router(config-if)#ip address 172.16.1.254 255.255.255.0 
      Router(config-if)#no shutdown 
      Router(config-if)#exit 
      Router(config)# 
      Router(config)#interface Serial2/0 
      Router(config-if)#ip address 200.10.10.241 255.255.255.252 
      Router(config-if)#clock rate 64000 //给串口DCE端配置时钟频率 
      Router(config-if)#no shutdown 
      Router(config-if)#exit 
      Router(config)# 
      Router(config)#ip route 0.0.0.0 0.0.0.0 200.10.10.242 
      Router(config)# 
      Router(config)#ip nat inside source static 172.16.1.1 191.1.1.33 //将191.1.1.33静态转换给WWW服务器 
      Router(config)#ip nat pool mypoolname 191.1.1.34 191.1.1.46 netmask 255.255.255.240 
      Router(config)#access-list 1 permit 172.16.1.0 0.0.0.255 
      Router(config)#ip nat inside source list 1 pool mypoolname 
      Router(config)#int f0/0 
      Router(config-if)#ip nat inside 
      Router(config-if)#int s2/0 
      Router(config-if)#ip nat outside 
      Router(config-if)#no shut 
      Router(config-if)#exit 
      Router(config)# 
      R2配置如下: 
      Router>enable 
      Router#configure terminal 
      Enter configuration commands, one per line. End with CNTL/Z. 
      Router(config)#interface Serial2/0 
      Router(config-if)#ip address 200.10.10.242 255.255.255.252 
      Router(config-if)# 
      Router(config-if)#exit 
      Router(config)#interface Serial3/0 
      Router(config-if)#ip address 200.10.10.245 255.255.255.252 
      Router(config-if)#clock rate 64000 
      Router(config-if)#no shutdown 
      Router(config-if)# 
      Router(config-if)#exit 
      Router(config)#interface FastEthernet0/0 
      Router(config-if)#ip address 200.10.10.250 255.255.255.252 
      Router(config-if)#no shutdown 
      Router(config-if)#exit 
      Router(config)# 
      Router(config)#ip route 211.82.14.0 255.255.255.0 200.10.10.246 
      Router(config)#ip route 191.1.1.32 255.255.255.240 200.10.10.241 
      Router(config)# 
      R3配置如下: 
      Router>enable 
      Router#configure terminal 
      Enter configuration commands, one per line. End with CNTL/Z. 
      Router(config)#interface Serial3/0 
      Router(config-if)#ip address 200.10.10.246 255.255.255.252 
      Router(config-if)# 
      Router(config-if)#exit 
      Router(config)#interface FastEthernet1/0 
      Router(config-if)#ip address 211.82.14.254 255.255.255.0 
      Router(config-if)#no shutdown 
      Router(config-if)#exit 
      Router(config)#ip route 0.0.0.0 0.0.0.0 200.10.10.245 
      Router(config)#

    检验NAT表 
    Router#show ip nat t

    ProInside globalInside localOutside localOutside global
    udp191.1.1.34:1025172.16.1.2:1025200.10.10.249:53200.10.10.249:53
     191.1.1.33172.16.1.1  
    tcp191.1.1.33:80172.16.1.1:80211.82.14.2:1025211.82.14.2:1025
    tcp191.1.1.34:1025172.16.1.2:1025211.82.14.1:80211.82.14.1:80

    类型三: 端口多路复用

    • 常用命令及步骤 
      设置静态IP地址转换,需完成下列步骤: 
      1) 在路由器上配置IP地址和IP路由; 
      2) 配置好ACL; 
      3) 端口映射命令格式: 
      ip nat inside source list 访问列表号pool 内部全局地址池的名称 overload

    • 任务背景 
      某小型公司组建了一个局域网,但该公司从ISP处仅得到一个合法全球地址200.10.10.1/24,但该公司内部主机都要能够访问Internet。

    • 任务分析 
      因为公司从ISP处得到的合法IP地址数只有一个,因此可以考虑使用端口映射的方法来进行网络地址转换。此处将公司内部网络划分为两个子网,分别为172.16.1.0/24和172.16.2.0/24,它们分别对应vlan 10 和vlan 20。为简化操作,此处路由器R1采用单臂路由的方式给内网提供路由。


    这里写图片描述


    • 配置命令 
      R1配置: 
      Router(config)#ip route 211.82.14.0 255.255.255.0 200.10.10.2 
      Router(config)#access-list 1 permit 172.16.1.0 0.0.0.255 
      Router(config)#access-list 1 permit 172.16.2.0 0.0.0.255 
      Router(config)#ip nat inside source list 1 int f0/1 overload 
      Router(config)#int f0/0.1 
      Router(config-subif)#ip nat inside 
      Router(config-subif)#int f0/0.2 
      Router(config-subif)#ip nat inside 
      Router(config-subif)#exit 
      Router(config)#int f0/1 
      Router(config-if)#ip nat outside 
      Router(config-if)#exit 
      Router(config)#exit
    展开全文
  • Cisco NAT-T实验

    2019-09-13 22:11:25
    Cisco NAT-T 实验 实验拓扑图: 实验步骤: 1 使用 DynamipsGUI 构建网络拓扑结构: 2 分别...
     
    Cisco NAT-T 实验
    实验拓扑图:
    实验步骤:
    1 使用 DynamipsGUI 构建网络拓扑结构:
    2 分别配置 3 台路由器:
    R1
    hostname R1
    no ip domain lookup
    line console 0
    exec-timeout 0 0
    logging synchronous
    interface Loopback0
    ip address 1.1.1 .1 255.255.255.0
    interface FastEthernet0/0
    ip address 20.1.1 .1 255.255.255.0
    crypto map test
    crypto isakmp enable
    crypto isakmp policy 1
    authentication pre-share
    crypto isakmp key cisco address 20.1.1 .1
    access-list 101 permit i p 1.1.1 .0 0.0.0.255 3.3.3.0 0.0.0.255
    crypto ipsec transform-set huyiqian ah-md5-hmac esp-3des
    crypto map test 1 ipsec-isakmp
    set peer 20.1.1 .2
    set transform-set huyiqian
    match address 101
    ip route 0.0.0 .0 0.0.0.0 FastEthernet0/0
    R2
    hostname R2
    no ip domain lookup
    line console 0
    exec-timeout 0 0
    logging synchronous
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    interface FastEthernet1/0
    ip address 20.1.1 .2 255.255.255.0
    ip nat outside
    access-list 100 permit i p 3.3.3 .0 0.0.0.255 any
    ip nat inside source list 100 interface FastEthernet0/0 overload
    ip nat inside source static udp 192.168.1.2 500 interface FastEthernet1/0 500
    ip nat inside source static udp 192.168.1.2 4500 interface FastEthernet1/0 4500
    ip nat inside source static esp 192.168.1.2 interface FastEthernet1/0
    ip route 0.0.0 .0 0.0.0.0 FastEthernet1/0
    ip route 3.3.3 .0 255.255.255.0 FastEthernet0/0
    R3
    hostname R3
    no ip domain lookup
    line console 0
    exec-timeout 0 0
    logging synchronous
    interface Loopback0
    ip address 3.3.3 .3 255.255.255.0
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.0
    crypto map test
    crypto isakmp policy 1
    authentication pre-share
    crypto isakmp key cisco address 20.1.1 .1
    access-list 101 permit i p 3.3.3 .0 0.0.0.255 1.1.1.0 0.0.0.255
    crypto ipsec transform-set huyiqian ah-md5-hmac esp-3des
    crypto map test 1 ipsec-isakmp
    set peer 20.1.1 .1
    set transform-set huyiqian
    match address 101
    ip route 0.0.0 .0 0.0.0.0 FastEthernet0/0
    3 检测网络连通性:
    R1
     
    R3
     
    R2
     
     

    转载于:https://my.oschina.net/u/2391603/blog/464031

    展开全文
  • 静态路由和DHCP/NAT的配置实例配套视频刘辉:02-静态路由和DHCP/NAT的配置实例​zhuanlan.zhihu.com实验描述:1. AR1 为公司总部出口路由器,申请了一个12.1.1.0/27 的公网IP 地址 AR3 为公司分支出口路由器 ,申请...
  • 思科NAT之PAT实验

    2020-09-02 20:10:07
    ip nat inside //为NAT的入接口 ! interface FastEthernet1/0 ip nat outside //为NAT的出接口 ! ip access-list standard NAT permit 192.168.1.0 0.0.0.255 //抓取感兴趣流 ! ip nat inside source list NAT ...
  • CISCO_NAT配置命令

    2014-02-15 15:07:48
    CISCO_NAT配置命令
  • 思科NAT映射详解

    2018-02-11 16:26:33
    1.实验拓扑图如下: 左侧模仿内网,右侧模仿外网 2.分别给设备配置IP,内网配置默认路由R1配置如下:配置路由R1#ip route ...3.配置nat转换 R1上操作如下R1(config)#access-list 1 permit 192.168.1.1 0.0.0.0 #建立...
  • Cisco NAT的配置例子

    2020-03-04 11:07:02
    本文介绍了一个cisco NAT 的配置例子。
  • 很实用的实战思科路由器NAT案例配置详解,路由器是利用NAT技术,把内网的多个IP与端口映射 到外网IP(WAN口)的端口进行通讯
  • cisco NAT网络地址转换

    2018-10-31 13:12:02
    NAT(Network Address Translation)网络地址转换,NAT提供一个连接互联网简单的方式,将内部网络用户的私网地址转换成外部公网地址,并在NAT地址转换表中记录转换项。当外部网络数据返回时,将根据NAT转换表项,将...
  • cisco NAT 的配置例子

    2011-12-21 13:48:28
    详细介绍NAT的配置。给出的事show run中的信息,关于NAT的配置都有相应的注释。
  • 思科防火墙ASA5520 外观网络拓扑图如下内网 网段 192.168.2.0/24公网IP地址 118.25.235.100公网IP地址网关:118.25.235.1.1防火墙内网IP:192.168.2.1/24配置步骤:1、基本配置及配置内外网接口 conf t hostname ASAFW...
  • cisconat实验

    千次阅读 2020-05-22 12:16:16
    目录 实验要求 实验拓扑 配置 创建Vlan ... NAT 测试 一:实验要求: 1.pc动态获取ip 2.pc在不同的vlan 3.内网全达,并可以访问外网,外网可以访问内网服务器 二: 实验拓扑 三:配置...
  • 思科NAT配置

    2019-10-10 09:12:18
    思科NAT配置 interface GigabitEthernet0/1 ip address 12.1.1.1 255.255.255.0 ip nat outside 先配置出方向的 interface GigabitEthernet0/0 ip address 192.168.1.254 255.255.255.0 ip nat inside 再配置入方向...
  • 利用GNs3模拟实验NAT转换(p1能ping通)一.pc配置Int fa1/0(config-if)#ip add 192.168.10.1 255.255.255.0(config-if)#exit(config)#no ip routing(关闭路由功能 )(config)#end二,R1配置R1(config)#int f1/1R1...
  • 了解思科网络设备的配置基本特点及 IOS 命令基本操作方法 了解NAT(Network Address Translation)的工作原理及基本配置 二、实验内容 1.创建拓扑 路由器连线不上请开启新的端口,如何开启自行百度,不在多写 实验...
  • 彻底理解Cisco NAT内部的一些事

    千次阅读 2013-09-16 19:29:12
    很多在Cisco配置过NAT的人都有过一个疑问,那就是inside和outside的区别!以下是Cisco官方文档上关于NAT执行顺序的说明: 注意红色和蓝色圈住的部分,对于inside-outside而言,NAT发生在路由之后,而对于outside-...
  • 思科NAT和PAT(基础)

    2017-06-06 15:00:31
    思科NAT和PAT 一.地址转换技术1.内网能够主动访问外网,外网不能主动访问内外网;2.内网安全;3.节省公网ip地址 缺点 慢;4.PAT 端口地址转换 节省公网ip 替换源端口和源地址;5.NAT 不节省公网ip 一个公网地址替换...
  • CISCO nat实例

    2020-10-17 15:32:37
    原文: https://blog.51cto.com/11806823/2071148
  • cisco思科NAT配置

    2009-03-04 15:40:59
    思科NAT配置介绍,很详细 思科自己的资料,详细 可供自学或当作参考书
  • 思科 NAT

    2019-08-22 20:17:40
    IP地址 私有IP地址 A:10.0.0.0~10.255.255.255 ...NAT 2个方向: inside outside 4个地址 内部本地地址 inside local 内部全局地址 inside global 外部本地地址 outside local 外部全局地址 outsi...
  • Cisco NAT端口映射

    千次阅读 2018-12-06 10:52:57
    实验环境:10.0.0.1/8 做SMTP服务器 10.0.0.2/8做WEB服务器 实验目的:以一个公网地址61.159.62.130可以访问10.0.0.1/8SMTP服务器和10.0.0.2/8WEB 服务器 tcp协议25端口号为邮箱服务器端口号,http为80 ...
  • CISCONAT配置.pdf

    2021-10-08 23:37:58
    CISCONAT配置.pdf
  • Cisco配置NAT

    2019-09-11 21:26:09
    前言: 最近整理一些以前的学习笔记(有部分缺失,会有些乱,...NAT(网络地址转换) 1、NAT作用: 将内部网络的IP地址(私有)翻译成另一个IP地址(公网),使内部网络可以连接到互联网等外部网络上。 2、NAT优点: 节...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 13,160
精华内容 5,264
关键字:

cisconat