精华内容
下载资源
问答
  • cisco三层交换机vlan配置
    万次阅读 多人点赞
    2020-06-27 15:36:47

    Cisco三层交换机实现vlan间路由的配置

    拓扑图:

    在这里插入图片描述
    一、配置要求如下:
    本次测试使用cisco Packet Tracer7.0模拟器进行,请按照实验操作文件(pka)的要求完成配置任务。pka文件中的拓扑和设备命名均不许修改,终端和网络设备接口的IP地址按要求进行分配。本次测试的时长为80分钟,系统将自动对各个配置点和连通情况进行测评。
    二、设备命名和IP地址分配
    请严格按下表分配IP地址

    设备名端口/接口IP地址掩码长度网关
    PC11.2Fa0172.16.11.224172.16.11.1
    PC22.2Fa0172.16.22.224172.16.22.1
    PC-R1Fa0192.168.1.324192.168.1.1
    Laptop22.3Fa0172.16.22.324172.16.22.1
    managerFa0172.16.1.224172.16.1.1
    Intra-SrvFa0172.16.200.224172.16.200.1
    DMZ-SrvFa0172.16.254.224172.16.254.1
    Inter-SrvFa06.0.0.286.0.0.1
    CSvlan11172.16.11.124-
    CSvlan22172.16.22.124-
    CSvlan1172.16.1.124-
    CSvlan200172.16.200.124-
    CSvlan100172.16.100.25424-
    CSFa0/5172.16.253.124-
    CallManagerFa0/0172.16.100.124-
    FirewallFa0/1172.16.254.124-
    FirewallFa0/0172.16.253.224-
    FirewallFa1/02.0.0.229-
    ISP1Fa1/02.0.0.129-
    ISP1Fa0/03.0.0.18-
    ISP1Fa0/15.0.0.18-
    ISP2Fa0/05.0.0.28-
    ISP2Fa0/14.0.0.28-
    ISP2S0/1/07.0.0.130-
    ISP2Fa1/08.0.0.18-
    ISP3Fa0/03.0.0.28-
    ISP3Fa0/14.0.0.18-
    ISP3Fa1/06.0.0.18-
    Div-RS0/1/07.0.0.230-

    三、实验目标要求
    1、PC11.2可以ping通DMZ-Srv、Intra-Srv,不可以ping通Inter-Srv
    2、Laptop22.3可以ping通DMZ-Srv、Intra-Srv、Inter-Srv
    3、PC-R1可以ping通DMZ-Srv、Intra-Srv、Inter-Srv以及PC22.2
    4、PC-R2和PC0可以ping通Inter-Srv ,可以访问DMZ-Srv的web服务
    5、1001、1002、2001三部IP电话可以互通
    四、配置步骤指导
    1.配置AS1和AS2两台接入层交换机

    • a) 创建vlan
    • b) 把接口加入vlan

    2. 配置CS核心交换机

    • a) 启用三层路由功能
    • b) 设置trunk封装模式为802.1q,设置与接入层交换机相连的端口为trunk模式
    • c) 创建vlan,把相应接口加入vlan
    • d) 为vlan虚接口设置IP地址
    • e) 设置Fa0/5端口为路由模式,设置端口IP地址
    • f) 设置默认路由指向出口路由器firewall

    3. 配置校园网的Firewall路由器,使之能够访问百度

    • a) 配置两条静态路由,一条默认路由指向互联网,一条路由指向校园网
    • b) 配置nat地址转换,使得校园网PC能够访问互联网
      Ø 设置转换访问控制列表(使用扩展访问控制列表)
      Ø 设置地址转换规则
      Ø 设定inside和outside接口
    • c) 配置静态地址映射,使得互联网能访问DMZ-Srv服务器(启用服务器http服务)
      Ø 方法1:使用端口映射
      Ø 方法2:把2.0.0.3映射到校园网
    • d) 配置控制列表禁止PC11.2访问互联网
      Ø 设置扩展访问控制列表,允许PC11.2访问DMZ-Srv、禁止PC11.2访问其他地址、允许所有IP流量
      Ø 把访问控制列表应用于Firewall校园网接口入方向上

    4. 配置ISP1、ISP2、ISP3互联网路由器

    • a) 配置loopback地址作为路由器ID
    • b) 启用ospf路由协议并宣告直连网络
    • c) 检查每台路由器的路由表

    5. 配置Div-R分公司路由器

    • a) 配置路由器接入链路封装格式为PPP
    • b) 配置缺省路由指向ISP2
    • c) 配置NAT网络地址转换(注意使用扩展访问控制列表)

    6. 配置wlan无线接入

    • a) 在无线AP和无线路由器上设置SSID为AP1和AP2、认证方式为WAP2,AP1密码为12345678,AP2密码为87654321
    • b) 在两台笔记本上配置无线网卡,分别接入无线AP和无线路由器

    7. 配置PPPoE接入

    • a) 配置接入cloud的DSL映射
    • b) 配置ISP2路由器支持PPPoE接入,使用AAA认证服务器
    • c) 配置Inter-Srv作为AAA认证服务器
    • d) 在pc0使用PPPoE Dialer接入网络,ipconfig查看地址并ping6.0.0.2
    • e) 配置无线路由器使用PPPoE接入网络

    8. 配置虚拟专用网,因国家规定,VPN的配置本文不提及,如有作业问题请留言

    9. 配置VoIP

    • a) 把总部IP电话和callmanager的接入端口加入到voice vlan1
    • b) 把分公司IP电话和Div-R向校园网的接入端口加入到voice vlan1
    • c) 在公司总部配置callmanager ,测试总部两部电话的连通性
    • d) 在分公司配置Div-R出口路由器作为callmanager,检查分公司IP电话
    • e) 把总部IP电话和callmanager的接入端口加入到vlan100
    • f) 在CS上设置VLAN100的虚接口地址为172.16.100.2
    • g) 在总部callmanager上设置默认路由指向172.16.100.2
    • h) 配置两台callmanager点对点连接,测试总部到分公司电话的连通性

    详细配置命令如下:

    1、配置AS1AS2两台接入层交换机
    		a)创建vlan
    		b)把接口加入vlan
    	AS1AS1(config)#
    		AS1(config)#vlan 11
    		AS1(config)#vlan 22
    		AS1(config-vlan)#int f0/2
    		AS1(config-if)#switchport mode access 
    		AS1(config-if)#switchport access vlan 11
    		AS1(config-vlan)#int f0/23
    		AS1(config-if)#switchport mode access 
    		AS1(config-if)#switchport access vlan 22
    		AS1(config-if)#
    	AS2:
    		AS2>en
    		AS2#conf t
    		AS2(config)#vlan 22
    		AS2(config-vlan)#int f0/2
    		AS2(config-if)#switchport mode access 
    		AS2(config-if)#switchport access vlan 22
    		AS2(config-if)#
    		
    2、配置CS核心交换机
    	a)启用三层路由功能
    		CS>en
    		CS#conf t
    		CS(config)#ip routing 									// 启用三层路由功能
    	b)设置trunk封装模式为802.1q,设置与接入层交换机相连的端口为trunk模式
    		CS(config)#int f0/1
    		CS(config-if)#switchport trunk encapsulation dot1q 		// 设置trunk封装模式为802.1q,
    		CS(config-if)#switchport mode tr
    		CS(config-if)#switchport mode trunk 					// 设置与接入层交换机相连的端口为trunk模式
    		CS(config-if)#
    		CS(config-if)#int f0/2
    		CS(config-if)#switchport tr en dot1q 
    		CS(config-if)#sw mo tr
    		CS(config-if)#sw mo trunk 
    		CS(config-if)#
    	c)创建vlan,把相应接口加入vlan
    		CS(config-if)#vlan 11									// 创建 Vlan,把相应接口加入 Vlan
    		CS(config-vlan)#vlan 22
    		CS(config-vlan)#vlan 100
    		CS(config-vlan)#vlan 200
    		
    		CS(config-vlan)#int f0/24
    		CS(config-if)#switchport mode ac
    		CS(config-if)#switchport mode access 
    		CS(config-if)#switchport ac
    		CS(config-if)#switchport access vlan 200
    		
    	d)为vlan虚接口设置IP地址
    		CS(config-if)#
    		CS(config-if)#int vlan 11
    		CS(config-if)#ip add 172.16.11.1 255.255.255.0
    		CS(config-if)#int vlan 22
    		CS(config-if)#ip add 172.16.22.1 255.255.255.0
    		CS(config-if)#int vlan 200
    		CS(config-if)#ip add 172.16.200.1 255.255.255.0
    	e)设置Fa0/5端口为路由模式,设置端口IP地址
    		CS(config-if)#
    		CS(config)#int f0/5
    		CS(config-if)#no sw
    		CS(config-if)#no switchport 
    		CS(config-if)#ip add 172.16.253.1 255.255.255.0
    		CS(config-if)#
    	f)设置默认路由指向出口路由器firewall
    		CS(config-if)#exit
    		CS(config)#ip route 0.0.0.0 0.0.0.0 172.16.253.2
    		CS(config)#
    
    3、配置 Firewall 出口路由器
    	a)配置两条静态路由,一条默认路由指向互联网,一条路由指向校园网
    		Router>en
    		Router#conf t
    		Router(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.1
    		Router(config)#ip route 172.16.0.0 255.255.0.0 172.16.253.1
    		Router(config)#
    	
    	b)配置nat地址转换,使得校园网PC能够访问互联网
    		NAT					使用扩展访问控制列表 101
    		  				使用扩展访问控制列表 102
    		禁止11.2访问互联网	使用扩展访问控制列表 103
    		Ø 设置转换访问控制列表(使用扩展访问控制列表)
    			Router(config)#
    			Router(config)#ac
    			Router(config)#access-list 101 de
    			Router(config)#access-list 101 deny ip 172.16.0.0 0.0.255.255 192.168.1.0 0.0.0.255
    			Router(config)#access-list 101 per ip 172.16.0.0 0.0.255.255 any
    		Ø 设置地址转换规则
    			Router(config)#ip nat i
    			Router(config)#ip nat inside s
    			Router(config)#ip nat inside source l
    			Router(config)#ip nat inside source list 101 int f1/0 ov
    			Router(config)#ip nat inside source list 101 int f1/0 overload 
    		Ø 设定inside和outside接口
    			Router(config)#int f1/0
    			Router(config-if)#ip nat ou
    			Router(config-if)#ip nat outside 
    			Router(config-if)#int f0/0
    			Router(config-if)#ip nat in
    			Router(config-if)#ip nat inside 
    	
    	c)配置静态地址映射,使得互联网能访问DMZ-Srv服务器(启用服务器http服务)
    		Router(config-if)#exit
    		Router(config)#ip nat inside source s
    		Router(config)#ip nat inside source static 172.16.254.2 2.0.0.3
    		Router(config)#int f0/1
    		Router(config-if)#ip nat in
    		Router(config-if)#ip nat inside 
    		Router(config-if)#
    	
    	d)配置控制列表禁止PC11.2访问互联网
    		( ☆☆☆建议最后设置该规则☆☆☆ )
    		Ø 设置扩展访问控制列表,允许PC11.2访问DMZ-Srv、禁止PC11.2访问其他地址、允许所有IP流量
    			access-list 103 deny ip 172.16.11.2 255.255.255.255 any
    			access-list 103 permit ip 172.16.11.2 255.255.255.255 172.16.254.2 255.555.255.0
    			access-list 103 permit ip any
    		Ø 把访问控制列表应用于Firewall校园网接口入方向上
    			int f0/0 
    			ip access-group 103 out 
    
    4、配置ISP1ISP2ISP3互联网路由器
    	a)配置loopback地址作为路由器ID
    	
    	b)启用ospf路由协议并宣告直连网络
    	ISP1:
    		Router>en 
    		Router#conf t
    		Router(config)#route osp
    		Router(config)#route ospf 1
    		Router(config-router)#netw 2.0.0.0 0.0.0.7 area 0
    		Router(config-router)#netw 3.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 5.0.0.0 0.255.255.255 area 0
    		Router(config-router)#
    	ISP2:
    		Router>en
    		Router#conf t
    		Router(config)#route os
    		Router(config)#route ospf 1
    		Router(config-router)#netw 4.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 5.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 8.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 7.0.0.0 0.0.0.3 area 0
    		Router(config-router)#
    	ISP3:
    		Router>en
    		Router#conf t
    		Router(config)#route os
    		Router(config)#route ospf 1
    		Router(config-router)#netw 3.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 4.0.0.0 0.255.255.255 area 0
    		Router(config-router)#netw 6.0.0.0 0.255.255.255 area 0
    		Router(config-router)#
    		
    	c)检查每台路由器的路由表
    		#sh ip route 
    		
    5、配置Div-R分公司路由器
    	a)配置路由器接入链路封装格式为PPP	( 两台路由器均需要配置 )
    		ISP2(config)# interface serial 0/1/0
    		ISP2(config-if)# clock rate 2000000					// 配置接口的时钟速率
    			// 在 ☆☆☆ 远离时钟 ☆☆☆ 一端配置时钟速率会有该提示:This command applies only to DCE interfaces
    			// 因此,应该是在☆☆☆靠近时钟☆☆☆一端( 主认证方 )配置,
    		ISP2(config-if)# encapsulation ppp				// 配置接口的封装格式为PPP
    		ISP2(config-if)# ppp authentication pap			// 认证方式为PAP加密
    		ISP2(config)# username user1 password 0 123		// 主认证方配置
    		
    		Div-R(config)# interface serial 0/1/0	
    		Div-R(config-if)# encapsulation ppp				// 配置接口的封装格式为PPP
    		Div-R(config-if)# ppp authentication pap			// 认证方式为PAP加密
    		Div-R(config-if)# ppp pap sent-username user1 password 0 123		// 被认证方配置
    		
    	b)配置缺省路由指向ISP2
    		ip route 0.0.0.0 0.0.0.0 7.0.0.1
    	
    	c)配置NAT网络地址转换(注意使用扩展访问控制列表)
    		access-list 101 deny ip 192.168.1.0 0.0.0.255 172.16.0.0 0.0.255.255
    		access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    		ip nat inside source list 101 int s0/1/0 overload 
    		int s0/1/0 
    		  ip nat outside
    		int f0/0
    		  ip nat inside
    
    6、配置wlan无线接入
    	a)在无线AP和无线路由器上设置SSIDAP1AP2、认证方式为WAP2AP1密码为12345678AP2密码为87654321
    		AP ---> Config ---> Port 1 ---> SSID: AP1 WPA2-PSK: 12345678
    	
    	b)在两台笔记本上配置无线网卡,分别接入无线AP和无线路由器
    		Laptop22.3:手动配置静态 IP 地址172.16.22.3
    
    7、配置PPPoE接入
    	a)配置接入cloud的DSL映射
    		Cloud0 ---> DSL ---> Modem4 <-> Ethernet6
    							 Modem5 <-> Ethernet6
    	b)配置ISP2路由器支持PPPoE接入,使用AAA认证服务器
    		int f1/0
    		  ip address 8.0.0.1 255.0.0.0
    		  pppoe enable								// 配置接口启用pppoe
    
    		ip local pool mypool 8.0.0.10 8.0.0.100		// 配置地址池
    
    		 # username user1 password 0 123			// 配置本地用户认证方式的用户名密码
    		Router(config)#aaa new-model 				// 启用 AAA 
    		Router(config)#aaa authentication ppp default group radius 	// 使用 Radius 对所有 PPP 用户进行身份验证
    		Router(config)#radius-server host 6.0.0.2 key 123			// 指定外部 AAA 服务器,设置预共享密钥
    
    		int virtual-template 1					// 定义虚拟模板
    		  ip unnumbered f1/0 					// 借用以太口地址
    		  peer default ip address pool mypool 	// 设定地址池
    		  ppp authentication chap				// 设定认证方式
    
    		vpdn enable 					// 全局启用虚拟拨号
    		vpdn-group mygroup 				// 定义虚拟拨号组
    		  accept-dialin					// 允许拨号接入
    		  protocol pppoe 				// 接入协议为pppoe
    		  virtual-template 1			// 设定虚拟模板
    		
    	c)配置Inter-Srv作为AAA认证服务器
    		Service ---> AAA ---> 
    			Network Configuration:
    				pppoe 4.0.0.2 Radius 123
    					  8.0.0.1 Radius 123
    			User Setup:
    				u1 		123		// 用于 WireLess 认证 
    				test 	123		// 用于 PC0 认证
    	
    	d)在pc0使用PPPoE Dialer接入网络,ipconfig查看地址并ping6.0.0.2
    		Desktop ---> PPPoE ---> User Name: u1 Password: cisco
    		
    	e)配置无线路由器使用PPPoE接入网络
    		Setup ---> PPPoE ---> Username: test Password: 123  Save Settings
    		WireLess ---> Basic WireLess Settings ---> Network Name: AP2  Standard Channel: 11
    				 ---> WireLess Security ---> Security Mode: WAP2 Persional  AES  87654321
    	
    8、配置虚拟专用网,因国家规定,VPN的配置本文不提及,如有作业问题请留言
    		
    9、配置VoIP
    	a)把总部IP电话和callmanager的接入端口加入到voice  vlan1
    		AS1:
    			vlan 100
    			int f0/1
    			switchport mode access 
    			switchport access vlan 100
    			switchport voice vlan 1
    		AS2:
    			vlan 100
    			int f0/1
    			switchport mode access 
    			switchport access vlan 100
    			switchport voice vlan 1
    		CS:
    			int f0/6
    			switchport mode access 
    			switchport access vlan 100
    			switchport voice vlan 1
    			
    	b)把分公司IP电话和Div-R向校园网的接入端口加入到voice  vlan1
    		Switch3:
    			int f0/1
    			switchport voice vlan 1
    			switchport mode access
    			int f0/24
    			switchport mode access
    			switchport voice vlan 1
    			
    	c)在公司总部配置callmanager ,测试总部两部电话的连通性
    		CallManager:
    			# 配置接口
    		# int f0/0
    		# ip add 172.16.100.1 255.255.255.0
    			# 配置DHCP
    		# ip dhcp pool voice
    		# network 172.16.100.0 255.255.255.0
    		# default-router 172.16.100.1
    		# option 150 ip 172.16.100.1
    			# 配置呼叫服务
    		# telephony-service
    		# max-dn 10
    		# max-ephone 10
    		# ip source-address 172.16.100.1 port 2000
    		# auto assign 1 to 10
    			# 为电话配置号码
    		# ephone-dn 1
    		# number 1001
    		# ephone-dn 2
    		# number 1002 
    		
    	d)在分公司配置Div-R出口路由器作为callmanager,检查分公司IP电话
    		Router:
    			# 配置接口
    		# int f0/0
    		# ip add 192.168.1.1 255.255.255.0
    			# 配置DHCP
    		# ip dhcp pool voip
    		# network 192.168.1.0 255.255.255.0
    		# default-router 192.168.1.1
    		# option 150 ip 192.168.1.1
    			# 配置呼叫服务
    		# telephony-service
    		# max-dn 10
    		# max-ephone 10
    		# ip source-address 192.168.1.1 port 2000
    		# auto assign 1 to 10
    			# 为电话配置号码
    		# ephone-dn 1
    		# number 2001
    	e)把总部IP电话和callmanager的接入端口加入到vlan100
    		在 9、a) 中已经完成该步操作
    		
    	f)CS上设置VLAN100的虚接口地址为172.16.100.254
    		int vlan 100
    		ip address 172.16.100.254 255.255.255.0
    		
    	g)在总部callmanager上设置默认路由指向172.16.100.254
    		ip route 0.0.0.0 0.0.0.0 172.16.100.254
    		
    	h)配置两台callmanager点对点连接,测试总部到分公司电话的连通性
    		CallManager:
    		dial-peer voice 1 voip
    		 destination-pattern  2...
    		 session target ipv4:192.168.1.1
    		
    		Router-FW:
    		dial-peer voice 1 voip
    		 destination-pattern  1...
    		 session target ipv4:172.16.100.1
    	
    	
    	限制 11.2 上网
    	d)配置控制列表禁止PC11.2访问互联网
    		( ☆☆☆建议最后设置该规则☆☆☆ )
    		Ø 设置扩展访问控制列表,允许PC11.2访问DMZ-Srv、禁止PC11.2访问其他地址、允许所有IP流量
    			access-list 103 deny ip 172.16.11.2 255.255.255.255 any
    			access-list 103 permit ip 172.16.11.2 255.255.255.255 172.16.254.2 0.255.255.255
    			access-list 103 permit ip any
    		Ø 把访问控制列表应用于Firewall校园网接口入方向上
    			int f0/0 
    			ip access-group 103 out 
    
    更多相关内容
  • 思科三层交换机VLAN配置 内部网络全部使用10.186.x.x网段,SW2和SW3两个交换机连接两个学院, Sw2学院有电脑500台,sw3学院有电脑200台,合理分配IP地址段,避免浪费, 两个学院可以互相访问,也可以访问内网的web ...
  • 由于期末在即,课程设计又是计科生的梦魇,所以我快马加鞭写了这篇三层交换机vlan划分的实验报告,希望能给那些和我一样受课程设计困扰的同学一些建议和帮助。示例:相信这个结构的拓扑图大家都熟悉吧。 2、Switch1...

    系列文章目录

    提示:这里可以添加系列文章的所有文章的目录,目录需要自己手动添加


    提示:写完文章后,目录可以自动生成,如何生成可参考右边的帮助文档


    前言

    由于期末在即,课程设计又是计科生的梦魇,所以我快马加鞭写了这篇三层交换机vlan划分的实验报告,希望能给那些和我一样受课程设计困扰的同学一些建议和帮助。

    提示:以下是本篇文章正文内容,下面案例可供参考

    一、拓扑图

    示例:相信这个结构的拓扑图大家都熟悉吧。
    在这里插入图片描述

    二、Switch配置

    1、Switch0配置

    代码如下(示例):

    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    %SYS-5-CONFIG_I: Configured from console by console
    rker.
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#e
    Switch(config)#int f0/1
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#int f0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#e
    Switch(config)#int f0/2
    Switch(config-if)#switchport mode trunk 
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
    
    该处使用的url网络请求的数据。
    
    下面展示一些 `内联代码片`。
    
    ```#
    

    2、Switch1配置

    //
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 20
    Switch(config-vlan)#e
    Switch(config)#int f0/3
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#int f0/2
    Switch(config-if)#switchport mode access 
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#int f0/1
    Switch(config-if)#switchport mode trunk 
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    
    
    
    

    3、三层Switch0配置

    // Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#vlan 20
    Switch(config-vlan)#e
    Switch(config)#ip routing
    Switch(config)#int vlan 10
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    
    Switch(config-if)#ip add
    Switch(config-if)#ip address 192.18.1.254 255.255.255.0
    Switch(config-if)#no shutdown 
    Switch(config-if)#int vlan 20
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    下面展示一些 `内联代码片`

    三、ping通试验

    1、pc0 ping pc2

    在这里插入图片描述

    2、pc2 ping pc3

    在这里插入图片描述

    提示:到这一步也全部ping通,实验的第一步也完成。关于DHCP获取ip的实验也可以加进来,前面也写过关于这一方面的实验。

    展开全文
  • Cisco三层交换机的详细配置

    万次阅读 多人点赞 2021-04-08 17:01:58
    ** 本文适用于新手小白...文章目录一、什么是三层交换机二、配置交换机步骤1.配置二层交换机2.配置三层交换机3.配置两台路由器以及最后一台电脑 一、什么是三层交换机 1.三层交换机 = 三层路由+二层交换机 2.工作在

    **

    本文适用于新手小白以及微微基础的同学来用于参考,实验是在Cisco Packet Tracer Student 进行,实验最终效果如图所示,所有命令配置与图中的一致。

    效果图

    使用到的机器型号为:五台电脑,一台服务器,三个普通交换机(2960型号),一个三层交换机(3560-24PS),两台普通服务器(2811)


    一、什么是三层交换机

    1.三层交换机 = 三层路由+二层交换机
    2.工作在OSI网络标准模型的第三层:网络层。
    3.特点:一次路由,多次转发。
    4.作用:三层交换机的作用是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的

    二、配置交换机步骤

    1.配置二层交换机

    按照要求,我们首先需要配置好三个交换机的五个VLAN区域,方便后续通信,还需将F0/2配置为turnk端口。第一台交换机具体命令如下:

    第一台交换机:
    en //进入特权模式
    conf t //进入全局模式 
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 10 //将F0/1划分为VLAN 10
    int f0/3
    switchport access vlan 20 //将F0/3划分为VLAN 20
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    
    第二台交换机:
    en
    conf t
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 30 //将F0/1划分为VLAN 30
    int f0/3
    switchport access vlan 40 //将F0/3划分为VLAN 40
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    
    第三台交换机
    en
    conf t
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //创建五个vlan区域
    exit //退出
    int f0/1 //进入F0/1
    switchport access vlan 50 //将F0/1划分为VLAN 10
    int f0/2
    switchport mode trunk //将F0/2配置为trunk端口,为交换机与服务器之间的相联
    

    至此,三台交换机配置完毕,我们开始三层交换机的配置

    2.配置三层交换机

    这台三层交换机的配置有些繁琐,但我们只要掌握其中的思路,剩下的只是重复的配置。具体命令如下:

    en
    conf t 
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    vlan 50 //配置vlan
    exit
    //配置vlan的ip,后续作为各vlan的网关,方便DHCP的ip下发,以及数据上行。
    int vlan10
    ip address 10.1.1.254 255.255.255.0
    int vlan20
    ip address 10.1.2.254 255.255.255.0
    int vlan30
    ip address 10.1.3.254 255.255.255.0
    int vlan40
    ip address 10.1.4.254 255.255.255.0
    int vlan50
    ip address 10.1.5.254 255.255.255.0 //至此vlan的IP地址设置完毕,设置途中可能会出现错误,确认命令无误后回车再写一遍命令就好了。
    
    //设置F0/1,F0/2,F0/4为turnk口
    int f0/1
    switchport trunk encapsulation dot1q //这一步的命令为确认端口协议为802.1Q 三层交换机有两个协议,一个是ISL,另一个就是802.Q1,配置前需要指定协议。
    switchport mode trunk 
    f0/2与f0/3同理,此处省略。
    
    配置DHCP服务器
    ip dhcp excluded-address 10.1.1.1 10.1.1.99 //保留1-99的IP地址不做分配
    ip dhcp pool v10 //配置DHCP地址池名字为v10
    network 10.1.1.0 255.255.255.0 //配置地址池网段
    default-router 10.1.1.254 //配置网关,(这就与前面配的vlan10的IP地址对应上了)
    dns-server 10.1.5.1 //dns服务器
    
    ip dhcp excluded-address 10.1.2.1 10.1.2.99 //保留1-99的IP地址不做分配
    ip dhcp pool v20 //配置DHCP地址池名字为v20
    network 10.1.2.0 255.255.255.0 //配置地址池网段
    default-router 10.1.2.254 //配置网关,(这就与前面配的vlan10的IP地址对应上了)
    dns-server 10.1.5.1 //dns服务器
    这里vlan10和vlan20区域的DHCP就配置好了,我们还需要按照此步骤配置vlan30,vlan40
    vlan50则不需要配置,因为vlan50里面是服务器,而服务器的IP是固定的,所以不需要DHCP来分配IP。 
    
    Switch(config)# ip routing 在三层交换机启动路由功能。
    
    配置好这步后,点击所在vlan10的计算机,点击IP配置,DHCP,好的,你已经成功一半了。
    接下来在打开计算机中的CMD ping一下其他计算机的IP,等待回包后。你已经成功四分之三了
    
    
    
    
    

    这步可以说是灵魂所在,有点复杂,但绝对正确,一遍不明白就多思考配制几遍,命令是壳,思想是核。对了,一定别忘了配置后启动三层交换机路由转发功能,这是总闸。


    3.配置两台路由器以及最后一台电脑

    这里考查的就是路由器的配置,以及三层交换机上的F0/3口的配置。就差这一嘚瑟了。

    1.按照要求,先配置最后一台电脑的固定IP。进入电脑——IP配置
    在这里插入图片描述
    接来下我们开始配置的第一台路由器
    在这里插入图片描述

    首先配置F0/0
    Router(config)#int f0/0
    Router(config-if)#ip ad
    Router(config-if)#ip address 80.1.1.254 255.255.255.0
    Router(config-if)#no sh //重启F0/1口
    
    配置F0/1
    Router(config-if)#int f0/1
    Router(config-if)#ip address 70.1.1.2 255.255.255.0
    Router(config-if)#no sh
    
    接下来设置目标网段以及下一跳转的路由器
    由于我们没有目标网段,所以设置为0网段
    Router(config)#ip route 0.0.0.0 0.0.0.0 70.1.1.1
    第一台路由配置完毕
    

    接来下我们开始配置的第二台路由器
    在这里插入图片描述

    Router(config)#int f0/1
    Router(config-if)#ip address 70.1.1.1 255.255.255.0
    Router(config-if)#no sh
    
    Router(config)#int f0/0
    Router(config-if)#ip address 60.1.1.2 255.255.255.0
    Router(config-if)#no sh
    设置双向目标地址以及下一跳转的路由器IP
    ip route 80.1.1.0 255.255.255.0 70.1.1.2
    ip route 0.0.0.0 0.0.0.0 60.1.1.1
    
    

    最后一步,设置三层交换机上的F0/3口

    首先将二层端口升级为三层端口,否则二层配置不了IP地址
    Switch(config)#int f0/3
    Switch(config-if)#no switchport 
    Switch(config-if)#ip address 60.1.1.1 255.255.255.0
    Switch(config-if)#exit
    配置好IP地址后,由于与目标IP中间有两个路由器,所以需要在路由表中
    写入两台路由的网段
    Switch(config)#ip route 80.1.1.0 255.255.255.0 60.1.1.2
    Switch(config)#ip route 70.1.1.0 255.255.255.0 60.1.1.2
    
    

    实验结束
    结果:实现全网互通。

    展开全文
  • cisco三层交换机怎么设置实现vlan间的通讯?层交换机是不能实现vlan间通讯的,这就需要三层路由功能,而3560默认情况下是二层交换机,这就需要多交换机进行一些配置,实现vlan间的通讯,下面通过具体实验对其进行...
  • 通过配置三层交换机或路由器实现VLAN间的通信,通过路由器实现vlan间通信(单臂路由)在路由器与交换机的端口上配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为下一跳地址),并在子接口上封装802....
  • 配置要求:1.完成设备名称和IP地址等的设置。2.完成telnet线路配置使管理终端能够远程访问所有网络设备。...3.按图示完成端口汇聚设置。...S1、B1为服务器模式,其他设备为...6.指定S1为所有VLAN的根交换机,并确保B1-B...

    配置要求:

    1.完成设备名称和IP地址等的设置。

    2.完成telnet线路配置使管理终端能够远程访问所有网络设备。远程访问密码为:123456,enable密码为1234。

    3.按图示完成端口汇聚设置。

    4.建立VTP域,域名mydomain1,密码111111。S1、B1为服务器模式,其他设备为客户端模式。(暂不配置)

    5.按图示完成VLAN及端口配置。

    6.指定S1为所有VLAN的根交换机,并确保B1-B2、B3-B4间链路处于阻断状态。(咱不配置)

    7.实现VLAN间的通信,确保各培训部间终端能够ping通。

    拓扑结构

    企业网络典型组网拓扑图

    设备配置

    (1)为每台PC和Server配置IP地址、子网掩码和网关(网关为interface vlan X 的ip地址)

    网关用于实现设备之间的三层通信,即路由,默认网关可先不填,因为还没有配置逻辑接口vlan的ip地址;也可以先填写,一般网关地址都为x.x.x.254,这里可以先写上192.168.2.254,后面再进行配置,其他PC配置略。

    配置PC的ip地址、子网掩码以及默认网关

    (2)为每台网络设备配置管理IP,配置命令如下,其他配置略:

    Switch>enable

    Switch#configure terminal

    #进入逻辑vlan接口1

    Switch(config)#interface vlan 1

    #配置ip地址,用于远程管理telnet登录使用

    Switch(config-if)#ip address 192.168.1.3 255.255.255.0

    #激活逻辑端口

    Switch(config-if)#no shutdown(用于激活接口,必须)

    网络设备管理地址配置

    (3)完成telnet线路配置

    #进入特权模式

    Switch>enable

    #进入配置模式

    Switch#configure terminal

    #配置进入到路由器特权模式的密码

    Switch(config)#enable password 1234

    #进入路由器的 VTY 虚拟终端下,“vty 0”表示用户连接数,共1个虚拟终端

    Switch(config)#line vty 0

    #配置 vty 的密码,即 telnet 密码

    Switch(config-line)#password 123456

    Switch(config-line)#login

    Switch(config-line)#end

    telnet线路配置

    其中 enable password 1234,用于配置进入特权模式所需要的密码

    password 123456,用于配置telnet管理员的远程登录密码

    配置完成后使用管理终端进行telnet连接,如图所示

    使用终端远程登录网络设备

    其他设备telnet配置略

    (4)端口汇聚配置

    构成EtherChannel的端口必须具有相同的特性,如双工模式、速度、Trunking的状态等。

    在两台三层交换机上分别配置链路聚合:

    Switch>enable

    Switch#configure terminal

    #创建以太通道,要指定一个唯一的通道组号,组号的范围是1~6的正整数。要取消EtherChannel时用“no interface port-channel 1”

    Switch(config)#interface port-channel 1

    Switch(config-if)#exit

    #进入端口21-22

    Switch(config)#interface range fastEthernet 0/21-22

    #将物理接口指定到已创建的通道中。

    Switch(config-if-range)#channel-group 1 mode desirable

    Switch(config-if-range)#no shutdown

    Switch(config-if-range)#end

    Switch#write

    3560交换机链路聚合配置

    配置完成后,使用show etherchannel summary命令,查看链路聚合配置情况

    查看链路聚合结果

    (5)trunk模式配置

    根据拓扑结构,在每台交换机上分别将用于连接网络设备的端口改为trunk模式。

    2960配置命令如下:

    配置二层交换机之间互连的端口为trunk类型

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface fastEthernet 0/24

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    2960二层交换机trunk口配置

    对于3560三层交换机,需要将封装类型改为dot1q,再将端口类型设置为trunk,配置如下:

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface f0/1

    #配置 trunk 链路的封装类型,同一链路的两端封装要相同。有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    Switch(config)#interface f0/2

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #同时对于链路聚合的port-channel 1 也要设置为trunk模式,配置通道中的物理接口的属性

    Switch(config)#interface port-channel 1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #另外一台3560交换机trunk模式配置相同

    3560三层交换机trunk口配置

    (6)VLAN配置

    在4个二层交换机上配置相应VLAN

    #创建VLAN2,VLAN3

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch#configure terminal

    Switch(config)#interface range f0/1-8

    #将接口f0/1-8划分到vlan2中,把交换机端口的模式改为 access 模式,说明该端口是用于连接计算机的,而不是用于 trunk

    Switch(config-if-range)#switchport access vlan 2

    Switch(config)#interface range f0/9-16

    #将接口f0/9-16划分到vlan3中

    Switch(config-if-range)#switchport access vlan 3

    对接入层交换机进行VLAN划分

    (7)单臂路由配置

    不同VLAN之间的通信,需要借助第三层设备,二层设备无法实现不同VLAN间的通信,可以选择路由器,三层交换机,本实验使用三层交换机进行实现,方法类似于华为设备中的VLANIF实现方式,配置逻辑接口VLAN,不同的VLAN对应配置不同的逻辑接口interface vlan x,并在接口下配置ip地址及子网掩码,此ip地址就是前文中提到的各终端设备的默认网关,对于不同VLAN中的终端设备,默认网关设置对应逻辑vlan中的ip地址即可实现三层交换机的路由功能。

    在S1交换机上创建单臂路由,配置命令如下:

    #在其中一台三层交换机S1上创建vlan即可,无需两台设备都配置,即一台作为路由器使用,另一台仍作为交换机使用

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch(config-vlan)#vlan 4

    Switch(config-vlan)#vlan 5

    Switch(config-vlan)#exit

    #开启三层交换机路由模式

    Switch(config)#ip routing

    #创建对应的逻辑接口vlan x

    Switch(config)#interface vlan 2

    #配置接口的IP地址及子网掩码

    Switch(config-if)#ip address 192.168.2.254 255.255.255.0

    #激活逻辑接口

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 3

    Switch(config-if)#ip address 192.168.3.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 4

    Switch(config-if)#ip address 192.168.4.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 5

    Switch(config-if)#ip address 192.168.5.254 255.255.255.0

    Switch(config-if)#no shutdown

    配置单臂路由

    若按照题目中要求,运行部内部电脑能够跨交换机通信,运行部和检修部之间无法ping通,信息培训部和通信培训部之间能够ping通,那么只需要将3560S1三层交换机中允许vlan2,3,4,5通过、并配置interface vlan 4 和 interface vlan 5 的ip地址即可,无需配置interface vlan2 和interface vlan 3 的ip地址(若配置会导致运行部和检修部之间也能ping通,),3560S2三层交换机中配置允许 vlan4和vlan5通过即可。

    未完待续。。。

    展开全文
  • 二、二层交换机配置 Switch# Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch...
  • 三层交换机配置: Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#vlan 30 Switch(config-vlan)#vlan 40 Switch(config-vlan)#exit Switch...
  • Cisco三层交换机VLAN配置案例PPT学习教案.pptx
  • 思科三层交换机实现不同VLAN间互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间...思科三层交换机VLAN间路由配置步骤:1、配置干道(TRUNK)在接口模式下声明该接口为trunk模式的命令格...
  • Cisco-3560三层交换机VLAN配置案例,cisco交换机的VLAN划分,通俗易懂。
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?...将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段 人事部、财务部、生产部、采购部分别属于...
  • CISCO三层交换机怎么配置DHCP服务?利用CISCO三层交换机自带的DHCP功能,可以实现多VLAN的IP地址自动分配,在三层交换机上如何配置DHCP服务呢,下面一起来看看
  • 三层交换机实现vlan间路由配置基础知识常用命令实验流程1.设计拓扑2.配置主机IP地址3.配置交换机4.验证主机是否连通5.查看三层交换机路由信息6.查看三层交换机ARP缓存 基础知识 二层交换机是利用Mac地址表进行转发...
  • CISCO三层交换机+二层交换机配置VLAN的实例[文].pdf
  • cisco3560三层交换机vlan间路由配置实例
  • 利用三层交换机实现VLAN间路由,  掌握交换机Tag VLAN的配置;  掌握三层交换机基本配置方法;  掌握三层交换机VLAN路由的配置方法; 通过三层交换机实现VLAN间相互通信
  • 使用Cisco Packet Tracer模拟器实现Cisco三层交换机实现Vlan间路由的配置脚本,内含每一步的详细操作及注释说明,包括配置接入层交换机、配置核心交换机、配置firewall路由器、配置ISP互联网路由器、配置分公司...
  • 三层交换机具备网络层的功能,实现VLAN相互访问的原理是:利用三层交换机的路由功能,通过识别数据包的IP地址,...掌握三层交换机VLAN路由的配置方法。通过三层交换机实现VLAN间相互通信。掌握三层交换机基本配置方法。
  • 步骤1:交换机trunk配置 交换机sw1配置 Switch>en Switch#conf t Switch(config)#ho sw1 sw1(config)#int f0/2 sw1(config-if)#sw mo tr sw1(config-if)#exit 交换机sw2配置 Switch>en Switch#conf t ...
  • 利用三层交换机的路由功能,实现不同vlan间的通信
  • 三层交换机VLAN配置

    2011-12-22 20:11:39
    思科模拟器上进行VLAN配置,学会如何如何划分VLAN,SVI端口的设置。。。
  • 交换机的VLAN配置三层交换机

    千次阅读 2021-11-24 09:07:04
    掌握交换机VLAN配置方法 二、【主要仪器设备或实验环境】 CiscoPacketTracer 、【实验内容与过程】 1.硬件连接(交换机用自己学号后2位+姓名来命名) 2.规划并配置电脑的IP地址并用Ping命令测试它们之间...
  • VLAN三层交换机配置

    2021-03-13 16:00:20
    文章目录VNAN三层交换机配置VLAN概述与优势分割广播域vlan的种类VLANVLAN的范围华为系统中配置VLAN的相关命令Trunk的作用如何实现交换机之间的VLAN通信交换网络中的链路类型VLAN跨交换机通信过程VLAN的标识在...
  • 主要步骤有建立网络拓扑、二层交换机的接口设置(创建VLAN、交换机的VLAN端口分配、交换机的端口分配)、三层交换机的接口设置(创建VLAN、交换机的端口分配、配置每个VLAN的接口与IP地址、开启IP路由功能)。
  • 思科三层交换机配置DHCP中继

    千次阅读 2022-06-07 15:19:27
    VLAN内的客户机能从DHCP服务器哪里获取IP地址如果VLAN2或VLAN3的客户机也需要通过这台DHCP服务器来获取IP地址 该如何操作
  • 拓扑图: 2层交换机Switch0: 2层交换机Switch0配置命令: Switch>enable #进入特权模式 Switch#configure terminal #进入配置模式 Switch(config)#vlan 10 ...
  • 3、熟练掌握三层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和三层交换机,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置三层vlan...
  • 思科三层交换机配置步骤

    万次阅读 多人点赞 2020-04-08 13:34:09
    思科三层交换机配置图如下: 配置的过程如下: 首先,设置各个PC的ip地址,子网掩码,网关 设置完成之后,进行二层交换机的设置: 在三层交换机的配置实验中 二层交换机设置的主要是vlan的设置,vlan接口的设置和...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,318
精华内容 4,527
关键字:

cisco三层交换机vlan配置