精华内容
下载资源
问答
  • 可以让不论在什么地方的电脑,只要连接上局域网之后,就可以通过自动获取Ip地址的方式获取Ip地址网关,这样的做法能够大大的节省网络成本以及网络资源,下面我们来具体的了解一下思科服务器配置dhcp服务器的方法。...

    因为现在生活中网络的流行以及广泛的使用,但企业和学校都会配备思科服务器,因为在配备了服务器之后,可以让不论在什么地方的电脑,只要连接上局域网之后,就可以通过自动获取Ip地址的方式获取Ip地址网关,这样的做法能够大大的节省网络成本以及网络资源,下面我们来具体的了解一下思科服务器配置dhcp服务器的方法。

    15872803644018.jpg

    首先各位小伙伴需要先打开思科模拟器软件,然后找出一台2811类型的路由器,以及两台2960类型的交换机和4台PC电脑,并且使用正确的电线,将每一个设备互相连接在一起。连接完成之后,需要将所有的设备重新命名,路由器命名为r1,交换机命名为sw1,另外一台交换机命名为sw2。

    命名完成之后先配置r1,配置时的命令为r1(config)#int f0/0、r1(config-if)#no sh;之后再配置路由器设备的远程登录以及密码保护,命令为r1(config)#lin vty 0 4、r1(config-line)#login local、r1(config-line)#username admin password cisco、r1(config-line)#exit、r1(config)#enable secret cisco、r1(config)#service password-encrption。

    r1路由器配置完成之后再配置交换机sw1,配置时的命令为sw1(config)#int vlan 1、sw1(config-if)#ip add 192.168.1.2 255.255.255.0、sw1(config-if)#no sh、sw1(config-if)#ex、sw1(config)#ip default-gateway 192.168.1.1。之后使用相同的方法配置sw2。

    完成之后配置vlan设定,首先需要在sw1上划分vlan2、3,然后将相应的端口加入其中,配置时的命令为sw1#conf t、Enter configuration commands, one per line. End with CNTL/Z、sw1(config)#vlan 2、sw1(config-vlan)#ex、sw1(config)#vlan 3、sw1(config-vlan)#ex、sw1(config)#int f0/4、sw1(config-if)#switchport mode access、sw1(config-if)#switchport access vlan 2、sw1(config-if)#int f0/5、sw1(config-if)#switchport mode access、sw1(config-if)#switchport access vlan 3、sw1(config-if)#ex。使用相同的方法,在sw3上面划分为lan,并且将相应的端口加入其中。

    完成之后配置单臂路由器,配置的命令为sw1(config)#int f0/1、sw1(config-if)#switchport  mode  trunk、sw1(config-if)#no  sh。

    之后在路由器r1上进行封装,配置命令为r1#conf t、Enter configuration commands, one per line.  End with CNTL/Z.、r1(config)#int f0/0、r1(config-if)#no shut、r1(config)#int f0/0.1、r1(config-subif)#encapsulation dot1Q 1、r1(config-subif)#ip add 192.168.1.1 255.255.255.0、r1(config-subif)#ex、r1(config)#int f0/0.2、r1(config-subif)#encapsulation dot1Q 2、r1(config-subif)#ip add 192.168.2.1 255.255.255.0、r1(config-subif)#ex、r1(config)#int f0/0.3、r1(config-subif)#encapsulation dot1Q 3、r1(config-subif)#ip add 192.168.3.1 255.255.255.0、r1(config-subif)#no sh、r1(config-subif)#ex。

    之后需要配置dhcp服务器,也就是配置路由器r1,命令为r1#enable、r1#conf t、r1(config)#ip dhcp excluded-address 192.168.2.1、r1(config)#ip dhcp pool vlan2、r1(dhcp-config)#net 192.168.2.0 255.255.255.0、r1(dhcp-config)#default-router 192.168.2.1、r1(dhcp-config)#dns-server 100.1.1.2、r1(config)#ip dhcp excluded-address 192.168.3.1、r1(config)#ip dhcp pool vlan3、r1(dhcp-config)#net 192.168.3.0 255.255.255.0、r1(dhcp-config)#dns-server 100.1.1.2、r1(dhcp-config)#ex。

    所有的操作步骤完成之后,配置就结束了。

    展开全文
  • 思科DHCP服务器配置实例解析首先我们应该汇总下我们所需要达到的目标:为服务器提供固定的地址,即做MAC与IP地址的绑定为客户机提供并非固定的地址,通常这会涉及到子网因为我们的实验环境限制,我们先设定第二条,...

    思科DHCP服务器配置实例解析

    首先我们应该汇总下我们所需要达到的目标:为服务器提供固定的地址,即做MAC与IP地址的绑定为客户机提供并非固定的地址,通常这会涉及到子网因为我们的实验环境限制,我们先设定第二条,检查下客户机能否得到IP地址,再设置第一条,看看是否按照我们的设定的得到IP地址。那么DHCP服务器配置文件如下:

    ddns-update-style interim;

    ignore client-updates;

    subnet 192.168.1.0 netmask 255.255.255.0 {

    # --- default gateway

    option routers 192.168.1.254;

    option subnet-mask 255.255.255.0;

    option nis-domain " sky.com";

    option domain-name " sky.com";

    option domain-name-servers 192.168.1.2;

    option time-offset -18000; # Eastern Standard Time

    # option ntp-servers 192.168.1.1;

    # option netbios-name-servers 192.168.1.1;

    # --- Selects point-to-point node (default is hybrid). Don't change this unless

    # -- you understand Netbios very well

    # option netbios-node-type 2;

    range 192.168.1.100 192.168.1.250;

    default-lease-time 21600;

    max-lease-time 43200;

    }

    保存并退出,然后重启dhcpd服务

    [root@a ~]# service dhcpd restart

    Shutting down dhcpd: [OK]

    Starting dhcpd: [OK]

    之后我们开启客户端,将客户机网卡设置为DHCP模式,然后我们可以看到客户机的IP地址为192.168.1.250,因为dhcp的IP地址倒着分发。

    将客户机进行ip与MAC的绑定,首先要获知客户机的MAC地址,Windows系统进入CMD,使用getmac命令,linux使用ifconfig可看到。之后我们修改配置文件,完整配置文件如下:

    ddns-update-style interim;

    ignore client-updates;

    subnet 192.168.1.0 netmask 255.255.255.0 {

    # --- default gateway

    option routers 192.168.1.254;

    option subnet-mask 255.255.255.0;

    option nis-domain " sky.com";

    option domain-name " sky.com";

    option domain-name-servers 192.168.1.2;

    option time-offset -18000; # Eastern Standard Time

    # option ntp-servers 192.168.1.1;

    # option netbios-name-servers 192.168.1.

    telnet和ssh登陆提示

    1;

    # --- Selects point-to-point node (default is hybrid). Don't change this unless

    # -- you understand Netbios very well

    # option netbios-node-type 2;

    range 192.168.1.100 192.168.1.250;

    default-lease-time 21600;

    max-lease-time 43200;

    host server2{

    hardware ethernet 00:0c:29:47:04:17;

    fixed-address 192.168.1.2;

    }

    }

    之后我们重启DHCP服务

    [root@a ~]# service dhcpd restart

    Shutting down dhcpd: [OK]

    Starting dhcpd: [OK]

    重启启用客户机的网卡,service network restart ,之后查看IP信息,这时我们可以看到地址已经变为192.168.1.2

    DHCP服务器配置故障排除

    1 如果遇见service dhcpd restart/start 无法启动的时候,可以试下:[root@a ~]# /usr/sbin/dhcpd start

    如果你的`配置文件有错误的话,会出现提示,主要关注的部分为line 之后的

    2 修改/etc/sysconfig/dhcpd文件,改变dhcp服务所监听的网口(在多网卡下),在DHCPDARGS=后面添加eth0

    3 另外可以关注下/var/lib/dhcpd/dhcpd.leases文件,这里面主要保存的是地址的分发

    DHCP服务器配置之防火墙的配置

    DHCP服务器主要工作在端口67上监听,然后在端口68上回应客户,所以我们需要配置防火墙,在服务器上面运行:Syetem-config-securitylevel,在other ports里面添加TCP 67 68端口即可,然后启动防火墙,运行service iptables start,然后测试,删除dhcpd.conf配置文件中绑定的部分,之后重启客户机的网卡,检测下能够正确获得到IP地址。

    DHCP服务器配置总结

    DHCP服务器配置实验至此就结束了,另外分享个技巧,在测试的时候,将2台VM虚拟的linux网卡模式调成Vmnet2模式,那样不会受到干扰。

    【思科DHCP服务器配置实例解析】相关文章:

    展开全文
  • 您可通过 DHCP 自动将可重复使用的 IP 地址分配给 DHCP 客户端。本文档举例说明了如何配置 DHCP 选项...以前,网络管理员必须用此功能手工配置在被启用的每个设备的Cisco IOS DHCP服务器。在路由器配置后,是劳动密...

    您可通过 DHCP 自动将可重复使用的 IP 地址分配给 DHCP 客户端。本文档举例说明了如何配置 DHCP 选项(例如域名系统 (DNS) 和 Windows Internet 名称服务 (WINS) 地址),以响应客户端设备 (CPE) 之后的本地客户端发出的 DHCP 请求。

    以前,网络管理员必须用此功能手工配置在被启用的每个设备的Cisco IOS DHCP服务器。在路由器配置后,是劳动密集型,费时和消耗大的去每个位置和做修改。

    结果, Cisco IOS DHCP服务器被提高为了允许配置信息自动地更新。网络管理员能配置一个或更多集中化DHCP服务器更新在DHCP池内的特定DHCP选项。远程服务器能从集中式服务器请求或导入这些选择参数。

    Cisco推荐本文的读者有这些题目知识:

    DHCP

    域名系统 (DNS)

    WINDOWS互联网名称服务(WINS)

    此配置用这些软件和硬件版本实施了并且测试:

    Cisco IOS软件版本12.2(27)

    有用于PC和客户端连接的NM-1E的两个Cisco 3660路由器

    The information in this document was created from the devices in a specific lab environment.All of the devices used in this document started with a cleared (default) configuration.If your network is live, make sure that you understand the potential impact of any command.

    Note:Cisco IOS DHCP服务功能在Cisco IOS Software Release 12.0(1)T介绍。您需要Cisco IOS软件版本12.0(2)T或以上为了用在Cisco 1700系列路由器上。关于支持DHCP服务功能的路由器的更多信息,请参阅Cisco IOS DHCP服务器文档的支持的平台部分。

    有关文档规则的详细信息,请参阅 Cisco 技术提示规则。

    在此部分,向您介绍信息配置DNS和WINS的DHCP服务器选项。‘中央’路由器为这些服务器选项被配置,并且‘远程’路由器导入这些选项。远程PC或客户端从‘远程’路由器接受这些被导入的选项在他们的DHCPACK阶段。

    Note:为了找到关于用于本文的命令的其他信息,请参见DHCP命令或请使用命令查找工具(仅限注册用户)。

    本文档使用此图中所示的网络设置:

    706dd704f1b4f43c675c8d80d57be7cd.png

    本文档使用以下配置:

    中央(3660)

    Central# show running-config

    Building configuration...

    .

    .

    .

    ip dhcp excluded-address 10.0.0.1 10.0.0.5

    !--- This range must not be assigned to DHCP clients.

    !

    ip dhcp pool Central

    network 10.0.0.0 255.255.255.0

    !--- Specify the network number and mask for DHCP clients.

    domain-name Central

    !--- Specify the domain name for the client.

    dns-server 10.0.0.2

    !--- Specify the DNS server you want to respond to DHCP clients who

    !--- need to correlate the host name to the IP address.

    netbios-name-server 10.0.0.2

    !--- Specify the Network Basic Input/Output System (NetBIOS)

    !--- WINS server (for Microsoft DHCP clients)

    !

    .

    .

    !

    interface FastEthernet0/0

    ip address 10.0.0.1 255.255.255.0

    duplex auto

    speed auto

    !

    .

    .

    !

    end

    Note:当您使用一个Cisco路由器作为DHCP服务器时,只有一个域每个DHCP池允许,换句话说,路由器不能发送DHCP租约到包括两个域名的客户端。混合在一个动态缓冲池的静态映射是不可能的。如果它是混合的, %此命令不可以与网络一起使用,始发地, VRF,或者中继池错误信息出现。

    遥控(3660)

    Remote# show running-config

    Building configuration...

    .

    .

    .

    ip dhcp excluded-address 192.168.1.1

    !--- This ip address must not be assigned to DHCP clients.

    !

    ip dhcp pool Client

    import all

    !--- Import DHCP option parameters into the database.

    network 192.168.1.0 255.255.255.248

    !--- Specify the network number and mask for DHCP clients.

    default-router 192.168.1.1

    !--- Specify the default gateway for DHCP clients.

    !

    .

    .

    !

    interface FastEthernet0/0

    ip address dhcp

    duplex auto

    speed auto

    !

    interface FastEthernet1/0

    ip address 192.168.1.1 255.255.255.248

    duplex auto

    speed auto

    !

    end

    service config命令与引导程序主机一道使用或boot network命令。service config命令被输入对enable (event)自动地配置系统的路由器从文件由引导程序主机指定了或boot network命令。

    service config命令可能也使用,不用引导程序主机或boot network命令。如果不指定主机或网络配置文件名,路由器使用默认配置文件。默认网络配置文件是网络设置。默认主机配置文件是主机设置,主机是路由器的主机名。如果Cisco IOS软件不能解析其主机名,默认主机配置文件是router-config。

    与service config命令一起请使用boot host命令。没有service config命令,路由器在NVRAM忽略boot host命令并且使用配置信息。在NVRAM的配置信息失踪无效或, service config命令自动地有效。网络服务器将尝试从远端主机装载两个配置文件。第一是包含适用于在网络的所有网络服务器的命令的网络配置文件。请使用boot network命令识别网络配置文件。第二是包含命令特别是适用于一个网络服务器的主机配置文件。请使用boot host命令识别主机配置文件。

    客户端派出广播,即使选项150被配置由于其默认性质寻找TFTP server,并且选项150在服务器端没有被定义没有客户端。除TFTP之外, 150选项为这些也是可用的:

    150 Etherboot

    150只幼虫配置路径名字

    DHCP选项可以用选择码ASCII字符串tftp服务器NAME命令配置。如果没有服务器的名字,并且,如果服务器仅配置有IP地址,然后请使用ip address命令选择码的ip。

    本部分提供了可用于确认您的配置是否正常运行的信息。

    命令输出解释程序工具(仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

    Remote#show ip dhcp import

    Address Pool Name: Client

    Domain Name Server(s): 10.0.0.2

    NetBIOS Name Server(s): 10.0.0.2

    Domain Name Option: Central

    Central#show ip dhcp server statistics

    Memory usage 13906

    Address pools 1

    Database agents 1

    Automatic bindings 1

    Manual bindings 0

    Expired bindings 0

    Malformed messages 0

    Message Received

    BOOTREQUEST 0

    DHCPDISCOVER 1

    DHCPREQUEST 1

    DHCPDECLINE 0

    DHCPRELEASE 0

    DHCPINFORM 0

    Message Sent

    BOOTREPLY 0

    DHCPOFFER 1

    DHCPACK 1

    DHCPNAK 0

    Central#show ip dhcp binding

    IP address Client-ID/Hardware address Lease expiration Type

    10.0.0.6 0063.6973.636f.2d30. Apr 25 2005 12:30 AM Automatic

    3036.302e.3563.6634.

    2e61.3961.382d.4574.

    30

    本部分提供的信息可用于对配置进行故障排除。

    Note:在发出 debug 命令之前,请参阅有关 debug 命令的重要信息。

    从一个PC或客户端采取的输出有微软视窗的操作系统用ipconfig /all命令产生DHCP配置的TCP/IP配置值。参考RFC 2132

    icon_popup_short.gif 关于DHCP选项的更多信息。

    C:\>ipconfig /all

    Windows 2000 IP Configuration

    Host Name . . . . . . . . . . . . : PC

    Primary DNS Suffix . . . . . . . : cisco.com

    Node Type . . . . . . . . . . . . : Hybrid

    IP Routing Enabled. . . . . . . . : No

    WINS Proxy Enabled. . . . . . . . : No

    DNS Suffix Search List. . . . . . : cisco.com

    Ethernet adapter Local Area Connection :

    Connection-specific DNS Suffix . : Central

    Description . . . . . . . . . . : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX)

    Physical Address. . . . . . . . : 00-10-5A-86-5A-CA

    DHCP Enabled. . . . . . . . . . : Yes

    Autoconfiguration Enabled . . . : Yes

    IP Address. . . . . . . . . . . : 192.168.1.2

    Subnet Mask . . . . . . . . . . : 255.255.255.248

    Default Gateway . . . . . . . . : 192.168.1.1

    DHCP Server . . . . . . . . . . : 10.0.0.6

    DNS Servers . . . . . . . . . . : 10.0.0.2

    Primary WINS Server . . . . . . : 10.0.0.2

    Lease Obtained. . . . . . . . . : Tuesday, April 26, 2005 6:04:29 PM

    Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

    展开全文
  • R1配置dhcp服务 创建dhcp地址池java 网关:192.168.1.1 dns:192.168.1.123 排除地址 192.168.1.1,192.168.1.123,192.168.1.3-192.168.1.20 Sw1作为集线器使用不配置任何功能 PC端使用DHCP自动获取IP地址 3、...

    1、拓扑图

    在这里插入图片描述

    2、任务描述

    • R1配置dhcp服务
      1. 创建dhcp地址池java
      2. 网关:192.168.1.1
      3. dns:192.168.1.123
      4. 排除地址 192.168.1.1,192.168.1.123,192.168.1.3-192.168.1.20
    • Sw1作为集线器使用不配置任何功能
    • PC端使用DHCP自动获取IP地址

    3、R1配置

    1. 进入特权模式:Router>en
    2. 进入全局模式:Router#conf t
    3. 更改设备名称:Router(config)#hostname R1
    4. 进入接口:R1(config)#int g0/0
    5. 配置ip:R1(config-if)#ip add 192.168.1.1 255.255.255.0
    6. 开启端口:R1(config-if)#no shutdown
    7. 进入全局模式:R1(config-if)#exit
    8. 创建dhcp地址池:R1(config)#ip dhcp pool java
    9. 设置地址网段:R1(dhcp-config)#network 192.168.1.0 255.255.255.0
    10. 设置网关地址: R1(dhcp-config)#default-router 192.168.1.1
    11. 设置dns地址:R1(dhcp-config)#dns-server 192.168.1.123
    12. 进入全局模式:R1(dhcp-config)#exit
    13. 排除地址192.168.1.1:R1(config)#ip dhcp excluded-address 192.168.1.1
    14. 排除地址192.168.1.123:R1(config)#ip dhcp excluded-address 192.168.1.123
    15. 排除地址192.168.1.3-192.168.1.20:R1(config)#ip dhcp excluded-address 192.168.1.3 192.168.1.20
    16. 进入特权模式:R1(config)#exit
    17. 保存配置:R1#wr

    4、测试

    • PC1地址获取:在这里插入图片描述

    • PC2地址获取:在这里插入图片描述

    • PC3地址获取:在这里插入图片描述

    展开全文
  • 配置 DHCP 服务器 运行 Cisco IOS 软件的 Cisco 路由器完全支持路由器充当 DHCP 服务器的角色。Cisco IOS DHCP 服务器从路由器内的指定地址池分配 IP 地址给 DHCP 客户端,并管理这些 IP 地址。 定义 DHCP 在...
  • Cisco Packet Tracer中配置DHCP服务器

    万次阅读 多人点赞 2018-12-15 22:17:16
    DHCP介绍: DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP...当DHCP服务器接收到来自网...
  • cisco dhcp服务器设置参考以下命令:首先假设两台思科路由器,R1(服务端)连接R2(客户端),组成一个简单的链式局域网,下面就来实现DHCP,配置的命令及其解释如下:1、R1 dhcp服务的配置dhcp#configure terminal//进入...
  • 思科3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名为server。IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows 2003 ...
  • 近期有许多读者朋友在读者QQ...其中列出了在Cisco路由器上配置DHCP服务器的必需和可选任务,以及各种功能配置的具体步骤和大量示例。在下一篇中将给出DHCP服务中继的配置与示例。 4.1 Cisco IOS DHCP服务器配置概述...
  • Cisco 3750交换机配置DHCP服务器实例

    千次阅读 2014-11-12 16:43:19
    Cisco 3750交换机配置DHCP服务器实例 分类: 系统运维 今天发表了>一文,深得各位兄弟支持,更有多人询问如何配置3550作DHCP服务器,因为当时在配置3550作为DHCP中继代理时顺便测试了一把将3550配置为DHCP...
  • C3550配置作为DHCP服务器工程实例网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在网络,命名为server,IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows2000 ...
  • Cisco 3550配置dhcp,网络上多有讨论,按照网上介绍的配置一句"IP HELPER-ADDRESS DHCP服务器地址"后,工程当中发现客户机不能从DHCP服务器获取IP地址,本人最近也刚好配置了3550作为DHCP服务器中继代理,最初也曾...
  • 本文参考:Cisco 3550交换机配置DHCP服务器实例。原文链接为:http://www.vlan9.com/cisco-tech/p003003766.html。主要是用于自己以后的复习参考。 网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在...
  • cisco dhcp服务器设置 内容精选换一换通过云服务器或者外部镜像文件创建私有镜像时,如果云服务器或镜像文件所在虚拟机的网络配置是静态IP地址时,您需要修改网卡属性为DHCP,以使私有镜像发放的新云服务器可以动态...
  • 配置DHCP服务器

    2011-06-23 10:05:13
    运行 Cisco IOS 软件的 Cisco 路由器完全支持路由器充当 DHCP 服务器的角色...将路由器配置DHCP 服务器的步骤如下: 步骤 1. 定义 DHCP 在分配地址时的排除范围。这些地址通常是保留供路由器接口、交换机管理 ...
  • Cisco3550交换机配置DHCP服务器 开启DHCP服务:service dhcp 转载于:https://blog.51cto.com/young/43867
  • Cisco 3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名 为server,IP地址段  为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域服务器为windows...
  • 第一步,在路由器连接PC0的那个端口f6/0配置ip为172.16.14.1,连接交换机的端口f0/0配置为172.16.13.1,连接服务器的端口f1/0配置为172.16.10.2。上代码:int f6/0ip address 172.16.14.1 255.255.255.0int f0/0ip ...
  • Cisco路由器中配置DHCP服务器 配置以太口地址: Interface Ethernet 0 \\进入以太网口配置模式 No shut \\启动以太网口 Ip address 192.168.2.1 255.255.255.0 \\设定IP地址与子网掩码 ip address 192....
  • 网络环境:一台3550EMI交换机,划分三个vlan,vlan2 为服务器所在网络,命名为server,IP地址段为192。168。2。0,子网掩码:255。255。255。0,网关:192。168。2。1,域服务器为windows 2000 advance server,同时...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,966
精华内容 3,186
关键字:

cisco配置dhcp服务器