精华内容
下载资源
问答
  • Hybrid是华为、H3C交换机的一种端口模式,这个接口也能够允许多个VLAN帧通过并且还可以指定哪些VLAN数据帧被剥离标签,主要实现高隔离度的波分和复用。
  • 交换机hybrid接口详解

    2019-03-05 19:59:39
    802.1Q报文结构; 接口的三种模式:access,hybrid,trunk详解 ; 交换机对于PVID VLAN(华为系)或native VLAN(思科)报文的处理方式
  • 实 验 报 告 路由交换技术 数学与信息技术学院 通信工程 1815 焦冰洋 2018061509 实验教案 第 9次课 2 学时 一实验题目 实验九 VLAN划分与VLAN间路由配置 二实验目的和要求 1理解Hybrid接口的方法 2. 理解Hybrid接口...
  • hybrid 接口

    2019-10-05 20:27:38
    SW1: system-view Vlan 10 Vlan 20 Vlan 30 interface Ethernet0/0/1 port hybrid pvid vlan 10 port hybrid untagged vlan 10 30 interface Ethernet0/0/2 ...port hybrid pvid vlan 20 ...port hybrid ...

    SW1:

    system-view

    Vlan 10

    Vlan 20

    Vlan 30

    interface Ethernet0/0/1

    port hybrid pvid vlan 10

    port hybrid untagged vlan 10 30

    interface Ethernet0/0/2

    port hybrid pvid vlan 20

    port hybrid untagged vlan 20 30

    interface GigabitEthernet0/0/2

    port hybrid tagged vlan 10 20 30

    interface GigabitEthernet0/0/1

    port hybrid untagged vlan 10 20 30

    SW2:

    system-view

    Vlan 10

    Vlan 20

    Vlan 30

    interface Ethernet0/0/3

    port hybrid pvid vlan 10

    port hybrid untagged vlan 10 30

    interface Ethernet0/0/4

    port hybrid pvid vlan 20

    port hybrid untagged vlan 20 30

    interface Ethernet0/0/5

    port hybrid pvid vlan 30

    port hybrid untagged vlan 10 20 30

    interface GigabitEthernet0/0/2

    port hybrid tagged vlan 10 20 30

     

    转载于:https://www.cnblogs.com/hehuanling/p/10048813.html

    展开全文
  • eNSP-Hybrid 接口的应用

    2021-04-08 10:24:18
    Hybrid 接口的应用 原理概述 Hybrid 接口既可以连接普通终端的接入链路又可以连接交换机间的干道链路,它允许多个VLAN 的帧通过,并可以在出接口方向将某些VLAN 帧的标签剥掉。 Hybrid 接口处理VLAN 帧的过程如下...

    Hybrid 接口的应用

    原理概述

    Hybrid 接口既可以连接普通终端的接入链路又可以连接交换机间的干道链路,它允许多个VLAN 的帧通过,并可以在出接口方向将某些VLAN 帧的标签剥掉。

    Hybrid 接口处理VLAN 帧的过程如下:

    (I) 收到一个二层帧,判断是否有VLAN 标签。没有标签,则标记上Hybrid 接口的PVID, 进行下一步处理;有标签,判断该Hybrid 接口是否允许该VLAN 的帧进入,允许则进行下一步处理,否则丢弃。

    (2) 当数据帧从Hybrid 接口发出时,交换机判断VLAN 在本接口的属性是Untagged还是Tagged。如果是Untagged , 先剥离帧的VLAN 标签再发送;如果是Tagged则直接发送帧。

    通过配置Hybrid 接口,能够实现对VLAN 标签的灵活控制,既能够实现Access 接口的功能,又能够实现Trunk 接口的功能。。

    实验内容

    某企业二层网络使用两台S3700 交换机S1和S2, 且两台设备在不同的楼层。网络管理员规划了3 个不同VLAN, HR 部门使用VLAN 10, 市场部门使用VLAN20, IT 部门使用VLAN30 。现在需要让处于不同楼层的HR 部门和市场部门实现部门内部通信,而两部门之间不允许互相通信; IT 部门可以访问任意部门。可以通过配置Hybrid 接口来实现较复杂的VLAN 控制。

    实验拓扑

    理解Hybrid 接口的应用拓扑如图 所示。

    实验编址

    我们配置一下相关信息

    设备

    接口

    IP地址

    子网掩码

    默认网关

    PC-1

    Ethernet0/0/1

    192.168.1.1

    255.255.255.0

    N/A

    PC-2

    Ethernet0/0/1

    192.168.1.2

    255.255.255.0

    N/A

    PC-3

    Ethernet0/0/1

    192.168.1.3

    255.255.255.0

    N/A

    PC-4

    Ethernet0/0/1

    192.168.1.4

    255.255.255.0

    N/A

    PC-5

    Ethernet0/0/1

    192.168.1.100

    255.255.255.0

    N/A

    实验步骤

    1.基础配置

    按照实验编址表为PC 配置IP 地址,如图所示的配置过程适用于所有终端。

    完成配置后,测试主机之间的连通性。在PC- 1 上, 使用ping 命令。可以观察到,此时PC-1访问其他主机通信正常,其他主机上的测试过程省略。

    在没有定义VLAN 及接口类型之前,默认情况下,在没有定义VLAN 及接口类型之前,交换机上所有接口都是Hybrid类型,接口的PVID 是VLAN 1, 即所有接口收到没有标签的二层数据帧,都被转发到VLAN 1 中,并继续以Untagged 的方式把帧发送至同为VLAN 1 的其他接口。所以,即使未做任何配置, 主机之间默认仍然可以互相通信。

    在S1 上使用display port vlan 命令查看接口的默认类型。可以观察到,接口默认是Hybrid 类型,接口PVID 是VLAN 1, 其他接口也一样

    在交换机上使用display vlan 命令查看接口和所属VLAN 的对应关系。

    可以观察到,所有接口都默认属于VLAN 1, 其他交换机也都一样,因此VLAN 1内所有的主机都可以直接访问。

    2. 实现组内通信、组间隔离

    交换机接口的类型可以是Access 、Trunk 和Hybrid。Access 类型的接口仅属于一个VLAN, 只能接收、转发相应 VLAN 的帧;而Trunk 类型接口则默认属于所有 VLAN,任何Tagged 帧都能经过 Trunk 接收和转发; Hybrid 类型接口则介于二者之间,可自主定义端口上能接收和转发哪些 VLAN Tag 的帧,并可决定 VLAN Tag 是否继续携带或者剥离。Access 和Trunk 类型接口是Hybrid 类型接口的两个特例,一个仅支待一个VLAN的传递,一个默认支持所有VLAN 的传递,而Access 类型和Trunk 类型的接口能做到的,Hybrid 接口都能做到。

    目前要求实现HR部门和市场部门的员工终端可以进行部门内部通信,即VLAN 10 内PC-2 和PC-4 之间可以自由访问, VLAN20 内的PC-1 和PC-3 之间可以自由访问,而两个部门间的员工不能互相访问,即 VLAN 10 和 VLAN20 之间不能互相访问。要实现此需求,可以使用 Access 和 Trunk 的配置方法,也可以仅使用Hybrid 的配置方法。

    3.使用Trunk 和Access 类型接口的配置过程

    将S1 上的E 0/0/2 和S2 上的E 0/0/2 配置为Access 类型,并将相应的接口加入到VLAN 20 。同理,将S 1上的E 0/0/3 和S2 上的E 0/0/3 也配置为Access 类型接口,并加入到VLAN 10 。而交换机之间的互连链路的两个E 0/0/ 1 接口则配置为Trunk 类型。

    配置完成后, 查看接口和VLAN 的对应关系。

    在PC-1 上测试与同VLAN20 的PC-3 的连通性,以及与VLAN 10 内终端的连通性。

    可以观察到,在单台交换机及跨交换机间的访问控制使用Trunk 和Access 类型接口实现了需求, 但同样的需求使用Hybrid 实现会更灵活。

    S1 的E 0/0/2 接口连接PC-1 主机,该接口收到 PC-1 发送的 Untagged 的帧会被交换机转发到 VLAN20。同样,交换机从其他接口收到 VLAN20 的发往PC-1的帧也会以Untagged 的方式从E 0/0/2 接口发送。S1 的E 0/0/3 接口连接PC-2 主机,该接口收到Untagged 的帧会被转发到 VLAN 10 。如果交换机收到的 VLAN 10 的发往 PC-2 的帧也会以 Untagged 的方式从接口E 0/0/3 发送。VLAN 10 和 VLAN 20 的帧也要经过交换机间链路发送至邻居交换机 S2 。反之,S1 收到来自邻居交换机 S2 的Tagged 的帧后,也会根据VLAN Tag 转发到相应的VLAN 。

    在S1的E 0/0/2 接口上使用undo port default vlan 命令用来恢复接口默认VLAN 。

    配置port link-type hybrid 命令修改接口类型为默认的Hybrid 类型。

    配置port hybrid untagged vlan 20 命令使得交换机在该接口转发VLAN20 的帧时,剥离掉相应的VLANTag20, 以Untagged 的方式发送给PC 。

    配置port hybrid pvid vlan 20 命令设置Hybrid 类型接口的默认VLANID, 即使得该端口上接收到PC 发来的未带VLAN Tag 的帧时,加上VLAN Tag 20, 并转发到VLAN 20 。

    同样在连接另一台终端的E 0/0/3 接口做同样配置。

    [Sl] interface Ethernet0/0/3

    [S1-Ethernet0/0/3] undo port default vlan

    [Sl·Ethernet0/0/3] port link-type hybrid

    [Sl- Ethernet0/0/3] port hybrid untagged vlan 10

    [S l·Ethernet0/0/3] port hybrid pvid vlan 10

    在连接交换机S1的E 0/0/1 接口上修改端口类型为默认的Hybrid 类型,并使用port hybrid tagged vlan 10 20 命令设置该链路仅接收带有VLAN Tag 10 和20 的帧,而交换机仅转发VLAN 1 0 和VLAN20 的帧到该链路。一般该命令配置在交换机互连的链路接口之上

    [S1] interface Ethernet0/0/1

    [Sl- Ethernet0/0/l] undo port trunk allow-pass vlan all

    [Sl- Ethernet0/0/l] port trunk allow-pass vlan 1

    [Sl- Ethernet0/0/1] port link-type hybrid

    [Sl- Ethernet0/0/l] port hybrid tagged vlan 10 20

    S2 交换机将在E 0/0/1 接口接收到的Tagged 帧,根据VLAN Tag 标识,向接口E /0/2转发 VLAN20 的帧,向接口E 0/0/3 转发VLAN 30 的帧。反之,接口E 0/0/2 接收到PC发送的未带 Tag 的帧转发到VLAN 20, 端口E 0/0/3 接收的到未带 Tag 的帧会被转发到VLAN 10, 并且这些帧发送到邻居交换机S1 时,会保留原有Tag 。

    S2 上的配置和S1 类似, 这里不再解释。

    [S2] interface ethernet0/0/2

    [S2- ethernet0/0/2] undo port default vlan

    (S2- ethernet0/0/2] port link-type hybrid

    [S2- ethernet0/0/2] port hybrid untagged vlan 20

    (S2- ethernet0/0/2] port hybrid pvid vlan 20

    [S2-Ethernet0/0/2] interface ethernet0/0/3

    [S2-Ethernet0/0/3] undo port default vlan

    [S2-Ethernet0/0/3] port link-type hybrid

    [S2-Ethernet0/0/3] port hybrid untagged vlan 10

    [S2-Ethernet0/0/3] port hybrid pvid vlan 10

    [S2-Ethernet0/0/3] interface ethernet 0/0/1

    [S2- Ethernet0/0/l] undo port trunk allow-pass vlan all

    [S2-Ethernet0/0/l] port trunk allow-pass vlan 1

    [S2-Ethernet0/0/1] port link-type hybrid

    [S2-Etbemet0/0/1] port hybrid tagged vlan 10 20

    配置完成后,使用display vlan 命令查看使用Hybrid 配置下接口和VLAN 的对应关系。

    可以观察到,同样的需求,Hybrid 和Access 、Trunk 都能实现,但Hybrid的灵活性及解决复杂需求的能力是Access 和Trunk 达不到的。

    4. 实现网管员对所有网络的访问

    在实现各部门内部终端可以互相访问,不同部门间的终端隔离访问后,要求网络管理员所在的 IT 部门(使用终端PC-5 ) 能够实现对所有部门的访问。即要求实现VLAN 30 访问VLAN 10 和 VLAN 20;而且 VLAN 10 和VLAN20 之间仍然不允许互相访问。如果S1的E 0/0/2 接口仍是Access 类型且属于VLAN 10, 则不能被其他VLAN 访问。若要 VLAN 30 的终端能访问 VLAN 10 的终端,则需要修改接口的配置,使其既能被 VLAN 10 访问,又能被 VLAN30 访问,这就要求此接口同时要属于多个VLAN, 且端口所连设备是PC,不能识别带VLAN Tag 的帧,故此时只能使用Hybrid 类型接口。Hybrid 端口既能被加入多个VLAN 中, 又能够在将其余VLAN 的帧转发到此接口时,剥离掉相应的VLAN Tag 。

    配置 S1 交换机, E 0/0/4 接口是网络管理员的PC 终端, 属于VLAN 30, 该接口收到的 PC 发送的 Untagged 帧要能够发送至 VLAN 30 中,配置 port hybrid pvid vlan 30命令设置 Untagged 帧加入至 VLAN 30 。

    [S1]vlan30

    [Sl-vlan30]interface Ethernet 0/0/4

    [S-Ethernet 0/0/4] port hybrid pvid vlan 30

    因为在华为交换上,默认所有接口都为Hybrid 类型接口,所以在该接口下不需要修改配置。

    S1 交换机收到 VLAN 10 、VLAN20 和VLAN30 的帧也要能够从该接口发送至PC,配置 port hybrid untagged vlan 10 20 30 命令使得上述 3 个 VLAN 的帧会以Untagged 的方式从该接口发送出去。

    同理,端口E 0/0/2 接PC-1, 接口收到PC 的Untagged 帧需要发送至 VLAN20, 使用port hybrid pvid vlan 20 命令。E 0/0/2 接口同时也要能够被 VLAN 30 和 VLAN20 的主机访问,即 VLAN20 和 30 的帧能够从该接口发送出去,并以Untagged 的方式发送至PC-1 。

    接口E 0/0/3 收到Untagged 的帧需发送至VLAN 10, 同时VLAN 10 和30 的帧要能从该接口发送出去。

    VLAN10 、VLAN20 和VLAN30 的帧要能够发送至邻居交换机S2 , 且要保留原有的VLANTag, 以便于邻居交换机S2 根据VLANTag 继续转发到相应的VLAN 。同样, 邻居交换机S2 发送过来的帧也会带有相应的VLAN Tag, 所以SI 与S2 间互连的接口E 0/0/1 配置如下。

    [S1] interface Ethernet0/0/1

    [S1- Ethernet0/0/1] port hybrid tagged vlan 10 20 30

    [S2] interface Ethernet0/0/1

    [S2- Ethernet0/0/l] port hybrid tagged vlan 10 20 30

    同理在S2 交换机上, E 0/0/1 接口收到的带有相应 VLANTag 标记的帧,如果是 LAN 10 的帧要能发送至接口E 0/0/3, 如果是VLAN 20 的帧要能发送至E 0/0/2 。而如果是VLAN 30 的帧要能发送至接口E 0/0/2 和E 0/0/3 。VLAN10 、20 和30 的帧都是以 Untagged 的方式发送至接口E 0/0/2 或E 0/0/3 。反之,如果PC-3 发出的Untagged 的帧发送至接口

    E 0/0/2 时会进入到Hybrid 接口PVID 所指明的VLAN 20 中, PC-4 发出的Untagged的帧发送至接口E 0/0/3 时会进入到Hybrid 接口PVID 所指明的VLAN 10 中,具体配置过程如下。

    [S2] interface Ethernet0/0/2

    [S2- Ethernet0/0/2] port hybrid untagged vlan 20 30

    [S2] interface Ethernet0/0/3

    [S2- Ethernet0/0/3] port hybrid untagged vlan 10 30

    S1 和S2 上全部配置完成后,使用ping 命令在IT 部门的网络管理员的PC-5 上测试与不同部门内的各台主机间的连通性,以PC-1 为例。可以观察到, PC-5 所属网络管理员所在的VLAN 30, 能够正常访问到其他部门的所有终端。

    同理,选择市场部门所在VLAN20 内的主机PC-1 , 测试其与其他主机间的连通性。测试PC- 1 与本部门内的主机PC-3 间的连通性,从结果可以看出,可以正常通信。

    测试PC- 1 与外部门的主机PC-2 和PC-4 间的连通性。,从结果可以看出,不能正常通信, 实现了设计要求。

    测试PC-1 与IT 部门网络管理员主机PC- 5 间的连通性,可以正常通信。

     

    在交换机上可以定义多个VLAN, 每个VLAN 都可以看作是一个广播域, 通常情况下每个VLAN 都会分配一个独立的 IP 网络,根据需要把相应主机所在的接口划入到指定的VLAN 中,并配置相应的网络IP 地址, VLAN 间通过路由来实现互相访问。这是较为常用的方法。但是相比于基于端口的Hybrid 配置,三层路由方式则不够灵活, 原因在于VLAN 之间的访问控制要借助于路由设备来实现。而控制VLAN 访问使用 Hybrid 接口则极大地简化了配置的复杂性, 它仅需在端口上自主定义基于VLAN Tag 的过滤规则,来决定指定的VLAN 的二层帧是否允许发送;它是通过二层来实现VLAN 间的访问控制,既不需要每个VLAN 定义单独的IP 网段,更不需要在VLAN 间引入路由设备,配置更为灵活方便。

    展开全文
  • 《华为基础实验》配置交换机的 hybrid 接口.docx
  • 华为交换机Hybrid接口及基础配置

    万次阅读 2019-08-08 21:32:55
    三种类型的接口可以共同存在一台交换机上,但Trunk接口不能直接切换为Hybrid接口,只能先设为Access接口,再设置为Hybrid接口。例如,trunk接口不能直接被设置为hybrid接口,只能先设为access接口,再设置为hybrid...

    一、回顾VLAN

    • VLAN基本概念

    VLAN即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域(多个VLAN)的通信技术。VLAN内的主机间可以直接通信,而VLAN间不能直接互通,从而将广播报文限制在一个VLAN内。由于VLAN之间的隔离,所以一些类似蠕虫病毒等的攻~击被限制在一个VLAN中,提高了安全性,同时也方便管理人员对网络进行管理。

    • VLAN隔离广播的方式

    物理隔离:通过三层设备实现路由器
    逻辑隔离:交换机通过VLAN划分广播域,将接口加入指定VLAN进行隔离

    • 为什么要使用VLAN?

    交换机不隔离广播,因此整个交换网络是个广播域,广播域过大会使网络拥塞。为了解决这一个问题,我们用vlan技术,将偌大的广播域隔离成一个个的小的区域,并且不同vlan区域间不能通信。

    缺点:vlan技术虽然能隔离广播,但是不同vlan之间不能通信,如果要通信,需要三层设备才能实现

    • VLAN的划分

    Vlan的划分并不是固定的,而是有多种不同的划分方法:基于端口、基于协议、基于IP地址、基于MAC地址。其中最常用的就是基于端口的划分,我们的学习也主要是围绕着基于端口划分。Vlan端口的划分是逻辑上的,与物理位置没有关系,不同地方的网络一样可以划分到同一个vlan中。

    • VLAN接口的类型和trunk的封装

    1)vlan的接口类型

    Access:接入链路,一般客户端到交换机使用
    Trunk:中继链路,负责承载多个vlan数据,同vlan跨交换机通信使用

    2)vlan的封装方式

    ISL:Cisco私有协议不兼容其他厂商,占用带宽资源过高
    Dot1Q:所有厂商都支持公有协议,占用带宽资源小

    二、Hybrid接口是什么?

    • Hybrid接口

    Hybrid接口是华为设备的一种特殊二层接口模式,类似于之前介绍的Access接口和Trunk接口,是一个工作在二层的接口技术,可以对数据帧打VLAN标签或不打VLAN标签。

    • Hybrid接口的特点

    按照VLAN接口封装类型,华为交换机的接口主要有三种模式:Access、Trunk和Hybrid;
    可以实现access或者trunk链路的功能;
    默认华为交换机接口工作在hybrid模式;
    Hybrid接口可以允许多个vlan的报文发送时不打标签;
    hybrid可以实现不同vlan间通信或者限制不同vlan间通信;
    hybrid接口灵活性强;

    Hybrid接口的作用
    流量隔离:简单来说就是阻止特定VLAN间通信
    流量互通:不同VLAN间通信

    • Hybrid接口的三个属性

    1)untag列表

    只在接口发送数据帧时起作用,如果需要发送的数据的VLAN标签在接口的untag列表中,将去除标签发送数据

    2)tag列表

    作用于接收被标记的数据帧和发送数据帧。当接口接收到带有VLAN标签的数据帧时,该接口的tag列表相当于VLAN的允许列表,不在列表中的数据帧将被丢弃,当接口发送数据时,数据的vlan标签在接口的tag列表中,将保持标签发送数据帧,否则丢弃数据帧

    3)PVID

    接口的默认PVID为VLAN1,PVID只在接收未标记帧时起作用,PVID用于在接收未标记数据帧时给数据帧打上当前的PVID标识

    • 根据PVID封装8021Q

    网络通过VLAN隔离的情况下,可以将流量分为两种类型。一种是标记流量,即通过802.1Q打了标签的数据帧;另一种是未标记流量,也就是原始的以太网帧。一般情况下由终端设备发送和接收的流量为未标记流量。当交换机接收到一个标记流量时,将通过其802.1Q标签来识别其VLANID。但是当交换机接收到一个未标记流量时,将根据接口PVID对该流量进行802.1Q封装。在华为设备中,每种类型的接口都有默认的PVID。
    华为交换机Hybrid接口及基础配置
    任何进入交换机的流量都应该被标记,如果进入交换机的流量携带vlan标签,那么它本身是可以标识vlan信息的,如果进入交换机的流量未被标记(如终端设备发送到交换机的流量),将通过接口的PVID进行标记,而标记的目的则是为后续的转发做准备。Hybrid接口的PVID值默认是vlan 1,意味着所有接口默认都属于vlan1。

    • 根据untag和tag列表进行收发
      交换机的Hybrid接口基于untag列表和tag列表接收或发送数据,其工作原理如下:
      .每个Hybrid接口都有一个默认的untag列表,其中包含一个或多个vlan编号,默认值为vlan 1
      .每个Hybrid接口都有一个tag列表,默认值为空,也可以设置包含一个或多个vlan编号。
      .Hybrid接口收到数据帧后,首先检查该数据帧是否携带标签,如果携带标签,则检查本接口的tag列表,若tag列表中存在数据帧封装的vlan ID,则接受,否则丢弃;如果不携带标签,那么根据Hybrid接口的PVID进行标记。
      .Hybrid接口发送数据帧之前,检查本接口的untag和tag列表,若数据帧封装的vlan ID存在untag列表中,则去掉802.1Q封装发送原始数据帧;若存在于tag列表中,则保留802.1Q封装并发送带标签的数据帧;若两个列表中都没有数据帧的vlan ID,则不发送该数据帧。

    在数据发送时untag列表的应用如下图:
    华为交换机Hybrid接口及基础配置

    tag列表处理数据帧的接收和发送如下图:
    华为交换机Hybrid接口及基础配置

    以上是Hybrid接口收发数据帧的基本原则,其对应的处理流程如下图:

    华为交换机Hybrid接口及基础配置
    Hybrid接口和Trunk接口都可以给多个vlan打标签,也可以传输多个vlan的流量;但是Hybrid接口可以允许多个不同vlan的报文发送时不打标签,而Trunk接口只允许默认vlan 的报文发送时不打标签。
    三种类型的接口可以共同存在一台交换机上,但Trunk接口不能直接切换为Hybrid接口,只能先设为Access接口,再设置为Hybrid接口。例如,trunk接口不能直接被设置为hybrid接口,只能先设为access接口,再设置为hybrid接口。

    下面来配置一个简单的案例
    华为交换机Hybrid接口及基础配置
    需求如下:
    公司内部网络由一台交换机四个VLAN构成,分别是VLAN10、VLAN20、VLAN30、VLAN100、公司要求VLAN10、VLAN20、VLAN30都可以访问VLAN100,但VLAN10、VLAN20、VLAN30之间不能相互访问。
    开始配置:
    1、按照拓扑图配置PC的IP地址,不需要配置网关,此拓扑是同网段通信
    2、配置交换机

    [LSW1]VLAN batch 10 20 30 100      #批量创建vlan
    
    [LSW1]int eth 0/0/1                       #进入接口
    [LSW1-Ethernet0/0/1]port link-type hybrid      #接口配置为hybrid 
    [LSW1-Ethernet0/0/1]port hybrid untagged vlan 10 100 #转发数据移除vlan10和100的标识
    [LSW1-Ethernet0/0/1]port hybrid pvid vlan 10   #进入接口接收数据打标识为vlan10的标识
    [LSW1-Ethernet0/0/1]quit
    
    [LSW1]int eth 0/0/2              #进入接口
    [LSW1-Ethernet0/0/2]port link-type hybrid        #接口配置为hybrid
    [LSW1-Ethernet0/0/2]port hybrid untagged vlan 20 100 #转发数据移除vlan20和100的标识
    [LSW1-Ethernet0/0/2]port hybrid pvid vlan 20   #进入接口接收数据打标识为vlan20的标识
    [LSW1-Ethernet0/0/1]quit
    
    [LSW1]int eth 0/0/3                 #进入接口
    [LSW1-Ethernet0/0/3]port link-type hybrid    #接口配置为hybrid
    [LSW1-Ethernet0/0/3]port hybrid untagged vlan 30 100#转发数据移除vlan30和100的标识 
    [LSW1-Ethernet0/0/3]port hybrid pvid vlan 30   #进入接口接收数据打标识为vlan30的标识
    [LSW1-Ethernet0/0/3]quit
    
    [LSW1]int eth 0/0/4          #进入接口
    [LSW1-Ethernet0/0/4]port link-type hybrid    #接口配置为hybrid
    [LSW1-Ethernet0/0/4]port hybrid untagged vlan 10 20 30 100
                                      #转发数据移除vlan10、20、30和100的标识
    [LSW1-Ethernet0/0/4]port hybrid pvid vlan 100#进入接口接收数据打标识为vlan100的标识
    [LSW1-Ethernet0/0/4]quit

    配置完成后以上要求即便实现,结果如下:
    华为交换机Hybrid接口及基础配置

    感谢阅读,如有问题多多提议

    展开全文
  • 华为交换机Hybrid接口

    2019-12-12 15:37:43
    Hybrid接口名词理解 tag:针对接口接收的数据。 在端口配置 port hybrid tagged vlan 10 20 ,为允许带有vlan 10或者vlan 20的标签通过。 untag:针对接口发送的数据。 在端口配置 port hybrid untagged vlan 10 30...

    Hybrid接口名词理解

    tag:针对接口接收的数据。
    在端口配置 port hybrid tagged vlan 10 20 ,为允许带有vlan 10或者vlan 20的标签通过。
    untag:针对接口发送的数据。
    在端口配置 port hybrid untagged vlan 10 30,为数据发出时会去除带有的vlan 10或者vlan 20的标签。
    pvid:针对进入端口没有标签的数据。
    在端口配置 port hybrid pvid vlan 10,是将没有标签的数据包发出时打上vlan 10 的标签。

    Hybrid接口处理VLAN帧的过程

    (1)收到一个二层帧,查看是否有vlan标签。没有标签,则标记上hybrid接口的pvid,进行下一步处理;有标签,判断是否允许进入,允许则进行下一步处理,否则丢弃。
    (2)当数据帧从接口发出时,交换机判断是否配置了untag。如果配置,先剥离帧的vlan标签再发送;如果没有,则直接发送帧。

    实验内容

    某企业二层网络使用两台S3700交换机,且两台设备在不同的楼层。网络管理员规划了3个不同VLAN,VLAN 10,20和30。现在需要让处于不同楼层的VLAN实现内部通信,而不同VLAN之间不允许互相通信;VLAN30可以访问任意VLAN。

    实验拓扑

    拓扑图

    实验步骤

    1.基本配置
    根据实验拓扑图配置PC地址,配置完成后可以观察到,PC机之间可以互相通信。

    在没有定义VLAN及接口类型之前,默认情况下,交换机上所有接口都是Hybrid类型,接口的PVID是VLAN 1,即所有接口收到没有标签的二层数据帧,都被转发到VLAN1中,并继续未标签的方式把帧发送至VLAN1的其他接口。
    

    2.实现组内通信、组间隔离

    S1交换机配置:

    [Huawei]vlan 10 
    [Huawei-vlan10]vlan 20
    [Huawei]int g0/0/2
    
    使用port hybrid pvid vlan 10命令设置接口的默认VLAN ID,当接口接收到PC未带标签的帧时,加上VLAN 10的标签,并转发到VLAN 10
    [Huawei-GigabitEthernet0/0/2]por hy pvi vlan 10
    
    使用port hybrid untagged vlan 10命令使得交换机在接口转发VLAN10的帧时,剥离掉相应的VLAN10标签,以Untagged的方式发给PC
    [Huawei-GigabitEthernet0/0/2]port hybrid untagged vlan 10 
    
    [Huawei-GigabitEthernet0/0/2]int g0/0/3
    [Huawei-GigabitEthernet0/0/3]port hy pv vl 20
    [Huawei-GigabitEthernet0/0/3]port hy unt vlan 20
    
    使用port hybrid tagged vlan 10 20命令设置该链路仅接收带有VLAN 10和20标签的帧,而交换机也仅转发VLAN 10和VLAN 20的帧到该链路。
    [Huawei-GigabitEthernet0/0/3]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port hybrid tagged vlan 10 20
    

    S2交换机同样配置:

    [Huawei]vlan 10 
    [Huawei-vlan10]vlan 20
    [Huawei-vlan20]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port hy pv vlan 10
    [Huawei-GigabitEthernet0/0/2]port hy unt vlan 10
    [Huawei-GigabitEthernet0/0/2]int g0/0/3
    [Huawei-GigabitEthernet0/0/3]port hy pv vlan 20
    [Huawei-GigabitEthernet0/0/3]port hy unt vlan 20
    [Huawei-GigabitEthernet0/0/3]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port hy ta vlan 10 20
    

    可以观察到,PC1和PC3之间连通,PC2和PC4之间连通。

    3.实现PC5VLAN30对所有网络的访问

    S1交换机配置:

    [Huawei]vlan 30
    [Huawei-vlan30]int g0/0/4
    [Huawei-GigabitEthernet0/0/4]por hy p vlan 30
    vlan 10,20,30标签的帧从该接口发出时剥离标签,以untagged发给PC
    [Huawei-GigabitEthernet0/0/4]port hy untagged vlan 10 20 30
    
    [Huawei-GigabitEthernet0/0/4]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port hy unta vlan 10 30
    [Huawei-GigabitEthernet0/0/2]int g0/0/3
    [Huawei-GigabitEthernet0/0/3]port hy unt vlan 20 30
    
    g0/0/1接口允许vlan 10,20,30标签的数据帧通过
    [Huawei-GigabitEthernet0/0/3]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port hy ta vlan 10 20 30
    
    [Huawei-GigabitEthernet0/0/1]dis vlan
    The total number of vlans is : 4
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/1(U)      GE0/0/2(U)      GE0/0/3(U)      GE0/0/4(U)      
                    GE0/0/5(D)      GE0/0/6(D)      GE0/0/7(D)      GE0/0/8(D)      
                    GE0/0/9(D)      GE0/0/10(D)     GE0/0/11(D)     GE0/0/12(D)     
                    GE0/0/13(D)     GE0/0/14(D)     GE0/0/15(D)     GE0/0/16(D)     
                    GE0/0/17(D)     GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)     
                    GE0/0/21(D)     GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)     
    
    10   common  UT:GE0/0/2(U)      GE0/0/4(U)                                      
    
                 TG:GE0/0/1(U)                                                      
    
    20   common  UT:GE0/0/3(U)      GE0/0/4(U)                                      
    
                 TG:GE0/0/1(U)                                                      
    
    30   common  UT:GE0/0/2(U)      GE0/0/3(U)      GE0/0/4(U)                      
    
                 TG:GE0/0/1(U)                                                      
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010                         
    20   enable  default       enable  disable    VLAN 0020                         
    30   enable  default       enable  disable    VLAN 0030   
    

    S2同样配置:

    [Huawei]vlan 30
    [Huawei-vlan30]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port hy un vlan 10 30
    [Huawei-GigabitEthernet0/0/2]int g0/0/3
    [Huawei-GigabitEthernet0/0/3]port hy un vlan 20 30
    [Huawei-GigabitEthernet0/0/3]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port hy ta vlan 10 20 30
    [Huawei-GigabitEthernet0/0/1]dis vlan
    The total number of vlans is : 4
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/1(U)      GE0/0/2(U)      GE0/0/3(U)      GE0/0/4(D)      
                    GE0/0/5(D)      GE0/0/6(D)      GE0/0/7(D)      GE0/0/8(D)      
                    GE0/0/9(D)      GE0/0/10(D)     GE0/0/11(D)     GE0/0/12(D)     
                    GE0/0/13(D)     GE0/0/14(D)     GE0/0/15(D)     GE0/0/16(D)     
                    GE0/0/17(D)     GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)     
                    GE0/0/21(D)     GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)     
    
    10   common  UT:GE0/0/2(U)                                                      
    
                 TG:GE0/0/1(U)                                                      
    
    20   common  UT:GE0/0/3(U)                                                      
    
                 TG:GE0/0/1(U)                                                      
    
    30   common  UT:GE0/0/2(U)      GE0/0/3(U)                                      
    
                 TG:GE0/0/1(U)                                                      
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010                         
    20   enable  default       enable  disable    VLAN 0020                         
    30   enable  default       enable  disable    VLAN 0030       
    

    4.实验结果
    PC5 测试连通其他主机

    PC>ping 10.1.1.1
    
    Ping 10.1.1.1: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: bytes=32 seq=1 ttl=128 time=47 ms
    From 10.1.1.1: bytes=32 seq=2 ttl=128 time=31 ms
    
    --- 10.1.1.1 ping statistics ---
      2 packet(s) transmitted
      2 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/39/47 ms
    
    PC>ping 10.1.1.2
    
    Ping 10.1.1.2: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.2: bytes=32 seq=1 ttl=128 time=47 ms
    From 10.1.1.2: bytes=32 seq=2 ttl=128 time=31 ms
    From 10.1.1.2: bytes=32 seq=3 ttl=128 time=31 ms
    From 10.1.1.2: bytes=32 seq=4 ttl=128 time=31 ms
    From 10.1.1.2: bytes=32 seq=5 ttl=128 time=31 ms
    
    --- 10.1.1.2 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/34/47 ms
    
    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=62 ms
    From 10.1.1.3: bytes=32 seq=3 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=4 ttl=128 time=47 ms
    From 10.1.1.3: bytes=32 seq=5 ttl=128 time=47 ms
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/56/63 ms
    
    PC>ping 10.1.1.4
    
    Ping 10.1.1.4: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.4: bytes=32 seq=1 ttl=128 time=47 ms
    From 10.1.1.4: bytes=32 seq=2 ttl=128 time=47 ms
    From 10.1.1.4: bytes=32 seq=3 ttl=128 time=47 ms
    From 10.1.1.4: bytes=32 seq=4 ttl=128 time=78 ms
    From 10.1.1.4: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 10.1.1.4 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/56/78 ms
    

    PC1连通情况

    PC>ping 10.1.1.100
    
    Ping 10.1.1.100: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.100: bytes=32 seq=1 ttl=128 time=31 ms
    From 10.1.1.100: bytes=32 seq=2 ttl=128 time=31 ms
    From 10.1.1.100: bytes=32 seq=3 ttl=128 time=47 ms
    From 10.1.1.100: bytes=32 seq=4 ttl=128 time=47 ms
    From 10.1.1.100: bytes=32 seq=5 ttl=128 time=31 ms
    
    --- 10.1.1.100 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/37/47 ms
    
    PC>ping 10.1.1.2
    
    Ping 10.1.1.2: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=62 ms
    From 10.1.1.3: bytes=32 seq=3 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=4 ttl=128 time=47 ms
    From 10.1.1.3: bytes=32 seq=5 ttl=128 time=62 ms
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/59/63 ms
    

    最后可以观察实现,PC5能够连通所有主机,PC1和PC3之间连通,PC2和PC之间连通。

    展开全文
  • Hybrid接口和Trunk接口的相同之处是都可以允许多个VLAN的流量通过并打标签,不同之处在于Hybrid接口可以允许多个VLAN的报文发送时不打标签。主要介绍华为交换机的Hybrid接口Hybrid接口作为华为交换机的特有...
  • Hybrid 接口应用

    2020-03-13 16:38:35
    **Hybrid接口即可连接普通终端的接入链路又可连接交换机的干道链路,允许多个VLAN 帧通过,并在出接口方向将某些VLAN帧的标签剥** 离。 **Hybrid 接口处理帧过程如下:** (1)收到一个二层帧,判断是否又二层标签...
  • 华为Hybrid接口详解(原理+配置)

    千次阅读 多人点赞 2020-06-01 16:41:39
    文章目录前言一、Hybrid接口1.1特点1.2工作原理1.3Hybrid接口收发过程1.4Hybrid收发过程流程图二、Hybrid接口配置实验1.1实验拓扑图1.2实验要求1.3实验配置1.4实验测试 前言 Hybrid接口是华为设备的特殊的二层接口...
  • 一、华为交换机基本配置1.1 交换机设备创建、删除VLAN1.2 设置接口类型1.2.1 设置access类型1.2.2 设置Trunk类型1.3 华为交换机日常维护查看命令二、Hybrid 接口特性2.1 Hyrid接口特点2.2 Hybrid接口作用三、Hybrid...
  • 理解hybrid接口的应用原理概述一、实验目的及编址二、实验拓扑二、实验内容配置双工模式1.配置ip地址做ping通测试总结与思考 原理概述 hybrid接口非常灵活 它允许多个vlan通过,并且可以在出接口方向将某些vlan tag...
  • Hybrid接口是华为设备的一种特殊二层接口模式,类似于之前介绍的Access接口和Trunk接口,是一个工作在二层的接口技术,可以对数据打 VLAN标签或不打VLAN标签,在正式介绍Hybrid接口之前,首先回顾下之前的VLAN知识。...
  • Hybrid接口的工作原理及其配置

    千次阅读 2019-08-08 12:06:03
    Hybrid接口的工作原理涉及及接口的三个属性: 分别为:untag列表,tag列表,PVID(port-base VLAN ID,基于端口的VLAN ID) untag列表:只在接口发送数据帧时起作用,如果需要发送的数据的VLAN标签在接口的...
  • Hybrid接口的应用及配置

    千次阅读 2019-03-27 20:23:22
    Hybrid接口既可以连接普通终端的接入链路也可以了解交换机之间的干道链路,它允许对个VLAN的帧通过,同时可以在出接口方向将某些VLAN帧的标签剥掉。 Hybrid接口处理VLAN帧的过程: (1)收到一个二层帧,判断是否...
  • Hybrid接口的配置

    2021-04-19 10:35:12
    Hybrid接口的配置 一、Hybrid接口原理 (1)、收到数据帧:判断是否有标签,无标签则打上Hybrid接口 的PVID;有标签,判断是否允许帧进入,否则丢弃。 (2)、发出帧:1.判断VLAN在本接口的属性【Untagged\Tagged】...
  • 实验原理 hybrid既可以连接普通终端的接入链路,又可以连接交换机的干路链路,他允许多个vlan的...当数据帧从hybrid接口发出时,交换机判断vlan在本接口的属性是untagged还是tagged,如果是untagged的,先剥离vlan标
  • 允许多个vlan的帧通过,还可以在出接口方向将某些vlan帧的标签过滤剥离掉 1、收到一个二层帧,首先判断是否有vlan标签, 没有标签,则标记上Hybrid接口的PVID,进行下一步处理 有标签,判断HYbrid接口是否允许该vlan...
  • 下面分别介绍Access接口、Trunk接口、Hybrid接口对收发数据帧的处理过程。 说明: QinQ接口可以给帧加上双层Tag,即在原来Tag的基础上,给帧加上一个新的Tag,具体处理过程请参见“QinQ配置”,本节不再赘述。 ...
  • Hybrid是华为、H3C交换机的一种端口模式,这个接口也能够允许多个VLAN帧通过并且还可以指定哪些VLAN数据帧被剥离标签,主要实现高隔离度的波分和复用。 Hybrid端口和Trunk端口在接收数据时,处理思路方法是一样的,...
  • H3C交换机的hybrid接口详解,很多初次接触hybrid这个概念的人会很迷茫,这个文档详细的讲解的h3c的hybrid接口,图文并茂,附带配置讲解,相信对大家会有所帮助。
  • 2.1access2.2trunk2.3hybrid接口和其属性2.3.1Hybrid2.3.2hybrid接口的几个参数3.hybrid接口原理和配置实验3.1实验描述3.2实验拓扑3.3实验需求3.4实验配置3.4.1SW1配置3.4.2SW2配置3.4.3R1配置3.4.4R2配置3.4.5接...
  • Hybrid接口是华为设备的特殊的二层接口模式,Hybrid接口和Trunk接口的相同之处是都可以允许多个VLAN的流量通过并打标签,不同之处在于Hybrid接口可以允许多个VLAN的报文发送时不打标签。 (2)Hybrid主要特点有: ...
  • Hybrid接口使用1

    2020-06-12 10:58:05
    文章目录一、实验环境二、需求描述三、实验步骤如所下所示四、总结 ...采用Hybrid接口配置,实现部分互联; 三、实验步骤如所下所示 1.按题目画出拓扑图; 2.配置PC1、PC2、PC3、PC4、PC5主机地址,以PC
  • 整个结构的所有接口,我们都使用hybrid接口类型 配置 交换机sw1 [Huawei]vlan batch 10 20 30 // 因为PC1可以访问vlan10和vlan30当中的主机,所以E0/0/3接口在接收到带有vlan10和vlan30标签的数据时,剥掉标签发送...
  •   Hello,今天学习一下交换机配置的hybrid接口,分享给大家,如有不正确的还请指教!   Hybrid接口:它可以连接普通终端的接入链路和连接交换机间的干道链路,允许多个VLAN的帧通过,并可以在出接口方向将需要...
  • Hybrid接口

    2021-06-01 18:53:21
    二,hybrid接口特点 三,hybrid接口的工作原理 一,VLAN的基本概念 特点: 隔离广播 方便管理 提高安全 VLAN接口: Access接口 trunk接口 Trunk封装 isl,do1lq 二,hybrid接口特点 华为交换机接口默认为...
  • 要求:PC1/PC2/PC3 分别连接交换机的 GE0/0/1、GE0/0/2、GE0/0/3 接口,三个接口均为hybrid 链路类型。设置 GE0/0/1 接口 pvid vlan 10、untagged vlan 10 30 等,参考网络拓扑 图 思路: access 接口收报文:判断...
  • 华为网络实验–access、trunk、hybrid接口配置实验 前言 Hybrid接口是华为设备特殊的二层接口模式, 可以类似于vlan和trunk接口, 可以对数据帧不打vlan标签和不打标签。 ●实验目的 通过配置交换机SW1和SW2不同接口...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,149
精华内容 6,059
关键字:

hybrid接口