精华内容
下载资源
问答
  • 思科PPPOE配置方法

    2020-07-24 11:17:44
    PPPoE是在以太网上实现PPP封装的协议,它利用以太网将大量主机接入网络,通过一个远端接入设备连入因特网,并对接入的每一个主机实现控制、计费等功能。 与传统的接入方式相比,pppoe具有较高的性能价格比,它在包括...

    PPPoE是在以太网上实现PPP封装的协议,它利用以太网将大量主机接入网络,通过一个远端接入设备连入因特网,并对接入的每一个主机实现控制、计费等功能。
    与传统的接入方式相比,pppoe具有较高的性能价格比,它在包括小区组网建设等一系列应用中被广泛采用,目前流行的宽带接入方式ADSL 就使用了pppoe协议。

    PPPoE的五种报文
    PADI —发现初始化报文
    PADO —发现提供报文
    PADR —发现请求报文
    PADS —发现会话确认报文
    PADT —发现终止报文

    需要注意调整MTU
    IP MTU 1492
    TCP MSS 1452

    配置:
    server端
    ip local pool cisco 61.128.1.1 //定义给客户分配的地址池范围
    bba-group pppoe xxxx //定义一个pppoe组
    virtual-template 1 //定义一个模板
    interface Ethernet0/0
    no ip address
    pppoe enable group xxxx //调用组
    interface Virtual-Template1 //调用模板
    ip address 61.128.1.10 255.255.255.0
    ip mtu 1492 //设置MTU
    peer default ip address pool cisco //指定从哪个池给客户分地址

    客户端
    interface Ethernet0/0
    no ip address
    pppoe enable group global // 使能pppoe
    pppoe-client dial-pool-number 6 //定义拨号的池

    interface Dialer1 //创建拨号接口
    mtu 1492 //设置MTU
    ip address negotiated //跟server端协商地址
    encapsulation ppp //指定PPP封装
    dialer pool 6 //调用拨号池

    认证:
    server
    username Cisco password 0 xxxx
    ppp authentication chap callin
    client
    ppp chap hostname Cisco
    ppp chap password xxxx

    NAT应该怎么做?
    outside接口应该写在dialer接口上
    interface dialer 1
    ip nat outside
    ip nat inside source list 2 interface dialer 1 overload

    如何从运营商获取一条默认路由?
    interface dialer 1
    ppp ipcp route default

    展开全文
  • 思科pppoe server端配置

    2020-03-30 19:14:19
    Cisco pppoe server 配置 1.在config目录下建立拨号需要用到的账号密码 2.建立一个名叫vlan99 BBA组 名字可以随便起 3.将虚拟模板接口1 关联到BBA组中 注意:bba-group 是一个虚拟的拨号组,在以前的ios中,pppoe...

    Cisco pppoe server 配置

    1.在config目录下建立拨号需要用到的账号密码

    在这里插入图片描述

    2.建立一个名叫vlan99 BBA组

    在这里插入图片描述

    名字可以随便起

    3.将虚拟模板接口1 关联到BBA组中

    在这里插入图片描述
    注意:bba-group 是一个虚拟的拨号组,在以前的ios中,pppoe拨号是嵌入到vpnd中的,后来思科将pppoe从VPND中移植出来,嵌入到BBA组中。Virtual-template是设备所使用的虚拟访问接口,一个pppoe的拨号连接就属于虚拟访问一种,该接口上存放着与虚拟访问有关的三层和二层信息,所以要把virtual-template与BBA-GROUP关联起来。

    4.进入虚拟模板1接口

    在这里插入图片描述

    5.ip unnumbered fastEthernet 0/0.99 配置该接口向0.99子接口借用地址,当然也可以自己配。
    在这里插入图片描述

    6.封装接口为ppp协议
    在这里插入图片描述

    7.使用chap认证
    在这里插入图片描述

    8.为pppoe客户端分配的一个叫vlan99地址池
    在这里插入图片描述

    8.在外面配置这个地址池

    ip local pool vlan99 192.168.99.10 192.168.99.100

    在这里插入图片描述
    9.进入0.99子接口封装do1q99

    在这里插入图片描述

    10.将bba组关联上去

    在这里插入图片描述
    11.为子接口配置地址

    在这里插入图片描述
    12.CPE 建立vlan99的wan 拨号查看是否成功
    13.在这里插入图片描述

    展开全文
  • 思科PPPOE基本配置 用思科路由怎样配置PPPOE,自动拨号上网 1、第一步:首先要配置VPDN组 R1(config)#vpdn enable R1(config)#vpdn-group 1 R1(config-vpdn)#request-dialin R1(config-vpdn-req-in)...

     

    思科PPPOE基本配置
     
     
     
    用思科路由怎样配置PPPOE,自动拨号上网
     
    1、第一步:首先要配置VPDN组
     
    R1(config)#vpdn enable
    R1(config)#vpdn-group 1
    R1(config-vpdn)#request-dialin
    R1(config-vpdn-req-in)#protocol pppoe
     
     
     
     
    2、第二步:配置路由器连接ADSL MODEM的接口
       
    R1(config)#int f0/0           在这里我以F0/0端口为例,是从这个端口和MODEM连接
    R1(config-if)#no ip address       无IP地址
    R1(config-if)#pppoe enable        允许以太接口运行PPPOE
    R1(config-if)#pppoe-client dial-pool-number 1   将以太接口的PPPOE客户端加入拨号池1
     
     
    3、第三步:配置逻辑接口
    R1(config)#int dialer 1                  进入逻辑接口,以1为例(接口范围0~255之间)
    R1(config-if)#ip address negotiated       从ADSL服务商动态协商得到IP地址
    R1(config-if)#ip mtu 1492       设置IP数据包的MTU值,这里很重要,默最小为128,1429为最大的
    R1(config-if)#ip tcp adjust-mss 1450  
    R1(config-if)#ip nat outside       为接口启用NAT
    R1(config-if)#encapsulation ppp      为该接口封装PPP协议
    R1(config-if)#dialer pool 1          接口使用1号池拨号
     
    R1(config-if)# ppp authentication pap callin                启用PPP PAP验证
    R1(config-if)#ppp pap sent-username xxxx password xxxx      使用你申请到的用户 和密码
     
    4、第四步:配置内部网络接口
     
    R1(config-if)#int f0/1
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#ip nat inside


     

    5、配置NAT
     
    R1(config)#access-list 1 permit 192.168.1.1 0.0.0.255             
    R1(config)#ip nat inside source list 1 interface dialer 1 overload    
     
     
     
    6、第六步:配置缺省路由
     
     
    R1(config)#IP route  0.0.0.0 0.0.0.0 DIaler 1  
     
     
     
    配置完成

    转载于:https://blog.51cto.com/3502539/966577

    展开全文
  • 思科防火墙、路由器配置PPPoE拨号文档
  • PPPOE配置

    2008-08-27 22:34:17
    港湾路由器PPPOE配置事例(思科的类同)- - 一、环境 软件版本:1.3正式版 路由器:1760/2651/3680 二、配置事例 1、 PPPOE客户端配置: 2、PPPOE服务器配置: 3、路由器做为PPPOE接入服务器...

    港湾路由器PPPOE配置事例(思科的类同)- -

                                          
    一、环境
     
    软件版本:1.3正式版
     
    路由器:1760/2651/3680
     
    二、配置事例
     
     
    1、  PPPOE客户端配置:
    2、PPPOE服务器配置:
    3、路由器做为PPPOE接入服务器(本地认证),同时router也作为PPPOEinternet的客户端,另外还使用了NAT功能。
    4、监视和维护PPPOE
     

    1、PPPOE客户端配置:
    配置拨号:
    Router(config)#interface dialer 0
    Router (config-if-dialer0)#ip address negotiated
    Router (config-if-dialer0)#dialer pool 1
    Router (config-if-dialer0)#dialer permit-dial-null-string
    Router (config-if-dialer0)#dialer-group 1
    Router (config-if-dialer0)#ppp pap sent-username user  password pass
    Router (config-if-dialer0)#exit
    Router (config)#dialer-list 1 protocol ip permit
    使能PPPOE:
    Router (config-if-eth0/1)#pppoe-client dial-pool-number 1

     
    2、PPPOE服务器配置:
    配置virtual-templete:
    Router(config)# ip local pool ip-pool 10.0.0.2 10.0.0.255
    Router(config)#interface virtual-templete 0
    Router (config-if-virtual-templete0)#ip address 10.0.0.1/24
    Router (config-if-virtual-templete0)# peer de ip address pool ip-pool
    Router (config-if-virtual-templete0)# ppp authentication chap default
    Router (config-if-virtual-templete0)#exit
    使能PPPOE:
    Router(config)#pppoe virtual-template 0
    Router (config-if-eth0/0)#pppoe enable
    配置AAA采用本地认证
    Router(config)#aaa-enable
    Router(config)#aaa authentication ppp default local
    Router(config)#username user1 privilege 1 password user1
    Router(config)#username aaa privilege 1 password aaa
    3、路由器Router做为PPPOE接入服务器(本地认证),同时router也作为PPPOE上internet的客户端,另外还使用了NAT功能。
        
    配置:
    access-list 1 permit 192.168.0.0/24      
    aaa-enable
    aaa authentication login default local
    aaa authentication ppp default local
    username 163 privilege 1 password 163
    username admin privilege 1 password harbour
    pppoe virtual-template 0
    ip local pool ip-pool 192.168.0.2 192.168.0.255
    dialer-list 1 protocol ip permit
    !
    interface eth1/0
     pppoe-client dial-pool-number 1
    !
    interface eth2/0
     pppoe enable
     
    !
    interface async0/0
    !
    interface dialer0
     ip address negotiated
     ip nat outside
     ppp pap sent-username 163 password 163
     dialer pool 1
     dialer-group 1
     dialer permit-dial-null-string
    !
    interface virtual-template0
     ip address 192.168.0.1/24
     ip nat inside
     peer default ip address pool ip-pool
     ppp authentication chap default
     compress stac     —— 此命令需要与客户端配合(如果客户端选择了压缩,则在路由器上要配上压缩,否则就不需要配了),否则网络注册比较慢(大概20秒种)!
     ppp ipcp DNS 91.21.80.1
    !
    !Rip config
     router rip
    !
    ip route 0.0.0.0/0 eth1/0
    ip nat on
    ip nat inside source list 1 interface eth1/0
    line console 0
    line aux 0
    line vty 0
     password harbour
     login authentication default
    line vty 1 9
    !
    !end
     
    监视和维护PPPOE
    PPPOE  DEBUG信息 Debug pppoe pppoe-data/ pppoe-packets
      
    (1) debug pppoe pppoe-packet的显示信息解释如下:
    router# debug pppoe pppoe-packet
    router# term moni
    pppoe:eth0/1 I code = PADI(0x09)
    网口eth0/1收到pppoe客户端的PADI
    pppoe:eth0/1 O code = PADO(0x07)
    网口eth0/1向pppoe客户端输出PADO
    pppoe:eth0/1 I code = PADR(0x19)
    网口eth0/1收到pppoe客户端的PADR
    pppoe:eth0/1 O code = PADS(0x65)
    网口eth0/1向pppoe客户端输出PADS
    pppoe:eth0/1 change state to SESSION
    pppoe连接进入会话阶段
    (2) debug pppoe pppoe-data的显示信息解释如下:
    router# debug pppoe pppoe-packet
    router# term moni
     pppoe:eth0/1 IN packet ,size 46
     网口eth0/1收到尺寸为46字节的包
    ppoe:eth0/1 OUT packet ,size 40
    网口eth0/1输出尺寸为40字节的包
    pppoe:eth0/1 OUT packet ,size 29
    网口eth0/1输出尺寸为29字节的包
    pppoe:eth0/1 IN packet ,size 46
    网口eth0/1收到尺寸为46字节的

    转载于:https://blog.51cto.com/52lin/95354

    展开全文
  • PPPoE配置

    千次阅读 2018-03-11 15:21:32
    思科:R1连接R2R1是客户端,R2是服务器端R2Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z.Router(config)#hostname R2R2(config)#vpdn enable ...
  • 思科路由器配置pppoeInternet路由器的服务器端口eth0/2的配置Internet(config)#interface eth0/2Internet(config-if)#pppoe enable //ppoe启用Internet(config-if)#no shutdownInternet(config-if)#exitInternet...
  • 现有客户需要使用思科的2600路由器上网,用户为10M光纤,申请了16个固定IP,ip为61.161.xxx.2-61.161.xxx.14,默认网关是61.161.xxx.1.内网ip段192.168.1.0,客户要实现192.168.1.50-192.168.1.60之间的ip可以上网,...
  • 这几天有个客户说自己试着调试购买的思科2921路由,配置ADSL拨号上网,客户端电脑可以自动获取IP地址,但是上不了网,打不开网页。 interface GigabitEthernet0/0description TO-ADSLno ip addressduplex autospeed ...
  • NATvpdn enable no vpdn logging 由于ADSL的PPPoE应用是通过虚拟拨号来实现的所以在路由器中需要使用VPDN的功能 ! vpdn-group pppoePPPoE启动了VPDN的进程 request-dialin protocol pppoe 设置拨号协议为PPPoE!...
  • 以前的路由器都是40多块钱的,最贵也不过100块钱,但是用起来很不好用,家里有三台电脑,那些垃圾路由器总是频繁的掉线,让我的牙疼,现在终于用了好的路由器,本以为思科RV042能让我的网络环境好起来,但是在配置上...
  • 实验拓扑:像以前做的大部分实验,都是以大客户或者数据中心的形式,直接拉一根网线,配好网线就能...如图,将在C1与R1之间通过拨号的方式上网(而非通过配置网关的方式)。首先进行基本配置R1#conf tR1(config-if)...
  • 第一章工程中常见的工程模型 第一节CCNA 模型 第二节CCNP 模型 第三节CCIE 模型 ...第一节思科pppoe 配置 第二节H3C 路由器配置 第五章CCNP 工程模型 第一节Vtp 实验1 第二节Vtp 实验2 vtp 工作方式
  • router(config)# vpdn enable 启用VPDN ...router(config)# vpdn-group pppoePPPoE启动VPDN的进程 router(config-vpdn)# request-dialin 定义呼叫 router(config-vpdn)# protocol pppoe 设置拨号协议为PPP...
  • PPPOE概述

    2017-08-01 11:43:14
    大分部ISP(Internet服务提供商)在网络上使用PPPoE(Point to Point Over Ethernet,以太网...今天为大家讲解一下PPPoE的基本原理、演示如何在思科路由器上配置服务器和客户端,以及在Windows操作系统上配置客户端。
  • 1.当2600安装WIC-1ADSL模块后的配置: vpdn enable no vpdn logging vpdn-group pppoe request-dialin interface Ethernet0 ip address 192.168.0.1 255.255.255.0 ip nat inside interface ATM0 no ip address no ...
  • 说明:此案例为电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2500(1841)路由器(双以太口),IOS 12.2(15)T,能够实现局域网共享上网. 此案例配置共分7步: 第一步:配置vpdn router(config)#vpdn ...
  • 实验拓扑: GNS3 0.8.6 +c3725-adventerprisek9-mz....2.通过配置IBGP协议建立邻居将所有的用户业务路由(大客户和PPPOE拨号)宣告。 3.通过配置路由反射器实现市内、省内业务路由互传。 4.通过建立EBGP邻居实现全...
  • 7.4广域网:PPPoE

    2020-03-16 18:56:53
    配置1.1 思科1.2 华为 1.配置   技术上没什么可说的,目前大部分家庭和公司都是PPPoE上网,不过一般都不在使用串口链路,而是使用以太网链路或光纤入户。所以在配置中我们使用以太网端口进行数据传输,拓扑图如下...
  • PPPOE拨号实验

    2011-06-06 17:02:17
    PPPOE拨号实验 实验目的 用R2模拟ISP运营商 R1模拟客户路由器拨号 C2模拟电脑拨号 模拟软件 GNS3 R1 R2通过真实主机的loopback地址连接 思科IOS为C7200-ADVSECURITYK9-M Version 12.4(11)T 配置 ISP端 ...
  • 使用Cisco Packet Tracer模拟器实现Cisco三层交换机实现Vlan间路由的配置脚本,内含每一步的详细操作及注释说明,包括配置接入层交换机、配置核心交换机、配置firewall路由器、配置ISP互联网路由器、配置分公司...
  • PPOE配置

    2009-04-04 11:48:59
    港湾路由器PPPOE配置事例(思科的类同)- - 一、环境 软件版本:1.3正式版 路由器:1760/2651/3680 二、配置事例 1、 PPPOE客户端配置: 2、PPPOE服务器配置: 3、路由器做为PPPOE接入服务器(本地...
  • 因为,思科有专门的CCNA、CCNP、CCIE无线认证(你懂的)...... 然而,很多学习CCNA课程的学员,都希望能够理解一些简单的无线、拨号、语音、安全等知识,所以,我也经常在培训课堂中,额外增加一些课时,给大家演示...
  • Cisco 防火墙 ASADHCP配置 实验目标 1、网络初始化(防火墙IP地址配置,以及接口nameif) 2、外网接口通过DHCP获取地址与DNS信息(由于PT模拟器不支持PPPOE,所以用DHCP模拟) 3、配置DHCP功能以及特性,实现内网...
  • 【高级】思科设备实现城域网ISIS+BGP+MPLS ×××多域互通实战实验拓扑:GNS3 0.8.6 + c3725-adventerprisek9-mz.124-...2.通过配置普通BGP协议,承载用户业务路由(大客户和PPPoE拨号),实现互联网路由传递。3.通过...
  • 简要说明了一下PPPOE配置,有兴趣的可以看看!打开密码还是sovand ! 官网地址:http://www.sovand.com 官网论坛:http://bbs.sovand.com 转载于:https://blog.51cto.com/sovand/534404...
  • 更多课程,请百度搜索“晁海江”...然而,很多学习CCNA课程的学员,都希望能够理解一些简单的无线、拨号、语音、安全等知识,所以,我也经常在培训课堂中,额外增加一些课时,给大家演示讲解上述知识点的基本配置。...

空空如也

空空如也

1 2
收藏数 35
精华内容 14
关键字:

思科pppoe配置