精华内容
下载资源
问答
  • 策略路由是一种比基于目标网络进行路由更加灵活的数据包路由转发机制。应用了策略路由,路由器将通过路由图决定如何对需要路由的数据包进行处理,路由图决定了一个数据包的下一跳转发路由器,在路由表已经产生的情况...
  • H3C S7500E 三层策略路由配置实例,三层技术,IP路由配置
  • H3C策略路由配置实战

    千次阅读 2021-03-19 11:15:55
    策略路由可以对于满足一定条件(ACL规则、报文长度等)的报文,执行指定的操作(设置报文的下一跳、出接口、缺省下一跳和缺省出接口等)。 报文到达后,其后续的转发流程如下: ·首先根据配置策略路由转发。 ...

    目录

    策略路由简介

    1. 对本地报文应用策略

    2. 对接口转发的报文应用策略


    华三策略路由实战

    策略路由简介

     

    与单纯依照IP报文的目的地址查找路由表进行转发不同,策略路由是一种依据用户制定的策略进行路由转发的机制。策略路由可以对于满足一定条件(ACL规则、报文长度等)的报文,执行指定的操作(设置报文的下一跳、出接口、缺省下一跳和缺省出接口等)。

    报文到达后,其后续的转发流程如下:

    ·            首先根据配置的策略路由转发。

    ·            若找不到匹配的节点或虽然找到了匹配的节点,但指导报文转发失败时,再根据路由表中除缺省路由之外的路由来转发报文。

    ·            若转发失败,则根据策略路由中配置的缺省下一跳和缺省出接口指导报文转发。

    ·            若转发失败,则再根据缺省路由来转发报文。

     

    根据作用对象的不同,策略路由可分为本地策略路由和转发策略路由:

    ·            本地策略路由:对设备本身产生的报文(比如本地发出的ping报文)起作用,指导其发送。

    ·            转发策略路由:对接口接收的报文起作用,指导其转发。

     

    1. 对本地报文应用策略

    通过本配置,可以将已经配置的策略应用到本地,指导设备本身产生报文的发送。应用策略时,该策略必须已经存在,否则配置将失败。

    对本地报文只能应用一个策略。应用新的策略前必须删除本地原来已经应用的策略。

    若无特殊需求,建议用户不要对本地报文应用策略。否则,有可能会对本地报文的发送造成不必要的影响(如ping、telnet服务的失效)。

     

    2. 对接口转发的报文应用策略

    通过本配置,可以将已经配置的策略应用到接口,指导接口接收的所有报文的转发。应用策略时,该策略必须已经存在,否则配置将失败。

    对接口转发的报文应用策略时,一个接口只能应用一个策略。应用新的策略前必须删除接口上原来已经应用的策略。

    一个策略可以同时被多个接口应用。

    ​实验拓扑

     

     

    配置需求

     

    1. 财务部访问互联网默认走电信链路;

    2. 销售部访问互联网默认走移动链路;

    3. 在默认链路故障时,访问互联网可以走另一条链路,保证业务可靠性。

     

    配置步骤

     

    1. 在R1上配置访问控制列表3000、3001,匹配策略路由报文

    acl advanced 3000 rule 0 permit ip source 192.168.1.0 0.0.0.255#acl advanced 3001 rule 0 permit ip source 192.168.2.0 0.0.0.255

    2. 在R1上创建名称为xhg的策略路由,节点0匹配acl 3000,节点5匹配3001

    policy-based-route xhg permit node 0 if-match acl 3000 apply next-hop 100.1.1.2#policy-based-route xhg permit node 5 if-match acl 3001 apply next-hop 200.1.1.2

    3. 在R1的GigabitEthernet0/1调用策略路由

    interface GigabitEthernet0/1 ip policy-based-route xhg

    配置验证

     

    <SW1>tracert -a 192.168.1.1 1.1.1.2traceroute to 1.1.1.2 (1.1.1.2) from 192.168.1.1, 30 hops at most, 40 bytes each packet, press CTRL_C to break 1  10.1.1.2 (10.1.1.2)  1.000 ms  0.000 ms  1.000 ms 2  100.1.1.2 (100.1.1.2)  1.000 ms  0.000 ms  1.000 ms 3 <SW1>tracert -a 192.168.2.1 1.1.1.2traceroute to 1.1.1.2 (1.1.1.2) from 192.168.2.1, 30 hops at most, 40 bytes each packet, press CTRL_C to break 1  10.1.1.2 (10.1.1.2)  0.000 ms  1.000 ms  0.000 ms 2  200.1.1.2 (200.1.1.2)  1.000 ms  1.000 ms  1.000 ms

     

    附:

     

    1.整体配置

    ​R1:

    # sysname R1# ip unreachables enable ip ttl-expires enable#policy-based-route xhg permit node 0 if-match acl 3000 apply next-hop 100.1.1.2#policy-based-route xhg permit node 5 if-match acl 3001 apply next-hop 200.1.1.2#interface GigabitEthernet0/0 port link-mode route combo enable copper ip address 100.1.1.1 255.255.255.0 nat outbound#interface GigabitEthernet0/1 port link-mode route combo enable copper ip address 10.1.1.2 255.255.255.252 ip policy-based-route xhg#interface GigabitEthernet0/2 port link-mode route combo enable copper ip address 200.1.1.1 255.255.255.0 nat outbound# ip route-static 0.0.0.0 0 100.1.1.2 ip route-static 0.0.0.0 0 200.1.1.2 ip route-static 192.168.1.0 24 10.1.1.1 ip route-static 192.168.2.0 24 10.1.1.1#acl advanced 3000 rule 0 permit ip source 192.168.1.0 0.0.0.255#acl advanced 3001 rule 0 permit ip source 192.168.2.0 0.0.0.255

    R2:

    # sysname R2# ip unreachables enable ip ttl-expires enable#interface GigabitEthernet0/0 port link-mode route combo enable copper ip address 100.1.1.2 255.255.255.0#interface GigabitEthernet0/1 port link-mode route combo enable copper ip address 1.1.1.1 255.255.255.0#interface GigabitEthernet0/2 port link-mode route combo enable copper ip address 200.1.1.2 255.255.255.0#

     

    SW1配置:

    # sysname SW1# ip unreachables enable ip ttl-expires enable#vlan 10#              vlan 20#interface Vlan-interface10 ip address 192.168.1.1 255.255.255.0#interface Vlan-interface20 ip address 192.168.2.1 255.255.255.0#interface GigabitEthernet1/0/1 port link-mode route combo enable fiber ip address 10.1.1.1 255.255.255.252# ip route-static 0.0.0.0 0 10.1.1.2#

     

    PC4:

    模拟财务部内网

    PC5:

    模拟销售部内网

    PC6

    模拟公网百度服务器

     

    2. 关注我,获取此次配置工程、更多配置案例、最新影视及常用办公软件

     

    展开全文
  • 华三(H3C)策略路由NQA多出口联动配置,nqa类似ip sla,文档里描述详细,谁用谁知道。
  • H3C_路由策略配置

    2019-05-05 17:22:28
    本书包含H3C路由策略和策略路由、组网需求、组网图、配置步骤,常见错误分析
  • H3C交换机&路由器的策略路由配置

    千次阅读 2019-12-12 21:34:46
    H3C交换机&路由器的策略路由配置 方法一:使用PBR实现,PBR就是策略路由(一般是存在路由器上的) 如图,SWA与SWB互联,两端设备的Ge1/0/1属于192.168.2.0/24,SWA设备Ge1/0/2属于192.168.1.0/24,PCA地址192.168...

    H3C交换机&路由器的策略路由配置

    方法一:使用PBR实现,PBR就是策略路由(一般是存在路由器上的)

    如图,SWA与SWB互联,两端设备的Ge1/0/1属于192.168.2.0/24,SWA设备Ge1/0/2属于192.168.1.0/24,PCA地址192.168.1.2/24,PCB地址192.168.3.2/24,SWA不配置192.168.3.0的路由,而是通过下一跳的策略路由实现SWA去192.168.3.0的路由去向SWB,SWB配置好回包路由即可实现主机互通。
    在这里插入图片描述
    SWA基础配置:
    [SWA]vlan 2
    [SWA-vlan2]quit
    [SWA]interface Vlan-interface 2
    [SWA-Vlan-interface2]ip address 192.168.2.1 24
    [SWA-Vlan-interface2]quit
    [SWA]interface Vlan-interface 1
    [SWA-Vlan-interface1]ip address 192.168.1.1 24
    [SWA-Vlan-interface1]quit

    [SWA]interface GigabitEthernet 1/0/1
    [SWA-GigabitEthernet1/0/1]port link-type access
    [SWA-GigabitEthernet1/0/1]port access vlan 2
    [SWA-GigabitEthernet1/0/1]quit
    [SWA]interface GigabitEthernet 1/0/2
    [SWA-GigabitEthernet1/0/2]port link-type access
    [SWA-GigabitEthernet1/0/2]port access vlan 1
    [SWA-GigabitEthernet1/0/2]quit

    SWB基础配置:
    [SWB]vlan 2
    [SWB-vlan2]quit
    [SWB]interface Vlan-interface 2
    [SWB-Vlan-interface2]ip address 192.168.2.2 24
    [SWB-Vlan-interface2]quit
    [SWB]interface Vlan-interface 1
    [SWB-Vlan-interface1]ip address 192.168.3.1 24
    [SWB-Vlan-interface1]quit

    [SWB]interface GigabitEthernet 1/0/1
    [SWB-GigabitEthernet1/0/1]port link-type access
    [SWB-GigabitEthernet1/0/1]port access vlan 2
    [SWB-GigabitEthernet1/0/1]quit

    [SWB]interface GigabitEthernet 1/0/2
    [SWB-GigabitEthernet1/0/2]port link-type access
    [SWB-GigabitEthernet1/0/2]port access vlan 1
    [SWB-GigabitEthernet1/0/2]quit
    [SWB]ip route-static 192.168.1.0 24 192.168.2.1       #配置好回包路由
    ----------以上的基础配置好后将两端的PC地址配置好,PCA不能与PCB互通,下面配置PBR

    SWA配置PBR选路策略:
    [SWA]acl advanced 3000
    [SWA-acl-ipv4-adv-3000]rule 5 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.3.0 0.0.0.255
    [SWA-acl-ipv4-adv-3000]rule 10 deny ip
    [SWA-acl-ipv4-adv-3000]quit

    [SWA]policy-based-route pbr permit node 5     #创建pbr策略名为pbr动作为允许节点为5
    [SWA-pbr-pbr-5]if-match acl 3000     #配置acl 3000里的源和目的
    [SWA-pbr-pbr-5]apply next-hop 192.168.2.2     #配置好下一跳
    [SWA-pbr-pbr-5]quit

    [SWA]interface Vlan-interface 1     #我这里是vlan环境,所以配置在vlan接口上,如果是路由口则配置在三层接pc端的接口
    [SWA-Vlan-interface1]ip policy-based-route pbr
    [SWA-Vlan-interface1]quit




    方法二:使用Qos策略实现
    先将刚才vlan1里的策略删除
    [SWA-Vlan-interface1]undo ip policy-based-route
    基础配置都一样,不在配置

    [SWA]traffic classifier c1       #创建Qos类
    [SWA-classifier-c1]if-match acl 3000
    [SWA-classifier-c1]quit
    [SWA]traffic behavior b1       #创建Qos的行为动作
    [SWA-behavior-b1]redirect next-hop 192.168.2.2
    [SWA-behavior-b1]quit
    [SWA]qos policy p1       #创建Qos策略将类和动作绑定
    [SWA-qospolicy-p1]classifier c1 behavior b1
    [SWA-qospolicy-p1]quit
    [SWA]qos vlan-policy p1 vlan 1 inbound       #绑定vlan即可

    ----------------------------------------------------------------------------------------------------

    展开全文
  • H3C路由器配置基于源地址的策略路由图文教程整理
  • 04 S5000PV3_S5130_S5150系列交换机策略路由配置案例 05 S3X00V3系列交换机策略路由配置案例 06 S7000_S7500E_10500系列交换机策略路由配置案例 07 S5500_S5800_S5830系列交换机策略路由配置案例 08 S5000PV2_S...
  • H3C 交换机策略路由流量负载均衡

    千次阅读 2019-08-06 19:27:23
    出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用pbr+静态路由迭代的配置方式实现上述...
    1.  

      组网环境

    1.  

      实现说明

    外网出口交换机上有2条运营商线路,出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用pbr+静态路由迭代的配置方式实现上述需求。

    1.  

      配置说明

    vlan 100

    description 流量路径-1

    #

    vlan 101

    description 流量路径-2

    #

    interface Vlan-interface100

    description 流量路径-1

     ip address 1.1.1.1 255.255.255.0

    #

    interface Vlan-interface101

    description 流量路径-2

     ip address 2.2.2.1 255.255.255.0

    #

    interface GigabitEthernet1/0/1

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 100

    #

    interface GigabitEthernet1/0/2

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 101

    #

    nqa entry admin 1

     type icmp-echo

      destination ip 1.1.1.2

      frequency 100

      next-hop ip 1.1.1.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa entry admin 2

     type icmp-echo

      destination ip 2.2.2.2

      frequency 100

      next-hop ip 2.2.2.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa schedule admin 1 start-time now lifetime forever

    nqa schedule admin 2 start-time now lifetime forever

    #

    track 1 nqa entry admin 1 reaction 1

    track 2 nqa entry admin 2 reaction 1

    #

    acl advanced 3000

     rule 0 permit ip source 10.0.0.0 0.0.0.8 

    #

    policy-based-route aaa permit node 1

     if-match acl 3000

     apply next-hop 111.111.111.111

    #

     ip route-static 111.111.111.111 32 1.1.1.1 track 1

     ip route-static 111.111.111.111 32 2.2.2.1 track 2

    #

     

    展开全文
  • H3C策略路由

    千次阅读 2015-05-14 13:48:13
    在RT2上使用策略路由,根据源地址的不同分别指向不同的下一跳 2.实验拓扑: 3.实验配置: RT1:  [RT1]int lo 0 [RT1-LoopBack0]ip add 10.1.0.1 24 [RT1-LoopBack0]int lo 1 [RT1-LoopBack1]ip add 10.2.0.1 24 ...

    1.实验原理:

    在RT2上使用策略路由,根据源地址的不同分别指向不同的下一跳

    2.实验拓扑:


    3.实验配置:

    RT1:             
    [RT1]int lo 0
    [RT1-LoopBack0]ip add 10.1.0.1 24 
    [RT1-LoopBack0]int lo 1
    [RT1-LoopBack1]ip add 10.2.0.1 24
    [RT1-LoopBack1]int g0/0/0
    [RT1-GigabitEthernet0/0/0]ip add 10.3.0.1 24
    [RT1-GigabitEthernet0/0/0]qu
    [RT1]ip route 0.0.0.0 0.0.0.0 10.3.0.2
    //
    RT2:
    [RT2]int g0/0/0
    [RT2-GigabitEthernet0/0/0]ip add 10.3.0.2 24
    [RT2-GigabitEthernet0/0/0]int g0/0/1
    [RT2-GigabitEthernet0/0/1]ip add 10.4.0.1 24
    [RT2-GigabitEthernet0/0/1]int g0/0/2
    [RT2-GigabitEthernet0/0/2]ip add 20.5.0.1 24
    [RT2-GigabitEthernet0/0/2]qu      
    [RT2]acl num 2001                                   //这里用访问控制链表来匹配IP地址
    [RT2-acl-basic-2001]rule 0 permit source 10.1.0.0 0.0.0.255
    [RT2-acl-basic-2001]acl num 2002 
    [RT2-acl-basic-2002]rule 0 per s 10.2.0.0 0.0.0.255
    [RT2-acl-basic-2002]qu
    [RT2]policy-based-route isp permit node 1          //这里定义策略路由
    [RT2-pbr-isp-1]if-match acl 2001                   //这里应用访问控制链表
    [RT2-pbr-isp-1]apply ip-address next-hop 10.4.0.2 
    [RT2-pbr-isp-1]qu
    [RT2]policy-based-route isp node 2
    [RT2-pbr-isp-2]if-match acl 2002
    [RT2-pbr-isp-2]apply ip-address next-hop 10.5.0.2 
    [RT2-pbr-isp-2]qu
    [RT2]int g0/0/0
    [RT2-GigabitEthernet0/0/0]ip policy-based-route isp  //把策略应用到接口
    [RT2]ip route 0.0.0.0 0.0.0.0 10.3.0.1
    //
    RT3:
    [RT3]int g0/0/0
    [RT3-GigabitEthernet0/0/0]ip add 10.4.0.2 24
    [RT3-GigabitEthernet0/0/0]int lo 0
    [RT3-LoopBack0]ip add 10.6.0.1 24
    [RT3]ip route 0.0.0.0 0.0.0.0 10.4.0.1
    ///
    RT4:
    [RT4]int g0/0/0
    [RT4-GigabitEthernet0/0/0]ip ad 10.5.0.2 24
    [RT4-GigabitEthernet0/0/0]int lo 0
    [RT4-LoopBack0]ip add 10.7.0.1 24
    [RT4-LoopBack0]qu
    [RT4]ip route 0.0.0.0 0.0.0.0 10.5.0.1
    

     4.实验结果: 
    

    RT1:
    [RT1]ping -a 10.1.0.1 10.6.0.1                             //这里要用扩展ping命令
      PING 10.6.0.1: 56  data bytes, press CTRL_C to break
        Reply from 10.6.0.1: bytes=56 Sequence=1 ttl=254 time=1 ms
        Reply from 10.6.0.1: bytes=56 Sequence=2 ttl=254 time=26 ms
        Reply from 10.6.0.1: bytes=56 Sequence=3 ttl=254 time=16 ms
        Reply from 10.6.0.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Request time out
    [RT1]ping -a 10.1.0.1 10.7.0.1
      PING 10.7.0.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
    [RT1]ping -a 10.2.0.1 10.6.0.1
      PING 10.6.0.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
    [RT1]ping -a 10.2.0.1 10.7.0.1
      PING 10.7.0.1: 56  data bytes, press CTRL_C to break
        Request time out
        Reply from 10.7.0.1: bytes=56 Sequence=2 ttl=254 time=5 ms
        Reply from 10.7.0.1: bytes=56 Sequence=3 ttl=254 time=4 ms
        Reply from 10.7.0.1: bytes=56 Sequence=4 ttl=254 time=5 ms
        Reply from 10.7.0.1: bytes=56 Sequence=5 ttl=254 time=1 ms
    


    展开全文
  • H3C 三层交换机策略路由配置方法

    万次阅读 2017-08-31 17:20:44
    ACL配置: acl number 3010 description CU_10Mbps ServiceNAT rule 5 permit ip source 192.168.1.2 0 rule 10 permit ip source 192.168.1.3 0 rule 15 permit ip source 192.168.1.4 0 acl number 3011...
  • 通过策略路由控制不同网段访问不同的外网出口。 <FW>dis cu # version 7.1.064, Alpha 7164 # sysname FW # context Admin id 1 # telnet server enable # irf mac-address persistent timer ir
  • H3C策略路由和QOS常见应用介绍及典型组网分析,个人感觉还可以,所以上传,大家看一下
  • 153网段配置到tfs服务器策略路由 1、 创建 Acl访控列表(客户端到服务器) acl number 31rule 0 permit ip source 172.20.153.0 0.0.0.255 destination 172.20.20.65 0 2、 创建Acl访控列表(服务...
  • 全面介绍H3C路由器中路由策略和策略路由器基础知识和工作原理,并以实战方式介绍H3C路由器各种路由策略和策略路由配置与管理方法
  • H3c 静态路由配置及和BFD联动实现高速切换(运营商技术之一),工程师必备知识
  • H3C_S12500系列路由交换机典型配置举例。很多配置举例。
  • H3C | S6X00系列交换机策略路由配置案例https://mp.weixin.qq.com/s/WKtmzm_a6u83ovwV5sUAjg 组网及说明 1 配置需求或说明 1.1适用产品系列 本案例适用于如S6300-52QF、S6520X-30QC-HI、S6800-54QT、S6820-4C S6900-...
  • 配置如下: [IP]int s0/2/0 [IP-Serial0/2/0]ip add 202.112.1.10 28 [IP-Serial0/2/0]int s0/2/1 [IP-Serial0/2/1]ip add 61.67.1.10 28 [IP-Serial0/2/1]int lo0 [IP-LoopBack0]ip add 1...
  • 一实验步骤 配置各台设备的ip地址 测试直连的连通性 配置RIP OSPF和ISIS路由协议 RIP路由引入到 OSPF中OSPF路由引入到 RIP中 ISIS路由引入到 OSPF中OSPF路由引入到ISIS中 路由的聚合 测试实验结果 二配置命令及其...
  • H3C交换机BFD典型配置举例
  • H3C SR8800策略路由典型配置举例.pdf
  • H3C 交换机 需要配置两条缺省路由的解决办法,采用策略路由,同时解决聚合线路无法配置QOS问题
  • 2.公司内网配置 RIP 互通,公网配置 OSPF 互通,R1 上配置默认路由指向 R2,内网使用路由器模拟 PC 3.R1 分别在电信和联通出口上配置 EASY IP,允许 192.168.1.0/24 和 192.168.2.0/24 网段访问互联网 4.在 R1 上...
  • 《轻轻松松配交换 V2.1》,新增:常用配置2篇(包含V5 /V7交换机策略路由配置方法); 2019-6-30 《轻轻松松配交换 V2.0》,新增:常用配置2篇(包含V5 /V7交换机静态路由、Track与NQA联动); 2019-5-31 ...
  • 全面介绍H3C路由器中路由策略和策略路由器基础知识和工作原理,并以实战方式介绍H3C路由器各种路由策略和策略路由配置与管理方法
  • H3C设备校园网双出口配置

    千次阅读 2019-10-30 19:39:29
    H3C设备上,谈到双出口,那么就避免不了策略路由这个概念,那么策略路由又是个什么鬼呢? 它与单纯依照IP报文的目的地址查找路由表进行转发不同,策略路由是一种依据用户制定的策略进行路由选择的机制。策略路由是...
  • 策略路由(PBR)配置

    2013-03-28 18:30:26
    1. 掌握策略路由配置 2. 理解策略路由的原理
  • 1. 配置需求定义策略aaa的策略路为由控制所有从以太网口E3/0/0接口接收的TCP报文,使用串口...10号节点,表示匹配acl 3102的任何报文不做策略路由处理;来自Ethernet3/0/0的报文将依次试图匹配5、10号节点的if-matc...
  • H3C 5500 策略路由配置

    2015-08-25 11:22:12
    h3c qos配置:http://down.51cto.com/data/2085592 转载于:https://blog.51cto.com/hiid365/1687984

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 17,025
精华内容 6,810
关键字:

h3c策略路由配置